Outdated version of the documentation. Find the latest one here.

Der erste Einstieg

Dieses Kapitel gibt eine kurze Einführung in die Installation von QGIS, verweist auf Alaska-Beispieldaten von der QGIS Webseite und zeigt anhand eines einfachen Beispiels, wie einfach es ist, Raster- und Vektordaten in QGIS zu visualisieren.

Installation

Die Installation von QGIS ist sehr einfach. Standard Installationspakete gibt es für MS Windows und Mac OS X. Für viele GNU/Linux Betriebssysteme stehen Binärpakete (.rpm und .deb) oder entsprechende Software Repositories zur Verfügung, die man im Installationsmanager des jeweiligen Betriebsystems eintragen kann. Aktuelle Informationen zu den Binärpaketen befinden sich im Downloadbereich auf der QGIS Webseite unter http://www.qgis.org.

Kompilieren des Quellcodes

If you need to build QGIS from source, please refer to the installation instructions. They are distributed with the QGIS source code in a file called ‘INSTALL’. You can also find it online at http://htmlpreview.github.io/?https://raw.github.com/qgis/QGIS/master/doc/INSTALL.html

Installation auf externen Medien

QGIS allows to define a --configpath option that overrides the default path (e.g. ~/.qgis2 under Linux) for user configuration and forces QSettings to use this directory, too. This allows users to e.g. carry a QGIS installation on a flash drive together with all plugins and settings. Also compare with section System Menu.

Beispieldaten

Die Dokumentation zeigt eine Reihe von Beispielen, die auf den Geodaten des QGIS Beispieldatensatzes basieren.

win Während der Installation unter Windows gibt es die Option, den QGIS Beispieldatensatz mit herunterzuladen. Wenn die Option ausgewählt wurde, werden die Daten nach Eigene Dateien in den Ordner GIS Database heruntergeladen. Mit dem Windows Explorer können Sie die Daten bei Bedarf nachträglich in ein anderes Verzeichnis verschieben. Wenn Sie die Option bei der Installation nicht ausgewählt haben, können Sie

  • bereits auf Ihrem Rechner vorhandene GIS Daten verwenden;

  • download sample data from at http://download.osgeo.org/qgis/data/qgis_sample_data.zip; or
  • QGIS deinstallieren, wieder neu installieren und dabei die entsprechende Option auswählen, wenn die oben angesprochenen Optionen nicht funktionieren.

nix osx For GNU/Linux and Mac OSX there are not yet dataset installation packages available as rpm, deb or dmg. To use the sample dataset download the file qgis_sample_data as ZIP archive from http://download.osgeo.org/qgis/data/qgis_sample_data.zip and unzip the archive on your system. The Alaska dataset includes all GIS data that are used as examples and screenshots in the user guide, and also includes a small GRASS database. The projection for the QGIS sample dataset is Alaska Albers Equal Area with unit feet. The EPSG code is 2964.

PROJCS["Albers Equal Area",
    GEOGCS["NAD27",
        DATUM["North_American_Datum_1927",
            SPHEROID["Clarke 1866",6378206.4,294.978698213898,
                AUTHORITY["EPSG","7008"]],
            TOWGS84[-3,142,183,0,0,0,0],
            AUTHORITY["EPSG","6267"]],
        PRIMEM["Greenwich",0,
            AUTHORITY["EPSG","8901"]],
        UNIT["degree",0.0174532925199433,
            AUTHORITY["EPSG","9108"]],
        AUTHORITY["EPSG","4267"]],
    PROJECTION["Albers_Conic_Equal_Area"],
    PARAMETER["standard_parallel_1",55],
    PARAMETER["standard_parallel_2",65],
    PARAMETER["latitude_of_center",50],
    PARAMETER["longitude_of_center",-154],
    PARAMETER["false_easting",0],
    PARAMETER["false_northing",0],
    UNIT["us_survey_feet",0.3048006096012192]]

If you intend to use QGIS as graphical frontend for GRASS, you can find a selection of sample locations (e.g. Spearfish or South Dakota) at the official GRASS GIS website http://grass.osgeo.org/download/sample-data/.

Ein erstes Übungsbeispiel

Nachdem Sie QGIS installiert und den Beispieldatensatz heruntergeladen und entpackt haben, beginnen wir mit einem einfachen und kurzen Beispiel. Ziel ist es, einen Raster- und einen Vektorlayer zu laden und wir verwenden dazu den Rasterlayer qgis_sample_data/raster/landcover.img und den Vektorlayer qgis_sample_data/gml/lakes.gml aus dem QGIS Beispieldatensatz.

QGIS starten

  • nix Starten Sie QGIS, indem Sie “QGIS” in die Kommandozeile tippen und Return drücken. Bei Binärversionen ist es auch möglich, QGIS im Programme Menü auszuwählen.

  • win Starten Sie QGIS über das Start Menü, das QGIS Desktop Icon oder durch doppelklicken auf eine evtl. bereits vorhandene QGIS Projektdatei.

  • osx Doppelklicken Sie auf das QGIS Icon in Ihrem Programmordner.

Laden eines Raster- und Vektorlayers aus dem Beispieldatensatz

  1. Drücken Sie auf den mActionAddRasterLayer Rasterlayer hinzufügen Knopf.

  2. Browsen Sie zum Ordner qgis_sample_data/raster/, wählen Sie die ERDAS Img Datei landcover.img und klicken dann auf [Öffnen].

  3. Wenn die Datei nicht aufgelistet ist, prüfen Sie in der ‘Dateien des Typs’ Combobox im unteren Bereich des Dialogs, ob der richtige Datentyp, in diesem Fall Erdas Imagine Images (*.img, *.IMG) eingestellt ist.

  4. Nun drücken Sie auf den mActionAddOgrLayer Vektorlayer hinzufügen Knopf.

  5. und wählen im Dialogfenster als Quelltyp radiobuttononDatei aus. Klicken Sie auf [Durchsuchen].

  6. Browsen Sie zum Ordner qgis_sample_data/gml/, wählen Sie die GML Datei lakes.gml aus und klicken auf [Öffnen]. Nun klicken Sie auf [Ok], um den Vektorlayer anzuzeigen.

  7. Zoomen Sie in einen Bereich in dem sich ein paar Seen befinden.

  8. Doppelklicken Sie auf lakes in der Legende. Der Dialog Layereigenschaften öffnet sich.

  9. Click on the Style menu and select a blue as fill color.
  10. Click on the Labels menu and check the checkbox Label this layer with checkbox to enable labeling and choose “NAMES” field as field containing labels.
  11. To improve readability of labels, you can add a white buffer around them, by clicking “Buffer” in the list on the left, checking checkbox Draw text buffer and choosing 3 as buffer size.
  12. Drücken Sie nun auf den Knopf [Anwenden], prüfen Sie, ob das Ergebnis gut aussieht und bestätigen Sie dann mit einem Klick auf [OK].

Sie sehen, wie einfach es ist, Raster- und Vektorlayer in QGIS zu visualisieren. Gehen Sie nun weiter zu den folgenden Kapiteln, um mehr über die vorhandenen Funktionalitäten, Einstellungsmöglichkeiten und ihre Benutzung zu erfahren.

QGIS Starten und Beenden

In Kapitel Ein erstes Übungsbeispiel wurde bereits kurz gezeigt, wie QGIS gestarted wird. Dies wird hier wiederholt und Sie werden sehen, dass QGIS darüber hinaus noch eine Reihe von Kommandozeilenoptionen zur Verfügung stellt.

  • nix Wenn QGIS bereits in einem ausführbaren Pfad installiert ist, können Sie QGIS in einem Kommandozeilenfenster mit dem Befehl: qgis starten, oder durch einen Doppelklick auf das QGIS Icon auf dem Desktop oder im Programme Menü.

  • win Starten Sie QGIS über das Start Menü, das QGIS Desktop Icon oder durch Doppelklicken auf eine evtl. bereits vorhandene QGIS Projektdatei.

  • osx Doppelklicken Sie auf das QGIS Icon in Ihrem Programmordner. Wenn Sie QGIS aus der Shell starten wollen, verwenden Sie /Pfad-zu-den-ausführbaren-Dateien/Contents/MacOS/Qgis.

Um QGIS zu beenden, klicken im Menü nix win File osx QGIS ‣ Beenden, oder benutzen Sie das Tastenkürzel Strg+Q.

Optionen der Kommandozeile

Wenn Sie QGIS in der Kommandozeile starten, stehen eine Reihe von Optionen zur Verfügung. Eine Liste erhalten Sie, indem Sie qgis ---help eingeben. Die Ausgabe zeigt folgende Informationen:

    qgis --help
    QGIS - 2.0.1-Dufour 'Dufour' (exported)
QGIS is a user friendly Open Source Geographic Information System.
    Usage: qgis [OPTION] [FILE]
      options:
        [--snapshot filename]           emit snapshot of loaded datasets to given file
        [--width width]                 width of snapshot to emit
        [--height height]               height of snapshot to emit
        [--lang language]               use language for interface text
        [--project projectfile]         load the given QGIS project
        [--extent xmin,ymin,xmax,ymax]  set initial map extent
        [--nologo]                      hide splash screen
        [--noplugins]                   don't restore plugins on startup
        [--nocustomization]             don't apply GUI customization
        [--optionspath path]            use the given QSettings path
        [--configpath path]             use the given path for all user configuration
        [--code path]           run the given python file on load
        [--help]                        this text

      FILES:
        Files specified on the command line can include rasters,
        vectors, and QGIS project files (.qgs):
        1. Rasters - Supported formats include GeoTiff, DEM
           and others supported by GDAL
        2. Vectors - Supported formats include ESRI Shapefiles
           and others supported by OGR and PostgreSQL layers using
           the PostGIS extension

Tipp

Ein Beispiel mit der Kommandozeile

Kommandozeilenoptionen beim Starten nutzen Sie können einen oder mehrere Kartenlayer in der Kommandozeile angeben, wenn Sie QGIS starten. Z.B.: Wenn Sie sich in dem Ordner qgis_sample_data befinden, können Sie durch folgendes Kommando QGIS mit einem Vektor- und einen Rasterlayer starten: qgis ./raster/landcover.img ./gml/lakes.gml

Kommandozeilenoption --snapshot

Diese Option ermöglicht es, einen PNG-Snapshot des aktuellen Kartenfensters zu erstellen. Dies ist z.B. sinnvoll, wenn Sie zahlreiche Projekte angelegt haben und Snapshots von den Daten machen wollen.

QGIS erstellt ein PNG-Bild mit 800x600 Pixeln. Dies können Sie mit den Parametern ---width und ---height anpassen und dann hinter der Option ---snapshot einen Dateinamen angeben.

Kommandozeilenoption --lang

Auf Basis der Systemsprache Ihres Rechners wird auch die Sprache der QGIS-Oberfläche eingestellt. Wenn Sie diese ändern möchten, können Sie das mit der Option ---lang erreichen. Eine Liste der unterstützten Sprachen finden Sie mit dem entsprechenden Länderkürzel unter http://hub.qgis.org/wiki/quantum-gis/GUI_Translation_Progress

Kommandozeilenoption --project

Es ist auch möglich, beim Starten von QGIS ein Projekt zu laden. Fügen Sie dazu die Option ``—project` mit dem Namen ihres Projektes hinzu und QGIS lädt alle darin enthaltenen Daten direkt beim Start.

Kommandozeilenoption ---extent

Um QGIS in einem bestimmten Ausschnitt Ihrer Daten zu starten, kann diese Option genutzt werden. Dazu wird durch die Eingabe von Eckkoordinaten eine ‘Bounding Box’ eingestellt. Die Koordinaten müssen durch Komma getrennt angegeben werden:

--extent xmin,ymin,xmax,ymax

Kommandozeilenoption --nologo

Diese Option verhindert das Anzeigen des Splashscreens beim Starten von QGIS.

Kommandozeilenoption --noplugins

Wenn Sie Probleme mit dem Starten von Erweiterungen haben können Sie das Laden beim Hochfahren von QGIS verhindern. Die Erweiterungen stehen danach immer noch über den QGIS-Erweiterungsmanager zu Verfügung.

Kommandozeilenoption --nocustomization

Mit dieser Option werden GUI Anpassungen beim Start nicht angewendet.

Kommandozeilenoption --optionspath

Sie können Mehrfachkonfigurationen durchführen und entscheiden welche Sie verwenden wollen wenn SIe QGIS unter Verwendung dieser Option starten. Unter Optionen können Sie überprüfen wo das Betriebssystem die Einstellungen speichert. Derzeit gibt es noch keine Möglichkeit die Datei festzulegen in die die Einstellungen gespeichert werden. Aus diesem Grund können Sie eine Kopie der Originaldatei machen und sie umbenennen.

Kommandozeilenoption --configpath

Diese Option ähnelt der vorangegangenen, überschreibt jedoch den Standardpfad (~/.qgis) für die Benutzerkonfiguration und zwingt QSettings dieses Verzeichnis zu verwenden. So kann der Benutzer z.B. eine QGIS-Installation mit allen Erweiterungen und Einstellungen auf einem USB-Stick transportieren.

QGIS Projekte

The state of your QGIS session is considered a Project. QGIS works on one project at a time. Settings are either considered as being per-project, or as a default for new projects (see Section Optionen). QGIS can save the state of your workspace into a project file using the menu options Project ‣ mActionFileSave Save or Project ‣ mActionFileSaveAs Save As.

Load saved projects into a QGIS session using Project ‣ mActionFileOpen Open ..., Project ‣ New from template or Project ‣ Open Recent.

If you wish to clear your session and start fresh, choose Project ‣ mActionFileNew New. Either of these menu options will prompt you to save the existing project if changes have been made since it was opened or last saved.

In einer Projektdatei sind folgenden Informationen gespeichert:

  • Hinzugefügte Layer

  • Einstellungen der Layer, inklusive Symbologie

  • Projektion für das Kartenfenster

  • Zuletzt gewählte Ausdehnung im Kartenfenster

Die Projektdatei wird im XML-Format gespeichert. Dadurch können Sie die Datei auch außerhalb von QGIS editieren, wenn Sie wissen, was Sie tun. Projektdateien aus älteren QGIS-Version funktionieren meist leider nicht. Um darauf hingewiesen zu werden, können Sie im Reiter Allgemein im Menü Einstellungen‣ Optionen das Kontrollkästchen:

checkbox Prompt to save project and data source changes when required

checkbox Warnung ausgeben, wenn QGIS-Projekt einer früheren Version geöffnet wird auswählen

Ausgabe

Abgesehen von der Möglichkeit, ein geöffnetes QGIS-Projekt in einer Projektdatei zu speichern, wie im obigen Kapitel QGIS Projekte beschrieben, gibt es noch zwei weitere Ausgabemöglichkeiten im Menü Datei‣:

  • Menu option Project ‣ mActionSaveMapAsImage Save as Image opens a file dialog where you select the name, path and type of image (PNG or JPG format). A world file with extension PNGW or JPGW saved in the same folder georeferences the image.
  • Menu option Project ‣ mActionNewComposer New Print Composer opens a dialog where you can layout and print the current map canvas (see Section Druckzusammenstellung).