5. 시작하기

이 장에서 QGIS를 설치하는 법, QGIS 웹페이지에서 예시 데이터를 다운로드하는 법, 그리고 래스터 및 벡터 레이어를 가시화하는 첫 번째의 간단한 세션을 수행하는 법을 간단히 살펴보겠습니다.

5.1. QGIS 설치

QGIS 프로젝트는 사용자 플랫폼에 따라 QGIS를 설치할 수 있는 여러 가지 방법을 제공합니다.

5.1.1. 바이너리로부터 설치

win MS 윈도우 와 osx 맥OS의 경우 표준 인스톨러를 사용할 수 있습니다. 수많은 nix GNU/Linux 배포판을 위한 바이너리 패키지(rpm 및 deb)나 설치 관리자에 추가할 수 있는 소프트웨어 저장소도 제공합니다.

사용자의 OS를 위한 추가 정보 및 지침을 살펴보려면 https://download.qgis.org 를 방문하십시오.

5.1.2. 소스로부터 설치

소스로부터 QGIS를 빌드해야 한다면, 설치 지침을 참조해주십시오. QGIS 소스코드와 함께 INSTALL 이라는 파일로 배포하고 있습니다. 온라인 상의 https://github.com/qgis/QGIS/blob/master/INSTALL.md 에서도 설치 지침을 찾아볼 수 있습니다.

사용자가 개발 중인 버전이 아니라 특정 배포판을 빌드하려는 경우, master 브랜치를 앞에서 언급한 링크에 있는 (주로 release-X_Y 라는 명칭인) 원하는 배포판의 브랜치로 전환해야 합니다. (배포판에 따라 설치 지침이 다를 수 있기 때문입니다.)

5.1.3. 외부 저장장치에 설치

QGIS를 (모든 플러그인과 설정들을 포함해서) 플래시 드라이브에 설치할 수 있습니다. 기본 경로 사용자 프로파일 을 무시하고 QSettings 가 사용자 설정 디렉터리를 사용하도록 강제하는 –profiles-path 옵션을 정의해주면 됩니다. 추가 정보를 원한다면 시스템 설정 을 참조하십시오.

5.1.4. 예시 데이터 다운로드

이 사용자 지침서는 (Alaska dataset 이라고도 하는) QGIS 샘플 데이터셋에 기반한 예시들을 담고 있습니다.

win 윈도우 인스톨러에는 QGIS 샘플 데이터셋을 다운로드할 수 있는 옵션이 있습니다. 이 옵션을 체크하면, 사용자의 Documents 폴더 안의 GIS Database 폴더에 데이터를 다운로드할 것입니다. 윈도우 파일 탐색기로 이 폴더를 다른 편리한 위치로 옮겨도 됩니다. 최초 QGIS 설치 과정에서 샘플 데이터셋을 설치하는 체크박스를 선택하지 않았다면, 다음 작업 중 하나를 할 수도 있습니다:

  • 사용자가 가지고 있던 GIS 데이터를 사용

  • https://github.com/qgis/QGIS-Sample-Data/archive/master.zip 주소에 있는 예시 데이터를 다운로드한 다음 사용자 시스템 상의 편리한 위치에 압축 파일을 해제

  • QGIS를 설치 제거한 다음 데이터 다운로드 옵션을 체크해서 다시 설치 (앞의 두 방법을 쓸 수 없을 경우에만 추천)

nix GNU/리눅스 및 osx 맥OS의 경우, 아직 rpm, deb 또는 dmg 유형의 데이터셋 설치 패키지를 제공하지 않습니다. 샘플 데이터셋을 이용하려면 https://github.com/qgis/QGIS-Sample-Data/archive/master.zip 에서 ZIP 압축 파일을 다운로드해서 사용자 시스템 상의 편리한 위치에 압축을 푸십시오.

이 알래스카 데이터셋은 사용자 지침서에 있는 예시 및 스크린샷에 쓰이는 모든 GIS 데이터를 포함하고 있습니다. 또 작은 GRASS 데이터베이스를 담고 있기도 합니다. 이 QGIS 샘플 데이터셋에 적용된 투영법은 피트 단위의 Alaska Albers Equal Area이며, EPSG 코드는 2964입니다.

PROJCS["Albers Equal Area",
GEOGCS["NAD27",
DATUM["North_American_Datum_1927",
SPHEROID["Clarke 1866",6378206.4,294.978698213898,
AUTHORITY["EPSG","7008"]],
TOWGS84[-3,142,183,0,0,0,0],
AUTHORITY["EPSG","6267"]],
PRIMEM["Greenwich",0,
AUTHORITY["EPSG","8901"]],
UNIT["degree",0.0174532925199433,
AUTHORITY["EPSG","9108"]],
AUTHORITY["EPSG","4267"]],
PROJECTION["Albers_Conic_Equal_Area"],
PARAMETER["standard_parallel_1",55],
PARAMETER["standard_parallel_2",65],
PARAMETER["latitude_of_center",50],
PARAMETER["longitude_of_center",-154],
PARAMETER["false_easting",0],
PARAMETER["false_northing",0],
UNIT["us_survey_feet",0.3048006096012192]]

QGIS를 GRASS 용 그래픽 프론트엔드로 이용하고자 할 경우, 공식 GRASS GIS 웹사이트 https://grass.osgeo.org/download/sample-data/ 에서 (사우스다코타 주의 스피어피시 또는 노스캐롤라이나 주 같은) 샘플 위치들을 모아 놓은 것을 찾아보십시오.

5.2. QGIS 실행 및 종료

사용자의 운영체제에서 다른 응용 프로그램을 실행하는 것과 동일하게 QGIS를 실행할 수 있습니다. 즉 다음과 같은 방법으로 QGIS를 실행할 수 있다는 뜻입니다.

  • nix 응용 프로그램(Applications) 메뉴, win 시작(Start) 메뉴, 또는 osx 독(Dock) 사용

  • 사용자의 응용 프로그램 폴더나 바탕화면에 있는 아이콘 더블 클릭

  • 기존 QGIS 프로젝트 (.qgz 또는 .qgs) 파일을 더블 클릭 (이때 해당 프로젝트가 함께 열립니다)

  • 명령 프롬프트에서 qgis 를 입력 (QGIS가 사용자의 PATH에 추가돼 있거나, QGIS 설치 폴더에서 입력한다고 가정)

QGIS를 종료하려면 다음과 같은 방법을 사용하십시오:

  • nix win Project ► Exit QGIS 메뉴 또는 Ctrl+Q 단축키 입력

  • osx QGIS ► Quit QGIS 메뉴 또는 Cmd+Q 단축키 입력

  • 또는 응용 프로그램의 주 인터페이스 우상단에 있는 빨간 가위표를 클릭

5.3. 예시 세션: 래스터 및 벡터 레이어 불러오기

이제 QGIS를 설치 하고 예시 데이터도 다운로드 했으니, 래스터 및 벡터 레이어를 가시화 하는 첫 예시 세션을 보여드리고자 합니다. 다음 파일들을 사용할 것입니다:

  • landcover 래스터 레이어 (qgis_sample_data/raster/landcover.img)

  • lakes 벡터 레이어 (qgis_sample_data/gml/lakes.gml)

예시 경로의 qgis_sample_data 는 데이터셋의 압축을 해제한 경로를 가리킵니다.

  1. QGIS 실행 및 종료 에서 배운대로 QGIS를 실행하십시오.

  2. QGIS에 파일들을 불러오려면:

    1. dataSourceManager Open Data Source Manager 아이콘을 클릭하십시오. 데이터소스 관리자(Data Source Manager)가 탐색기(Browser) 모드로 열릴 것입니다.

    2. qgis_sample_data/raster/ 폴더를 찾으십시오.

    3. ERDAS IMG 파일 landcover.img 를 선택한 다음 더블클릭하십시오. 배경에 landcover 레이어가 추가될 것입니다. 데이터소스 관리자 창은 닫히지 않습니다.

      ../../../_images/add_raster1.png

      그림 5.1 QGIS의 새 프로젝트에 데이터 추가하기

    4. lakes 데이터를 불러오려면, qgis_sample_data/gml/ 폴더를 찾은 다음 lakes.gml 파일을 더블클릭해서 여십시오.

    5. Coordinate Reference System Selector 대화창이 열립니다. Filter 메뉴에서 2964 를 입력해서 아래쪽에 있는 좌표계(Coordinate Reference System)를 필터링하십시오.

      ../../../_images/selectCRS.png

      그림 5.2 해당 데이터의 좌표계를 선택

    6. NAD27 / Alaska Alberts 항목을 선택합니다.

    7. OK 를 클릭합니다.

    8. 데이터소스 관리자 창을 닫으십시오.

이제 사용자의 프로젝트 안에서 몇몇 랜덤한 색상으로 표시된 레이어 2개를 사용할 수 있습니다. lakes 레이어에 대해 간단한 사용자 지정 작업을 해보겠습니다.

  1. Navigation 툴바에 있는 zoomIn Zoom In 도구를 선택하십시오.

  2. 호수가 몇 개 보이도록 마음에 드는 영역으로 조금 확대해보세요.

  3. 맵 범례에 있는 lakes 레이어를 더블 클릭해서 Properties 대화창을 엽니다.

  4. 호수의 색상을 변경하려면:

    1. symbology Symbology 탭을 클릭합니다.

    2. 채우기(fill) 색상으로 파란색을 선택하십시오.

      ../../../_images/selectFillColor.png

      그림 5.3 호수 색상을 선택하기

    3. OK 를 클릭하십시오. 이제 호수들이 맵 캔버스 상에서 파란색으로 보일 것입니다.

  5. 호수의 이름을 보이게 하려면:

    1. lakes 레이어의 Properties 대화창을 다시 여십시오.

    2. labeling Labels 탭을 클릭합니다.

    3. 드롭다운 메뉴에서 Single labels 를 선택해서 라벨 작업을 활성화합니다.

    4. Label with 목록에서 NAMES 항목을 선택하십시오.

      ../../../_images/showLabels.png

      그림 5.4 호수의 이름을 표시

    5. Apply 를 클릭하십시오. 호수의 경계선 위로 이름을 불러올 것입니다.

  6. 라벨 텍스트 주위에 하얀색의 버퍼를 추가해서 라벨의 가독성을 향상시킬 수 있습니다.

    1. 왼쪽에 있는 목록에서 Buffer 탭을 클릭하십시오.

    2. checkbox Draw text buffer 를 체크하십시오.

    3. 버퍼 크기로 3 을 선택하십시오.

    4. Apply 를 클릭합니다.

    5. 결과가 보기에 좋은지 확인하고, 필요할 경우 버퍼 크기 값을 조정하십시오.

    6. 마지막으로 OK 를 클릭해서 Layer Properties 대화창을 닫고 변경 사항을 적용합니다.

이제 맵을 조판하기 위한 몇몇 장식을 추가한 다음 QGIS에서 내보내보겠습니다:

  1. View ► Decorations ► Scale Bar 메뉴를 선택하십시오.

  2. 대화창이 열리면, checkbox Enable Scale Bar 옵션을 체크하십시오.

  3. 사용자가 바라는대로 대화창의 옵션을 지정해보십시오.

  4. Apply 를 클릭합니다.

  5. 같은 방식으로, 장식(Decorations) 메뉴에서 더 많은 (방위표, 저작권 등등의) 항목들을 사용자 지정 속성으로 맵 캔버스에 추가해보십시오.

  6. Project ► Import/Export ► saveMapAsImage Export Map to Image… 를 클릭하십시오.

  7. 열린 대화창에 있는 Save 버튼을 클릭하십시오.

  8. 파일 위치와 포맷을 선택한 다음 Save 를 다시 클릭해서 확정하십시오.

  9. 사용자의 변경 사항을 .qgz 프로젝트 파일로 저장하려면 Project ► fileSave Save… 메뉴를 클릭하십시오.

끝났습니다! QGIS에서 얼마나 쉽게 래스터 및 벡터 레이어를 가시화하고 옵션을 설정한 다음, 사용자의 맵을 다른 소프트웨어에서 사용할 수 있는 이미지 포맷으로 생성할 수 있는지 아시겠지요. 다음 장에서는 사용할 수 있는 기능, 특징 및 설정들과 그 사용법을 배워보겠습니다.

참고

계속해서 QGIS를 단계적인 예제들을 통해 배워보고 싶다면 QGIS 교육 교재 를 공부하십시오.