14.3. Lesson: 林分をデジタル化する

Unless you are going to use your georeferenced map as a simple background image, the next natural step is to digitize elements from it. You have already done so in the exercises about creating vector data in Lesson: 新しいベクターデータセットを作成する, when you digitized the school fields. In this lesson, you are going to digitize the forest stands' borders that appear in the map as green lines but instead of doing it using an aerial image, you will use your georeferenced map.

このレッスンの目標: 林分をデジタル化し、最終的にそれらに目録データを追加して、デジタル化作業を支援するための技術を学びます。

14.3.1. basic Follow Along: 林分境界を抽出する

前のレッスンで保存された、 map_digitizing.qgs プロジェクトを QGISで開きます。

地図をスキャンして地理参照してしまえば、画像をガイドとして見ることで直接デジタル化を開始できるでしょう。デジタル化に使用しようとしている画像が、例えば航空写真である場合には、それが最も正しい方向である可能性が高いでしょう。

If what you are using to digitize is a good map, as it is in our case, it is likely that the information is clearly displayed as lines with different colors for each type of element. Those colors can be relatively easy extracted as individual images using an image processing software like GIMP. Such separate images can be used to assist the digitizing, as you will see below.

最初のステップは、GIMPを使用して、林分、つまりオリジナルのスキャン地図で見ることができた緑がかった線すべて、だけを含む画像を得ることです。

  • GIMPを開きます(それがまだインストールされていない場合は、インターネットからダウンロードするか、先生に尋ねます)。

  • exercise_data/forestry フォルダの中で、オリジナルの地図画像 rautjarvi_map.tif を開きます ファイル ► 開く 。 林分は緑色の線として(各ポリゴン内には緑で林分の数も一緒に)表されていることに注意してください。

../../../_images/gimp_map.png

これで林分の境界(緑がかったピクセル)を構成している画像内のピクセルを選択できます:

  • ツール 選択 ► 色で を開きます。

  • アクティブツールで、林分の線が線を構成する画素を区別するのに十分なくらい近くなるように、画像にズームインします( Ctrlキー+マウスホイール )。下の左の画像を参照してください。

  • ツールは、いくつかのピクセルの色の値を収集するように行の中央にマウスカーソルをクリックしてドラッグ。

  • マウスクリックを解除し、数秒待って。ツールによって収集された色と一致する画素が画像全体を通して選択されます。

  • 緑がかったピクセルが画像全体で選択されているかを確認するためにズームアウト。

  • 結果に満足できない場合は、クリックやドラッグ操作を繰り返します。

  • ピクセルの選択は、以下の右の画像のようになるはずです。

../../../_images/green_px_selected.png

選択を完了したら、新しいレイヤーとしてこの選択をコピーして別の画像ファイルとして保存する必要があります。

  • 選択された画素をコピー( Ctrl+C )します。

  • そして、ピクセルを直接貼り付けます( Ctr+V )、GIMPには貼り付けられたピクセルが新しい一時的な レイヤーとして、 レイヤー-ブラシ パネル中の 浮動選択(貼り付け レイヤー) として表示されます。

  • その一時レイヤーを右クリックして 新しいレイヤーへ を選択します。

  • レイヤーを貼り付け のみが表示されるよう、元の画像レイヤーの隣の「目」のアイコンをクリックしてそれを非表示にしてください。

../../../_images/saving_green_px.png
  • 最後に、 ファイル ► エクスポート... を選択し、 ファイルの種類を選択(拡張子で)TIFF画像 として設定し、 digitizing フォルダを選択してそれに rautjarvi_map_green.tif と名前を付けます。尋ねられたとき非圧縮を選択します。

画像内の他の要素で同様の処理を行うことができます。例えば、道路を表す黒線や地形等高線を表す茶線を抽出したりもできたでしょう。しかし私たちにとっては林分で十分です。

14.3.2. basic Try Yourself 緑色画素の画像をジオリファレンス

前のレッスンで行ったように、この新しい画像は、データの残りの部分とともに使用できるようにするためにジオリファレンスする必要があります。

この画像はジオリファレンサツールに関する限りは基本的に元の地図画像と同じ画像なので、これ以上地上基準点をデジタル化する必要はないことに注意してください。ここでは、忘れてはならないいくつかのものがあります:

  • この画像も、もちろん、KKJ/フィンランドゾーン2 CRSです。

  • 保存された地上基準点を使用する必要があります、 ファイル ► GCP 点をロード

  • 変換設定 を確認することを忘れないでください。

  • 出力ラスターに digitizing フォルダ中で rautjarvi_green_georef.tif と名前を付けます。

新しいラスターが元の地図ときちんと合っていることを確認してください。

14.3.3. basic Follow Along: デジタル化を支援するポイントを作成する

QGISでのデジタル化ツールを心に持っていて、デジタル化の間にそれらの緑のピクセルにスナップしたら便利だろうとすでにお考えかもしれません。それはまさに次にしようとしていること、QGISで利用可能なスナップツールを使用して、後でデジタル化するときに林分の境界をたどる支援するためにそれらを使用するためにこれらのピクセルからポイントを作成です。

  • ラスター ► 変換 ► ポリゴン化(ベクターからラスター) ツールを使用して、緑の線をポリゴンに ベクター化してください。どのようにか覚えていない場合、 Lesson: ラスターからベクターへの変換 で確認できます。

  • digitizing フォルダ内に rautjarvi_green_polygon.shp と名前を付けて保存します。

ズームインしてポリゴンがどのように見えるかを参照してください。何かこのようになっているでしょう:

../../../_images/green_polygons.png

これらのポリゴンからポイントを得る次のオプションは、その重心を得ることです:

  • ベクター ► ジオメトリツール ► ポリゴン重心 を開きます。

  • ツールの入力ファイルとしてたった今得たポリゴンレイヤーを設定します。

  • digitizing フォルダ内部で 出力 に green_centroids.shp と名前を付けます。

  • 結果を キャンバス に追加 をチェックします。

  • ポリゴンの重心を計算するためのツールを実行します。

../../../_images/green_points.png

今、TOCから rautjarvi_green_polygon レイヤーを削除できます。

重心レイヤーのシンボルをこのように変更します:

  • green_centroidsレイヤーのプロパティ を開きます。

  • Go to the Symbology tab.

  • 単位 を地図単位に設定してください。

  • サイズ を1に設定してください。

ポイント1つ1つを区別する必要はありません。それらはスナップツールが使用するためそこにある必要があるだけです。これらのポイントを使用することで、それらがない場合よりもずっと簡単に元の線をたどれるようになりました。

14.3.4. basic Follow Along: 林分をデジタル化

これで実際のデジタル化作業を開始する準備が整いました。 ポリゴンタイプ のベクターファイルの作成から始めますが、この演習のためには、関心領域の一部がすでにデジタル化されているシェープファイルがあります。主要道路(幅の広いピンクの線)と湖の間に残っている林分の半分のデジタル化を完了するだけでしょう:

../../../_images/forest_stands_to_digitize.png
  • ファイルマネージャのブラウザを使用して digitizing フォルダに行きます。

  • 地図に forest_stands.shp ベクターファイルをドラッグ&ドロップします。

どのポリゴンがすでにデジタル化されているかが容易に見えるように、新しいレイヤーのシンボルを変更します。

  • ポリゴンの塗りを緑に。

  • ポリゴン境界を1mmに。

  • そして透明度を50%に設定します。

過去のモジュールを覚えていれば今、私たちは、セットアップおよびスナップオプションを有効にする必要があります:

  • Go to Project ► Snapping options....

  • Activate the snapping for the green_centroids and the forest_stands layers.

  • それらのレイヤーの 許容誤差 を5地図単位に設定してください。

  • forest_stands レイヤーの 交差を回避 ボックスを チェックします。

  • トポロジ編集を有効 をチェックします。

  • 適用 をクリックします。

../../../_images/snapping_settings_forest.png

これらのスナップ設定では、デジタル化中に重心レイヤー中のポイントの一つまたはデジタル化されるポリゴンのどこかの頂点に十分近づくといつでも、ピンクの十字がスナップされる点に表示されます。

最後に、forest_stands`と :kbd:`rautjarvi_georef を除くすべてのレイヤーの可視性をオフにします。地図画像がこれ以上の透明されていないことを確認してください。

デジタル化を開始する前に注意すべきいくつかの重要な事:

  • 国境のデジタル化ではあまりに正確にしようとしないでください。

  • 境界が直線である場合は、ノード2つだけでデジタル化してください。一般に、できるだけ少ないノードを使用してデジタル化してください。

  • 正確であることが必要と感じた場合のみズームインして範囲を閉じてください、例えばいくつかのコーナーで、またはポリゴンを特定のノードで他のポリゴンと接続したいとき。

  • デジタル化しながら、マウスの中ボタンを使用してズームイン/アウトおよびパンしてください。

  • 一度に1つのポリゴンをデジタル化してください。

  • 1つのポリゴンをデジタル化した後、地図から見える林分IDを書き込みます。

今、デジタル化を開始できます:

  • 地図ウィンドウで林分番号357の位置を確認します。

  • forest_stands.shp レイヤーについて編集を有効にします。

  • 地物を追加 ツールを選択します。

  • ドットの一部を接続することにより、林分 357 をデジタル化開始します。

  • スナップを示すピンク十字に留意されたいです。

../../../_images/dgitizing_357_1.png
  • 完了したら、右クリックしてそのポリゴンのデジタル化を終了します。

  • 林分 id を入力します(この場合は357)。

  • OK をクリックします。

デジタル化し終えてもポリゴン id の入力を求められなかった場合は、 設定 ► オプション ► デジタル化 に行き、 地物作成後まで 属性 フォームのポップアップを抑止 がチェックされていないことを確認してください。

デジタル化されたポリゴンは次のようになります。

../../../_images/dgitizing_357_3.png

今、第二のポリゴンのために、林分番号358を拾います。 forest_stands レイヤー 交差を回避 がチェックされていることを確認してください。このオプションではデジタル化においてポリゴンが交差することを許容しません。既存のポリゴンを超えてデジタル化した場合、新しいポリゴンは既存のポリゴンの境界に合うようにトリミングされます。この特性を使用すれば共通の境界が自動的に得られます。

  • 林分357と共通する角の一つで林分358をデジタル化し始めます。

  • それから両方の林分のための他の共通の角に到達するまで、正常に継続します。

  • 最後に、共通の境界が交差されていないことを確認しながらポリゴン357内のいくつかのポイントをデジタル化します。下の左の画像を参照。

  • 右の林358の編集を終了します

  • id を358と入力します。

  • Click OK, your new polygon should show a common border with the stand 357 as you can see in the image on the right.

../../../_images/dgitizing_358_5.png

既存のポリゴンを重ねたポリゴンの一部は自動的にトリミングされていて、それがあることを意図したように、共通の境界が残されています。

14.3.5. basic Try Yourself 林分をデジタル化完了

今、2つ林分の準備ができています。そして、続行する方法について良いアイデア。主要道路と湖によって制限されているすべての林分をデジタル化するまで、自分でデジタル化を続行します。

それは大変な作業のように見えるかもしれませんが、すぐに林分をデジタル化するのに慣れるでしょう。それは約15分かかります。

デジタル化中に、ポリゴンを編集したり削除したノードを、分割またはマージする必要がある場合があります。 Lesson: 地物のトポロジ で必要なツールについて学びましたが、今それらについて読み直しに行くにはおそらく良い瞬間です。

トポロジの編集を有効 がアクティブになっていると、共通の境界は、両方のポリゴンの同じ時間に編集されているように、2つのポリゴンに共通のノードを移動できます、ことを覚えておいてください。

結果は次のようになります。

../../../_images/stands_fully_digitized.png

14.3.6. basic Follow Along: 林分データを結合

地図のために持っている森林目録データは、紙に書かれている可能性があります。その場合は、最初にテキストファイルやスプレッドシートにそのデータを記述する必要があります。この演習では、1994年目録(地図と同じ目録)からの情報は、カンマ区切りテキスト(CSV)ファイルとして準備ができています。

テキストエディタで exercise_data\forestry ディレクトリ中の rautjarvi_1994.csv ファイルを開き、目録データファイルが 林分 の番号である ID と呼ばれる 属性 を持っていることに注意してください。これらの番号はポリゴンに入力した 林分 のIDと同じであり、 ベクターファイルにテキストファイルからのデータをリンクするために使用できます。同じフォルダにある rautjarvi_1994_legend.txt ファイルでこの目録データのメタデータを見ることができます。

  • QGIS で .csv レイヤー ► 区切りテキストレイヤーを追加... ツールを開きます。ダイアログ で、それを次のように設定します。

../../../_images/inventory_csv_import.png

.csv ファイルからデータを追加するには:

  • forest_stands レイヤーのための[レイヤーのプロパティ]を開きます。

  • 結合 タブに移動します

  • ダイアログボックスの下部にあるプラス記号をクリックします。

  • 結合レイヤー として rautjarvi_1994.csv を 、 結合 フィールドとして ID を選択します。

  • 結合先 フィールドも id に設定されていることを確認してください。

  • OK を2回クリックします。

テキストファイルからのデータは、今ベクターファイルにリンクする必要があります。起こったことを確認するには、 forest_stands レイヤーの属性テーブル を開きます。目録データファイルからのすべての 属性 は、今お使いのデジタル化された ベクターレイヤーにリンクされていることがわかります。

14.3.7. basic Try Yourself 属性 名の名前を変更してエリアと境界を追加する

.csv ファイルからのデータがちょうど ベクターファイルにリンクされています。データが実際に ベクターファイルに記録されるように、このリンクを恒久的なものにするには新しい ベクターファイルとして forest_stands レイヤーを保存する必要があります。 属性テーブル を閉じ、forest_stands レイヤーを右クリックして forest_stands_1994.shp としてそれを保存します。

まだ追加していなかった場合は、新しい forest_stands_1994.shp を地図で開きます。そして、 属性 テーブル を開きます。追加した列の名前はぜんぜん有用でないことに気づきます。これを解決するには:

  • 前に他のプラグインに行ったように テーブルマネージャ プラグインを追加します。

  • プラグインが有効になっていることを確認します。

  • TOCでレイヤー forest_stands_1994.shp を選択します。

  • 次に、ベクター ► テーブルマネージャ ► テーブルマネージャ に行きます。

  • ダイアログボックスを使用し、 .csv ファイル中のものと一致するように列の名前を編集します。

../../../_images/forestry_table_manager.png
  • 保存 をクリックします。

  • はい を選択してレイヤースタイルを維持します。

  • テーブルマネージャ ダイアログを閉じます。

これらの 林分 に関連する情報を収集完了するには、 林分 の面積と周囲を計算することがあります。Lesson: 補足の実習 内のポリゴンのための領域を計算しました。する必要がある場合は、そのレッスンに戻り 林分 の領域を計算し、新しい 属性 に 面積 と名前を付け、計算値はヘクタールであることを確認してください。

forest_stands_1994.shp レイヤーは準備され、利用可能なすべての情報が満載です。

後で戻ってくる必要がある場合に備え、現在の地図の表示を維持するためにプロジェクトを保存します。

14.3.8. In Conclusion

これにはマウスを数回クリックする必要がありますが、今、デジタル形式とQGISでの使用のために準備中で古い調査データを持っています。

14.3.9. What's Next?

まっさらな新しいデータセットで異なる分析することで開始できますが、より最新のデータセットの分析を行うことにより興味があるのではないでしょうか。次のレッスンのトピックは、現在の航空写真やデータセットにいくつかの関連情報の追加を使用した林分の作成になります。