14.6. Lesson: 地図帳ツールで詳細な地図を作成する

体系的なサンプリングの設計が準備でき、野外チームがナビゲーションデバイスにGPS座標をロードしました。彼らはまた、すべてのサンプルプロットで測定された情報を収集するための野外データフォームを持っています。野外チームは、すべてのサンプルプロットへ行く道が簡単に見つかるよう、いくつかの地上情報がサンプルプロットのより小さいサブセットや地図エリアに関する情報と一緒にはっきり見える大量の詳細地図を要求してきました。地図帳ツールを使用することで、大量の地図を共通のフォーマットで自動的に作成できます。

このレッスンの目標: QGISで地図帳ツールを使用して、野外目録作業を支援するための詳細な印刷可能な地図を作成することを学びます。

14.6.1. basic Follow Along: Preparing the Print Layout

森林地域と私たちのサンプリングプロットの詳細な地図を自動化できるようになるには、まず野外作業のために有用と考えるすべての要素が入った地図テンプレートを作成する必要があります。もちろん、最も重要なのは、前に見てきたように、適切にスタイル設定されることですが、印刷された地図を完成する他の要素もたくさん追加する必要があります。

前のレッスンからQGISプロジェクトを開きます forest_inventory.qgs 。少なくとも以下のレイヤーを持っている必要があります。

  • forest_stands_2012 (50%の透明度、緑塗りつぶしと暗緑色の境界線を有する)。

  • systematic_plots_clip

  • rautjarvi_aerial

プロジェクトを新しい名前 map_creation.qgs で保存します。

To create a printable map, remember that you use the Layout Manager:

  • Open Project ► Layout Manager....

  • In the Layout manager dialog.

  • Click the Add button and name your print layout forest_map.

  • OK をクリックします。

  • 表示 ボタンをクリックします。

地図がA4用紙のために、紙や余白に合うように、プリンタオプションを設定します。

  • Open menuselection:Layout --> Page Setup....

  • サイズA4(217 X 297ミリメートル)

  • 向き風景

  • Margins (millimeters) are all set to 5.

印刷レイアウト ウィンドウで、 構図 タブ(右のパネル)に行き、 紙と品質 に対するこれらの設定がプリンタ用に定義されたものと同じであることを確認してください:

  • サイズA4(210x297mm)

  • 向き

  • 品質300dpi

Composing a map is easier if you make use of the canvas grid to position the different elements. Review the settings for the layout grid:

  • 組版 タブ中で グリッド 地域を展開します。

  • 余白10 mm に設定されていることを確認してください。

  • そして 許容誤差2mm に設定されています。

グリッドの使用を有効にする必要があります。

  • 表示 メニューを開きます。

  • グリッドを表示 をチェックします。

  • グリッドにスナップ をチェックします。

  • Notice that options for using guides are checked by default, which allows you to see red guiding lines when you are moving elements in the layout.

Now you can start to add elements to your layout. Add first a map element so you can review how the map canvas looks as you will be making changes in the layers symbology:

  • Click on the addMap Add Map button.

  • 地図がそれのほとんどを占めるようにキャンバス上でクリックして矩形にドラッグします。

../../../_images/composer_1.png

マウスカーソルがキャンバスのグリッドにスナップされるに注意してください。他の要素を追加したときに、この機能を使用してください。より精度を高くしたい場合は、グリッド 間隔 設定を変更してください。何らかの理由でいくつかの点でグリッドにスナップしたくない場合は、常に ビュー メニュー中でいつでもそのチェックを切り替えできます。

14.6.2. basic Follow Along: 背景地図を追加する

Leave the layout open but go back to the map. Lets add some background data and create some styling so that the map content is as clear as possible.

  • Add the background raster basic_map.tif that you can find in the exercise_data\forestry\ folder.

  • プロンプトが表示されたら ETRS89/ETRS-TM35FIN CRS をラスターのために選択します。

ご覧のように背景地図にはすでにスタイルが付いています。このタイプの使用準備ができている地図作成ラスターは非常に一般的です。それは、ベクターデータから作成された標準形式でスタイルとラスターとして格納されていますので、いくつかのベクターレイヤーにスタイル付けする手間や良い結果を得られているか心配する必要がありません。

  • 今、プロットの約4または5行を見ることができるようにサンプルプロットにズームします。

The current styling of the sample plots is not the best, but how does it look in the print layout?:

../../../_images/plots_zoom1-2.png

最後の演習の間、白いバッファは空撮画像の上ではOKでしたが、今は背景画像はほとんどが白であり、ほとんどラベルが見えません。レイアウト上でどのように見えるか確認もできます:

  • Go to the Print Layout window.

  • Use the select button to select the map element in the layout.

  • アイテムのプロパティ タブに移動します。

  • 範囲 の下で 地図キャンバス範囲に設定 をクリックしてください。

  • 要素を再描画する必要がある場合は、 メインプロパティ 下の プレビューを更新 をクリックしてください。

これは明らかに十分ではありません。野外チームのためにプロット番号ができるだけはっきり見えるようにしたいです。

14.6.3. basic Try Yourself レイヤーのシンボルを変更する

シンボル体系の Module: Creating and Exploring a Basic Map 、およびラベルの Module: ベクターデータを分類する 中で作業してきました。利用可能なオプションとツールのいくつかについて、更新する必要がある場合は、それらのモジュールに戻ります。目標は、プロットの位置と名前ができるかぎりはっきりと見えるように、しかしつねに背景地図要素が見えるようにすることです。この画像からいくつかのガイダンスを取ることができます。

../../../_images/plots_zoom2_symbology.png

後で forest_stands_2012 レイヤーの緑のスタイリングを使用するでしょう。それを維持し、林分の境界だけを表示するようそれを可視化するには:

  • forest_stands_2012 を右クリックし 複製 を選択します

  • たとえば塗りつぶしと赤の境界がない別のスタイルを定義するために使用できる、forest_stands_2012 copy という名前の新しいレイヤーを取得します。

今、林分にはの二つの異なる視覚化があり、詳細地図にどちらを表示するか決定できます。

印刷レイアウト ウィンドウに何度も戻り、地図がどのように見えるかを確認します。詳細地図を作成するという目的のため、全体の森林地域の縮尺(下の左画像)ではなくより近い縮尺(下の右画像)で良く見えるシンボルを探しています。地図やレイアウトでズームを変更するたびに、 プレビューを更新地図キャンバス範囲設定 を使用することを忘れないでください。

../../../_images/composer_2-3.png

14.6.4. basic Try Yourself 基本地図テンプレートを作成する

満足なシンボル体系を得たら、印刷された地図にいくつかのより多くの情報を追加する準備が整いました。少なくとも次の要素を追加します。

  • タイトル。

  • スケールバー。

  • 地図のグリッドフレーム。

  • グリッドの両側の座標。

Module: Laying out the Maps では既に同様の組成を作成しています。必要に応じてそのモジュールに戻ってください。参考のために、この例の画像を見ることができます:

../../../_images/map_template1.png

地図を画像として書き出し、それを見てください。

  • Layout ► Export as Image....

  • 例えば JPGフォーマット を使用してください。

これは、印刷されたときに、それがどのように見えるかです。

14.6.5. basic Follow Along: Adding More Elements to the Print Layout

提案された地図テンプレート画像でおそらくお気づきのように、キャンバスの右側には空間がたくさんあります。他に何をそこに置けるか見てみましょう。ここでの地図の目的のためには凡例は本当は必要はありませんが、概要地図といくつかのテキストボックスで、地図に値を追加できます。

全体図は、野外チームが、一般的な森林地域内の詳細図を置くのに役立ちます。

  • タイトルテキストのすぐ下で、キャンバスに別の地図要素を追加します。

  • アイテムのプロパティ タブで、 全体図 ドロップダウンを開きます。

  • 概要フレーム を地図 Map 0 に設定してください。これは小さい地図上に大きい地図に表示された範囲を表す影の矩形を作成します。

  • フレーム オプションが黒色で、 厚さ0.30 であることもチェックします。

../../../_images/more_elements1.png

この概観地図では本当に望んでいる森林地域の概観になっていないことに注意してください。望んでいることは、この地図が森林地域全体を表現し、それが背景地図と forest_stands_2012 レイヤーだけを表示して、サンプルプロットを表示しないことです。そして、もうレイヤーの可視性や順序を変更しても変更されないよう、そのビューをロックすることです。

  • Go back to the map, but don't close the Print Layout.

  • forest_stands_2012 レイヤーを右クリックし 、レイヤー範囲にズーム をクリックします。

  • basic_mapforest_stands_2012 以外のすべてのレイヤーを無効にします。

  • Go back to the Print Layout.

  • 選択された小地図では、 地図キャンバス範囲を設定 をクリックし 、その範囲を地図ウィンドウで見えるものに設定してください。

  • メインプロパティ 下の 地図項目のためにレイヤーをロック をチェックすることにより、全体図のビューをロックします。

今概観地図は、予想するより以上のものであり、そのビューはもう変更しないでしょう。しかし、もちろん、詳細地図は今まだ林分境界もサンプルのプロットも表示していません。修正しましょう:

  • 再度、地図ウィンドウに移動し、見えるようにしたいレイヤーを選択します( systematic_plots_clipforest_stands_2012 copyBasic_map )。

  • サンプルプロットの数ラインだけ見えるように再び拡大します。

  • Go back to the Print Layout window.

  • Select the bigger map in your layout (select).

  • 項目のプロパティ 中で プレビューを更新地図キャンバス範囲に設定 をクリックしてください。

大きな地図だけが、現在の地図ビューを表示している、小さな索引地図は、それをロックしたときに持っていた同じ景色を保っていることに注意してください。

索引図は、詳細地図に示されている範囲の陰影付の枠を表示していることにも注意。

../../../_images/more_elements2.png

テンプレート地図はほぼ準備ができています。ここで2つのテキストボックスを地図の下に追加します、一方はテキスト「詳細地図ゾーン:」含む、もう一方は「備考:」。それらが上の画像で見えるように配置してください。

また、全体図に北矢印を追加できます。

  • 画像を追加 ツールを使用してください addImage

  • 全体図の右上にクリックしてください。

  • アイテムのプロパティ検索ディレクトリ を開き、矢印画像を参照します。

  • 画像回転 の下で 地図でSync をチェックし、 Map 1 (概要地図)を選択します。

  • 背景 のチェックを外します。

  • 矢印画像のサイズを小さな地図上で良く見えるサイズに変更します。

The basic map layout is ready, now you want to make use of the Atlas tool to generate as many detail maps in this format as you consider necessary.

14.6.6. basic Follow Along: 地図帳カバレッジを作成する

地図帳カバレッジは、カバレッジ内のすべての地物に対して1枚の地図という詳細地図を作成するために使用される、ただのベクターレイヤーです。次に何をするかのアイデアを得るために、ここに森林地域のため詳細地図のフルセットがあります:

../../../_images/preview_atlas_results.png

カバレッジは何か既存のレイヤーでも良いのですが、通常はその特定の目的のために1つ作成する方が理にかなっています。森林地域をカバーするポリゴンのグリッドを作成してみましょう:

  • QGIS地図ビューで ベクター ► 研究ツール ► ベクターグリッド を開きます。

  • この画像に示すようにツールを設定します。

../../../_images/coverage_polygons.png
  • atlas_coverage.shp として出力を保存します。

  • 新しい atlas_coverage レイヤーを、ポリゴンが塗りを持たないようにスタイル設定します。

新しいポリゴンは全体の森林地域をカバーしていて、それらは(各ポリゴンから作成された)各地図に何が含まれているかを教えてくれます。

../../../_images/atlas_coverage.png

14.6.7. basic Follow Along: 地図帳ツールを設定する

最後のステップは、地図帳ツールを設定することです:

  • Go back to the Print Layout.

  • 右側のパネルで 地図帳作成 タブに行きます。

  • 次のようにオプションを設定します。

../../../_images/atlas_settings.png

詳細地図の焦点として atlas_coverage 内部のそれは地物(ポリゴン)を使用する地図帳ツールに指示します。これは、レイヤー内のすべての地物の出力1つの地図になります。隠しカバレッジレイヤー は出力地図でポリゴンを表示しないように地図帳に伝えます。

もう一つする必要があります。すべての出力地図に対してどの地図要素が更新されるつもりかを地図帳ツールに伝える必要があります。今までに、すべての地物のために変更される地図は、サンプルプロットの詳細ビューを含むように準備したものであるとおそらく推測できます、つまりそれはキャンバス中の大きい方の地図要素です:

  • より大きな地図要素を選択します。

  • アイテムのプロパティ タブに移動します。

  • リストで、地図帳によって制御 をチェックします。

  • そして 地物周りにマージンg10% と設定します。ビューの範囲はポリゴンよりも10%大きくなります、これは詳細地図が10% 重なりを持っていることを意味します。

../../../_images/controlled_by_atlas.png

今、地図がどのように見えるか確認するために地図帳地図のプレビューツールを使用できます。

  • ボタン atlas を使用して、または地図帳ツールバー が表示されていない場合は 地図帳 ► 地図帳をプレビュー を通じて、地図帳のプレビューを有効にします。

  • 作成される地図を移動するには、地図帳ツールバーまたは 地図帳 メニューの矢印を使用できます。

それらのいくつかは関心のない地域をカバーしていることに注意してください。それについて何かをして、それらの無用な地図を印刷しないことで、木をいくらか節約しましょう。

14.6.8. basic Follow Along: カバレッジレイヤーを編集する

それらの地域のために関心のないポリゴンを削除するだけでなく、カバレッジ レイヤーの 属性テーブル からのコンテンツを生成するように、地図内のテキストラベルもカスタマイズできます。

  • 地図ビューに戻ります。

  • atlas_coverage レイヤーの編集を有効にします。

  • 下の画像に(黄色で)選択されたポリゴンを選択します。

  • 選択したポリゴンを削除します。

  • 編集を無効にして、編集内容を保存します。

../../../_images/remove_polygons.png

You can go back to the Print Layout and check that the previews of the Atlas use only the polygons you left in the layer.

使用しているカバレッジレイヤーは、まだ地図内のラベルの内容をカスタマイズするために使用できる有用な情報を持っていません。最初のステップはそれらを作成すること、たとえばポリゴン領域のゾーンコードおよび野外チームが考慮に入れるいくつかの発言のフィールドを追加できます:

  • atlas_coverage レイヤーのための 属性テーブル を開きます。

  • 編集を有効にします。

  • calculateField 計算機を使用して、以下の二つのフィールドを作成して投入します。

  • Zone という名前の、タイプ 整数(整数) のフィールドを作成します。

  • ボックスで $rownum を書き込み/コピー/構築します。

  • 名前が Remarks 、タイプが テキスト(文字列) 、幅が 255 の別のフィールドを作成します。

  • ボックスで 「備考なし」 と書き込みます。これは、すべてのポリゴンに対してすべてデフォルト値を設定します。

森林管理は、地域を訪れる際に役に立つかもしれない地域に関するいくつかの情報を持っています。例えば、橋の有無、湿地や保護種の位置。 atlas_coverage レイヤーはおそらくまだ編集モードです、 Remarks フィールド中に次のテキストを対応するポリゴンに追加します(セルを編集するにはそのセルをダブルクリックしてください):

  • ゾーン 2について:プロット19の北に橋。p_13とp_14間にシベリアリス。

  • ゾーン 6について: 湖の北へ沼に移するのは困難

  • ゾーン 7について: p_94.の南東にシベリアリス

  • 編集を無効にして、編集内容を保存します。

atlas_coverage レイヤーの属性テーブルはほぼ準備ができて、今、テキストラベルの一部がそこから情報を使用したい地図帳ツールを伝える必要があります。

  • Go back to the Print Layout.

  • 詳細図... を含むテキストラベルを選択します。

  • フォント サイズを 12 に設定してください。

  • ラベル内のテキストの末尾にカーソルを設定します。

  • In the Item properties tab, inside the Main properties click on Insert or Edit an Expression....

  • 関数リストフィールドと値 の下のフィールド ゾーン をダブルクリックします。

  • OK をクリックします。

  • アイテムプロパティ 中のボックス内のテキストは 詳細図調査ゾーン: [% "Zone" %] と表示されるはずです。 [% "Zone" %]atlas_coverage レイヤーからの対応する地物について、フィールド ゾーン の値によって置換されることに注意。

異なる地図帳プレビュー地図を見て、ラベルの内容をテストします。

ゾーン情報を持つフィールドを使用して、 注釈: というテキストを持つラベルに対しても同じ操作を行います。式を入力する前にブレークラインを残すことができます。下の画像でゾーン2のプレビューの結果を見ることができます:

../../../_images/preview_zone2.png

地図帳プレビューを使用して。すぐに作成されているであろうすべての地図を閲覧してお楽しみください!

14.6.9. basic Follow Along: 地図を印刷する

最後になりましたが、印刷や画像ファイルやPDFファイルに地図をエクスポートします。 地図帳 ► 地図帳をPDFとして書き出し...地図帳 ► 地図帳を画像として書き出し... を使用できます。現在、SVGのエクスポート形式は正常に動作せず、貧しい結果が得られます。

現地事務所に印刷用に送付できるよう、単一のPDFとして地図を印刷しましょう:

  • 右パネルの 地図帳作成 タブに移動します。

  • 出力 の下で 可能ならば単一ファイルに書き出し をチェックします。これはすべての地図を1つのPDFファイルにまとめます。このオプションがチェックされていない場合はすべての地図に1つずつファイルが得られます。

  • Open Layout ► Export as PDF....

  • PDFファイルを exercise_data\forestry\samplig\map_creation\ フォルダ中に inventory_2012_maps.pdf として保存します。

すべてが期待どおりに行ったことを確認するためにPDFファイルを開きます。

同じように簡単にすべての地図に対して別々の画像を作成できます(単一ファイルの作成をオフにすることを忘れないでください)、作成されるであろう画像のサムネイルをここで見ることができます:

../../../_images/maps_as_images.png

印刷レイアウト で、レイアウトテンプレートとして forestry_atlas.qpt として exercise_data\forestry\map_creation\ フォルダ中に地図を保存します。 レイアウト ► テンプレートとして保存 を使用します。このテンプレートは何度も何度も使用できます。

Close the Print Layout and save your QGIS project.

14.6.10. In Conclusion

別のプロットに移動するのを助けるために野外で使用される詳細地図を自動作成するのに使用できるテンプレート地図の作成にこぎつけました。お気づきのように、これは簡単な作業ではありませんでしたが、他の地域についても同様の地図を作成する必要があるときに利益がもたらされ、先ほど保存したテンプレートを使用できます。

14.6.11. What's Next?

次のレッスンではレーザー測量データを使用してDEMを作成し、それからそれを使用してデータや地図の視認性を高める方法を示します。