Outdated version of the documentation. Find the latest one here.

Интерфейс QGIS

В приложении QGIS, графический интерфейс пользователя разделяется на шесть основных областей, которые перечислены ниже и отмечены соответствующими номерами на рисунке:

Figure QGIS GUI 1:

../../../_images/startup.png

QGIS GUI with Alaska sample data nix

Примечание

Внешний вид элементов интерфейса (заголовки окон и т.п.) может отличаться, в зависисмости от операционной системы и менеджера окон.

Интерфейс QGIS разделяется на пять областей:

  1. Главное меню

  2. Панель инструментов

  3. Легенда

  4. Область карты

  5. Строка состояния

Компоненты интерфейса QGIS, комбинации клавиш и контекстная справка более подробно описаны в следующих разделах.

Панель инструментов

Панели инструментов обеспечивают доступ к большинству тех же функций, что и меню, а также содержат дополнительные инструменты для работы с картой. Для каждого пункта панели инструментов также доступна всплывающая подсказка. Для её получения просто задержите мышь над пунктом панели инструментов.

Каждую панель инструментов можно перемещать в зависимости от ваших потребностей. Кроме того, каждую панель инструментов можно скрыть при помощи контекстного меню, которое вызывается щелчком правой кнопкой мыши на соответствующей панели (см. также Панели инструментов).

Совет

Восстановление панелей инструментов

Если вы случайно скрыли все панели инструментов, можно вернуть их обратно, используя пункт меню Вид ‣ Панели инструментов ‣. Если панели исчезли при работе в Windows, что иногда случается c QGIS, необходимо удалить ключ реестра \HKEY_CURRENT_USER\Software\QuantumGIS\qgis\UI\state. При следующем запуске QGIS будет использовать значение по умолчанию и все панели инструментов снова станут видны.

Легенда

Область легенды содержит список всех слоёв проекта. Флажок у каждого элемента легенды используется для показа или сокрытия слоя.

Выделенный слой можно перетаскивать выше или ниже других слоёв, меняя их порядок расположения. Порядок расположения слоев означает, что слои находящиеся ближе к верхней части легенды, отрисовываются в окне карты над слоями, перечисленными в легенде ниже.

Слои можно объединять в группы. Это можно сделать следующими способами:

  1. Поместите курсор мыши в окне легенды карты, щёлкните правой кнопкой мыши и выберите пункт Добавить группу. Введите название группы и нажмите Enter. Теперь можно выделить слой и перетащить его на значок группы.

  2. Выберите несколько слоёв, вызовите контекстное меню и выберите Сгруппировать выделенное. Выделенные ранее слои буду автоматически помещены в новую группу.

Исключить слой из группы можно перетащив его из группы на свободное место в области легенды, или выбрав пункт Сделать элементом первого уровня в контекстном меню слоя. Группы могут быть вложенными.

Флажок возле имени группы даёт возможность переключать видимость всех слоев в группе одним действием.

Содержание контекстного меню, доступного при нажатии правой кнопки мыши на слое, зависит от того, на каком слое в окне легенды вы нажали правой кнопкой — растровом или векторном. Для векторных слоев GRASS mActionToggleEditing Режим редактирования недоступен. Редактирование векторных слоев GRASS рассматривается в разделе Оцифровка и правка векторных слоёв GRASS.

Контекстное меню для растровых слоев

  • Увеличить до границ слоя

  • Увеличить до наилучшего масштаба (100%)

  • Показать в обзоре

  • Удалить

  • Изменить систему координат

  • Выбрать систему координат слоя для проекта

  • Свойства

  • Переименовать

  • Копировать стиль

  • Добавить группу

  • Развернуть все

  • Свернуть все

  • Обновлять порядок отрисовки

Дополнительно, в зависимости от положения слоя

  • Сделать элементом первого уровня

  • Сгруппировать выделенное

Контекстное меню для векторных слоев

  • Увеличить до границ слоя

  • Показать в обзоре

  • Удалить

  • Изменить систему координат

  • Выбрать систему координат слоя для проекта

  • Открыть таблицу атрибутов

  • Режим редактирования (недоступен для слоёв GRASS)

  • Сохранить как...

  • Сохранить выделение как...

  • Запрос...

  • Показать количество объектов

  • Свойства

  • Переименовать

  • Копировать стиль

  • Добавить группу

  • Развернуть все

  • Свернуть все

  • Обновлять порядок отрисовки

Дополнительно, в зависимости от положения слоя

  • Сделать элементом первого уровня

  • Сгруппировать выделенное

Контекстное меню для групп слоев

  • Увеличить до группы

  • Удалить

  • Изменить систему координат группы

  • Переименовать

  • Добавить группу

  • Развернуть все

  • Свернуть все

  • Обновлять порядок отрисовки

При зажатой клавише CTRL можно выделять несколько слоёв или групп одновременно. Это позволит переместить все выделенные слои из одной группы в другую.

Кроме того, можно удалить сразу несколько слоёв или групп, выделив их с зажатой клавишей Ctrl, а затем нажав Ctrl+D. Так можно удалить все выделенные слои или группы из списка слоёв.

Независящий от легенды порядок отрисовки

Начиная с QGIS 1.8 появилась возможность задавать порядок отрисовки независимо от расположения слоёв в легенде. Для использования этой возможности активируйте панель Порядок отрисовки из меню Вид ‣ Панели и настройте порядок отрисовки слоёв в ней. Таким образом слои в легенде могут быть расположены в порядке важности, но отрисовка будет выполняться в правильном порядке (см. рисунок figure_layer_order). Сбрасывание флажка checkbox Порядок отрисовки вернет прежнее поведение (порядок отрисовки определяется положением слоёв в легенде).

Figure Layer Order:

../../../_images/layer_order.png

Define a legend independent layer order nix

Область карты

Это наиболее важная часть QGIS — в этой области отображаются карты. Карта, отображаемая в области, зависит от того, какие векторные и растровые слои загружены в QGIS (см. соответствующие разделы). Данные в окне карты можно панорамировать (прокручивать, смещать фокус отображения карты на другую область) и масштабировать (увеличивать или уменьшать). Также с картой можно выполнять многие другие операции, которые перечислены выше в описаниях меню и панелей инструментов. Область карты и легенда тесно связаны друг с другом — карта отображает изменения, вносимые в легенде.

Совет

Масштабирование карты с помощью колеса мыши

Для увеличения и уменьшения масштаба карты можно пользоваться колесом мыши. Поместите курсор мыши внутри области карты и вращайте колесо вперед (от себя) для увеличения масштаба (приближения) и назад для уменьшения масштаба (удаления). Масштабирование производится относительно центра, которым является положение курсора мыши. Поведение колеса мыши при масштабировании, можно настроить по своему вкусу на вкладке Инструменты в меню Установки ‣ Параметры.

Совет

Панорамирование карты, используя клавиши со стрелками и клавишу пробела

Для панорамирования (прокрутки) карты можно пользоваться клавишами со стрелками. Поместите курсор мыши внутри области карты, нажмите клавишу вправо для панорамирования на восток, влево — для панорамирования на запад, вверх — для панорамирования на север и вниз — для панорамирования на юг. Также можно панорамировать карту используя клавишу пробел: просто передвигайте курсор, удерживая нажатой клавишу «пробел».

Строка состояния

Строка состояния отображает текущую позицию в координатах карты (например, в метрах или десятичных градусах) курсора мыши при его перемещении в окне карты. Слева от отображаемых координат в строке состояния, находится маленькая кнопка, которая позволяет переключаться между отображением координат позиции курсора и координат границ вывода карты при масштабировании и панорамировании.

Рядом с полем отображения координат курсора показывается масштаб карты. При масштабировании это значение меняется автоматически. Начиная с QGIS 1.8 масштаб можно выбирать из списка предустановленных значений от 1:500 до 1:1000000.

Индикатор выполнения в строке состояния, отображает процесс отрисовки (рендеринга) каждого слоя в окне карты. В некоторых случаях, таких, как подсчёт статистики в растровых слоях, индикатор состояния используется для отображения статуса длительных операций.

В случае, если будет доступен новый модуль или обновление для существующего модуля, в строке состояния появится новое сообщение. Справа в строке состояния, находится маленький флажок, который используется для временного прекращения отрисовки слоев в окне карты (см. раздел Рендеринг ниже). Нажатием на кнопку mIconStopRendering можно немедленно прекратить отрисовку карты.

Последним справа в строке состояния находится код EPSG текущей системы координат и значок Преобразования координат. Нажатие на этом значке открывает окно свойcтв текущего проекта с активной вкладкой Система координат.

Совет

Вычисление правильного масштаба карты

При запуске QGIS, единицами измерения по умолчанию являются градусы, и предполагается, что любые координаты в ваших слоях также заданы в градусах. Для получения правильных значений масштаба, можно вручную изменить единицы слоя на метры на вкладке Общие пункта меню Установки ‣ Свойства проекта, либо выбрать систему координат (CRS) нажатием на значке mIconProjectionDisabled Преобразование координат в правом нижнем углу строки состояния. В последнем случае, единицы слоя будут установлены в соответствии с указанными в системе координат, например, «+units=m».