Outdated version of the documentation. Find the latest one here.

Настройка QGIS

QGIS гибко настраивается при помощи меню Установки. Здесь можно изменить настройки панелей инструментов, свойства проекта и настроить внешний вид QGIS.

Панели инструментов

В меню Панели‣ можно отключить неиспользуемые элементы QGIS. Меню Панели инструментов ‣ позволяет скрывать и отображать группы кнопок на панелях инструментов (см. figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

The Panels and Toolbars menu nix

Совет

Обзорная карта

Панель Обзора (или обзорная карта) предоставляет вид полного охвата слоев, добавленных в обзор. Панель обзора можно включить в меню Вид ‣ Панели. Внутри окна обзора находится прямоугольник, который показывает текущий охват карты. Это позволяет быстро определять, какая часть карты сейчас просматривается в QGIS. Обратите внимание, что подписи в окне обзора не отображаются, даже если они включены для соответствующих слоёв. Если нажать и переместить красный прямоугольник, показывающий текущий охват в обзорной карте, область карты обновится соответствующим образом.

Совет

Отладочные сообщения

В QGIS 1.8 появилась возможность просматривать отладочные сообщения. Чтобы увидеть панель отладочных сообщений активируйте флажок checkbox Отладочные сообщения в меню Вид ‣ Панели. По мере поступления сообщений они будут отображаться во вкладках Общие и Модули

Свойства проекта

В окне свойств проекта, находящегося в меню nix Файл ‣ Свойства проекта или win Установки ‣ Свойства проекта, настраиваются специальные параметры проекта, включая:

  • На вкладке Общие определяется заглавие проекта, цвет выделения и фона, единицы слоя, точность, и параметр сохранения относительных путей к слоям.

  • Вкладка Система координат позволяет выбрать систему координат для данного проекта и включить преобразование координат векторных и растровых слоёв «на лету», если используются слои с разными системами координат.

  • С помощью третьей вкладки Определяемые слои можно настроить (или отключить) то, какие слои будут реагировать на инструмент «Определить объекты» (cм. параграф «Инструменты карты» в разделе Параметры для включения «Определения нескольких слоев»).

  • Вкладка Сервер OWS позволяет задать характеристики сервера QGIS, ограничения охвата и поддерживаемые системы координат. Активация флага checkbox Включить WKT-геометрию в ответы на GetFeatureInfo позволит запрашивать слой через WMS.

Параметры

mActionOptions Некоторые основные параметры QGIS могут быть определены в диалоговом окне Параметры. Выберите пункт меню Установки ‣ mActionOptions Параметры. Параметры можно изменить на следующих вкладках:

Общие

  • checkbox Запрашивать сохранение изменений в проекте, когда это необходимо

  • checkbox Предупреждать при попытке открытия файлов проекта старых версий QGIS

  • Изменить цвет выделения и фона

  • Изменить тему интерфейса

  • Изменить тему значков (можно выбрать следующие варианты: «default», «classic» или «gis»)

  • Изменить размер значков (возможные варианты: 16, 24 и 32 пикселя)

  • Изменить размер шрифта в меню

  • Определить реакцию на двойной щелчок по слою в легенде (открывать свойства слоя или открывать таблицу атрибутов)

  • checkbox Выводить имя слоя с заглавной буквы

  • checkbox Показывать в легенде атрибуты классификации

  • checkbox Создавать миниатюры в легенде для растровых слоёв

  • checkbox Не показывать заставку при запуске

  • checkbox Показывать совет дня при запуске

  • checkbox Открывать результаты определения во встраиваемом окне (требуется перезапуск)

  • checkbox Открывать параметры прилипания во встраиваемом окне (требуется перезапуск)

  • checkbox Открывать таблицу атрибутов во встраиваемом окне (требуется перезапуск)

  • checkbox Добавлять слои PostGIS двойным щелчком и включить расширенную выборку

  • checkbox Добавлять новые слои в выбранную или текущую группу

  • checkbox Копировать геометрию в формате WKT из таблицы атрибутов

  • Вид таблицы атрибутов selectstring (можно выбрать следующие варианты: «Показывать все объекты» (по умолчанию); «Показывать выделенные объекты»; «Показывать объекты, видимые в области карты»)

  • Размер кеша таблицы атрибутов (строк)

  • Задать Представление значений NULL

  • Запрашивать загрузку дочерних слоёв растра selectstring. Некоторые форматы растровых данных поддерживают дочерние слои — в GDAL их называют subdatasets. Например, файлы NetCDF — если в таком файле описано несколько переменных, GDAL распознаёт их как дочерние слои. Эта настройка определяет обработку таких файлов QGIS. Доступны следующие варианты:

    • «Всегда» всегда спрашивать (если найдены дочерние слои)

    • «Если необходимо» спрашивать, если слой не имеет каналов, но имеет дочерние слои

    • «Никогда» никогда не спрашивать, ничего не загружается

    • «Загружать все» никогда не спрашивать, сразу загружать все дочерние слои

  • Искать источники данных в панели обозревателя selectstring. Вариант «По расширению» позволяет ускорить загрузку дерева каталогов, которая может требовать некоторого времени при использовании варианта «По содержимому» и большом количестве файлов в каталоге (десятки и сотни).

  • Сканировать содержимое архивов (.zip) в панели обозревателя selectstring. Этот параметр также введен для ускорения загрузки дерева каталогов. Доступны следующие варианты:

    • «Быстрое сканирование» проверяет поддерживается ли расширение одним из драйверов

    • «Полное сканирование» открывает каждый файл и проверяет его валидность

    • «Пропускать» не используйте этот параметр, в следующих версиях QGIS он будет удален

GDAL

Библиотека GDAL предназначена для работы с растровыми данными. На этой вкладке можно указать какой именно драйвер GDAL необходимо использовать для открытия файлов, если данный формат поддерживается более чем одним драйвером.

Модули

  • При необходиомсти укажите Пути поиска дополнительных модулей.

Отрисовка

  • checkbox Добавляемые на карту слои видимы по умолчанию

  • Количество объектов для отрисовки между обновлениями экрана

  • checkbox Использовать кэш для ускорения перерисовки там, где это возможно

  • checkbox Рисовать сглаженные линии (снижает скорость отрисовки)

  • checkbox Исправлять ошибки заливки полигонов

  • checkbox Использовать новую реализацию отрисовки условных знаков

  • настройки визуализации растров: «Каналы отображения в RGB», checkbox Использовать стандартное отклонение и «Улучшение контраста»

  • Добавить/удалить Пути поиска значков в формате SVG (Scalable Vector Graphics)

Дополнительно, на вкладке Общие меню Установки ‣ Свойства проекта можно задать, какие пути сохранения использовать для текстур SVG, — абсолютные или относительные.

Инструменты

  • Настройка Режим определения selectstring используется для указания того, какие слои будут показываться при использовании инструмента «Определить объекты».При выборе «Сверху вниз» или «Сверху вниз, до первого найденного» вместо «Текущий слой», при использовании инструмента «Определить объекты» будут показаны атрибуты всех определяемых слоев (см. раздел Проекты, параграф «Свойства проекта» для настройки определяемых слоев).

  • checkbox Открывать форму, если найден один объект

  • установить Радиус поиска для определения объектов и всплывающих описаний (задается в процентах от ширины видимой карты)

  • Указать Эллипсоид для вычисления расстояний

  • Установить Цвет линии для инструментов измерений

  • Установить число Десятичных знаков

  • checkbox Сохранять базовые единицы

  • radiobuttonon Установить единицы измерения по умолчанию (метры или футы)

  • radiobuttonon Установить единицы измерения углов (градусы, радианы или грады)

  • Задать Действие при прокрутке колеса мыши selectstring («Увеличить», «Увеличить и центрировать», «Увеличить в положении курсора», «Ничего»)

  • Установить Фактор увеличения для колеса мыши

Совмещение

  • Установить Алгоритм размещения selectstring для подписей, символов и диаграмм (выберите один из вариантов: «Central point» (по умолчанию), «Chain», «Popmusic tabu chain», «Popmusic tabu» или «Popmusic chain»)

Оцифровка

  • Установить Толщину линии и Цвет линии для «резиновой нити»

  • Установить Режим прилипания по умолчанию selectstring («К вершинам», «К сегментам», «К вершинам и сегментам»)

  • Установить Порог прилипания по умолчанию (в единицах карты или пикселях)

  • Установить Радиус поиска для редактирования вершин (в единицах карты или пикселях)

  • checkbox Показывать маркеры только для выбранных объектов

  • Установить Стиль маркера selectstring («Перекрестие» (по умолчанию), «Полупрозрачный круг» или «Без маркера») и Размер маркера.

  • checkbox Отключить всплывающее окно ввода атрибутов для каждого создаваемого объекта

  • checkbox Использовать последние введённые значения

  • Настроить Проверку геометрии. Редактирование сложных линий/полигонов с большим количеством узлов может замедлить отрисовку. Это происходит из-за того, что процедура проверки геометрии, используемая в QGIS по умолчанию довольно медленная. Ускорить отрисовку можно либо используя для проверки геометрии библиотеку GEOS (начиная с GEOS 3.3) или отключив её вообще. Проверка геометрии при помощи GEOS намного быстрее, но у нее есть недостаток — обнаруживается только первая проблема с геометрией.

Следующие три параметра относятся к инструменту mActionOffsetCurve Параллельная кривая, описанному в разделе Дополнительные функции оцифровки. При помощи этих настроек можно управлять видом параллельной кривой. Все эти настройки будут учитываться только при использовании GEOS 3.3 или более поздней версии.

  • Стиль соединения параллельной линии

  • Количество сегментов на квадрант параллельной кривой

  • Предел острия параллельной кривой

Система координат

Вкладка Система координат разделена на две группы элементов управления. Первая группа позволяет задать систему координат по умолчанию для новых проектов.

  • Создавать новые проекты в указанной системе координат

  • checkbox Включить преобразование координат «на лету»

Вторая группа позволяет определить поведение QGIS при создании нового слоя или при загрузке слоя с неопределенной системой координат.

  • radiobuttonoff Запрашивать систему координат

  • radiobuttonoff Использовать систему координат проекта

  • radiobuttonon Использовать нижеприведённую систему координат по умолчанию

Язык

  • checkbox Переопределить системный язык и Язык, используемый вместо системного

  • Дополнительная информация о системном языке

Сеть

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

  • checkbox Использовать прокси-сервер для внешних соединений и настроить поля «Узел», «Порт», «Пользователь», и «Пароль».

  • Установить Тип прокси selectstring в соответствии с конфигурацией сети.

    • Default Proxy: прокси определяется настройками приложения

    • Socks5Proxy: Общий прокси для любого вида связи. Поддерживаются TCP, UDP, привязка к порту (входящие соединения) и авторизация

    • HttpProxy: реализован с использованием команды «СONNECT», поддерживает только исходящие TCP соединения; поддерживает авторизацию

    • HttpCachingProxy: использует стандартные команды HTTP, имеет смысл использовать только с запросами HTTP

    • FtpCachingProxy: реализован посредством FTP прокси, имеет смысл использовать только с запросами FTP

  • Задать Параметры кеширования (путь к кэшу и его размер)

  • Задать Адрес поиска WMS-серверов,по умолчанию используется http://geopole.org/wms/search?search=\%1\&type=rss

  • Установить Таймаут для сетевых запросов (мс). Значение по умолчанию — 60000

Если вы не хотите использовать прокси-сервер для некоторых адресов, можно добавить их в текстовое поле ниже (см. Figure_Network_Tab), нажав кнопку [Добавить]. После двойного нажатия на только что созданной строке ввода URL (Uniform Resource Locator), введите адрес, для которого не хотите использовать прокси-сервер. Нажатие на кнопке [Удалить] удаляет выбранную строку адреса.

Для получения более детальной информации о различных настройках прокси-сервера, обратитесь к Руководству Qt-library-documentation по адресу http://qt-project.org/doc/qt-4.8/qnetworkproxy.html#ProxyType-enum.

Совет

Использование прокси-серверов

Использование прокси-серверов иногда может быть довольно сложным. Для проверки вышеописанных типов прокси, действуйте методом «проб и ошибок», проверяя в каждом случае успешность соединений.

Можно настроить параметры в соответствии с вашими потребностями. Внесение некоторых изменений может потребовать перезапуска QGIS для их применения.

  • nix параметры сохраняются в текстовом файле: $HOME/.config/QuantumGIS/qgis.conf

  • osx ваши настройки можно найти в файле: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win параметры хранятся в ветке системного реестра:

\HKEY\CURRENT_USER\Software\QuantumGIS\qgis

Настройка интерфейса

В QGIS 1.8 появился инструмент настройки графического интерфейса. Он позволяет (де)активировать практически любой элемент графического интерфейса QGIS. Такая возможность может быть полезной, если у вас установлено множество модулей, которые не используются, но занимают место на панелях.

Figure Customization 1:

../../../_images/customization.png

The Customization dialog nix

Все настройки интерфеса разбиты на пять групп. В разделе checkbox Docks собраны все плавающие окна. Плавающие окна это различные диалоги, которые после запуска могут быть размещены в любом месте экрана или встроенны в основное окно QGIS (см. также Панели инструментов). В разделе checkbox Menus настраивается видимость элементов главного меню. Группа checkbox StatusBar позволяет деактивировать элементы строки состояния, например, поле с системой координат. В разделе checkbox Toolbars можно (де)активировать различные кнопки на панелях инструментов и, наконец, в группе checkbox Элементы управления можно отключить или включить как целые диалоги, так и отдельные их элементы.

При помощи инструмента mActionSelect Выбрать элементы управления в приложении можно выбирать элементы интерфейса QGIS, которые необходимо скрыть, и быстро находить их в списке элементов (см. figure_customization). Различные варианты настройки можно сохранить для дальнейшего использования. Чтобы сделанные изменения вступили в силу, необходимо перезапустить QGIS.