Outdated version of the documentation. Find the latest one here.

Редактирование

QGIS предоставляет разнообразные возможности для редактирования векторных данных OGR, PostGIS и Spatialite.

Примечание

Процедура редактирования данных GRASS имеет свои отличия — подробнее см. раздел Оцифровка и правка векторных слоёв GRASS.

Совет

Параллельное редактирование

Данная версия QGIS не различает между собой нескольких пользователей, одновременно редактирующих одни и те же данные. Сохраняются изменения того пользователя, который сохранил их последним.

Настройка порога прилипания и радиуса поиска

Перед началом редактирования узлов необходимо установить величину порога прилипания и радиуса поиска, что позволит оптимизировать редактирование геометрии векторных слоёв.

Порог прилипания

Порог прилипания — это расстояние, используемое QGIS для поиска ближайшего узла и/или сегмента, к которому надо присоединиться при создании нового узла или передвижении уже существующего. Если превысить порог прилипания, то при нажатии кнопки мыши узел будет создан «в стороне», вместо того, чтобы быть привязанным к уже существующему узлу и/или сегменту. Величина порога прилипания оказывает влияние на функционирование всех инструментов программы, связанных с величинами допуска.

  1. Общая для всего проекта величина порога прилипания устанавливается в Установки ‣ mActionOptions Параметры (для Mac: QGIS ‣ mActionOptions Настройки, для Linux: Редактирование ‣ mActionOptions Параметры). На вкладке Оцифровка можно установить режим прилипания по умолчанию: к вершинам, к сегментам, или к вершинам и сегментам. Также можно определить значения по умолчанию для единиц измерения порога прилипания и радиуса поиска. Эти величины могут быть установлены как в единицах карты, так и в пикселах. Преимущество использования пикселов в качестве единиц заключается в том, что при зуммировании порог прилипания не будет изменяться. В нашем небольшом проекте оцифровки (по рабочему набору данных Alaska) мы установили в качестве единицы порога прилипания фут. Ваши результаты могут отличаться, но величины, близкие к 300 футов, дают приемлемые результаты при работе в масштабе 1:10000.

  2. Величина порога прилипания для отдельного слоя устанавливается в Установки ‣ (или Файл) Параметры прилипания... для включения и настройки режима и порога прилипания для каждого слоя (см. figure_edit_1).

Обратите внимание, что величина порога прилипания для отдельного слоя имеет преимущество над общим порогом прилипания, установленным на вкладке Оцифровка. Таким образом, если надо отредактировать один слой и прилепить его вершины к другому слою, необходимо активировать прилипание «прилипание к» для слоя, затем снизить общий порог прилипания для проекта до меньшего значения. Кроме того, прилипание невозможно для слоя, не активизированного в диалоговом окне параметров прилипания, независимо от параметров общего прилипания. Поэтому необходимо убедиться, что у слоя, к которому необходимо применить прилипание, стоит флажок.

Figure Edit 1:

../../../_images/editProjectSnapping.png

Edit snapping options on a layer basis nix

Радиус поиска

Радиус поиска — это расстояние, используемое QGIS для поиска ближайшей вершины, которую вы пытаетесь переместить, щелкая кнопкой мыши по карте. За пределом радиуса поиска QGIS не сможет найти и выделить какую-либо вершину для последующего редактирования, о чем сообщит всплывающее окно предупреждения. Порог прилипания и радиус поиска устанавливаются в единицах карты или пикселях, так что для того, чтобы установить приемлемые значения, лучше всего с ними поэкспериментировать. Если установлен слишком большой порог, QGIS может прилепиться к неверной вершине, особенно, если работа идет с большим количеством близко расположенных вершин. Однако слишком маленький порог не позволит обнаружить какой-либо объект.

Радиус поиска для редактирования вершин в единицах слоя устанавливается на вкладке Оцифровка, расположенной в меню Установки ‣ mActionOptions Параметры. Там же устанавливается общий для всего проекта порог прилипания.

Масштабирование и прокрутка карты

Перед редактированием слоя следует увеличить район исследований на карте. Это спасёт от ожидания прорисовки всех вершин слоя.

Помимо использования кнопок mActionPan Прокрутка карты и mActionZoomIn Увеличить / mActionZoomOut Уменьшить на панели инструментов, навигация также может осуществляться с помощью «колеса» мыши, клавиши «Пробел» и стрелок.

Зуммирование и прокрутка карты с помощью «колеса» мыши

Нажатие и удержание «колеса» мыши во время редактирования позволяет перемещать карту в пределах основного окна, а его прокручивание приводит к масштабированию карты. Для увеличения необходимо расположить курсор мыши внутри площади карты и крутить «колесо» вперед (от себя), для уменьшения — назад (к себе). Положение курсора мыши является центром области зуммирования. Можно настроить режим зуммирования «колесом» мыши, используя вкладку Инструменты в меню Установки ‣ mActionOptions Параметры.

Прокрутка карты с помощью стрелок

Прокрутка карты во время редактирования возможна с помощью стрелок. Расположите курсор мыши внутри площади карты и нажмите на правую стрелку для перемещения на восток, на левую стрелку для перемещения на запад, стрелку вверх для перемещения на север и стрелку вниз для перемещения на юг.

Также возможно использовать клавишу «Пробел» для временного замещения мыши при прокрутке карты. Нажатие стрелок клавиатуры «Вверх» и «Вниз» приведет к увеличению и уменьшению карты, не прерывая процесса оцифровки.

Топологическое редактирование

Кроме установки параметров прилипания для отдельного слоя, в диалоге Параметры прилипания можно активировать некоторые функции контроля топологии. Так, здесь можно можно активировать checkbox Включить топологическое редактирование и/или активировать checkbox Предотвращать пересечение новых полигонов.

Включение топологического редактирования

Опция checkbox Включить топологическое редактирование предназначена для редактирования и управления общими границами в мозаике полигонов. QGIS «определяет» общие границы в мозаике полигонов. При изменении положения вершины одного полигона QGIS позаботится о том, чтобы положение вершины соседнего полигона изменилось соответственно.

Предотвращение пересечения новых полигонов

Следующая топологическая опция называется checkbox Предотвращать пересечение новых полигонов и позволяет избежать пересечений в мозаике полигонов, что ускоряет редактирование смежных полигонов. Если один полигон уже существует, с помощью этой функции можно оцифровать новый с пересечением первого, и QGIS обрежет второй полигон по общей границе. Основное преимущество заключается в том, что пользователи не должны цифровать все вершины по границе смежных полигонов.

Редактирование существующего слоя

По умолчанию, QGIS подгружает слои, делая их доступными только для чтения: это защита от непреднамеренного редактирования слоя, что случается, например, при неловком движении «мышкой». Однако, можно установить редактирование любого слоя при условии, если на это имеется соответствующее разрешение, и основной источник данных имеет возможность записи (т.е. эти файлы доступны не только для чтения). Редактирование слоев наиболее универсально, если используются источники данных, основанных на PostgreSQL/PostGIS.

Все возможности редактирования векторных слоев разделены между панелями инструментов оцифровки и дополнительным функциям оцифровки, описанных в разделе Дополнительные функции оцифровки. Их можно активировать и деактивировать в меню Вид ‣ Панели инструментов ‣. Используя основные инструменты для оцифровки, можно выполнять следующие функции:

Иконка

Назначение

Иконка

Назначение

mActionToggleEditing

Режим редактирования

mActionCapturePoint

Добавить объект: создать точку

mActionCaptureLine

Добавить объект: создать линию

mActionCapturePolygon

Добавить объект: создать полигон

mActionMoveFeature

Переместить объект

mActionNodeTool

Редактирование узлов

mActionDeleteSelected

Удалить выделенное

mActionEditCut

Вырезать объекты

mActionEditCopy

Копировать объекты

mActionEditPaste

Вставить объекты

mActionFileSave

Сохранить изменения

   

Основные инструменты редактирования векторного слоя

Любое редактирование начинается с выбора функции mActionToggleEditing Режим редактирования. Эта опция доступна из контекстного меню после щелчка правой кнопки мыши по легенде слоя.

Также, чтобы начать или закончить редактирование, можно использовать кнопку mActionToggleEditing Режим редактирования на панели инструментов по оцифровке. После того, как слой стал редактируемым, над каждой вершиной появятся специальные маркеры и станут доступными кнопки с дополнительными функциями из панели инструментов.

Совет

Регулярное сохранение

Не забывайте нажимать mActionFileSave Сохранить изменения регулярно. Это позволит не только сохранить последние изменения, но и удостовериться, что источники данных могут принять все сделанные изменения.

Добавление объектов

Можно использовать кнопки на панели инструментов: mActionCapturePoint Создать точку, mActionCaptureLine Создать линию или mActionCapturePolygon Создать полигон, чтобы переключить QGIS в режим редактирования.

Для каждого объекта сначала идет оцифровка формы, а затем добавляются атрибуты. Чтобы начать оцифровку и создать первую точку нового объекта, надо нажать левой кнопкой мыши в области карты.

Для продолжения линий и полигонов надо продолжать нажимать на левую кнопку мыши для создания каждого дополнительного узла. Чтобы закончить редактирование объекта, просто щелкните правой кнопки мыши в любом месте карты. Это подтверждение того, что редактирование данного объекта окончено.

В процессе редактирования будет появляться окно атрибутов, позволяя тем самым вводить информацию для нового объекта. Figure_edit_2 показывает ввод атрибутов для вымышленной реки Аляски. В вкладке Оцифровка из меню Установки ‣ Параметры можно также активировать функцию checkbox Не показывать всплывающее окно ввода атрибутов для каждого создаваемого объекта checkbox Использовать последние введённые значения.

Figure Edit 2:

../../../_images/editDigitizing.png

Enter Attribute Values Dialog after digitizing a new vector feature nix

С помощью опции mActionMoveFeature Переместить объект на панели инструментов можно двигать созданные объекты.

Совет

Типы значений атрибутов

При редактировании shape-файла типы атрибутов проверяются во время ввода. Поэтому невозможно ввести числовое значение в текстовое поле диалога Атрибуты или наоборот. Если это сделать все же необходимо, то следует отредактировать атрибуты на следующем шаге в диалоге Таблица атрибутов.

Редактирование узлов

Как для слоев данных PostgreSQL/PostGIS, так и для слоев, состоящих из shape-файлов, mActionNodeTool Редактирование узлов предоставляет возможности изменения узлов объектов, аналогичные имеющимся в программах CAD. Можно выделить сразу множество вершин и перемещать, добавлять или удалять их все вместе. Инструмент редактирования узлов работает с включенной функцией перепроецирования «на лету», а также поддерживает топологическое редактирование объектов. Этот инструмент, в отличие от остальных инструментов Quantum GIS, довольно «настойчивый»: так, когда некоторая операция выполнена, инструмент продолжает оставаться активным, а объект выделенным. Если инструмент редактирования узлов не может обнаружить объекты, на дисплей выдается предупреждение.

Важно правильно установить Установки ‣ mActionOptions Параметры ‣ Оцифровка ‣ Радиус поиска selectnumber, значение должно быть больше нуля. В противном случае QGIS не распознает редактируемую вершину.

Совет

Маркировка вершин

Данная версия QGIS поддерживает три типа маркировки вершин — полупрозрачный круг, крест и «без маркера». Чтобы изменить стиль маркировки, выберите mActionOptions Параметры из меню Установки и на вкладке Оцифровка выберите подходящий тип.

Основные операции

Включите инструмент mActionNodeTool Редактирование узлов и выделите объект простым нажатием на него. На месте каждой вершины этого объекта появятся красные рамки.

  • Выделение вершин: Выделение узла происходит простым нажатием по нему кнопкой мыши, при этом цвет рамки изменится на синий. Чтобы выделить несколько узлов одновременно, надо удерживать клавишу Shift. Нажатие на Ctrl используется для инвертирования выделения узлов (выделенные узлы становятся невыделенными и наоборот). Также несколько узлов одновременно можно выделить, если нажать кнопкой мыши где-нибудь в стороне от объекта и очертить прямоугольную область вокруг интересующего множества вершин. Или просто нажать на отрезок линии и оба смежных узла будут выделены.

  • Добавление узлов: Добавить узлы также просто. Двойной щелчок мыши рядом с отрезком линии добавит новую вершину рядом с положением курсора. Обратите внимание, что вершина появится на ребре объекта, а не точно в месте курсора,но при необходимости ее можно переместить.

  • Удаление узлов: После выделения вершин для их удаления надо нажать клавишу Delete, вершины будут удалены. Обратите внимание, что, согласно стандарту Quantum GIS, необходимое количество узлов для каждого типа объекта все же останется. Чтобы полностью удалить объект, надо использовать другой инструмент, а именно mActionDeleteSelected Удалить выделенное.

  • Перемещение узлов: Выделите все вершины, которые собираетесь перемещать. Все выделенные вершины будут перенесены в направлении курсора. Если активна функция прилипания, все вершины могут перескочить на ближайшие узлы или линии.

При отпускании кнопки мыши все изменения будут сохранены и появятся в диалоге отмены. Запомните, что все операции поддерживают топологическое редактирование, когда оно включено. Перепроецирование «на лету» также поддерживается. Кроме того, инструмент показывает всплывающие подсказки при наведении указателя мыши на узел.

Вырезать, копировать и вставить объекты

Выделенные объекты можно удалять, копировать и вставлять из слоя в слой одного проекта QGIS при условии, что для них включен mActionToggleEditing Режим редактирования.

Объекты также можно вставить во внешние приложения в виде текста: объекты отражаются в формате CSV, где их геометрия передается форматом OGC Well-Known Text (WKT).

Однако в настоящей версии QGIS текстовые объекты из внешних приложений не могут быть добавлены в слой QGIS. Когда же может пригодиться функция копирования и вставки? Оказывается, возможно редактирование нескольких слоев одновременно и копирование/вставка объектов между ними. Для чего это может понадобиться? Предположим, необходимо поработать со слоем озер, в котором интересует только одно или два озера, а не все 5000, как, например, в нашем слое big_lakes. Тогда можно создать новый слой и, используя операции копирование/вставка, переместить в него нужные озера.

Рассмотрим пример копирования отдельных озер в новый слой:

  1. Загрузите слой, из которого вы собираетесь копировать (исходный слой)

  2. Загрузите или создайте слой, в который вы будете копировать (целевой слой)

  3. Начаните редактирование целевого слоя

  4. Активируйте исходный слой щелчком мыши по нему в легенде

  5. Используя инструмент mActionSelect Выбрать объекты, выделите объект(ы) в исходном слое

  6. Нажмите кнопку mActionEditCopy Копировать объекты

  7. Сделайте активным целевой слой, щелкнув по нему в легенде кнопкой мыши

  8. Нажмите mActionEditPaste Вставить объекты

  9. Завершите редактирование и сохраните изменения

Что случится, если исходный и целевой слой имеют разную структуру (названия полей и их типы отличаются)? QGIS заполнит совпадающие поля и проигнорирует остальные. Если результат копирования атрибутов в целевой слой не имеет значения, то становится неважно, в каком виде они там будут представлены. Если в целевом слое необходимо сохранить все с точностью — объекты и их атрибуты, необходимо убедиться, что структуры исходного и целевого слоя совпадают.

Совет

Соответствие вставляемых объектов

Если исходный и целевой слой находятся в одинаковой проекции, тогда геометрия вставленных объектов будет идентична исходному слою. Однако если целевой слой находится в проекции, отличной от исходной, тогда QGIS не гарантирует идентичность геометрии. Это происходит по причине незначительных ошибок округления, неизбежных при переходе от одной проекции к другой.

Удаление выделенных объектов

Если надо удалить весь полигон, вначале его необходимо выделить, используя обычный инструмент mActionSelect Выбрать объекты. Также можно выделить несколько объектов для удаления. После выбора соответствующих объектов используйте инструмент mActionDeleteSelected Удалить выделенное, объекты будут удалены.

Инструмент mActionEditCut Вырезать объекты на панели инструментов по оцифровке также может использоваться для удаления объектов. Это действительно удаляет объекты, но также помещает их в «пространственный буфер». Таким образом, вырезание объектов приводит к их удалению. Затем можно использовать инструмент mActionEditPaste Вставить объекты, чтобы вернуть их обратно. Это дает возможность отменить выполненное удаление объекта. Операции вырезания, копирования и вставки работают только на выделенных объектах, это означает, что можно работать с несколькими объектами одновременно.

Совет

Поддержка удаления объектов

Когда редактируется shape-файл, удаление объектов из него возможно, если QGIS использует версию GDAL 1.3.2 или выше. Версии QGIS для операционных систем OS X и Windows, доступные для скачивания на официальном сайте, сделаны с использованием версии GDAL 1.3.2 или выше.

Сохранение отредактированных слоев

Когда слой находится в режиме редактирования, любые изменения сохраняются только в памяти QGIS. Поэтому они не сохраняются непосредственно на диск. Если необходимо сохранить изменения в текущем слое и при этом продолжать его редактирование, нужно просто нажать на кнопку mActionFileSave Сохранить изменения. Если выключить режим редактирования нажав на mActionToggleEditing Режим редактирования (или просто выйти из QGIS), то появится запрос, хотите вы сохранить изменения или нет.

Если изменения не могут быть сохранены (например, диск полон или атрибуты имеют неверное значение), QGIS сохранит их в своей памяти. Это позволит откорректировать изменения и попробовать еще раз.

Совет

Целостность данных

Создание резервной копии данных перед началом редактирования — это всегда хорошая идея. Несмотря на то, что авторы QGIS сделали все возможное для сохранения ваших данных, они по-прежнему не дают никаких гарантий в этом отношении.

Дополнительные функции оцифровки

Иконка

Назначение

Иконка

Назначение

mActionUndo

Отменить

mActionRedo

Вернуть

mActionSimplify

Упростить объект

mActionAddRing

Добавить кольцо

mActionAddIsland

Добавить часть

mActionDeleteRing

Удалить кольцо

mActionDeletePart

Удалить часть

mActionReshape

Корректировать объекты

mActionOffsetCurve

Параллельная кривая

mActionSplitFeatures

Разбить объекты

mActionMergeFeatures

ОБъединить выбранные объекты

mActionRotatePointSymbols

Повернуть значки

mActionMergeFeatures

Объединить атрибуты выбранных объектов

   

Дополнительные возможности редактирования векторного слоя

Отменить и Вернуть

Инструменты mActionUndo Отменить и mActionRedo Вернуть позволяют отменить либо вернуть последний или какой-либо конкретный шаг при редактировании векторных данных. Основной вид операций Отменить/Вернуть представляет из себя виджет, где показаны все действия (см. Figure_edit_3). Этот виджет по умолчанию не показывается, чтобы он появился, надо нажать правой кнопкой мыши на панели инструментов и кликнуть по флажку Отменить/Вернуть. Однако функция Отменить/Вернуть активна, даже если виджет не выведен на экран.

Figure Edit 3:

../../../_images/redo_undo.png

Redo and Undo digitizing steps nix

При нажатии кнопки «Отменить» состояние всех объектов и их атрибутов возвращается на шаг назад. Изменения, произведенные в каком-либо другом месте (например, в одном из модулей), могут иметь неспецифические названия для своих операций, которые появляются в этой закладке. Операции можно отменить или оставить их изменения.

Для отмены или повтора действия достаточно выбрать необходимый пункт из списка операций, после чего все объекты будут возвращены в состояние, предшествующее указанной операции.

Упростить объект

Инструмент mActionSimplify Упростить объект позволяет уменьшить количество вершин объекта, при этом, геометрия объекта не изменяется. Необходимо выделить объект, после чего он будет подсвечен красным и появится ползунок. При движении ползунка красная опоясывающая линия меняет свою форму, показывая тем самым, как именно объект будет упрощен. Если нажать кнопку [OK], новая упрощенная геометрия будет сохранена. Если объект не может быть упрощен (например, мультиполигоны), появится всплывающее окно предупреждения.

Добавить кольцо

Можно создать кольцевой полигон, используя функцию mActionAddRing Добавить кольцо на панели инструментов. Внутри существующего полигона можно оцифровать последующий полигон, который превратиться в «отверстие», таким образом, только оставшаяся область между границами внешнего и внутреннего полигона и будет кольцевым полигоном.

Добавить часть

Можно использовать mActionAddIsland Добавить часть для добавления новых полигонов к мультиполигональным объектам. Новая полигональная часть должна быть создана за границами мультиполигона.

Удалить кольцо

Инструмент mActionDeleteRing Удалить кольцо позволяет удалять кольцевые полигоны внутри существующей площади. Этот инструмент работает только с полигональными слоями. Никакик изменений не произойдет, если инструмент применяется на внешнем контуре полигона. Инструмент может применяться как для полигональных объектов, так и на мультиполигональных. Перед тем, как выделить вершины кольца, настройте порог прилипания для вершин.

Удалить часть

Инструмент mActionDeletePart Удалить часть позволяет удалять части мультиполигональных объектов (например, удалить полигон мультиполигонального объекта). Инструмент не сможет удалить последнюю часть объекта. Она останется нетронутой. Инструмент работает со всеми типами геометрии: точками, линиями, полигонами. Перед тем, как выделить вершины части, необходимо настроить порог прилипания для вершин.

Корректировать объекты

Можно корректировать форму линий и полигонов, используя инструмент mActionReshape Корректировать объекты, расположенный на панели инструментов. Он удаляет часть линии или полигона между первым и последним пересечением с исходной линией. При работе с полигонами это может иногда привести к непредсказуемым результатам. Этот инструмент наиболее пригоден для корректировки небольших частей полигонов. Редактирование нескольких полигональных объектов одновременно невозможно, так как при этом будут создаваться полигоны с ошибочной геометрией.

Рассмотрим редактирование границы полигона при помощи этого инструмента. Сначала необходимо поставить точку внутри полигона, рядом с местом, где необходимо добавить новую вершину. Затем провести линию через контур и добавить новые вершины. Для завершения операции поместите указатель внутри контура и нажмите правую клавишу мыши. Инструмент автоматически добавит новые вершины в местах пересечения контура. Аналогичным образом можно «вырезать» часть полигона. В этом случаем начинать и заканчивать построение необходимо вне контура.

Примечание

Инструмент корректировки объектов может изменять начало кольца полигона или замкнутой линии. Так, точка, представленная «дважды», больше не будет таковой. Это не должно быть проблемой при использовании большинства приложений, но, тем не менее, это необходимо иметь в виду.

Параллельная кривая

Инструмент mActionOffsetCurve Параллельная кривая является новым инструментом редактирования. Он предназначен для параллельного переноса линий и колец полигона. Инструмент может применяться к редактируемому слою (в этом случае изменяются объекты) или же к фоновым слоям (в этом случае создаются копии линий/колец и добавляются в редактируемый слой). Таким образом, он идеально подходит для создания линейных слоёв с фиксированным шагом. Размер смещения отображается в нижней левой части строки состояния.

Разбить объекты

Можно разбить объекты, используя инструмент mActionSplitFeatures Разбить объекты на панели инструментов. Чтобы разбить объект, просто нарисуйте линию через него.

Объединить выбранные объекты

Инструмент mActionMergeFeatures Объединить выбранные объекты позволяет объединять объекты, которые имеют общие границы и атрибуты.

Объединить атрибуты выбранных объектов

Инструмент mActionMergeFeatures Объединить атрибуты выбранных объектов позволяет объединять атрибуты нескольких объектов без их объединения в один объект.

Повернуть значки

Инструмент mActionRotatePointSymbols Повернуть значки в настоящее время поддерживает только «старую» символику. Он позволяет изменить поворот точечного символа на карте, если задано вращение по столбцу атрибутивной таблицы точечного слоя на вкладке Стиль из меню свойств слоя — Свойства слоя. В другом случае инструмент будет неактивным.

Figure Edit 4:

../../../_images/rotatepointsymbol.png

Rotate Point Symbols nix

Чтобы повернуть объект, выделите точечный объект на карте и вращайте его, удерживая нажатой левую кнопку мыши. При этом будет отображаться красная стрелка с величиной угла поворота (см. Figure_edit_4). Когда вы отпустите левую кнопку мыши, в таблице атрибутов обновится значение.

Примечание

Если удерживать кнопку Ctrl нажатой, поворот будет осуществляться с шагом 15 градусов.

Создание нового векторного слоя

QGIS позволяет создавать новые shape-файлы и слои Spatialite. Создание новых слоев GRASS осуществляется с помощью расширения GRASS. Для более подробной информации по созданию слоев GRASS обратитесь к разделу Создание нового векторного слоя GRASS.

Создание нового shape-файла

Чтобы создать новый редактируемый shape-файл, выберите Создать ‣ mActionNewVectorLayer Создать новый shape-файл из меню Слой. Появится диалог Новый векторный слой, как показано на Figure_edit_5. Выберите тип слоя (точка, линия или полигон) и желаемую систему координат.

Обратите внимание, что QGIS пока еще не поддерживает создание объектов в размерности 2.5D (т.е. объектов с координатами X, Y, Z), кроме того, не поддерживается создание объектов с линейной системой координат (координата M).

Figure Edit 5:

../../../_images/editNewVector.png

Creating a new Shapefile layer Dialog nix

В завершении создания shape-файла следует добавить желаемые атрибуты. Для этого надо нажать на кнопку [Добавить] и задать имя и тип атрибутов. При необходимости, добавленный по умолчанию атрибут «id» можно удалить. Поддерживаются только следующие типы атрибутов: «Текст», «Целое число», и «Десятичное число». Дополнительно, в соответствии с выбранным типом атрибута, можно определить размер и точность для нового поля атрибутов. Как только все необходимые параметры заданы, нажмите кнопку [OK] и задайте имя для выходного shape-файла. QGIS автоматически добавит к имени файла расширение .shp. После того, как shape-файл создан, он будет добавлен в карту и доступен для обычного редактирования, как описано в разделе Редактирование существующего слоя выше.

Создание нового слоя SpatiaLite

Чтобы создать новый редактируемый слой SpatiaLite, выберите Создать ‣ mActionNewVectorLayer Создать слой SpatiaLite из меню Слой. Появится диалог Создать слой SpatiaLite, как показано на Figure_edit_6.

Figure Edit 6:

../../../_images/editNewSpatialite.png

Creating a New SpatiaLite layer Dialog nix

Первый шаг — выбрать существующую базу данных SpatiaLite или создать новую. Загрузить существующую базу данных можно, нажав на кнопку browsebutton справа от поля имени для базы данных. Затем следует задать имя новому слою и определить тип слоя и EPSG SRID. По желанию можно выбрать checkbox Создать первичный ключ с автоматическим приращением.

Чтобы задать таблицу атрибутов для нового слоя SpatiaLite, добавьте имена и определите соответствующие типы данных для новых столбцов таблицы, затем нажмите кнопку [Добавить]. В завершение нажмите кнопку [OK]. QGIS автоматически добавит новый слой в легенду, и он будет доступен для обычного редактирования, как описано в разделе Редактирование существующего слоя выше.

Дальнейшая работа со слоями SpatiaLite может выполняться при помощи модуля DB Manager, см. раздел db_manager.

Работа с таблицей атрибутов

Таблица атрибутов представляет объекты выделенного слоя. Каждая строка таблицы соответствует одному объекту на карте и отражает его атрибуты в столбцах. Объекты в таблице можно искать, выделять, перемещать и редактировать.

Чтобы открыть таблицу атрибутов векторного слоя, необходимо сделать его активным, нажав по нему кнопкой мыши в легенде карты. Затем в меню Слой выберите mActionOpenTable Открыть таблицу атрибутов. Также можно открыть таблицу атрибутов, щелкнув по слою в легенде правой кнопкой мыши, и выбрав mActionOpenTable Открыть таблицу атрибутов из выпадающего меню.

Откроется новое окно, в котором будут представлены атрибуты для каждого объекта слоя (cм. figure_attributes_1). Количество объектов указано в заголовке атрибутивной таблицы.

Figure Attributes 1:

../../../_images/vectorAttributeTable.png

Attribute Table for Alaska layer nix

Выделение объектов в таблице атрибутов

Выделенная строка в таблице атрибутов представляет все атрибуты выделенного объекта слоя. Таблица атрибутов отражает все изменения в выделении объектов слоя через главное окно карты или наоборот. Смена выделения в таблице атрибутов приводит к изменению выделения в главном окне карты, также выделение другого объекта слоя приводит к выделению соответствующей ему строки таблицы.

Строки можно выделить, если нажать кнопкой мыши на номер строки, расположенный слева от неё. Выделение строки не меняет текущего положения курсора. Несколько строк можно выделить, удерживая клавишу Ctrl. Также доступно Сквозное выделение, для этого необходимо удерживать клавишу Shift и выбрать несколько строк, также нажимая на их номера-заголовки, расположенные слева. Все строки между текущим положением курсора и выбранными строками будут выделены. Перемещение курсора атрибутивной таблице, путем нажатия на ячейки, не изменяет выделение. А изменение выделения на карте не приводит к изменению положения курсора атрибутивной таблицы.

Каждый столбец может быть отсортирован. Для этого надо нажать кнопкой мыши на его заголовоке. Небольшая стрелка отражает порядок сортировки (направленная вниз стрелка означает убывание величины от верхних строк к нижним, а направленная вверх стрелка означает возрастание величины от верхних строк к нижним).

Для простого поиска по атрибутам только по одному столбцу можно использовать поле Искать. Выберите поле (столбец), по которому хотите произвести поиск, из выпадающего списка, и нажмите кнопку [Поиск]. Количество сопоставленных записей появится в окне результатов. Для более сложного поиска используйте кнопку расширенного поиска browsebutton, которая откроет окно Конструктор поисковых запросов, описанный в разделе Конструктор поисковых запросов.

Чтобы отобразить только выбранные строки, нажмите кнопкой мыши в окошке checkbox Только выбранные записи. Для поиска только по выделенным записям активируйте checkbox Искать среди выбранных. Остальные кнопки, расположенные слева снизу атрибутивной таблицы, обладают следующими функциями:

  • mActionOpenTable Снять выделение или Ctrl+U

  • mActionSelectedToTop Переместить выделенные в начало или Ctrl+T

  • mActionInvertSelection Обратить выделение или Ctrl+S

  • mActionCopySelected Копировать выбранные строки в буфер обмена также с Ctrl+C

  • mActionZoomToSelected Увеличить карту до выбранных строк также с Ctrl+J

  • PanToSelected Центрировать выделение также с Ctrl+P

  • mActionToggleEditing Режим редактирования для редактирования отдельных значений таблицы атрибутов и активации функций, описанных ниже. Также можно использовать комбинацию клавиш Ctrl+E

  • mActionDeleteSelected Удалить выделенные объекты или Ctrl+D

  • mActionNewAttribute Добавить поле для слоев PostGIS и OGR с версией GDAL >= 1.6. Или используйте комбинацию клавиш Ctrl+W

  • mActionDeleteAttribute Удалить поле пока только для слоев PostGIS и OGR с версией GDAL >= 1.9, также доступно по Ctrl+L

  • mActionCalculateField Открыть калькулятор полей или Ctrl-I

Совет

Игнорирование геометрии в формате WKT

Если необходимо использовать данные во внешних программах (например, Excel) используйте кнопку mActionCopySelected Копировать выбранные строки в буфер обмена. Чтобы описание геометрии объектов не копировалось необходимо отключить настройку checkbox Копировать геометрию в формате WKT из таблицы атрибутов во вкладке Общие диалога Параметры, который вызывается из меню Установки ‣ Параметры.

Сохранение выделенных объектов в качестве нового слоя

Выделенные объекты можно сохранить в любом OGR-совместимом векторном формате и заодно преобразовать в другую систему координат. Для этого достаточно вызвать контекстное меню слоя нажав правую кнопку мыши и выбрать пункт Сохранить выделение как..., затем необходимо указать имя итогового файла, его формат и желаемую систему координат (см. раздел Легенда). Кроме того, в этом диалоге можно задать дополнительные параметры OGR.

Работа с непространственными атрибутивными таблицами

QGIS также позволяет загружать непространственные таблицы. Реализована поддержка таблиц в OGR-совместимых форматах, а также работа через поставщиков данных «текст с разделителями» и PostgreSQL. Такие таблицы могут использоваться для поиска полей или просто редактироваться. После загрузки таблицы будут отображаться в легенде. Открывать непространственные таблицы можно при помощи инструмента mActionOpenTable Открыть таблицу атрибутов, редактирование осуществляется аналогично редактированию атрибутивной таблицы слоя.

Примером использования непространственных таблиц может быть использование её колонок для ограничения диапазона доступных значений атрибута векторного слоя при оцифровке. Более подробно об этом рассказывается в разделе Поля.