Outdated version of the documentation. Find the latest one here.

Основные инструменты

Комбинации клавиш

Быстрый доступ ко многим действиям в QGIS осуществляется при помощи комбинаций клавиш клавиатуры. Комбинации, назначенные по умолчанию, перечислены в разделе Главное меню. Изменить существующие комбинации клавиш и добавить новые можно в диалоге настройки, который вызывается пунктом меню Установки ‣ Комбинации клавиш.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Define shortcut options nix (KDE)

Процесс редактирования комбинаций клавиш очень прост. Выберите действие или инструмент из списка и воспользуйтесь кнопками [Изменить], [Удалить] или [По умолчанию]. Единожды определив свою конфигурацию комбинаций клавиш, можно сохранить её в XML-файле и загрузить на другом компьютере с установленной QGIS.

Контекстная справка

Если вам необходима помощь по конкретной теме, можно воспользоваться контекстной справкой по нажатию кнопки [Справка], имеющейся в большинстве диалоговых окон, но, обратите внимание на то, что сторонние модули могут перенаправлять на справочные материалы, размещенные в сети Интернет.

Рендеринг

По умолчанию, QGIS перерисовывает все видимые слои всякий раз, когда требуется обновление области карты. События, запускающие процесс обновления карты, включают:

  • добавление слоя

  • панорамирование или масштабирование

  • изменение размеров окна QGIS

  • включение или отключение слоя/слоёв в легенде

В ряде случаев, QGIS позволяет контролировать процесс отрисовки.

Видимость в пределах масштаба

Видимость слоя в пределах масштаба позволяет определить минимальный и максимальный масштабы, при которых слой будет видимым. Для включения видимости в пределах масштаба откройте диалоговое окно Свойства, дважды щёлкнув на слое в легенде. На вкладке Общие активируйте флажок checkbox Видимость в пределах масштаба и установите значения минимального и максимального масштаба.

Значения масштабов можно задать по первому масштабированию слоя, который вы хотите использовать, отмечая значение масштаба в строке состояния QGIS.

Управление отрисовкой карты

Отрисовка карты может контролироваться одним из следующих способов:

Приостановка отрисовки

Для приостановки отрисовки карты снимите флажок checkbox Отрисовка в правом нижнем углу строки состояния. Когда флажок checkbox Отрисовка выключен, QGIS не будет перерисовывать карту в ответ на события, описанные в разделе Рендеринг. Приостановку отрисовки можно использовать в следующих случаях:

  • добавление нескольких слоев сразу и задание символики перед отрисовкой карты

  • добавление одного или нескольких больших слоев и включение видимости в пределах масштаба перед отрисовкой карты

  • добавление одного или нескольких больших слоев и масштабирование к определенному охвату перед отрисовкой карты

  • комбинации вышеперечисленного

Включение флажка checkbox Отрисовка активирует отрисовку и немедленно обновляет содержимое карты.

Добавление невидимых слоёв

QGIS позволяет всегда загружать новые слои без отрисовки на карте. Это означает, что слой будет добавлен к карте, но флажок видимости в легенде изначально не будет активен. Для настройки этого параметра выберите пункт меню Установки ‣ Параметры и нажмите на вкладке Отрисовка. Выключите флажок checkbox Добавляемые на карту слои видимы по умолчанию. Теперь любой слой, добавленный к карте, по умолчанию будет невидимым (выключенным).

Отмена отрисовки

Чтобы остановить отрисовку карты нажмите ESC. Обновление карты будет отменено и она останется частично отрисованной. Между нажатием клавиши ESC и остановкой отрисовки может пройти некоторое время.

Примечание

Данная возможность в настоящее время недоступна — из-за проблем в библиотеке Qt, приводившим к ошибкам, функция временно отключена.

Обновление окна карты во время отрисовки

Можно настроить параметр обновления карты во время прорисовки объектов. По умолчанию, QGIS не отображает никаких объектов слоя на карте до тех пор, пока не отрисуется весь слой. Для обновления окна карты в процессе загрузки данных, выберите пункт меню Установки ‣ Параметры и перейдите на вкладку Отрисовка. Установите число объектов в соответствующее значение для обновления карты во время отрисовки. Установка значения равным 0 запрещает обновление карты во время отрисовки слоя (значение по умолчанию). Установка слишком низкого значения скажется на производительности — окно карты будет постоянно обновляться во время загрузки данных. Приемлемыми значениями можно считать 500 и более объектов.

Регулирование качества отрисовки

Для регулирования качества отрисовки карты можно задать два параметра. Выберите пункт меню Установки ‣ Параметры, перейдите на вкладку Отрисовка и включите или отключите следующие флажки.

  • checkbox Рисовать сглаженные линии (снижает скорость отрисовки)

  • checkbox Исправлять ошибки заливки полигонов

Измерения

Измерения на карте работают только с прямоугольными системами координат (например, UTM). Если загруженная карта определена в географической системе координат (широта/долгота), результаты измерений длин или площадей будут неправильными. Чтобы этого избежать, необходимо указать соответствующую систему координат (см. раздел Работа с проекциями). Все измерительные инструменты также используют параметры прилипания, используемые для оцифровки. Это может пригодиться, если необходимо провести измерения вдоль линейных или площадных объектов в векторных слоях.

Выбрать необходимый инструмент измерения можно нажав на кнопку mActionMeasure на панели инструментов.

Измерение длин, площадей и углов

mActionMeasure QGIS позволяет измерить реальное и неспроецированное расстояние между точками в соответствии с заданными эллипсоидом. Для указания эллипсоида, выберите пункт меню Установки ‣ Параметры, перейдите на вкладку Инструменты и выберите нужный вам эллипсоид. На этой же вкладке можно выбрать цвет линии, единицы измерения по умолчанию (метры или футы) и единицы измерения углов (градусы, радианы или грады).Чтобы измерить расстояние, нажимайте на карте, ставя на ней точки. Длина каждого сегмента получившейся линии, а также суммарный результат, будут показаны в окне измерений. Прекратить измерение можно, щёлкнув правой кнопкой мыши.

Figure Measure 1:

../../../_images/measure_line.png

Measure Distance nix (KDE)

mActionMeasureArea Аналогично осуществляется измерение площадей, в окне измерений выводится площадь указанной области. Кроме того, инструмент измерений будет прилипать к объектам выбранного слоя, при условии, что для слоя установлен порог прилипания (см. раздел Настройка порога прилипания и радиуса поиска). Так, если необходимо провести точное измерение длины линейного объекта или площади полигонального объекта, необходимо настроить порог прилипания, а затем выбрать слой. Теперь, при использовании инструмента измерений, при каждом нажатии кнопки мыши (в пределах порога прилипания), курсор будет прилипать к объектам этого слоя.

Figure Measure 2:

../../../_images/measure_area.png

Measure Area nix (KDE)

mActionMeasureAngle Также, вы можете измерять углы, выбрав инструмент «Измерить угол». Курсор станет крестообразным. Нажмите для создания первого сегмента угла, который хотите измерить, затем перемещайте курсор для создания необходимого угла. Результат измерения будет показан во всплывающем диалоговом окне.

Figure Measure 3:

../../../_images/measure_angle.png

Measure Angle nix (KDE)

Выбор объектов

QGIS предоставляет несколько инструментов для выбора объектов на карте. Чтобы выделить один или несколько объектов нажмите на кнопку mActionSelect и воспользуйтесь одним из инструментов:

  • mActionSelect Выбрать отдельный объект

  • mActionSelectRectangle Выбрать объекты прямоугольником

  • mActionSelectPolygon Выбрать объекты полигоном

  • mActionSelectFreehand Выбрать объекты произвольной линией

  • mActionSelectRadius Выбрать объекты в радиусе

Снять выделение с объектов можно нажав на кнопку mActionDeselectAll Снять выделение во всех слоях.

Оформление

QGIS предоставляет следующие элементы оформления: знак авторского права, указатель «север-юг», масштабная линейка. Они используются для оформления карты с использованием картографических элементов.

Примечание

В предыдущих версиях QGIS аналогичный функционал предоставлялся модулем «Оформление».

Указатель «север-юг»

north_arrow Указатель «север-юг» размещает на карте простую стрелку, направленную на север. В настоящее время для указателя доступен только один стиль. Вы можете задать направление указателя или позволить QGIS определить его автоматически. Если вы выберите вариант автоматического определения направления, то QGIS предположит лучшее направление для указателя. Разместить указатель возможно в любом из четырех углов поля карты.

Figure Decorations 2:

../../../_images/north_arrow_dialog.png

The North Arrow Dialog nix

Масштабная линейка

scale_bar Масштабная линейка добавляет простую масштабную линейку на поле карты. Вы можете определить стить и местоположение линейки аналогично панели надписей.

Figure Decorations 3:

../../../_images/scale_bar_dialog.png

The Scale Bar Dialog nix

QGIS поддерживает отображение масштаба только в тех же единицах измерения, что и карта. То есть, если единица измерения на вашем слое — метр, вы не можете добавить масштабную линейку в футах. Аналогично, если вы используете десятичные градусы, то не можете создать масштабную линейку с единицей измерения метр.

Для добавления масштабной линейки:

  1. Выберите из меню Вид ‣ Оформление ‣ Масштабная линейка. Откроется диалог (см. figure_decorations_3)

  2. Выберите вариант размещения в открывающемся списке Размещение selectstring «Внизу слева»

  3. Выберите стиль из списка Стиль линейки selectstring «Штрихи вниз»

  4. Выберите цвет линейки Цвет линейки или используйте черный цвет по умолчанию

  5. Установите размер линейки и надписей Размер линейки «30 градусов»

  6. Убедитесь, что флажок checkbox Включить масштабную линейку включен

  7. ополнительно можете выбрать автоматическое изменение размера для округления показателя при изменении размера поля карты checkbox Автоматически изменять размер для округления показателя

  8. Нажмите кнопку [OK]

Совет

Настройки оформления

Когда вы сохраняете проект в формате .qgs, любые изменения произведенные с указателем «север-юг», масштабной линейкой и знаком авторского права так же будут сохранены и восстановлены при последующем открытии проекта.

Инструменты аннотации

Инструмент mActionTextAnnotation Текстовая аннотация на панели атрибутов предоставляет возможность размещения форматированного текста в выноске на карте QGIS. Выберите инструмент аннотаций и нажмите внутри окна карты.

Figure annotation 1:

../../../_images/annotation.png

Annotation text dialog nix

Двойное нажатие на сноске открывает диалоговое окно с различными параметрами. Здесь находится текстовый редактор для ввода форматированного текста и прочие настраиваемые параметры. Например, можно привязать аннотацию к карте (обозначив маркером) или располагать ее свободно относительно карты. Аннотацию можно перемещать относительно карты (перетаскиванием маркера) или перемещать саму сноску. Иконки являются частью темы «gis», и используются в других темах.

Инструмент mActionAnnotation Переместить аннотацию позволяет перемещать аннотацию в окне карты.

Диалоговая аннотация

Дополнительно, вы можете создавать свои собственные диалоговые аннотации. Инструмент mActionFormAnnotation Диалоговая аннотация полезен для отображения атрибутов векторного слоя в виде индивидуальной формы, настроенной в Qt Designer (см. figure_custom_annotation). Это похоже на конструктор форм для инструмента «Определить объекты», но отображается в виде аннотации. Для получения дополнительной информации посетите блог QGIS http://blog.qgis.org/node/143.

Figure annotation 2:

../../../_images/custom_annotation.png

Customized qt designer annotation form nix

Примечание

Нажатие Ctrl+T при активном инструменте аннотаций (переместить аннотацию, текстовая аннотация, диалоговая аннотация), инвертирует видимость существующих аннотаций.

Пространственные закладки

Пространственные закладки позволяют создавать своеобразные «закладки» географического положения и возвращаться к ним позднее.

Создание закладки

Для создания закладки:

  1. Масштабируйте или панорамируйте карту до интересующей вас территории.

  2. Выберите пункт меню Вид ‣ Новая закладка или нажмите Ctrl-B.

  3. введите описательное имя для закладки (до 255 символов)

  4. Нажмите Enter, чтобы добавить закладку, или [Удалить] для удаления существующей закладки

Помните, что можно иметь множество закладок с одинаковыми названиями.

Работа с закладками

Для использования закладок и управления ими выберите пункт меню Вид ‣ Показать закладки. Диалоговое окно Пространственные закладки позволяет просматривать или удалять закладки. Но нельзя редактировать название закладки или координаты.

Просмотр закладки

В диалоговом окне Пространственные закладки, выберите необходимую закладку, нажав на неё, затем нажмите кнопку [Увеличить до]. Также можно просмотреть закладку, дважды нажав на неё.

Удаление закладки

Для удаления закладки из диалогового окна Пространственные закладки выберите её и нажмите кнопку [Удалить]. Подтвердите ваш выбор нажатием на кнопке [ОК] или отмените удаление нажатием кнопки [Отменить].

Встраиваемые проекты

Если вам необходимо к существующему проекту добавить содержимое другого проекта, выберите в меню Слой ‣ Встроить слои и группы.

Встраивание слоёв

Следующий диалог позволяет встраивать слои из другого проекта:

  1. Нажмите кнопку browsebutton, чтобы указать другой проект из набора данных «Аляска».

  2. Выберите проект grassland. Содержимое проекта будет отображено в диалоге (см. figure_embed_dialog).

  3. Зажмите клавишу Ctrl и выделите слои grassland и regions. Эти слои будут встроенны в текущий проект.

Figure Nesting 1:

../../../_images/embed_dialog.png

Select layers and groups to embed nix

Хотя встроенные слои можно редактировать, изменение их свойств, например, символики или подписей невозможно.

Удаление встроенных слоёв

Вызовите контекстное меню слоя и выберите mActionRemoveLayer Удалить.