Outdated version of the documentation. Find the latest one here.

Modifica

QGIS supporta la modifica di layer vettoriali OGR, PostGIS e Spatialite.

Nota

The procedure for editing GRASS layers is different - see Section Digitalizzare e modificare layer vettoriali GRASS for details.

Suggerimento

Modifiche concorrenti

Questa versione di QGIS non effettua alcuna verifica sulla possibilità che più utenti stiano effettuando contemporaneamente modifiche sullo stesso layer, è quindi l’ultimo utente che effettua il salvataggio ad apportare le modifiche definitive.

Settare la tolleranza dello snapping e il raggio di ricerca degli elementi

Prima di editare vertici, è molto importante sia impostare il livello di snapping che il valore del raggio di ricerca al fine di gestire in maniera ottimale la modifica delle geometrie di un layer vettoriale.

Tolleranza di snapping

La tolleranza di snapping è la distanza entro la quale QGIS cerca il vertice e/o segmento più vicino al quale si cerca di agganciarsi quando si crea un nuovo vertice o si sposta un vertice esistente. Se non si è entro la tolleranza di snapping, QGIS lascerà il vertice creato o spostato nella posizione in cui si rilascia il pulsante del mouse invece di agganciarlo ad un vertice e/o segmento esistente. La tolleranza di snapping influenza tutti gli strumenti che lavorano con una tolleranza.

  1. La tolleranza di snapping può essere impostata a livello dell’intero progetto scegliendo la voce di menu Impostazioni ‣ mActionOptions Opzioni. Su Mac andare su QIS ‣ mActionOptions Preferenze..., su Linux: Modifica ‣ mActionOptions Opzioni. Nella scheda Digitalizzazione è possibile impostare la modalità di snap predefinita tra snap al vertice, al segmento o entrambe. Si può anche definire una tolleranza di snapping e un raggio di ricerca per la modifica di un vertice, in unità di mappa o in pixel. Impostando i valori in pixel, invece che in unità di mappa, si evita di dover modificare la tolleranza in seguito ad operazioni di zoom. Nel nostro progetto di digitalizzazione (con il dataset Alaska), definiamo la tolleranza di snap in metri. I risultati possono variare, ma alla scala 1:10000 il valore di circa 100 metri dovrebbe andare bene.

  2. È anche possibile impostare una tolleranza di snapping per singolo layer scegliendo la voce di menu Impostazioni ‣ (oppure File ‣) Opzioni si snap... (figura figure_edit_1 ).

Da notare che la tolleranza di snap per un singolo layer sovrascrive la tolleranza globale impostata nella scheda Digitalizzazione. Se è necessario modificare un layer ed impostare lo snap per i suoi vertici, allora abilitare la tolleranza di snap solamente sul layer richiesto. Diminuire la tolleranza di snap globale a un livello più basso ed assicurarsi che sia selezionatala casella di controllo per il layer.

Figure Edit 1:

../../../_images/editProjectSnapping.png

Edit snapping options on a layer basis nix

Raggio di ricerca

Il raggio di ricerca è la distanza che QGIS usa per cercare il vertice più vicino che si sta provando a spostare quando si clicca nella mappa. Se non si è entro il raggio di ricerca, QGIS non troverà né selezionerà alcun vertice e mostrerà un avvertimento in una finestra pop-up. La tolleranza di snapping e il raggio di ricerca sono impostati in unità di mappa o in pixel e potrebbe essere necessario fare diversi tentativi prima di trovare l’impostazione migliore. Se si specifica una tolleranza troppo alta, QGIS potrebbe agganciare il vertice sbagliato, specialmente se si ha a che fare con molti vertici vicini all’area in cui si sta effettuando la modifica. Impostando invece un raggio di ricerca troppo piccolo impedirà a QGIS di trovare alcuna geometria da spostare.

Il raggio di ricerca per la modifica di vertici può essere definito in unità del layer dalla scheda Digitalizzazione sotto il menu Impostazioni ‣ mActionOptions Opzioni, sotto lo stesso percorso dal quale è possibile impostare la tolleranza di snapping a livello di progetto.

Zoom e spostamento

Prima di editare un layer sarebbe opportuno ingrandire la vista mappa su un’area di interesse, al fine di evitare una lunga attesa per la visualizzazione di tutti i vertici della mappa.

Oltre ad utilizzare le icone mActionPan Sposta mappa e mActionZoomIn Ingrandisci / mActionZoomOut Rimpicciolisci è possibile interagire con la mappa con la rotellina del mouse, la barra spaziatrice e i tasti freccia della tastiera.

Zoom e spostamento con la rotella del mouse

Per spostarsi nella mappa cliccare sulla rotella del mouse e trascinare, mentre per lo zoom basta ruotare la stessa. Posizionare il cursore nell’area di mappa e ruotare la rotellina verso di sé per ridurre e verso lo schermo per ingrandire. La posizione del puntatore del mouse determinerà il centro dell’area da ingrandire. È possibile personalizzare il comportamento della rotella del mouse nella scheda Strumenti mappa alla voce di menu Impostazioni ‣ mActionOptions Opzioni.

Spostamento con i tasti freccia

È possibile spostare la vista mappa anche con i tasti freccia della tastiera. Posizionare il mouse nella vista mappa e cliccare la freccia destra per spostarsi verso est, la freccia sinistra per spostarsi verso ovest, la freccia in su per spostarsi verso nord e la freccia in giù per spostarsi verso sud.

È anche possibile tenere premuta la barra spaziatrice mentre si sposta il mouse per spostare la vista mappa e usare i tasti PgUp e PgDown per aumentare o ridurre l’ingrandimento senza interrompere la sessione di digitalizzazione.

Modifiche topologiche

Oltre alle opzioni di snap a livello di singolo layer, la finestra di dialogo Opzioni di snap... permette di impostare altre funzionalità topologiche. È possibile selezionare le opzioni checkbox Abilita la modifica topologica e/o checkbox Evita inters.: quest’ultima evita l’intersezione di nuovi poligoni.

Abilitare la modifica topologica

L’opzione checkbox Abilita la modifica topologica serve a mantenere bordi comuni tra poligoni adiacenti durante l’editazione. QGIS individua un bordo condiviso in un insieme di poligoni e tutto ciò che si deve fare è spostare il vertice una volta sola: QGIS si occuperà di aggiornare i bordi di poligoni adiacenti.

Evitare le intersezioni per i nuovi poligoni

L’opzione checkbox Evita inters. impedisce l’intersezione di poligoni adiacenti, rendendone più spedita la digitalizzazione. Se si ha già un poligono, è possibile con questa opzione abilitata, digitalizzare un secondo poligono in modo che entrambi si intersechino; QGIS taglierà automaticamente il secondo lungo il bordo comune, con il vantaggio che l’utente non deve digitalizzare tutti i vertici coincidenti.

Modifica di un layer esistente

Al fine di evitare modifiche involontarie, i dati sono caricati in QGIS in modalità solo lettura. Comunque, è sempre possibile modificare un layer se ciò è consentito dallo specifico fornitore di dati e se il dato medesimo è anche scrivibile (ovvero i file non sono in modalità sola lettura). Le funzioni di modifica di layer sono più versatili quando sono applicate a dati immagazzinati in database PostgreSQL/PostGIS.

In QGIS sono presenti due barre strumenti distinte per la modifica dei vettori, una di base e l’altra avanzata, quest’ultima descritta nella Sezione Digitalizzazione avanzata. Entrambe le barre possono essere attivate/disattivate sotto Visualizza ‣ Barra degli strumenti ‣. Gli strumenti di base offrono le seguenti funzionalità:

Icona

Azione

Icona

Azione

mActionToggleEditing

Attiva modifica

mActionCapturePoint

Aggiunge elementi: Inserisci punto

mActionCaptureLine

Aggiunge elementi: Inserisci linea

mActionCapturePolygon

Aggiunge elementi: Inserisci poligono

mActionMoveFeature

Muove elementi

mActionNodeTool

Strumento vertici

mActionDeleteSelected

Elimina elementi selezionati

mActionEditCut

Taglia elementi

mActionEditCopy

Copia elementi

mActionEditPaste

Incolla elementi

mActionFileSave

Salva modifiche

   

Strumenti di base per la modifica di layer vettoriali

Ogni sessione di modifica è inizializzata dall’opzione mActionToggleEditing Modifica, che può essere attivata e disattivata nel menù contestuale che si apre cliccando con il tasto destro del mouse sul nome del layer nella legenda.

In alternativa, è possibile usare il pulsante Modifica mActionToggleEditing Modifica. Quando il layer è in modalità modifica, i vertici In alternativa, è possibile usare il pulsante sono contrassegnati da indicatori (croci o cerchi semitrasparenti) e altri strumenti sono attivati nella barra degli strumenti di modifica.

Suggerimento

Salvataggio ad intervalli regolari

Ricordarsi di usare mActionFileSave Salva modifiche regolarmente, in modo da consentire il salvataggio delle modifiche recenti e per verificare che le stesse siano accettate dalla fonte di dati.

Aggiungere elementi

È possibile usare gli strumenti mActionCapturePoint Inserisci punto, mActionCaptureLine Inserisci linea o mActionCapturePolygon Inserisci poligono per porre il puntatore di QGIS in modalità digitalizzazione.

Per ogni elemento, bisogna dapprima digitalizzare la geometria e successivamente inserire gli attributi. Per digitalizzare la geometria, cliccare con il tasto sinistro del mouse nella vista mappa per creare il primo punto del nuovo elemento.

Per linee e poligoni, continuare a cliccare con il tasto sinistro per ogni ulteriore vertice che si desidera inserire. Quando è terminato l’inserimento dei vertici o dei punti, cliccare con il tasto destro in qualunque punto della mappa per confermare di aver terminato l’inserimento della geometria dell’elemento.

Apparirà quindi la finestra degli attributi che consentirà di inserire le informazioni per l’elemento appena creato (figura Figure_edit_2). Nella scheda Digitalizzazione della voce di menu Impostazioni ‣ Opzioni è possibile attivare/disattivare le due opzioni checkbox Non aprire la finestra degli attributi dopo la creazione di ogni geometria checkbox Ripeti i valori degli attributi usati per ultimi.

Figure Edit 2:

../../../_images/editDigitizing.png

Enter Attribute Values Dialog after digitizing a new vector feature nix

Per spostare degli elementi utilizzare lo strumento mActionMoveFeature Muovi elemento/i.

Suggerimento

Tipologie di attributo

Relativamente agli shapefile, la modifica del tipo di attributo è validata durante l’inserimento, per cui non è ovviamente possibile inserire un numero in una colonna testuale quando compare la finestra di dialogo Attributi e viceversa. Qualora si avesse tale necessità, è necessario modificare gli attributi in un secondo momento per mezzo della finestra di dialogo Tabella degli attributi.

Strumento vertici

Sia per i layer PostgreSQL/PostGIS che per gli shapefile, lo mActionNodeTool Strumento vertici fornisce capacità di modifica dei vertici simili ai programmi CAD. È possibile selezionare più vertici contemporaneamente e spostarli e/o cancellarli con un’unica operazione. Lo strumento supporta la modifica topologica e lavora anche con la proiezione al volo attiva; se non trova nessun elemento apre una finestra di avviso che suggerisce di controllare le impostazioni di snapping.

Pertanto, è importante impostare Impostazioni ‣ mActionOptions Opzioni ‣ Digitalizzazione ‣ Raggio di ricerca: selectnumber ad un valore superiore a zero (per esempio 10). Altrimenti QGIS non è in grado di gestire adeguatemente la modifica dei vertici.

Suggerimento

Indicatori dei vertici

The current version of QGIS supports three kinds of vertex-markers: Semi transparent circle, Cross and None. To change the marker style, choose mActionOptions Options from the Settings menu and click on the Digitizing tab and select the appropriate entry.

Operazioni di base

Attivare lo strumento mActionNodeTool Strumento vertici e selezionare un elemento cliccandoci sopra: un riquadro rosso apparirà su ogni vertice dell’elemento.

  • Selecting vertices: You can select vertices by clicking on them one at a time, by clicking on an edge to select the vertices at both ends, or by clicking and dragging a rectangle around some vertices. When a vertex is selected its color changes to blue. To add more vertices to the current selection, hold down the Ctrl key while clicking. Hold down Ctrl or Shift when clicking to toggle the selection state of vertices (vertices that are currently unselected will be selected as usual, but also vertices that are already selected will become unselected).
  • Aggiungere vertici: per aggiungere un vertice fare doppio click nei pressi di un bordo. Si noti che il vertice apparirà sul bordo e non alla posizione del cursore del mouse.

  • Eliminare vertici: per eliminare un vertice selezionato basta premere il tasto Delete. Si noti che non è possibile eliminare un intero elemento tramite lo strumento mActionNodeTool Strumento vertici; QGIS manterrà un numero minimo di vertici per il tipo di elemento su cui si sta lavorando. Per eliminare completamente un elemento, usare lo strumento mActionDeleteSelected Elimina il selezionato.

  • Spostare vertici: selezionare i vertici di interesse, quindi cliccare e trascinare nella direzione verso la quale si intende spostare i vertici; i vertici saranno spostati tutti insieme. Se lo snap è attivo, l’intera selezionare può essere agganciata al vertice e/o linea più vicina.

Ogni cambiamento operato con lo strumento vertici è memorizzato nel dialogo Annulla. Tutte le operazioni supportano le modifiche topologiche (se attivate) ed è possibile operare con la proiezione a volo attiva. Lo strumento vertici offre, inoltre, la possibilità di ottenere informazioni su un vertice lasciando semplicemente il cursore del mouse sul vertice di interesse.

Tagliare, copiare ed incollare elementi

Gli elementi selezionati possono essere tagliati, copiati ed incollati tra layer dello stesso progetto di QGIS a patto che anche per il layer di destinazione sia stata abilitata la modalità di modifica tramite l’opzione mActionToggleEditing Modifica.

Gli elementi possono essere anche incollati in applicazioni esterne in formato testo: gli elementi verranno rappresentati nel formato CSV con le informazioni della geometria espresse nel formato testo OGC Well Known Text (WKT).

Le funzioni di copia/incolla sono utili quando si devono modificare più layer copiando le modifiche effettuate in uno di questi negli altri. Supponendo, ad esempio, di voler lavorare su un layer contenente solo alcuni laghi, diventa molto più agevole creare un nuovo layer vuoto nel quale incollare gli elementi dei quali necessitiamo invece di lavorare sul layer big_lakes contenente 5000 elementi.

Dovremo quindi effettuare le seguenti operazioni:

  1. Caricare il layer dal quale vogliamo copiare gli elementi (layer sorgente)

  2. Caricare o creare il layer nel quale vogliamo incollare gli elementi copiati (layer di destinazione)

  3. Impostare entrambi i layer in modalità modifica

  4. Rendere attivo il layer sorgente cliccando sul relativo nome nella legenda

  5. Attivare lo strumento mActionSelect Seleziona il singolo elemento per selezionare gli elementi dal layer sorgente

  6. Cliccare sullo stumento mActionEditCopy Copia elementi

  7. Rendere attivo il layer di destinazione cliccando sul relativo nome nella legenda

  8. Attivare lo strumento mActionEditPaste Incolla elementi

  9. Terminare le modifiche e salvare

Se il layer sorgente e quello di destinazione hanno un diverso schema (nomi e tipi dei campi) QGIS popola, se presenti, i campi comuni e ignora il resto. Se non è importante che vengano copiati anche gli attributi nel layer di destinazione, si può non prestare attenzione a come viene definito lo schema della tabella attributi, altrimenti è necessario definirlo in modo che lo schema del layer sorgente e quello del layer di destinazione combacino.

Suggerimento

Congruenza degli elementi incollati

Se il layer sorgente e quello di destinazione usano lo stesso sistema di proiezione, gli elementi incollati saranno assolutamente identici a quelli del layer di origine. Nel caso in cui invece la proiezione del layer di destinazione sia differente QGIS non garantisce che la geometria sia identica a causa del pur ridotto errore di arrotondamento introdotto nel passaggio da un sistema di proiezione all’altro.

Cancellare elementi selezionati

Se si vuole eliminare un intero poligono, è possibile farlo selezionando dapprima l’elemento che intendiamo cancellare con lo strumento mActionSelect Seleziona il singolo elemento: è possibile anche selezionare più poligoni contemporaneamente. Una volta definita la selezione, usare lo strumento mActionDeleteSelected Elimina il selezionato per cancellare la selezione.

Anche lo strumento mActionEditCut Taglia geometrie può essere usato per eliminare elementi: tali elementi vengono spostati in un blocco appunti spaziale. In questo modo è possibile annullare l’operazione incollando nuovamente gli elementi tagliati con lo strumento mActionEditPaste Incolla elementi, fornendo in ultima analisi almeno un livello di annullamento. Gli strumenti taglia, copia e incolla lavorano sugli elementi selezionati, consentendo quindi di lavorare su più di un elemento alla volta.

Suggerimento

Supporto alla cancellazione di elementi

Quando si modificano shapefile, la cancellazione di elementi funziona solo se QGIS è compilato con una versione di GDAL pari a 1.3.2 o superiore, come accade per le versioni compilate per OS X e Windows disponibili sul sito.

Salvare i layer modificati

When a layer is in editing mode, any changes remain in the memory of QGIS. Therefore they are not committed/saved immediately to the data source or disk. If you want to save edits to the current layer but want to continue editing without leaving the editing mode, you can click the mActionFileSave Save Edits button. When you turn editing mode off with the mActionToggleEditing Toggle editing (or quit QGIS for that matter), you are also asked if you want to save your changes or discard them.

Se le modifiche non possono essere salvate (ad es. perché il disco di destinazione è pieno o gli attributi contengono valori esterni agli estremi ammissibili), lo stato della memoria di QGIS è preservato, consentendo dunque di correggere gli errori e riprovare il salvataggio.

Suggerimento

Integrità dei dati

È buona norma fare un back-up del dato originale prima di procedere alla modifica. Per quando siano stati fatti molti sforzi da parte dei programmatori di QGIS per preservare l’integrità del dato, non vi è alcuna garanzia che ciò avvenga.

Digitalizzazione avanzata

Icona

Azione

Icona

Azione

mActionUndo

Annulla

mActionRedo

Ripristina

mActionSimplify

Semplifica geometrie

mActionAddRing

Aggiungi buco

mActionAddIsland

Aggiungi una parte

mActionDeleteRing

Elimina buco

mActionDeletePart

Elimina parte

mActionReshape

Modifica la forma

mActionOffsetCurve

Curva di offset

mActionSplitFeatures

Spezza elemento

mActionMergeFeatures

Unisci le geometrie selezionate

mActionRotatePointSymbols

Ruota i simboli per i punti

mActionMergeFeatures

Unisci gli sttributi delle geometrie selezionate

   

Barra degli strumenti di digitalizzazione avanzata

Annullare e rispristinare

Gli strumeti mActionUndo Annulla e mActionRedo Ripristina permettono di annullare/ripristinare le modifiche ad un layer vettoriale. Inoltre, è disponibile un widget che memorizza e mostra tutte le operazioni annulla/ripristina (Figura Figure_edit_3). Per attivare il widget cliccare con il tasto destro del mouse sulla barra degli strumenti ed attivare la casella di controllo Annulla/Ripristina. Annulla/Ripristina è comunque attivo, anche se il widget non è visibile.

Figure Edit 3:

../../../_images/redo_undo.png

Redo and Undo digitizing steps nix

Cliccando su Annulla, tutti gli elementi e gli attributi vengono riportati al loro stato precedente. Le modifiche effettuate con strumenti diversi da quelli per la digitalizzazione (es. un plugin), potrebbero non essere annullabili.

Se nel widget Annulla/Ripristina si clicca su una determinata operazione, tutti gli elementi saranno riportati allo stato successivo all’operazione selezionata.

Semplifica geometrie

Lo strumento mActionSimplify Semplifica geometrie permette di ridurre il numero di vertici di un elemento, preservandone la geometria: un elemento selezionato con lo strumento sarà evidenziato da una linea di semplificazione rossa, inoltre verrà mostrato a schermo un cursore (Tolleranza linea di semplificazione). Muovendo il cursore, la linea di semplificazione cambia e mostra la forma che assumerà l’elemento che si sta semplificando. Per memorizzare la geometria semplificata, cliccare su [OK] . Se una geometria non può essere semplificata (come nel caso di un multi-poligono), verrà mostrato un messaggio di errore.

Aggiungi buco

Si possono digitalizzare nuovi poligoni all’interno di poligoni esistenti, al fine di creare un buco all’interno di questi ultimi, scegliendo lo strumento mActionAddRing Aggiungi buco. In questo modo solo l’area compresa tra i bordi del poligono interno e di quello esterno verrà evidenziata come poligono ad anello.

Aggiungi una parte

Lo strumento mActionAddIsland Aggiungi una parte permette di aggiungere una parte ad un multi-poligono; la nuova parte va digitalizzata all’esterno del poligono selezionato.

Elimina buco

Lo strumento mActionDeleteRing Elimina buco permette di eliminare un buco all’interno di un poligono. Lo strumento funziona esclusivamente con layer di poligoni. Nessuna azione viene effettuata se lo strumento viene usato sul bordo esterno di un poligono. Prima di selezionare i vertici di un buco, impostare adeguatamente la tolleranza.

Elimina parte

Lo strumento mActionDeletePart Elimina parte permette di eliminare parti da geometrie multi-parte (multi-punto, multilinea, multi-poligono); lo strumento non ha effetto sull’ultima parte aggiunta. Prima di selezionare i vertici di una parte, impostare adeguatamente la tolleranza.

Modifica la forma

Lo strumento mActionReshape Modifica forma permette di modificare la forma di elementi a geometria lineare e poligonale tracciando una nuova linea: la porzione di elemento tra i due punti di intersezione con la nuova linea sarà rimpiazzata dalla forma di quest’ultima. Prestare particolare attenzione ad utilizzare lo strumento con i poligoni: limitarsi a piccole porzioni di poligono. La nuova forma non può intersecare più buchi, altrimenti si generano poligoni non validi.

Per modificare, ad esempio, il bordo di un poligono basta cliccare un primo punto all’interno del poligono, cliccare un secondo punto all’esterno del poligono, tracciare il profilo della nuova forma, rientrare nel poligono e cliccare con il tasto destro del mouse per terminare l’operazione. Lo strumento aggiungerà automaticamente nuovi nodi laddove la nuova linea interseca il bordo del poligono. È, inoltre, possibile rimuovere parte di un poligono iniziando la nuova linea all’esterno del poligono, aggiungendo vertici all’interno e terminando la linea all’esterno con il tasto destro del mouse.

Nota

Lo strumento potrebbe alterare la posizione iniziale di un poligono o di una linea chiusa, per cui nodo iniziale e nodo finale potrebbero non coincidere. Per molte applicazioni tale fatto non è un problema rilevante, ma è opportuno tenerne conto.

Dividere elementi

Il nuovo strumento di digitalizzazione mActionOffsetCurve Curva di offset sposta parallelamente linee e buchi di poligoni. Lo strumento può essere utilizzato sia per modificare il layer che per effettuare modifiche di sfondo (vengono create cosi delle copie delle linee / anelli che vengono aggiunte al layer modificato). E’ ideale per creare linee di distanza: la misura dello spostamento compare nella parte bassa dello schermo.

Spezza elemento

È possibile dividere degli elementi tramite lo strumento mActionSplitFeatures Spezza elemento e tracciando una linea attraverso l’elemento di interesse.

Unire elementi

Lo strumento mActionMergeFeatures Unisci le geometri selezionate permette di unire elementi con bordi condivisi e stessi attributi.

Unire attributi di elementi

Lo strumento mActionMergeFeatures Unisci gli attributi degli elementi selezionati permette di unire gli attributi di elementi con bordi condivisi e stessi attributi senza però, unirne i bordi.

Ruota i simboli per i punti

Attualmente lo strumento mActionRotatePointSymbols Ruota i simboli per i punti è supportato dalla sola simbologia di vecchia generazione. Esso permette di cambiare la rotazione di un simbolo per punti qualora sia stata definita una colonna rotazione nella tabella degli attributi di un layer puntuale (scheda Stile della finestra di dialogo Proprietà layer. In caso contrario lo strumento non è attivo.

Figure Edit 4:

../../../_images/rotatepointsymbol.png

Rotate Point Symbols nix

Per modificare la rotazione, selezionare un elemento puntuale nella vista mappa e ruotarlo tenendo premuto il tasto sinistro del mouse; apparirà una freccia rossa ed il valore di rotazione (Figura Figure_edit_4). Al termine dell’operazione, il valore di rotazione nella tabella degli attributi sarà aggiornato di conseguenza.

Nota

Se si tiene premuto il tasto Ctrl, la rotazione avverrà per step di 15 gradi.

Creare nuovi layer vettoriali

QGIS permette di creare shapefile e layer SpatiaLite. La creazione di layer GRASS è supportata dal plugin di GRASS. Per ulteriori informazioni sulla creazione di layer GRASS fare riferimento alla sezione Creare un nuovo layer vettoriale GRASS.

Creare un nuovo Shapefile

Per creare un nuovo layer shapefile selezionare Nuovo ‣ mActionNewVectorLayer Nuovo layer shapefile... dal menu Layer. Apparirà la finestra di dialoto Nuovo vettore mostrata in figura Figure_edit_5. Scegliere il tipo di geometria (Punto, Linea o Poligono) ed il sistema di riferimento (SR).

Si noti che QGIS non supporta la creazione di elementi 2.5D (ad es. elementi con coordinate XYZ) o il conteggio degli elementi.

Figure Edit 5:

../../../_images/editNewVector.png

Creating a new Shapefile layer Dialog nix

Per completare la creazione del nuovo layer shapefile vanno specificati gli attributi, definendone nome e tipo e cliccando su [Aggiungi alla lista degli attributi]. La colonna ’id’ è aggiunta automaticamente da QGIS, ma può essere eliminata. Allo stato attuale sono supportati solo attributi Tipo: Numeri decimali selectstring, Type: Numeri interi selectstring, e Type: Testo selectstring . in funzione del tipo di attributo è possibile definire larghezza e precisione. Una volta definiti gli attributi, cliccare su [OK] e assegnare un nome allo shapefile. QGIS aggiungerà automaticamente l’estensione .shp al nome indicato. Una volta creato il layer, lo stesso sarà aggiunto alla vista mappa e potrà essere modificato come descritto alla precedente Sezione Modifica di un layer esistente.

Creare un nuovo layer SpatiaLite

Per creare un nuovo layer spatialite selezionare Nuovo ‣ mActionNewVectorLayer Nuovo layer SpatiaLite... dal menu Layer.Apparirà la finestra di dialogo Nuovo layer SpatiaLite mostrata in figura Figure_edit_6.

Figure Edit 6:

../../../_images/editNewSpatialite.png

Creating a New SpatiaLite layer Dialog nix

Selezionare un database Spatialite esistente o crearne uno nuovo tramite il pulsante browsebutton alla destra del campo ’Database’. Indicare un nome per il nuovo layer, definire il tipo di layer ed il sistema di riferimento (EPSG SRID). Se richiesto, è possibile creare una chiave primaria autoincrementale selezionando checkbox Crea una chiave primaria autoincrementale.

Per definire la tabella degli attributi del nuovo layer, indicare nome e tipo dell’attributo desiderato e cliccare su [Aggiungi alla tabella degli attributi] quindi cliccare su [OK]. Una volta creato il layer, lo stesso sarà aggiunto alla vista mappa e potrà essere modificato come descritto alla precedente sezione Modifica di un layer esistente.

I layer Spatialite possono essere gestiti attraverso DB Manager, vedi sezione Plugin DB Manager.

Lavorare con la tabella degli attributi

La tabella degli attributi mostra gli elementi di un layer. Ogni riga nella tabella rappresenta un elemento ed ogni colonna un attributo. Gli elementi possono essere cercati, selezionati, spostati e modificati.

Per aprire la tabella degli attributi di un layer vettoriale, rendere attivo il layer e selezionare l’opzione mActionOpenTable Apri tabella attributi dal menu Layer. Lo stesso risultato si ottiene cliccando con il tasto destro del mouse soprail layer in legenda e selezionando mActionOpenTable Apri tabella degli attributi dal menu contestuale.

Si aprirà la finestra di dialogo mostrata in Figura figure_attributes_1: il titolo della finestra, inoltre, mostra il numero di elementi selezionati sul totale degli elementi del layer.

Figure Attributes 1:

../../../_images/vectorAttributeTable.png

Attribute Table for Alaska layer nix

Selezionare elementi nella tabella degli attributi

Ogni riga selezionata nella tabella degli attributi mostra gli attributi di un elemento selezionato nel layer. Se l’insieme di elementi selezionati nella vista mappa viene modificato, la selezione viene aggiornata anche nella tabella e viceversa. Allo stesso modo, se cambia l’insieme delle righe selezionate nella tabella degli attributi, cambierà anche la visualizzazione degli elementi nella vista mappa.

Le righe possono essere selezionate cliccando sul numero alla loro sinistra. Si possono selezionare righe multiple tenendo premuto il tasto Ctrl. È possibile selezionare un sottoinsieme di righe tenendo premuto Shift e cliccando sulle due righe che delimitano il sottoinsieme di interesse. Spostare il cursore del mouse e cliccare nelle celle della tabella non modifica la selezione. Cambiare la selezione della vista mappa non modifica la posizione del cursore nella tabella.

Le righe della tabella possono essere ordinate in funzione degli attributi. Cliccare sull’intestazione dell’attributo rispetto al quale si intende ordinare la tabella: una piccola freccia a destra del nome dell’attributo indicherà il verso dell’ordinamento (freccia in su per ordinamento crescente, freccia in giù per ordinamento decrescente).

Per effettuare una ricerca per attributo su un solo attributo, selezionare la colonna di interesse dal menu a cascata a sinistra del pulsante Cerca, inserire il testo da ricercare nella casella e cliccare su [Cerca ]. Le righe che soddisfano la stringa di ricerca saranno selezionate, mentre il numero totale di righe trovate apparirà nella barra del titolo della tabella degli attributi e nella barra di stato della finestra principale. Per la ricerca avanzata cliccare su Ricerca avanzata |browsebutton : il pulsante aprirà il Costruttore di interrogazioni descritto nella sezione Costruttore di interrogazioni.

Per visualizzare solo le righe selezionate usare l’opzione checkbox Mostra solo i selezionati. Per ricercare solo nelle righe selezionate usare l’opzione checkbox Cerca solo i selezionati. La casella di controllo checkbox Maiusc/minusc abilita la ricerca sensibile al carattere. Gli altri pulsanti, in basso a sinistra, hanno le seguenti funzionalità:

  • mActionOpenTable Unselect all anche con Ctrl+U

  • mActionSelectedToTop Muovi selezione in alto anche con Ctrl+T

  • mActionInvertSelection Inverti selezione anche con Ctrl+S

  • mActionCopySelected Copia le righe selezionate nel blocco appunti anche con Ctrl+C

  • mActionZoomToSelected Zoom mappa alle righe selezionate anche con Ctrl+J

  • mActionZoomToSelected Zoom mappa alle righe selezionate anche con Ctrl+P

  • mActionToggleEditing Modalità modifica per modificare singoli valori della tabella e per abilitare le funzionalità di seguito descritte. Anche con Ctrl+E

  • mActionDeleteSelected Elimina gli elementi selezionati anche con Ctrl+D

  • mActionNewAttribute Nuova colonna per layer PostGIS ed OGR con GDAL versione >= 1.6. Anche con Ctrl+W

  • mActionDeleteAttribute Elimina colonna per layer PostGIS ed OGR con GDAL versione >= 1.9. Anche con Ctrl+L

  • mActionCalculateField Apri il calcolatore di campi anche con Ctrl+I

Suggerimento

Geometrie WKT

Se si desiderano visualizzare gli attributi in un programma esterno (per esempio Excel), usare il pulsante mActionCopySelected Copia le righe selezionate nel blocco appunti. E’ possibile copiare le informazioni senza le geometrie del layer vettoriale disattivando Impostazioni ‣ Opzioni ‣ scheda Generale checkbox Copia la geometria in formato WKT dalla tabella degli attributi.

Salvare elementi selezionati come nuovo layer

Gli elementi selezionati possono essere salvati in uno dei formati vettoriali supportati da OGR, anche con sistema di riferimento diverso da quello del layer di origine. Cliccare con il tasto destro del mouse sul layer in legenda e selezionare Salva selezione con nome ‣ dal menu contestuale: quindi definire il nome, il formato ed il sistema di riferimento del file di output (Sezione Legenda). È anche possibile specificare le opzioni di creazione OGR.

Lavorare con tabelle di attributi non spaziali

QGIS permette di caricare tabelle di dati non spaziali nei formati supportati da OGR, dal fornitore PostgreSQL e in testo delimitato. Una volta caricata, la tabella viene elencata nella legenda e può essere aperta con mActionOpenTable Apri tabella degli attributi ed editata come qualsiasi altra tabella di layer.

Ad esempio, è possibile usare una colonna di una tabella non spaziale per definire il valore o un intervallo di valori di attributi ammissibili per un layer vettoriale durante la digitalizzazione. Per ulteriori informazioni riferirsi al widget di modifica nella Sezione Scheda Campi.