Outdated version of the documentation. Find the latest one here.

Configurazione di QGIS

QGIS è altamente configurabile attraverso i menu Impostazioni ‣ e Visualizza ‣. Scegliere rispettivamente fra Opzioni, Personalizzazione e Pannelli, Barre degli strumenti.

Pannelli e Barre degli strumenti

Nel menu Pannelli ‣ è possibile attivare e disattivare i widgets di QGIS. Il menu Barre degli strumenti ‣ offre la possibilità di attivare e disattivare gruppi di icone nella barra degli strumenti di QGIS (see figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

The Panels and Toolbars menu nix

Suggerimento

Panoramica

Il pannello di panoramica della mappa fornisce una vista completa dei layer aggiunti ad essa. Può essere selezionato nel menu Visualizza ‣ Pannelli. All’interno della panoramica è presente un rettangolo che mostra l’estensione corrente della mappa. Ciò permette di determinare rapidamente quale area della mappa si sta attualmente osservando. Si noti che le etichette non sono visualizzate nella panoramica anche se i layer hanno la funzione di visualizzazione delle etichette attiva. Cliccando e trascinando nella panoramica il rettangolo rosso che mostra l’estensione corrente della vostra vista, la mappa si sposta di conseguenza.

Suggerimento

Messaggi di log

Dalla versione 1.8 di QGIS è possibile tenere traccia dei messaggi di QGIS. E’ possibile attivare la casella di controllo checkboxMessaggi di log nel menu Visualizza ‣ Pannelli e seguire cosi i messaggi relativi alle varie operazioni nella scheda Generale e Plugin.

Proprietà progetto

Nella finestra delle proprietà del progetto sotto nix File ‣ Proprietà progetto o win Impostazioni ‣ Proprietà progetto possono essere impostate opzioni specifiche del progetto. Queste includono:

  • Nella scheda Generale il titolo del progetto, il colore di selezione e dello sfondo, le unità di misura e l’opzione per salvare i percorsi relativi ai layer. È possibile impostare le unità di misura (usato solo quando la riproiezione è disabilitata) e la precisione per le cifre decimali.

  • La scheda Sistema di riferimento (SR) permette di scegliere il sistema di proiezione delle coordinate e di abilitare la riproiezione al volo dei layer vettoriali quando vengono visualizzati layer con differenti SR.

  • La scheda Layer interrogabil permette di definire i layer che risponderanno allo strumento di interrogazione. (Vedere il paragrafo Strumenti mappa nella sezione Opzioni dell’interfaccia grafica (GUI) per abilitare l’interrogazione di layer multipli.)

  • La scheda Server WMS permette di definire le informazioni del Service Capabilities, l’Estensione pubblicata e le Restrizioni dei sistemi di coordinate del mapserver QGIS. Attivando checkbox Aggiungi geometria WKT alle informazioni di risposta dell’oggetto il layer WMS risulterà interrogabile.

Opzioni dell’interfaccia grafica (GUI)

mActionOptions Alcune opzioni di base per QGIS possono essere impostate nella finestra Opzioni. Selezionare la voce di menu Impostazioni ‣ mActionOptions Opzioni. Le schede nelle quali possono essere regolate le opzioni sono:

Generale

  • checkbox Richiedi di salvare i cambiamenti di progetto se necessario

  • checkbox Avvisa quando viene aperto un file di progetto salvato con una vecchia versione di QGIS

  • Cambia il colore della selezione e dello sfondo

  • Cambia lo stile di QGIS

  • Tema delle icone (scelta tra ‘default’, ‘classic’ e ‘gis’)

  • Dimensione delle icone (scelta tra 16, 24 e 32).

  • Carattere

  • Azione eseguita in legenda sul comando doppio-click (scelta tra Apri proprietà del layer e Apri tabella degli attributi).

  • checkbox Rendi maiuscoli i nomi dei layer nella legenda

  • checkbox Visualizza i nomi degli attributi della classificazione nella legenda

  • checkbox Crea le icone raster nella legenda

  • checkbox Nascondi lo splash screen all’avvio

  • checkbox Mostra suggerimenti all’avvio

  • checkbox Apri i risultati di un’interrogazione in una finestra agganciata (richiede il riavvio di QGIS)

  • checkbox Apri le opzioni di snap in una finestra agganciata (richiede il riavvio di QGIS)

  • checkbox Apri la tabella degli attributi in una finestra agganciata (richiede il riavvio di QGIS)

  • checkbox Aggiungi un layer PostGIS con un doppio click e seleziona la modalità estesa

  • checkbox Aggiungi nuovi layer al gruppo selezionato

  • checkbox Copia la geometria in formato WKT dalla tabella degli attributi

  • Comportamento della tabella attributi (scelta tra Mostra tutti gli elementi, Mostra gli elementi selezionati, Mostra gli elementi sulla mappa corrente)

  • Cache riga attributi tabella

  • Mostra i valori NULL come

  • Richiedi i sublayer raster selectstring. Alcuni sublayers raster di supporto - vengono chiamati subdatasets in GDAL. Un esempio sono i file netcdf - se ci sono diverse variabili netcdf, GDAL riconosce ogni variabile come un subdataset. L’opzione permette di controllare la gestione dei sublayers quando uno di questi viene aperto. Vengono proposte diverse scelte:

    • ‘Sempre’: chiede sempre (se sono presenti sublayers)

    • ‘Se necessario’ chiede se il layer non ha contorni, ma ha sublayers

    • ‘Mai’ non chiede mai, non verrà caricato niente

    • ‘Carica tutto’ non chiede niente, ma carica tutti i sublayers

  • Ricerca elementi validi nella finestra del browser selectstring. L’opzione ‘Controlla l’esensione’ è stata pensata per velocizzare il caricamento di una cartella, l’operazione potrebbe richiedere diverso tempo se l’opzione ‘Controlla il contenuto del file’ è attivata e vi sono molti file (decine o centinaia).

  • Ricerca contenuto dei file compressi (.zip) nella finestra del browser selectstring. Anche questa opzione è stata pensata per velocizzare il caricamento di una cartella. E’ possibile scegliere fra:

    • ‘Scansione base’: controlla che l’estensione sia supportata da uno dei driver

    • ‘Scansione completa’: apre ogni file per verificare che ogni file sia valido

    • ‘Passthru’ non usare questa opzione, sarà rimossa nella prossima versione di QGIS

GDAL

GDAL è una libreria di scambio dati per file raster. In questa scheda potete scegliere quali driver di GDAL usare per un caricare un file raster poiché a volte sono disponibili più driver GDAL.

Plugins

  • Percorsi da aggiungere per cercare ulteriori librerie plugin C++.

Visualizzazione in corso

  • checkbox Per impostazione i nuovi layer aggiunti alla mappa vengono visualizzati subito

  • Numero di geometrie da disegnare prima di aggiornare lo schermo.

  • checkbox Usa il caching di disegno quando possibile per velocizzare la visualizzazione

  • checkbox Rendi le linee meno irregolari a spese delle prestazioni

  • checkbox Risolvi problemi con i poligoni riempiti non correttamente

  • checkbox Utilizza la nuova generazione di simboli per la visualizzazione

  • Definisci le impostazioni per la visualizzazione raster: ‘selezione banda RGB’, checkbox Usa deviazione standard e ‘migliora contrasto’

  • Percorso(i) dove cercare i simboli SVG (Scalable Vector Symbols)

È possibile definire se salvare i percorsi alle texture svg in modalità assoluta o relativa nella scheda Generale del menu Impostazioni ‣ Proprietà progetto.

Strumenti mappa

  • L’impostazione Modalità determina quali layer saranno mostrati attraverso lo strumento ’Informazioni elementi’. Passando a “Top down” o “Il primo attivo” invece di “Layer in uso” gli attributi di tutti i layer selezionabili (Si veda la Sezione Proprietà progetto in: Progetti sulle modalità di impostazione dei layer selezionabili) saranno visibili tramite lo strumento Informazioni elementi.

  • checkbox Apri il modulo degli elementi se viene identificato un un singolo elemento

  • Specificare il raggio di ricerca come percentuale della larghezze della mappa

  • Ellissoide per calcoli di distanza

  • Colore elastico

  • Posizioni decimali

  • checkbox Mantieni le unità di base

  • radiobuttonon Unità di misura preferita (Metri o Piedi)

  • radiobuttonon Unità preferita per gli angoli (Gradi, Radianti o Gradi Decimali)

  • Define Mouse wheel action selectstring (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Fattore di zoom

Sovrapposizioni

  • Definizione dell’algoritmo di posizionamento selectstring delle etichette, dei simobli e dei diagrammi (scelta tra ‘Punto centrale’, ‘Catena’, ‘Catena tabu’, ‘Popmusic’, ‘Tabu popmusic’, ‘Catena popmusic’)

Digitalizzazione

  • Colore e spessore della linea

  • Modalità di snap predefinita selectstring (‘al vertice’, ‘al segmento’ o ‘entrambe’)

  • Tolleranza di snapping predefinita in unità di mappa o in pixel

  • Raggio di ricerca per le modifiche dei vertici in unità di mappa o in pixel

  • checkbox Utilizza indicatori solo per le geometrie selezionate

  • Stile indicatore selectstring (‘croce’ (predefinita), ‘cerchio semitrasparente’ o ‘nessuno’) e della dimensione per gli indicatori dei vertici.

  • checkbox Non aprire la finestra degli attributi dopo la creazione di ogni geometria

  • checkbox Ripeti i valori degli attributi usati per ultimi

  • Verifica le geometrie La digitalizzazione di linee o poligoni complessi con molti nodi può determinare una visualizzazione molto lenta. Questo accade perché la procedura di verifica di default in QGIS impiega molto tempo. Per velocizzare questo processo è possibile selezionare la validazione delle geometrie GEOS (partendo da GEOS 3.3) oppure è possibile disattivarla del tutto. La validazione delle geometrie effettuata da GEOS è molto veloce, lo svantaggio è che verrà riportato solamente il primo problema geometrico rilevato.

Le 3 opzioni successive si riferiscono allo strumento mActionOffsetCurve Curva di offset in Digitalizzazione avanzata. Attraverso i vari settaggi è possibile influenzare la forma della linea di offset. Queste opzioni sono possibili da GEOS 3.3.

  • Stile di unione per l’offset

  • Segmenti di quadrante per l’offset

  • Limite di smussatura per l’offset

SR

La scheda SR è divisa in due aree. La prima permette di impostare il SR predefinito per i nuovi progetti.

  • Inizia un nuovo progetto sempre con questo SR.

  • checkbox Effettua sempre la riproiezione al volo

La seconda area permette di definire cosa accade quando un nuovo layer viene creato o quando viene caricato un layer senza SR.

  • radiobuttonoff Richiedi SR

  • radiobuttonoff Usa il SR del progetto

  • radiobuttonon Utilizza come predefinito il SR visualizzato sotto

Lingua

  • checkbox Sovrascrivi lingua in uso

  • Informazioni sulla lingua correntemente impostata nel sistema

Rete

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

  • checkbox Utilizza un proxy per l’accesso web, definizione di host, porta, utente e password.

  • Definizione del Tipo proxy selectstring.

    • Default Proxy:Il proxy è determinato sulla base delle impostazioni in uso del proxy dell’applicazione

    • Socks5Proxy: Proxy generico per ogni tipo di connessione. Supporta TCP, UDP, associazione a una porta (connessione in entrata) e autenticazione.

    • HttpProxy: Realizzato usando il comando “CONNECT”, supporta solamente connessioni TCP in uscita; supporta l’autenticatione.

    • HttpCachingProxy: Realizzato usando normali comandi HTTP, è utile solamente nel contesto di richieste HTTP

    • FtpCachingProxy: Realizzato usando un proxy FTP, è utile solamente nel contesto di richieste FTP

  • Impostazioni della cache (cartella e dimensione)

  • Indirizzo di ricerca WMS (Quello predefinito è “http://geopole.org/wms/search?search=%1&type=rss”)

  • Timeout per le richieste di rete in ms - predefinito 60000

Si possono escludere alcuni URL aggiungendole nella casella di testo al di sotto delle impostazioni del proxy (see Figure_Network_Tab) premendo il pulsante [Aggiungi] . In seguito fare doppio click nel campo URL appena creato e inserire l’URL che si desidera escludere dall’utilizzo del proxy. Ovviamente il pulsante [Rimuovi] elimina l’elemento selezionato.

Per informazioni più dettagliate sulle diverse impostazioni del proxy, si prega di fare riferimento al manuale della documentazione delle librerie QT suhttp://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Suggerimento

UTILIZZO DEI PROXY

L’utilizzo dei proxy può a volte essere complicato. E’ utile testare i tipi di proxy succitati e controllare il loro funzionamento nel vostro caso specifico.

Queste opzioni possono essere modificate in funzione delle proprie esigenze. Alcuni cambiamenti potrebbero richiedere il riavvio di QGIS prima di essere attivi.

  • nix Le impostazioni sono salvate in un file di testo: $HOME/.config/QuantumGIS/qgis.conf

  • osx Le impostazioni vengono collocate in: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win Le impostazioni vengono inserite nel registro di sistema alla voce:

\HKEY\CURRENT_USER\Software\QuantumGIS\qgis

Personalizzazione

Lo strumento di personalizzazione è una nuova implementazione di QGIS 1.8. Permette di attivare/disattivare praticamente qualunque elemento dell’interfaccia di QGIS. Questa possibilità è molto utile se sono stati installati molti plugins che vengono usati raramente e che riempiono lo schermo.

Figure Customization 1:

../../../_images/customization.png

The Customization dialog nix

Il menu Personalizzazione di QGIS è diviso in cinque gruppi. In checkbox Docks si trovano le finestre dock. Queste sono applicazioni che possono essare avviate e usate come finestre mobili, fisse oppure possono essere incorporate nella finestra principale di QGIS come se fossero dei widget (see also Pannelli e Barre degli strumenti). In checkbox Menu è possibile nascondere funzioni all’interno della Barra dei Menu. In checkbox Barra di stato è possibile disattivare caratteristiche come le informazioni sulle coordinate. In checkbox Barra degli strumenti è possibile attivare/disattivare le icone della barra degli strumenti di QGIS e in checkbox Widgets si possono attivare/disattivare i diversi pannelli presenti in QGIS.

Con mActionSelect Passa ai widget per la cattura nell’applicazione principale è possibile cliccare sugli elementi di QGIS che si intendono nascondere dall’interfaccia e trovarli nel menu Personalizzazione (see figure_customization). E’ possibile anche salvare i diversi setaggi a seconda dei diversi utilizzi. Prima che i cambiamenti diventino effettivi è necessario riavviare QGIS.