Outdated version of the documentation. Find the latest one here.

Strumenti generali

Scorciatoie da tastiera

QGIS fornisce delle scorciatoie da tastiera predefinite per molte delle sue funzionalità: queste sono disponibili nella sezione Barra dei Menu. Inoltre, l`opzione di menu Impostazioni ‣ Configura scorciatoie ‣ permette di modificare le scorciatoie da tastiera predefinite e di aggiungerne delle nuove.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Define shortcut options nix (KDE)

La configurazione è molto semplice; basta selezionare una funzionalità di interesse e cliccare [Cambia], [Elimina] or [Selezione predefinita]. Le configurazioni possono essere salvate in un file XML e caricate in un’altra installazione di QGIS.

Guide contestuali

Quando si ha necessità di maggiori informazioni su una funzionalità specifica è possibile utilizzare la guida contestuale disponibile in molte finestre di dialogo. Si noti che nel caso di plugin di terze parti la guida contestuale potrebbe rimandare ad una pagina web dedicata.

Visualizzazione

Come impostazione di default QGIS ricarica nella vista tutti i layer visibili ogni qualvolta la vista vieneaggiornata. Gli eventi che causano l’aggiornamento della vista includono:

  • Aggiunta di un layer

  • Spostamento, ingrandimento o riduzione (pan e zoom)

  • Ridimensionamento della finestra di QGIS

  • Cambiamento della visibilità di uno o più layer

QGIS consente di controllare il processo di resa a video in diverse maniere.

Visualizzazione in funzione della scala

La visualizzazione in funzione della scala consente di specificare la scala minima e massima rispettivamenteal di sotto e al di sopra della quale un layer resta visibile. Per impostare la visualizzazione in funzione dellascala, aprire la finestra di dialogo Properties facendo doppio click sul layer nella legenda. Nella scheda Generale spuntare la casella di controllo checkboxVisualizza in funzione della scala e impostare i valori per la scala massima e minima.

I valori di scala possono essere determinati usando prima lo zoom sul layer per il quale si vuole impostarel’opzione e prendendo successivamente nota del valore di scala visualizzato nella barra di stato di QGIS.

Controllare la visualizzazione della mappa

La visualizzazione della mappa può essere controllata nei seguenti modi:

Sospensione della visualizzazione

Per sospendere la resa a video, cliccare sulla casella di controllo checkbox Aggiorna in basso a destra della barra di stato. Quando la casella checkbox Aggiorna non è selezionata, QGIS non ridisegna la vista quando si verifica uno degli eventi precedentemente descritti alla Sezione Visualizzazione. Casi in cui si potrebbe voler sospendere la visualizzazione a video includono:

  • Aggiunta di molti layer ed applicazione di uno stile visuale prima della visualizzazione

  • Aggiunta di uno o più layer di grosse dimensioni e impostazione di una scala prima della visualizzazione

  • Aggiunta di uno o più layer di grossa dimensione e zoom ad un’area specifica prima della visualizzazione

  • Combinazioni delle precedenti

La selezione della casella di controllo checkbox Aggiorna abilita la visualizzazione e causa l’immediato aggiornamento della vista mappa.

Controllare la visibilità dei layer quando sono caricati

Può essere scelta l’opzione di caricare i nuovi layer senza che essi vengano immediatamente resi a video.Ciò significa che quando si aggiungerà un layer al progetto, la casella di controllo per la visibilità nella legendasarà disabilitata di default. Per impostare questa opzione, scegliere l’opzione di menu Impostazioni ‣ Opzioni ‣ e cliccare sulla scheda Visualizzazione in corso. Deselezionare la casella di controllo checkbox Per impostazione predefinita i nuovi layer aggiunti alla mappa vengono visualizzati subito. Ogni layer aggiunto alla mappa sarà quindi spento (invisibile) di default.

Fermare la visualizzazione

Per fermare la visualizzazione della mappa premere il tasto ESC. Si bloccherà cosi l`aggiornamento della vista e la mappa rimarrà parzialmente disegnata. Dopo aver premuto il tasto ESC potrebbe passare un po` di tempo affinchè l`interruzione della visualizzazione della mappa sia effettiva.

Nota

Al momento non è possibile interrompere la visualizzazione in corso: questa opzione è stata disabilitata nella porta qt4 a causa di diversi problemi dell`interfaccia utente (UI).

Aggiornamento della mappa durante la visualizzazione

Può essere impostata un’opzione per aggiornare la mappa man mano che gli elementi del layer vengono letti. Di default QGIS non traccia alcun elemento a video fino a che l’intero layer non sia stato letto. Per aggiornare la visualizzazione man mano che gli elementi vengono letti dall’archivio, selezionare la voce di menu Impostazioni‣ Opzioni ‣ e cliccare sulla scheda Visualizzazione in corso. Impostare il numero di elementi che si desidera vengano letti prima che lo schermo venga aggiornato. Un valore pari a 0 disabilita l’aggiornamento durante il disegno degli oggetti (impostazione predefinita). Un valore troppo basso diminuisce le prestazioni in quanto la mappa viene continuamente aggiornata man mano che gli elementi del layer vengono letti. Un valore suggerito è 500.

Modificare la qualità della visualizzazione

Vi sono due opzioni per modificare la qualità della visualizzazione. Dal menu Impostazione ‣ Opzioni ‣ cliccare sulla scheda Visualizzazione in corso e selezionare o deselezionare le seguenti caselle di controllo.

  • checkbox Rendi le linee meno irregolari a spese delle prestazioni

  • checkbox Risolvi problemi con i poligoni riempiti non correttamente

Misurazioni

È possibile effettuare misure unicamente nei sistemi di coordinate piane (es. UTM). Se la mappa caricata è definita in un sistema di coordinate geografiche (es. latitudine/longitudine), il risultato della misura di linee o di aree sarà errato. Per misurare è quindi necessario impostare correttamente il sistema di coordinate della mappa (si veda la Sezione Lavorare con le proiezioni). Tutti i moduli di misura usano inoltre le opzioni di snapping del modulo di digitalizzazione. Questo è utile se si desidera misurare lungo linee o aree di layer vettoriali.

Per selezionare uno strumento di misura cliccare su mActionMeasure e scegliere lo strumento che si intende utilizzare.

Misurare lunghezze, aree ed angoli

mActionMeasure QGIS è in grado di fornire la misura della distanza reale tra due punti in funzione di uno specifico ellissoide. Ciò può essere configurato con l’opzione di menu Impostazioni ‣ Opzioni ‣ cliccando sulla scheda Strumenti mappa e scegliendo l’ellissoide appropriato. Qui sarà possibile definire il colore elastico e l’unità di misura preferita (metri o piedi). Lo strumento consentirà allora di cliccare punti sulla mappa: la misura di ogni segmento verrà mostrata nella finestra dello strumento insieme alla misura totale. Per terminare la misura cliccare con il tasto destro del mouse.

Figure Measure 1:

../../../_images/measure_line.png

Measure Distance nix (KDE)

mActionMeasureArea Questo strumento consente di misurare aree; la finestra mostrerà unicamente l’area totale misurata.In aggiunta, lo strumento di misura farà lo snap sul layer selezionato al momento, nel caso il layer abbia definita la sua tolleranza di snap (Sezione Settare la tolleranza dello snapping e il raggio di ricerca degli elementi). Se, quindi, si vuole misurare esattamente lungo una linea o un poligono è necessario prima definire la tolleranza di snap, poi selezionare il layer. In questo modo, quando vengono usati gli strumenti di misura, ogni click del mouse (all’interno della tolleranza definita) si aggancerà a quel layer.

Figure Measure 2:

../../../_images/measure_area.png

Measure Area nix (KDE)

mActionMeasureAngle È possibile misurare angoli tramite lo strumento Misura angoli. Cliccare e disegnare il primo segmento dell’angolo, poi spostare il mouse per disegnare l’angolo stesso; la misura apparirà in una finestra popup.

Figure Measure 3:

../../../_images/measure_angle.png

Measure Angle nix (KDE)

Selezionare e deselezionare elementi

QGIS fornisce diversi strumenti per la selezione di elementi nella vista mappa. Per selezionare uno o più elementi cliccare mActionSelect e scegliere lo strumento di interesse:

  • mActionSelect Seleziona il singolo elemento

  • mActionSelectRectangle Seleziona elementi con un rettangolo

  • mActionSelectPolygon Seleziona elementi con un poligono

  • mActionSelectFreehand Seleziona elementi a mano libera

  • mActionSelectRadius Seleziona elementi con un cerchio

Per deselezionare tutti gli elementi selezionati cliccare su mActionDeselectAll Deselect features from all layers.

Decorazioni

Le decorazioni includono l`Etichetta Copyright, la Freccia Nord e la Barra di scala. Sono usati per decorare la mappa aggiungendo elementi cartografici.

Nota

Prima di QGIS 1.8 le stesse funzionalità erano fornite dal Plugin Decorazione.

Freccia Nord

north_arrow North Arrow aggiunge alla mappa una semplice freccia indicante il nord. Al momento c’è un solo stile disponibile. Si può modificare manualmente l’angolo della freccia o lasciare che QGIS imposti automaticamente la direzione. Per il posizionamento della freccia si hanno quattro possibilità, corrispondenti ai quattro angoli della mappa.

Figure Decorations 2:

../../../_images/north_arrow_dialog.png

The North Arrow Dialog nix

Barra di Scala

scale_bar Scale Bar aggiunge una semplice barra di scala alla mappa. Si può controllare lo stile ed il posizionamento, come anche l’etichettatura della scala.

Figure Decorations 3:

../../../_images/scale_bar_dialog.png

The Scale Bar Dialog nix

QGIS supporta solamente la visualizzazione della scala nella stessa unità di misura della mappa. Se l’unità di misura dei layer è il metro, non si può creare una barra di scala in piedi. Allo stesso modo, se si usano gradi decimali, non si può creare una barra di scala che mostri le distanze in metri.

Per aggiungere una barra di scala:

  1. Selezionare dal menu Visualizzazione ‣ Decorazioni‣ Barra di scale. Si aprirà cosi una finestra di dialogo (see figure_decorations_3)

  2. Scegliere il posizionamento dal menu a tendina Posizionamento In basso a sinistra

  3. Scegliere lo stile dalla lista Stile della Barra di Scala Porta in basso

  4. Scegliere il colore della barra di scala Colore della barra black o usare il colore nero di default

  5. Impostare la dimensione della barra e la sua etichetta Dimensione della barra 30 gradi

  6. Assicurarsi che la casella di controllo checkbox Abilitare barra di scala sia selezionata

  7. Se si vuole, scegliere di arrotondare automaticamente il numero quando la mappa viene ridimensionata checkbox Arrotonda automaticamente il numero durante il ridimensionamento

  8. Cliccare [OK]

Suggerimento

Impostazioni delle decorazioni

Quando si salva un progetto .qgs, ogni impostazione relativa alle decorazioni viene salvata nello stesso progetto e ripristinata alla successiva apertura del file .qgs.

Note testuali

Lo strumento mActionTextAnnotation note nella barra degli attributi permette di posizionare del testo formattato sulla vista mappa di QGIS. Scegliere lo strumento note e cliccare nella vista mappa.

Figure annotation 1:

../../../_images/annotation.png

Annotation text dialog nix

Facendo doppio-click sull’elemento aggiunto sulla mappa dallo strumento note si ha accesso ad una finestra di dialogo con varie opzioni. C’è un editor di testo semplificato per l’inserimento del testo formattato; è possibile scegliere se vincolare il testo alla mappa o solo allo schermo.

Il testo può essere spostato secondo le proprie esigenze tramite lo strumento mActionFormAnnotation muovi nota.

Nota con modulo

È possibile creare moduli note personalizzati. Lo strumento mActionFormAnnotation Note con modulo è utile per visualizzare gli attributi di un layer vettoriale in un modulo personalizzato qt designer(Figura figure_custom_annotation). È simile alla finestra dello strumento ’Informazioni elementi’, ma il tutto viene mostrato in una nota. Si veda il blog http://blog.qgis.org/node/143 per maggiori dettagli.

Figure annotation 2:

../../../_images/custom_annotation.png

Customized qt designer annotation form nix

Nota

Nota: Premendo Ctrl+T con uno strumento nota attivo (Nota testuale, Nota con modulo, Muovi nota) lo stato di visualizzazione delle note si inverte: se sono visibili diventano invisibili e viceversa.

Segnalibri geospaziali

I segnalibri geospaziali consentono di memorizzare una posizione geografica alla quale ritornare in un secondo momento.

Creazione di un segnalibro

Per creare un segnalibro:

  1. Usare lo zoom o muovere la mappa all’estensione d’interesse.

  2. Selezionare la voce di menu Visualizza‣ Nuovo segnalibro‣ oppure premere Ctrl-B.

  3. Inserire un nome descrittivo per il segnalibro (fino a 255 caratteri).

  4. Cliccare su [OK] per aggiungere il segnalibro o [Close] per uscire senza aggiungere il segnalibro.

Si noti che è possibile avere più di un segnalibro con lo stesso nome.

Uso e gestione dei segnalibri

Per usare o gestire i segnalibri, selezionare la voce di menu Visualizza‣ Mostra segnalibri ‣. La finestra Segnalibri geospaziali consente di usare lo zoom a un segnalibro o di eliminarne uno. Non è possibile editare il nome o le coordinate di un segnalibro.

Zoom a un segnalibro

Dalla finestra Segnalibri geospaziali, selezionare il segnalibro desiderato cliccando su di esso, quindi cliccare su [Zoom A]. Si può usare lo zoom su un segnalibro anche facendo doppio click su di esso.

Cancellare un segnalibro

Per cancellare un segnalibro dalla finestra Segnalibri geospaziali, cliccare su di esso e poi sul pulsante [Elimina]. Confermare la scelta cliccando su [OK] o annullare l’eliminazione cliccando su [Close].

Progetti nidificati

Per includere file di progetti diversi all`interno del proprio progetto, scegliere Layer ‣ Includi layer e gruppi ‣.

Layers inclusi

La finestra di dialogo permette di scegliere quali layer di altri progetti includere:

  1. Scegliere browsebutton per cercare un altro progetto del dataset Alaska.

  2. Selezionare il file progetto grassland. E` possibile vedere il contenuto del progetto (Figura figure_embed_dialog).

  3. Premere Ctrl e cliccare sui layer grassland e regioni. I layers sono aggiunti sia nella legenda che nella vista della mappa.

Figure Nesting 1:

../../../_images/embed_dialog.png

Select layers and groups to embed nix

Non si possono modificare le proprietà, come stile e etichette, dei layers aggiunti.

Eliminare i layers

Cliccare con il tasto destro sul layer aggiunto e scegliere mActionRemoveLayer Rimuovi.