Überblick über das Drucklayout

Das Drucklayout stellt immer mehr Layout- und Druckfunktionen bereit. Es ermöglicht es Ihnen, Elemente wie die QGIS Kartenanzeige, Beschriftungen, Legenden, Maßstäbe, Grundformen, Pfeile, Attributtabellen und HTML-Rahmen hinzuzufügen. Sie können bei jedem Element die Größe verändern, es gruppieren, ausrichten und positionieren als auch die Eigenschaften anpassen um Ihr Layout zu erstellen. Das Layout kann gedruckt oder in Bildformate, PostScript, PDF oder SVG (der Export in SVG funktioniert nicht mit einigen aktuellen Qt4 Versionen, Sie sollten dies individuell an Ihrem System ausprobieren) exportiert werden. Sie können das Layout als Vorlage speichern und es wieder in anderen Sitzungen laden. Schließlich kann das Erstellen mehrerer Karten basierend auf einer Vorlage mit der Atlaserzeugung durchgeführt werden. Sie finden eine Liste von Tools in table_composer_1_:

Ein erstes Übungsbeispiel

Bevor Sie mit dem Drucklayout anfangen zu arbeiten, müssen Sie einige Raster- oder Vektorlayer in das QGIS Kartenfenster laden und deren Eigenschaften Ihren Wünschen anpassen. Wenn alles nach Ihren Wünschen dargestellt und symbolisiert ist, klicken Sie das auf die Schaltfläche |newComposer| Neues Drucklayout in der Werkzeugleiste oder wählen Sie Projekt ‣ Neues Drucklayout. Sie werden aufgefordert einen Titel für das neue Layout auszuwählen.

Um zu zeigen wie man eine Karte erstellt folgen Sie den nächsten Anweisungen.

  1. Wählen Sie den addMap Neue Karte hinzufügen Werkzugleistenknopf aus und zeichnen Sie ein Rechteck auf die Seite indem Sie die linke Maustaste gedrückt halten. Innerhalb des gezeichneten Rechteckes erscheint die QGIS Kartenansicht auf der Seite.
  2. Wählen Sie die Schaltfläche scaleBar Neuen Maßstab hinzufügen in der Werkzeugleiste und klicken Sie mit links in die Zeichenfläche der Druckzusammenstellung. Der Zeichenfläche wird ein Maßstab hinzugefügt.
  3. Wähllen Sie den addLegend Neue Legende hinzufügen Werkzeugleistenknopf und zeichnen Sie ein Rechteck auf die Seite indem sie die linke Maustaste gedrückt halten. Innerhalb des Rechtecks wird die Legende gezeichnet.
  4. Wählen Sie das select Den Elementinhalt verschieben Icon um die Karte auszuwählen und verschieben Sie es ein bisschen.
  5. Während das Kartenelement noch ausgewählt ist, können Sie auch seine Größe verändern. Dazu klicken Sie in eins der weißen kleinen Rechtecke in einer der Ecken des Kartenelements, halten Sie die linke Maustaste gedrückt und verschieben Sie das Rechteck an einen neuen Ort.
  6. Klicken Sie den Reiter Elementeigenschaften im linken unteren Bedienfeld und suchen Sie die Einstellung für die Kartendrehung. Ändern Sie den Wert der Einstellung Kartendrehung auf ‚15.00°‘. Sie sollten sehen, wie der Drehwinkel des Kartenelements sich ändert.
  7. Jetzt können Sie Ihr Drucklayout mit den Exportwerkzeugen im Menü Layout ausdrucken oder in ein Bildformat, nach PDF oder SVG exportieren.
  8. Schließlich können Sie Ihr Drucklayout mit der Schaltfläche fileSave Projekt speichern innerhalb der Projektdatei speichern.

Sie können dem Drucklayout mehrere Elemente hinzufügen. Es ist auch möglich, dass es mehr als eine Karten-, Legenden- oder Maßstabselement enthält, und das auf einer oder mehreren Seiten. Jedes Element hat seine eigenen Eigenschaften und, im Fall der Karte, seine eigenen Ausmaße. Wenn Sie ein Element aus der Zusammenstellungsansicht entfernen wollen, können Sie das mit den Tasten Entf oder Rücktaste tun.

Layoutverwaltung

Die Layoutverwaltung ist das Hauptfenster, um Drucklayouts innerhalb des Prohjekts zu verwalten. Sie gibt Ihnen eine Übersicht über die vorhandenen Layouts und Berichte im Projekt und bietet folgende Werkzeuge:

  • ein neues Drucklayout oder einen neuen Bericht auf der Basis der leeren oder einer bestimmten Vorlage erzeugen oder ein bereits vorhandenes duplizieren;
  • eins davon umbenennen oder löschen;
  • sie im Projekt zu öffnen.

So öffnen Sie die Maske Layout-Verwaltung:

  • Im QGIS-Hauptfenster wählen Sie im Menü Project ‣ Layout-Verwaltung… oder klicken Sie auf die Schaltfläche layoutManager Layout-Verwaltung in der Projektwerkzeugleiste;
  • im Drucklayout oder im Berichtsfenster wählen Sie im Menü Layout ‣ Layout-Verwaltung… oder klicken Sie auf die Schaltfläche layoutManager Layouverwaltung in der Layout-Werkzeugleiste.
../../../_images/print_composer_manager.png

Die Layout-Verwaltung

Die Layout-Verwaltung listet im oberen Teil alle im Projekt verfügbaren Drucklayouts oder Berichte auf und bietet folgende Werkzeuge:

  • Anzeigen: Sie können mehrere Drucklayouts und/oder Berichte auswählen und sie mit einem Klick öffnen. Ein Doppelklick auf den Namen öffnet auch;
  • das ausgewählte Drucklayout oder den ausgewählten Bericht duplizieren (setzt voraus, dass ein einzelner Eintrag ist ausgewählt ist): erzeugt ein neues Fenster und benutzt das ausgewählte Element als Vorlage. Sie werden dazu aufgefordert, einen neuen Titel für das Layout zu vergeben;
  • das ausgewählte Drucklayout oder den ausgewählten Bericht umbenennen (setzt voraus, dass ein einzelner Eintrag ist ausgewählt ist): Sie werden dazu aufgefordert, einen neuen Titel für das Layout zu vergeben;
  • das Layout entfernen: das (oder die) ausgewählte(n) Layout(s) wird (werden) aus dem Projekt gelöscht.

Im unteren Teil können Sie neue Drucklayouts oder Berichte erzeugen und dabei eine Vorlage benutzen. In der Voreinstellung wird QGIS die Vorlagen im Nutzerprofil und den Vorlagenverzeichnissen der Anwendung suchen (sie sind mit den beiden Schaltflächen unten im Fenster zugänglich) aber auch in jedem Verzeichnis, das in Einstellungen ‣ Optionen ‣ Layouts als Pfad(e) um nach zusätzlichen Druckvorlagen zu suchen eingetragen wurde. Alle gefundenen Vorlagen werden im Auswahlfeld angezeigt. Wählen Sie eine aus und drücken Sie auf die Schaltfläche Erzeugen…, um einen neuen Bericht oder ein neues Drucklayout zu erzeugen.

Sie können auch Vorlagen aus einem eigenen Verzeichnus benutzen; in diesem Fall wählen Sie Bestimmtes aus dem Auswahlfeld, gehen Sie im Dateisystem zur Vorlage und drücken Sie Erzeugen….

Tipp

So erzeugen Sie Drucklayouts im Bedienfeld Browser aus Vorlagen heraus

Das Einfügen einer Vorlagendatei .qpt per drag and drop aus dem Dateimanager in das Kartenfenster oder ein Doppelklick darauf im Bedienfeld Browser erzeugt ein neues Drucklayout aus der Vorlagendatei.