8.4. Lesson: Exercice Supplémentaire

Dans cette leçon, vous serez guidé à travers une analyse complète de SIG dans QGIS.

Note

Leçon élaborée par Linfiniti Consulting (Afrique du Sud) et Siddique Motala (Université de technologie de la péninsule du Cap)

8.4.1. Énoncé du problème

Vous êtes mandaté pour trouver les aires de la Péninsule du Cap et alentours adaptées à l’accueil d’espèces rares de plante « fynbos ». L’étendue de votre aire d’investigation couvre Cape Town et la péninsule du Cap entre Melkbosstrand au nord et Strand au sud. Les botanistes vous ont fourni les caractéristiques suivantes adaptées aux espèces en question:

  • elle se développe sur les pentes orientées à l’est

  • elle se développe sur des pentes d’inclinaison comprises entre 15% et 60%

  • elle se développe sur des surfaces qui enregistrent un cumul annuel de pluies >1000mm

  • elle devra se situer à au moins 250m de tout aménagement humain

  • la zone de végétation dans laquelle elle se situera, doit être d’au moins 6000 m²

En tant qu’étudiant à l’université, vous avez accepté de rechercher la plante dans quatre zones différentes de terrain approprié. Vous voulez que ces quatre zones soient les plus proches de l’université du Cap où vous vivez. Utilisez vos compétences en SIG pour déterminer où vous devez aller pour chercher.

8.4.2. Aperçu de la solution

Les données de cet exercice se trouvent dans le dossier :file`exercise_data/more_analysis`.

Vous devez trouver les quatre sites adaptés le plus proche de l’Université de Cape Town.

La solution impliquera :

  1. Analyse d’une couche raster MNE pour trouver les pentes orientées à l’est et les pentes avec les gradients corrects

  2. Analyse d’une couche raster des précipitations pour trouver les zones ayant la bonne quantité de pluie

  3. Analyse d’une couche de vecteurs de zonage pour trouver des zones éloignées des établissements humains et de taille correcte

8.4.3. Follow Along: Mise en place de la carte

  1. Cliquez sur le bouton projectionEnabled CRS courant dans le coin inférieur droit de l’écran. Sous l’onglet CRS du dialogue qui apparaît, utilisez l’outil « Filtre » pour rechercher « 33S ». Sélectionnez l’entrée WGS 84 / UTM zone 33S (avec le code EPSG 32733).

  2. Cliquez sur OK

  3. Enregistrez le fichier de projet en cliquant sur le bouton fileSave sauvegarder le projet de la barre d’outils, ou utilisez l’élément de menu Fichier ► Sauvegarder sous….

    Enregistrez-le dans un nouveau répertoire appelé Rasterprac, que vous devez créer quelque part sur votre ordinateur. Vous enregistrerez également les couches que vous aurez créées dans ce répertoire. Enregistrez le projet sous le nom votre_nom_fynbos.qgs.

8.4.4. Chargement de données dans la carte

Afin de traiter les données, vous devrez charger les couches nécessaires (noms des rues, zones, précipitations, MNE, quartiers) dans le canevas de la carte.

8.4.4.1. Pour les données vectorielles…

  1. Cliquez sur le bouton | dataSourceManager | Ouvrir le gestionnaire de sources de données dans la barre d’outils du gestionnaire de sources de données, et activez l’onglet addOgrLayer Vecteur dans la boîte de dialogue qui apparaît, ou utilisez Layer -> Add Layer -> addOgrLayer Ajouter un calque vectoriel …

  2. Assurez-vous que radioButtonOn Fichier est sélectionné

  3. Cliquez sur le bouton pour rechercher le(s) jeu(x) de données vecteur

  4. Dans la boîte de dialogue qui apparaît, ouvrez le répertoire exercise_data/more_analysis/Streets.

  5. Sélectionnez le fichier Street_Names_UTM33S.shp

  6. Cliquer sur Ouvrir.

    Le dialogue se ferme et affiche le dialogue original, avec le chemin d’accès au fichier spécifié dans le champ de texte à côté de jeu de donnees Vecteur. Cela vous permet de vous assurer que le bon fichier est sélectionné. Il est également possible de saisir manuellement le chemin d’accès au fichier dans ce champ, si vous le souhaitez.

  7. Cliquez sur ajouter. La couche vecteur sera chargée dans votre carte. Sa couleur est automatiquement assignée. Vous la changerez plus tard.

  8. Renommez la couche en Streets.

    1. Faites un clic droit dessus dans le panneau couches (par défaut, le panneau situé sur le côté gauche de l’écran)

    2. Cliquez sur renommer dans le dialogue qui apparaît et renommez-le, en appuyant sur la touche entrer lorsque vous avez terminé

  9. Répétez le processus d’ajout de vecteurs, mais cette fois, sélectionnez le fichier Generalised_Zoning_Dissolve_UTM33S.shp dans le répertoire Zoning.

  10. Renommez-le en Zoning.

  11. Chargez également la couche vecteur admin_boundaries/Western_Cape_UTM33S.shp dans votre carte.

  12. Renommez-la en districts.

8.4.4.2. Pour les raster…

  1. Cliquez sur le bouton dataSourceManager ouvrir gestionnaire source donnees et activez l’onglet addRasterLayer Raster dans le dialogue qui apparaît, ou utilisez l’élément de menu couche ► ajouter couche ► addRasterLayer ajouter couche raster….

  2. Assurez-vous que radioButtonOn Fichier est sélectionné

  3. Naviguez vers le fichier approprié, sélectionnez-le et cliquez sur Ouvrir.

  4. Faites-le pour chacun des deux fichiers raster suivants, DEM/SRTM.tif et rainfall/reprojected/rainfall.tif.

  5. Renommez la grille SRTM en DEM et la grille des précipitations en Rainfall (avec une majuscule initiale)

8.4.5. Changement de l’ordre des couches

Cliquez et faites glisser les couches de haut en bas dans le panneau couches pour modifier l’ordre dans lequel elles apparaissent sur la carte afin que vous puissiez voir autant de couches que possible.

Maintenant que toutes les données sont chargées et correctement visibles, l’analyse peut commencer. Il est préférable que l’opération de découpage soit effectuée en premier. De cette façon, aucune puissance de traitement n’est gaspillée pour calculer des valeurs dans des domaines qui ne seront pas utilisés de toute façon.

8.4.6. Trouver les bons districts

En raison du domaine d’investigation susmentionné, nous devons limiter nos districts aux suivants :

  • Bellville

  • Cape

  • Goodwood

  • Kuils River

  • Mitchells Plain

  • Simon Town

  • Wynberg

  1. Cliquez avec le bouton droit de la souris sur la couche Districts dans le panneau Couches.

  2. Dans le menu qui apparaît, sélectionnez l’élément de menu Filtrer…. La boîte de dialogue Constructeur de requêtes apparaît.

  3. Vous allez maintenant construire une requête pour sélectionner uniquement les districts candidats :

    1. Dans la liste des champs, double-cliquez sur le champ NAME_2 pour le faire apparaître dans le champ de texte SQL where clause ci-dessous

    2. Cliquez sur le bouton IN pour l’ajouter à la requête SQL

    3. Ouvrez les parenthèses

    4. Cliquez sur le bouton tous sous la liste (actuellement vide) valeurs.

      Après un court délai, cela remplira la liste valeurs avec les valeurs du champ sélectionné (NAME_2).

    5. Double-cliquez sur la valeur Bellville dans la liste valeurs pour l’ajouter à la requête SQL.

    6. Ajoutez une virgule et double-cliquez pour ajouter le district Cape

    7. Répétez l’étape précédente pour les autres districts

    8. Fermer les parenthèses

      La dernière requête doit être (l’ordre des districts entre parenthèses n’a pas d’importance): :

      "NAME_2" in ('Bellville', 'Cape', 'Goodwood', 'Kuils River',
                   'Mitchells Plain', 'Simon Town', 'Wynberg')
      

      Note

      Vous pouvez également utiliser l’opérateur OR ; la requête ressemblerait à ceci: :

      "NAME_2" = 'Bellville' OR "NAME_2" = 'Cape' OR
      "NAME_2" = 'Goodwood' OR "NAME_2" = 'Kuils River' OR
      "NAME_2" = 'Mitchells Plain' OR "NAME_2" = 'Simon Town' OR
      "NAME_2" = 'Wynberg'
      
    9. Cliquez deux fois sur OK.

      Les districts indiqués sur votre carte sont désormais limités à ceux de la liste ci-dessus.

8.4.7. Couper les rasters

Maintenant que vous avez une aire d’intérêt, vous pouvez couper les rasters de cette aire.

  1. Ouvrez le dialogue de découpage en sélectionnant l’élément de menu Raster ► Extraction ► découper le raster à partir d’une couche de masque…

  2. Dans la liste déroulante couche entree, sélectionnez la couche DEM.

  3. Dans la liste déroulante couche masque, sélectionnez la couche Districts.

  4. Faites défiler vers le bas et spécifiez un emplacement de sortie dans le champ de texte découpé (masque) en cliquant sur le bouton et en choisissant sauvegarder sous un fichier…

    1. Naviguez vers le répertoire Rasterprac.

    2. Entrez un nom de fichier - DEM_clipped.tif

    3. Sauvegarder

  5. Assurez-vous que la case checkbox ouvrir le fichier en sortie après exécution de l’algorithme est cochée

  6. Cliquez sur Exécuter

    Une fois l’opération de découpage terminée, laissez la boîte de dialogue découper le raster à partir d’une couche masque ouverte, afin de pouvoir réutiliser la zone de découpage

  7. Sélectionnez la couche raster Rainfall dans la liste déroulante Couche d’entrée et enregistrez votre sortie sous le nom Rainfall_clipped.tif.

  8. Ne modifiez pas les autres options. Laissez tout comme avant et cliquez sur executer.

  9. Une fois la deuxième opération de découpage terminée, vous pouvez fermer la boîte de dialogue decouper le raster à partir d’une couche masque

  10. Sauvegardez la carte

8.4.7.1. Aligner les raster

Pour notre analyse, nous avons besoin que les rasters aient le même CRS et qu’ils soient alignés.

Nous commençons par modifier la résolution de nos données pluviométriques à 30 mètres (taille du pixel) :

  1. Faites un clic droit sur la couche Rainfall_clipped et sélectionnez Exporter► sauvegarder sous… dans le menu contextuel.

  2. Sous Résolution, réglez les résolutions Horizontale et Verticale à 30 (mètres).

  3. Enregistrez le fichier sous le nom Rainfall30.tif dans rainfall/reprojected (Nom du fichier)

Ensuite, nous alignons le DEM :

  1. Faites un clic droit sur la couche DEM_clipped et sélectionnez Exporter ► Sauvegarder sous… dans le menu contextuel

  2. Pour le CRS, choisissez WGS 84 / UTM zone 33S (code EPSG 32733)

  3. Sous Résolution, réglez les résolutions Horizontale et Verticale à 30 (en mètres).

  4. Sous Etendue, cliquez sur Calculer à partir de la couche et choisissez Rainfall30.

  5. Enregistrez le fichier sous le nom DEM30.tif dans DEM/reprojected (Nom du fichier)

Afin de bien voir ce qu’il se passe, la symbologie des couches doit être changée.

8.4.8. Changement de la symbologie des couches vectorielles

  1. Dans le panneau Couches, faites un clic droit sur la couche Streets.

  2. Sélectionnez Propriétés dans le menu qui apparaît

  3. Passez à l’onglet Symbologie dans la boîte de dialogue qui apparaît

  4. Cliquez sur l’entrée Remplissage dans le widget du haut

  5. Sélectionnez un symbole dans la liste ci-dessous ou fixez-en un nouveau (couleur, transparence, …)

  6. Cliquez sur OK pour fermer la boîte de dialogue Propriétés couche. Cela va changer le rendu de la couche Streets.

  7. Suivez un processus similaire pour la couche Zoning et choisissez une couleur appropriée pour celle-ci

8.4.9. Changement de la symbologie des couches raster

La symbologie des couches raster est quelque peu différente.

  1. Ouvrez le dialogue Propriétés pour la couche raster Rainfall30

  2. Passez à l’onglet Symbologie. Vous remarquerez que ce dialogue est très différent de la version utilisée pour les couches vectorielles.

  3. Développer Paramètres des valeurs min/max

  4. Assurez-vous que le bouton moyenne +/- écart-type est selectionne

  5. Assurez-vous que la valeur dans la case associée est 2.00.

  6. Pour amelioration du contraste, assurez-vous qu’il est écrit etirer jusqu’au MinMax.

  7. Pour Color gradient, changez-le en White to Black.

  8. Cliquez sur OK

    Le raster Rainfall30, si il est visible, doit changer de couleur, ce qui vous permet de voir différentes valeurs de luminosité pour chaque pixel

  9. Répétez ce processus pour la couche DEM30, mais fixez les écarts types utilisés pour l’étirement à 4,00.

8.4.10. Nettoyer la carte.

  1. Supprimez les couches originales Rainfall et DEM, ainsi que Rainfall_clipped et DEM_clipped du panneau couches :

    • Faites un clic-droit sur ces couches et sélectionnez Supprimer.

      Note

      Cela ne va pas supprimer les données de votre périphérique de stockage, cela va seulement l’ôter de votre carte.

  2. Sauvegardez la carte

  3. Vous pouvez maintenant cacher les couches vecteur en décochant la case à côté d’elles dans le panneau couches. Cela accélérera le rendu de la carte et vous fera gagner du temps.

8.4.11. Créer l’ombrage

Afin de créer l’ombrage, vous devrez utiliser un algorithme créé dans ce but.

  1. Dans le panneau couches, assurez-vous que DEM30 est la couche active (c’est-à-dire qu’elle est mise en évidence en ayant été cliquée)

  2. Cliquez sur le menu Raster ► Analyse ► Ombrage… pour ouvrir le dialogue ombrage

  3. Descendez jusqu’à Ombrage et enregistrez la sortie dans votre répertoire Rasterprac sous le nom hillshade.tif.

  4. Assurez-vous que la case checkbox ouvrir le fichier en sortie après exécution de l’algorithme est cochée

  5. Cliquez sur Exécuter

  6. Attendez que le processus se termine.

La nouvelle couche hillshade est apparue dans le panneau Couches.

  1. Faites un clic droit sur la couche hillshade dans le panneau Couches” et faites apparaître la fenêtre des :guilabel:`Proprietes

  2. Cliquez sur l’onglet Transparence et réglez le curseur Opacité globale sur 20%.

  3. Cliquez sur OK

  4. Notez l’effet lorsque l’ombre transparente est superposée sur le MNT coupé. Vous devrez peut-être changer l’ordre de vos couches, ou cliquer sur la couche Rainfall30 pour voir l’effet.

8.4.12. Pente

  1. Cliquez sur le menu Raster ► Analyse ► Pente… pour ouvrir le dialogue de l’algorithme Pente

  2. Sélectionnez DEM30 comme Couche d’entrée.

  3. Check checkbox Pente exprimée en pourcentage au lieu de degrés. La pente peut être exprimée en différentes unités (pourcentage ou degrés). Nos critères suggèrent que la plante d’intérêt pousse sur des pentes dont la pente est comprise entre 15 et 60 %. Nous devons donc nous assurer que nos données sur la pente sont exprimées en pourcentage.

  4. Indiquez un nom de fichier et un emplacement appropriés pour votre sortie.

  5. Assurez-vous que la case checkbox ouvrir le fichier en sortie après exécution de l’algorithme est cochée

  6. Cliquez sur Exécuter

L’image de la pente a été calculée et ajoutée à la carte. Comme d’habitude, elle est rendue en niveaux de gris. Changez la symbologie pour une symbologie plus colorée :

  1. Ouvrez la couche Dialogue des propriétés (comme d’habitude, via le menu contextuel de la couche)

  2. Cliquez sur l’onglet Symbologie

  3. Là où il est écrit Bande grise unique (dans le menu déroulant Type de rendu), changez-le en Pseudo-couleur à bande unique.

  4. Choisissez moyenne +/- écart-type x pour parametre valeur Min / Max ` avec une valeur de ``2.0`.

  5. Sélectionnez une rampe de couleurs appropriée

  6. Cliquez sur Exécuter

8.4.13. Try Yourself Aspect

Utilisez la même approche que pour le calcul de la pente, en choisissant Aspect… dans le menu Raster ► analyse.

N’oubliez pas de sauvegarder le projet régulièrement.

8.4.14. Reclassement des rasters

  1. Choisissez Raster ► calculatrice raster…

  2. Indiquez votre répertoire Rasterprac comme emplacement pour la couche Output (cliquez sur le bouton ), et enregistrez-le sous le nom slope15_60.tif.

  3. Assurez-vous que la case ouvrir le fichier sortie après exécution de l’algorithme est sélectionnée.

    Dans la liste bandes raster sur la gauche, vous verrez toutes les couches raster dans votre panneau couches. Si votre couche Pente est appelée slope, elle sera répertoriée comme pente@1. Indication de la bande 1 du raster de pente.

  4. La pente doit être comprise entre 15 et 60 degrés.

    En utilisant les éléments de la liste et les boutons de l’interface, construisez l’expression suivante: :

    (slope@1 > 15) AND (slope@1 < 60)
    
  5. Configurez le champ Couche de sortie avec un emplacement approprié et un nom de fichier.

  6. Cliquez sur Exécuter.

Trouvez maintenant l’aspect correct (face est : entre 45 et 135 degrés) en utilisant la même approche.

  1. Construisez l’expression suivante: :

    (aspect@1 > 45) AND (aspect@1 < 135)
    

Vous saurez que cela a fonctionné lorsque toutes les pentes orientées vers l’est seront blanches dans le raster résulta t (c’est presque comme si elles étaient éclairées par le soleil du matin).

Trouvez de la même manière la bonne pluviométrie (supérieure à 1000 mm). Utilisez l’expression suivante: :

Rainfall30@1 > 1000

Maintenant que vous disposez de ces trois critères, chacun dans une grille distincte, vous devez les combiner pour voir quelles zones répondent à tous les critères. Pour ce faire, les rasters seront multipliés les uns par rapport aux autres. Dans ce cas, tous les pixels qui se chevauchent et qui ont une valeur de 1 conserveront la valeur de 1 (c’est-à-dire que l’emplacement répond aux critères), mais si un pixel de l’un des trois rasters a une valeur de 0 (c’est-à-dire que l’emplacement ne répond pas aux critères), alors il aura une valeur de 0 dans le résultat. De cette façon, le résultat ne contiendra que les zones de chevauchement qui répondent à tous les critères appropriés.

8.4.15. Combiner des rasters

  1. Ouvrez la Calculatrice raster (Raster ► calculatrice raster…)

  2. Construisez l’expression suivante (avec les noms appropriés pour vos couches): :

    [aspect45_135] * [slope15_60] * [rainfall_1000]
    
  3. Définissez l’emplacement de sortie dans le répertoire Rasterprac.

  4. Nommez le raster en sortie : file:aspect_slope_rainfall.tif.

  5. Assurez-vous que la case checkbox ouvrir le fichier après exécution de l’algorithme est cochée

  6. Cliquez sur Exécuter

Le nouveau raster affiche désormais correctement les zones où les trois critères sont satisfaits.

Sauvegardez le projet.

Le prochain critère à remplir est que la zone doit être éloignée de 250 mètres des zones urbaines. Nous satisferons à cette exigence en nous assurant que les zones que nous calculons se trouvent à l’intérieur de zones rurales et qu’elles sont à 250 mètres ou plus de la limite de la zone. C’est pourquoi nous devons d’abord trouver toutes les zones rurales.

8.4.16. Trouver les zones rurales

  1. Cacher toutes les couches dans le panneau couche

  2. Masquer la couche vecteur zoning

  3. Faites un clic droit dessus et faites apparaître la boîte de dialogue table attribut. Notez les nombreuses façons différentes dont la terre est zonée ici. Nous voulons isoler les zones rurales. Fermez la table des attributs.

  4. Faites un clic droit sur la couche Zoning et sélectionnez filtrer… pour faire apparaître le dialogue constructeur de requetes

  5. Construisez la requête suivante: :

    "Gen_Zoning" = 'Rural'
    

    Si vous êtes bloqué, consultez les instructions précédentes.

  6. Cliquez sur OK pour fermer la fenêtre du Constructeur de requêtes. La requête devrait retourner une entité.

Vous devriez voir les polygones ruraux de la couche zoning. Vous devrez les sauvegarder.

  1. Dans le menu du clic droit pour Zoning, sélectionnez Exporter ► Sauvegarder les entités sous….

  2. Enregistrez votre couche dans le répertoire Rasterprac.

  3. Nommez le fichier de sortie : file:rural.shp.

  4. Cliquez sur OK

  5. Sauvegarder le projet

Il faut maintenant exclure les zones qui se trouvent dans un rayon de 250m de la limite des zones rurales. Pour ce faire, il faut créer une zone tampon négative, comme expliqué ci-dessous.

8.4.17. Création d’un tampon négatif

  1. Cliquez sur l’élément de menu vecteur ► outils de geoprocessing ► tampon…

  2. Dans le dialogue qui apparaît, sélectionnez la couche rural comme couche vectorielle d’entrée (:guilabel : sélectionner les entités seulement ne doit pas être coché)

  3. Réglez Distance à -250. La valeur négative signifie que le tampon sera un tampon intérieur. Assurez-vous que les unités sont des mètres dans le menu déroulant.

  4. Check checkbox Dissoudre le résultat.

  5. Dans Buffered, placez le fichier de sortie dans le répertoire Rasterprac, et nommez-le rural_buffer.shp.

  6. Cliquez sur sauver.

  7. Cliquez sur executer et attendez que le traitement soit terminé

  8. Fermez la boîte de dialogue Tampon.

    Assurez-vous que votre tampon a fonctionné correctement en notant en quoi la couche rural_buffer est différente de la couche rural. Vous devrez peut-être changer l’ordre de dessin afin d’observer la différence.

  9. Supprimer la couche rural

  10. Sauvegarder le projet

Maintenant, vous devez combiner votre couche vecteur rural_buffer avec le raster aspect_slope_rainfall. Pour les combiner, nous devrons modifier le format des données de l’une des couches. Dans ce cas, vous vectoriserez le raster, car les couches vecteur sont plus pratiques lorsque nous voulons calculer des surfaces.

8.4.18. Vectoriser le raster

  1. Cliquez sur l’élément de menu Raster ► Conversion ► Polygoniser (Raster to Vector)…

  2. Sélectionnez le raster aspect_slope_rainfall comme Couche d’entrée.

  3. Définissez Nom du champ à créer`à ``suitable` (le nom du champ par défaut est DN - Digital number data)

  4. Sauvegardez le résultat. Sous vectorisé, sélectionnez sauvegarder fichier sous. Définissez l’emplacement à Rasterprac et nommez le fichier aspect_slope_rainfall_all.shp.

  5. Assurez-vous que la case checkbox ouvrir le fichier après exécution de l’algorithme est cochée

  6. Cliquez sur Exécuter

  7. Fermer le dialogue lorsque le traitement est terminé

Toutes les zones raster ont été vectorisées, vous devez donc sélectionner uniquement les zones qui ont une valeur de 1 dans le champ suitable. (Nombre numérique).

  1. Ouvrez le dialogue constructeur requete (clic droit - Filtre…) pour la nouvelle couche vecteur

  2. Construisez cette requête : :

    "suitable" = 1
    
  3. Cliquez sur OK

  4. Après vous être assuré que la requête est complète (et que seules les zones qui répondent aux trois critères, c’est-à-dire avec une valeur de 1, sont visibles), créez un nouveau fichier vecteur à partir des résultats, en utilisant la commande Exporter –> Sauvegarder les entités sous… dans le menu contextuel de la couche

  5. Enregistrez le fichier dans le répertoire Rasterprac.

  6. Nommez le fichier aspect_slope_rainfall_1.shp

  7. Supprimez la couche aspect_slope_rainfall_all de votre carte

  8. Sauvegardez votre projet

Lorsque nous utilisons un algorithme pour vectoriser raster, l’algorithme produit parfois ce que l’on appelle des « géométries non valides », c’est-à-dire qu’il y a des polygones vides, ou des polygones comportant des erreurs, qui seront difficiles à analyser à l’avenir. Nous devons donc utiliser l’outil « reparer géométrie ».

8.4.19. reparer géométrie

  1. Dans la la boite a outil traitement, cherchez « reparer geometries », et l’executer…

  2. Pour la Couche d’entrée, sélectionnez aspect_slope_rainfall_1

  3. Sous reparer geometries, sélectionnez sauveharder fichier sous, et enregistrez la sortie dans Rasterprac et nommez le fichier fixed_aspect_slope_rainfall.shp.

  4. Assurez-vous que la case checkbox ouvrir le fichier après exécution de l’algorithme est cochée

  5. Cliquez sur Exécuter

  6. Fermer le dialogue lorsque le traitement est terminé

Maintenant que vous avez vectorisé le raster et fixé la géométrie résultante, vous pouvez combiner les critères d’aspect, de pente et de précipitations avec la distance par rapport aux critères d’établissement humain en trouvant l’intersection de la couche fixed_aspect_slope_rainfall et de la couche rural_buffer.

8.4.20. Déterminer l’intersection des vecteurs

  1. Cliquez sur l’élément de menu vecteur ► outils géoprocessing ► Intersection…

  2. Dans le dialogue qui apparaît, sélectionnez la couche rural_buffer comme Couche d’entrée

  3. Pour la couche Overlay, sélectionnez la couche fixed_aspect_slope_rainfall.

  4. Dans Intersection, placez le fichier de sortie dans le répertoire Rasterprac.

  5. Nommez le fichier de sortie rural_aspect_slope_rainfall.shp

  6. Cliquez sur sauver.

  7. Cliquez sur executer et attendez que le traitement soit terminé

  8. Fermez le dialogue Intersection.

    Assurez-vous que votre intersection a fonctionné correctement en notant que seules les zones de chevauchement subsistent.

  9. Sauvegarder le projet

Le prochain critère de la liste est que la zone doit être supérieure à 6000 ㎡. Vous allez maintenant calculer les zones de polygone afin d’identifier les zones qui ont la taille appropriée pour ce projet.

8.4.21. Calcul de l’aire pour chaque polygone

  1. Ouvrez le menu contextuel de la nouvelle couche vecteur

  2. Sélectionnez ouvrir la table attributs.

  3. Cliquez sur le bouton toggleEditing basculer mode edition ` dans le coin supérieur gauche de la table, ou appuyez sur :kbd:`Ctrl+e.

  4. Cliquez sur le bouton calculateField ouvrir calculateur de champ dans la barre d’outils en haut de la table, ou appuyez sur Ctrl+i.

  5. Dans la boîte de dialogue qui apparaît, assurez-vous que la case checkbox créer un nouveau champ est cochée, et définissez le nom du champ en sortie à area Le type de champ de sortie doit être un nombre décimal (réel). Définissez Precision à 1 (une décimale).

  6. Dans la zone Expression, tapez: :

    $area
    

    Cela signifie que le calculateur de terrain va calculer l’aire de chaque polygone dans la couche vectorielle et va ensuite remplir une nouvelle colonne d’entier (appelée area) avec la valeur calculée.

  7. Cliquez sur OK

  8. Faites la même chose pour un autre nouveau champ appelé id. Dans Expression de la calculatrice de champ, tapez: :

    $id
    

    Cela garantit que chaque polygone a un identifiant unique à des fins d’identification.

  9. Cliquez sur toggleEditing basculer mode édition à nouveau, et enregistrez vos modifications si vous y êtes invité

8.4.22. Sélection des aires d’une taille donnée

Maintenant que les aires sont connues :

  1. Construisez une requête (comme d’habitude) pour sélectionner uniquement les polygones qui sont plus grands que 6000 ㎡. La requête est: :

    "area" > 6000
    
  2. Enregistrez la sélection dans le répertoire Rasterprac comme une nouvelle couche vecteur appelée suitable_areas.shp.

Vous disposez maintenant des zones appropriées qui répondent à tous les critères d’habitat pour la plante rare qu’est le fynbos, parmi lesquelles vous choisirez les quatre zones les plus proches de l’Université du Cap.

8.4.23. Numériser l’Université du Cap

  1. Créer une nouvelle couche vecteur dans le répertoire Rasterprac comme précédemment, mais cette fois, utiliser Point comme type geometrie et la nommer university.shp.

  2. Assurez-vous qu’il se trouve dans le CRS correct (Project CRS:EPSG:32733 - WGS 84 / UTM zone 33S)

  3. Terminez la création de la nouvelle couche (cliquez sur OK)

  4. Cachez toutes les couches sauf la nouvelle couche university et la couche Streets.

  5. Ajouter un fond de carte (OSM) :

    1. Allez dans le panneau navigateur et naviguez jusqu’à tuiles XYZ ► OpenStreetMap.

    2. Glissez et déposez l’entrée OpenStreetMap au bas du panneau couches

    À l’aide de votre navigateur Internet, recherchez l’emplacement de l’université du Cap. Compte tenu de la topographie unique du Cap, l’université se trouve dans un endroit très reconnaissable. Avant de retourner à QGIS, prenez note de l’endroit où se trouve l’université et de ce qui se trouve à proximité.

  6. Assurez-vous que la couche Streets a été cliquée et que la couche University est en surbrillance dans le panneau couches

  7. Allez dans le menu vue ► barres outils et assurez-vous que numerisation est sélectionné. Vous devriez alors voir une icône de barre d’outils avec un crayon (toggleEditing basculer mode edition). C’est le bouton basculer mode edition.

  8. Cliquez sur le bouton basculer en mode édition pour entrer dans le mode edition. Cela vous permet d’éditer une couche vecteur

  9. Cliquez sur le bouton capturePoint ajouter un point, qui doit se trouver à proximité du bouton toggleEditing basculer mode edition.

  10. Lorsque l’outil Ajouter une entité est activé, cliquez avec le bouton gauche de la souris sur votre meilleure estimation de l’emplacement de l’université du Cap

  11. Fournir un nombre entier arbitraire lorsqu’on demande l “ id.

  12. Cliquez sur OK

  13. Cliquez sur le bouton saveEdits sauver modif.

  14. Cliquez sur le bouton basculer en mode edition pour arrêter votre session d’édition

  15. Sauvegarder le projet

8.4.24. Trouvez les lieux les plus proches de l’Université du Cap

  1. Allez dans la Boîte à outils de traitement, localisez l’algorithme Joindre les attributs par le plus proche (Outils généraux pour les vecteurs ► Joindre les attributs par le plus proche) et exécutez-le

  2. Couche d’entrée devrait être university, et Couche d’entrée 2` suitable_areas.

  3. Définir un emplacement et un nom de sortie appropriés (Joined layer)

  4. Réglez le Maximum des plus proches voisins à 4.

  5. Assurez-vous que la case checkbox ouvrir le fichier après exécution de l’algorithme est cochée

  6. Laissez les autres paramètres avec leurs valeurs par défaut

  7. Cliquez sur Exécuter

La couche de points qui en résultera contiendra quatre entités - elles auront toutes l’emplacement de l’université et ses attributs, et en plus, les attributs des zones appropriées à proximité (y compris l”id), et la distance à cet emplacement.

  1. Ouvrez la table d’attributs du résultat de la jointure

  2. Notez l”id des quatre zones appropriées les plus proches, puis fermez la table d’attributs

  3. Ouvrez la table d’attributs de la couche Suitable_areas

  4. Construire une requête pour sélectionner les quatre zones appropriées les plus proches de l’université (en les sélectionnant à l’aide du champ id)

C’est la réponse finale à la question de recherche.

Pour votre soumission, créez une mise en page entièrement étiquetée qui inclut la couche semi-transparente « hillshade » sur un raster attrayant de votre choix (comme le DEM ou le raster de pente, par exemple). Incluez également l’université et la couche suitable_areas, avec les quatre zones appropriées les plus proches de l’université mises en évidence. Suivez toutes les bonnes pratiques en matière de cartographie pour créer votre carte de sortie.