8.4. Lesson: Ejercicio Suplementario

En esta lección, serás guiado a través de un análisis SIG completo en QGIS.

Nota

Lección desarrollada por Linfiniti Consulting (África del Sur) y Siddique Motala (Universidad de Tecnología de la Península del Cabo)

8.4.1. Planteamiento del Problema

Tiene la tarea de encontrar áreas dentro y alrededor de la Península del Cabo que sean hábitats adecuados para una especie de planta rara de fynbos. El alcance de su área de investigación cubre Ciudad del Cabo y la Península del Cabo entre Melkbosstrand en el norte y Strand en el sur. Los botánicos le han proporcionado las siguientes preferencias mostradas por la especie en cuestión:

  • Crece en la cara este de pendientes

  • Crece en pendientes con un gradiente entre 15% y 60%

  • Crece en áreas que tienen una lluvia anual >1000 mm

  • Solo será encontrada a al menos 250 m de cualquier asentamiento humano

  • El área de vegetación en la cuál se dá debe ser al menos de 6000 ㎡

Como estudiante de la Universidad, ha aceptado buscar la planta en cuatro áreas de terreno adecuadas diferentes. Desea que esas cuatro áreas adecuadas sean las más cercanas a la Universidad de Ciudad del Cabo donde vive. Utilice sus habilidades de SIG para determinar dónde debe ir a buscar.

8.4.2. Esquema de la Solución

Los datos para este ejercicio puede encontrarse en la carpeta exercise_data/more_analysis.

Va a encontrar las cuatro áreas adecuadas que están más cercanas a la Universidad de Ciudad del Cabo.

La solución implicará:

  1. Analizar una capa ráster MDE para encontrar las pendientes orientadas al este y las pendientes con los gradientes correctos

  2. Analizar una capa rásrter de lluvia para encontrar las áreas con la cantidad correcta de lluvia

  3. Analizar una capa vectorial con zonas donde encontrar áreas que estén alejadas de los asentamientos humanos y que tengan el tamaño correcto.

8.4.3. Follow Along: Configurar el mapa

  1. Click en el botón projectionEnabled SRC actual en la esquina inferior derecha de la pantalla. En la pestaña SRC del diálogo que aparece, usa la herramienta «Filtrar» para buscar «33S». Selecciona la entrada WGS 84 / UTM zone 33S (con código EPSG 32733).

  2. Haga click en Aceptar.

  3. Guarde el archivo de proyectoclickando en el botón de la barra de herramientas fileSave Guardar proyecto , o use el elemento de menú Archivo ► Guardar como….

    Guárdelo en un nuevo directorio llamado Rasterprac, que debe crear en algún lugar de su computadora. También guardará las capas que cree en este directorio. Guarda el proyecto como your_name_fynbos.qgs.

8.4.4. Cargar Datos dentro del Mapa

Para procesar los datos, deberá cargar las capas necesarias (nombres de calles, zonas, precipitaciones, MDE, distritos) en el lienzo del mapa.

8.4.4.1. Para vectores…

  1. Click en el botón dataSourceManager Abrir Administrador de Fuente de datos en la Barra de herramientas de administrador de fuente de datos, y active la pestaña addOgrLayer Vectorial en el diálogo que aparece, o use el elemento de menú Capa ► Añadir capa ► addOgrLayer Añadir capa vectorial…

  2. Asegúrese de que radioButtonOn Archivo está seleccionado

  3. Click en el botón para navegar hasta la base(s) de datos vectorial

  4. En el diálogo que aparece, abre el directorio exercise_data/more_analysis/Streets

  5. Seleccione el archivo Street_Names_UTM33S.shp

  6. Haz clic en Abrir.

    El cuadro de diálogo se cierra y muestra el cuadro de diálogo original, con la ruta del archivo especificada en el campo de texto junto a Conjunto(s) de datos vectoriales. Esto le permite asegurarse de que esté seleccionado el archivo correcto. También es posible ingresar la ruta del archivo en este campo manualmente, si así lo desea.

  7. Haga clic en Añadir. La capa vectorial se cargará en su mapa. Su color se asigna automáticamente. Lo cambiará más tarde.

  8. Renombre la capa a Streets

    1. Click derecho en el panel Capas (de forma predeterminada, el panel a lo largo del lado izquierdo de la pantalla)

    2. Click Renombrar en el diálogo emergente y renómbrela, presionando la tecla Enter cuando termine

  9. Repita el proceso de adición de vectores, pero esta vez seleccione el archivo Generalised_Zoning_Dissolve_UTM33S.shp en el directorio Zoning.

  10. Renómbrelo a Zoning.

  11. Carga tambien la capa vectorial admin_boundaries/Western_Cape_UTM33S.shp en tu mapa.

  12. Renómbrela como Districts.

8.4.4.2. Para rásters…

  1. Click en el botón dataSourceManager Abrir administrador de fuente de datos y habilite la pestaña addRasterLayer Raster en el diálogo emergente, o use el elemento de menú Capa ► Añadir capa ► addRasterLayer Añadir capa ráster…

  2. Asegúrese de que radioButtonOn Archivo está seleccionado

  3. Navegue hasta el archivo apropiado, selecciónelo y haga click en Abrir

  4. Haga esto para cada uno de los siguientes dos archivos ráster, DEM/SRTM.tif y rainfall/reprojected/rainfall.tif

  5. Cambie el nombre del ráster SRTM a DEM y el ráster de lluvia a Rainfall (con una mayúscula inicial)

8.4.5. Cambio de orden de capas

Haga clic y arrastre las capas hacia arriba y hacia abajo en el panel Capas para cambiar el orden en el que aparecen en el mapa para que pueda ver la mayor cantidad de capas posible.

Ahora que todos los datos están cargados y correctamente visibles, puede comenzar el análisis. Es mejor si la operación de recorte se realiza primero. Esto es para que no se desperdicie potencia de procesamiento en el cálculo de valores en áreas que no se van a utilizar de todos modos.

8.4.6. Encuentra los Distritos Correctos

Debido al área de investigación antes mencionada, necesitamos limitar nuestros distritos a los siguientes:

  • Bellville

  • Cape

  • Goodwood

  • Kuils River

  • Mitchells Plain

  • Simon Town

  • Wynberg

  1. Click derecho en la capa Districts en el panel Capas.

  2. En el menú emergente, selecciona el elemento de menú Filtrar…. Aparecerá el diálogo Constructor de consultas.

  3. Ahora creará una consulta para seleccionar solo los distritos candidatos:

    1. En la lista Campos, haga doble clic en el campo NAME_2 para que aparezca en el campo de texto clausula where de SQL abajo

    2. Click en el botón IN para agregarlo a la consulta SQL

    3. Abre los paréntesis

    4. Haga click en el botón Todos debajo de la lista (actualmente vacía) Valores.

      Después de un breve retraso, esto llenará la lista Valores con los valores del campo seleccionado (NAME_2).

    5. Haga doble clic en el valor Bellville en la lista Valores para agregarlo a la consulta SQL.

    6. Añade una coma y doble click para agregar el distrito Cape

    7. Repite el paso anterior para los restantes distritos

    8. Cierra paréntesis

      La consulta final debe ser (el orden de los distritos entre corchetes no importa):

      "NAME_2" in ('Bellville', 'Cape', 'Goodwood', 'Kuils River',
                   'Mitchells Plain', 'Simon Town', 'Wynberg')
      

      Nota

      También puede usar el operador OR; la consulta debería asemejarse a esto:

      "NAME_2" = 'Bellville' OR "NAME_2" = 'Cape' OR
      "NAME_2" = 'Goodwood' OR "NAME_2" = 'Kuils River' OR
      "NAME_2" = 'Mitchells Plain' OR "NAME_2" = 'Simon Town' OR
      "NAME_2" = 'Wynberg'
      
    9. Click dos veces en Aceptar.

      Los distritos que se muestran en su mapa ahora están limitados a los de la lista anterior.

8.4.7. Recorta los Ráster

Ahora que tienes un área de interés, puedes recortar los ráster a esa área.

  1. Abra el diálogo Cortar seleccionando el elemento de menú :menuselectios:`Raster --> Extracción --> Cortar Raster por Capa de Máscara...`

  2. En la lista desplegable Capa de entrada, seleccione la capa DEM

  3. En la lista desplegable Capa de máscara, selecciones la capa Distritos

  4. Desplácese hacia abajo y especifique una ubicación de salida en el campo de texto Cortado (máscara) haciendo clic en el botón y eligiendo Guardar en archivo …

    1. Navegue hasta el directorio Rasterprac

    2. Introduzca un nombre de archivo - DEM_clipped.tif

    3. Guardar

  5. Asegúrese de que checkbox Abrir archivo de salida después de ejecutar el algoritmo está marcado

  6. Click en Ejecutar

    Una vez completada la operación de recorte, deje abierto el cuadro de diálogo Recortar ráster por capa de máscara para poder reutilizar el área de recorte

  7. Seleccione la capa ráster Rainfall en la lista desplegable Capa de entrada y guarde su salida como Rainfall_clipped.tif

  8. No cambie ninguna otra opción. Deje todo igual y haga clic en Ejecutar.

  9. Una vez completada la segunda operación de recorte, puede cerrar el cuadro de diálogo Recortar ráster por capa de máscara

  10. Guarde el mapa

8.4.7.1. Alinear los rásters

Para nuestro análisis, necesitamos que los rásteres tengan el mismo SRC y que estén alineados.

Primero cambiamos la resolución de nuestros datos de lluvia a 30 metros (tamaño de píxel):

  1. Haga clic con el botón derecho en la capa Rainfall_clipped y seleccione :menuselection:`Exportar -> Guardar como… ` en el menú contextual.

  2. En Resolución, establezca resoluciones Horizontal y Vertical a 30 (metros).

  3. Guarde el archivo como Rainfall30.tif en rainfall/reprojected (File name)

Entonces nosotros alineamos el DEM:

  1. Haga clic con el botón derecho en la capa DEM_clipped y seleccione :menuselection:`Exportar -> Guardar como… ` en el menú contextual

  2. Para SRC, elija WGS 84 / UTM zone 33S (código EPSG 32733)

  3. En Resolución, establezca las resoluciones Horizontal y Vertical a 30 (en metros).

  4. En Extensión, click en Calcular desde capa y elija Rainfall30

  5. Guarde el archivo como DEM30.tif en DEM / reprojected (Nombre de archivo)

Para ver correctamente qué está pasando, se necesita cambiar la simbología para las capas.

8.4.8. Cambio de simbología de capas vectoriales

  1. En el panel Capas, click derecho en la capa Streets

  2. Seleccione Propiedades del menú emergente

  3. Cambie a la pestaña Simbología en el diálogo emergente

  4. Click en la entrada :guilabel:`Fill`en la parte superior del control

  5. Seleccione un símbolo en la lista a continuación o establezca uno nuevo (color, transparencia, …)

  6. Click en Aceptar para cerrar el cuadro de diálogo Propiedades de Capa. Esto cambiará la representación de la capa Streets.

  7. Siga un proceso similar para la capa Zoning y elija un color apropiado para ella

8.4.9. Cambio de simbología de capas ráster

La simbología de capas ráster es algo diferente.

  1. Abre el diálogo Propiedades para la capa ráster Rainfall30

  2. Cambie a la pestaña Simbología. Notarás que este diálogo es muy diferente de la versión utilizada para las capas vectoriales.

  3. Expande Configuración de valores Min/Max

  4. Asegúrate de que el botón Media +/- desviación estándar está seleccionado

  5. Asegúrate de que el valor en el cuadro asociado sea 2.00

  6. Para Mejora de Contraste, asegúrate que dice Estirar a MinMax

  7. Para gradiente de Color, cámbielo a Blanco a Negro

  8. Haga click en Aceptar.

    El ráster Rainfall30, si está visible, debe cambiar de color, lo que le permite ver diferentes valores de brillo para cada píxel

  9. Repita este proceso para la capa DEM30, pero establezca las desviaciones estándar utilizadas para el estiramiento en 4,00

8.4.10. Limpia el mapa

  1. Borre las capas Rainfall y DEM, así como Rainfall_clipped y DEM_clipped del panel de Capas:

    • Haz clic derecho en esas capas y selecciona Eliminar.

      Nota

      Esto no borrará los datos de tu dispositivo de almacenamiento, solamente los quitará de tu mapa.

  2. Guarde el mapa

  3. Ahora puede ocultar las capas vectoriales desmarcando la casilla junto a ellas en el panel Capas. Esto hará que el mapa se procese más rápido y le ahorrará algo de tiempo.

8.4.11. Crear el sombreado del relieve

Para crear el sombreado, necesitará usar un algoritmo que fue escrito para este propósito.

  1. En el panel Capas, asegúrese de que DEM30 es la capa activa (es decir, está resaltada al hacer clic en ella)

  2. Click en el elemento de menú Raster ► Análisis ► Sombreado… para abrir el diálogo Sombreado

  3. Desplácese hacia abajo hasta Sombreado y guarde la salida en su directorio Rasterprac como hillshade.tif

  4. Asegúrese de que checkbox Abrir archivo de salida después de ejecutar el algoritmo está marcado

  5. Click en Ejecutar

  6. Espera a que termine de procesar.

La nueva capa hillshade ha aparecido en el panel Capas.

  1. Click derecho en la capa hillshade en el panel Capas y trae el diálogo Propiedades

  2. Click en la pestaña Transparencia y ajuste el control deslizante Opacidad Global a 20%

  3. Haga click en Aceptar.

  4. Observe el efecto cuando el sombreado transparente se superpone sobre el MDE recortado. Es posible que deba cambiar el orden de sus capas o hacer clic en la capa Rainfall30 para ver el efecto.

8.4.12. Pendiente

  1. Click en el elemento de menú Raster ► Análisis ► Pendiente… para abrir el diálogo del algoritmo Pendiente

  2. Seleccione DEM30 como Capa de entrada

  3. Marque checkbox Pendiente expresada como porcentaje en lugar de grados. La pendiente se puede expresar en diferentes unidades (porcentaje o grados). Nuestros criterios sugieren que la planta de interés crece en pendientes con una pendiente entre el 15% y el 60%. Por lo tanto, debemos asegurarnos de que nuestros datos de pendiente se expresen como un porcentaje.

  4. Especifica un nombre de archivo y localización apropiados para tu salida.

  5. Asegúrese de que checkbox Abrir archivo de salida después de ejecutar el algoritmo está marcado

  6. Click en Ejecutar

La imagen de la pendiente se ha calculado y se ha añadido al mapa. Como de costumbre, se representa en escala de grises. Cambie la simbología por una más colorida:

  1. Abar el diálogo Propiedades de la capa (como es usual, mediante click derecho en el menú de la capa)

  2. Click en la pestaña Simbología

  3. Donde dice gris Monobanda (en el menú desplegable tipo de renderizador), cámbialo a pseudocolor Monobanda

  4. Elige Media +/- desviación estándar x para Configuración de valores Min / Max con un valor de 2.0

  5. Selecciona una Rampa de color adecuada

  6. Click en Ejecutar

8.4.13. Try Yourself Aspecto

Utilice el mismo enfoque que para calcular la pendiente, eligiendo Aspecto… en el menú Raster ► Análisis.

Recuerde grabar el proyecto periodicamente.

8.4.14. Reclasificar rásters

  1. Escoja Ráster ► Calculadora Ráster…

  2. Especifica tu directorio Rasterprac como localización para la Capa de Salida (click en el botón ), y guárdalo como slope15_60.tif

  3. Asegúrate de que checkbox Añadir resultados al proyecto está seleccionado.

    En la lista bandas Ráster a la izquierda, verás todas las capas ráster de su panel Capas. Si tu capa de pendientes se llama slope, será listada como slope@1. Indicando banda1 del ráster de pendiente.

  4. La pendiente necesita estar entre 15 y 60 grados.

    Con los elementos de la lista y los botones de la interfaz, crea la siguiente expresión:

    (slope@1 > 15) AND (slope@1 < 60)
    
  5. Ajusta el campo Capa de salida a un nombre y localización adecuados.

  6. Haz clic en Aceptar.

Ahora encuentra el aspecto adecuado (orientados al este: entre 45 y 135 grados) usando el mismo enfoque.

  1. Construye la siguiente expresión:

    (aspect@1 > 45) AND (aspect@1 < 135)
    

Sabrá que funcionó cuando todas las pendientes orientadas al este sean blancas en el ráster resultante (es casi como si estuvieran iluminadas por la luz del sol de la mañana).

Encuentre la precipitación correcta (superior a 1000 mm) de la misma manera. Utilice la siguiente expresión:

Rainfall30@1 > 1000

Ahora que tiene los tres criterios cada uno en rásteres separados, debe combinarlos para ver qué áreas satisfacen todos los criterios. Para hacerlo, los rásteres se multiplicarán entre sí. Cuando esto sucede, todos los píxeles superpuestos con un valor de 1 conservarán el valor de 1 (es decir, la ubicación cumple con los criterios), pero si un píxel en cualquiera de los tres rásteres tiene el valor de 0 (es decir, la ubicación no cumple con los criterios), entonces el resultado será 0. De esta manera, el resultado contendrá solo las áreas superpuestas que cumplan con todos los criterios apropiados.

8.4.15. Combinación de rásters

  1. Abra la calculadora de ráster (:menuselection:`Ráster –> Calculadora Ráster… )

  2. Construye la siguiente expresión (con los nombres apropiados para sus capas):

    [aspect45_135] * [slope15_60] * [rainfall_1000]
    
  3. Configure la ubicación saliente al directorio Rasterprac

  4. Nombre el ráster saliente como aspect_slope_rainfall.tif

  5. Asegúrate de que checkbox Añadir resultados al proyecto está marcado

  6. Click en Ejecutar

El nuevo ráster ahora muestra correctamente las áreas donde se cumplen los tres criterios.

Guarde el proyecto.

El siguiente criterio que debe cumplirse es que el área debe estar a 250 m de distancia de las áreas urbanas. Satisfaceremos este requisito asegurándonos de que las áreas que calculamos estén dentro de las áreas rurales y que estén a 250 m o más del borde del área. Por lo tanto, primero debemos encontrar todas las áreas rurales.

8.4.16. Encontrar áreas rurales

  1. Oculta todas las capas en el panel de Capas

  2. Visualice la capa vectorial Zoning

  3. Haga clic con el botón derecho del ratón en él y abra el cuadro de diálogo Tabla de Atributos. Tenga en cuenta las diferentes formas en que la tierra se divide en zonas aquí. Queremos aislar las zonas rurales. Cierre la tabla de atributos.

  4. Click derecho en la capa Zoning y selecciona select Filtrar… para llamar al diálogo Constructor de consultas

  5. Construye la siguiente consulta:

    "Gen_Zoning" = 'Rural'
    

    Vea las instrucciones anteriores si se atasca.

  6. Click en Aceptar para cerrar el diálogo Constructor de Consultas. La consulta debería devolver una entidad.

Debería ver los polígonos rurales de la capa Zoning. Deberá guardarlos.

  1. En el menú de click derecho Zoning, selecciona Exportar ► Guardar objetos como….

  2. Guarda tu capa en el directorio Rasterprac

  3. Nombre el archivo saliente como rural.shp

  4. Haga click en Aceptar.

  5. Guarde el proyecto

Ahora debe excluir las áreas que están dentro de los 250 m del borde de las áreas rurales. Haga esto creando un búfer negativo, como se explica a continuación.

8.4.17. Crear un buffer negativo

  1. Click en el elemento de menú Vectorial ► Herramientas de Geoproceso ► Buffer…

  2. En el diálogo emergente, seleccione la capa rural como su capa vectorial de entrada (solo objetos seleccionados no debe estar marcada)

  3. Establecer Distancia a -250. El valor negativo significa que el búfer será un búfer interno. Asegúrese de que las unidades sean metros en el menú desplegable.

  4. Marque checkbox Disolver resultado

  5. En Hecho buffer, ubique el archivo saliente en el directorio Rasterprac, y nómbrelos rural_buffer.shp

  6. Click en Guardar

  7. Click en Ejecutar y esperar a que se complete el procesamiento

  8. Cierra el cuadro de diálogo Buffer.

    Asegúrese de que su búfer funcionó correctamente observando cómo la capa rural_buffer es diferente de la capa rural. Es posible que deba cambiar el orden de dibujo para observar la diferencia.

  9. Borre la capa rural

  10. Guarde el proyecto

Ahora necesita combinar su capa vectorial rural_buffer con el ráster aspect_slope_rainfall. Para combinarlos, necesitaremos cambiar el formato de datos de una de las capas. En este caso, vectorizarás el ráster, ya que las capas vectoriales son más convenientes cuando queremos calcular áreas.

8.4.18. Vectorizar el ráster

  1. Click en el elemento de menú Ráster ► Conversión ► Poligonizar (Ráster a Vectorial)…

  2. Seleccione el archivo ráster aspect_slope_rainfall como capa de entrada

  3. Configure el Nombre del campo a crear a suitable (el nombre predeterminado de campo es DN - dato número Digital)

  4. Guarde la salida. En Vectorizado, seleccione Guardar archivo como. Establece la ubicación en Rasterprac y el nombre del archivo aspect_slope_rainfall_all.shp.

  5. Asegúrate de que checkbox Añadir resultados al proyecto está marcado

  6. Click en Ejecutar

  7. Cierre el diálogo cuando el proceso se complete.

Todas las áreas del ráster se han vectorizado, por lo que debe seleccionar solo las áreas que tienen un valor de 1 en el campo suitable. (Número digital.

  1. Abra el diálogo Contructor de consultas (click derecho - Filtrar…) para la nueva capa vectorial

  2. Construya esta consulta:

    "suitable" = 1
    
  3. Haga click en Aceptar.

  4. Una vez que esté seguro de que la consulta está completa (y solo las áreas que cumplen con los tres criterios, es decir, con un valor de 1 son visibles), cree un nuevo archivo vectorial a partir de los resultados, utilizando :guilabel:`Exportar –> Guardar entidades como… `en el menú contextual de la capa

  5. Guarde el archivo en el directorio Rasterprac

  6. Nombre el archivo aspect_slope_rainfall_1.shp

  7. Borra la capa aspect_slope_rainfall_all de su mapa

  8. Guarde su proyecto

Cuando usamos un algoritmo para vectorizar un ráster, a veces el algoritmo produce lo que se llama «Geometrías no válidas», es decir, hay polígonos vacíos, o polígonos con errores en ellos, que serán difíciles de analizar en el futuro. Entonces, necesitamos usar la herramienta «Corregir geometría».

8.4.19. Corregir geometría

  1. En la Caja de Herramientas de Procesos, busque «Corregir geometrías», y pulse Ejecutar…

  2. Para la capa de entrada, seleccione aspect_slope_rainfall_1

  3. En geometrías corregidas, seleccione Guardar archivo como, guarde la salida en Rasterprac y renombre el archivo como fixed_aspect_slope_rainfall.shp.

  4. Asegúrate de que checkbox Añadir resultados al proyecto está marcado

  5. Click en Ejecutar

  6. Cierre el diálogo cuando el proceso se complete.

Ahora que ha vectorizado el ráster y arreglado la geometría resultante, puede combinar los criterios de orientación, pendiente y lluvia con los criterios de distancia desde el asentamiento humano al encontrar la intersección de la capa fixed_aspect_slope_rainfall y la capa `` rural_buffer``.

8.4.20. Determinación de la intersección vectorial

  1. Click en el elemento de menú Vectorial ► Herramientas de Geoprocesos ► Intersección…

  2. En el diálogo emergente, seleccione la capa rural_buffer como capa de entrada

  3. Para la Capa de superposición, seleccione la capa fixed_aspect_slope_rainfall

  4. En Intersección, ubique el archivo saliente en el directorio Rasterprac

  5. Nombre el archivo saliente rural_aspect_slope_rainfall.shp

  6. Click en Guardar

  7. Click en Ejecutar y esperar a que se complete el procesamiento

  8. Cierre el diálogo Intersección.

    Asegúrese de que su intersección haya funcionado correctamente notando que solo quedan las áreas superpuestas.

  9. Guarde el proyecto

El siguiente criterio en la lista es que el área debe ser mayor que 6000 ㎡. Ahora calculará las áreas poligonales para identificar las áreas que tienen el tamaño apropiado para este proyecto.

8.4.21. Cálgulo del área para cada polígono

  1. Abra la nueva capa vectorial con el menú de click derecho

  2. Seleccione Abrir tabla de atributos

  3. Click en el botón toggleEditing Conmutar el modo edición en la esquina superior izquierda de la tabla, o presionando Ctrl+e

  4. Click en el botón calculateField Abrir calculadora de campo en la barra de herramientas a lo largo de la parte superior de la tabla, o presione Ctrl+i

  5. En el cuadro de diálogo que aparece, asegúrese de que checkbox Crear nuevo campo está marcado, y establece Nombre del campo de salida en area El tipo de campo de salida debe ser un número decimal (real). Establezca Precisión en 1 (un decimal).

  6. En el cuadro Expresión, escribe:

    $area
    

    Esto significa que la calculadora de campo calculará el área de cada polígono en la capa vectorial y luego completará una nueva columna de números enteros (llamada «area») con el valor calculado.

  7. Haga click en Aceptar.

  8. Haga lo mismo para otro campo nuevo llamado «id». En Expresión de calculadora de campo, escriba:

    $id
    

    Eso asegura que cada polígono tiene una ID única para su identificación.

  9. Click de nuevo en toggleEditing Conmutar modo de edición, y guarde sus ediciones si se le solicita

8.4.22. Selección de áreas para un tamaño dado

Ahora que las áreas son conocidas:

  1. Cree una consulta (como de costumbre) para seleccionar solo los polígonos que sean más grandes que 6000 ㎡. La consulta es:

    "area" > 6000
    
  2. Guarde la selección en el: archivo: directorio Rasterprac como una nueva capa vectorial llamada suitable_areas.shp.

Ahora tiene las áreas adecuadas que cumplen con todos los criterios de hábitat para la planta rara fynbos, de la cual seleccionará las cuatro áreas más cercanas a la Universidad de Ciudad del Cabo.

8.4.23. Digitalizar la Universidad de Ciudad del Cabo

  1. Cree una nueva capa vectorial en el directorio Rasterprac como antes, pero esta vez, use Punto como tipo de geometría y asígnele el nombre university.shp

  2. Ensure that it is in the correct CRS (Project CRS:EPSG:32733 - WGS 84 / UTM zone 33S)

  3. Termine de crear la nueva capa (haga clic en Aceptar)

  4. Ocultar todas las capas excepto la nueva capa university y la capa Streets.

  5. Agrega un mapa de fondo (OSM):

    1. Vaya al panel Navegador y navegue hasta XYZ Tiles -> OpenStreetMap

    2. Arrastre y suelte la entrada OpenStreetMap al fondo del panel de Capas

    Usando su navegador de Internet, busque la ubicación de la Universidad de Ciudad del Cabo. Dada la topografía única de Ciudad del Cabo, la universidad se encuentra en una ubicación muy reconocible. Antes de regresar a QGIS, tome nota de dónde se encuentra la universidad y qué hay cerca.

  6. Asegúrate de hacer click en la capa Streets y que la capa university esté resaltada en el panel Capas

  7. Navegue hasta el elemento de menú Ver -> Barras de herramientas y asegúrese de que Digitalización esté seleccionada. A continuación, debería ver un icono de la barra de herramientas con un lápiz (toggleEditing Conmutar edición). Este es el botón Conmutar edición.

  8. Haga clic en el botón Conmutar edición para ingresar al modo de edición. Esto le permite editar una capa vectorial

  9. Click en el botón capturePoint Añadir objeto de punto, el cuál debería estar cerca del botón toggleEditing Conmutar edición

  10. Con la herramienta activada Añadir objeto activada, haga clic con el botón izquierdo en su mejor estimación de la ubicación de la Universidad de Ciudad del Cabo

  11. Proporcione un entero arbitrario cuando se le solicite el id

  12. Haga click en Aceptar.

  13. Click en el botón saveEdits Guardar cambios de la capa

  14. Click en el botón conmutar edición para detener su sesión de edición

  15. Guarde el proyecto

8.4.24. Encontrar las ubicaciones más cercanas a la Universidad de Ciudad del Cabo

  1. Vaya a la Caja de herramientas de procesamiento, busque el algoritmo Unir atributos por cercanía (Vector general -> Unir atributos cercanía) y ejecútelo

  2. Capa de entrada debe ser university, y capa de entrada 2 suitable_areas

  3. Establecer una ubicación y un nombre de salida adecuados (Capa unida)

  4. Configure los Máximo de vecinos mas próximo a 4

  5. Asegúrate de que checkbox Añadir resultados al proyecto está marcado

  6. Deja el resto de parámetros con sus valores predeterminados

  7. Click en Ejecutar

La capa de puntos resultante contendrá cuatro entidades: todas tendrán la ubicación de la universidad y sus atributos, y además, los atributos de las áreas cercanas adecuadas (incluido el id) y la distancia a esa ubicación.

  1. Abra la tabla de atributos del resultado de la unión

  2. Nota la id de las cuatro áreas adecuadas más cercanas y luego cierre la tabla de atributos

  3. Abre la tabla de atributos de la capa suitable_areas

  4. Construya una consulta para seleccionar las cuatro áreas adecuadas más cercanas a la universidad (seleccionándolas usando el campo id)

Esta es la respuesta final a la pregunta investigada.

Para su envío, cree un diseño completamente etiquetado que incluya la capa de sombreado semitransparente sobre un ráster atractivo de su elección (como el DEM o el ráster de pendiente, por ejemplo). Incluya también la universidad y la capa de áreas adecuadas, destacando las cuatro áreas adecuadas más cercanas a la universidad. Siga todas las mejores prácticas para cartografía al crear su mapa de salida.