8.4. Lesson: Extra oefening

In deze les zult u door een volledige analyse in QGIS worden geleid.

Notitie

Les ontwikkeld door Linfiniti Consulting (Zuid-Afrika) en Siddique Motala (Cape Peninsula University of Technology)

8.4.1. Definitie van het probleem

U krijgt de taak om gebieden in en rondom Cape Peninsula te vinden die een geschikte woonomgeving zijn voor een zeldzame fijnbos plantensoort. Het bereik van uw onderzoeksgebied bedekt Kaapstad en de Cape Peninsula tussen Melkbosstrand in het noorden en Strand in het zuiden. Botanisten hebben u voorzien van de volgende voorkeuren voor de betreffende plantensoort:

  • Het groeit op hellingen die uitkijken op het oosten

  • Het groeit op hellingen met een verloop tussen 15% en 60%

  • Het groeit in gebieden die een totale jaarlijkse regenval hebben van > 1000 mm

  • Het kan alleen worden gevonden op een afstand van tenminste 250 m van een menselijke nederzetting

  • Het gebied met vegetatie waarin het voorkomt zou tenminste een omvang moeten hebben van 6000 ㎡

Als student aan de universiteit heeft u er in toegestemd de plant te zoeken op vier verschillende geschikte stukken land vanaf uw. U wilt de vier geschikte gebieden gebruiken die het dichtst bij de Universiteit van Kaapstad zijn, ten opzichte van waar u woont. Gebruik uw vaardigheden in GIS om te bepalen waar u zou moeten zoeken.

8.4.2. Overzicht van de oplossing

De gegevens voor deze oefening zijn te vinden in de map exercise_data/more_analysis.

U gaat de vier meest geschikte gebieden zoeken die het dichtst bij de universiteit van Kaapstad liggen.

De oplossing zal omvatten:

  1. Analyseren van een DEM om de hellingen te zoeken die uitkijken op het oosten en de hellingen met het juiste verloop

  2. Analyseren van een raster voor de regenval om de gebieden te vinden met de juiste hoeveelheid regen

  3. Analyseren van de vectorlaag Zoning om gebieden te vinden die verwijderd liggen van menselijke nederzettingen en van de juiste grootte zijn

8.4.3. Follow Along: Instellen van de kaart

  1. Klik op de knop projectionEnabled Huidig CRS in de uiterste rechterbenedenhoek van het scherm. Gebruikg, onder de tab CRS van het scherm dat verschijnt, het gereedschap “Filter” om te zoeken naar “33S”. Selecteer het item WGS 84 / UTM zone 33S (met EPSG-code 32733).

  2. Klik op OK

  3. Sla het project op door te klikken op de knop op de werkbalk fileSave Project opslaan, of gebruik het menu-item Project ► Opslaan als….

    Sla het op in een nieuwe map genaamd Rasterprac, die u ergens op uw computer zou moeten maken. U zou in die map ook alle lagen die u maakt moeten opslaan. Sla het project op als uw_naam_fynbos.qgs.

8.4.4. Gegevens in de kaart laden

In order to process the data, you will need to load the necessary layers (street names, zones, rainfall, DEM, districts) into the map canvas.

8.4.4.1. Voor vectors…

  1. Klik op de knop dataSourceManager Databronnen beheren openen op de werkbalk Databronnen beheren en schakel naar de tab addOgrLayer Vector in het dialoogvenster dat verschijnt, of gebruik het menuitem Kaartlagen ► Laag toevoegen ► addOgrLayer Vectorlaag toevoegen….

  2. Zorg er voor dat radioButtonOn Bestand is geselecteerd

  3. Klik op de knop om te bladeren naar vector gegevensset(s)

  4. Open, in het dialoogvenster dat verschijnt, de map exercise_data/more_analysis/Streets.

  5. Selecteer het bestand Street_Names_UTM33S.shp

  6. Klik op Openen.

    Het dialoogvenster sluit en geeft het originele dialoogvenster weer, met het bestandspad gespecificeerd in het tekstveld naast Vector databron(nen). Dit stelt u in staat er voor te zorgen dat het juiste bestand is geselecteerd. Het is ook mogelijk het bestandspad handmatig in het veld in te voeren, als u dat zou willen.

  7. Klik op Toevoegen. De vectorlaag zal worden geladen in uw kaart. De kleur ervan wordt automatisch toegewezen. U zult die later wijzigen.

  8. Hernoem de laag naar Streets

    1. Klik er met rechts op in het paneel Lagen (standaard is dat het paneel aan de linkerkant van het scherm)

    2. Klik op Laag hernoemen in het dialoogvenster dat verschijnt en hernoem het, druk op de toets Enter indien gereed

  9. Herhaal het proces van het toevoegen van de vector, maar selecteer deze keer het bestand Generalised_Zoning_Dissolve_UTM33S.shp in de map Zoning.

  10. Hernoem het naar Zoning.

  11. Laad ook de vectorlaag admin_boundaries/Western_Cape_UTM33S.shp in uw kaart.

  12. Hernoem die naar Districts.

8.4.4.2. Voor rasters…

  1. Klik op de knop dataSourceManager Databronnen beheren openen en schakel naar de tab addRasterLayer Raster in het dialoogvenster dat verschijnt, of gebruik het menuitem Kaartlagen ► Laag toevoegen ► addRasterLayer Rasterlaag toevoegen…

  2. Zorg er voor dat radioButtonOn Bestand is geselecteerd

  3. Navigeer naar het toepasselijke bestand, selecteer het en klik op Openen

  4. Doe dit voor elk van de twee rasterbestanden, DEM/SRTM.tif en Rainfall/reprojected/rainfall.tif.

  5. Hernoem het raster SRTM naar DEM en het raster voor de regenval naar Rainfall (met een hoofdletter aan het begin)

8.4.5. Wijzigen van de volgorde van lagen

Klik en sleep de lagen op en neer in het paneel Lagen om de volgorde waarin zij verschijnen op de zodanig dat u zoveel mogelijk lagen kunt zien.

Nu alle gegevens zijn geladen en op de juiste wijze zichtbaar zijn, kan de analyse beginnen. Het is het beste als de bewerking clippen als eerste wordt uitgevoerd. Dit om er voor te zorgen dat er geen verwerkingskracht wordt verspilt in het berekenen van waarden in gebieden die toch niet gebruikt gaan worden.

8.4.6. Zoek naar de juiste districten

Vanwege het eerder vermelde gebied van onderzoek moeten we onze districten beperken tot de volgende:

  • Bellville

  • Cape

  • Goodwood

  • Kuils River

  • Mitchells Plain

  • Simon Town

  • Wynberg

  1. Klik met rechts op de laag Districts in het paneel Lagen.

  2. Selecteer, in het menu dat verschijnt, het menu-item Filteren…. Het dialoogvenster Querybouwer verschijnt.

  3. U zult nu een query gaan bouwen om alleen de kandidaat-districten te selecteren:

    1. Dubbelklik, in de lijst Velden, op het veld NAME_2 om het te laten verschijnen in het tekstveld Provider-specifieke filter-expressie onderin

    2. Klik op de knop IN om het toe te voegen aan de SQL-query

    3. Open de haakjes

    4. Klik op de knop Alles onder de (momenteel lege) lijst Waarden.

      Na korte tijd zal dit de lijst Waarden vullen met de waarden van het geselecteerde veld (NAME_2).

    5. Dubbelklik op de waarde Bellville in de lijst Waarden om die toe te voegen aan de SQL-query.

    6. Voeg een komma toe en dubbelklik om het district Cape toe te voegen

    7. Herhaal de vorige stap voor de resterende districten

    8. Sluit de haakjes

      De uiteindelijke query zou moeten zijn (de volgorde van de districten binnen de haakjes is niet van belang):

      "NAME_2" in ('Bellville', 'Cape', 'Goodwood', 'Kuils River',
                   'Mitchells Plain', 'Simon Town', 'Wynberg')
      

      Notitie

      U zou ook de operator OR kunnen gebruiken, de query zou er dan zo uitzien:

      "NAME_2" = 'Bellville' OR "NAME_2" = 'Cape' OR
      "NAME_2" = 'Goodwood' OR "NAME_2" = 'Kuils River' OR
      "NAME_2" = 'Mitchells Plain' OR "NAME_2" = 'Simon Town' OR
      "NAME_2" = 'Wynberg'
      
    9. Klik twee keer op OK.

      De in uw kaart weergegeven districten beperken zich nu tot die in de lijst hierboven.

8.4.7. Clippen van de rasters

Nu u een beperkt gebied heeft, kunt u de rasters tot dit gebied clippen.

  1. Open het dialoogvenster om te clippen door het menuitem Raster ► Extractie ► Raster op maskerlaag clippen… te selecteren.

  2. Selecteer, in de keuzelijst Invoerlaag, de laag DEM.

  3. Selecteer, in de keuzelijst Maskeerlaag, de laag Districts.

  4. Scroll naar beneden en specificeer een locatie voor de uitvoer in het tekstveld Geclipt (masker) door te klikken op de knop Selecteren… en te kiezen voor. Opslaan als bestand…

    1. Navigeer naar de map Rasterprac

    2. Voer een bestandsnaam in - DEM_clipped.tif

    3. Sla op

  5. Zorg er voor dat het vak Uitvoerbestand openen na uitvoeren algoritme is geselecteerd

  6. Klik op Uitvoeren

    Laat, nadat de bewerking voor het clippen is voltooid, het dialoogvenster Raster op maskerlaag clippen open, om in staat te zijn het geclipte gebied opnieuw te gebruiken

  7. Selecteer de rasterlaag Rainfall in de keuzelijst Invoerlaag en sla uw uitvoer op als Rainfall_clipped.tif

  8. Wijzig geen van de andere opties. Laat alles hetzelfde en klik op Uitvoeren.

  9. Nadat de tweede bewerking om te clippen is voltooid, kunt u het dialoogvenster Raster op maskerlaag clippen sluiten

  10. Sla de kaart op

8.4.7.1. Uitlijnen van de rasters

Voor onze analyse moeten de rasters hetzelfde CRS hebben en moeten zij worden uitgelijnd.

Eerst wijzigen we de resolutie van onze gegevens voor de regenval naar 30 meter (pixelgrootte):

  1. Klik met rechts op de laag Rainfall_clipped en selecteer Exporteren► Opslaan als… in het contextmenu.

  2. Stel, onder Resolutie, de resoluties Horizontaal en Verticaal in op 30 (meter).

  3. Sla het bestand op als Rainfall30.tif in rainfall/reprojected (bestandsnaam)

Daarna lijnen we de DEM uit:

  1. Klik met rechts op de laag DEM_clipped en selecteer Exporteren► Opslaan als… in het contextmenu.

  2. Kies voor CRS WGS 84 / UTM zone 33S (EPSG-code 32733)

  3. Stel, onder Resolutie, de resoluties Horizontaal en Verticaal in op 30 (meter).

  4. Klik, onder Bereik, op Uit laag berekenen en kies Rainfall30

  5. Sla het bestand op als DEM30.tif in DEM/reprojected (bestandsnaam)

De symbologie voor de lagen moet gewijzigd worden om op de juiste wijze te kunen zien wat er gebeurt,

8.4.8. Wijzigen van de symbologie van vectorlagen

  1. Klik met rechts, in het paneel Lagen, op de laag Streets

  2. Selecteer Eigenschappen uit het menu dat tevoorschijn komt

  3. Schakel naar de tab Symbologie in het dialoogvenster dat verschijnt

  4. Klik op het item Vulling in de bovenste widget

  5. Selecteer een symbool uit de lijst eronder of stel een nieuwe in (kleur, transparantie, …)

  6. Klik op OK om het dialoogvenster Laageigenschappen te sluiten. Dit zal het renderen van de laag Streets wijzigen.

  7. Volg een soortgelijk proces voor de laag Zoning en kies er een toepasselijke kleur voor

8.4.9. Wijzigen van de symbologie van rasterlagen

Symbologie voor rasterlagen is enigszins anders.

  1. Open het dialoogvenster Laageigenschappen voor de rasterlaag Rainfall30

  2. Schakel naar de tab Symbologie. U zult zien dat dit dialoogvenster voor de stijl heel anders is dan de versie die werd gebruikt voor vectorlagen.

  3. Vergroot Instellingen min / max waarden

  4. Zorg er voor dat de knop Gemiddelde +/- standaardafwijking is geselecteerd

  5. Zorg er voor dat de waarde in het toepasselijke vak 2.00 is

  6. Voor Contrastverbetering, zorg er voor dat er staat ‘Stretch’ tot MinMax

  7. Voor Kleurovergang, wijzig het naar Wit naar zwart

  8. Klik op OK

    Het raster “Rainfall30” zou, indien zichtbaar, van kleur moeten veranderen, wat u in staat stelt de verschillende waarden voor helderheid voor elke pixel te zien

  9. Herhaal dit proces voor de laag DEM30, maar stel de standaardafwijking die moet worden gebruikt voor het uitrekken in op 4.00.

8.4.10. De kaart opruimen

  1. Verwijder de originele lagen Rainfall en DEM, als ook Rainfall_clipped en DEM_clipped, uit het paneel Lagen:

    • Klik met rechts op deze lagen en selecteer Verwijder.

      Notitie

      Dit zal niet de gegevens uit uw opslagapparaat verwijderen, ze worden alleen uit uw kaart verwijderd.

  2. Sla de kaart op

  3. U kunt nu de vectorlagen verbergen door het vak naast ze in het paneel Lagen leeg te maken. Dit zorgt er voor dat de kaart sneller wordt gerenderd en u enige tijd bespaart.

8.4.11. De schaduw voor heuvels maken

U zult een algoritme moeten gebruiken dat speciaal werd geschreven voor dit doel om de schaduw voor heuvels te maken.

  1. Zorg er voor dat, in het paneel Lagen, DEM30 de actieve laag is (d.i. hij is geaccentueerd door erop te klikken).

  2. Klik op het menu-item Raster ► Analyse ► Schaduw voor heuvels… om het dialoogvenster Schaduw voor heuvels te openen

  3. Scroll naar beneden naar Schaduw voor heuvels en sla de gegevens op in uw map Rasterprac als hillshade.tif

  4. Zorg er voor dat het vak Uitvoerbestand openen na uitvoeren algoritme is geselecteerd

  5. Klik op Uitvoeren

  6. Wacht tot de verwerking is voltooid.

De nieuwe laag hillshade is verschenen in het paneel Lagen.

  1. Klik met rechts op de laag hillshade in het paneel Lagen en roep het dialoogvenster Eigenschappen op

  2. Klik op de tab Transparantie en stel de schuifbalk Globale doorzichtbaarheid in op 20%

  3. Klik op OK

  4. Let op het effect als de transparante hillshade wordt weergegeven over de geclipte DEM. U zou misschien de volgorde van uw lagen moeten wijzigen, of de laag Rainfall30 uit moeten schakelen om het effect te zien.

8.4.12. Helling

  1. Klik op het menu-item Raster ► Analyse ► Helling… om het dialoogvenster voor het algoritme Helling te openen

  2. Selecteer DEM30 als Invoerlaag

  3. Selecteer checkbox Helling weergeven in procenten in plaats van in graden. Helling kan worden uitgedrukt in verschillende eenheden (percentage of graden). Onze criteria suggereren dat de plant, waarin we geïnteresseerd zijn, groeit op hellingen met een verloop tussen 15% en 60%. We moeten er dus voor zorgen dat de gegevens voor onze helling worden weergegeven als procenten.

  4. Specificeer een toepasselijke bestandsnaam en locatie voor uw uitvoer.

  5. Zorg er voor dat het vak Uitvoerbestand openen na uitvoeren algoritme is geselecteerd

  6. Klik op Uitvoeren

De afbeelding voor de helling wordt berekend en toegevoegd aan de kaart. Zoals gewoonlijk is het gerenderd in grijswaarden. Wijzig de symbologie naar een meer kleurrijke:

  1. Open het dialoogvenster Eigenschappen voor de laag (zoals gewoonlijk via het menu voor rechts-klikken van de laag)

  2. Klik op de tab Symbologie

  3. Waar het zegt Enkelbands grijs (in de keuzelijst Rendertype), wijzig die naar Enkelbands pseudokleur

  4. Kies Gemiddelde +/- standaardafwijking x voor Instellingen min / max waarden met een waarde van 2.0

  5. Selecteer een geschikt Kleurverloop

  6. Klik op Uitvoeren

8.4.13. Try Yourself Ligging

Gebruik dezelfde benadering als voor het berekenen van de helling, maar selecteer Aspect… in het menu Raster ► Analyse.

Denk er aan om het project regelmatig op te slaan.

8.4.14. Rasters opnieuw classificeren

  1. Kies Raster ► Rasterberekeningen…

  2. Specificeer uw map Rasterprac als de locatie voor de Uitvoerlaag (klik op de knop ), en sla het op als slope15_60.tif

  3. Zorg er voor dat het vak Voeg resultaat toe aan project is geselecteerd.

    In de lijst Rasterbanden aan de linkerkant, ziet u alle rasterlagen in uw paneel Lagen. Als uw laag voor de helling is genaamd slope, zal die zijn vermeld als slope@1. Dat geeft band 1 van het raster slope aan.

  4. De helling moet tussen 15 en 60 graden zijn.

    Bouw, met behulp van de items in de lijst en de knoppen in de interface, de volgende expressie:

    (slope@1 > 15) AND (slope@1 < 60)
    
  5. Stel het veld Uitvoerbestand in op een toepasselijke locatie en bestandsnaam.

  6. Klik op Uitvoeren.

Zoek nu naar het juiste aspect (uitkijkend op het oosten: tussen 45 en 135 graden) met behulp van dezelfde benadering.

  1. Bouw de volgende expressie:

    (aspect@1 > 45) AND (aspect@1 < 135)
    

U zult weten of het heeft gewerkt als alle hellingen die op het oosten uitkijken wit zijn gekleurd in het resulterende raster (het lijkt er bijna op alsof zij worden verlicht door het zonlicht in de morgen).

Zoek op dezelfde manier naar de juiste regenval (meer dan 1000 mm). Gebruik de volgende expressie:

Rainfall30@1 > 1000

Nu u alle drie criteria elk in afzonderlijke rasters heeft, moet u ze combineren om te zien welke gebieden voldoen aan alle criteria. De rasters zullen met elkaar worden vermenigvuldigd om dat te doen. Wanneer dit gebeurt zullen alle overlappende pixels met de waarde 1 de waarde 1 behouden (d.i. de locatie voldoet aan de criteria), maar als een pixel in één van de drie rasters de waarde 0 heeft (d.i. de locatie voldoet niet aan de criteria), dan zal het 0 zijn in het resultaat. Op deze manier zal het resultaat alleen de overlappende gebieden bevatten die voldoen aan alle toepasselijke criteria.

8.4.15. Rasters combineren

  1. Open de Rasterberekeningen (Raster ► Rasterberekeningen…)

  2. Bouw de volgende expressie (met de toepasselijke namen voor uw lagen):

    [aspect45_135] * [slope15_60] * [rainfall_1000]
    
  3. Stel de locatie voor de uitvoer in op de map Rasterprac

  4. Noem het uitvoerraster aspect_slope_rainfall.tif

  5. Zorg er voor dat checkbox Uitvoerbestand openen na uitvoeren algoritme is geselecteerd

  6. Klik op Uitvoeren

Het nieuwe raster geeft nu op de juiste manier de gebieden weer waar aan alle drie criteria wordt voldaan.

Sla het project op.

Het volgende criterium waaraan moet worden voldaan is dat het gebied 250 m van stedelijke gebieden moet liggen. We zullen aan dit vereiste voldoen door er voor te zorgen dat de gebieden die we berekenen binnen landelijke gebieden liggen en 250 m of meer vanaf de rand van het gebied ligt. Maar, dan moeten we wel eerst de landelijke gebieden zoeken.

8.4.16. Landelijke gebieden zoeken

  1. Verberg alle lagen in het paneel Lagen

  2. Geef de vectorlaag Zoning weer

  3. Klik er met rechts op en open het dialoogvenster Attributentabel. Merk de vele verschillende manieren op waarin het land is opgedeeld. We willen de landelijke gebieden isoleren. Sluit de Attributentabel.

  4. Klik met rechts op de laag Zoning en selecteer Filteren… om het dialoogvenster Querybouwer op te roepen

  5. Bouw de volgende query:

    "Gen_Zoning" = 'Rural'
    

    Bekijk de eerdere instructies als u het even niet weet.

  6. Klik op OK om het dialoogvenster Querybouwer te sluiten. De query zou één object terug moeten geven.

U zou de polygonen voor landelijke gebieden moeten zien uit de laag Zoning. U zult deze op moeten slaan.

  1. Selecteer, in het contextmenu van Zoning, Exporteren ► Objecten opslaan als….

  2. Sla uw laag op in de map Rasterprac

  3. Noem het uitvoerbestand rural.shp

  4. Klik op OK

  5. Sla het project op

Nu moet u de gebieden uitsluiten die binnen 250m vanaf de rand van de landelijke gebieden liggen. Doe dat door een negatieve buffer te maken, zoals hieronder uitgelegd.

8.4.17. Een negatieve buffer maken

  1. Klik op het menu-item Vector ► Geoprocessing-gereedschap ► Buffer…

  2. Selecteer, in het dialoogvenster dat verschijnt, de laag rural als uw invoer vectorlaag (Alleen geselecteerde objecten gebruiken zou niet moeten zijn geselecteerd)

  3. Stel Afstand in op -250. De negatieve waarde betekent dat de buffer een interne buffer zal zijn. Zorg er voor dat in het keuzemenu de eenheden in meters zijn.

  4. Selecteer checkbox Resultaat samenvoegen

  5. Plaats, in Gebufferd, het uitvoerbestand in de map Rasterprac, en noem het rural_buffer.shp

  6. Klik op Opslaan

  7. Klik op Uitvoeren en wacht tot de verwerking is voltooid

  8. Sluit het dialoogvenster Buffer.

    Zorg er voor dat uw buffer correct werkte door te zien hoe de laag rural_buffer verschilt van de laag rural. U moet misschien de volgorde van tekenen veranderen om het verschil te kunnen zien.

  9. Verwijder de laag rural

  10. Sla het project op

Nu moet u uw vectorlaag rural_buffer combineren met het raster aspect_slope_rainfall. We zullen de gegevensindeling van een van de lagen moeten wijzigen om ze te kunnen combineren. In dit geval zult u de raster vectoriseren, omdat vectorlagen handiger zijn als we gebieden willen berekenen.

8.4.18. Het raster vectoriseren

  1. Klik op het menu-item Raster ► Conversie ► Polygoniseren (raster naar vector)….

  2. Selecteer het raster aspect_slope_rainfall als Invoerlaag

  3. Stel Naam van het te maken veld in op geschikt (de standaard veldnaam is DN - Digitaal nummergegevens)

  4. Sla de uitvoer op. Onder Gevectoriseerd, selecteer Opslaan als bestand. Stel de locatie in op Rasterprac en noem het bestand aspect_slope_rainfall_all.shp.

  5. Zorg er voor dat checkbox Uitvoerbestand openen na uitvoeren algoritme is geselecteerd

  6. Klik op Uitvoeren

  7. Sluit het dialoogvenster als de verwerking voltooid is

Alle gebieden van het raster zijn gevectoriseerd, dus u moet alleen de gebieden selecteren die de waarde 1 in het veld suitable hebben. (Digital Number)

  1. Open het dialoogvenster Querybouwer (klik met rechts op - Filteren…) voor de nieuwe vectorlaag

  2. Bouw deze query:

    "suitable" = 1
    
  3. Klik op OK

  4. Nadat u er zeker van bent dat de query voltooid is (en alleen de gebieden die voldoen aan alle drie criteria, d.i. met een waarde van 1, zichtbaar zijn), maak een nieuw vectorbestand uit de resultaten, met Exporteren –> Objecten opslaan als… in het contextmenu van de laag

  5. Sla het bestand op in de map Rasterprac

  6. Noem het bestand aspect_slope_rainfall_1.shp

  7. Verwijder de laag aspect_slope_rainfall_all uit uw kaart

  8. Sla uw project op

Wanneer we een algoritme gebruiken om een raster te vectoriseren, maakt het algoritme soms wat wordt genoemd “Ongeldige geometrieën”, d.i. er zijn lege polygonen, of polygonen met fouten erin, die in de toekomst moeilijk te analyseren zullen zijn. We moeten dus het gereedschap “Geometrieën repareren” gebruiken.

8.4.19. Geometrieën repareren

  1. Zoek, in de Processing Toolbox, naar “Geometrieën repareren”, en druk op Uitvoeren…

  2. Selecteer voor de Invoerlaag aspect_slope_rainfall_1

  3. Onder Gerepareerde geometrieën, selecteer Opslaan als bestand. Stel de locatie in op Rasterprac en noem het bestand fixed_aspect_slope_rainfall.shp.

  4. Zorg er voor dat checkbox Uitvoerbestand openen na uitvoeren algoritme is geselecteerd

  5. Klik op Uitvoeren

  6. Sluit het dialoogvenster als de verwerking voltooid is

Nu u het raster hebt gevectoriseerd, en de resulterende geometrieën hebt gerepareerd, kunt u de criteria voor ligging, helling en regenval combineren met het criterium voor de afstand tot een menselijke nederzetting door de kruisingen te zoeken van de laag fixed_aspect_slope_rainfall en de laag rural_buffer.

8.4.20. Bepalen van de kruising van vectors

  1. Klik op het menu-item Vector ► Geoprocessing-gereedschap ► Kruising…

  2. Selecteer, in het dialoogvenster dat verschijnt, de laag rural_buffer als Invoerlaag

  3. Selecteer voor de Overleglaag de laag fixed_aspect_slope_rainfall

  4. Plaats, in Kruising, het uitvoerbestand in de map Rasterprac

  5. Noem het uitvoerbestand rural_aspect_slope_rainfall.shp

  6. Klik op Opslaan

  7. Klik op Uitvoeren en wacht tot de verwerking is voltooid

  8. Sluit het dialoogvenster Kruising.

    Zorg er voor dat het zoeken van de kruisingen juist heeft gewerkt door te zien dat alleen de overlappende gebieden zijn overgebleven.

  9. Sla het project op

Het volgende criteria op de lijst is dat het gebied groter moet zijn dan 6000 ㎡. U zult nu de polygoon-gebieden berekenen om de gebieden te identificeren die de juiste grootte hebben voor dit project.

8.4.21. Het gebied voor elke polygoon berekenen

  1. Open het rechtsklik-menu van de nieuwe vectorlaag

  2. Selecteer Attributentabel openen

  3. Klik op de knop toggleEditing modus Bewerken aan-/uitzetten aan de linkerbovenzijde van de tabel, of druk op Ctrl+e.

  4. Klik op de knop calculateField Veldberekening openen op de werkbalk aan de bovenzijde van de tabel, of druk op Ctrl+i

  5. Zorg er voor dat, in het dialoogvenster dat verschijnt, checkbox Nieuw veld aanmaken is geselecteerd, en stel de Naam voor veld in op area. Het type voor het veld zou een decimaal getal (real) moeten zijn. Stel Precisie in op 1 (één decimaal).

  6. Typ in het gebied Expressie:

    $area
    

    Dit betekent dat de veldberekening het gebied van elke polygoon in de vectorlaag zal berekenen en ze dan zal vermelden in een nieuwe kolom met een geheel getal (genaamd area) met de berekende waarde.

  7. Klik op OK

  8. Herhaal deze stap voor een ander veld genaamd id. Typ in het gebied Expressie:

    $id
    

    Dit zorgt er voor dat elke polygoon een unieke ID heeft ter identificatie.

  9. Klik opnieuw op de knop toggleEditing modus Bewerken aan-/uitzetten en sla uw gegevens op als daarnaar gevraagd wordt

8.4.22. Gebieden met een bepaalde grootte selecteren

Nu de gebieden bekend zijn:

  1. Bouw een query (zoals gewoonlijk) om alleen de polygonen te selecteren die groter zijn dan 6000 m². De query is:

    "area" > 6000
    
  2. Sla de selectie op in de map Rasterprac als een nieuwe vectorlaag, genaamd suitable_areas.shp.

U heeft nu de geschikte gebieden die voldoen aan alle criteria voor de habitat van de zeldzame fynbos-plant, waaruit u de vier gebieden kunt kiezen die het dichtst bij de universiteit van Kaapstad liggen.

8.4.23. Digitaliseren van de universiteit van Kaapstad

  1. Maak, net als eerder, een nieuwe vectorlaag in de map Rasterprac, maar selecteer deze keer de waarde Punt als Type geometrie en noem de laag university.shp

  2. Zorg er voor dat het in het juiste CRS (Project CRS:EPSG:32733 - WGS 84 / UTM zone 33S) staat

  3. Voltooi het maken van de nieuwe laag (klik op OK)

  4. Verberg alle lagen, met uitzondering van de nieuwe laag university en de laag Streets.

  5. Voeg een achtergrondkaart toe (OSM):

    1. Ga naar het paneel Browser en navigeer naar XYZ Tiles ► OpenStreetMap

    2. Sleep en zet het item OpenStreetMap neer aan de onderzijde van het paneel Lagen

    Zoek, met uw internetbrowser, de locatie op van de universiteit van Kaapstad. Gegeven de unieke topografie van Kaapstad, is de universiteit een zeer herkenbare locatie. Onthoud, voordat u teruggaat naar QGIS, waar de universiteit is gelegen en wat er in de buurt ligt.

  6. Zorg er voor dat op de laag Streets is geklikt, en dat de laag university is geaccentueerd in het paneel Lagen

  7. Navigeer naar het menu-item Beeld ► Werkbalken en zorg er voor dat Digitaliseren is geselecteerd. U zou dan een pictogram voor de werkbalk moeten zien met een potlood erop (toggleEditing Bewerken aan-/uitzetten). Dat is de knop Bewerken aan-/uitzetten.

  8. Klik op de knop Bewerken aan-/uitzetten om naar de modus Bewerken te gaan. Dat stelt u in staat een vectorlaag te bewerken

  9. Klik op de knop capturePoint Object Punt toevoegen, die dichtbij de knop toggleEditing Bewerken aan/uitzetten zou moeten staan

  10. Met het gereedschap Object Punt toevoegen geactiveerd, klik met links op uw beste schatting voor de locatie van de universiteit van Kaapstad

  11. Geef een uniek geheel getal op als daarnaar gevraagd wordt voor de id

  12. Klik op OK

  13. Klik op de knop saveEdits Wijzigingen laag opslaan

  14. Klik op de knop Bewerken aan-/uitzetten om uw sessie voor bewerkingen te beëindigen

  15. Sla het project op

8.4.24. Zoek de locaties die het dichtst bij de universiteit van Kaapstad liggen

  1. Ga naar de Toolbox van Processing, zoek naar het algoritme Koppel attributen op dichtstbijzijnde (Vector algemeen ► Koppel attributen op dichtstbijzijnde) en voer het uit

  2. Invoerlaag zou university moeten zijn, en Invoerlaag 2 suitable_areas

  3. Stel een toepasselijke locatie voor de uitvoer en een naam in (Samengevoegde laag)

  4. Stel Maximum dichtstbijzijnde buren in op 4

  5. Zorg er voor dat checkbox Uitvoerbestand openen na uitvoeren algoritme is geselecteerd

  6. Laat de rest van de parameters op hun standaard instellingen staan

  7. Klik op Uitvoeren

De resulterende puntenlaag zal vier objecten bevatten - zij zullen allemaal de locatie van de universiteit hebben en de attributen daarvan, en, in aanvulling daarop, de attributen van de nabijgelegen geschikte gebieden (inclusief de id), en de afstand tot die locatie.

  1. Open de attributentabel van het resultaat van het samenvoegen

  2. Onthoud de id van de vier meest nabij gelegen geschikte gebieden, en sluit dan de attributentabel

  3. Open de attributentabel van de laag suitable_areas

  4. Bouw een query om alleen de vier geschikte gebieden te selecteren die het dichtst bij de universiteit liggen (selecteer ze met het veld id)

Dit is het uiteindelijke antwoord op de onderzoeksvraag.

Maak, voor als u het inlevert, een volledig gelabelde lay-out die de semi-transparante laag hillshade over een aantrekkelijk raster van uw keuze (zoals de DEM of de laag slope bijvoorbeeld) bevat. Neem ook de polygoon en de laag suitable_areas, waarop de vier geschikte gebieden, die het dichtst bij de universiteit liggen, zijn geaccentueerd. Volg alle best practices voor cartografie bij het maken van uw kaart voor de uitvoer.