9.4. Lesson: Ejercicio Suplementario

En esta lección, serás guiado a través de un análisis SIG completo en QGIS.

Nota

Lección desarrollada por Linfiniti y S Motala (Universidad Tecnológica de Península del Cabo)

9.4.1. Planteamiento del Problema

Eres el encargado de encontrar áreas en Península del Cabo que sean adecuadas para el hábitat de especies de plantas fynbos raras. La extensión de tu área de investigación en Península del Cabo es: Sur de Melkbosstrand, Oeste de Strand. Botánicos te han proporcionado las preferencias exhibidas por las especies en cuestion:

  • Crecen en pendientes orientadas al este.

  • Crecen en pendientes con gradiente entre 15 y 60%.

  • Crecen en áreas que tienen un total de precipitación anual de > 1200 mm.

  • Solo se encuentran a al menos 250 m de distancia de los asentamientos humanos.

  • El área de vegetación en la que ocurre debería ser de al menos 6000m2.

Como voluntario de Naturaleza del Cabo, has acordado buscar la planta en el terreno adecuado más cercano a tu casa. Utiliza tus habilidades SIG para determinar dónde deberías ir a ver.

9.4.2. Esquema de la Solución

The data for this exercise can be found in the exercise_data/more_analysis folder. You are going to find the candidate area that is closest to a house of your choice. The solution will involve:

  1. análisis del MDE para encontrar las pendientes orientadas al este y las pendientes con el gradiente correcto;

  2. análisis del ráster de precipitación para encontrar las áreas con cantidad de precipitación correcta;

  3. análisis de las zonas de capa vectorial para encontrar áreas que tengan la distancia a enclaves humanos y sean del tamaño correctos.

9.4.3. Preparando el Mapa

  1. Haz clic en el botón «estado SRC» en la esquina inferior derecha de la pantalla. En la pestaña SRC de la pestaña que aparece, verás la casilla Sistema de referencia de coordenadas del mundo.

  2. En esta casilla, navega hasta Sistemas de coordenadas proyectadas ‣ Universal Transverse Mercator (UTM).

  3. Select the entry WGS 84 / UTM zone 33S (with the EPSG code 32733).

  4. Click OK. The map is now in the UTM33S coordinate reference system.

  5. Guarda el mapa clicando en el botón de la barra de herramientas Guardar proyecto como, o utiliza el elemento del menú Proyecto ‣ Guardar como….

  6. Save the map in a directory called Rasterprac that you should create somewhere on your computer. You will save whatever layers you create in this directory as well.

9.4.4. Cargar Datos dentro del Mapa

Para procesar los datos, necesitarás cargar las capas necesarias (nombres de calles, zonas, precipitación, MDE) en la vista del mapa.

9.4.4.1. For vectors…

  1. Click on the dataSourceManager Open Data Source Manager button and enable the addOgrLayer Vector tab in the dialog that appears, or use the Layer ‣ Add Layer ‣ addOgrLayer Add Vector Layer… menu item.

  2. Ensure that the File radio button is selected.

  3. Click on the button to browse for Vector dataset(s).

  4. In the dialog that appears, open the exercise_data/more_analysis/streets directory.

  5. Select the file Street_Names_UTM33S.shp.

  6. Haz clic en Abrir.

    The dialog closes and shows the original dialog, with the file path specified in the text field next to the Vector dataset(s) button. This allows you to ensure that the correct file is selected. It is also possible to enter the file path in this field manually, should you wish to do so.

  7. Click Add. The vector layer will load in your map. Its color is automatically assigned. It will be changed later.

  8. Rename the layer to Streets.

    1. Right-click on it in the Layers panel (by default, the pane along the left-hand side of the screen).

    2. Click Rename in the dialog that appears and rename it, pressing the Enter key when done.

  9. Repeat the vector adding process, but this time select the Generalised_Zoning_Dissolve_UTM33S.shp file in the Zoning directory.

  10. Rename it to Zoning.

9.4.4.2. For rasters…

  1. Click on the dataSourceManager Open Data Source Manager button and enable the addRasterLayer Raster tab in the dialog that appears, or use the Layer ‣ Add Layer ‣ addRasterLayer Add Raster Layer… menu item.

  2. Ensure that the File radio button is selected.

  3. Navega hasta el archivo apropiado, selecciónalo y haz clic en Abrir.

  4. Do this for each of the two raster files. The files you want are DEM/reproject/DEM.tif and Rainfall/reprojected/rainfall.tif.

  5. Rename the rainfall raster to Rainfall (with an initial capital). Initially when you load them, the images will be gray rectangles. Don’t worry, this will be changed later.

  6. Guarda el mapa.

Para ver correctamente qué está pasando, se necesita cambiar la simbología para las capas.

9.4.5. Cambio de simbología de capas vectoriales

  1. In the Layers panel, right-click on the Streets layer.

  2. Selecciona Propiedades del menú que aparece.

  3. Switch to the Symbology tab in the dialog that appears.

  4. Haga clic sobre el botón etiquetado Cambiar, con un cuadro mostrando el color actual de la capa Streets.

  5. Selecciona un color nuevo en el cuadro de diálogo que aparece.

  6. Haz clic en Aceptar.

  7. Vuelve a hacer clic en Aceptar en el cuadro de diálogo Propiedades de la capa. Esto cambiará el color de la capa Streets.

  8. Sigue un proceso similar para la capa Zoning y elige un color adecuado para ella.

9.4.6. Cambio de simbología de capas ráster

La simbología de capas ráster es algo diferente.

  1. Abre el cuadro de diálogo Propiedades para el ráster Precipitación.

  2. Switch to the Symbology tab. You’ll notice that this dialog is very different from the version used for vector layers.

  3. Asegúrate de que el botón Media +/- desviación estándar está seleccionado.

  4. Change the value in the associated box to 2.00 (it should be set to 0.00 by default).

  5. En el título Mejora de contraste, cambia el valor del menú desplegable a Estirar a MinMax.

  6. Haz clic en Aceptar. El ráster «Precipitación», si está visible, debería cambiar de colores, permitiendote ver diferentes valores de brillo para cada píxel.

  7. Repeat this process for the DEM, but set the standard deviations used for stretching to 4.00.

9.4.7. Cambio de orden de capas

  1. In the Layers panel, click and drag layers up and down to change the order they appear in on the map.

  2. Newer versions of QGIS may have a Control rendering order checkbox beneath the Layers panel. Ensure that it is checked.

Ahora que todos los datos están cargados y son adecuadamente visibles, el análisis puede comenzar. Es mejor si las operaciones de recorte se hacen primero. Así no se malgasta potencia procesando áreas que no serían utilizadas de todas formas.

9.4.8. Encuentra los Distritos Correctos

  1. Load the vector layer admin_boundaries/Western_Cape_UTM33S.shp into your map.

  2. Rename it to Districts.

  3. Right-click on the Districts layer in the Layers panel.

  4. En el menú que aparece, selecciona el elemento del menú Filtrar…. El cuadro de diálogo Constructor de Consultas aparecerá.

Ahora construirás una consulta para seleccionar solo la siguiente lista de distritos:

  • Bellville

  • Cape

  • Goodwood

  • Kuils River

  • Mitchells Plain

  • Simons Town and

  • Wynberg.

  1. En la lista Campos, haz doble clic en el campo NAME_2. Aparece en el campo de texto inferior Expresión de filtrado específica del proveedor.

  2. Click the = button; an = sign is added to the SQL query.

  3. Haz clic en el botón Todos bajo la lista Values (actualmente vacío). Después de una corta espera, se rellenará la lista Values con los valores del campo seleccionado (NAME_2).

  4. Haz doble clic en el valor Bellville en la lista Values. Como antes, será añadido a la consulta SQL.

In order to select more than one district, you’ll need to use the OR boolean operator.

  1. Haz clic en el botón O y será añadido a la consulta SQL.

  2. Utilizando un proceso similar al anterior, añade lo siguiente a la consulta existente SQL:

    "NAME_2" = 'Cape'
    
  3. Add another OR operator, then work your way through the list of districts above in a similar fashion.

    La consulta final debería ser

    "NAME_2" = 'Bellville' OR "NAME_2" = 'Cape' OR "NAME_2" = 'Goodwood' OR
    "NAME_2" = 'Kuils River' OR "NAME_2" = 'Mitchells Plain' OR "NAME_2" =
    'Simons Town' OR "NAME_2" = 'Wynberg'
    
  4. Haz clic en Aceptar. Los distritos mostrados en tu mapa están limitados a los de la lista anterior.

9.4.9. Recorta los Ráster

Ahora que tienes un área de interés, puedes recortar los ráster a esa área.

  1. Asegúrate de que las únicas capas visibles son las de MDE, Rainfall y Districts.

  2. Los Districts deben estar en primer lugar para ser visibles.

  3. Abre el cuadro de diálogo para recortar seleccionando el elemento del menú Ráster ‣ Extracción ‣ Clipper.

  4. En la lista del menú desplegable Archivo de entrada (ráster), selecciona la capa MDE.

  5. Especifica una localización de salida en el campo de texto Archivo de salida clicando en el botón Seleccionar….

  6. Navigate to your Rasterprac directory.

  7. Introduce un nombre de archivo.

  8. Guarda el archivo. Deja la casilla de verificación Valor de sin datos vacía.

  9. Utiliza el modo de corte Extensión asegurándote que el botón radial correcto está seleccionado.

  10. Haz clic y arrastra un área en el mapa, de modo que el área que incluye los distritos esté seleccionada.

  11. Check the Open output file after running algorithm box.

  12. Haz clic en Run.

  13. Cuando la operación de corte se complete, NO CIERRES el cuadro de diálogo Clipper. (Cerrarlo te haría perder el área a cortar que ya habías definido)

  14. Selecciona el ráster Precipitación en el menú desplegable Archivo de entrada (ráster) y elige un nombre de archivo de salida diferente.

  15. Do not change any other options. Do not alter the existing clipping area which you drew previously. Leave everything the same and click Run.

  16. Después de que la segunda operación de corte haya terminado, puedes cerrar el cuadro de diálogo Clipper.

  17. Guarda el mapa.

9.4.10. Limpia el mapa

  1. Remove the original Rainfall and DEM layers from the Layers panel:

  2. Haz clic derecho en esas capas y selecciona Eliminar.

    Nota

    Esto no borrará los datos de tu dispositivo de almacenamiento, solamente lo quitará de tu mapa.

  3. Desactiva las etiquetas de la capa Streets.

    1. Haz clic en el botón Etiquetado.

    2. Quita la marca de la casilla Etiquetar esta capa con.

    3. Haz clic en Aceptar.

  4. Muestra todas las Streets de nuevo:

    1. Right-click on the layer in the Layers panel.

    2. Selecciona Filtrar.

    3. En el cuadro de diálogo que aparece, haz clic en el botón Limpiar, luego haz clic en Aceptar.

    4. Espera mientras se cargan los datos. Todas las calles serán visibles ahora.

  5. Change the raster symbology as before (see Cambio de simbología de capas ráster).

  6. Guarda el mapa.

  7. You can now hide the vector layers by unchecking the box next to them in the Layers panel. This will make the map render faster and will save you some time.

In order to create the hillshade, you will need to use an algorithm that was written for this purpose.

9.4.11. Crear el sombreado del relieve

  1. In the Layers panel, ensure that the DEM is the active layer (i.e., it is highlighted by having been clicked on).

  2. Click on the Raster ‣ Analysis ‣ Hillshade menu item to open the Hillshade dialog.

  3. Especifica una localización apropiada para la capa de salida y nómbrala hillshade.

  4. Check the Open output file after running algorithm box.

  5. Haz clic en Run.

  6. Espera a que termine de procesar.

La nueva capa hillshade a aparecido en tu Lista de capas.

  1. Haz clic derecho en la capa hillshade en tu Lista de capas y abre el cuadro de diálogo Propiedades.

  2. Click on the Transparency tab and set the transparency slider to 80%.

  3. Click Run on the dialog.

  4. Observa el efecto cuando el sombreado de relieve transparente se sobre impone sobre el MDE recortado.

9.4.12. Pendiente

  1. Haz clic en el elemento del menú Ráster ‣ Análisis de terreno.

  2. Selecciona el tipo de análisis Pendiente, con el MDE acortado como la capa de entrada.

  3. Especifica un nombre de archivo y localización apropiados para propósitos de salida.

  4. Check the Open output file after running algorithm box.

  5. Haz clic en Run.

La imagen pendiente ha sido calculada y añadida al mapa. Sin embargo, como siempre, solo es un rectángulo gris. Para ver adecuadamente qué está pasando, cambia la simbología como sigue.

  1. Abre el cuadro de diálogo Propiedades de la capa (como siempre, con el menú de clic derecho en la capa).

  2. Click on the Symbology tab.

  3. Donde dice Unibanda gris (en el menú desplegable Tipo de renderizador), cámbialo a Unibanda pseudocolor.

  4. Asegúrate de que el botón radial Media +/- desviación estándard está seleccionado.

9.4.13. Orientación

Utiliza el mismo enfoque que para calcular la pendiente, pero selecciona Orientación en el cuadro de diálogo inicial.

Recuerda guardar el mapa periódicamente.

9.4.14. Reclasificar rásters

  1. Haz clic en el elemento del menú Ráster ‣ Calculadora ráster….

  2. Specify your Rasterprac directory as the location for the output layer.

  3. Ensure that the Open output file after running algorithm box is selected.

In the Raster bands list on the left, you will see all the raster layers in your Layers panel. If your Slope layer is called slope, it will be listed as slope@1.

The slope needs to be between 15 and 60 degrees. Everything less than 15 or greater than 60 must therefore be excluded.

  1. Utiliando la lista de elementos y botones en la interfaz, construye la siguiente expresión:

    ((slope@1 < 15) OR (slope@1 > 60)) = 0
    
  2. Ajusta el campo Capa de salida a un nombre y localización adecuados.

  3. Haz clic en Run.

Now find the correct aspect (east-facing: between 45 and 135 degrees) using the same approach.

  1. Construye la siguiente expresión:

    ((aspect@1 < 45) OR (aspect@1 > 135)) = 0
    
  2. Find the correct rainfall (greater than 1200mm) the same way. Build the following expression:

    (rainfall@1 < 1200) = 0
    

Having reclassified all the rasters, you will now see them displayed as gray rectangles in your map (assuming that they have been added to the map correctly). To properly display raster data with only two classes (1 and 0, meaning true or false), you will need to change their symbology.

9.4.15. Ajuste del estilo para capas reclasificadas

  1. Open the Symbology tab in the layer’s Properties dialog as usual.

  2. Bajo el título Cargar valores min / max, selecciona el botón radial Real (más lento).

  3. Haz clic en el botón Cargar.

The Custom min / max values fields should now populate with 0 and 1, respectively. (If they do not, then there was a mistake with your reclassification of the data, and you will need to go over that part again.)

  1. En el título Mejora de contraste, ajusta la lista del menú desplegable Sin realce a Estirar a MinMax.

  2. Haz clic en Aceptar.

  3. Hazlo para los tres ráster reclasificados, ¡y recuerda guardar tu trabajo!

The only criterion that remains is that the area must be 250m away from urban areas. We will satisfy this requirement by ensuring that the areas we compute are 250m or more from the edge of a rural area. Hence, we need to find all rural areas first.

9.4.16. Encontrar áreas rurales

  1. Hide all layers in the Layers panel.

  2. Haz visible la capa vectorial Zoning.

  3. Haz clic derecho en ella y abre el cuadro de diálogo Filtrar.

  4. Construye la siguiente consulta:

    "Gen_Zoning" = 'Rural'
    

    Mira antes las instrucciones para construir la consulta ara la capa Streets si te quedas atascado.

  5. Cuando hayas terminado, cierra el cuadro de diálogo Constructor de consultas.

Deberías ver una colección de polígonos de la capa Zoning. Necesitarás guardarlos en un nuevo archivo de capa.

  1. En el menú de clic derecho en Zoning, selecciona Guardar como….

  2. Guarda tu capa en el directorio Zoning.

  3. Name the output file rural.shp.

  4. Haz clic en Aceptar.

  5. Añade la capa a tu mapa.

  6. Haz clic en el elemento del menú Vectorial ‣ Herramientas de geoproceso ‣ Disolver.

  7. Selecciona la capa rural como tu capa vectorial de entrada, mientras dejas la casilla Usar sólo objetos espaciales seleccionados sin marcar.

  8. Leave empty the Dissolve field(s) option to combine all selected features in a single one.

  9. Guarda tu capa en el directorio Zoning.

  10. Check the Open output file after running algorithm box.

  11. Haz clic en Run.

  12. Cierra el cuadro de diálogo Disolver.

  13. Borra las capas rural y Zoning.

  14. Guarda el mapa.

Now you need to exclude the areas that are within 250m from the edge of the rural areas. Do this by creating a negative buffer, as explained below.

9.4.17. Crear un buffer negativo

  1. Haz clic en el elemento del menú Vectorial ‣ herramientas de geoproceso ‣ Buffer(s).

  2. En el cuadro de diálogo que aparece, selecciona la capa rural_dissolve como tu capa vectorial de entrada (Usar sólo objetos espaciales seleccionados no debería estar seleccionado).

  3. Select the Buffer distance button and enter the value -250 into the associated field; the negative value means that the buffer must be an internal buffer.

  4. Selecciona la casilla Disolver resultados de buffer.

  5. Ajusta el archivo de salida al mismo directorio que los otros archivos vectoriales rurales.

  6. Name the output file rural_buffer.shp.

  7. Haz clic en Guardar.

  8. Haz clic en Aceptar y espera a que se complete el proceso.

  9. Selecciona en el cuadro de diálogo que aparece.

  10. Cierra el cuadro de diálogo Buffer.

  11. Borra la capa rural_dissolve.

  12. Guarda el mapa.

Para incorporar las zonas rurales al mismo análisis con los tres ráster existentes, será necesario rasterizarlo. Pero para que los ráster sean compatibles para el análisis, necesitarán tener el mismo tamaño. Además, antes de rasterizar, necesitarás recortar el vector a la misma área que los ráster. Un vector solo puede ser recortado por otro vector, así que primero necesitaras crear un polígono de encuadre del mismo tamaño que los ráster.

9.4.18. Crear un encuadre vectorial

  1. Click on the menu item Layer ‣ New ‣ New Shapefile Layer….

  2. En el título Tipo, selecciona el botón Poligono.

  3. Click Specify CRS and set the coordinate reference system WGS 84 / UTM zone 33S : EPSG:32733.

  4. Haz clic en Aceptar.

  5. Haz clic en Aceptar en el cuadro de diálogo Nueva capa vectorial.

  6. Guarda el vector en el directorio Zoning.

  7. Name the output file bbox.shp.

  8. Oculta todas las capas excepto la nueva capa bbox y uno de los ráster reclasificados.

  9. Ensure that the bbox layer is highlighted in the Layers panel.

  10. Navega hasta el elemento del menú Ver ‣ Barras de herramientas y asegúrate de que Digitalización está seleccionado. Deberías ver en una barra de herramientas el icono de un lápiz o un koki. Es el botón Conmutar edición.

  11. Haz clic en el botón Conmutar edición para entrar al modo edición. Esto te permite editar una capa vectorial.

  12. Haz clic en el botón Añadir objeto espacial, que debería estar cerca del botón Conmutar edición. Puede que esté oculto tras un botón de flechas dobles; si lo está, haz clic en las flechas dobles para mostrar los botones ocultos de la barra de herramientas Digitalización.

  13. Con la herramienta Añadir objeto espacial activada, haz clic izquierdo en las esquinas del ráster. Puede que necesites ampliar el zum con la rueda del ratón para asegurarte que es exacto. Para desplazarte sobre el mapa en este modo, haz clic y arrastra el mapa con el boton central o la rueda del ratón.

  14. Para el cuarto y último punto, haz clic derecho para finalizar la forma.

  15. Introduce un número arbitrario para la forma ID.

  16. Haz clic en Aceptar.

  17. Haz clic en el botón Guardar cambios.

  18. Haz clic en el botón Conmutar edición para terminar tu sesión de edición.

  19. Guarda el mapa.

Ahora que tienes un cuadro delimitador, puedes utilizarlo para recortar la capa rural buffer.

9.4.19. Recortar una capa vectorial

  1. Asegúrate de que solo son visibles las capas bbox y rural_buffer, con el último por encima.

  2. Haz clic en el elemento del menú Vectorial ‣ Herramientas de geoproceso > Cortar.

  3. En el cuadro de diálogo que aparece, ajusta la capa vectorial de entrada a rural_buffer y la capa para cortar a bbox, con ambas casillas usar sólo objetos espaciales seleccionados sin marcar.

  4. Pon el archivo de salida en el directorio Zoning.

  5. Name the output file rural_clipped.

  6. Haz clic en Aceptar.

  7. Cuando se requiera añadir la capa al TDC, haz clic en .

  8. Cierra el cuadro de diálogo.

  9. Compara los tres vectores y ve los resultados por ti mismo.

  10. Borra las capas bbox y rural_buffer, luego guarda tu mapa.

Ahora ya está lista para ser rasterizada.

9.4.20. Rasterizar una capa vectorial

Necesitarás especificar un tamaño de píxel para un nuevo ráster que crees, así que primero necesitarás saber el tamaño de uno de los ráster existentes.

  1. Abre el cuadro de diálogo Propiedades de cualquiera de los tres ráster existentes.

  2. Cambia a la pestaña Metadatos.

  3. Make a note of the X and Y values under the heading Dimensions in the Metadata table.

  4. Cierra el cuadro de diálogo Propiedades.

  5. Haz clic en el elemento del menú Ráster ‣ Conversión ‣ Rasterizar. Puede que recibas una alerta sobre conjunto de datos no soportado. Haz clic de todos modos he ignoralo.

  6. Selecciona rural_clipped como tu capa de entrada.

  7. Ajusta la localización de archivo de salida dentro del directorio Zoning.

  8. Name the output file rural_raster.tif.

  9. Check the New size box and enter the X and Y values you made a note of earlier.

  10. Marca la casilla Cargar en la vista del mapa cuando se termine.

  11. Click the pencil icon next to the text field which shows the command that will be run. At the end of the existing text, add a space and then the text -burn 1. This tells the Rasterize function to «burn» the existing vector into the new raster and give the areas covered by the vector the new value of 1 (as opposed to the rest of the image, which will automatically be 0).

  12. Haz clic en Aceptar.

  13. El nuevo ráster se debería mostrar en tu mapa una vez se ha computado.

  14. El nuevo ráster se verá como un rectángulo gris - puedes cambiar el estilo de la presentación como hiciste para reclasificar ráster.

  15. Guarda tu mapa.

Now that you have all four criteria each in a separate raster, you need to combine them to see which areas satisfy all the criteria. To do so, the rasters will be multiplied with each other. When this happens, all overlapping pixels with a value of 1 will retain the value of 1, but if a pixel has the value of 0 in any of the four rasters, then it will be 0 in the result. In this way, the result will contain only the overlapping areas.

9.4.21. Combinación de rásters

  1. Haz clic en el elemento del menú Ráster ‣ Calculadora ráster….

  2. Construye la siguiente expresión (con los nombres apropiados para tus capas, dependiendo de cómo las llamaste)

    [Rural raster] * [Reclassified aspect] * [Reclassified slope] *
    [Reclassified rainfall]
    
  3. Set the output location to the Rasterprac directory.

  4. Name the output raster cross_product.tif.

  5. Ensure that the Open output file after running algorithm box is checked.

  6. Haz clic en Run.

  7. Cambia la simbología del nuevo ráster del mismo modo que ajustaste el estilo para los otros rásters reclasificados. El nuevo ráster ahora representa adecuadamente las áreas donde todos los criterios se satisfacen.

To get the final result, you need to select the areas that are greater than 6000m^2. However, computing these areas accurately is only possible for a vector layer, so you will need to vectorize the raster.

9.4.22. Vectorizar el ráster

  1. Haz clic en el elemento del menú Ráster ‣ Conversión ‣ Poligonizar.

  2. Select the cross_product.tif raster.

  3. Set the output location to Rasterprac.

  4. Name the file candidate_areas.shp.

  5. Ensure that Open output file after running algorithm is checked.

  6. Haz clic en Run.

  7. Cierra el cuadro de diálogo cuando el proceso esté completo.

All areas of the raster have been vectorized, so you need to select only the areas that have a value of 1.

  1. Abre el cuadro de diálogo Query para el vector nuevo.

  2. Construye esta consulta:

    "DN" = 1
    
  3. Haz clic en Aceptar.

  4. Create a new vector file from the results by saving the candidate_areas vector after the query is complete (and only the areas with a value of 1 are visible). Use the Save as… function in the layer’s right-click menu for this.

  5. Save the file in the Rasterprac directory.

  6. Nombra al archivo candidate_areas_only.shp.

  7. Guarda tu mapa.

9.4.23. Cálgulo del área para cada polígono

  1. Abre el menú de la nueva capa vectorial con clic derecho.

  2. Seleccióna Abrir tabla de atributos.

  3. Haz clic en el botón Conmutar el modo edición en la parte inferior de la tabla, o pulsa Ctrl+E.

  4. Haz clic en el botón Abrir calculadora de campos en la parte inferior de la tabla, o pulsa Ctrl+M.

  5. Under the New field heading in the dialog that appears, enter the field name area. The output field type should be an integer, and the field width should be 10.

  6. En tipo Expresión de la calculadora de campos:

    $area
    

    Esto significa que la calculadora de campo calculará el área de cada polígono en la capa vectorial y creará una columna nueva (llamada area) con el valor calculado.

  7. Haz clic en Aceptar.

  8. Hacer lo mismo para otro nuevo campo llamado id. En tipo Expresión de la calculadora de campos:

    $id
    

    Eso asegura que cada polígono tiene una ID única para su identificación.

  9. Haz clic de nuevo en Conmutar el modo edición, y guarda tus ediciones si es requerido.

9.4.24. Selección de áreas para un tamaño dado

Ahora que las áreas son conocidas:

  1. Build a query (as usual) to select only the polygons larger than 6000m^2. The query is:

    "area" > 6000
    
  2. Save the selection as a new vector layer called solution.shp.

Ahora tienes tus áreas para tu solución, de las que tendrás que elegir la más proxima a tu casa.

9.4.25. Digitaliza tu casa

  1. Crea una nueva capa vectorial como antes, pero esta vez, selecciona el valor Tipo como Punto.

  2. ¡Asegúrate de que es el SRC correcto!

  3. Name the new layer house.shp.

  4. Acaba de crear la nueva capa.

  5. Entra en el modo de edición (mientras la capa nueva está seleccionada).

  6. Haz clic en el punto donde tu casa o otra residencia actual esté, utilizando las calles como guía. Puede que tengas que abrir otras capas para ayudarte a encontrar tu casa. Si no vives cerca, haz clic en algún lugar donde una casa podría ser concebible.

  7. Introduce un número arbitrario para la forma ID.

  8. Haz clic en Aceptar.

  9. Guarda tu edición y sal del modo de edición.

  10. Guarda el mapa.

Necesitarás encontrar los centroides («centros de masa») para los polígonos solución para decidir cual está más cerca de tu casa.

9.4.26. Calcula los centroides de los polígonos

  1. Click on the Vector ‣ Geometry Tools ‣ Centroids menu item.

  2. Especifica la capa de entrada como solution.shp.

  3. Provide the output location as Rasterprac.

  4. Call the destination file solution_centroids.shp.

  5. Check checkbox Open output file after running algorithm to add the result to the TOC (Layers panel).

  6. Click Run and close the dialog.

  7. Arrastra la nueva capa al principio de la lista para poder verla.

9.4.27. Calcula qué centroide está más cerca de tu casa

  1. Click on the menu item Vector ‣ Analysis Tools ‣ Distance matrix.

  2. The input layer should be your house, and the target layer solution_centroids. Both of these should use the id field as their unique ID field.

  3. El tipo de matriz de salida debería ser lineal.

  4. Ajusta una localización y nombre adecuadas para la salida.

  5. Haz clic en Aceptar.

  6. Abre el archivo en un editor de textos (o importalo a nuna hoja de cálculo). Observa qué ID está asociada con la Distance más corta. Puede que haya más de una con la misma distancia.

  7. Build a query in QGIS to select only the solution areas closest to your house (selecting it using the id field).

Esta es la respuesta final a la pregunta investigada.

Para tu presentación, incluye la capa semi transparente del relieve sombreado encima del ráster de tu elección (como MDE o slope raster, por ejemplo). Incluye también el polígono del área(s) solución más cercano, así como tu casa. Sigue las mejores prácticas de cartografía para crear tu mapa de salida.