13.3. データフォーマットとフィールドを書き出す

13.3.1. ラスターデータ

GIS raster data are matrices of discrete cells that represent features / phenomena on, above or below the earth's surface. Each cell in the raster grid has the same size, and cells are usually rectangular (in QGIS they will always be rectangular). Typical raster datasets include remote sensing data, such as aerial photography, or satellite imagery and modelled data, such as elevation or temperature.

Unlike vector data, raster data typically do not have an associated database record for each cell. They are geocoded by pixel resolution and the X/Y coordinate of a corner pixel of the raster layer. This allows QGIS to position the data correctly on the map canvas.

The GeoPackage format is convenient for storing raster data when working with QGIS. The popular and powerful GeoTiff format is a good alternative.

QGIS makes use of georeference information inside the raster layer (e.g., GeoTiff) or an associated world file to properly display the data.

13.3.2. ベクターデータ

Many of the features and tools available in QGIS work the same, regardless the vector data source. However, because of the differences in format specifications (GeoPackage, ESRI Shapefile, MapInfo and MicroStation file formats, AutoCAD DXF, PostGIS, SpatiaLite, DB2, Oracle Spatial, MSSQL Spatial databases, and many more), QGIS may handle some of their properties differently. Support is provided by the OGR Simple Feature Library. This section describes how to work with these specificities.

注釈

QGIS supports (multi)point, (multi)line, (multi)polygon, CircularString, CompoundCurve, CurvePolygon, MultiCurve, MultiSurface feature types, all optionally with Z and/or M values.

You should also note that some drivers don't support some of these feature types, like CircularString, CompoundCurve, CurvePolygon, MultiCurve, MultiSurface feature type. QGIS will convert them.

13.3.2.1. GeoPackage

The GeoPackage (GPKG) format is platform-independent, and is implemented as a SQLite database container, and can be used to store both vector and raster data. The format was defined by the Open Geospatial Consortium (OGC), and was published in 2014.

GeoPackage can be used to store the following in a SQLite database:

  • vector features

  • tile matrix sets of imagery and raster maps

  • attributes (non-spatial data)

  • extensions

Since QGIS version 3.8, GeoPackage can also store QGIS projects. GeoPackage layers can have JSON fields.

GeoPackage is the default format for vector data in QGIS.

13.3.2.2. ESRI Shapefile format

The ESRI Shapefile format is still one of the most used vector file formats, even if it has some limitations compared to for instance GeoPackage and SpatiaLite.

An ESRI Shapefile format dataset consists of several files. The following three are required:

  1. .shp ファイルは地物のジオメトリを持ちます.

  2. .dbf ファイルはdBase形式で属性を保持します.

  3. .shx 索引ファイル

An ESRI Shapefile format dataset can also include a file with a .prj suffix, which contains projection information. While it is very useful to have a projection file, it is not mandatory. A Shapefile format dataset can contain additional files. For further details, see the the ESRI technical specification at https://www.esri.com/library/whitepapers/pdfs/shapefile.pdf.

GDAL 3.1 has read-write support for compressed ESRI Shapefile format (shz and shp.zip).

Improving Performance for ESRI Shapefile format datasets

To improve the drawing performance for an ESRI Shapefile format dataset, you can create a spatial index. A spatial index will improve the speed of both zooming and panning. Spatial indexes used by QGIS have a .qix extension.

これらの手順で索引を作成できます:

  1. Load an ESRI Shapefile format dataset (see ブラウザパネル)

  2. Open the Layer Properties dialog by double-clicking on the layer name in the legend or by right-clicking and choosing Properties... from the context menu

  3. In the Source tab, click the Create Spatial Index button

Problem loading a .prj file

If you load an ESRI Shapefile format dataset with a .prj file and QGIS is not able to read the coordinate reference system from that file, you will need to define the proper projection manually in the Layer Properties ▶ Source tab of the layer by clicking the setProjection Select CRS button. This is due to the fact that .prj files often do not provide the complete projection parameters as used in QGIS and listed in the CRS dialog.

For the same reason, if you create a new ESRI Shapefile format dataset with QGIS, two different projection files are created: a .prj file with limited projection parameters, compatible with ESRI software, and a .qpj file, providing all the parameters of the CRS. Whenever QGIS finds a .qpj file, it will be used instead of the .prj.

13.3.2.3. 区切りテキストファイル

Delimited text files are very common and widely used because of their simplicity and readability -- data can be viewed and edited in a plain text editor. A delimited text file is tabular data with columns separated by a defined character and rows separated by line breaks. The first row usually contains the column names. A common type of delimited text file is a CSV (Comma Separated Values), with columns separated by commas. Delimited text files can also contain positional information (see Storing geometry information in delimited text files).

QGIS allows you to load a delimited text file as a layer or an ordinary table (see ブラウザパネル or 区切りテキストファイルをインポートする). First check that the file meets the following requirements:

  1. The file must have a delimited header row of field names. This must be the first line of the data (ideally the first row in the text file).

  2. If geometry should be enabled, the file must contain field(s) that define the geometry. These field(s) can have any name.

  3. The X and Y coordinates fields (if geometry is defined by coordinates) must be specified as numbers. The coordinate system is not important.

  4. If you have a CSV file with non-string columns, you must have an accompanying CSVT file (see section Using CSVT file to control field formatting).

The elevation point data file elevp.csv in the QGIS sample dataset (see section サンプルデータのダウンロード) is an example of a valid text file:

X;Y;ELEV
-300120;7689960;13
-654360;7562040;52
1640;7512840;3
[...]

Some things to note about the text file:

  1. The example text file uses ; (semicolon) as delimiter (any character can be used to delimit the fields).

  2. 最初の行は見出しです。ここには XY および ELEV というフィールドが含まれています。

  3. No quotes (") are used to delimit text fields

  4. The X coordinates are contained in the X field

  5. The Y coordinates are contained in the Y field

13.3.2.3.1. Storing geometry information in delimited text files

Delimited text files can contain geometry information in two main forms:

  • As coordinates in separate columns (eg. Xcol, Ycol... ), for point geometry data;

  • As well-known text (WKT) representation of geometry in a single column, for any geometry type.

Features with curved geometries (CircularString, CurvePolygon and CompoundCurve) are supported. Here are some examples of geometry types in a delimited text file with geometries coded as WKT:

Label;WKT_geom
LineString;LINESTRING(10.0 20.0, 11.0 21.0, 13.0 25.5)
CircularString;CIRCULARSTRING(268 415,227 505,227 406)
CurvePolygon;CURVEPOLYGON(CIRCULARSTRING(1 3, 3 5, 4 7, 7 3, 1 3))
CompoundCurve;COMPOUNDCURVE((5 3, 5 13), CIRCULARSTRING(5 13, 7 15,
  9 13), (9 13, 9 3), CIRCULARSTRING(9 3, 7 1, 5 3))

Delimited text files also support Z and M coordinates in geometries:

LINESTRINGZ(10.0 20.0 30.0, 11.0 21.0 31.0, 11.0 22.0 30.0)

13.3.2.3.2. Using CSVT file to control field formatting

When loading CSV files, the OGR driver assumes all fields are strings (i.e. text) unless it is told otherwise. You can create a CSVT file to tell OGR (and QGIS) the data type of the different columns:

タイプ

名前

整数値

Integer

4

小数点付き数値

Real

3.456

日付

Date (YYYY-MM-DD)

2016-07-28

時刻

Time (HH:MM:SS+nn)

18:33:12+00

日付と時刻

DateTime (YYYY-MM-DD HH:MM:SS+nn)

2016-07-28 18:33:12+00

CSVTファイルは、データ型が引用符で囲まれ、コンマで区切られた 一行 のプレーンテキストファイルです(例:::)

"Integer","Real","String"

各列の幅と精度を指定することもできます、例::

"Integer(6)","Real(5.5)","String(22)"

このファイルは .csv ファイルと同じフォルダに同じ名前で保存されますが、拡張子は .csvt です。

You can find more information at GDAL CSV Driver.

13.3.2.4. PostGIS レイヤー

PostGIS layers are stored in a PostgreSQL database. The advantages of PostGIS are spatial indexing, filtering and querying capabilities. Using PostGIS, vector functions such as select and identify work more accurately than they do with OGR layers in QGIS.

ちなみに

PostGIS Layers

Normally, a PostGIS layer is identified by an entry in the geometry_columns table. QGIS can load layers that do not have an entry in the geometry_columns table. This includes both tables and views. Refer to your PostgreSQL manual for information on creating views.

This section contains some details on how QGIS accesses PostgreSQL layers. Most of the time, QGIS should simply provide you with a list of database tables that can be loaded, and it will load them on request. However, if you have trouble loading a PostgreSQL table into QGIS, the information below may help you understand QGIS messages and give you directions for modifying the PostgreSQL table or view definition to allow QGIS to load it.

13.3.2.4.1. 主キー

QGISは、PostgreSQLレイヤーがレイヤーの一意のキーとして使用できる列を含むことが必要です。テーブルの場合、これは通常、テーブルに主キー、またはそれに一意制約を持つ列を必要とすることを意味します。QGISでは、この列は、型INT4(サイズ4バイトの整数)であることが必要です。あるいは、CTID列が主キーとして使用できます。テーブルには、これらの項目がない場合、OID列が代わりに使用されます。列が索引化されると性能が向上します(主キーはPostgreSQLでは自動的に索引化されていることに注意)。

QGIS offers a checkbox Select at id that is activated by default. This option gets the ids without the attributes, which is faster in most cases.

13.3.2.4.2. ビュー

PostgreSQLのレイヤーがビューである場合は、同じ要件が存在しますが、ビューはいつでもそれらの上にユニーク制約に主キーまたは列を持ってはいません。ビューをロードする前に、QGISダイアログ内の主キーフィールド(整数である必要があります)を定義する必要があります。適切な列がビューに存在しない場合、QGISはそのレイヤーをロードしません。このような場合、解決は、適切な列(整数の種類と主キーまたは一意性制約のいずれか、好ましくは索引付け)が含まないようにビューを変更することです。

テーブルに関しては、チェックボックス IDで選択 がデフォルトで有効になっています(チェックボックスの意味については上記参照)。高価なビューを使用する場合は、このオプションを無効にすることができます。

13.3.2.4.3. QGIS layer_style テーブルとデータベースのバックアップ

If you want to make a backup of your PostGIS database using the pg_dump and pg_restore commands, and the default layer styles as saved by QGIS fail to restore afterwards, you need to set the XML option to DOCUMENT before the restore command:

SET XML OPTION DOCUMENT;

13.3.2.4.4. データベース側をフィルタ

QGIS allows to filter features already on server side. Check Settings ▶ Options ▶ Data Sources ▶ checkbox Execute expressions on server-side if possible to do so. Only supported expressions will be sent to the database. Expressions using unsupported operators or functions will gracefully fallback to local evaluation.

13.3.2.4.5. PostgreSQL データ型のサポート

Data types supported by the PostgreSQL provider include: integer, float, boolean, binary object, varchar, geometry, timestamp, array, hstore and json.

13.3.2.5. PostgreSQLへデータをインポートする

データはDB Managerプラグインとコマンドラインツールのshp2pgsqlとogr2ogrなど、いくつかのツールを使用して、PostgreSQL/ PostGISにインポートできます。

13.3.2.5.1. DBマネージャ

QGIS comes with a core plugin named dbManager DB Manager. It can be used to load data, and it includes support for schemas. See section DB Manager Plugin for more information.

13.3.2.5.2. shp2pgsql

PostGIS includes a utility called shp2pgsql, that can be used to import Shapefile format datasets into a PostGIS-enabled database. For example, to import a Shapefile format dataset named lakes.shp into a PostgreSQL database named gis_data, use the following command:

shp2pgsql -s 2964 lakes.shp lakes_new | psql gis_data

This creates a new layer named lakes_new in the gis_data database. The new layer will have a spatial reference identifier (SRID) of 2964. See section 投影法の利用方法 for more information about spatial reference systems and projections.

ちなみに

PostGISからデータセットをエキスポートする

There is also a tool for exporting PostGIS datasets to Shapefile format: pgsql2shp. It is shipped within your PostGIS distribution.

13.3.2.5.3. ogr2ogr

In addition to shp2pgsql and DB Manager, there is another tool for feeding geographical data in PostGIS: ogr2ogr. It is part of your GDAL installation.

To import a Shapefile format dataset into PostGIS, do the following:

ogr2ogr -f "PostgreSQL" PG:"dbname=postgis host=myhost.de user=postgres
password=topsecret" alaska.shp

This will import the Shapefile format dataset alaska.shp into the PostGIS database postgis using the user postgres with the password topsecret on the host server myhost.de.

Note that OGR must be built with PostgreSQL to support PostGIS. You can verify this by typing (in nix):

ogrinfo --formats | grep -i post

If you prefer to use the PostgreSQL's COPY command instead of the default INSERT INTO method, you can export the following environment variable (at least available on nix and osx):

export PG_USE_COPY=YES

ogr2ogr does not create spatial indexes like shp2pgsl does. You need to create them manually, using the normal SQL command CREATE INDEX afterwards, as an extra step (as described in the next section パフォーマンスの改善).

13.3.2.5.4. パフォーマンスの改善

Retrieving features from a PostgreSQL database can be time-consuming, especially over a network. You can improve the drawing performance of PostgreSQL layers by ensuring that a PostGIS spatial index exists on each layer in the database. PostGIS supports creation of a GiST (Generalized Search Tree) index to speed up spatial searching (GiST index information is taken from the PostGIS documentation available at https://postgis.net).

ちなみに

You can use the DBManager to create an index for your layer. You should first select the layer and click on Table ▶ Edit table, go to Indexes tab and click on Add Spatial Index.

The syntax for creating a GiST index is:

CREATE INDEX [indexname] ON [tablename]
  USING GIST ( [geometryfield] GIST_GEOMETRY_OPS );

Note that for large tables, creating the index can take a long time. Once the index is created, you should perform a VACUUM ANALYZE. See the PostGIS documentation (POSTGIS-PROJECT in 文献とWeb参照) for more information.

The following example creates a GiST index:

[email protected]ison:~/current$ psql gis_data
Welcome to psql 8.3.0, the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help with psql commands
       \g or terminate with semicolon to execute query
       \q to quit

gis_data=# CREATE INDEX sidx_alaska_lakes ON alaska_lakes
gis_data-# USING GIST (the_geom GIST_GEOMETRY_OPS);
CREATE INDEX
gis_data=# VACUUM ANALYZE alaska_lakes;
VACUUM
gis_data=# \q
[email protected]:~/current$

13.3.2.6. 経度 180° をまたぐベクターレイヤー

Many GIS packages don't wrap vector maps with a geographic reference system (lat/lon) crossing the 180 degrees longitude line (http://postgis.refractions.net/documentation/manual-2.0/ST_Shift_Longitude.html). As result, if we open such a map in QGIS, we could see two widely separated locations, that should appear near each other. In Figure_vector_crossing, the tiny point on the far left of the map canvas (Chatham Islands) should be within the grid, to the right of the New Zealand main islands.

../../../_images/vectorNotWrapping.png

図 13.21 180° 経線を横断する緯度/経度での地図

この問題の回避方法は経度の値を PostGIS の ST_Shift_Longitude 関数を使って変換することです この関数はジオメトリの各地物の各コンポーネント中の点/頂点を読み、その経度が < 0° の場合 360° を加算します。その結果は 0° - 360° の間になり 180° が中心の地図にプロットできます。

../../../_images/vectorWrapping.png

図 13.22 経度 180° をまたぐため ST_Shift_Longitude 関数の適用した結果

13.3.2.6.1. 利用方法

  • DBマネージャプラグインを利用したPostGIS (PostgreSQLへデータをインポートする) へのデータインポート例.

  • PostGISコマンドラインインターフェイスを利用して以下のコマンドを発行して下さい (これは例で "TABLE" のところはあなたのPostGISテーブルの実際の名前にして下さい): gis_data=# update TABLE set the_geom=ST_Shift_Longitude(the_geom);

  • すべてがうまくいけば更新された地物の数についての確認を求められます,それから地図をロードして違いを見ることができるでしょう (Figure_vector_crossing_map).

13.3.2.7. SpatiaLite レイヤー

If you want to save a vector layer using the SpatiaLite format, you can do this by following instructions at Creating new layers from an existing layer. You select SpatiaLite as Format and enter both File name and Layer name.

Also, you can select SQLite as format and then add SPATIALITE=YES in the Custom Options ▶ Data source field. This tells GDAL to create a SpatiaLite database. See also https://gdal.org/drivers/vector/sqlite.html.

QGIS also supports editable views in SpatiaLite. For SpatiaLite data management, you can also use the core plugin DB Manager.

新しいSpatiaLiteレイヤを作成したい場合は 新しいSpatiaLiteレイヤーを作成する を参照して下さい。

13.3.2.8. GeoJSON specific parameters

When exporting layers to GeoJSON, there are some specific Layer Options available. These options come from GDAL which is responsible for the writing of the file:

  • COORDINATE_PRECISION the maximum number of digits after the decimal separator to write in coordinates. Defaults to 15 (note: for Lat Lon coordinates 6 is considered enough). Truncation will occur to remove trailing zeros.

  • RFC7946 by default GeoJSON 2008 will be used. If set to YES, the updated RFC 7946 standard will be used. Default is NO (thus GeoJSON 2008). See https://gdal.org/drivers/vector/geojson.html#rfc-7946-write-support for the main differences, in short: only EPSG:4326 is allowed, other crs's will be transformed, polygons will be written such as to follow the right-hand rule for orientation, values of a "bbox" array are [west, south, east, north], not [minx, miny, maxx, maxy]. Some extension member names are forbidden in FeatureCollection, Feature and Geometry objects, the default coordinate precision is 7 decimal digits

  • WRITE_BBOX set to YES to include the bounding box of the geometries at the feature and feature collection level

Besides GeoJSON there is also an option to export to "GeoJSON - Newline Delimited" (see https://gdal.org/drv_geojsonseq.html). Instead of a FeatureCollection with Features, you can stream one type (probably only Features) sequentially separated with newlines.

GeoJSON - Newline Delimited has some specific Layer options availabe too:

  • COORDINATE_PRECISION see above (same as for GeoJSON)

  • RS whether to start records with the RS=0x1E character. The difference is how the features are separated: only by a newline (LF) character (Newline Delimited JSON, geojsonl) or by also prepending a record-separator (RS) character (giving GeoJSON Text Sequences, geojsons). Default to NO. Files are given the .json extension if extension is not provided.

13.3.2.9. DB2 空間レイヤー

IBM DB2 for Linux、UnixおよびWindows(DB2 LUW)、IBM DB2 for z / OS(メインフレーム)およびIBM DashDB製品では、空間データを関係テーブルの列に格納および分析できます。 QGISのDB2プロバイダーは、これらのデータベースの空間データの視覚化、分析、操作の全範囲をサポートしています。

これらの機能に関するユーザーマニュアルは、 DB2 z/OS KnowledgeCenter, DB2 LUW KnowledgeCenterDB2 DashDB KnowledgeCenter にあります。

DB2空間機能の操作の詳細については、IBM DeveloperWorksの DB2 Spatial Tutorial を参照してください。

DB2プロバイダーは現在、Windows ODBCドライバーを介してWindows環境のみをサポートしています。

QGISを実行しているクライアントには、次のいずれかがインストールされている必要があります。

  • DB2 LUW

  • IBMデータサーバードライバパッケージ

  • IBMデータサーバークライアント

To open a DB2 data in QGIS, see the ブラウザパネル or データベースレイヤーをロードする section.

If you are accessing a DB2 LUW database on the same machine or using DB2 LUW as a client, the DB2 executables and supporting files need to be included in the Windows path. This can be done by creating a batch file like the following with the name db2.bat and including it in the directory %OSGEO4W_ROOT%/etc/ini:

@echo off
REM Point the following to where DB2 is installed
SET db2path=C:\Program Files (x86)\sqllib
REM This should usually be ok - modify if necessary
SET gskpath=C:\Program Files (x86)\ibm\gsk8
SET Path=%db2path%\BIN;%db2path%\FUNCTION;%gskpath%\lib64;%gskpath%\lib;%path%