Outdated version of the documentation. Find the latest one here.

14.2. Lesson: Géoréférencer une carte

Une tâche usuelle en forêt est la mise à jour des informations pour une zone forestière. Il est possible que les informations précédentes pour cette zone datent de plusieurs années et ont été collectées en analogique (c’est à dire sur papier) ou peut-être quelles ont été digitalisées mais que vous avez seulement une version papier de ces données d’inventaire.

Il est probable que vous souhaitiez utiliser cette information dans votre SIG pour, par exemple, comparer les nouveaux inventaires avec des anciens. Cela signifie que vous aller avoir besoin de digitaliser l’information obtenue manuellement en utilisant votre logiciel de SIG. Mais dans un premier temps, vous allez devoir scanner et géo-référencer votre carte papier.

Objectif de cette leçon : Apprendre à utiliser l’outil Géoréférencer dans QGIS.

14.2.1. basic Numériser la carte

La première tâche que vous devrez faire est de numériser votre carte. Si votre carte est trop grande, alors vous pouvez la numériser en différentes parties mais gardez en tête que vous devrez répéter les tâches de prétraitement et de géoréférencement pour chaque parties. Donc si cela est possible, numérisez la carte en le moins de parties possible.

Si vous utilisez une carte différente que celle fournie avec ce manuel, utilisez votre propre scanner pour numériser la carte en tant que fichier image, avec une résolution de 300 DPI. Si votre carte est en couleur, scannez l’image en couleur pour que vous puissiez plus tard utiliser ces couleurs pour séparer les informations de votre carte dans différentes couches (par ex, massifs forestiers, lignes de contour, routes...).

Pour cet exercice vous utiliserez une carte précédemment numérisée, vous pouvez la trouver en tant que rautjarvi_map.tif sous le dossier de données exercise_data/forestry.

14.2.2. basic Follow Along: Géoréférencer la carte numérisée

Ouvrez QGIS et configurez le SCR du projet comme kbd:ETRS89 / ETRS-TM35FIN dans Project ‣ Propriétés du projet ‣ SCR, qui est le SCR couramment utilisé en Finlande. Assurez-vous que Activer la projection ‘à la volée’ est coché, puique nous travaillerons avec des anciennes données qui ont un autre SCR.

../../../_images/f_1.png

Sauvegardez le projet QGIS sous map_digitizing.qgs.

Vous utiliserez l’extension géoréférencement de QGIS, l’extension est déjà installée dans QGIS. Activez l’extension en utilisant le gestionnaire d’extensions comme vous l’avez fait dans des modules précédents. L’extension est appelée Georeferencer GDAL.

Pour géoréférencer la carte :

  • Ouvrez l’outil de géoréférence, Raster ‣ Géoréférencer ‣ Georeferencer.

  • Add the the map image file, :kdb:`rautjarvi_map.tif`, as the image to georeferenciate, File ‣ Open raster.
  • Quand demandé, trouvez et sélectionnez le SCR KKJ / Finland zone 2, c’est le SCR qui a été utilisé en Finlande en 1994 lorsque cette carte a été créée.

  • Cliquez sur OK.

Ensuite, vous devez définir les paramètres de transformation pour le géoréférencement de la carte :

  • Ouvrez Paramètres ‣ Paramètres de transformation.

  • Cliquez sur l’icône à côté de la boîte Raster de sortie, allez dans le dossier et créez le dossier exercise_data\forestry\digitizing et nommez le fichier rautjarvi_georef.tif.

  • Mettez le reste des paramètres comme montré ci-dessous.

../../../_images/Clipboard10.png
  • Cliquez sur OK.

La carte contient plusieurs croix marquant les coordonnées dans la carte, nous les utiliserons pour géoréférencer cette carte. Vous pouvez utiliser les outils de zoom et de déplacement comme vous le faites habituellement dans QGIS pour inspecter l’image dans la fenêtre du Georeferencer.

  • Zoom in to the left lower corner of the map and note that there is a cross-hair with a coordinate pair, x and y, that as mentioned before are in KKJ / Finland zone 2 CRS.You will use this point as the first ground control point for the georeferencing your map.
  • Sélectionnez l’outil Ajouter un point et cliquez sur l’intersection de la croix (déplacez-vous et zoomez au besoin).

  • Dans la boîte de dialogue Enter les coordonnées de la carte écrivez les coordonnées qui apparaissent dans la carte (X: 2557000 et Y: 6786000).

  • Cliquez sur OK.

La première coordonnée pour le géoréférencement est maintenant prête.

Recherchez d’autres réticules dans l’image faite de lignes noires, ils sont séparés de 1000 mètres dans les deux directions Nord et Est. Vous devriez être capable de de calculer les coordonnées de ces points par comparaison au premier.

Zoom out in the image and move to the right until you find other cross-hair, and estimate how many kilometres you have moved. Try to get ground control points as far from each other as possible. Digitize at least three more ground control points in the same way you did the first one. You should en up with something similar to this:

../../../_images/Clipboard09.png

Dès que vous aurez trois points de contrôle, vous allez pouvoir évaluer l’erreur de géo-référencement sous la forme d’une ligne rouge à l’extérieur des points. Les pixels d’erreur sont visibles aussi dans GCP table dans les colonnes dX[pixels] et dY[pixels] . L’erreur en pixel ne doit pas être supérieure à 10 pixels, si c’est les cas vous devez vérifier les coordonnées que vous avez saisi pour trouver quel est le problème. Vous pouvez utiliser l’image ci-dessus comme un guide.

Une fois que vous êtes satisfait de vos points de contrôle, sauvegardez vos points de contrôle, au cas où vous en auriez besoin plus tard, et vous pourrez :

Enfin, géoréférencez votre carte :

  • Fichier ‣ Commencer le géoréférencement.

  • Notez que vous avez déjà nommé le fichier rautjarvi_georef.tif quand vous avez configuré les paramètres du Géoréférenceur.

Vous pouvez maintenant voir la carte dans le projet QGIS comme un raster géoréférencé. Notez que le raster semble être légèrement tourné, mais c’est simplement à cause du fait que les données sont dans KKJ / Finland zone 2 et votre projet dans ETRS89 / ETRS-TM35FIN.

To check that your data is properly georeferenced you can open the aerial image in the exercise_dataforestry folder, named rautjarvi_aerial.tif. Your map and this image should match quite well. Set the map transparency to 50% and compare it to the aerial image.

../../../_images/Clipboard14.png

Sauvegardez les changements dans votre projet QGIS, vous continuerez à partir de ce point pour la prochaine leçon.

14.2.3. In Conclusion

Comme vous l’avez vu, géoréférencez une carte papier est une opération relativement simple.

14.2.4. What’s Next?

Dans la prochaine leçon, vous numériserez les massifs forestiers de votre carte sous forme de polygones et ajoutez pour eux les données d’inventaire.