Outdated version of the documentation. Find the latest one here.

QGIS Configuration

QGIS is highly configurable through the Settings menu. Choose between Project Properties, Options and Customization.

Nota

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described below could be in the Project or the Settings menu.

Proprietà progetto

In the properties window for the project under nix Settings ‣ Project Properties (kde) or nix osx win Project ‣ Project Properties (Gnome, OS X or Windows), you can set project-specific options.

  • In the General menu, the general settings let you:

    • give a title to the project beside the project file path
    • choose the color to use for features when they are selected
    • choose the background color: the color to use for the map canvas
    • set whether the path to layers in the project should be saved as absolute (full) or as relative to the project file location. You may prefer relative path when both layers and project files can be moved or shared or if the project is accessed from computers on different platforms.
    • choose to avoid artifacts when project is rendered as map tiles. Note that checking this option can lead to performance degradation.

    Calculating areas and distances is a common need in GIS. However, these values are really tied to the underlying projection settings. The Measurements frame lets you control these parameters. You can indeed choose:

    • the ellipsoid to use: it can be an existing one, a custom one (you’ll need to set values of the semi-major and semi-minor axis) or None/Planimetric.
    • the units for distance measurements for length and perimeter and the units for area measurements. These settings, which default to the units set in QGIS options but then overrides it for the current project, are used in:
      • Attribute table field update bar
      • Field calculator calculations
      • Identify tool derived length, perimeter and area values
      • Default unit shown in measure dialog

    The Coordinate display allows you to choose and customize the format of units to use to display the mouse coordinate in the status bar and the derived coordinates shown via the identify tool.

    Finally, you can define a project scale list, which overrides the global predefined scales.

Figure General Menu:

../../../_images/project_general.png

General tab of Project Properties dialog

  • La scheda SR permette di scegliere il sistema di riferimento e di abilitare la riproiezione al volo di raster e vettori quando questi hanno un SR diverso.

  • With the Identify layers menu, you set (or disable) which layers will respond to the identify tool. By default, layers are set queryable.
  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colors assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.
  • The tab OWS Server allows you to define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions.
  • La scheda Macro serve per modificare le macro di Python per il progetto. Attualmente sono disponibili tre macro: openProject(), saveProject() e closeProject().

Figure Macro Menu:

../../../_images/macro.png

Macro settings in QGIS

  • La scheda Relazioni permette di impostare relazioni 1:n. Le relazioni sono definite nella finestra di dialogo delle proprietà del progetto. Una volta impostate le relazioni per un vettore, la vista modulo (cioè quando si interroga il vettore con lo strumento informazioni elemento) elencherà le relazioni in una finestra dedicata. Le relazioni 1:n sono uno strumento molto prezioso che può essere utilizzato, per esempio, per tenere traccia delle ispezioni storiche di un tratto stradale o di manutenzione delle tubature. Per maggiori informazioni sulle relazioni 1:n dai un’occhiata alla sezione Creare relazioni uno a molti.

Opzioni dell’interfaccia grafica (GUI)

options Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ options Options. The tabs where you can customize your options are described below.

Menu Generale

Applicazione

  • Select the Style (QGIS restart required) selectString and choose between ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlooks’ (nix).
  • Define the Icon theme selectString. Currently only ‘default’ is possible.
  • Define the Icon size selectString.
  • Define the Font. Choose between radioButtonOn Qt default and a user-defined font.
  • Change the Timeout for timed messages or dialogs selectString.
  • checkbox Nascondi lo splash screen all’avvio

  • checkbox Mostra suggerimenti all’avvio

  • checkbox Titoli del gruppo box in grassetto

  • checkbox Box gruppi secondo stile QGIS

  • checkbox Use native color chooser dialogs
  • checkbox Use live-updating color chooser dialogs
  • checkbox Custom side bar style
  • checkbox Experimental canvas rotation support (restart required)

File di progetto

  • Open project on launch selectString (choose between ‘New’, ‘Most recent’ and ‘Specific’). When choosing ‘Specific’ use the browseButton to define a project.
  • checkbox Crea un nuovo progetto dal progetto predefinito. Puoi scegliere Definisce il progetto attuale come predefinito oppure Ripristina il predefinito. Sfoglia fra i tuoi file e specifica la cartella in cui sono presenti i progetti da usare come modello. Se hai spuntato la casella di controllo checkbox Crea un nuovo progetto dal progetto predefinito e hai salvato un progetto nella cartella dei modelli, comparirà la nuova voce Progetto ‣ Nuovo da modello.

  • checkbox Chiedi di salvare il progetto e cambia sorgente dati quando richiesto

  • checkbox Prompt for confirmation when a layer is to be removed
  • checkbox Avvisa quando viene aperto un file di progetto salvato con una vecchia versione di QGIS

  • Enable macros selectString. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

Menu Sistema

Ambiente

Il gruppo Ambiente mostra le variabili di ambiente e permette anche di configurarle (vedi figure_environment_variables). Questa opzione è particolarmente utile per piattaforme stile Mac, dove le applicazioni GUI non ereditano necessariamente l’ambiente shell dell’utente. È utile anche per impostare/visualizzare le variabili di ambiente usate da strumenti esterni, gestiti da Processing come, SAGA e GRASS. Infine è utile anche per abilitare gli output del debug per specifiche sezione del codice sorgente.

  • checkbox Usa variabili utente (necessario il riavvio - includere i separatori). Gestisci le variabili con i pulsanti [Aggiungi] e [Rimuovi]. Il Variabili di ambiente attuali ‣ mostra le variabili di ambiente già definite e puoi scegliere di filtrarle spuntando la casella di controllo checkbox Mostrare le sole variabili specifiche di QGIS.

Figure System Environment:

../../../_images/sys-env-options.png

System environment variables in QGIS

Percorsi verso i plugin

[Aggiungi] o [Rimuovi] Percorsi per cercare ulteriori librerie plugin C++

Menu Sorgente dati

Attributi delle geometrie e tabelle

  • checkbox Apri la tabella degli attributi in una finestra agganciata (richiede il riavvio di QGIS)

  • checkbox Copy geometry in WKT representation from attribute table. When using copySelected Copy selected rows to clipboard from the Attribute table dialog, this has the result that the coordinates of points or vertices are also copied to the clipboard.
  • Attribute table behavior selectString. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Attribute table row cache selectNumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Mostra i valori NULL come. Puoi definire un attributo con cui verranno visualizzati i valori NULL (nessun valore).

Trattamento delle sorgenti dati

  • Scan for valid items in the browser dock selectString. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compressed files (.zip) in browser dock selectString. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Richiedi i sublayer raster al caricamento. Alcuni raster supportano i sublayer, chiamati subdataset in GDAL. Un esempio sono i file netCDF: se sono presenti diverse variabili netCDF, GDAL riconosce ogni variabile come un subdataset. L’opzione permette di gestire i sublayer quando uno di questi viene aperto. Puoi scegliere fra:

    • ‘Sempre’: chiede sempre (se sono presenti sublayer)

    • ‘Se necessario’: chiede se il layer non ha bande, ma ha sublayer

    • ‘Mai’: non chiede mai e non carica niente

    • ‘Carica tutto’: non chiede, ma carica tutti i sublayer

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Add PostGIS layers with double click and select in extended mode
  • checkbox Aggiungi layer Oracle con un doppio click e seleziona modalità estesa

  • checkbox Execute expressions on server-side if possible
  • checkbox create transaction groups automatically whenever possible (Experimental). When this mode is turned on, all (postgres) layers from the same database are synchronised in their edit state, i.e. when one layer is put into edit state, all are, when one layer is committed or one layer is rolled back, so are the others. Also, instead of buffering edit changes locally, they are directly sent to a transaction in the database which gets committed when the user clicks save layer.

Hidden Browser Path

This widget lists all the folder you chose to hide from the Browser panel. Removing a folder from the list will make it available in the Browser panel.

Menu Visualizzazione

Rendering behavior

  • checkbox Per impostazione predefinita i nuovi layer aggiunti alla mappa vengono visualizzati subito

  • checkbox Usa il caching del disegno quando possibile per velocizzare la visualizzazione

  • checkbox Visualizza i layyer in parallelo usando più processori della CPU

  • checkbox Numero massimo di processori

  • Intervallo dio aggiornamento della mappa (predefinito a 250 ms)

  • checkbox Enable feature simplification by default for newly added layers
  • Semplifica dal lato provider se possibile

  • checkbox Semplifica dal lato provider se possibile

  • Scala massima alla quale il layer dovrebbe essere semplificato

Impostazioni di visualizzazione

  • checkbox Rendi le linee meno irregolari a spese delle prestazioni

Raster

  • Con Selezione banda RGB puoi scegliere il numero di bande rosse, verdi e blu.

Miglioramento contrasto

  • Single band gray selectString. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectString. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectString. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectString. Options are ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’.
  • Limiti di taglio del conteggio cumulativo pixel

  • Moltiplicatore deviazione standard

Debugging

  • checkbox Aggiornamento della visualizzazione della mappa

Menu Colori

This menu allows you to add some custom color that you can find in each color dialog window of the renderers. You will see a set of predefined colors in the tab: you can delete or edit all of them. Moreover you can add the color you want and perform some copy and paste operations. Finally you can export the color set as a gpl file or import them.

Menu Mappa & Legenda

Aspetto della mappa (modificato dalle proprietà del progetto)

  • Scegli un Colore della selezione e un Colore di sfondo

Legenda dei layer

  • Double click action in legend selectString. You can either ‘Open layer properties’ or ‘Open attribute table’ with the double click.
  • Puoi scegliere diverse opzioni per gli Stili elementi legenda:

    • checkbox Nomi dei layer in maiuscolo

    • checkbox Nomi dei layer in grassetto

    • checkbox Nomi gruppo in grassetto

    • checkbox Visualizza nomi di classificazione degli attributi

    • checkbox Crea le icone raster (potrebbe essere lento)

Menu Strumenti mappa

This menu offers some options regarding the behavior of the Identify tool.

  • Raggio di ricerca per identificare e visualizzare le relative informazioni sulla mappa è un fattore di tolleranza espressa come percentuale della larghezza mappa. Ciò significa che lo strumento di informazione mostrerà i risultati se si fa clic all’interno di questa tolleranza.

  • Colore di evidenziaione di scegliere con quale colore saranno evidenziati gli elementi identificati.

  • Buffer determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width determines how thick should the outline of a highlighted object be.

Strumenti di misura

  • Colore elastico

  • Posizioni decimali

  • checkbox Keep base unit to not automatically convert large numbers (e.g., meters to kilometers)
  • Preferred distance units radioButtonOn (‘Meters’, ‘Feet’, ‘Nautical Miles’, ‘Degrees’ or ‘Map Units’ )
  • Preferred area units radioButtonOn (‘Square meters’, ‘Square feet’, ‘Square yards’, ‘Hectares’, ‘Map Units’ ...)
  • Preferred angle units radioButtonOn (‘Degrees’, ‘Radians’, ‘Gon/gradians’, ‘Minutes of arc’ ...)

Spostamento e zoom

  • Define Mouse wheel action selectString (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Fattore di zoom

Scale preimpostate

Here, you find a list of predefined scales. With the signPlus and signMinus buttons you can add or remove your personal scales. You can also import or export scales from/to a .XML file. Note that you still have the possibility to remove your changes and reset to the predefined list.

Menu Compositore

Opzioni predefinite del compositore

You can define the Default font here.

Reticolo

  • Define the Grid style selectString (‘Solid’, ‘Dots’, ‘Crosses’)
  • Define the Grid color

Grid and guide defaults

  • Define the Grid spacing selectNumber
  • Define the Grid offset selectNumber for x and y
  • Define the Snap tolerance selectNumber

Menu Digitalizzazione

Creazione di geometrie

  • checkbox Non aprire la finestra degli attributi dopo la creazione di ogni geometria

  • checkbox Ripeti i valori degli attributi usati per ultimi

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Elastico

  • Definisci le proprietà dell’elastico, Spessore della linea e Colore della linea

Snapping

  • checkbox Apri le opzioni di snap in una finestra agganciata (richiede il riavvio di QGIS)

  • Define Default snap mode selectString (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Imposta la Tolleranza di snapping predefinita in unità di mappa o pixel

  • Imposta il Raggio di ricerca per le modifiche dei vertici in unità di mappa o in pixel

Indicatori di vertice

  • checkbox Utilizza indicatori solo per le geometrie selezionate

  • Define vertex Marker style selectString (‘Cross’ (default), ‘Semi transparent circle’ or ‘None’)
  • Specifica le Dimensioni indicatore

Strumento per la curva di offset

The next 3 options refer to the offsetCurve Offset Curve tool in Digitalizzazione avanzata. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Stile unione

  • Segmenti di quadrante

  • Limite di smusso

Menu GDAL

GDAL è una libreria di lettura e scrittura per file raster. In questa scheda puoi Modificare le opzioni di creazione e Modificare le opzioni per le piramidi. Scegli quali driver GDAL devono essere utilizzati per un formato raster specifico poiché spesso sono disponibili più driver GDAL per lo stesso formato.

Menu SR

SR predefinito per nuovi progetti

  • radioButtonOff Don’t enable ‘on the fly’ reprojection
  • radioButtonOn Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radioButtonOff Enable ‘on the fly’ reprojection by default
  • Seleziona un SR e Inizia un nuovo progetto sempre con questo SR

SR per i nuovi layer

Questa sezione permette di specificare il comportamento di QGIS quando viene creato un nuovo layer oppure quando viene caricato un layer privo di SR.

  • radioButtonOn Prompt for CRS
  • radioButtonOff Use project CRS
  • radioButtonOff Use default CRS

Trasformazioni datum predefinite

  • checkbox Chiedi la trasformazione del datum quando non è definito un valore di riferimento

  • Se hai lavorato con la trasformazione del SR ‘al volo’ puoi vedere i risultati della trasformazione nella finestra di sotto. Questa finestra mostra infatti le informazioni del ‘SR sorgente’, ‘SR destinazione’, ‘Trasformazione datum sorgente’ e ‘Trasformazione datum destinazione’.

Menu Lingua

  • checkbox Sovrascrivi lingua in uso

  • Informazioni sulla lingua correntemente impostata nel sistema

Authentication

In the Authentication tab you can set authentication configurations and manage PKI certificates. See Authentication System for more details.

Menu Rete

Generale

  • Indirizzo di ricerca WMS (Quello predefinito è “http://geopole.org/wms/search?search=%1&type=rss”)

  • Imposta il Timeout per le richieste di rete (ms) - il valore predefinito è 60000

  • Imposta il Periodo di scadenza predefinito per piastrelle WMSC/WMTS (ore) - valore standard è 24

  • Specifica il Numero massimo di tentativi in caso di errore nella richiesta della mattonella

  • Definisci l’Utente-Agente

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

Impostazioni della cache

Specifica la Cartella e la Dimensione per la cache.

  • checkbox Utilizza un proxy per l’accesso web, definizione di host, porta, utente e password.

  • Set the Proxy type selectString according to your needs.
    • Default Proxy:Il proxy è determinato sulla base delle impostazioni in uso del proxy dell’applicazione

    • Socks5Proxy: Proxy generico per ogni tipo di connessione. Supporta TCP, UDP, associazione a una porta (connessione in entrata) e autenticazione.

    • HttpProxy: Realizzato usando il comando “CONNECT”, supporta solamente connessioni TCP in uscita; supporta l’autenticatione.

    • HttpCachingProxy: Realizzato usando normali comandi HTTP, è utile solamente nel contesto di richieste HTTP.

    • FtpCachingProxy: Realizzato usando un proxy FTP, è utile solamente nel contesto di richieste FTP.

È possibile escludere alcuni URL aggiungendo il testo nella sezione dedicata (vedi Figure_Network_Tab).

Per informazioni più dettagliate sulle diverse impostazioni del proxy, fai riferimento al manuale della documentazione delle librerie QT suhttp://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Suggerimento

UTILIZZO DEI PROXY

L’utilizzo dei proxy può risultare complicato. È utile testare i tipi di proxy elencati sopra e controllare il loro funzionamento nel tuo caso specifico.

You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

  • nix Impostazioni sono salvate in file testo $HOME/.config/QGIS/QGIS2.conf

  • osx puoi trovare le impostazioni in: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win le impostazioni sono salvate nel resistro: HKEY\CURRENT_USER\Software\QGIS\qgis

Personalizzazione

The customization dialog lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you want to provide your end-users with a ‘light’ version of QGIS, containing only the icons, menus or panels they need.

Nota

Before your changes are applied, you need to restart QGIS.

Figure Customization 1:

../../../_images/customization.png

The Customization dialog

Ticking the checkbox Enable customization checkbox is the first step on the way to QGIS customization. This enables the toolbar and the widget panel from which you can uncheck and thus disable some GUI items.

The configurable item can be:

  • a Menu or some of its sub-menus from the Barra dei Menu
  • a whole Panel (see Panels and Toolbars)
  • the Status bar described in label_statusbar or some of its items
  • a Toolbar: the whole bar or some of its icons
  • or any widget from any dialog in QGIS: label, button, combobox...

With select Switch to catching widgets in main application, you can click on an item in QGIS interface that you want to be hidden and QGIS automatically unchecks the corresponding entry in the Customization dialog.

Once you setup your configuration, click [Apply] or [Ok] to validate your changes. This configuration becomes the one used by default by QGIS at the next startup.

The modifications can also be saved in a .ini file using fileSave Save To File button. This is a handy way to share a common QGIS interface among multiple users. Just click on fileOpen Load from File from the destination computer in order to import the .ini file. You can also run command line tools and save various setups for different use cases as well.

Suggerimento

Easily restore predefined QGIS

The initial QGIS GUI configuration can be restored by one of the methods below:

  • unchecking checkbox Enable customization option in the Customization dialog or click the selectAllTree Check All button
  • pressing the [Reset] button in the QSettings frame under Settings ‣ Options menu, System tab
  • launching QGIS at a command prompt with the following command line qgis --nocustomization
  • setting to false the value of UI ‣ Customization ‣ Enabled variable under Settings ‣ Options menu, Advanced tab.

In most cases, you need to restart QGIS in order to have the change applied.