Outdated version of the documentation. Find the latest one here.

QGIS Configuration

QGIS is highly configurable through the Settings menu. Choose between Panels, Toolbars, Project properties, Options and Customization.

Panels and Toolbars

In the Panels‣ menu you can switch on and off QGIS widgets. The Toolbars‣ menu provides the possibility to switch on and off icon groups in the QGIS toolbar (see figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

The Panels and Toolbars menu nix

Truco

Activating the QGIS Overview

In QGIS you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Truco

Show Log Messages

It’s possible to track the QGIS messages. You can activate checkboxLog Messages in the menu Settings ‣ Panels and follow the messages in the General and Plugin tab during loading and operation.

Project Properties

In the properties window for the project under nix Project ‣ Project Properties or win Project ‣ Project Properties you set project specific options. These include:

  • In the General menu the project title, selection and background color, layer units, precision, and the option to save relative paths to layers can be defined. If the CRS transformation is on you can choose an ellipsoid for distance calculations. You can define the canvas units (only used when CRS transformation is disabled) and the precision of decimal places to use. You also can define a project scale list, that overrides the global predefined scales.
  • The CRS menu enables you to choose the Coordinate Reference System for this project, and to enable on-the-fly re-projection of raster and vector layers when displaying layers from a different CRS.
  • With the third Identify layers menu you set (or disable) which layers will respond to the identify tool. (See the Map tools paragraph from the Options section to enable identifying of multiple layers.)
  • The menu Default Styles lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them.
  • The tab OWS Server allows to define information about the QGIS Server WMS and WFS Capabilities, the Extent and the CRS Restrictions.
  • The menu Macros is to create a Python module, saved into a project.qgs file to be loaded and have specific functions run on the following project events: openProject(), saveProject() and closeProject().

Figure Macro Menu:

../../../_images/macro.png

Macro settings in QGIS

Options

mActionOptions Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ mActionOptions Options. The menus where you can optimize your options are:

General Menu

Application

  • Select the Style (QGIS restart required) selectstring and choose between ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlux’ (nix).
  • Define the Icon theme selectstring. Currently only ‘default’ is possible.
  • Define the Icon size selectstring.
  • Define the Font. Choose between radiobuttonon QT default and a user-defined font.
  • Change the Timeout for timed messages or dialogs selectstring.
  • checkbox Hide splash screen at startup
  • checkbox Show tips at startup
  • checkbox Bold group box titles
  • checkbox QGIS-styled group boxes
  • checkbox Use live-updating color chooser dialog

Project files

  • Open project on launch selectstring (choose between ‘New’. ‘Most recent’ and ‘Specific’. When choosing ‘Specific’ use the browsebutton to define a project)
  • checkbox Create new project from default project. You have the possibility to press on Set current project as default or on Reset default. You can browse through your files and define a directory where you find your user-defined project templates. There will be an entry in Project ‣ New From Template if you first activate checkbox Create new project from default project and then save a project in the project templates folder.
  • checkbox Prompt to save project and data source changes when required
  • checkbox Warn when opening a project file saved with an older version of |qg|
  • Enable macros selectstring. This option was created to handle macros which are written to perform an action

on project events. You can chosse between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

System Menu

Environment

System environment variables can now be viewed and many configured in the Environment menu (see figure_environment_variables). This is useful for platforms, such as Mac, where a GUI application does not necessarily inherit the user’s shell environment. It’s also useful for setting/viewing environment variables for the external tool sets controlled by the processing toolbox, e.g. SAGA, GRASS; and, for turning on debugging output for specific sections of the source code.

  • checkbox Use custom variables (restart required - include separators). You can Add and Remove variables. Current environment variables ‣ are displayed below and it’s possible to checkbox Show only QGIS-specific variables.

Figure System Environment:

../../../_images/sys-env-options.png

System environment variables in QGIS

Plugin paths

  • Add or Remove Path(s) to search for additional C++ plugin libraries

Data Sources Menu

Feature attributes and table

  • checkbox Open attribute table in a dock window (QGIS restart required)
  • checkbox Copy geometry in WKT representation from attribute table. When using mActionCopySelectedCopy selected rows to clipboard from the Attribute table menu then this has the result that also the coordinates of points or vertices are copied to the clipboard.
  • Attribute table behaviour selectstring. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’
  • Attribute table row cache selectstring. This row cache makes it possible to save the last loaded x attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representation for NULL values Here you can define a value for data fields containing a NULL value.

Data source handling

  • Scan for valid items in the browser dock selectstring. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compresses files (.zip) in browser dock selectstring. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Prompt for raster sublayers when opening. Some rasters support sublayers - they are called subdatasets in GDAL. An example is netcdf files - if there are many netcdf variables, GDAL sees every variable as a subdataset. The option is to control how to deal with sublayers when a file with sublayers is opened. You have the following choices:
    • ‘Always’: always ask (if there are existing sublayers)
    • ‘If needed’: ask if layer has no bands, but has sublayers
    • ‘Never’: never prompt, will not load anything
    • ‘Load all’: never prompt, but load all sublayers
  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information this will be ignored by QGIS.
  • checkbox Add PostGIS layer with double click and select in extended mode
  • checkbox Add Oracle layers with double click and select in extended mode

Rendering Menu

Rendering quality

  • checkbox Make lines appear less jagged at the expense of some drawing performance
  • checkbox Fix problems with incorrectly filled polygons

Rasters

  • with RGB band selection you can define the number for the Red, Green and Blue band.

Contrast enhancement

  • Single band gray selectstring. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’
  • Multi band color (byte/band) selectstring. ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectstring. ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectstring. ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’
  • Cumulative pixel count cut limits
  • Standard deviation multiplier

Debugging

  • Show these events in the Log Message panel (under rendering tab): checkbox Map canvas refresh

Canvas and Legend Menu

Default map appearance (overridden by project properties)

  • Define a Selection color and a Background color.

Layer legend

  • Double click action in legend selectstring. You can either ‘Open layer properties’ or ‘Open attribute table’ with the double click.
  • the following Legend item styles are possible
    • checkbox Capitalise layer names
    • checkbox Bold layer names
    • checkbox Bold group names
    • checkbox Display classification attribute names
    • checkbox Create raster icons (may be slow)
    • checkbox Add new layers to selected or current group

Map tools Menu

Identify

  • checkbox Open identify results in a dock window (QGIS restart required)
  • The Mode setting determines which layers will be shown by the Identify tool. By switching to ‘Top down’ or ‘Top down, stop at first’ instead of ‘Current layer’ attributes for all identifiable layers (see the Project properties section under: Projects to set which layers are identifiable) will be shown with the Identify tool.
  • checkbox Open feature form, if a single feature is identified
  • Define Search radius for identifying and displaying map tips as a percentage of the map width

Measure tool

  • Define Rubberband color for measure tools
  • Define Decimal places
  • checkbox Keep base unit
  • Preferred measurements units radiobuttonon (‘meters’ or ‘feet’)`
  • Preferred angle units radiobuttonon (‘Angle’, ‘Radians’ or ‘Gon’)

Panning and zooming

  • Define Mouse wheel action selectstring (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Define Zoom factor for wheel mouse

Predefined scales

Here you find a list of predefined scales. With the ‘+’ and ‘-‘ buttons you can add or remove your individual scales.

Digitizing Menu

Feature creation

  • checkbox Suppress attributes pop-up windows after each created feature
  • checkbox Reuse last entered attribute values
  • Validate geometries. Editing complex lines/polygons with many nodes can end up with very slow rendering. This is because the default validation procedures in QGIS can use a lot of time. To speed up rendering it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Rubberband

  • Define Rubberband Line width and Line color

Snapping

  • checkbox Open snapping options in a dock window (QGIS restart required)
  • Define Default snap mode selectstring (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Define Default snapping tolerance in map units or pixels
  • Define the Search radius for vertex edits in map units or pixels

Vertex markers

  • checkbox Show markers only for selected features
  • Define vertex Marker style selectstring (‘Cross’ (default), ‘Semi transparent circle’ or ‘None’)
  • Define vertex Marker size

Curve offset tool

The next 3 options refer to the mActionOffsetCurve Offset Curve tool in Advanced digitizing. Through the various settings, it is possible to influence the shape of the line offset. These options are possible from GEOS 3.3 .

  • Join style for curve offset
  • Quadrant segments for curve offset
  • Miter limit for curve offset

GDAL Menu

GDAL is a data exchange library for raster files. In this tab you can Edit create options and Edit Pyramids Options of the raster formats. Define which GDAL driver to be used for a raster format as in some cases more than one GDAL driver is available.

CRS Menu

Default CRS for new projects

  • checkbox Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • checkbox Enable on the fly re-projection by default
  • Select a CRS and Always start new projects with this CRS

CRS for new layers

This area allows to define the action, when a new layer is created, or when a layer without CRS is loaded.

  • radiobuttonon Prompt for CRS
  • radiobuttonoff Use project CRS
  • radiobuttonoff Use default CRS displayed below

Locale Tab

  • checkbox Overwrite system locale and Locale to use instead
  • Information about active system locale

Network Tab

General

  • Define WMS search address, default is http://geopole.org/wms/search?search=\%1\&type=rss
  • Define Timeout for network requests (ms) - default is 60000
  • Define Default expiration period for WMSC/WMTS tiles (hours) - default is 24

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

Cache settings

Define the Directory and a Size for the cache.

  • checkbox Use proxy for web access and define ‘Host’, ‘Port’, ‘User’, and ‘Password’.
  • Set the Proxy type selectstring according to your needs.
    • Default Proxy: Proxy is determined based on the application proxy set using
    • Socks5Proxy: Generic proxy for any kind of connection. Supports TCP, UDP, binding to a port (incoming connections) and authentication.
    • HttpProxy: Implemented using the “CONNECT” command, supports only outgoing TCP connections; supports authentication.
    • HttpCachingProxy: Implemented using normal HTTP commands, it is useful only in the context of HTTP requests
    • FtpCachingProxy: Implemented using an FTP proxy, it is useful only in the context of FTP requests

Excluding some URLs can be added to the text box below the proxy-settings (see Figure_Network_Tab).

If you need more detailed information about the different proxy-settings, please refer to the manual of the underlying QT-library-documentation at http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Truco

Using Proxies

Using proxies can sometimes be tricky. It is useful to ‘trial and error’ the above proxy types and check if they succeed in your case.

You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

  • nix settings are saved in a text file: $HOME/.config/QGIS/qgis.conf
  • osx you can find your settings in: $HOME/Library/Preferences/org.qgis.qgis.plist
  • win settings are stored in the registry under: HKEY\CURRENT_USER\Software\QGIS\qgis

Customization

The customization tool lets you (de)activate almost every element in the QGIS user interface. This can get very useful if you have a lot of plug-ins installed that you never use and that are filling your screen.

Figure Customization 1:

../../../_images/customization.png

The Customization dialog nix

QGIS Customization is divided into five groups. In checkbox Menus you can hide entries in the Menu bar. In checkbox Panel you find the panel windows. Panel windows are applications that can be started and used as a floating, top-level window or embedded to the QGIS main window as a docked widget (see also Panels and Toolbars). In the checkbox Status Bar features like the coordinate information can be deactivated. In checkbox Toolbars you can (de)activate the toolbar icons of QGIS and in checkbox Widgets you can (de)activate dialogs as well as their buttons.

With mActionSelect Switch to catching widgets in main application you can click on elements in QGIS you want to be hidden and find the corresponding entry in Customization (see figure_customization). You can also save your various different setups for different use cases as well. Before your changes are applied, you need to restart QGIS.