重要

翻訳は あなたが参加できる コミュニティの取り組みです。このページは現在 89.44% 翻訳されています。

15.1. データを開く

オープンソース・ソフトウェアのエコシステムの一部として、QGISは様々なライブラリの上に構築されています。これらのライブラリは、QGIS独自のプロバイダと組み合わされることで、多くのフォーマットを読み込む機能と、そして多くの場合は書き出す機能も提供しています:

  • ベクタデータ形式: GeoPackage、GML、GeoJSON、GPX、KML、コンマ区切りテキスト、ESRIフォーマット(シェープファイル、ジオデータベース等)、MapInfo、MicroStationファイル形式、AutoCAD DWG/DXF、GRASS、その他多くの形式が含まれます。完全なリストは、 サポートしているベクタ形式 を参照してください。

  • ラスタデータ形式: GeoTIFF、JPEG、ASCII Gridded XYZ、MBTiles、RやIDRISIラスタ、 GDAL Virtual、SRTM、Sentinel Data、ERDAS IMAGINE、ArcInfo Binary Grid、ArcInfo ASCII Grid、その他多くの形式が含まれます。完全なリストは サポートしているラスタ形式 を参照してください。

  • データベース形式:PostgreSQL/PostGIS, SQLite/SpatiaLite, Oracle, MS SQL Server, SAP HANA, MySQL等

  • WebマップとWebデータサービス(WM(T)S、WFS、WCS、CSW、XYZ tiles、ArcGIS services等)もQGISのプロバイダで扱うことが可能です。これらの一部についてのより詳しい情報は OGC / ISOプロトコルの操作 を参照してください。

  • アーカイブされたフォルダからサポートしているフォーマットのファイルを読み込んだり、QML ファイル ( QML-QGISスタイルファイル形式 )などのQGISネイティブ形式や仮想レイヤ、メモリレイヤを使用することができます。

80以上のベクタ形式と140以上のラスタ形式が GDAL とQGISネイティブプロバイダによってサポートされています。

注釈

さまざまな理由により、リストに挙げたすべてのフォーマットがQGISで動作するわけではありません。例えば、外部のプロプライエタリなライブラリを必要とする場合や、お使いのOSのGDAL/OGRのインストールが、使用したいフォーマットをサポートするようにビルドされていない場合もあります。利用可能なフォーマットのリストを確認するには、コマンドラインで ogrinfo --formats (ベクタ用)や gdalinfo --formats (ラスタ用)を実行するか、QGIS上で 設定 ► オプション ► GDAL のメニューを確認してください。

QGISでは、データ形式に応じて、データセットを開くためのさまざまなツールがあります。それらは主に レイヤ ► レイヤの追加 ► メニューまたは レイヤ管理 ツールバー( ビュー ► ツールバー メニューで有効にできます)で使用できます。ただし、これらのツールはすべて データソースマネージャ ダイアログというただ一つのダイアログを指しています。このダイアログは データソースマネージャツールバー にある dataSourceManager データソースマネージャを開く ボタンを押すか、または Ctrl+L を押すと開くことができます。 データソースマネージャ ダイアログ( 図 15.1 )は、ファイルベースのデータやデータベース、QGISがサポートするWebサービスを開くための統一されたインターフェイスを提供します。

../../../_images/datasource_manager.png

図 15.1 QGISのデータソースマネージャダイアログ

このメインエントリポイントの他に、接続されたデータベースを分析したり操作したりする高度な機能を提供する dbManager DBマネージャ プラグインがあります。DBマネージャの機能についての詳細は、 DBマネージャプラグイン を参照してください。

他にも多くのツールやネイティブのプラグイン、サードパーティ製のプラグインがあり、様々なデータ形式を開くのに役立ちます。

この章では、QGISでデータをロードするためにデフォルトで提供されているツールのみを説明します。主に、 データソースマネージャ ダイアログに焦点を当てますが、 各タブの説明だけでなく、データプロバイダやフォーマットの仕様に基づいたツールについても説明します。

15.1.1. ブラウザパネル

ブラウザ は、素早く簡単にデータをプロジェクトに追加する主な方法の一つです。これは、以下の方法で利用できます。

  • dataSourceManager データソースマネージャを開く ボタン( Ctrl+L )を押して開いた データソースマネージャ のタブの一つにブラウザがあります。

  • ビュー ► パネルkde設定 ► パネル )メニューもしくは Ctrl+2 を押すことで開くQGISのパネルとして利用できます。

どちらの場合でも、 ブラウザ はレイヤの種類(ラスタ、ベクタ、テーブル)やデータソースの形式(プレーンまたは圧縮ファイル、データベース、webサービス)に関係なく、ファイルシステム内を検索しジオデータを管理するのに役立ちます。

15.1.1.1. インターフェースについて

ブラウザパネルの上部には、以下の機能を持つボタンがあります:

  • addLayer 選択したレイヤの追加 :レイヤのコンテキストメニューから レイヤをプロジェクトに追加する を選択することでも、マップキャンバスにデータを追加することができます。

  • refresh 再読み込み :ブラウザツリーを更新します

  • filterMap ブラウザのフィルタ :特定のデータを検索するためにブラウザをフィルタリングします。検索語やワイルドカードを入力すると、ブラウザはツリーをフィルタリングして、一致するDBテーブル、ファイル名、フォルダへのパスのみを表示します -- 他のデータやフォルダは表示されません。 図 15.2 のブラウザ(2)パネルの例を参照してください。比較は大文字と小文字を区別するかどうかを指定できます。また、下記のオプションを設定することもできます:

    • 通常 :検索テキストを含むアイテムを表示します

    • ワイルドカード?* の文字を使用して、検索テキストの位置指定を調整した検索を実行できます。

    • 正規表現

  • collapseTree すべて折りたたむ :ツリー全体を折りたたみます

  • metadata プロパティウィジェットの有効化/無効化 :オンに切り替わると、パネルの下部に新しいウィジェットが追加され、選択されたアイテムのメタデータが表示されます。

ブラウザ パネル内のエントリは階層的にまとめられており、いくつかのトップレベルエントリがあります:

  1. お気に入り :よく使用する場所へのショートカットを置くことができる場所です

  2. 空間ブックマーク :よく使用するマップ範囲を保存できる場所です( 地図上の範囲のブックマーク 参照)

  3. プロジェクトホーム :プロジェクトに関連したデータ(の大半)が保存されているフォルダへのクイックアクセスです。デフォルト値は、プロジェクトファイルがあるディレクトリです。

  4. ファイルシステムの ホーム ディレクトリと、ファイルシステムのルートディレクトリ

  5. 接続されているローカルドライブやネットワークドライブ

  6. それから、プラットフォームや基礎となるライブラリにもよりますが、多数のコンテナ / データベース形式やサービスプロトコルのトップレベルエントリがあります:

    • geoPackage GeoPackage

    • spatialite SpatiaLite

    • postgis PostgreSQL

    • hana SAP HANA

    • mssql MS SQL Server

    • oracle Oracle

    • wms WMS/WMTS

    • vectorTileLayer Vector Tiles

    • xyz XYZ Tiles

    • wcs WCS

    • wfs WFS/OGC API-Features

    • afs ArcGIS REST Server

15.1.1.2. ブラウザ項目とのインタラクション

ブラウザは、ブラウザへのドラッグ&ドロップや、ブラウザからキャンバスや レイヤ パネルへのドラッグ&ドロップ、 レイヤ パネルからブラウザ内のレイヤコンテナ(例えばGeoPackage等)へのドラッグ&ドロップをサポートしています。

ブラウザ内のプロジェクトファイルのアイテムは展開することができ、プロジェクトに含まれる(グループを含む)完全なレイヤツリーを表示します。プロジェクトのアイテムはブラウザ内の他のアイテムと同様に扱われるため、(例えばGeoPackageファイルにレイヤアイテムをコピーするために)ブラウザ内でドラッグ&ドロップしたり、ドラッグ&ドロップやダブルクリックで現在のプロジェクトにアイテムを追加したりすることができます。

ブラウザ パネル内の要素を右クリックすると、コンテキストメニューが開きます。

ファイルシステムのディレクトリエントリの場合、コンテキストメニューには次のようなものがあります:

  • 新規 ► は、下記のエントリから選択して新規作成します

    • ディレクトリ...

    • GeoPackage...

    • シェープファイル...

  • お気に入りとして追加 :お気に入りフォルダは好きな時に名前の変更( お気に入りの名前の変更... ) や削除( お気に入りを削除 )ができます。

  • ブラウザから隠す :隠されたフォルダは 設定 ► オプション ► データソース ► ブラウザに表示しないパス の設定で見えるように戻すことができます。

  • このディレクトリの高速スキャン

  • ディレクトリを開く...

  • ターミナルで開く...

  • プロパティ...

  • ディレクトリプロパティ...

プロジェクト内でレイヤとして扱うことのできるリーフエントリについては、コンテキストメニューにサポート項目があります。例えば、非データベース、非サービスベースのベクタ、ラスタ、メッシュデータソースには、以下の項目があります:

  • レイヤエクスポート ► ファイルへ...

  • レイヤをプロジェクトに追加する

  • レイヤのプロパティ

  • 管理 ► "<name of file>" の名前を変更... または "<name of file>" を削除...

  • ファイルに表示

  • ファイルプロパティ...

レイヤのプロパティ エントリを選択すると、(レイヤがプロジェクトに追加された後に ベクタ レイヤや ラスタ レイヤのプロパティで表示されるものと同様な)以下の情報が表示されます:

  • レイヤに関する メタデータ 。メタデータのグループは次のとおりです: プロバイダからの情報 (可能ならば パス はソースへのハイパーリンクで表示されます)、 識別領域アクセス属性 (ベクタレイヤの場合)、 バンド (ラスタレイヤの場合)、 連絡先リンク (ベクタレイヤの場合)、 リファレンス (ラスタレイヤの場合)、 履歴

  • プレビュー パネル

  • ベクタソースの場合は属性テーブル( 属性 パネル内)

ブラウザ を使用してプロジェクトにレイヤを追加するには、次の手順で操作します:

  1. ブラウザ を上記の方法で有効にします。ファイルシステム、データベース、webサービスのブラウザツリーが表示されます。データベースやwebサービスが表示される前に、データベースやwebサービスへ接続する必要があるかもしれません(専用のセクションを参照してください)。

  2. リストの中からレイヤを見つけます。

  3. レイヤのコンテキストメニューを使用するか、レイヤ名をダブルクリックするか、レイヤを マップキャンバス へとドラッグ&ドロップします。これでレイヤは レイヤパネル に追加され、マップキャンバス上で見ることができるようになります。

    Tip

    ブラウザからQGISプロジェクトを直接開く

    プロジェクト名をダブルクリックするか、マップキャンバス上へドラッグ&ドロップすることで、ブラウザパネルからQGISのプロジェクトを直接開くこともできます。

ファイルがロードされたら、マップナビゲーションツールを使用してレイヤをあちこちズームすることができます。レイヤのスタイルを変更するには、凡例内のレイヤ名をダブルクリックするか、レイヤ名を右クリックしてコンテキストメニューから プロパティ を選択し、 レイヤプロパティ ダイアログを開きます。ベクタレイヤのシンボロジ設定の詳細については、 シンボロジプロパティ を参照してください。

ブラウザツリー内のアイテムを右クリックすると、以下の機能があります:

  • ファイルやテーブルについては、メタデータを表示したり、プロジェクト内に開きます。テーブルは名前を変更したり、行を削除したり、全行削除することもできます。

  • フォルダについては、お気に入りにブックマークしたり、ブラウザツリーから隠したりできます。非表示となったフォルダは、 設定 ► オプション ► データソース タブで管理することができます。

  • 空間ブックマーク の管理:ブックマークを作成したり、ブックマークを XML ファイルとしてエクスポートしたり、XML ファイルからインポートしたりできます。

  • データベースやwebサービスへの接続を作成します。

  • 再読み込みや、スキーマ名の変更、スキーマの削除ができます。

また、ファイルをデータベースにインポートしたり、1つのスキーマ/データベースから別のスキーマ/データベースにテーブルをコピーしたりすることもドラッグ&ドロップで簡単に行うことができます。2つ目のブラウザパネルを利用することで、ドラッグ中に長いスクロールを行わずに済みます。ファイルを選択して、一方のパネルから他方のパネルへとドラッグ&ドロップするだけです。

../../../_images/browser_panels.png

図 15.2 横並びのQGISブラウザパネル

Tip

OSのファイルブラウザからドラッグ&ドロップでQGISにレイヤを追加する

オペレーティングシステムのファイルブラウザから レイヤパネル またはマップキャンバスにファイルをドラッグ&ドロップしても、ファイルをプロジェクトに追加できます。

15.1.2. DBマネージャ

DBマネージャ プラグインは、QGISがサポートする空間データベース形式(PostGIS、SpatiaLite、GeoPackage、Oracle Spatial、MS SQL Server、仮想レイヤ)を統合して管理するためのもう一つのツールです。これは、 プラグイン ► プラグインの管理とインストール... メニューから有効化することができます。

dbManager DBマネージャ プラグインにはさまざまな機能があります。

  • データベースに接続し、その構造や内容を表示する

  • データベースのテーブルをプレビューする

  • ダブルクリックまたはドラッグ&ドロップで、マップキャンバスへレイヤを追加する

  • QGISブラウザや他のデータベースから、データベースにレイヤを追加する

  • SQLクエリを作成し、実行結果をマップキャンバスへ追加する

  • 仮想レイヤ を作成する

DBマネージャの機能に関する更なる情報は、 DBマネージャプラグイン を参照してください。

../../../_images/db_manager.png

図 15.3 DBマネージャダイアログ

15.1.3. プロバイダベースの読み込みツール

ブラウザパネルとDBマネージャはレイヤを追加するためにQGISが提供する主なツールですが、この他に、データプロバイダに特化したツールもあります。

注釈

いくつかの 外部プラグイン も、QGISで特定の形式のファイルを開くためのツールを提供しています。

15.1.3.1. ファイルからレイヤを読み込む

ファイルからレイヤを読み込むには、次の手順で操作します:

  1. データソースマネージャ ダイアログでレイヤタイプのタブを開きます。つまり、 dataSourceManager データソースマネージャを開く ボタン(または Ctrl+L )を押し、目的のタブを有効にします。 もしくは、

    • ベクタデータ(GML、ESRIシェープファイル、Mapinfo、DXFなど)については、 Ctrl+Shift+V を押すか、 レイヤ ► レイヤの追加 ► addOgrLayer ベクタレイヤの追加 メニューオプションを選択するか、 addOgrLayer ベクタレイヤの追加 ツールバーボタンをクリックします。

      ../../../_images/addvectorlayerdialog.png

      図 15.4 ベクタレイヤの追加ダイアログ

    • ラスタデータ(GeoTiff、MBTiles、GRIdded Binary、DWGなど)については、 Ctrl+Shift+R を押すか、 レイヤ ► レイヤの追加 ► addRasterLayer ラスタレイヤの追加 メニューオプションを選択するか、 addRasterLayer ラスタレイヤの追加 ツールバーボタンをクリックします。

      ../../../_images/addrasterlayerdialog.png

      図 15.5 ラスタレイヤの追加ダイアログ

  2. ソースタイプは radioButtonOn ファイル を選択します

  3. ... ブラウズ ボタンをクリックします

  4. ファイルシステムを検索し、サポートされているデータソースを読み込みます。ダイアログで Ctrl キーを押しながら複数のアイテムをクリックするか、 Shift キーを押しながら最初と最後のアイテムを選択することでアイテム範囲を選択することで、複数のレイヤを同時に読み込むことが可能です。ファイル形式のフィルタには、十分にテストされたファイル形式のみが表示されます。他のファイル形式は、 全ファイル (プルダウンメニューの一番上のアイテム)を選択することで読み込むことができます。

  5. 開く ボタンを押し、選択したファイルを データソースマネージャ ダイアログに読み込みます

    ../../../_images/openoptionsvectorlayer.png

    図 15.6 オプション付きでシェープファイルをロードする

  6. Press Add to load the file in QGIS and display them in the map view. When adding vector datasets containing multiple layers, the Select Items to Add dialog will appear. In this dialog, you can choose the specific layers from your dataset that you want to add. Also, under Options you can choose to:

    • checkboxAdd layers to a group

    • checkboxShow system and internal tables

    • checkboxShow empty vector layers.

    図 15.7 shows QGIS after loading the alaska.shp file.

    ../../../_images/shapefileloaded.png

    図 15.7 アラスカのシェープファイルがロードされたQGIS

注釈

GDALドライバはベクタファイルとラスタファイルを読み込むときにオープン動作の定義ができます。これは、ファイルが選択されたときに表示されます。オプションの詳細は https://gdal.org/drivers/vector/ および https://gdal.org/drivers/raster で説明されており、QGISでファイルを選択すると、ハイパーリンク付きのテキストで選択したファイルタイプのドキュメントへ直接移動できます。

注釈

MapInfo (例 .tab )やAutoCAD( .dxf )などいくつかのファイル形式は一つのファイル内にさまざまなジオメトリタイプを混在させることが可能なため、このようなデータセットを開く時には、レイヤごとに1つのジオメトリとするために、使用するジオメトリを選択するダイアログが開きます。

addOgrLayer ベクタaddRasterLayer ラスタ タブでは、 ファイル 以外のソースタイプからレイヤを読み込むことができます:

  • ArcInfo Binary CoverageUK. National Transfer FormatUS Census Bureau のraw TIGER形式、 OpenfileGDB といった特定のベクタフォーマットを読み込むことができます。これらを読み込むためには、 ソースタイプradioButtonOn ディレクトリ を選択します。この場合、 ... ブラウズ ボタンを押すと、ダイアログではディレクトリの選択が可能になります。

  • radioButtonOn データベース ソースタイプでは、既存のデータベース接続を選択したり、選択したデータベースタイプの接続を作成したりすることができます。利用可能なデータベースタイプには、 ODBCEsri Personal GeoDatabaseMS SQL ServerPostgreSQLMySQL などがあります。

    新規 ボタンを押すと、 新しいOGRデータベース接続を作成する ダイアログが開きます。指定できるパラメータは 保存された接続の作成 で説明しているものと同じです。 Open ボタンを押すと、利用可能なテーブルの中から、例えば PostGIS が有効になっているデータベースのテーブルなどを選択することができます。

  • radioButtonOn プロトコル ソースタイプは、ローカル、あるいはネットワークに保存されたデータを開きます。このデータはパブリックアクセスが可能か、商用クラウドストレージサービスのプライベートバケットに保存されているかのいずれかです。サポートされているプロトコルタイプは以下のとおりです:

    • HTTP/HTTPS/FTPURI と、必要に応じて 認証 を指定します

    • AWS S3Google Cloud StorageMicrosoft Azure BlobAlibaba OSS CloudOpen Stack Swift Storage 等のクラウドストレージ。 バケットまたはコンテナオブジェクトキー を入力する必要があります。

    • OGC WFS 3 をサポートするサービス(まだ実験段階です)。 GeoJSON または GEOJSON - Newline Delimited フォーマットを使用しているか、 CouchDB データベースに基づくものです。 URI が必須で、 認証 はオプションです。

    • ベクタソースタイプ全てについて、 文字コード の指定が可能です。 自動 ► 設定を使うこともできます。

15.1.3.2. メッシュレイヤを読み込む

メッシュは通常、時間やその他の成分を持った非構造格子です。空間成分には、2Dまたは3D空間の頂点、辺、面の集合が含まれます。メッシュレイヤに関する詳細な情報は メッシュデータの操作 を参照してください。

メッシュレイヤをQGISに追加するには、次の手順で操作します:

  1. レイヤ ► メニューから選択するか、 dataSourceManager データソースマネージャを開く ボタンをクリックして、 データソースマネージャ ダイアログを開きます。

  2. 左のパネルの addMeshLayer メッシュ タブを有効にします。

  3. ... ブラウズ ボタンを押し、ファイルを選択します。 さまざまなファイル形式 がサポートされています。

  4. ファイルを選択し、 追加 ボタンを押します。ネイティブのメッシュレンダリングを使用してレイヤが追加されます。

  5. 選択したファイルが多数のメッシュレイヤを含む場合には、ダイアログが表示され、読み込むサブレイヤ選択するよう促されます。読み込むレイヤを選択して OK ボタンを押すと、ネイティブのメッシュレンダリングでレイヤが読み込まれます。レイヤ群をグループにして読み込むこともできます。

../../../_images/mesh_datasource_manager.png

図 15.8 データソースマネージャのメッシュタブ

15.1.3.3. 区切りテキストファイルをインポートする

区切りのあるテキストファイル(例えば .txt.csv.dat.wkt )は上記のツールを使って読み込むことができますが、その方法ではファイルはシンプルなテーブルとして表示されます。時には、区切りのあるテキストファイルに可視化したい座標 / ジオメトリが含まれていることがあります。 addDelimitedTextLayerCSVテキストレイヤの追加 で読み込むことで、これを可視化することができます。

  1. dataSourceManager データソースマネージャを開く アイコンをクリックし、 データソースマネージャ ダイアログを開きます

  2. addDelimitedTextLayer CSVテキスト タブを有効にします

  3. ... ブラウズ ボタンをクリックし、インポートしたい区切りのあるテキストファイル(例えば qgis_sample_data/csv/elevp.csv )を選択します。

  4. プロジェクト内でレイヤに使用したい名前を レイヤ名 フィールドに入力します。 (例: Elevation

  5. 以下に説明するように、データセットや必要に合わせて設定を行います。

../../../_images/delimited_text_dialog.png

図 15.9 CSVテキストダイアログ

ファイル形式

ファイルが選択されると、QGISは最近使用された区切り文字を使用してファイルの解析を試み、フィールドと行を識別します。QGISがファイルを正しく解析できるようにするためには、正しい区切り文字を選択することが重要です。区切り文字には、次のいずれかを選択して指定することができます:

  • radioButtonOnCSV(コンマで区切られた値) は、コンマの文字を使います。

  • radioButtonOff正規表現区切り を選んだ場合は フィールドにテキストを入力します。例えば、区切り文字をタブに変更するには、 \t (これは正規表現ではタブ文字に使用されます)を使用します。

  • radioButtonOffカスタム区切り は、 コンマ空白タブセミコロン 等の定義済み区切り文字の中から選択します。

レコードとフィールドのオプション

他にもデータ認識に使用できる便利なオプションがいくつかあります:

  • 破棄するヘッダ行数 :ファイルの始めの数行が空行あるいは別フォーマットであるときに、これをインポートしないようにする場合に便利です。

  • checkbox最初の行はフィールド名 :最初の行の値をフィールド名として使用します。チェックがない場合には、QGISはフィールド名に field_1field_2 等を使用します。

  • checkboxフィールド型を検出する :フィールドの型を自動的に認識します。チェックがない場合には、全ての属性はテキストフィールドとして扱われます。

  • checkbox小数点記号にコンマを使う :小数点の区切り文字を強制的ににコンマとすることができます。

  • checkbox前後の空白を削除する :フィールドから前後の空白文字を取り除くことができます。

  • checkbox空フィールドを削除する

  • カスタム論理値: ブール値として検出される一組のカスタム文字列を追加することができます。

フィールド型を検出

QGISは、(checkboxフィールド型を検出 をチェックしている限り)フィールド型を自動的に検出しようとしますが、それは、オプションのサイドカーCSVTファイル(参照:GeoCSV仕様)の内容を調べ、ファイル全体をスキャンして、すべての値が実際にエラーなく変換できることを確認することによって行われます。フォールバックするときのフィールド型はテキストです。

検出されたフィールド型は、サンプルデータのプレビューテーブルのフィールド名の下に表示され、必要な場合は手動で変更できます。

次のフィールド型がサポートされています:

  • ブール値 ブール値として解釈される、大文字小文字を区別しないリテラルの組みで、1/0, true/false, t/f, yes/no

  • 整数 (integer)

  • 整数 (integer - 64 bit)

  • 小数点付き数値: 倍精度浮動小数点数

  • 日付

  • 時刻

  • 日付時刻

  • テキスト

ジオメトリ定義

ファイルが解析されたら、 ジオメトリ定義 の設定を行います。

  • radioButtonOnポイント座標 レイヤがポイントジオメトリ型で、 X属性Y属性Z属性 (3次元データの場合)、 M値の属性 (計測次元の場合)のフィールドを含む場合には、これを指定します。座標が度 / 分 / 秒で定義されている場合には、 checkbox度分秒を使う のチェックボックスにチェックを入れます。 setProjection CRSの選択 ウィジェットを使用して、適切な ジオメトリのCRS を指定します。

  • radioButtonOnWell-known text (WKT) オプションは、空間情報がWKTにより表現されている場合に使用します:WKTジオメトリが含まれる ジオメトリフィールド を選択し、 適切な ジオメトリタイプ を選ぶか、QGISの自動検出に任せます。setProjection CRSの選択 ウィジェットを使用して、 適切な ジオメトリのCRS を指定します。

  • ファイルが非空間データの場合には、 radioButtonOn ジオメトリなし(属性のみのテーブル) を有効にすると、通常のテーブルとして読み込まれます。

レイヤ設定

また、以下を有効にできます:

  • checkbox空間インデックスを使う :地物の表示や空間的な選択のパフォーマンスを改善します。

  • checkboxサブセットインデックスを使う :(レイヤプロパティで定義されている場合に) サブセットフィルタ のパフォーマンスを改善します。

  • checkboxファイルを監視する :QGISの実行中に他のアプリケーションによってファイルが変更されたかを監視します。

最後に 追加 をクリックし、マップにレイヤを追加します。この例では、 Elevation という名前のポイントレイヤがプロジェクトに追加され、QGISの他のマップレイヤと同様に動作します。このレイヤは .csv ソースファイルに対するクエリの結果であり(従ってこれにリンクされているため)、ディスク上に空間レイヤを取得するには 保存する 必要があります。

サンプルデータ

パーサーのプロパティを設定すると、サンプルデータのプレビューが適用された設定に合わせて更新されます。

また、サンプルデータテーブルでは、自動的に決定されたカラムの型を上書きすることもできます。

15.1.3.4. DXFファイルやDWGファイルをインポートする

DXF ファイルや DWG ファイルはブラウザパネルからドラッグ&ドロップするだけでQGISに追加できます。プロジェクトに追加したいサブレイヤを選択するプロンプトが表示されます。レイヤはランダムなスタイルのプロパティで追加されます。

注釈

いくつかのジオメトリタイプ(ポイント、ライン、ポリゴン)を含むDXFファイルは、 <filename.dxf> entities <geometry type> のような名前でレイヤが生成されます。

dxf/dwgファイルの構成とシンボロジをQGISでも保つためには、 プロジェクト ► インポートとエクスポート ► DWG/DXFからレイヤをインポート... から専用のツールを使用するとよいでしょう。このツールにより、次の操作を行います:

  1. 図面ファイルからGeoPackageデータベースに要素をインポートする

  2. インポートした要素をプロジェクトに追加する

DWG/DXFのインポート ダイアログでは、図面ファイルの内容をインポートするために以下の情報を入力する必要があります:

  1. Input the location of the Source drawing, i.e. the DWG/DXF drawing file to import.

  2. 図面ファイルのデータの座標参照系を指定します。

  3. Input the location of the Target package, i.e. the GeoPackage file that will store the data. If an existing file is provided, then it will be overwritten.

  4. Choose how to import blocks with the dedicated combobox:

    • Expand Block Geometries: imports the blocks in the drawing file as normal elements.

    • Expand Block Geometries and Add Insert Points: imports the blocks in the drawing file as normal elements and adds the insertion point as a point layer.

    • Add Only Insert Points: adds the blocks insertion point as a point layer.

  5. checkbox カーブを使用する をチェックすると、インポートされたレイヤを カーブ ジオメトリタイプに変換します。

  6. Use the Import button to import the drawing into the destination GeoPackage file. The GeoPackage database will be automatically populated with the drawing file content. Depending on the size of the file, this can take some time.

.dwg ファイルまたは .dxf ファイルのデータがGeoPackageデータベースへとインポートされたら、ダイアログの下半分にあるフレームにインポートファイルからのレイヤのリストが表示されます。ここからQGISプロジェクトに追加したいレイヤを選択できます:

  1. At the top, set a Group name to group the drawing files in the project. By default this is set to the filename of the source drawing file.

  2. 表示するレイヤにチェックを入れます。選択された各レイヤは、図面レイヤのポイント、ライン、ラベル、面地物に対するベクタレイヤを含むアドホックなグループに追加されます。レイヤのスタイルは、元々 *CADで持っていたスタイルと似た見た目になります。

  3. 最初からレイヤが表示されているかどうかを選択します。

  4. checkbox レイヤを結合する オプションをチェックすると、全てのレイヤを単一のグループにまとめます。

  5. OK ボタンを押すと、QGISでレイヤを開きます。

../../../_images/dwg_dxf_import_dialog.png

図 15.10 DWG/DXFファイルのインポートダイアログ

15.1.3.5. OpenStreetMapベクタのインポート

多くの国ではデジタル道路地図等のジオデータが無料で利用できないため、OpenStreetMapプロジェクトは人気があります。OSMプロジェクトの目的は、GPSデータや航空写真、ローカルな知識からフリーで編集可能な世界地図を作成することです。この目的を支援するため、QGISはOSMデータのサポートを提供しています。

ブラウザパネル を使用して .osm ファイルをマップキャンバスに読み込むと、ジオメトリタイプに基づいてサブレイヤを選択するためのダイアログが現れます。読み込んだレイヤには .osm ファイル内のそのジオメトリタイプの全てのデータが含まれており、 osm ファイルのデータ構造が保持されています。

15.1.3.6. SpatiaLiteレイヤ

addSpatiaLiteLayer 初めてSpatiaLiteデータベースからデータをロードするときは、始めに以下の操作を行います:

  • addSpatiaLiteLayer SpatiaLiteレイヤの追加 ツールバーボタンをクリックする

  • レイヤ ► レイヤの追加 メニューから addSpatiaLiteLayer SpatiaLiteレイヤの追加... オプションを選択する

  • Ctrl+Shift+L を押す

これによりウィンドウが現れ、QGISが既に知っているSpatiaLiteデータベース(ドロップダウンメニューから選択)に接続するか、新しいデータベースへの新規接続を定義します。新規接続を定義するには、 新規 をクリックし、ファイルブラウザを使用してSpatiaLiteデータベースを指定します。SpatiaLiteデータベースは .sqlite 拡張子を持つファイルです。

また、QGISはSpatiaLiteで編集可能なビューもサポートしています。

15.1.3.7. GPS

GPSデータを格納するための異なるファイル形式はいくつもあります。同じファイル内のウェイポイント、ルートとトラックの任意の数を含むことができ、標準の交換フォーマットであるQGISが使用するフォーマットGPX(GPS交換フォーマット)と呼ばれます。

... ブラウズ ボタンを使用してGPXファイルを選択し、GPXファイルから読み込みたい地物タイプをチェックボックスを使用して選択します。各地物タイプは別々のレイヤで読み込まれます。

GPSデータの操作についての詳細は GPSデータの操作 を参照。

../../../_images/gps_datasource.png

図 15.11 GPSデータの読み込みダイアログ

15.1.3.8. GRASS

GRASSベクタデータでの作業は GRASS GIS の統合 セクションで説明しています。

15.1.4. レイヤメタデータ検索パネル

By default, QGIS can retrieve layers metadata from the connections or data providers that allow metadata storage (more details on saving metadata to the database). The Metadata search panel allows to browse the layers by their metadata and add them to the project (either with a double-click or the Add button). The list can be filtered:

  • by text, watching a set of metadata properties (identifier, title, abstract)

  • by spatial extent, using the current project extent or the map canvas extent

  • by the layer (geometry) type

注釈

メタデータのソースは、プラグインによって拡張可能なレイヤメタデータプロバイダのシステムによって実装されています。

../../../_images/layer_metadata_search_panel.png

図 15.16 レイヤメタデータ検索パネル

15.1.5. QGISカスタム形式

QGISには2つのカスタム形式があります:

15.1.6. QLR - QGISレイヤ定義ファイル

レイヤのコンテキストメニューで エクスポート ► レイヤ定義ファイルとして保存... を使用して、レイヤの定義を レイヤ定義ファイル (QLR - .qlr )として保存することができます。

QLR形式によって、 "完全な" QGISレイヤを他のQGISユーザーと共有することができます。 QLRファイルには、データソースへのリンクとレイヤのスタイル設定に必要な全てのQGISスタイル情報が含まれています。

QLRファイルはブラウザパネル内に表示され、レイヤを(保存されたスタイルで)レイヤパネルに追加するために使用できます。QLRファイルをシステムのファイルマネージャからマップキャンバスへとドラッグ&ドロップすることもできます。

15.1.7. ウェブサービスへ接続する

QGISを使用すると、さまざまな種類のOGC ウェブサービス(WM(T)S、WFS(-T)、WCS、CSW、...)にアクセスすることができます。QGIS Serverのおかげで、このようなサービスを公開することもできます。 QGIS Server ガイド / マニュアル には、これらの機能についての説明があります。

15.1.7.1. ベクタタイルサービスを利用する

ベクタタイルサービスは、 データソースマネージャ ダイアログの addVectorTileLayer ベクタタイル タブまたは ブラウザ パネルの Vector Tiles エントリのコンテキストメニューから追加することができます。サービスは、 新規一般接続...新規ArcGIS Vector Tile Service接続... のいずれかです。

以下を入力することで、サービスを設定できます:

  • 名前

  • URL :一般接続の場合は http://example.com/{z}/{x}/{y}.pbf のような形式、ArcGISベースのサービスの場合は http://example.com/arcgis/rest/services/Layer/VectorTileServer のような形式です。サービスはタイルを .pbf 形式で提供している必要があります。

  • checkbox最小ズームレベル および checkbox最大ズームレベル :ベクタタイルはピラミッド構造を持っています。これらのオプションを使用すると、タイルピラミッドから個別にレイヤを生成することができます。これらのレイヤは、QGISでベクタタイルのレンダリングに使用されます。

    メルカトル図法(OpenStreetMap Vector Tilesで使用)の場合、ズームレベル0は世界全体を 1:500.000.000 の縮尺で表現します。ズームレベル14は、縮尺 1:35.000 での表現です。

  • Style URL :MapBox GL JSONスタイル設定へのURLです。これを設定すると、この接続からのレイヤがQGISに追加される場合に、常にそのスタイルが適用されます。ArcGISベクタタイルサービス接続の場合、このURLはサーバー側の設定で指定されるデフォルトのスタイル設定を上書きします。

  • 認証 :必要に応じて設定

  • リファラー

図 15.17 は、MapTiler planet Vector Tiles サービスの設定ダイアログを示しています。

../../../_images/vector_tiles_maptilerplanet.png

図 15.17 ベクタタイル - Maptiler Planet の設定

接続設定は、 データソースマネージャ ダイアログ内の ベクタタイル エントリや、 ブラウザ パネルのVector Tilesのコンテキストメニューを通じて .XML ファイルに保存( 接続を保存 )することができます。同様に、接続をファイルから追加する( 接続を読み込む )こともできます。

ベクタタイルサービスへの接続が設定できたら、以下の操作が可能です。

  • ベクタタイルの接続設定の 編集

  • 接続の 削除

  • ブラウザ パネルでは、エントリを右クリックすることで、以下の操作もできます:

    • レイヤをプロジェクトに追加する :ダブルクリックでもレイヤを追加できます

    • レイヤのプロパティ... を確認し、サービスによって提供されるメタデータやデータのプレビューにアクセスできます。レイヤがプロジェクトに読み込まれている場合には、より多くの設定が可能です。

15.1.7.2. XYZタイルサービスを利用する

XYZ Tile services can be added via the addXyzLayer XYZ tab of the Data Source Manager dialog or the contextual menu of the XYZ Tiles entry in the Browser panel. By default, QGIS provides some default and ready-to-use XYZ Tiles services:

  • xyzMapzen Global Terrain により、プロジェクトに使える世界的なDEMソースに即座にアクセスできます。詳細とリソースは、https://registry.opendata.aws/terrain-tiles/

  • xyz OpenStreetMap で世界の2Dマップにアクセスできます。|numref:figure_xyz_tiles_openstreetmap はOpenStreetMap XYZ Tileサービスの設定ダイアログを表示します。

To add a new service, press New (respectively New Connection from the Browser panel) and provide:

../../../_images/xyz_tiles_dialog_osm.png

図 15.18 XYZ Tiles - OpenStreetMap の設定

  • 名前

  • the URL, you can add http://example.com/{z}/{x}/{y}.png or file:///local_path/{z}/{x}/{y}.png

  • 認証 :必要に応じて設定

  • 最小ズームレベル および 最大ズームレベル

  • リファラー

  • タイル解像度 :可能な値は 不明(スケールされていない)標準(256x256 / 96DPI) および 高解像度(512x512 / 192DPI) です

  • 断面データの解釈: WMTS/XYZ ラスタデータセットを、あらかじめ定義されたエンコーディングスキームに従って、シングルバンド float 型のラスタレイヤに変換します。サポートされているスキームは デフォルト (変換は行われません), MapTiler Terrain RGB および Terrarium Terrain RGB です。選択されたコンバータは、RGBソースの値を各ピクセルのfloat値に変換します。一度読み込まれると、レイヤはシングルバンドの浮動小数点ラスタレイヤとして表示され、QGISの通常の:ref:ラスタレンダラ <raster_rendering> を使ってスタイルを設定することができます。

Press OK to establish the connection. It will then be possible to:

  • Add the new layer to the project; it is loaded with the name given in the settings.

  • XYZタイル接続設定の 編集

  • 接続の 削除

  • ブラウザ パネルでは、エントリを右クリックすることで、以下の操作もできます:

    • レイヤエクスポート... ► ファイルへ は、 タイルをラスタとして保存します

    • レイヤをプロジェクトに追加する :ダブルクリックでもレイヤを追加できます

    • レイヤのプロパティ... を確認し、サービスによって提供されるメタデータやデータのプレビューにアクセスできます。レイヤがプロジェクトに読み込まれている場合には、より多くの設定が可能です。

Configurations can be saved to .XML file (Save Connections) through the XYZ entry in Data Source Manager dialog or its contextual menu in the Browser panel. Likewise, they can be added from a file (Load Connections).

OpenStreetMapのXMLファイルは以下のようになっています:

<!DOCTYPE connections>
<qgsXYZTilesConnections version="1.0">
  <xyztiles url="https://tile.openstreetmap.org/{z}/{x}/{y}.png"
   zmin="0" zmax="19" tilePixelRatio="0" password="" name="OpenStreetMap"
   username="" authcfg="" referer=""/>
</qgsXYZTilesConnections>

Tip

Loading XYZ tiles without creating a connection

It is also possible to add XYZ tiles to a project without necessarily storing its connection settings in you user profile (e.g. for a dataset you may need once). In the Data Source Manager ► XYZ tab, edit any properties in the Connection Details group. The Name field above should turn into Custom. Press Add to load the layer in the project. It will be named by default XYZ Layer.

XYZタイルサービスの例:

  • OpenStreetMap Monochrome: URL: http://tiles.wmflabs.org/bw-mapnik/{z}/{x}/{y}.png, 最小ズームレベル: 0, 最大ズームレベル: 19

  • Googleマップ: URL: https://mt1.google.com/vt/lyrs=m&x={x}&y={y}&z={z}, 最小ズームレベル: 0, 最大ズームレベル: 19

  • Open Weather Map Temperature: URL: http://tile.openweathermap.org/map/temp_new/{z}/{x}/{y}.png?appid={api_key} 最小ズームレベル: 0, 最大ズームレベル: 19

15.1.7.3. ArcGIS REST Serversを利用する

ArcGIS REST Serversは、 データソースマネージャ ダイアログの addAfsLayer ArcGIS REST Server タブまたは ブラウザ パネルの ArcGIS REST Servers エントリのコンテキストメニューから追加することができます。 新規 (あるいは 新規接続 )を押し、以下の情報を入力します:

  • 名前

  • URL

  • Community endpoint URL

  • Content endpoint URL

  • 認証 :必要に応じて設定

  • リファラー

注釈

ArcGIS Feature Service接続で、対応するPortal endpoint URL が設定されているものは、ブラウザパネル内でコンテンツグループごとに検索できます。

接続にPortal endpointsが設定されている場合、ブラウザパネルで接続を展開すると、通常表示されるサービスの完全なリストの代わりに “Groups” フォルダと “Services” フォルダが表示されます。グループフォルダを展開すると、ユーザーがメンバーとなっているすべてのコンテンツグループの一覧が表示され、それぞれのグループを展開すると、そのグループに所属するサービス項目が表示されます。

接続設定は、 データソースマネージャ ダイアログ内の ArcGIS REST Server エントリを通じて .XML ファイルに保存( 接続を保存 )することができます。同様に、接続をファイルから追加する( 接続を読み込む )こともできます。

ArcGIS REST Serverへの接続が設定できたら、以下の操作が可能です。

  • ArcGIS REST Server接続設定の 編集

  • 接続の 削除

  • 接続の 再読み込み

  • 利用可能なレイヤへのフィルタ適用

  • checkbox現在のビュー領域に重なる地物のみをリクエストする オプションを用いて、利用可能なレイヤのリストから選択する

  • ブラウザ パネルでは、接続エントリを右クリックすることで、以下の操作ができます:

    • 再読み込み

    • 接続の編集...

    • 接続を削除...

    • サービス情報を見る :デフォルトのウェブブラウザを開き、サービス情報を表示します

  • レイヤのエントリを右クリックすると、以下の操作ができます:

    • サービス情報を見る :デフォルトのウェブブラウザを開き、サービス情報を表示します

    • レイヤエクスポート ► ファイルへ…

    • レイヤをプロジェクトに追加する :ダブルクリックでもレイヤを追加できます

    • レイヤのプロパティ... を確認し、サービスによって提供されるメタデータやデータのプレビューにアクセスできます。レイヤがプロジェクトに読み込まれている場合には、より多くの設定が可能です。

15.1.7.4. Using 3D tiles services

To load a 3D tiles into QGIS, use the addTiledSceneLayer Scene tab in the Data Source Manager dialog.

../../../_images/scene.png

図 15.19 Data Source Manager - Scene

Create a New Cesium 3D Tiles Connection by clicking on New. Add Name and URL or add local tileset file.

Support for 3D tiles:

  • Remote source - http://example.com/tileset.json

  • Local files - file:///path/to/tiles/tileset.json

../../../_images/tiled_scene_connection.png

図 15.20 Tiled Scene Connection

You can also add the service from Browser Panel.

After creating new connection you are able to Add the new layer to your map.

../../../_images/3d_tiles_layer.png

図 15.21 3D Tiles Layer - Textured