14.3. Lesson: Digitizando Masas Forestales

A menos que vaya a utilizar su mapa georreferenciado como una simple imagen de fondo, el siguiente paso natural es digitalizar elementos a partir de él. Ya lo ha hecho en los ejercicios sobre la creación de datos vectoriales en Lesson: Creando un Nuevo Conjunto de Datos Vectoriales, cuando digitalizó los campos de la escuela. En esta lección, va a digitalizar los bordes de los bosques que aparecen en el mapa como líneas verdes, pero en lugar de hacerlo con una imagen aérea, utilizará su mapa georreferenciado.

El objetivo de esta lección: Aprender una técnica para asistir la tarea de digitalización, digitalizar una masa forestal y finalmente añadirle los datos de inventario.

14.3.1. basic Follow Along: Extrayendo los Bordes de las Masas Forestales

Abre el proyecto map_digitizing.qgs en QGIS, que guardaste en la lección anterior.

Una vez escaneado y georeferenciado tu mapa podría empezar a digitalizarse directamente mirando las imágenes a modo de guía. Esa sería la forma más adecuada si la imagen desde la que vas a digitalizar es, por ejemplo, una fotografía aérea.

Si lo que está utilizando para digitalizar es un buen mapa, como en nuestro caso, es probable que la información se muestre claramente como líneas con diferentes colores para cada tipo de elemento. Esos colores se pueden extraer con relativa facilidad como imágenes individuales utilizando un software de procesamiento de imágenes como GIMP. Estas imágenes separadas se pueden usar para ayudar a la digitalización, como verá a continuación.

El primer paso será utilizar GIMP para obtener una imagen que contenga solo las masas forestales, es decir, todas las líneas verdosas que podrías ver en el mapa original escaneado:

  • Abre GIMP (si todavía no lo has instalado, descárgatelo de internet o pregunta a tu profesor).

  • Abre la imagen del mapa original, File ▶ Open, rautjarvi_map.tif en la carpeta exercise_data/forestry. Observa que las masas forestales están representadas como líneas verdes (con el número de la masa también en verde dentro de cada polígono).

../../../_images/gimp_map.png

Ahora puede seleccionar los píxeles en la imagen que forman los bordes de las masas forestales (los píxeles verdosos):

  • Abre la herramienta Select ▶ By color.

  • Con la herramienta activa, haz zum en la imagen (Ctrl + mouse wheel) para que las líneas de las masas forestales estén suficientemente cerca para diferenciar los píxeles que forman la línea. Mira la imagen inferior izquierda.

  • Haz clic y arrastra el cursor del ratón en el medio de la línea para que la herramienta recolecte muchos valores de color de píxel.

  • Deja de clicar y espera unos segundos. Los píxeles que coincidan con los colores recogidos por la herramienta serán seleccionados en toda la imagen.

  • Aleja el zum para ver como los píxeles verdosos se han seleccionado en toda la imagen.

  • Si no estas contento con tus resultados, repite la operación de clicado y arrastrar.

  • Su selección de píxeles debería parecerse a la imagen inferior derecha.

../../../_images/green_px_selected.png

Una vez hayas terminado con la selección necesitas copiar la selección como una capa nueva y guardarla como un archivo de imagen separado:

  • Copia (Ctr+C) los píxeles seleccionados.

  • Y pégalos directamente (Ctr+V), GIMP los presentará como una nueva capa temporal en el panel Layers - Brushes como un Floating Selection (Pasted Layer).

  • Haz clic derecho en la capa temporal y selecciona To New Layer.

  • Haz clic en el icono «eye» junto a la capa original para desactivarlo, para que solo sea visible la Pasted Layer:

../../../_images/saving_green_px.png
  • Finalmente, selecciona File ▶ Export…, ajusta Select File Type (By Extension) como una TIFF image, selecciona la carpeta digitizing y nómbrala rautjarvi_map_green.tif. Selecciona no comprimir cuando se pregunte.

Podrías hacer el mismo proceso con otros elementos de la imagen, por ejemplo para extraer las líneas negras que representan calles o las marrones que representan las líneas de contorno del terreno. Pero para nosotros, con las masas forestales es suficiente.

14.3.2. basic Try Yourself georeferenciar la Imagen de píxeles Verdes

Como hiciste en la lección anterior, necesitas georeferenciar esta nueva imagen para ser capaz de utilizarla con el resto de tus datos.

Observa que no necesitas digitalizar los puntos de control base de nuevo porque esta imagen es básicamente la misma imagen que la del mapa original, siempre y cuando la herramienta de georeferenciación esté conectada. Aquí hay algunas cosas que deberías recordar:

  • Esa imagen también está, por supuesto, en SRC KKJ / Finland zone 2.

  • Deberías utilizar los puntos de control base que guardaste, File ▶ Load GCP points.

  • Recuerde revisar los Ajustes de transformación.

  • Nombra el ráster de salida como rautjarvi_green_georef.tif en la carpeta digitizing.

Comprueba que el nuevo ráster encaja bien en el mapa original.

14.3.3. basic Follow Along: Creando Puntos de Soporte para Digitalizar

Tenga en cuenta las herramientas de digitalización en QGIS, que ya podría estar pensando que sería de gran ayuda para ajustarse a los píxeles verdes durante la digitalización. Eso es precisamente lo que va a hacer después de crear puntos de esos píxeles para utilizarlas más tarde para ayudarle a seguir las fronteras los estantes forestales en la digitalización, utilizando las herramientas de autoensamblado disponibles en QGIS.

  • Utiliza la herramienta Raster ▶ Conversion ▶ Polygonize (Raster to Vector) para vectorizar tus líneas verdes a polígonos. Si no recuerdas cómo, puedes repasarlo en el módulo 9.1.1.

  • Guárdalo como rautjarvi_green_polygon.shp dentro de la carpeta digitizing.

Amplía el zum y observa como se ven los polígonos. Obtendrás algo como esto:

../../../_images/green_polygons.png

La siguiente opción para sacar los puntos de los polígonos es obtener sus centroides:

  • Abre Vector ▶ Geometry tools ▶ Polygon centroids.

  • Establezca la capa poligonal que acaba de crear como archivo de entrada para la herramienta.

  • Nombra la salida como green_centroids.shp dentro de la carpeta digitizing.

  • Comprueba Add result to canvas.

  • Inicia la herramienta para calcular los centroides para los polígonos.

../../../_images/green_points.png

Ahora puedes borrar la capa rautjarvi_green_polygon del TOC.

Cambia la simbología de la capa de centroides:

  • Abre las Layer Properties para green_centroids.

  • Vaya a la pestaña Symbology.

  • Ajusta Unit a Map unit.

  • Ajusta Size a 1.

No es necesario diferenciar los puntos entre ellos, solo necesitas que estén ahí para que las herramientas de rotura los utilicen. Puedes utilizar esos puntos ahora para seguir las líneas originales mucho más fácil que sin ellos.

14.3.4. basic Follow Along: Digitaliza las Masas Forestales

Ahora estás listo para empezar con el trabajo de digitalización. Empezarías creando un archivo vectorial de polygon type, pero para este ejercicio, hay un archivo shape con parte del área de interés ya digitalizada. Terminarás de digitalizar la mitad de las masas forestales que se ha dejado entre las calles principales (líneas anchas rosas) y el lago:

../../../_images/forest_stands_to_digitize.png
  • Ve a la carpeta digitizing utilizando tu navegador del administrador de archivos.

  • Arrastra y suelta el archivo vectorial forest_stands.shp a tu mapa.

Cambia la simbología de la nueva capa para que sea más fácil ver qué polígonos han sido ya digitalizados:

  • El relleno de los polígonos a verde.

  • Los bordes de los polígonos a 1mm.

  • Ajusta la transparencia al 50%.

Ahora, si recuerdas los módulos anteriores, tenemos que ajustar y activar las opciones de rotura:

  • Ve a Proyecto▶ Snapping options….

  • Active el ajuste para green_centroids y las capas forest_stands.

  • Ajusta su Tolerance a 5 unidades de mapa.

  • Activa la caja Avoid Int. para la capa forest_stands.

  • Activa Enable topological editing.

  • Haz clic en Apply.

../../../_images/snapping_settings_forest.png

Con esos ajustes de rotura, cuando quiera que estés digitalizando y te acerques lo suficiente a uno de ellos en la capa de centroides o cualquier otro vértice de tus polígonos digitalizados, una cruz rosa aparecerá en el punto al que se romperá.

Finalmente, desactiva la visibilidad de todas las capas excepto forest_stands y rautjarvi_georef. Asegúrate de que la imagen del mapa deja de ser transparente.

Un par de cosas importantes a observar antes de empezar a digitalizar:

  • No intentes ser demasiado preciso con la digitalización de los bordes.

  • Si un borde es una línea recta, digitalízala con solo dos nodos. En general, digitaliza utilizando el menor número de nodos posible.

  • Amplía el zum a rangos cercanos solo si crees que necesitas ser preciso, por ejemplo, en algunas esquitas o cuando quieres que un polígono conecte con otro en un cierto nodo.

  • Utiliza el botón medio del ratón para amliar y reducir el zum y desplazarte mientras digitalizas.

  • Digitaliza solo un polígono de cada vez

  • Después de digitalizar un polígono, escribe la identidad de masa forestal que puedes ver en el mapa.

Ahora puedes empezar a digitalizar:

  • Localiza la masa forestal número 357 en la ventana del mapa.

  • Habilita la edición para la capa forest_stands.shp.

  • Selecciona la herramienta Add feature.

  • Comienza a digitalizar la masa 357 conectando algunos de los puntos.

  • Observa las cruces rosas indicativas de rotura.

../../../_images/dgitizing_357_1.png
  • Cuando hayas terminado, haz clic derecho para terminar la digitalización de ese polígono.

  • Introduce la id de la masa forestal (en este caso 357),

  • Haz clic en OK.

Si no se pregunta por la id del polígono cuando acabes de digitalizarlo, ve a Settings ▶ Options ▶ Digitizing y asegúrate que Suppress attribute form pop-up after feature creation no está marcado.

Tu polígono digitalizado se verá así:

../../../_images/dgitizing_357_3.png

Ahora para el segundo polígono, recoja el estante numero 358. Asegúrese que Evitar enteros. este habilitado para la capa forest_stands. Esta opción no permite la intersección de polígonos al digitalizar, a fin de que si digitaliza sobre un polígono existente, el nuevo polígono se recortará para coincidir con los bordes de los polígonos ya existentes. Puede utilizar esta característica para obtener bordes comunes automáticamente.

  • Comienza a digitalizar la masa 358 en una de las esquinas comunes con la masa 357.

  • Continúa normalmente hasta que llegues a la otra esquina en común de ambas masas.

  • Finalmente, digitalice unos cuantos puntos dentro del polígono 357 asegurándose que el borde común no se intersecta. Vea la imagen inferior izquierda.

  • Haz clic derecho para terminar de editar la masa forestal 358.

  • Introduce la id como 358.

  • Click OK, su nuevo polígono debería mostrar un borde común con el soporte 357 como puede ver en la imagen de la derecha.

../../../_images/dgitizing_358_5.png

La parte del polígono que se estaba sobreponiendo al polígono existente se ha ajustado automáticamente y te ha dejado un borde común, como tú querías.

14.3.5. basic Try Yourself Terminando la Digitalización de las Masas Forestales

Ahora tienes dos masas forestales diferentes preparadas. Y una buena idea de cómo proceder. Continúa digitalizando por tu cuenta hasta que hayas digitalizado todas las masas forestales que estén limitadas por la calle principal y el lago.

Puede parecer mucho trabajo, pero pronto te acostumbrarás a digitalizar las masas forestales. Debería llevarte unos 15 minutos.

Durante la digitalización puede que necesite editar o eliminar nodos, separar o unir polígonos. Aprendió acerca de las herramientas necesarias en Lesson: Topología de los Elementos, ahora es probablemente un buen momento para ir a leer acerca de ellos de nuevo.

Recuerda que tener activa la Enable topological editing, te permite mover nodos comunes a dos polígonos para que el borde común sea editado al mismo tiempo para ambos polígonos.

Tu resultado se parecerá a esto:

../../../_images/stands_fully_digitized.png

14.3.6. basic Follow Along: Añadiendo Datos a las Masas Forestales

Es posible que los datos de inventario forestal que tienes en tu mapa también estén escritos en papel. En ese caso, primero tendrías que haber escrito los datos en un archivo de texto o una hoja de cálculo. Para este ejercicio, la información del inventario para 1994 (el mismo inventario que el mapa) está listo como un archivo de texto separado por comas (csv).

Abra el archivo rautjarvi_1994.csv del directorio exercise_data\forestry en un editor de textos y observe que el archivo de datos de inventario tiene un atributo llamado ID que tiene los números de la masa forestal. Esos números son los mismos que los ids de la masa forestal que ha escrito a sus polígonos y se puede utilizar para enlazar los datos desde el archivo de texto a su archivo vectorial. Puede ver los metadatos para estos datos de inventario en el archivo rautjarvi_1994_legend.txt en la misma carpeta.

  • Abre .csv en QGIS con la herramienta Layer ▶ Add Delimited Text Layer…. En el diálogo, ajústalo como sigue:

../../../_images/inventory_csv_import.png

Para añadir los datos desde el archivo .csv:

  • Abre las Propiedades de Capa para la capa forest_stands.

  • Ve a la pestaña Joins.

  • Haz clic en el signo de suma de la parte inferior de la caja de diálogo.

  • Selecciona rautjarvi_1994.csv como la Join layer y ID como el campo Join.

  • Asegúrate de que el campo Target también está ajustado a id.

  • Haz clic en OK dos veces.

Los datos del archivo de texto deberían estar enlazados ahora a tu archivo vectorial. Para ver qué ha ocurrido, abre la tabla de atributos para la capa forest_stands. Puedes ver que todos los atributos del archivo de datos de inventario están enlazados ahora a tu capa vectorial digitalizada.

14.3.7. basic Try Yourself Renombrando Nombres de Atributos y Añadiendo Área y Perímetro

Los datos del archivo .csv se acaban de enlazar a tu archivo vectorial. Para hacer que el enlace sea permanente, para que los datos se guarden al archivo vectorial necesitas guardar la capa forest_stands como un nuevo archivo vectorial. Cierra la tabla de atributos y haz clic derecho a la capa forest_stands para guardarla como forest_stands_1994.shp.

Abre tu nueva forest_stands_1994.shp en tu mapa si no la has añadido ya. Luego abre la tabla de atributos. Notarás que los nombres de las columnas que acabas de añadir no son muy útiles. Para solucionarlo:

  • Añade el complemento Table Manager como has hecho con otros complementos antes.

  • Asegúrate que el complemento está activado.

  • En TOC selecciona la capa forest_stands_1994.shp.

  • Luego, vaya a Vectorial ▶ Administrador de tabla ▶ Administrador de tabla.

  • Utiliza la caja de diálogo para editar los nombres de las columnas para que coincidan a los del archivo .csv.

../../../_images/forestry_table_manager.png
  • Haz clic en Save.

  • Seleciona Yes para conservar el estilo de la capa.

  • Cierra el diálogo Table Manager.

Para acabar de reunir la información relacionada con esas masas forestales, puedes calcular el área y perímetro de las masas. Calculaste áreas para los polígonos en el Module 9.4.24., vuelve a esa lección si lo necesitas y calcula las áreas para las masas forestales, nombra al nuevo atributo Area y asegúrate de que los valores calculados están en hectáreas.

Ahora tu capa forest_stands_1994.shp está lista y equipada con toda la información disponible.

Guarda tu proyecto para mantener la presentación del mapa actual en caso de que necesites volver a él luego.

14.3.8. In Conclusion

Ha llevado unos pocos clics de ratón pero ahora tienes tus viejos datos de inventario en formato digital y listos para usar en QGIS.

14.3.9. What’s Next?

Podrías empezar haciendo diferentes análisis con tu nueva marca de conjuntos de datos, pero puede que estés más interesado en relizar análisis en un conjunto de datos más actualizado. El tema de la siguiente lección será la creación de masas forestales utilizando fotos aéreas actuales y la adición de información relevante a tu conjunto de datos.