5.1. Lesson: Creando un Nuevo Conjunto de Datos Vectoriales

Los datos que has usado vienen de algún sitio. Para la mayoría de aplicaciones comunes, los datos ya existen; pero cuanto más particular y especializado sea el proyecto, más difícil será encontrar datos disponibles. En estos casos, necesitarás crear tus propios datos nuevos.

El objetivo de esta lección: Crear un nuevo conjunto de datos.

5.1.1. basic Follow Along: Cuadro de Diálogo de Creación de Capas

Antes de poder añadir nuevos datos vectoriales, necesitas un conjunto de datos vectoriales al que añadirlos. En nuestro caso, empezarás creando nuevos datos por completo, en lugar de editar un conjunto de datos existente. Además, necesitarás definir de antemano tu propio conjunto de datos nuevo.

  1. Abra QGIS y cree un nuevo proyecto en blanco.

  2. Navegue y haga click en la entrada de menú Capa ▶ Crear Capa ▶ Nueva Capa de archivo Shape. Se le presentará el diálogo Nueva Capa de archivo Shape que le permitirá definir una nueva capa.

    ../../../_images/create_vector_layer.png
  3. Click en para el campo Nombre de archivo. Aparecerá un diálogo Guardar.

  4. Navegue al directorio exercise_data.

  5. Guarde su nueva capa como school_property.shp.

    Es importante en este punto decidir qué tipo de conjunto de datos quieres. Cada tipo de capa vectorial esta «construida de forma diferente» en sus bases, así que una vez hayas creado la capa, no puedes cambiar su tipo.

    Para el siguiente ejercicio, vamos a crear nuevas entidades que describen áreas. Para muchas entidades, necesitarás crear un conjunto de datos poligonal.

  6. Para Tipo de Geometría, seleccione Polígono desde el menú desplegable:

    ../../../_images/polygon_selected.png

    Esto no tiene impacto en el resto del cuadro de diálogo, pero hará que se use el tipo correcto de geometría cuando se cree el conjunto de datos vectorial.

    El siguiente campo le permite especificar el Sistema de Coordenadas de Referencia, o CRS. CRS es un método de asociar coordenadas numéricas a una posición en la superficie terrestre. Vea el Manual de Usuario en Working with Projections para saber mas.

    Para este ejemplo usaremos el CRS predeterminado asociado a este proyecto, que es WGS84.

    ../../../_images/default_crs.png

    A continuación hay una colección de campos agrupados en Nuevo Campo. Por defecto, una capa nueva tiene solo un atributo, el campo id (que debería ver en Lista de campos) a continuación. Sin embargo, para que los datos que cree sean útiles, debe decir algo sobre las entidades que creará en esta nueva capa. Para nuestros propósitos actuales, será suficiente agregar un campo llamado nombre que contendrá Datos de texto y se limitará a la longitud del texto de 80 caracteres.

  7. Copie el setup siguiente, entonces haga ciick en el botón Añadir a la Lista de Campos:

    ../../../_images/new_attribute.png
  8. Comprueba que tu cuadro de diálogo ahora tiene este aspecto:

    ../../../_images/new_attribute_added.png
  9. Haga clic en Aceptar.

La nueva capa debería aparecer en su panel Capas

5.1.2. basic Follow Along: Fuentes de Datos

Cuando creas nuevos datos, obviamente deben ser sobre objetos que existen realmente en el terreno. Además, necesitarás obtener la información de alguna parte.

Hay muchas formas posibles de obtener datos sobre objetos. Por ejemplo, podrías utilizar un GPS para capturar puntos en el mundo real y luego importar los datos al QGIS. O podrías sondear los puntos con un teodolito e introducir las coordenadas manualmente para crear nuevas entidades. También podrías digitalizar procesos para trazar objetos desde sensores de datos remotos, como imagenes de satélite o fotografía aérea.

Para nuestro ejemplo, estarás utilizando un enfoque de digitalización. Las muestras de bases de datos raster se proporcionan, así que necesitarás importarlas cuando sea necesario.

  1. Click en el botón dataSourceManager Administrador de Fuentes de Datos.

  2. Seleccione raster Ráster en el lado izquierdo.

  3. En el panel Fuente, click en el botón :

  4. Navigue a exercise_data/raster/.

  5. Seleccione el archivo 3420C_2010_327_RGB_LATLNG.tif.

  6. Click en Abrir para cerrar la ventana de diálogo.

    ../../../_images/add_raster.png
  7. Click en Añadir y Cerrar. Una imagen se cargará en su mapa.

    ../../../_images/raster_added.png
  8. Si no ve aparecer una imagen aérea, seleccione la nueva capa, click derecho y elija Zoom a la capa en el menú contextual.

    ../../../_images/zoom_to_raster.png
  9. Click en el botón zoomIn Acercar zoom , y amplíe el área resaltado en azul abajo:

    ../../../_images/map_area_zoom.png

Ahora estás preparado para digitalizar estos tres campos:

../../../_images/field_outlines1.png

Antes de empezar a digitalizar, mueva la capa school_property sobre la imagen aérea.

  1. Seleccione la capa school_property en el panel de Capas y arrástrela a la parte superior.

../../../_images/move_school_layer.png

Para empezar a digitalizar, necesitarás entrar en modo de edición. Los software SIG normalmente lo requieren para prevenir que edites o borres accidentalmente datos importantes. El modo edición se activa o desactiva individualmente para cada capa.

Para entrar al modo edición para la capa school_property:

  1. Click en la capa school_property en el panel Capas para seleccionarla.

  2. Click en el botón toggleEditing Conmutar Edición.

    Si no puedes encontrar ese botón, comprueba que la barra de herramientas Digitalización está activada. Debería haber un marcador junto a la entrada del menú Ver ▶ Barras de herramientas ▶ Digitalización.

    Tan pronto como estés en modo edición, verás que algunas herramientas de digitalización se han activado:

    • capturePolygon Añadir polígono

    • vertexToolActiveLayer Herramienta de vértices

    Otros botones relevantes están todavía inactivos, pero se activarán cunado empecemos a interactuar con nuestros nuevos datos.

    Note que la capa school_property en el panel Capas ahora tiene un icono de lápiz, indicando que está en modo edición.

  3. Click en el botón capturePolygon Añadir polígono para empezar a digitalizar nuestros campos escolares.

    Notarás que el cursor del mouse se ha convertido en una cruz. Esto le permite colocar con mayor precisión los puntos que digitalizará. Recuerde que incluso cuando usa la herramienta de digitalización, puede acercar y alejar su mapa girando la rueda del ratón, y puede desplazarse presionando la rueda del ratón y arrastrando el mapa.

    El primer elemento que digitalizarás será el athletics field:

    ../../../_images/school_area_one.png
  4. Empieza a digitalizar clickando en un punto a lo largo del borde del campo.

  5. Sitúa más puntos clickando puntos adicionales en el borde, hasta que la forma que estés dibujando cubra completamente el campo.

    ../../../_images/school_field_outline.png
  6. Después de colocar su último punto, haga click derecho para terminar de dibujar el polígono. Esto finalizará la función y le mostrará el diálogo Atributos.

  7. Rellena los valores como sigue:

    ../../../_images/school_area_one_attributes.png
  8. Click en OK, y habrá creado una nueva entidad!

    ../../../_images/new_feature.png
  9. En el panel Capas seleccione la capa school_property.

  10. Click derecho y elija Abrir Tabla de Atributos en el menú contextual.

    ../../../_images/open_attribute_table.png

    En la tabla verá la función que acaba de agregar. Mientras está en modo de edición, puede actualizar los datos de los atributos haciendo doble click en la celda que desea actualizar.

    ../../../_images/feature_table.png
  11. Cierra la tabla de atributos.

  12. Para grabar la nueva entidad que hemos creado, click en`el botón saveEdits Guardar cambios de la capa.

Recuerda, si has cometido un error cuando digitalizabas el elemento, siempre puedes editarlo después de haberlo creado. Si has cometido un error, continúa digitalizando hasta que termines de crear el elemento como hasta ahora. Entonces:

  1. Click en el botón vertexToolActiveLayer Herramientas de vértices.

  2. Pase el ratón sobre el vértice que desea mover y haga click izquierdo en el vértice.

  3. Mueva el ratón a la localización correcta del vértice, y haga click izquierdo. Esto moverá el vértice a la nueva localización.

    ../../../_images/select_vertex.png
    ../../../_images/moved_vertex.png

    Se puede usar el mismo procedimiento para mover un segmento de línea, pero deberá desplazarse sobre el punto medio del segmento de línea.

Si desea deshacer un cambio, puede presionar el botón undo Deshacer o Ctrl+Z.

Recuerda guardar tus cambios clickando en el botón saveEdits Guardar cambios en la capa.

Para habilitar las herramientas de edición de entidades restantes, es necesario seleccionar la entidad.

  1. Click en el botón selectRectangle Seleccionar objetos espaciales por área en la barra de herramientas de Atributos.

  2. Click en la entidad que acaba de crear y los botones restantes se habilitarán.

    ../../../_images/all_active_buttons.png

    Ver User Manual para la descripción de los otros botones en esta barra de herramientas.

  3. Cuando este hecha la edición, click en el botón toggleEditing Conmutar edición para salir del modo edición, y guarde sus cambios.

5.1.3. basic Try Yourself: Digitalizando Polígonos

Digitaliza la propia escuela y el campo superior. Utiliza esta imagen para asistirte:

../../../_images/field_outlines1.png

Recuerda que cada nueva entidad necesita tener un único valor id!

Nota

Cuando hayas terminado de añadir elementos a la capa, recuerda guardar tus ediciones y salir del modo edición.

Nota

Puede estilizar el relleno, el borde y la ubicación y formato de la etiqueta de la school_property usando las técnicas aprendidas en lecciones anteriores.

5.1.4. moderate Follow Along: Usando la Tabla del Editor de Vértices

Otra forma de editar una entidad es ingresar manualmente los valores de coordenadas reales para cada vértice usando la tabla Editor de vértices.

  1. Asegúrate de que estás en modo edición en la capa school_property.

  2. Si todavía no está activado, click en el botón vertexToolActiveLayer Herramientas de vértices

  3. Mueva el ratón sobre una de las entidades de polígono que creó en la capa school_property y haga click derecho sobre ella. Esto seleccionará la entidad y aparecerá un panel Editor de vértices.

    ../../../_images/vertex_editor_table.png

    Nota

    Esta tabla contiene las coordenadas para los vértices de la entidad. Observe que hay siete vértices para esta entidad, pero solo seis se identifican visualmente en el área del mapa. Tras una inspección más cercana, uno notará que las filas 0 y 6 tienen coordenadas idénticas. Estos son los vértices de inicio y fin de la geometría de la entidad, y son necesarios para crear una entidad de polígono cerrado.

  4. Click y arrastre un cuadro sobre un vértice, o múltiples vértices, de una entidad seleccionada.

    ../../../_images/vertex_select.png

    Los vértices seleccionados cambiarán a un color azul y la tabla Editor de vértices tendrá las filas correspondientes resaltadas, que contienen las coordenadas de los vértices.

    ../../../_images/vertex_selected.png
  5. Para actualizar una coordenada, haga doble click izquierdo en la celda de la tabla que desea editar e ingrese el valor actualizado. En este ejemplo, la coordenada x de la fila `` 4`` se actualiza de 20.4450 a 20.4444.

    ../../../_images/edit_vertex_in_vertex_editor.png
  6. Después de ingresar el valor actualizado, presione la tecla Intro para aplicar el cambio. Verá que el vértice se mueve a la nueva ubicación en la ventana del mapa.

  7. Cuando este hecha la edición, click en el botón toggleEditing Conmutar edición para salir del modo edición, y guarde sus cambios.

5.1.5. basic Try Yourself: Digitalizadno líneas

Vamos a digitalizar dos rutas que aún no están marcadas en la capa de carreteras; uno es un camino, el otro es una pista. Nuestro camino corre a lo largo del borde sur del suburbio de Railton, comenzando y terminando en carreteras marcadas:

../../../_images/path_start_end.png

Nuestra pista está un poco más lejos hacia el sur:

../../../_images/track_start_end.png
  1. Cree un nuevo conjunto de datos de línea de ESRI Shapefile llamado routes.shp, con los atributos id y type (use la aproximación anterior para guiarse).

  2. Si la capa de carreteras no está en su mapa, agréguela desde el archivo GeoPackage training-data.gpkg incluido en la carpeta exercise_data de los datos de entrenamiento que descargó.

  3. Activa el modo edición.

  4. Como está trabajando con una entidad lineal, haga click en el botón addLineFeature Añadir Línea para iniciar el modo de digitalización lineal.

  5. Uno a uno, digitalice la ruta y la pista en la capa rutas. Intente seguir las rutas con la mayor precisión posible, agregando puntos adicionales a lo largo de las esquinas o giros.

  6. Establezca el valor del atributo type como path o track.

  7. Use el diálogo Propiedades de capa para ñadir estilo a sus rutas. Siéntase libre de usar diferentes estilos para caminos y pistas.

  8. Guarde sus ediciones y desactive el modo de edición presionando el botón toggleEditing Conmutar edición.

Comprueba tus resultados

5.1.6. In Conclusion

¡Ahora sabes cómo crear elementos! Este curso no cubre el añadir elementos de tipo puntos, esto no es realmente necesario una vez que has trabajado con elementos más complicados (líneas y polígonos). Funciona exactamente igual, excepto por que solo clicas una vez donde quieras que esté el punto, le das atributos como habitualmente, y luego el elemento se crea.

Saber cómo digitalizar es importante porque es una actividad muy común en programas SIG.

5.1.7. What’s Next?

Las entidades en una capa SIG no son solo imágenes, sino objetos en el espacio. Por ejemplo, los polígonos adyacentes saben dónde están en relación entre ellos. Esto se llama topología. En la próxima lección verá un ejemplo de por qué esto puede ser útil.