14.6. Lesson: Creación de Mapas detallados con la herramienta Atlas

El diseño de muestreo sistemático está listo y los equipos de campo han cargado las coordenadas GPS en sus sistemas de navegación. También tienen un formulario de datos de campo donde colectarán la información medida en cada parcela de muestreo. Para encontrár más fácilmente su camino a cada parcela de muestreo, ellos han pedido un número de mapas detallados donde se puede ver claramente alguna información sobre el terreno junto con un pequeño conjunto de parcelas de muestreo y otra información sobre el área del mapa. Puedes utilizar la herramienta Atlas para generar automáticamente un número de mapas con un formato común.

El objetivo de esta lección: Aprender a utilizar la herramienta Atlas en QGIS para generar mapas detallados que se puedan imprimir para asistir en el trabajo de inventario de campo.

14.6.1. basic Follow Along: Preparing the Print Layout

Antes de que podamos automatizar los mapas detallados de la mayoría del área forestal y nuestras parcelas de muestreo, necesitamos crear una plantilla de mapa con todos los elementos que consideremos útiles para el trabajo de campo. Por supuesto lo más importante será un un estilo apropiado, pero como has visto anteriormente, también necesitarás añadir muchos otros elementos que completen el mapa impreso.

Abre el proyecto QGIS de la lección anterior forest_inventory.qgs. Deberías tener al menos las capas siguientes:

  • forest_stands_2012 (con una transparencia del 50%, relleno verde y líneas de los bordes verde oscuro).

  • systematic_plots_clip.

  • rautjarvi_aerial.

Guarda el proyecto con un nuevo nombre, map_creation.qgs.

To create a printable map, remember that you use the Layout Manager:

  • Open Project ▶ Layout Manager….

  • In the Layout manager dialog.

  • Click the Add button and name your print layout forest_map.

  • Haz clic en OK.

  • Haz clic en el botón Show.

Ajusta las opciones de impresora para que tu página y márgenes del mapa se ajusten a un papel A4:

  • Open menuselection:Layout –> Page Setup….

  • Size es A4 (217 x 297 mm).

  • Orientation es Landscape.

  • Margins (millimeters) are all set to 5.

In the Print Layout window, go to the Composition tab (on the right panel) and make sure that these settings for Paper and quality are the same you defined for the printer:

  • Size: A4 (210x297mm).

  • Orientation: Landscape.

  • Quality: 300dpi.

Composing a map is easier if you make use of the canvas grid to position the different elements. Review the settings for the layout grid:

  • En la pestaña Composition expande la región Grid.

  • Comprueba que Spacing está ajustado a 10 mm.

  • Y que Tolerance es 2 mm.

Necesitas activar el uso de la cuadrícula:

  • Abre el menú View.

  • Habilita Show grid.

  • Habilita Snap to grid.

  • Notice that options for using guides are checked by default, which allows you to see red guiding lines when you are moving elements in the layout.

Ahora puedes empezar a añadir elementos a tu lienzo del mapa. Añade primero un elemento del mapa para revisar cómo se ve ya que estáras realizando cambios en la simbología de las capas:

  • Haga clic en el botón Añadir nuevo mapa : addMap.

  • Haz clic y arrastra la caja en el lienzo para que el mapa ocupe la mayor parte.

../../../_images/composer_1.png

Observa cómo el cursor del ratón se ajústa al lienzo en cuadrícula. Utiliza esta función cuando añadas otros elementos. Si quieres tener más precisión, cambia los ajustes de cuadrícula Spacing. Si por alguna razón no quieres forzar el cursor a la cuadrícula en algún momento, siemper puedes habilitarlo o deshabilitarlo en el menú View.

14.6.2. basic Follow Along: Adición de un Mapa de Fondo

Leave the layout open but go back to the map. Lets add some background data and create some styling so that the map content is as clear as possible.

  • Add the background raster basic_map.tif that you can find in the exercise_data\forestry\ folder.

  • Cuando se requiera selecciona el SRC ETRS89 / ETRS-TM35FIN para la capa ráster.

Como puedes ver el mapa base ya está estilizado. Este tipo de rásters cartográficos listos para utililar es muy común. Está creado a partir de datos vectoriales, estilizado en un formato estándar y guardado como un ráster para que no tengas que dar estilo a muchas capas vectoriales y preocuparte de obtener un buen resultado.

  • Ahora amplía tus parcelas de muestreo, para poder ver solo cuatro o cinco líneas de parcelas.

The current styling of the sample plots is not the best, but how does it look in the print layout?:

../../../_images/plots_zoom1-2.png

While during the last exercises, the white buffer was OK on top of the aerial image, now that the background image is mostly white you barely can see the labels. You can also check how it looks like on the layout:

  • Go to the Print Layout window.

  • Use the select button to select the map element in the layout.

  • Ve a la pestaña Item properties.

  • En Extents haz clic en Set to map canvas extent.

  • Si necesitas refrescar el elemento, en Main properties haz clic en Update preview.

Obviamente esto no es suficientemente bueno, tú quieres hacer los números de las parcelas tan claramente visibles como se pueda para los equipos de campo.

14.6.3. basic Try Yourself Cambio de la Simbología de las Capas

Has estado trabajando en Crear y explorar un mapa básico con simbología y en Module: Clasificación de Datos Vectoriales con etiquetas. Regresa a estos módulos si necesita refrescarse sobre algunas de las opciones y herramientas disponibles. Su objetivo es conseguir que los lugares parcelas y los nombre sean tan visibles como sea posible, pero siempre permitiendo ver los elementos del mapa de fondo. Puede tomar alguna orientación de esta imagen:

../../../_images/plots_zoom2_symbology.png

Luego utilizarás el estilo verde para la capa forest_stands_2012. Para mantenerlo, y tener una visualización que solo muestre los bordes de las masas:

  • Haz clic derecho en forest_stands_2012 y selecciona Duplicate

  • Obtendrás una capa nueva llamada forest_stands_2012 copy que puedes utilizar para definir un estilo diferente, por ejemplo sin relleno y con bordes rojos.

Ahora tienes dos visualizaciones diferentes de las masas forestales y puedes decidir cual visualizar en tu mapa detallado.

Go back to the Print Layout window often to see what the map would look like. For the purposes of creating detailed maps, you are looking for a symbology that looks good not at the scale of the whole forest area (left image below) but at a closer scale (right image below). Remember to use Update preview and Set to map canvas extent whenever you change the zoom in your map or the layout.

../../../_images/composer_2-3.png

14.6.4. basic Try Yourself Creación de una Plantilla Básica del Mapa

Una vez tienes una simbología con la que estás contento, estás listo para añadir alguna otra información a tu mapa imprimible. Añade al menos los elementos siguientes:

  • Título.

  • Una barra de escala.

  • Una cuadrícula para tu mapa.

  • Coordenadas en los bordes de la cuadrícula.

Ya has creado una composición parecida en Module: Trazando los mapas. Vuelve a ese módulo si lo necesitas.

../../../_images/map_template1.png

Exporta tu mapa como una imagen y revísalo.

  • Layout ▶ Export as Image….

  • Utiliza el formato JPG format, por ejemplo.

Así es como se verá cuando esté impreso.

14.6.5. basic Follow Along: Adding More Elements to the Print Layout

Como probablemente hayas observado en las imágenes sugeridas de plantilla de mapa, hay espacio de sobra en la parte derecha del lienzo. Vamos a ver qué más podría haber ahí. Para los propósitos de nuestro mapa, una leyenda no es realmente necesaria, pero un mapa resumen y algunas cajas de texto podrian añadir valor al mapa.

El mapa resumen ayudará a los equipos de campo a situar al mapa detallado dentro del área forestal general:

  • Añade otro elemento del mapa al lienzo, justo bajo el texto del título.

  • En la pestaña Item properties, abre el menú desplegable Overview.

  • Ajusta Overview frame a Map 0. Esto crea un rectángulo sombreado encima de un mapa más pequeño representando la extensión visible del mapa grande.

  • Habilita también la opción con color negro Frame y un Thickness de 0.30.

../../../_images/more_elements1.png

Notice that your overview map is not really giving an overview of the forest area which is what you want. You want this map to represent the whole forest area and you want it to show only the background map and the forest_stands_2012 layer, and not display the sample plots. And also you want to lock its view so it does not change anymore whenever you change the visibility or order of the layers.

  • Go back to the map, but don’t close the Print Layout.

  • Haz clic derecho en la capa forest_stands_2012 y haz clic en Zoom to Layer Extent.

  • Desactiva todas las capas excepto basic_map y forest_stands_2012.

  • Go back to the Print Layout.

  • Con el mapa pequeño seleccionado, haz clic en Set to map canvas extent para ajustar su extensión a lo que puedes ver en la ventana del mapa.

  • Bloquea la vista para el mapa resumen habilitando Lock layers for map item en Main properties.

Ahora tu mapa resumen se parece más a lo que tú querías y no volverá a cambiar. Pero, por supuesto, ahora tu mapa detallado ha dejado de mostrar los bordes de las masas ni las parcelas de muestreo. Vamos a solucionarlo:

  • Vuelve a la ventana del mapa y selecciona las capas que quieres que sean visibles (systematic_plots_clip, forest_stands_2012 copy y Basic_map).

  • Vuelve a ampliar el zoom para tener visibles solo unas pocas líneas de parcelas de muestreo.

  • Go back to the Print Layout window.

  • Select the bigger map in your layout (select).

  • En Item properties haz clic en Update preview y Set to map canvas extent.

Observa que solo el mapa grande se muestra en la vista actual del mapa, y el mapa resumen pequeño se mantiene en la misma vista en que lo bloqueaste.

También observa que la visión general está mostrando una franja sombreada de la extensión mostrada en el mapa detallado.

../../../_images/more_elements2.png

Tu plantilla está casi lista. Añade ahora dos cajas de texto bajo el mapa, una conteniendo el texto “Detailed map zone: “ y la otra “Remarks: “. Sitúalas para que puedas verlas en la imágen superior.

También puedes añadir una flecha de Norte al mapa resumen:

  • Utilice la herramienta Añadir imagen, addImage.

  • Haz clic en la esquina superior derecha del mapa resumen.

  • En Item properties abre Search directories y busca la imagen de una flecha.

  • En Image rotation, habilita Sync with map y selecciona Map 1 (el mapa resumen).

  • Deshabilita Background.

  • Ajusta el tamaño de la flecha para que quede bien en el mapa pequeño.

The basic map layout is ready, now you want to make use of the Atlas tool to generate as many detail maps in this format as you consider necessary.

14.6.6. basic Follow Along: Creación de una Cubierta Atlas

La cobertura Atlas es solo una capa vectorial que se utilizará para generar los detalles de los mapas, un mapa para cada objeto espacial de la cobertura. Para tener una idea de que harás a continuación, aquí hay un conjunto completo de mapas detallados para el área forestal:

../../../_images/preview_atlas_results.png

La cubierta podría ser una capa existente, pero normalmente tiene más sentido crear una para el propósito específico. Vamos a crear una maya de polígonos cubriendo el área forestal:

  • En la vista del mapa QGIS, abre Vector ▶ Research Tools ▶ Vector grid.

  • Ajusta la herramienta como se muestra en la imagen:

../../../_images/coverage_polygons.png
  • Guarda el resultado como atlas_coverage.shp.

  • Cambia el estilo de la capa kbd:atlas_coverage de modo que los polígonos no tengan relleno.

Los nuevos polígonos están cubriendo toda la superficie forestal y le dan una idea de lo que cada mapa (creado a partir de cada polígono) contendrá.

../../../_images/atlas_coverage.png

14.6.7. basic Follow Along: Configurar la Herramienta Atlas

El último paso es configurar la herramienta Atlas:

  • Go back to the Print Layout.

  • En el panel de la derecha, ve a la pestaña Atlas generation.

  • Configura las opciones como sigue:

../../../_images/atlas_settings.png

That tells the Atlas tool to use the features (polygons) inside atlas_coverage as the focus for every detail map. It will output one map for every feature in the layer. The Hidden coverage layer tells the Atlas to not show the polygons in the output maps.

Una cosa más debe hacerse. Necesitas decirle a la herramienta Atlas qué elemento del mapa será actualizado para cada mapa de salida. Por ahora, probablemente puedes suponer que el mapa a ser cambiado para cada elemento es uno de los que has preparado para contener vistas detalladas de las parcelas de muestreo, que es el elemento más grande del mapa de tu lienzo:

  • Selecciona el elemento más grande del mapa.

  • Ve a la pestaña Item properties.

  • En la lista, habilita Controlled by atlas.

  • Y ajusta Marging around feature a 10%. La extensión de la vista sera un 10% mayor que los polígonos, lo que significa que tus mapas detallados tendrán un 10% superpuesto.

../../../_images/controlled_by_atlas.png

Ahora puedes utilizar la herramienta de vista previa para los mapas Atlas para revisar que todos tus mapas se ven así:

  • Active la vista previa de Atlas mediante el botón atlas o si la barra de herramientas del Atlas no esta visible, por Atlas ▶ Vista previa del Atlas.

  • Puedes utilizar las flechas de la barra del menú de la herramientas Atlas Atlas para moverte a través de los mapas que serán creados.

Observa que algunos de ellos cubren áreas que no son interesantes. Vamos a hacer algo al respecto y salvaremos algunos árboles al no imprimir mapas inútiles.

14.6.8. basic Follow Along: Edición de la Capa de Cobertura

En lugar de borrar los polígonos para esas áreas que no son interesantes, puedes también personalizar las etiquetas de texto en tu mapa a generar con contenido de la Attribute table de tu capa de cobertura:

  • Vuelve a la vista del mapa.

  • Habilita la edición de la capa atlas_coverage.

  • Selecciona los polígonos que están seleccionados (en amarillo) en la imagen inferior.

  • Borra los polígonos seleccionados.

  • Guarda y deshabilita la edición.

../../../_images/remove_polygons.png

You can go back to the Print Layout and check that the previews of the Atlas use only the polygons you left in the layer.

La capa de cobertura que estás utilizando todavía no tiene información útil que podrías utilizar para personalizar el contenido de las etiquetas en tu mapa. El primer paso es crearlas, puedes añadir por ejemplo un código de zona para las áreas de los polígonos y un campo con algunas observaciones para que los equipos de campo tengan en cuenta:

  • Abre la Attribute table para la capa atlas_coverage.

  • Habilita la edición.

  • Utilice la calculadora calculateField para crear y llenar los siguientes dos campos.

  • Crea un campo llamado Zone y escribe Whole number (integer).

  • En la caja Expression escribe/copia/construye $rownum.

  • Crea otro campo llamado Remarks, del tipo Text (string) y con un ancho de 255.

  • En la caja Expression escribe 'No remarks.'. Esto ajustará todos los valores por defecto para todos los polígonos.

El gestor forestal tendrá alguna información sobre el área que puede ser útil cuando visite el área. Por ejemplo, la existencia de un puente, un pantano o la presencia de especies protegidas. Probablemente la capa atlas_coverage todavía está en modo edición, y el siguiente texto en el campo Remarks a los polígonos correspondientes (haz doble clic en la celda para editarla):

  • Para la Zone 2: Puente al norte de la parcela 19. Ardilla siberiana entre p_13 y p_14..

  • Para la Zone 6: Dificultad de tránsito en el pantano al norte del lago..

  • Para la Zone 7: Ardilla siberiana al sureste de p_94..

  • Desactiva y guarda la edición.

Casi listo, ahora tienes que decirle a la herramienta Atlas que quieres que algunas de las etiquetas de texto utilicen la informacion de la tabla de atributos de la capa atlas_coverage:

  • Go back to the Print Layout.

  • Selecciona la etiqueta de texto que contiene Detailed map....

  • Ajusta el tamaño de Font a 12.

  • Ajusta el cursor al final del texto en la etiqueta.

  • En la pestaña Item properties, en Main properties haz clic en Insert an expression.

  • En la Function list haz doble clic en el campo Zone under Field and Values.

  • Haz clic en OK.

  • El texto dentro de la caja en el Propiedades del elemento deben mostrar Detalle del mapa de la zona inventariada: [% "Zone" %]. Tenga en cuenta que la [% "Zone" %] será substituida por el valor del campo Zona para el objeto espacial correspondiente de la capa atlas_coverage.

Comprueba el contenido de la etiqueta mirando diferentes mapas de vista previa de Atlas.

Haga lo mismo para las etiquetas con el texto Observaciones: utilizando el campo con la información de la zona. Puede dejar una línea de descanso antes de ingresar la expresión. Puede ver el resultado para la vista previa de la zona en la imagen inferior:

../../../_images/preview_zone2.png

Utiliza la vista previa del Atlas para navegar a través de todos los mapas que crearás pronto, ¡y disfrútalo!

14.6.9. basic Follow Along: Impresión de los Mapas

Por último pero no menos importante, imprimir o exportar tus mapas a archivos de imagen o archivos PDF. Puedes utilizar Atlas ▶ Export Atlas as Images… o Atlas ▶ Export Atlas as PDF…. Actualmente la exportación a formato SGV y funciona correctamente y dará malos resultados.

Vamos a imprimir los mapas como un archivo PDF que puedes enviar a la oficina de campo para imprimir:

  • Ve a la pestaña Atlas generation en el panel derecho.

  • En Output activa Single file export when possible. Esto pondrá todos los mapas juntos en un archivo PDF, si esta opción no está activada obtendrás un archivo para cada mapa.

  • Open Layout ▶ Export as PDF….

  • Guarda el archivo PDF como inventory_2012_maps.pdf en tu carpeta exercise_data\forestry\samplig\map_creation\.

Abre el archivo PDF para comprobar que todo fué como esperabas.

Podrías crear imágenes para cada mapa así de fácil (recuerda desactivar la creación de archivos individuales), aquí puedes ver las miniaturas de las imágenes que serían creadas:

../../../_images/maps_as_images.png

In the Print Layout, save your map as a layout template as forestry_atlas.qpt in your exercise_data\forestry\map_creation\ folder. Use Layout ▶ Save as Template. You will be able to use this template again and again.

Close the Print Layout and save your QGIS project.

14.6.10. In Conclusion

Te las has arreglado para crear un mapa de plantilla que puede ser utilizado para generar automáticamente mapas detallados para ser utilizados para ayudar a navegar hasta las diferentes parcelas. Como observaste, no fué una tarea fácil pero el beneficio vendrá cuando necesites crear mapas similares para otras regiones utilizando la plantilla que acabas de guardar.

14.6.11. What’s Next?

En la siguiente lección, verás cómo puedes utilizar datos LIDAR para crear un DEM y luego utilizarlo para ampliar tus datos y la visibilidad del mapa.