Outdated version of the documentation. Find the latest one here.

14.2. Lesson: 맵을 지리참조시키기

일반적인 삼림관리 작업은 삼림 지역에 대한 정보를 업데이트하는 일일 것입니다. 해당 지역의 정보가 몇 년 전의 것일 수도 있고, 아날로그적으로 (즉 종이 위에) 수집되었을 수도 있으며, 또는 디지털화되었다고 해도 여러분이 접근할 수 있는 정보는 해당 목록 데이터의 하드카피 버전뿐일 수도 있습니다.

예를 들자면 아마도 이전 목록 정보와 비교하기 위해 해당 정보를 GIS에서 사용하고자 하는 경우가 대부분일 것입니다. 즉 GIS 소프트웨어를 이용해서 지금 접근할 수 있는 정보를 디지털화해야 한다는 의미입니다. 그러나 디지털화 작업을 시작하기 전에 여러분의 종이 지도를 스캔하고 지리참조시키는 아주 중요한 첫 번째 단계를 거쳐야 합니다.

이 강의의 목표: QGIS의 지리참조 도구를 사용하는 방법을 배우기.

14.2.1. basic 맵 스캔하기

여러분이 해야 할 첫 번째 작업은 여러분의 지도를 스캔하는 일입니다. 지도가 아주 클 경우, 부분 부분을 각각 따로 스캔할 수 있지만 각 부분마다 전처리 및 지리참조 작업을 반복해야 한다는 것을 명심하십시오. 따라서 가능한 한 가장 적은 부분들로 지도를 스캔하는 것이 좋습니다.

이 교재가 제공하는 것과는 다른 지도를 사용할 예정이라면, 여러분의 스캐너를 이용하여 지도를 직접 이미지 파일로 스캔하십시오. 해상도 300 DPI 정도가 좋습니다. 여러분의 지도에 여러 색상이 쓰였다면 컬러로 스캔하십시오. 나중에 이 색상들을 사용하여 지도에서 정보를 분리, 서로 다른 레이어로 저장할 수 있습니다. (예 : 수종경계, 등고선, 도로 등등)

이 예제에서 쓰일 미리 스캔된 맵은 데이터 폴더 exercise_data/forestry 안에 있는 rautjarvi_map.tif 파일입니다.

14.2.2. basic Follow Along: 스캔한 맵을 지리참조시키기

QGIS를 실행한 다음 Project ‣ Project Properties ‣ CRS 메뉴에서 이 프로젝트의 CRS를 ETRS89 / ETRS-TM35FIN 으로 설정하십시오. 현재 핀란드에서 쓰이고 있는 CRS입니다. Enable ‘on the fly’ CRS transformation 체크박스가 체크되어 있는지 확인하십시오. 다른 CRS를 사용하는 이전 데이터도 같이 작업할 예정이기 때문입니다.

../../../_images/f_1.png

이 QGIS 프로젝트를 map_digitizing.qgs 라는 이름으로 저장하십시오.

이미 QGIS에 설치된 지리참조 플러그인을 사용할 것입니다. 이전 강의에서 실습했던 것처럼 플러그인 관리자를 이용해서 해당 플러그인을 활성화하십시오. 지리참조 플러그인의 명칭은 Georeferencer GDAL 입니다.

맵을 지리참조시키려면,

  • Raster ‣ Georeferencer ‣ Georeferencer 메뉴를 클릭해서 지리참조 도구를 실행하십시오.

  • File ‣ Open raster 메뉴를 클릭해서 지리참조의 대상이 될 이미지 파일 rautjarvi_map.tif 를 맵에 추가합니다.

  • 대화 창이 열리면 KKJ / Finland zone 2 CRS를 찾아 선택하십시오. 이 맵이 생성된 1994년 당시 핀란드에서 쓰이던 CRS입니다.

  • OK 를 클릭하십시오.

다음으로 맵을 지리참조시키기 위한 변환 설정을 정의해야 합니다.

  • Settings ‣ Transformation settings 메뉴를 클릭합니다.

  • Output raster 옆에 있는 아이콘을 클릭해서 데이터 폴더로 이동한 다음, exercise_data\forestry\digitizing 폴더를 생성하고 rautjarvi_georef.tif 라는 이름으로 저장하십시오.

  • 나머지 파라미터를 다음과 같이 설정하십시오.

../../../_images/Clipboard10.png
  • OK 를 클릭하십시오.

이 맵에는 좌표를 표시하는 십자 표식이 몇 개 있는데, 이미지를 지리참조시키기 위해 이것을 이용할 것입니다. 지리참조 도구 창에서 QGIS에서 보통 하던 대로 확대/축소 및 이동 도구를 통해 이미지를 살펴보십시오.

  • 맵의 좌하단으로 확대해 들어가면, 앞에서 언급했던 KKJ / Finland zone 2 좌표계의 x, y 값이 달린 십자 표식이 보일 겁니다. 맵을 지리참조시키기 위해 이 포인트를 첫 번째 지상기준점으로 이용할 것입니다.

  • Add point 도구를 사용해서 십자 표식의 교차점을 선택하십시오. (필요하다면 확대/축소 및 이동 도구를 사용하십시오.)

  • Enter map coordinates 대화 창에 맵 위에 써 있는 좌표(X: 2557000, Y: 6786000)를 입력하십시오.

  • OK 를 클릭하십시오.

지리참조 작업을 위한 첫 번째 좌표가 준비됐습니다.

검정색 라인 이미지에서 다른 십자 표식을 찾아보십시오. 각각 북쪽과 동쪽 방향에 서로 1000 미터 간격으로 떨어져 있습니다. 첫 번째 좌표를 기준으로 이 포인트들의 좌표를 계산할 수 있을 겁니다.

이미지를 축소한 다음 다른 십자 표식을 찾을 때까지 오른쪽으로 이동하십시오. 그리고 몇 킬로미터나 이동했는지 측정해보십시오. 가능한 한 서로에게서 가장 멀리 떨어진 지상기준점을 찾아보십시오. 첫 지상기준점과 동일한 방법으로 적어도 3개 이상의 지상기준점을 더 디지타이즈하십시오. 다음과 같은 화면을 보게 될 것입니다.

../../../_images/Clipboard09.png

3개 이상의 지상기준점을 디지타이즈했기 때문에 포인트에서 뻗어나온 빨강색 라인을 볼 수 있을 겁니다. 이 라인은 지리참조 오류를 의미합니다. GCP tabledX[pixels]dY[pixels] 열에서도 픽셀 단위로 표출된 오류를 볼 수 있습니다. 이 오류는 10 픽셀을 넘어서는 안 됩니다. 만약 10 픽셀 이상일 경우 디지타이즈한 포인트및 입력한 좌표를 살펴보고 문제가 무엇인지 알아내야 합니다. 앞의 이미지를 기준으로 삼으십시오.

여러분의 기준점에 만족한다면 나중에 필요하게 될 경우를 대비해서 지상기준점 포인트를 저장하십시오. 필요하게 될 겁니다.

  • File ‣ Save GCP points as... 메뉴를 클릭하십시오.

  • exercise_data\forestry\digitizing 폴더에 rautjarvi_map.tif.points 라는 이름으로 파일을 저장하십시오.

마지막으로, 사용자의 맵을 지리참조시킵니다.

  • File ‣ Start georeferencing 메뉴를 클릭하십시오.

  • 여러분이 지리참조 도구 설정을 정의했을 때 이미 rautjarvi_georef.tif 라는 이름으로 파일을 저장했던 것을 기억하십시오.

이제 QGIS 프로젝트에서 지리참조된 래스터인 맵을 볼 수 있습니다. 래스터가 약간 기운 것처럼 보이지만, 데이터의 좌표계는 KKJ / Finland zone 2 이고 프로젝트는 ETRS89 / ETRS-TM35FIN 이기 때문입니다.

데이터가 제대로 지리참조되었는지 확인하려면 exercise_data\forestry 폴더에 있는 파일명 rautjarvi_aerial.tif 항공사진을 불러옵니다. 맵과 이 사진이 잘 맞아야 합니다. 맵의 투명도를 50%로 설정한 다음 항공사진과 비교해보십시오.

../../../_images/Clipboard14.png

변경 사항을 QGIS 프로젝트에 저장하십시오. 다음 강의에서도 이 프로젝트를 사용할 것입니다.

14.2.3. In Conclusion

종이 지도를 지리참조시키는 일은 상대적으로 간단한 작업이라는 사실을 알게 되었습니다.

14.2.4. What’s Next?

다음 강의에서는 맵 상에 수종경계(forest stands)를 폴리곤으로 디지타이즈하고 해당 폴리곤에 목록 데이터를 추가할 것입니다.