Outdated version of the documentation. Find the latest one here.

14.6. Lesson: 아틀라스 도구로 상세지도 생성

체계적인 표본 조사구 설계를 완료했고 현장 팀도 내비게이션 기기에 GPS 좌표를 입력했습니다. 또한 표본 조사구에서 산정된 정보를 수집하는 데 쓰일 현장 조사 양식도 준비됐습니다. 그런데 현장 팀이 보다 쉽게 표본 조사구를 찾을 수 있도록 해당 지역에 대한 대략적인 정보와 함께 몇몇 표본 조사구를 기준으로 지상에 대한 정보를 확실히 알아볼 수 있는 상세지도 여러 장을 요청했습니다. 여러분은 아틀라스 도구를 이용해서 양식이 공통된 지도 여러 장을 자동적으로 생성할 수 있습니다.

이 강의의 목표: QGIS에서 아틀라스 도구를 사용하여 현장 목록화 작업에 도움이 될, 인쇄할 수 있는 상세한 맵을 생성하기.

14.6.1. basic Follow Along: 맵 작성자 준비

삼림 지역 및 표본 조사구의 상세한 맵을 자동생산하기 전에, 현장 조사에 도움이 될 모든 요소들을 갖춘 지도 템플릿을 만들어야 합니다. 물론 적절한 스타일을 적용하는 일이 가장 중요하지만, 이전에 경험했듯이, 인쇄 지도를 완성하기 위해서는 다른 요소들도 많이 필요합니다.

이전 강의에서 만들었던 forest_inventory.qgs 프로젝트를 여십시오. 적어도 다음 레이어들이 들어 있을 것입니다.

  • forest_stands_2012 레이어 (투명도 50%, 녹색 면, 진녹색 경계선)

  • systematic_plots_clip 레이어

  • rautjarvi_aerial 레이어

프로젝트를 map_creation.qgs 라는 이름으로 새로 저장하십시오.

인쇄할 수 있는 맵을 생성하려면 Composer Manager 도구를 사용하면 됩니다.

  • 메뉴에서 Project ‣ Composer Manager... 를 클릭하십시오.

  • Composer manager 대화 창에서,

  • Add 버튼을 클릭한 다음 작성자를 forest_map 으로 명명하십시오.

  • OK 를 클릭하십시오.

  • Show 를 클릭하십시오.

프린터 옵션에서 맵이 A4 종이에 맞도록 용지 및 여백을 설정하십시오.

  • 메뉴에서 Composer ‣ Page Setup 을 클릭하십시오.

  • SizeA4 (217 x 297 mm) 로 설정합니다.

  • OrientationLandscape 로 설정합니다.

  • Margins (milimeters) 를 모두 5 로 설정합니다.

Print Composer 창에서 (오른쪽 패널에 있는) Composition 탭으로 이동, Paper and quality 옵션들이 프린터 설정과 동일한지 확인하십시오.

  • Size : A4 (210x297mm)

  • Orientation : Landscape

  • Quality : 300dpi

서로 다른 요소들을 배치하는 데 캔버스 그리드를 사용하면 맵 작성 작업이 더 쉬워집니다. 작성자 그리드 설정을 살펴봅시다.

  • Composition 탭으로 이동해서 Grid 영역을 확장하십시오.

  • Spacing10 mm 로 설정돼 있는지 확인하십시오.

  • Tolerance2 mm 로 설정돼 있는지도 확인하십시오.

그리드 사용을 활성화해야 합니다.

  • 메뉴에서 View 를 클릭하십시오.

  • Show grid 체크박스를 체크합니다.

  • Snap to grid 체크박스를 체크합니다.

  • guides 를 사용하기 위한 옵션은 기본적으로 체크되어 있습니다. 여러분이 맵 작성자 안에서 요소를 이동시킬 때 빨강색 지시선을 표출하는 옵션입니다.

이제 맵 캔버스에 요소를 추가할 수 있습니다. 레이어의 심볼을 변경할 경우 맵이 어떻게 보이는지 살펴볼 수 있도록 먼저 맵 요소를 추가합니다.

  • Click on the Add New Map button: mActionAddMap.
  • 캔버스 위에 클릭&드래그로 맵이 들어갈 사각형을 크게 그리십시오.

../../../_images/composer_1.png

마우스 커서가 캔버스 그리드에 스냅되어 붙는 걸 알 수 있을 겁니다. 다른 요소를 추가할 때 이 기능을 사용하십시오. 좀 더 정확히 작업하고 싶다면, 그리드의 Spacing 설정을 변경하십시오. 작업 도중 어떤 이유로든 그리드에 스냅하고 싶지 않게 될 경우, View 메뉴에서 언제든지 체크/해제할 수 있습니다.

14.6.2. basic Follow Along: 배경 맵 추가

작성자를 그대로 내버려두고 다시 프로젝트 맵으로 돌아갑시다. 몇몇 배경 데이터를 추가하고 스타일을 생성해서 맵의 내용을 가능한 한 명확하게 만들겠습니다.

  • exercise_data\forestry\ 폴더에 있는 배경 래스터 파일 basic_map.tif 를 추가하십시오.

  • CRS 대화 창이 뜨면 ETRS89 / ETRS-TM35FIN 좌표계를 선택합니다.

배경 맵에 이미 스타일이 적용된 걸 알 수 있습니다. 이렇게 미리 준비된 유형의 지도 제작용 래스터는 많이 있습니다. 이 배경 맵은 벡터 데이터를 기반으로 생성되어 표준 포맷 스타일을 적용해서, 여러 벡터 레이어에 일일이 스타일을 적용하면서 괜찮은 결과가 나올지 걱정할 필요가 없도록 래스터로 저장된 파일입니다.

  • 이제 조사구 주변에 서너 개의 라인만 보일 때까지 표본 조사구를 확대해보십시오.

표본 조사구에 현재 적용된 스타일은 최선이 아닙니다. 과연 맵 작성자에서는 어떻게 보일까요?

../../../_images/plots_zoom1-2.png

지난 예제에서는 항공사진 위에서 흰색 버퍼가 괜찮게 보였지만, 이번에는 배경 이미지가 거의 흰색이기 때문에 라벨을 보기 힘듭니다. 라벨이 맵 작성자에서 어떻게 보이는지도 확인해보세요.

  • Print Composer 창으로 이동합니다.

  • Use the mActionSelect button to select the map element in the composer.
  • Item properties 탭으로 이동합니다.

  • Extents 아래에 있는 Set to map canvas extent 를 클릭하십시오.

  • 요소를 새로고침해야 할 경우, Main properties 아래에 있는 Update preview 를 클릭하십시오.

현재 상태로는 이 지도를 사용할 수 없습니다. 가능한 한 현장 팀이 조사구 번호를 뚜렷이 볼 수 있도록 만들어야 합니다.

14.6.3. basic Try Yourself 레이어의 심볼 변경

Module: 기본 맵 생성 강의에서 심볼에 대해, Module: 벡터 데이터 범주화 강의에서 라벨에 대해 배웠습니다. 필요하다면 다시 해당 강의들을 복습해서 사용할 수 있는 옵션 및 도구에 대한 기억을 되살리십시오. 이번 예제의 목표는 가능한 한 조사구의 위치와 명칭을 뚜렷이 보이게 만들지만 동시에 언제나 배경 맵의 요소들도 볼 수 있도록 만드는 일입니다. 다음 그림을 기준으로 삼아도 좋습니다.

../../../_images/plots_zoom2_symbology.png

향후 forest_stands_2012 레이어의 녹색 스타일을 사용하게 될 것입니다. 해당 스타일을 유지하면서 수종경계 경계선만 보이도록 하려면,

  • forest_stands_2012 레이어를 오른쪽 클릭한 다음 Duplicate 를 선택하십시오.

  • 새로운 레이어 forest_stands_2012 copy 가 생성되어, 이 레이어에 예를 들어 투명한 면 및 빨간 경계선 등 다른 스타일을 적용할 수 있습니다.

이제 수종경계를 두 가지 서로 다른 스타일로 보여줄 수 있게 되었습니다. 상세지도에 어떤 스타일을 사용할지, 여러분이 선택할 수 있습니다.

작업 중 종종 Print composer 창을 확인해서 지도가 어떻게 보이는지 확인하십시오. 상세지도를 생성하는 목적에 맞춰 삼림 지역 전체가 보이는 축척(다음 오른쪽 그림)이 아니라 더 확대된 축척(다음 왼쪽 그림)에서 괜찮게 보이는 심볼을 찾아 적용해야 합니다. 맵이나 작성자에서 확대/축소할 때마다 Update previewSet to map canvas extent 를 확인해야 한다는 사실을 잊지 마십시오.

../../../_images/composer_2-3.png

14.6.4. basic Try Yourself 기본 맵 템플릿 생성

만족할 만한 심볼을 결정했다면, 인쇄할 맵에 몇 가지 정보를 더 추가할 준비가 된 것입니다. 최소한 다음 요소들은 추가해주십시오.

  • 제목

  • 스케일바

  • 사용자 맵을 위한 격자 테두리

  • 격자 주위의 좌표 표시

여러분은 Module: 맵 생성 강의에서 이미 비슷한 맵을 작성해본 경험이 있습니다. 필요하다면 해당 강의를 복습해보십시오. 다음 그림을 참조해도 좋습니다.

../../../_images/map_template1.png

여러분의 맵을 이미지 파일로 내보내기 한 다음 살펴보십시오.

  • 메뉴에서 Composer ‣ Export as Image 를 클릭합니다.

  • 이번 예제에서는 JPG format 을 사용합니다.

맵을 인쇄하면 바로 이렇게 보일 것입니다.

14.6.5. basic Follow Along: 맵 작성자에 더 많은 요소를 추가하기

예시로 보여드린 맵 템플릿 이미지에서 아마 알아차렸을 테지만, 캔버스 오른쪽에 공간이 많이 남아 있습니다. 이 공간에 어떤 것들을 넣을 수 있는지 알아봅시다. 이번 강의의 목적을 생각하면 범례가 꼭 필요하지는 않지만, 개요(overview) 맵과 텍스트 상자 몇 개를 추가하면 맵이 훨씬 쓸 만해질 것입니다.

현장 팀이 전체 삼림 지역 안에서 상세지도가 어느 곳을 가리키는지 파악하는 데 개요 맵이 도움이 됩니다.

  • 캔버스의 제목 바로 아래에 맵 요소를 하나 더 추가하십시오.

  • Item properties 탭으로 이동, Overview 드롭다운 메뉴를 펼치십시오.

  • Overview frameMap 0 로 설정합니다. 이렇게 하면 상세 맵이 개요 맵 어디에 위치하는지 그 범위를 어두운 사각형으로 표시해줍니다.

  • Frame 옵션의 색상을 검정색으로, Thickness0.30 으로 설정하십시오.

../../../_images/more_elements1.png

지금 개요 맵은 여러분이 바라는 대로 삼림 지역 전체를 보여주고 있지 않습니다. 개요 맵은 삼림 지역 전체를 보여주면서 forest_stands_2012 레이어와 배경 맵만을 표출해야 합니다. 개요 맵에 표본 조사구는 필요없습니다. 또 여러분이 레이어들의 가시성이나 순서를 변경할 때마다 개요 맵이 바뀌지 않도록 개요 맵의 뷰를 고정해야 합니다.

  • 다시 프로젝트의 맵으로 이동하십시오. 이때 Print composer 를 끄면 안 됩니다.

  • forest_stands_2012 레이어를 오른쪽 클릭한 다음 Zoom to Layer Extent 를 클릭하십시오.

  • basic_mapforest_stands_2012 를 제외한 모든 레이어를 끄십시오.

  • 다시 Print composer 로 이동합니다.

  • 개요 맵을 선택한 다음, Set to map canvas extent 를 클릭해서 프로젝트 맵 창에서 볼 수 있는 범위로 설정하십시오.

  • Main properties 아래에 있는 Lock layers for map item 을 클릭해서 개요 맵의 뷰를 고정합니다.

이제 개요 맵이 기대치에 가까워졌고 그 뷰도 더 이상 바뀌지 않을 겁니다. 그러나 또한, 상세 맵에 수종경계 경계선이나 표본 조사구가 보이지 않을 겁니다. 이 문제를 해결하려면,

  • 프로젝트 맵으로 이동해서 상세 맵에 표출하려 하는 레이어들(systematic_plots_clip, forest_stands_2012 copyBasic_map)을 선택하십시오.

  • 다시 표본 조사구의 라인이 서너 개만 보일 때까지 확대하십시오.

  • Print composer 창으로 다시 이동합니다.

  • Select the bigger map in your composer (mActionSelect).
  • Item properties 에서 Update previewSet to map canvas extent 를 클릭하십시오.

상세 맵만 현재 맵 뷰에 보이는 대로 표출되고, 개요 맵은 여러분이 고정한 대로 변하지 않는다는 사실을 잘 기억해두세요.

또한 상세 맵의 범위가 개요 맵에 어두운 사각형으로 표시된다는 것도 기억하세요.

../../../_images/more_elements2.png

템플릿 맵의 준비가 거의 끝났습니다. 맵 하단에 텍스트 상자 두 개를 추가하고, 하나엔 ‘Detailed map zone: ‘ 그리고 다른 하나엔 ‘Remarks: ‘를 입력하십시오. 텍스트 상자를 앞의 그림처럼 배치하세요.

또 개요 맵에 북쪽을 가리키는 화살표를 추가해도 됩니다.

  • Use the Add image tool, mActionAddImage.
  • 개요 맵의 우상단을 클릭하십시오.

  • Item properties 탭으로 이동해서 Search directories 를 선택한 다음 화살표 이미지를 찾으십시오.

  • Image rotation 아래에 있는 Sync with map 체크박스를 체크하고 Map 1 (개요 맵)을 선택하십시오.

  • Background 체크박스를 해제하십시오.

  • 개요 맵에 잘 어울리도록 화살표 이미지의 크기를 조정합니다.

맵 작성자의 기본적인 준비가 끝났습니다. 이제 아틀라스 도구를 통해 이 양식의 상세지도를 필요한 만큼 얼마든지 생성할 수 있습니다.

14.6.6. basic Follow Along: 아틀라스 커버리지 생성

아틀라스 커버리지란 해당 커버리지 안에 있는 모든 피처를 표출 하는 하나의 맵, 상세지도를 생성하는 데 쓰일 벡터 레이어일 뿐입니다. 다음 단계가 어떤 작업일지 알고 싶다면, 삼림 지역에 대한 모든 상세지도를 모아놓은 다음 그림을 살펴보십시오.

../../../_images/preview_atlas_results.png

어떤 기존 레이어도 커버리지가 될 수 있지만, 이 특정한 목적을 위한 새 레이어를 생성하는 편이 더 합당할 것입니다. 삼림 지역을 커버하는 폴리곤 그리드를 생성해봅시다.

  • QGIS 맵뷰의 메뉴에서 Vector ‣ Research Tools ‣ Vector grid 를 선택합니다.

  • 다음 그림처럼 도구를 설정하십시오.

../../../_images/coverage_polygons.png
  • 산출물을 atlas_coverage.shp 라는 이름으로 저장하십시오.

  • 폴리곤의 면이 투명하도록 새로 만든 atlas_coverage 레이어의 스타일을 변경하십시오.

새로운 폴리곤들은 삼림 지역 전체를 커버하며, (각 폴리곤으로부터 생성된) 각각의 상세지도가 어떤 내용을 담게 될지 알 수 있습니다.

../../../_images/atlas_coverage.png

14.6.7. basic Follow Along: 아틀라스 도구 설정

마지막 단계는 아틀라스 도구를 설정하는 것입니다.

  • Print Composer 로 이동합니다.

  • 오른쪽 패널에 있는 Atlas generation 탭을 선택합니다.

  • 다음과 같이 옵션을 설정하십시오.

../../../_images/atlas_settings.png

이렇게 하면 아틀라스 도구가 atlas_coverage 레이어 안에 있는 피처(폴리곤들)를 모든 상세지도의 맵 범위로 이용하게 됩니다. 레이어의 각 피처가 상세지도 하나를 산출할 것입니다. Hidden coverage layer 옵션은 산출된 맵에 폴리곤을 보이지 않게 하는 역할을 합니다.

한 가지 더 해야 할 일이 있습니다. 모든 상세지도에 어떤 맵 요소를 업데이트할지 아틀라스 도구를 설정해야 합니다. 지금쯤이면 캔버스에서 더 상위 요소인 표본 조사구의 상세 뷰를 담도록 여러분이 준비해온 맵이 각 폴리곤에 따라 업데이트돼야 한다는 사실을 알 수 있을 겁니다.

  • 상위 맵 요소를 선택해봅시다.

  • Item properties 탭으로 이동합니다.

  • 목록에서 Controlled by atlas 체크박스를 체크합니다.

  • Marging around feature 옵션을 10% 로 설정하십시오. 뷰의 범위가 폴리곤보다 10% 넓어집니다. 즉 상세 맵들이 10%씩 겹치게 된다는 뜻입니다.

../../../_images/controlled_by_atlas.png

이제 아틀라스 맵에 대해 미리보기 도구를 사용해서 여러분의 맵이 어떻게 보일지 살펴볼 수 있습니다.

  • Activate the Atlas previews using the button mIconAtlas or if your Atlas toolbar is not visible, via Atlas ‣ Preview Atlas.
  • 아틀라스 툴바 또는 Atlas 메뉴의 화살표를 이용해서 생성될 맵을 둘러볼 수 있습니다.

일부 생성될 맵이 커버하는 지역이 관심 지역이 아니라는 사실을 알 수 있습니다. 쓸모없는 맵을 인쇄하여 나무 몇 그루를 낭비하지 않도록 조치를 취해봅시다.

14.6.8. basic Follow Along: 커버리지 레이어 편집

관심 지역이 아닌 지역의 폴리곤을 제거하는 작업 외에도, 여러분의 맵 안에 있는 텍스트 라벨을 사용자 지정해서 커버리지 레이어의 Attribute table 안의 내용으로 생성할 수 있습니다.

  • 맵뷰로 다시 이동하십시오.

  • atlas_coverage 레이어의 편집 모드를 활성화하십시오.

  • 다음 그림에서 (노랑색으로) 선택된 폴리곤들을 선택하십시오.

  • 선택한 폴리곤들을 제거합니다.

  • 편집 모드를 해제하고 변경 사항을 저장하십시오.

../../../_images/remove_polygons.png

Print Composer 로 다시 이동해서 아틀라스 미리보기에 여러분이 레이어에 남겨둔 폴리곤 범위만 표출되는지 확인하십시오.

현재 사용 중인 커버리지 레이어는 상세 맵의 라벨 내용으로 사용자 지정할 수 있는 쓸모 있는 정보를 담고 있지 않습니다. 그런 정보를 생성하는 첫 번째 단계로, 예를 들어 폴리곤 지역의 구역 번호와 현장 팀이 고려해야 할 의견을 담은 항목을 추가할 수 있을 것입니다.

  • atlas_coverage 레이어의 Attribute table 을 여십시오.

  • 편집 모드를 활성화합니다.

  • Use the mActionCalculateField calculator to create and populate the following two fields.
  • Whole number (integer) 유형으로 Zone 이라는 명칭을 가진 항목을 생성하십시오.

  • Expression 란에 표현식 $rownum 을 입력/복사/구성하십시오.

  • 255 길이의 Text (string) 유형으로 Remarks 라는 명칭을 가진 항목을 생성하십시오.

  • Expression 란에 'No remarks.' 라고 입력하십시오. 모든 폴리곤에 대한 기본값으로 설정될 것입니다.

삼림 관리자는 해당 지역 방문 시 유용할 수도 있는 정보를 가지고 있을 겁니다. 예를 들면 다리, 늪의 존재 여부나 보호종의 서식지 위치 등을 말입니다. atlas_coverage 레이어가 편집 모드인지 확인한 다음, 각각의 폴리곤의 Remarks 항목에 다음 텍스트를 입력(편집하려면 해당 셀을 더블클릭)하십시오.

  • Zone 2 : Bridge to the North of plot 19. Siberian squirrel between p_13 and p_14.

  • Zone 6 : Difficult to transit in swamp to the North of the lake.

  • Zone 7 : Siberian squirrel to the South East of p_94.

  • 편집 모드를 해제하고 변경 사항을 저장하십시오.

준비가 거의 끝났습니다. 이제 atlas_coverage 레이어의 속성 테이블에 담긴 정보를 이용해서 텍스트 라벨을 표출하도록 아틀라스 도구를 설정해야 합니다.

  • Print Composer 로 이동합니다.

  • Detailed map... 텍스트 라벨을 선택하십시오.

  • Font 크기를 12 로 설정합니다.

  • 라벨 안의 텍스트 끝부분에 커서를 위치시킵니다.

  • Item properties 탭으로 이동, Main properties 안에 있는 Insert an expression 을 클릭하십시오.

  • Function list 에서 Field and Values 아래에 있는 Zone 항목을 더블클릭하십시오.

  • OK 를 클릭하십시오.

  • Item properties 에 있는 상자 안의 텍스트가 Detail map inventory zone: [% "Zone" %] 으로 보일 겁니다. 이때 [% "Zone" %] 부분이 atlas_coverage 레이어에서 대응하는 피처의 Zone 항목의 값으로 대체되는지 확인하세요.

각각의 아틀라스 미리보기를 살펴 라벨의 내용이 제대로 표출되는지 확인하십시오.

구역 정보가 담긴 항목을 통해 Remarks: 텍스트에 동일한 라벨 작업을 하십시오. 표현식을 입력하기 전에 행바꿈을 남길 수도 있습니다. 다음 그림은 이 작업을 마친 구역 2의 미리보기입니다.

../../../_images/preview_zone2.png

이제 곧 인쇄에 들어갈 맵들을 아틀라스 미리보기를 통해 살펴보세요.

14.6.9. basic Follow Along: 지도 인쇄

마지막으로 여러분의 지도를 이미지 또는 PDF 파일로 인쇄 또는 내보내기할 차례입니다. Atlas ‣ Export Atlas as Images... 메뉴 또는 Atlas ‣ Export Atlas as PDF... 메뉴를 이용하면 됩니다. 현재 버전에서 SVG 형식으로 내보내기 기능은 제대로 동작하지 않아 좋은 산출물을 얻기 힘듭니다.

맵들을 현장 사무소에 보내 인쇄하게 할 수 있는 PDF 파일 하나로 출력해봅시다.

  • 오른쪽 패널에 있는 Atlas generation 탭으로 이동합니다.

  • Output 아래에 있는 Single file export when possible 체크박스를 체크하십시오. 모든 맵을 하나의 PDF 파일로 출력합니다. 이 옵션이 해제된 경우, 맵 하나마다 PDF 파일 하나씩 출력됩니다.

  • Composer ‣ Export as PDF... 메뉴를 실행하십시오.

  • exercise_data\forestry\samplig\map_creation\ 폴더에 파일명 inventory_2012_maps.pdf 로 PDF 파일을 저장하십시오.

모든 작업이 제대로 됐는지 PDF 파일을 열어 확인해보십시오.

모든 맵을 개별 이미지로 쉽게 출력할 수 있습니다. (파일 하나로 생성 옵션을 해제하면 됩니다.) 다음은 그렇게 출력한 이미지의 썸네일들입니다.

../../../_images/maps_as_images.png

Print Composer 에서 exercise_data\forestry\map_creation\ 폴더에 여러분의 맵을 맵 작성자 템플릿 forestry_atlas.qpt 로 저장하십시오. Composer ‣ Save as Template 메뉴를 이용하세요. 이렇게 저장한 템플릿은 두고두고 다시 사용할 수 있습니다.

Print Composer 창을 닫고 QGIS 프로젝트를 저장하십시오.

14.6.10. In Conclusion

여러분은 현장에서 여러 곳의 표본 조사구를 찾아가는 데 쓰일 상세지도를 자동적으로 생성할 수 있는 맵 템플릿을 생성했습니다. 여러분도 경험했듯이 쉬운 작업은 아니었지만, 이렇게 저장한 템플릿은 향후 여러분이 다른 지역의 유사한 지도를 생성해야 할 때 큰 도움이 될 겁니다.

14.6.11. What’s Next?

다음 강의에서는 LiDAR 데이터를 이용해서 DEM을 생성하는 방법과, DEM을 통해 여러분의 데이터와 맵의 시인성을 향상시키는 방법을 배울 것입니다.