Outdated version of the documentation. Find the latest one here.

.

QGIS Configuration

QGIS is highly configurable through the Settings menu. Choose between Panels, Toolbars, Project Properties, Options and Customization.

Catatan

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described above could be located in the View menu (Panels and Toolbars) or in Project for Options.

Panels and Toolbars

In the Panels‣ menu, you can switch on and off QGIS widgets. The Toolbars‣ menu provides the possibility to switch on and off icon groups in the QGIS toolbar (see figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

The Panels and Toolbars menu nix

Tip

Activating the QGIS Overview

In QGIS, you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu nix Settings ‣ Panels or win View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Tip

Show Log Messages

It’s possible to track the QGIS messages. You can activate checkbox Log Messages in the menu nix Settings ‣ Panels or win View ‣ Panels and follow the messages that appear in the different tabs during loading and operation.

Properti Proyek

In the properties window for the project under nix Settings ‣ Project Properties (kde) or nix win Project ‣ Project Properties (Gnome), you can set project-specific options. These include:

  • In the General menu, the project title, selection and background color, layer units, precision, and the option to save relative paths to layers can be defined. If the CRS transformation is on, you can choose an ellipsoid for distance calculations. You can define the canvas units (only used when CRS transformation is disabled) and the precision of decimal places to use. You can also define a project scale list, which overrides the global predefined scales.
  • Menu CRS memungkinkan Anda untuk memilih Coordinat Reference System untuk proyek ini, dan memungkinkan proyeksi ulang on-the-fly lapisan raster dan lapisan vektor ketika menampilkan lapisan dari CRS yang berbeda.

  • With the third Identify layers menu, you set (or disable) which layers will respond to the identify tool (see the “Map tools” paragraph from the Opsi section to enable identifying of multiple layers).
  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.
  • The tab OWS Server allows you to define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions.
  • Menu Macros digunakan untuk mengedit Python macros untuk proyek. Saat ini, hanya tiga macro yang tersedia: openProject(), saveProject() dan closeProject().

Figure Macro Menu:

../../../_images/macro.png

Macro settings in QGIS

  • Menu Relasi digunakan untuk menentukan relasi 1:n. Relasi ditentukan dalam dialog properti proyek. Setelah ada relasi lapisan, elemen antarmuka pengguna baru form tampilan (misalnya ketika mengidentifikasi fitur dan membuka form) akan daftar entitas terkait. Ini menyediakan cara ampuh mengekspresikan misalnya sejarah inspeksi pada panjang pipa atau segmen jalan. Anda bisa menemukan lebih jauh tentang relasi 1:n di Bagian Creating one to many relations.

Opsi

mActionOptions Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ mActionOptions Options. The tabs where you can customize your options are described below.

Menu Umum

Aplikasi

  • Select the Style (QGIS restart required) selectstring and choose between ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlooks’ (nix).
  • Define the Icon theme selectstring. Currently only ‘default’ is possible.
  • Define the Icon size selectstring.
  • Define the Font. Choose between radiobuttonon Qt default and a user-defined font.
  • Change the Timeout for timed messages or dialogs selectstring.
  • checkbox Sembunyikan layar splash saat startup

  • checkbox Tampilkan Petunjuk saat startup

  • checkbox Judul tebal kotak grup

  • checkbox QGIS-styled kotak grup

  • checkbox Use native color chooser dialogs
  • checkbox Use live-updating color chooser dialogs
  • checkbox Custom side bar style
  • checkbox Experimental canvas rotation support (restart required)

Berkas proyek

  • Open project on launch selectstring (choose between ‘New’, ‘Most recent’ and ‘Specific’). When choosing ‘Specific’ use the browsebutton to define a project.
  • checkbox Buat proyek baru dari proyek default. Anda memiliki kemungkinan untuk menekan Atur proyek sekarang sebagai default atau pada Reset default. Anda dapat menelusuri melalui berkas-berkas dan menentukan direktori dimana Anda menemukan pengguna-ditetapkan proyek template Anda. Akan ada sebuah entri di Project ‣ Baru dari Template jika Anda pertama kali mengaktifkan checkbox Buat proyek baru dari proyek default dan kemudian simpan proyek dalam folder proyek template.

  • checkbox Prompt untuk menyimpan proyek dan sumber data perubahan bila diperlukan

  • checkbox Prompt for confirmation when a layer is to be removed
  • checkbox Peringatkan ketika membuka berkas proyek QGIS yang disimpan dengan versi lama

  • Enable macros selectstring. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

Menu Sistem

Lingkungan

Sistem lingkungan variabel saat ini dapat dilihat dan banyak dikonfigurasi dalam menu Lingkungan (lihat figure_environment_variables). Hal ini berguna untuk platform, seperti Mac, di mana aplikasi GUI tidak selalu mewarisi lingkungan shell pengguna. Ini juga berguna untuk pengaturan / melihat lingkungan variabel untuk mengatur alat eksternal yang dikendalikan oleh pengolahan toolbox (seperti SAGA, GRASS), dan untuk menyalakan keluaran debugging untuk bagian tertentu dari kode sumber.

  • checkbox Gunakan penyesuaian variabel (dibutuhkan restart - termasuk pemisah). Anda bisa [Tambah] dan [Hapus] variabel. Variabel lingkungan yang sudah ditetapkan akan ditampilkan dalam:guilabel:Variabel lingkungan sekarang, dan hal itu memungkinkan untuk menyaring mereka dengan mengaktifkan checkbox Tampilkan hanya variabel spesifik-QGIS.

Figure System Environment:

../../../_images/sys-env-options.png

System environment variables in QGIS

Plugin path

[Tambah] atau [Hapus] Path(s) untuk mencari tambahan C++ librari Plugin

Menu sumber data

Atribut dan tabel fitur

  • checkbox Buka tabel atribut di dock window (dibutuhkan restart QGIS)

  • checkbox Copy geometry in WKT representation from attribute table. When using mActionCopySelected Copy selected rows to clipboard from the Attribute table dialog, this has the result that the coordinates of points or vertices are also copied to the clipboard.
  • Attribute table behaviour selectstring. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Attribute table row cache selectnumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representasi untuk nilai NULL Here you can define a value for data fields containing a NULL value. Di sini Anda dapat menentukan nilai untuk bidang data yang berisi nilai NULL.

Menangani sumber data

  • Scan for valid items in the browser dock selectstring. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compressed files (.zip) in browser dock selectstring. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Konfirmasi sublapisan raster saat membuka. Beberapa raster mendukung sublapisan – mereka disebut subdataset di GDAL. Contohnya adalah berkas netCDF - jika ada banyak variabel netCDF, GDAL melihat setiap variabel sebagai sub dataset. Pilihan ini untuk mengontrol bagaimana menangani sub-lapisan ketika sebuah berkas dengan sub-lapisan dibuka. Anda memiliki pilihan berikut:

    • ‘Selalu’: Selalu bertanya (jika ada sub-lapisan yang ada)

    • ‘Jika diperlukan’: Menanyakan apakah lapisan tidak memiliki band, namun memiliki sub-lapisan

    • ‘Tidak Pernah’: Tidak pernah meminta, tidak akan memuat apa-apa

    • ‘Muat semua’: Tidak pernah meminta, tetapi memuat semua sub-lapisan

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Add PostGIS layers with double click and select in extended mode
  • checkbox Tambahkan lapisan Oracle with dobel klik dan pilih dalam mode diperpanjang

Menu Rendering

Rendering behaviour

  • checkbox Secara default lapisan baru yang ditambahkan ke peta harus ditampilkan

  • checkbox Gunakan render caching yang memungkinkan mempercepat gambar ulang

  • checkbox Render layers in parallel using many CPU cores
  • checkbox Max cores to use
  • Map update interval (default to 250 ms)
  • checkbox Enable feature simplication by default for newly added layers
  • Simplification threshold
  • checkbox Sederhanakan di sisi penyedia jika mungkin

  • Maximum scale at which the layer should be simplified

Kualitas rendering

  • checkbox Membuat garis tampil kurang bagus dengan mengorbankan beberapa kinerja menggambar

Raster-raster

  • Dengan RGB band seleksi Anda bisa menetapkan nomor dari band Merah, Hijau dan Biru.

Contrast enhancement

  • Single band gray selectstring. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectstring. Options are ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’.
  • Kumulatif batas jumlah potong pixel

  • Standar deviasi multiplier

Debugging

  • checkbox Refresh kanvas peta

Colors Menu

This menu allows you to add some custom color that you can find in each color dialog window of the renderers. You will see a set of predefined colors in the tab: you can delete or edit all of them. Moreover you can add the color you want and perform some copy and paste operations. Finally you can export the color set as a gpl file or import them.

Menu Kanvas dan Legenda

Standar penampilan peta (diganti oleh proyek properti)

  • Tetapkan Seleksi warna dan Warna latar.

Legenda lapisan

  • Double click action in legend selectstring. You can either ‘Open layer properties’ or ‘Open attribute table’ with the double click.
  • Mengikuti Gaya item legenda:

    • checkbox Nama lapisan kapital

    • checkbox Nama lapisan tebal

    • checkbox Nama grup tebal

    • checkbox Tampilkan klasifikasi nama atribut

    • checkbox Buat ikon raster (mungkin lambat)

Menu perangkat Peta

This menu offers some options regarding the behaviour of the Identify tool.

  • Search radius for identifying and displaying map tips is a tolerance factor expressed as a percentage of the map width. This means the identify tool will depict results as long as you click within this tolerance.
  • Highlight color allows you to choose with which color should features being identified are to be highlighted.
  • Buffer expressed as a percentage of the map width, determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width expressed as a percentage of the map width, determines how thick should the outline of a highlighted object be.

Alat pengukuran

  • Tentukan Warna Rubberband untuk peralatan pengukuran

  • Tentukan Tempat desimal

  • checkbox Keep base unit
  • Preferred measurements units radiobuttonon (‘Meters’, ‘Feet’, ‘Nautical Miles’ or ‘Degrees’)`
  • Preferred angle units radiobuttonon (‘Degrees’, ‘Radians’ or ‘Gon’)

Menggeser dan memperbesar

  • Define Mouse wheel action selectstring (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Tentukan Faktor pembesaran untuk roda tetikus

Skala yang ditentukan

Here, you find a list of predefined scales. With the [+] and [-] buttons you can add or remove your individual scales.

Menu Penyusun

Standar Komposisi

You can define the Default font here.

Penampilan Kotak

  • Define the Grid style selectstring (‘Solid’, ‘Dots’, ‘Crosses’)
  • Define the Grid color

Grid and guide defaults

  • Define the Grid spacing selectnumber
  • Define the Grid offset selectnumber for x and y
  • Define the Snap tolerance selectnumber

Menu Digitalisasi

Membuat fitur

  • checkbox Menekan atribut jendela pop-up setelah setiap fitur dibuat

  • checkbox Gunakan kembali nilai atribut terakhir yang dimasukkan

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Rubberband

  • Tentukan Rubberband Lebar garis dan Warna garis

Snapping

  • checkbox Buka opsi mengambil di dock window (dibutuhkan restart QGIS)

  • Define Default snap mode selectstring (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Tentukan Default toleransi snapping dalam satuan peta atau pixel

  • Tentukan Cari radius untuk suntingan simpul dalam satuan peta atau pixel

Penanda simpul

  • checkbox Tampilkan penanda hanya untk fitur yang dipilih

  • Define vertex Marker style selectstring (‘Cross’ (default), ‘Semi transparent circle’ or ‘None’)
  • Tentukan simpul Ukuran Penanda

Alat ofset kurva

The next 3 options refer to the mActionOffsetCurve Offset Curve tool in Advanced digitizing. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Gaya Join

  • Segmen Quadrant

  • Batas Miter

Menu GDAL

GDAL adalah data pertukaran librari untuk berkas raster. Dalam tab ini Anda dapat Edit membuat opsi dan Edit Opsi Pyramid dari format raster. Menentukan driver GDAL yang akan digunakan untuk format raster seperti dalam beberapa kasus lebih dari satu driver GDAL tersedia.

Menu CRS

CRS standar untuk proyek baru

  • radiobuttonoff Don’t enable ‘on the fly’ reprojection
  • radiobuttonon Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radiobuttonoff Enable ‘on the fly’ reprojection by default
  • Pilih sebuah CRS dan Selalui mulai proyek baru dengan CRS ini

CRS untuk lapisan baru

Daerah ini memungkinkan untuk menentukan tindakan ketika sebuah lapisan baru dibuat, atau ketika lapisan tanpa CRS dimuat.

  • radiobuttonon Prompt for CRS
  • radiobuttonoff Use project CRS
  • radiobuttonoff Use default CRS

Transformasi datum standar

  • checkbox Mintalah transformasi datum bila tidak ada standar yang ditentukan

  • Jika Anda telah bekerja dengan transformasi CRS ‘on-the-fly’ Anda bisa melihat hasil dari transformasi dalam jendela di bawah. Anda bisa menemukan informasi tentang ‘Sumber CRS’ dan ‘Destinasi CRS’ maupun ‘Sumber datum transform’ dan ‘Destinasi datum transform’.

Menu Lokal

  • checkbox Timpah sistem lokal dan Lokal gunakan sebagai pengganti

  • Informasi tentang sistem lokal aktif

Menu Jaringan

Umum

  • Tentukan WMS cari alamat, default http://geopole.org/wms/search?search=\%1\&type=rss

  • Tentukan Timeout untuk permintaan jaringan (ms) - default 60000

  • Tentukan Standar periode ekspirasi untuk WMSC/WMTS (jam) - default 24

  • Tentukan Mencoba kembali Maksimum jika terjadi kesalahan permintaan genteng

  • Tentukan User-Agent

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

Pengaturan cache

Tentukan Direktori dan Ukuran untuk cache.

  • checkbox Gunakan proxy untuk akses web dan tentukan ‘Host’, ‘Port’, ‘Pengguna’, and ‘Kata Sandi’.

  • Set the Proxy type selectstring according to your needs.
    • Proxy Standar: Proxy ditentukan berdasarkan aplikasi pengaturan menggunakan proxy

    • Socks5Proxy: Proxy generik untuk setiap jenis koneksi. Mendukung TCP, UDP, mengikat ke port (koneksi masuk) dan otentikasi.

    • HttpProxy: Menggunakan perintah “CONNECT”, mendukung hanya koneksi TCP; mendukung otentikasi.

    • HttpCachingProxy: Menggunakan perintah normal HTTP, itu hanya berguna dalam konteks permintaan HTTP.

    • FtpCachingProxy: Menggunakan proxy FTP, itu hanya berguna dalam konteks permintaan FTP.

Tidak termasuk beberapa URL dapat ditambahkan ke kotak teks di bawah pengaturan-proxy (lihat Figure_Network_Tab).

Jika Anda membutuhkan informasi lebih rinci tentang pengaturan-proxy yang berbeda, silakan lihat panduan QT-librari-dokumentasi di http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Tip

Menggunakan Proxi

Menggunakan proxi kadang-kadang bisa rumit. Hal ini berguna ‘coba dan eror’ jenis proxi di atas, untuk memeriksa apakah mereka berhasil dalam kasus Anda.

You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

  • nix Settings are saved in a text file: $HOME/.config/QGIS/QGIS2.conf
  • osx Anda dapat menemukan pengaturan Anda di: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win pengaturan terkirim ke registri: HKEY\CURRENT_USER\Software\QGIS\qgis

Penyesuaian (Customization)

The customization tool lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you have a lot of plugins installed that you never use and that are filling your screen.

Figure Customization 1:

../../../_images/customization.png

The Customization dialog nix

QGIS Customization is divided into five groups. In checkbox Menus, you can hide entries in the Menu bar. In checkbox Panels, you find the panel windows. Panel windows are applications that can be started and used as a floating, top-level window or embedded to the QGIS main window as a docked widget (see also Panels and Toolbars). In the checkbox Status Bar, features like the coordinate information can be deactivated. In checkbox Toolbars, you can (de)activate the toolbar icons of QGIS, and in checkbox Widgets, you can (de)activate dialogs as well as their buttons.

With mActionSelect Switch to catching widgets in main application, you can click on elements in QGIS that you want to be hidden and find the corresponding entry in Customization (see figure_customization). You can also save your various setups for different use cases as well. Before your changes are applied, you need to restart QGIS.