Outdated version of the documentation. Find the latest one here.

.

QGIS Configuration

QGIS is highly configurable through the Settings menu. Choose between Panels, Toolbars, Project Properties, Options and Customization.

Note

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described above could be located in the View menu (Panels and Toolbars) or in Project for Options.

Panels and Toolbars

In the Panels‣ menu, you can switch on and off QGIS widgets. The Toolbars‣ menu provides the possibility to switch on and off icon groups in the QGIS toolbar (see figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

The Panels and Toolbars menu nix

Astuce

Activating the QGIS Overview

In QGIS, you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu nix Settings ‣ Panels or win View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Astuce

Show Log Messages

It’s possible to track the QGIS messages. You can activate checkbox Log Messages in the menu nix Settings ‣ Panels or win View ‣ Panels and follow the messages that appear in the different tabs during loading and operation.

Propriétés du projet

In the properties window for the project under nix Settings ‣ Project Properties (kde) or nix win Project ‣ Project Properties (Gnome), you can set project-specific options. These include:

  • In the General menu, the project title, selection and background color, layer units, precision, and the option to save relative paths to layers can be defined. If the CRS transformation is on, you can choose an ellipsoid for distance calculations. You can define the canvas units (only used when CRS transformation is disabled) and the precision of decimal places to use. You can also define a project scale list, which overrides the global predefined scales.
  • Le menu SCR vous permet de choisir le Système de Coordonnées de Référence pour le projet et d’activer la projection à la volée des couches raster et vecteur définies dans un SCR différent.

  • With the third Identify layers menu, you set (or disable) which layers will respond to the identify tool (see the “Map tools” paragraph from the Options section to enable identifying of multiple layers).
  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.
  • The tab OWS Server allows you to define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions.
  • Le menu Macros permet d’éditer des modules Python pour les projets. Actuellement, seules trois macros sont disponibles : openProject(), saveProject() et closeProject().

Figure Macro Menu:

../../../_images/macro.png

Macro settings in QGIS

  • L’onglet Relations permet de définir des relations 1:n. Les relations sont définies dans la fenêtre des propriétés du projet. Une fois les relations définies sur une couche, un nouvel élément apparaît dans la vue formulaire de cette couche (par exemple, lors de l’identification d’une entité et l’ouverture du formulaire associé) et vous liste les entités qui lui sont reliées. Ceci fournit un moyen puissant d’exprimer, par exemple, l’historique d’inspection le long d’une pipeline ou d’un tronçon de route. Vous trouverez de plus amples informations sur les relation 1:n dans la section Creating one to many relations.

Options

mActionOptions Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ mActionOptions Options. The tabs where you can customize your options are described below.

Onglet Général

Application

  • Select the Style (QGIS restart required) selectstring and choose between ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlooks’ (nix).
  • Define the Icon theme selectstring. Currently only ‘default’ is possible.
  • Define the Icon size selectstring.
  • Define the Font. Choose between radiobuttonon Qt default and a user-defined font.
  • Change the Timeout for timed messages or dialogs selectstring.
  • checkbox Cacher l’écran de démarrage

  • checkbox Montrer les astuces au démarrage

  • checkbox Titre des groupes de couches en gras

  • checkbox Style QGIS pour les groupes de couches

  • checkbox Utiliser les fenêtres natives de choix de couleur

  • checkbox Fenêtres de choix de couleur avec mise à jour dynamique

  • checkbox Style personnalisé de la barre latérale

  • checkbox Rotation du canevas de la carte (expérimental, redémarrage requis)

Fichiers projet

  • Open project on launch selectstring (choose between ‘New’, ‘Most recent’ and ‘Specific’). When choosing ‘Specific’ use the browsebutton to define a project.
  • checkbox Créer les nouveaux projets à partir du projet par défaut. Vous pouvez choisir d’Utiliser le projet courant comme défaut ou de Réinitialiser le projet par défaut. Vous pouvez parcourir vos fichiers et sélectionner le répertoire où sont stockés vos modèles de projets personnalisés. Cela créera une nouvelle entrée dans le menu Projet ‣ Nouveau depuis un modèle si vous cochez checkbox Créer les nouveaux projets à partir du projet par défaut et sauvegardez un projet dans le répertoire de modèles de projets spécifié.

  • checkbox Demander de sauver le projet et les sources de données quand nécessaire

  • checkbox Demander une confirmation lorsqu’une couche va être supprimée

  • checkbox M’avertir lors de l’ouverture d’un fichier projet sauvegardé avec une version précédente de QGIS

  • Enable macros selectstring. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

Menu Système

Environnement

Les variables d’environnement Système peuvent maintenant être visualisées et configurées pour certains dans le groupe Environnement (voir figure_environment_variables). Ceci est pratique sur certaines plateformes, notamment sur Mac, ou une application avec interface graphique n’hérite pas nécessairement des paramètres de l’environnement en ligne de commande de l’utilisateur. Ceci est aussi utile pour paramétrer/visualiser les variables d’environnement des outils externes contrôlés par la boîte à outils de traitement (par exemple SAGA, GRASS) et activer les sorties de débogage pour des sections spécifiques du code source.

  • checkbox Utiliser des variables personnalisées (redémarrage requis - inclure des séparateurs). Vous pouvez [Ajouter] et [Supprimer] des variables. Les variables d’environnement déjà définies sont affichées dans Variables d’environnement courantes, et il est possible de les filtrer en activant checkbox Afficher uniquement les variables liées à QGIS.

Figure System Environment:

../../../_images/sys-env-options.png

System environment variables in QGIS

Chemins vers les extensions

[Ajouter] ou [Supprimer] un ou des Chemin(s) vers des extensions C++ supplémentaires

Onglet Sources de données

Attributs et tables

  • checkbox Ouvrir la table d’attributs dans une fenêtre intégrée (redémarrage requis)

  • checkbox Copy geometry in WKT representation from attribute table. When using mActionCopySelected Copy selected rows to clipboard from the Attribute table dialog, this has the result that the coordinates of points or vertices are also copied to the clipboard.
  • Attribute table behaviour selectstring. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Attribute table row cache selectnumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Représentation des valeurs NULL permet de définir une valeur par défaut pour les champs contenant la valeur NULL.

Gestion des sources de données

  • Scan for valid items in the browser dock selectstring. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compressed files (.zip) in browser dock selectstring. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Demande à l’ouverture s’il y a des sous-couches raster. Certains rasters comportent des sous-couches - appelées sous-jeux de données dans GDAL. Par exemple les fichiers netCDF - s’il y a de nombreuses variables netCDF, GDAL considérera chaque variable comme un sous-jeux de données. L’option vous permet de choisir comment traiter les sous-jeux de données quand un fichier avec des sous-couches est ouvert. Vous avez les choix suivants :

    • ‘Toujours’ : Demande toujours (s’il existe des sous-couches)

    • ‘Si nécessaire’ : Demande si la couche n’a pas de bande, mais qu’elle possède des sous-couches

    • ‘Jamais’ : Ne demande jamais, mais ne charge rien

    • ‘Charger tout’ : Ne demande jamais, mais charge toutes les sous-couches

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Ajouter des couches PostGIS avec un double-clic et sélectionner en mode étendu

  • checkbox Ajouter les couches Oracle par double-clic et sélection en mode étendu

Onglet Rendu

Rendering behaviour

  • checkbox Par défaut les couches supplémentaires sont affichées

  • checkbox Utiliser le cache du rendu si possible pour accélérer l’affichage

  • checkbox Rendu des couches en parallèle en utilisant plusieurs cœurs du processeur

  • checkbox Nombre de cœurs à utiliser

  • Intervalle de rafraîchissement de l’affichage de la carte (par défaut de 250 ms)

  • checkbox Enable feature simplication by default for newly added layers
  • Seuil de simplification

  • checkbox Réaliser la simplification par le prestataire de service lorsque c’est possible

  • Échelle maximale à partir de laquelle la couche doit être simplifiée

Qualité du rendu

  • checkbox Les lignes semblent moins déchiquetées aux dépends d’une certaine vitesse d’exécution

Rasters

  • Avec la Sélection de bande RVB, vous pouvez définir la valeur des bandes Rouge, Verte et Bleue.

Amélioration du contraste

  • Single band gray selectstring. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectstring. Options are ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’.
  • Limite de découpe pour le comptage cumulé de pixels

  • Multiplicateur de l’écart-type

Déboggage

  • checkbox Actualisation de la carte

Onglet couleurs

Cet onglet vous permet d’ajouter des couleurs personnalisées supplémentaires que vous pouvez trouver dans chaque fenêtre de dialogue des rendus de couleur. Vous verrez un jeu de couleurs prédéfinies dans l’onglet : vous pouvez supprimer ou éditer chacune d’entre elles. Vous pouvez également ajouter la couleur que vous voulez et effectuer une opération de copier-coller. Finalement, vous pouvez importer ou exporter un jeu de couleurs comme fichier gpl.

Onglet Carte et légende

Apparence de la carte par défaut (écrasée par les propriétés du projet si définies)

  • Définir la Couleur de la sélection et la Couleur de fond.

Légende des couches

  • Double click action in legend selectstring. You can either ‘Open layer properties’ or ‘Open attribute table’ with the double click.
  • Les Styles des objets de la légende peuvent être :

    • checkbox Noms de couches en majuscules

    • checkbox Noms de couches en gras

    • checkbox Noms de groupes de couches en gras

    • checkbox Afficher le nom du champ de classification

    • checkbox Créer des icônes raster dans la légende (lent)

Onglet Outils cartographiques

This menu offers some options regarding the behaviour of the Identify tool.

  • Rayon de recherche pour identifier les entités et afficher les infobulles est un facteur de tolérance exprimé comme un pourcentage de la largeur de la carte. Cela signifie que l’outil identifier illustrera les résultats tant que vous cliquez à l’intérieur de cette tolérance.

  • Couleur de surbrillance vous permet de choisir avec quelle couleur les entités qui devraient être identifiées sont en surbrillance.

  • Buffer expressed as a percentage of the map width, determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width expressed as a percentage of the map width, determines how thick should the outline of a highlighted object be.

Outils de mesure

  • Définir la Couleur du trait des outils de mesure

  • Définir le Nombre de décimales

  • checkbox Keep base unit
  • Preferred measurements units radiobuttonon (‘Meters’, ‘Feet’, ‘Nautical Miles’ or ‘Degrees’)`
  • Preferred angle units radiobuttonon (‘Degrees’, ‘Radians’ or ‘Gon’)

Déplacement et zoom

  • Define Mouse wheel action selectstring (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Définir le Facteur de zoom pour la molette de la souris

Échelles prédéfinies

Here, you find a list of predefined scales. With the [+] and [-] buttons you can add or remove your individual scales.

Onglet Composeur d’impression

Valeurs par défaut pour les compositions

Vous pouvez définir une Police par défaut ici.

Apparence de la grille

  • Define the Grid style selectstring (‘Solid’, ‘Dots’, ‘Crosses’)
  • Définir la Couleur de la grille

Grille et guide par défaut

  • Define the Grid spacing selectnumber
  • Define the Grid offset selectnumber for x and y
  • Define the Snap tolerance selectnumber

Onglet Numérisation

Création d’entités

  • checkbox Supprimer les fenêtres d’avertissements lors de la création de chaque entité

  • checkbox Réutiliser la dernière valeur attributaire saisie

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Contours d’édition

  • Définissez la Largeur de ligne et la Couleur de ligne du trait lors de l’édition.

Accrochage

  • checkbox Ouvrir les options d’accrochage dans une fenêtre intégrée (redémarrage de QGIS requis)

  • Define Default snap mode selectstring (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Définir Tolérance d’accrochage par défaut en unités de carte ou en pixels

  • Définir le Rayon de recherche pour l’édition des sommets en unités de carte ou en pixels

Symbole des sommets

  • checkbox Montrer les symboles uniquement pour les entités sélectionnées

  • Define vertex Marker style selectstring (‘Cross’ (default), ‘Semi transparent circle’ or ‘None’)
  • Définir la Taille du marqueur des sommets

Outil de décalage de courbe

The next 3 options refer to the mActionOffsetCurve Offset Curve tool in Numérisation avancée. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Style de jointure

  • Segments de quadrant

  • Limite de la pointe

Onglet GDAL

GDAL est une bibliothèque qui permet de gérer les fichiers raster. Dans cet onglet, vous pouvez Modifier les options des pyramides et Modifier les options de création des différents formats raster ainsi que définir quel pilote GDAL utiliser dans le cas où plus d’un est disponible.

Onglet SCR

SCR par défaut pour les nouveaux projets

  • radiobuttonoff Don’t enable ‘on the fly’ reprojection
  • radiobuttonon Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radiobuttonoff Enable ‘on the fly’ reprojection by default
  • Sélectionner un SCR et Toujours lancer ce SCR pour les nouveaux projets

SCR pour les nouvelles couches

Cet espace vous permet de définir une action à faire lorsqu’une nouvelle couche est créée ou lorsqu’une couche sans SCR est chargée.

  • radiobuttonon Prompt for CRS
  • radiobuttonoff Use project CRS
  • radiobuttonoff Use default CRS

Transformations géodésiques par défaut

  • checkbox Demander un datum pour la conversion de coordonnées lorsque aucun n’est défini par défaut

  • Si vous avez utilisé la ‘projection à la volée’, vous pouvez visualiser les transformations effectuées en bas de la fenêtre. Vous y trouverez des informations sur le ‘SCR source’ et le ‘SCR cible’ ainsi que la ‘Transformation géodésique source’, appliquée au SCR source, et la ‘Transformation géodésique cible’, appliquée au SCR cible.

Onglet Langue

  • checkbox Écraser la langue du système et la Langue à utiliser

  • Informations sur les paramètres de langue du système

Onglet Réseau

Général

  • Définir l’Adresse de recherche WMS, par défaut : http://geopole.org/wms/search?search=\%1\&type=rss

  • Définir le Délai d’abandon pour les requêtes réseaux (ms) - la valeur par défaut est 60000

  • Définir le Délai d’expiration pour les tuiles WMSC/WMTS (en heures)- la valeur par défaut est 24

  • Définir le Nombre d’essais maximum lors d’une erreur de requête vers une tuile

  • Définir le User-Agent

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

Paramètres du cache

Définir le Répertoire et la Taille du cache.

  • checkbox Utiliser un proxy pour l’accès internet et définir l’‘Hôte’, le ‘Port’, l’‘Utilisateur’, et le ‘Mot de passe’.

  • Set the Proxy type selectstring according to your needs.
    • Default Proxy : le proxy est déterminé sur la base du proxy de l’application

    • Socks5Proxy : proxy générique pour tout type de connexion. Supporte le TCP, UDP, binding à un port (connexions entrantes) et l’authentification.

    • HttpProxy : implémenté avec la commande “CONNECT” , supporte uniquement les connexions TCP sortantes, supporte l’authentification.

    • HttpCachingProxy : implémenté via les commandes HTTP normales, utile uniquement dans un contexte de requêtes HTTP.

    • FtpCachingProxy : implémenté avec un proxy FTP, utile uniquement dans un contexte de requêtes FTP.

Vous pouvez exclure certaines adresses en les ajoutant dans la zone de texte sous les paramètres de proxy (voir Figure_Network_Tab).

Si vous avez besoin d’informations plus détaillées sur les différents paramètres de proxy, référez-vous au manuel de la bibliothèque sous-jacente QT : http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Astuce

Utiliser les proxy

L’utilisation de proxy peut se révéler difficile. Il est utile de tester les types de proxy décrits ci-dessus et vérifier s’ils conviennent.

You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

  • nix Les paramètres sont sauvegardés dans un fichier texte : $HOME/.config/QGIS/QGIS2.conf

  • osx Les paramètres se trouvent dans: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win Les paramètres sont stockés dans la base de registre, sous: HKEY\CURRENT_USER\Software\QGIS\qgis

Personnalisation

The customization tool lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you have a lot of plugins installed that you never use and that are filling your screen.

Figure Customization 1:

../../../_images/customization.png

The Customization dialog nix

QGIS Customization is divided into five groups. In checkbox Menus, you can hide entries in the Menu bar. In checkbox Panels, you find the panel windows. Panel windows are applications that can be started and used as a floating, top-level window or embedded to the QGIS main window as a docked widget (see also Panels and Toolbars). In the checkbox Status Bar, features like the coordinate information can be deactivated. In checkbox Toolbars, you can (de)activate the toolbar icons of QGIS, and in checkbox Widgets, you can (de)activate dialogs as well as their buttons.

With mActionSelect Switch to catching widgets in main application, you can click on elements in QGIS that you want to be hidden and find the corresponding entry in Customization (see figure_customization). You can also save your various setups for different use cases as well. Before your changes are applied, you need to restart QGIS.