Outdated version of the documentation. Find the latest one here.

QGIS Configuration

QGIS is highly configurable through the Settings menu. Choose between Project Properties, Options and Customization.

Catatan

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described below could be in the Project or the Settings menu.

Properti Proyek

In the properties window for the project under nix Settings ‣ Project Properties (kde) or nix osx win Project ‣ Project Properties (Gnome, OS X or Windows), you can set project-specific options.

  • In the General menu, the general settings let you:

    • give a title to the project beside the project file path
    • choose the color to use for features when they are selected
    • choose the background color: the color to use for the map canvas
    • set whether the path to layers in the project should be saved as absolute (full) or as relative to the project file location. You may prefer relative path when both layers and project files can be moved or shared or if the project is accessed from computers on different platforms.
    • choose to avoid artifacts when project is rendered as map tiles. Note that checking this option can lead to performance degradation.

    Calculating areas and distances is a common need in GIS. However, these values are really tied to the underlying projection settings. The Measurements frame lets you control these parameters. You can indeed choose:

    • the ellipsoid to use: it can be an existing one, a custom one (you’ll need to set values of the semi-major and semi-minor axis) or None/Planimetric.
    • the units for distance measurements for length and perimeter and the units for area measurements. These settings, which default to the units set in QGIS options but then overrides it for the current project, are used in:
      • Attribute table field update bar
      • Field calculator calculations
      • Identify tool derived length, perimeter and area values
      • Default unit shown in measure dialog

    The Coordinate display allows you to choose and customize the format of units to use to display the mouse coordinate in the status bar and the derived coordinates shown via the identify tool.

    Finally, you can define a project scale list, which overrides the global predefined scales.

Figure General Menu:

../../../_images/project_general.png

General tab of Project Properties dialog

  • Menu CRS memungkinkan Anda untuk memilih Coordinat Reference System untuk proyek ini, dan memungkinkan proyeksi ulang on-the-fly lapisan raster dan lapisan vektor ketika menampilkan lapisan dari CRS yang berbeda.

  • With the Identify layers menu, you set (or disable) which layers will respond to the identify tool. By default, layers are set queryable.
  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colors assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.
  • The tab OWS Server allows you to define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions.
  • Menu Macros digunakan untuk mengedit Python macros untuk proyek. Saat ini, hanya tiga macro yang tersedia: openProject(), saveProject() dan closeProject().

Figure Macro Menu:

../../../_images/macro.png

Macro settings in QGIS

  • Menu Relasi digunakan untuk menentukan relasi 1:n. Relasi ditentukan dalam dialog properti proyek. Setelah ada relasi lapisan, elemen antarmuka pengguna baru form tampilan (misalnya ketika mengidentifikasi fitur dan membuka form) akan daftar entitas terkait. Ini menyediakan cara ampuh mengekspresikan misalnya sejarah inspeksi pada panjang pipa atau segmen jalan. Anda bisa menemukan lebih jauh tentang relasi 1:n di Bagian Creating one to many relations.

Opsi

options Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ options Options. The tabs where you can customize your options are described below.

Menu Umum

Aplikasi

  • Select the Style (QGIS restart required) selectString and choose between ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlooks’ (nix).
  • Define the Icon theme selectString. Currently only ‘default’ is possible.
  • Define the Icon size selectString.
  • Define the Font. Choose between radioButtonOn Qt default and a user-defined font.
  • Change the Timeout for timed messages or dialogs selectString.
  • checkbox Sembunyikan layar splash saat startup

  • checkbox Tampilkan Petunjuk saat startup

  • checkbox Judul tebal kotak grup

  • checkbox QGIS-styled kotak grup

  • checkbox Use native color chooser dialogs
  • checkbox Use live-updating color chooser dialogs
  • checkbox Custom side bar style
  • checkbox Experimental canvas rotation support (restart required)

Berkas proyek

  • Open project on launch selectString (choose between ‘New’, ‘Most recent’ and ‘Specific’). When choosing ‘Specific’ use the browseButton to define a project.
  • checkbox Buat proyek baru dari proyek default. Anda memiliki kemungkinan untuk menekan Atur proyek sekarang sebagai default atau pada Reset default. Anda dapat menelusuri melalui berkas-berkas dan menentukan direktori dimana Anda menemukan pengguna-ditetapkan proyek template Anda. Akan ada sebuah entri di Project ‣ Baru dari Template jika Anda pertama kali mengaktifkan checkbox Buat proyek baru dari proyek default dan kemudian simpan proyek dalam folder proyek template.

  • checkbox Prompt untuk menyimpan proyek dan sumber data perubahan bila diperlukan

  • checkbox Prompt for confirmation when a layer is to be removed
  • checkbox Peringatkan ketika membuka berkas proyek QGIS yang disimpan dengan versi lama

  • Enable macros selectString. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

Menu Sistem

Lingkungan

Sistem lingkungan variabel saat ini dapat dilihat dan banyak dikonfigurasi dalam menu Lingkungan (lihat figure_environment_variables). Hal ini berguna untuk platform, seperti Mac, di mana aplikasi GUI tidak selalu mewarisi lingkungan shell pengguna. Ini juga berguna untuk pengaturan / melihat lingkungan variabel untuk mengatur alat eksternal yang dikendalikan oleh pengolahan toolbox (seperti SAGA, GRASS), dan untuk menyalakan keluaran debugging untuk bagian tertentu dari kode sumber.

  • checkbox Gunakan penyesuaian variabel (dibutuhkan restart - termasuk pemisah). Anda bisa [Tambah] dan [Hapus] variabel. Variabel lingkungan yang sudah ditetapkan akan ditampilkan dalam:guilabel:Variabel lingkungan sekarang, dan hal itu memungkinkan untuk menyaring mereka dengan mengaktifkan checkbox Tampilkan hanya variabel spesifik-QGIS.

Figure System Environment:

../../../_images/sys-env-options.png

System environment variables in QGIS

Plugin path

[Tambah] atau [Hapus] Path(s) untuk mencari tambahan C++ librari Plugin

Menu sumber data

Atribut dan tabel fitur

  • checkbox Buka tabel atribut di dock window (dibutuhkan restart QGIS)

  • checkbox Copy geometry in WKT representation from attribute table. When using copySelected Copy selected rows to clipboard from the Attribute table dialog, this has the result that the coordinates of points or vertices are also copied to the clipboard.
  • Attribute table behavior selectString. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Attribute table row cache selectNumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representasi untuk nilai NULL Here you can define a value for data fields containing a NULL value. Di sini Anda dapat menentukan nilai untuk bidang data yang berisi nilai NULL.

Menangani sumber data

  • Scan for valid items in the browser dock selectString. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compressed files (.zip) in browser dock selectString. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Konfirmasi sublapisan raster saat membuka. Beberapa raster mendukung sublapisan – mereka disebut subdataset di GDAL. Contohnya adalah berkas netCDF - jika ada banyak variabel netCDF, GDAL melihat setiap variabel sebagai sub dataset. Pilihan ini untuk mengontrol bagaimana menangani sub-lapisan ketika sebuah berkas dengan sub-lapisan dibuka. Anda memiliki pilihan berikut:

    • ‘Selalu’: Selalu bertanya (jika ada sub-lapisan yang ada)

    • ‘Jika diperlukan’: Menanyakan apakah lapisan tidak memiliki band, namun memiliki sub-lapisan

    • ‘Tidak Pernah’: Tidak pernah meminta, tidak akan memuat apa-apa

    • ‘Muat semua’: Tidak pernah meminta, tetapi memuat semua sub-lapisan

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Add PostGIS layers with double click and select in extended mode
  • checkbox Tambahkan lapisan Oracle with dobel klik dan pilih dalam mode diperpanjang

  • checkbox Execute expressions on server-side if possible
  • checkbox create transaction groups automatically whenever possible (Experimental). When this mode is turned on, all (postgres) layers from the same database are synchronised in their edit state, i.e. when one layer is put into edit state, all are, when one layer is committed or one layer is rolled back, so are the others. Also, instead of buffering edit changes locally, they are directly sent to a transaction in the database which gets committed when the user clicks save layer.

Hidden Browser Path

This widget lists all the folder you chose to hide from the Browser panel. Removing a folder from the list will make it available in the Browser panel.

Menu Rendering

Rendering behavior

  • checkbox Secara default lapisan baru yang ditambahkan ke peta harus ditampilkan

  • checkbox Gunakan render caching yang memungkinkan mempercepat gambar ulang

  • checkbox Render layers in parallel using many CPU cores
  • checkbox Max cores to use
  • Map update interval (default to 250 ms)
  • checkbox Enable feature simplification by default for newly added layers
  • Simplification threshold
  • checkbox Sederhanakan di sisi penyedia jika mungkin

  • Maximum scale at which the layer should be simplified

Kualitas rendering

  • checkbox Membuat garis tampil kurang bagus dengan mengorbankan beberapa kinerja menggambar

Raster-raster

  • Dengan RGB band seleksi Anda bisa menetapkan nomor dari band Merah, Hijau dan Biru.

Contrast enhancement

  • Single band gray selectString. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectString. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectString. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectString. Options are ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’.
  • Kumulatif batas jumlah potong pixel

  • Standar deviasi multiplier

Debugging

  • checkbox Refresh kanvas peta

Colors Menu

This menu allows you to add some custom color that you can find in each color dialog window of the renderers. You will see a set of predefined colors in the tab: you can delete or edit all of them. Moreover you can add the color you want and perform some copy and paste operations. Finally you can export the color set as a gpl file or import them.

Menu Kanvas dan Legenda

Standar penampilan peta (diganti oleh proyek properti)

  • Tetapkan Seleksi warna dan Warna latar.

Legenda lapisan

  • Double click action in legend selectString. You can either ‘Open layer properties’ or ‘Open attribute table’ with the double click.
  • Mengikuti Gaya item legenda:

    • checkbox Nama lapisan kapital

    • checkbox Nama lapisan tebal

    • checkbox Nama grup tebal

    • checkbox Tampilkan klasifikasi nama atribut

    • checkbox Buat ikon raster (mungkin lambat)

Menu perangkat Peta

This menu offers some options regarding the behavior of the Identify tool.

  • Search radius for identifying and displaying map tips is a tolerance factor expressed as a percentage of the map width. This means the identify tool will depict results as long as you click within this tolerance.
  • Highlight color allows you to choose with which color should features being identified are to be highlighted.
  • Buffer determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width determines how thick should the outline of a highlighted object be.

Alat pengukuran

  • Tentukan Warna Rubberband untuk peralatan pengukuran

  • Tentukan Tempat desimal

  • checkbox Keep base unit to not automatically convert large numbers (e.g., meters to kilometers)
  • Preferred distance units radioButtonOn (‘Meters’, ‘Feet’, ‘Nautical Miles’, ‘Degrees’ or ‘Map Units’ )
  • Preferred area units radioButtonOn (‘Square meters’, ‘Square feet’, ‘Square yards’, ‘Hectares’, ‘Map Units’ ...)
  • Preferred angle units radioButtonOn (‘Degrees’, ‘Radians’, ‘Gon/gradians’, ‘Minutes of arc’ ...)

Menggeser dan memperbesar

  • Define Mouse wheel action selectString (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Tentukan Faktor pembesaran untuk roda tetikus

Skala yang ditentukan

Here, you find a list of predefined scales. With the signPlus and signMinus buttons you can add or remove your personal scales. You can also import or export scales from/to a .XML file. Note that you still have the possibility to remove your changes and reset to the predefined list.

Menu Penyusun

Standar Komposisi

You can define the Default font here.

Penampilan Kotak

  • Define the Grid style selectString (‘Solid’, ‘Dots’, ‘Crosses’)
  • Define the Grid color

Grid and guide defaults

  • Define the Grid spacing selectNumber
  • Define the Grid offset selectNumber for x and y
  • Define the Snap tolerance selectNumber

Menu Digitalisasi

Membuat fitur

  • checkbox Menekan atribut jendela pop-up setelah setiap fitur dibuat

  • checkbox Gunakan kembali nilai atribut terakhir yang dimasukkan

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Rubberband

  • Tentukan Rubberband Lebar garis dan Warna garis

Snapping

  • checkbox Buka opsi mengambil di dock window (dibutuhkan restart QGIS)

  • Define Default snap mode selectString (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Tentukan Default toleransi snapping dalam satuan peta atau pixel

  • Tentukan Cari radius untuk suntingan simpul dalam satuan peta atau pixel

Penanda simpul

  • checkbox Tampilkan penanda hanya untk fitur yang dipilih

  • Define vertex Marker style selectString (‘Cross’ (default), ‘Semi transparent circle’ or ‘None’)
  • Tentukan simpul Ukuran Penanda

Alat ofset kurva

The next 3 options refer to the offsetCurve Offset Curve tool in Advanced digitizing. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Gaya Join

  • Segmen Quadrant

  • Batas Miter

Menu GDAL

GDAL adalah data pertukaran librari untuk berkas raster. Dalam tab ini Anda dapat Edit membuat opsi dan Edit Opsi Pyramid dari format raster. Menentukan driver GDAL yang akan digunakan untuk format raster seperti dalam beberapa kasus lebih dari satu driver GDAL tersedia.

Menu CRS

CRS standar untuk proyek baru

  • radioButtonOff Don’t enable ‘on the fly’ reprojection
  • radioButtonOn Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radioButtonOff Enable ‘on the fly’ reprojection by default
  • Pilih sebuah CRS dan Selalui mulai proyek baru dengan CRS ini

CRS untuk lapisan baru

Daerah ini memungkinkan untuk menentukan tindakan ketika sebuah lapisan baru dibuat, atau ketika lapisan tanpa CRS dimuat.

  • radioButtonOn Prompt for CRS
  • radioButtonOff Use project CRS
  • radioButtonOff Use default CRS

Transformasi datum standar

  • checkbox Mintalah transformasi datum bila tidak ada standar yang ditentukan

  • Jika Anda telah bekerja dengan transformasi CRS ‘on-the-fly’ Anda bisa melihat hasil dari transformasi dalam jendela di bawah. Anda bisa menemukan informasi tentang ‘Sumber CRS’ dan ‘Destinasi CRS’ maupun ‘Sumber datum transform’ dan ‘Destinasi datum transform’.

Menu Lokal

  • checkbox Timpah sistem lokal dan Lokal gunakan sebagai pengganti

  • Informasi tentang sistem lokal aktif

Authentication

In the Authentication tab you can set authentication configurations and manage PKI certificates. See Authentication System for more details.

Menu Jaringan

Umum

  • Tentukan WMS cari alamat, default http://geopole.org/wms/search?search=\%1\&type=rss

  • Tentukan Timeout untuk permintaan jaringan (ms) - default 60000

  • Tentukan Standar periode ekspirasi untuk WMSC/WMTS (jam) - default 24

  • Tentukan Mencoba kembali Maksimum jika terjadi kesalahan permintaan genteng

  • Tentukan User-Agent

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

Pengaturan cache

Tentukan Direktori dan Ukuran untuk cache.

  • checkbox Gunakan proxy untuk akses web dan tentukan ‘Host’, ‘Port’, ‘Pengguna’, and ‘Kata Sandi’.

  • Set the Proxy type selectString according to your needs.
    • Proxy Standar: Proxy ditentukan berdasarkan aplikasi pengaturan menggunakan proxy

    • Socks5Proxy: Proxy generik untuk setiap jenis koneksi. Mendukung TCP, UDP, mengikat ke port (koneksi masuk) dan otentikasi.

    • HttpProxy: Menggunakan perintah “CONNECT”, mendukung hanya koneksi TCP; mendukung otentikasi.

    • HttpCachingProxy: Menggunakan perintah normal HTTP, itu hanya berguna dalam konteks permintaan HTTP.

    • FtpCachingProxy: Menggunakan proxy FTP, itu hanya berguna dalam konteks permintaan FTP.

Tidak termasuk beberapa URL dapat ditambahkan ke kotak teks di bawah pengaturan-proxy (lihat Figure_Network_Tab).

Jika Anda membutuhkan informasi lebih rinci tentang pengaturan-proxy yang berbeda, silakan lihat panduan QT-librari-dokumentasi di http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Tip

Menggunakan Proxi

Menggunakan proxi kadang-kadang bisa rumit. Hal ini berguna ‘coba dan eror’ jenis proxi di atas, untuk memeriksa apakah mereka berhasil dalam kasus Anda.

You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

  • nix Settings are saved in a text file: $HOME/.config/QGIS/QGIS2.conf
  • osx Anda dapat menemukan pengaturan Anda di: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win pengaturan terkirim ke registri: HKEY\CURRENT_USER\Software\QGIS\qgis

Penyesuaian (Customization)

The customization dialog lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you want to provide your end-users with a ‘light’ version of QGIS, containing only the icons, menus or panels they need.

Catatan

Before your changes are applied, you need to restart QGIS.

Figure Customization 1:

../../../_images/customization.png

The Customization dialog

Ticking the checkbox Enable customization checkbox is the first step on the way to QGIS customization. This enables the toolbar and the widget panel from which you can uncheck and thus disable some GUI items.

The configurable item can be:

  • a Menu or some of its sub-menus from the Bar Menu
  • a whole Panel (see Panels and Toolbars)
  • the Status bar described in Status Bar or some of its items
  • a Toolbar: the whole bar or some of its icons
  • or any widget from any dialog in QGIS: label, button, combobox...

With select Switch to catching widgets in main application, you can click on an item in QGIS interface that you want to be hidden and QGIS automatically unchecks the corresponding entry in the Customization dialog.

Once you setup your configuration, click [Apply] or [Ok] to validate your changes. This configuration becomes the one used by default by QGIS at the next startup.

The modifications can also be saved in a .ini file using fileSave Save To File button. This is a handy way to share a common QGIS interface among multiple users. Just click on fileOpen Load from File from the destination computer in order to import the .ini file. You can also run command line tools and save various setups for different use cases as well.

Tip

Easily restore predefined QGIS

The initial QGIS GUI configuration can be restored by one of the methods below:

  • unchecking checkbox Enable customization option in the Customization dialog or click the selectAllTree Check All button
  • pressing the [Reset] button in the QSettings frame under Settings ‣ Options menu, System tab
  • launching QGIS at a command prompt with the following command line qgis --nocustomization
  • setting to false the value of UI ‣ Customization ‣ Enabled variable under Settings ‣ Options menu, Advanced tab.

In most cases, you need to restart QGIS in order to have the change applied.