Outdated version of the documentation. Find the latest one here.

Het Vector Eigenschappen Menu

Het menu Laag Eigenschappen voor een vector laag geeft in informatie over de laag, instellingen van de stijlen en de label opties. Wanneer de Vector laag geladen is vanuit een PostgreSQL/PostGIS database, kun je ook de SQL opdracht aanpassen waarmee deze laag is opgehaald door het Query Builder venster te starten onder het tabblad Algemeen. Om toegang te krijgen tot het menu Laag Eigenschappen kun je dubbelklikken op een kaartlaag in de legenda of een laag selecteren en met de rechtermuisklik het snelmenu openen en de menuoptie Eigenschappen selecteren.

Figure Vector Properties 1:

../../../_images/vectorLayerSymbology.png

Vector Layer Properties Dialog nix

Tabblad Stijl

symbology Sinds QGIS 1.4.0 is het mogelijke twee soorten symbologie naast elkaar te gebruiken, waarbij de nieuwe verbeterde symbologie de oude zal gaan vervangen. In QGIS 1.8.0 is de nieuwe symbologie de standaard geworden die verder verbeterd is en nieuwe functionaliteit bevat.

Een beschrijving van de oude symbologie is beschikbaar in Oude Symbologie.

Er zijn drie soorten symbologie: markering symbolen (voor punten), lijn symbolen (voor lijnen) en vulling en buitenlijn symbolen (voor polygonen). Symbolen kunnen bestaat uit een of meerdere symbool lagen. Het is mogelijk om een symbool een kleur te geven, dan krijgen alle symboollagen die kleur. Je kunt voor een symboollaag de kleur vastzetten - die kleur wordt dan niet mee gewijzigd bij het wijzigen van de kleur van een symbool. Op die manier kun je symbolen maken die bestaan uit meerdere kleuren. Op dezelfde manier kun je ook de lijndikte voor lijnsymbolen voor alle lagen tegelijk wijzigen of voor 1 laag vastzetten. Dit werkt ook voor de grootte en de hoek van symboollagen.

Beschikbare typen symbool lagen

  • Punt lagen

    • Tekst markering: puntsymbool met tekst.

    • Simpele markering: puntsymbool op basis van voorgecodeerde symbolen.

    • SVG markering: puntsymbool op basis van een SVG afbeelding.

    • Ellipse marker: Ellipsvormig puntsymbool op basis van attribuutwaarden.

    • Vector veld marker: Vectoren als symbologie op basis van attribuutwaarden.

  • Lijn lagen

    • Lijn decoratie: Voeg een lijn decoratie toe, bijvoorbeeld een pijlpunt om de lijn een richting te geven.

    • Lijn markering: Een lijn die opgebouwd wordt met op regelmatige afstanden een markering symbool.

    • Simpele lijn: Een ‘normale’ opgebouwde lijn (met een gezette lijndikte, kleur en penstijl/lijnarcering).

  • Polygoon lagen

    • Centroïde vulling: Plaats op de centroïde van een polygoon een voorgecodeerd markeringsymbool.

    • SVG vulling: Vul het polygoon op met een SVG symbool.

    • Simpele vulling: Een ‘normaal’ opgebouwde polygoon ( met een gezette vulkleur, arcering en een dikte van de buitenlijn).

    • Lijnpatroonvulling: Vul het polygoon met een lijnpatroon.

    • Puntpatroonvulling: Vul een polygoon met een puntpatroon.

    • Buitenlijn: Lijn met decoratie: Voeg een lijn decoratie toe, bijvoorbeeld een pijltje om de richting vand de lijn mee aan te geven.

    • Buitenlijn: Markeringslijn: Gebruik een voorgecodeerd markeringssymbool om daarmee de grens van een vlak mee op te bouwen.

    • Buitenlijn: Simpele lijn: Geef de buitenlijn die de grens van een vlak aangeeft een breedte, een kleur en een penstijl/lijnarcering.

Kleurverlopen

Kleurverlopen worden gebruikt om makkelijk te kunnen kiezen uit heel veel kleuren die gebruikt worden tijdens het opbouwen van de kaart. De kleuren van gebruikte symbolen worden toegekend vanuit de kleurverlopen.

Er zijn drie typen kleurverlopen:

  • Gradiënt: Waarbij de ene kleur langzaam overvloeit naar een andere kleur.

  • Random: Genereer willekeurig/’at Random’ kleuren van uit een gespecificeerd kleurenpalet.

  • ColorBrewer: Maak een kleurenspectrum aan vanuit een kleurenschema en een gedefinïeerd aantal kleurenklassen.

Kleurverlopen kunnen worden gezet in het tabblad Kleurverloop van het menu Stijl manager door op de knop [Toevoegen] te drukken en een type kleurverloop te kiezen (zie vector_style_manager).

Stijlen

Een stijl groepeert een set van verschillende symbolen en kleurverlopen. Je kunt in zo’n stijlengroep je favoriete symbolen vastleggen en deze gebruiken zonder deze symbolen telkens opnieuw weer op te bouwen. Stijlonderdelen (symbolen en kleurverlopen) hebben altijd een naam waarmee ze kunnen worden opgevraagd uit de stijlen. Er is minimaal één standaard stijl in QGIS (die aangepast kan worden) en de gebruiker kan daarnaast stijlen toevoegen. In het onderste deel van het tabblad Stijl zijn vier knoppen aanwezig voor het beheer van Stijlen: Gebruik [Terug naar Standaard Stijl] om terug te gaan naar je standaard stijl, [Opslaan als Standaard] om de huidige stijl op te slaan als standaard stijl, [Stijl laden...] om je stijl op te laden en [Stijl Opslaan...] om de ingestelde stijl op te slaan. Laagstijlen kunnen ook gekopiëerd worden van de ene laag naar een andere. Selecteer een laag en kies via het menu Kaartlagen ‣ mActionEditCopy Kopiëer stijl en selecteer vervolgens een andere laag. Kies vervolgens Kaartlagen ‣ mActionEditPaste Plak stijl.

Renderers

De Renderer is verantwoordelijk voor het opbouwen van het kaartbeeld waarbij de objecten met de goede symbologie wordt getekend. Er zijn vier soorten Renderers: Enkel Symbool, Categoriëen (in de oude symbologie werd deze unieke kleuren genoemd), gradueel en Regel-gebaseerd. Er is geen continue kleuren renderer aangezien deze in feite een speciale variant van de Graduele renderer is. De graduele gecategoriseerde renderer kan worden aangemaakt door een combinatie van een symbool en een kleurverloop te kiezen.

Werken met de Nieuwe Symbologie

In het tabblad:guilabel:Stijl kun je kiezen uit vijf soorten Renderers: Enkel Symbool, Categoriën, Gradueel, Regel-gebaseerd en Puntverplaatsing. Voor elk vectortype (punten, lijnen en polygonen) zijn vector symboollaag typen beschikbaar (zie vector_symbol_types). Afhankelijk van de gekozen renderer, zal het tabblad stijl verschillende opties en instellingen bevatten, die in de volgende paragrafen worden beschreven. Het menu van de nieuwe symbologie bevat ook de knop [Stijlen Manager] die toegang geeft tot de Stijlen Manager (zie vector_style_manager). De Stijlen Manager biedt de mogelijkheid om bestaande symbolen te verwijderen en om nieuwe toe te voegen.

Tip

Selecteer en wijzig meerdere symbolen

Met de nieuwe symbologie kun je meerdere symbolen selecteren en via de rechtermuis kun de kleur, transparantie, de grootte en de dikte van de buitenlijnen aanpassen.

De Enkel Symbool Renderer

De renderer Enkel Symbool wordt gebruikt om alle objecten van een kaartlaag te presenteren met een enkel door de gebruiker toegekend symbool. De eigenschappen die kunnen worden gewijzigd in het tabblad Stijl is deels afhankelijk van het type kaartlaag, maar voor alle typen geldt de volgende opbouw.Links bovenin het tabblad, kun je de voorvertoning zien van het huidige symbool. Onderin het tabblad is een lijst van symbolen die reeds aangemaakt zijn voor de huidige stijl, klaar om te gebruiken door deze te selecteren uit de lijst. Het huidige symbool kan worden aangepast gebruik makende van de knop [Eigenschappen] onder het voorbeeld van het symbool, waarmee het venster Symbooleigenschappen kan worden geopend, of de knop [Aanpassen] rechts van de voorvertoning, die het standaard Kleuren dialoogvenster opent.

Figure Symbology 1:

../../../_images/singlesymbol_ng_line.png

Single symbol line properties nix

In het tabblad Stijl kun je de transparatie van de laag instellen en aangeven of je millimeters of kaarteenheden wilt gebruiken voor de schaalgrootte. Daarnaast kun je ook de schaalgrootte en rotering instellen die afhankelijk is van attribuutwaarden van diezelfde laag.Deze is beschikbaar onder de knop [Geavanceerd] naast de knop [Stijl opslaan...]). Daarin kun je via de keuzelijst Symboollagen... kiezen waarmee een menu opent waarin je kunt aangeven in welke volgorde de symboollagen moet worden opgebouwd (wanneer het symbool bestaat uit meerdere lagen).

Na het symbool te hebben aangepast kan deze worden opgeslagen en worden toegevoegd aan de lijst van huidige stijl symbolen (gebruik makende van de knop [Stijl opslaan...]) zodat deze in de toekomst weer gebruikt kan worden. In het vervolgmenu Sla laageigenschappen op als stijlbestand dat verschijnt na het indrukken van de knop [Stijl opslaan] kun ervoor kiezen om de stijl van de laag op te slaan in een QGIS stijl bestand (.qml) of als SLD bestand (.sld). Een SLD (Styled Layer Descriptor) is een open standaard formaat voorgeschreven door het OGC, die o.a. ook wordt gebruikt door geoserver. Voor de export mogen alle renderstijlen gebruikt worden, maar wanneer een SLD stijl bestand wordt geimporteerd zullen deze worden omgezet naar de simpele symbolen of de regelgebaseerde renderstijl. categoriën of graduele renderstijlen worden daarbij omgezet naar regelgebaseerde renderstijlen. Wanneer je dat wilt voorkomen kun je de stijl het beste opslaan als .qml bestand, maar het is aan de andere kant ook een eenvoudige manier om de renderstijl snel om te zetten.

De Categoriën Renderer

De Categoriën Renderer wordt gebruikt om alle objecten van een laag te tekenen met één symbool met een kleur die afhankelijk is van een attribuutwaarde van diezelfde laag. Het tabblad Stijl geeft je de mogelijkheid om een keuze te maken uit:

  • Een kolom (uit de lijst van attribuutvelden)

  • Het symbool (gebruik makende van het Symbool selectie menu)

  • De kleuren (uit de lijst van de kleurverlopen)

Met de knop [Geavanceerd] die zich rechtsonder in het menu bevindt, kun je instellen welke velden gebruikt kunnen worden voor de rotatie of voor de schaalgrootte van het symbool afhankelijk te maken van de veldwaarde. Daarbij kun je eenvoudig een veld kiezen in een keuzelijstje van velden die je daar eventueel voor kunt gebruiken.

Het voorbeeld in figure_symbology_2 toont de categoriën rendering dialoog gebruikt voor de laag rivers van de QGIS sample dataset.

Figure Symbology 2:

../../../_images/categorysymbol_ng_line.png

Categorized Symbolizing options nix

Je kunt zelf een nieuwe kleurverloop aanmaken door onderin de lijst van kleurverlopen te kiezen voor Nieuw kleurverloop.... In het venster dat opent kun je vervolgens een kleurverlooptype selecteren uit: Gradiënt, Random of ColorBrewer. Na het drukken op de knop [OK] kun je vervolgens ook meerdere ‘stops’ in het kleurverloop opnemen. Zie figure_symbology_3 die een voorbeeld toont van een zelf gemaakte kleurverloop.

Figure Symbology 3:

../../../_images/customColorRampGradient.png

Example of custom gradient color ramp with multiple stops nix

De Graduele Renderer

De Graduele Renderer wordt gebruikt om voor een laag aan de hand van een enkel symbool de classificatie weer te geven aan de hand van de kleuren die afhankelijk is van een attribuutwaarde.

Figure Symbology 4:

../../../_images/graduatesymbol_ng_line.png

Graduated Symbolizing options nix

Net als de Categoriën Renderer, kun je hiervoor de rotatie en de grootte afhankelijk maken van attribuutwaarden.

Net als de categoriën Renderer, heeft het tabblad Stijl de selectiemogelijkheden:

  • Een kolom (uit de lijst van attribuutvelden)

  • Het symbool (Gebruik makende van het Symbool selectie menu)

  • The colors (using the Color Ramp list)

Aanvullend kun je het aantal klassen kiezen en ook welke modus je wilt gebruiken voor de Klassificatie. De beschikbare modus zijn:

  • Gelijke Interval

  • Quantilen

  • Natuurlijke Grenzen (Jenks)

  • Standaard Afwijking

  • Mooie Grenzen

De lijst in het onderste deel van het tabblad Stijl somt de klassen op met hun bereik, labels en symbolen die voor het renderen worden gebruikt.

Het voorbeeld in figure_symbology_4 toont de dialoog van de Renderer Gradueel voor de laag rivers van de QGIS voorbeeld dataset.

De Regel-gebaseerde Renderer

De Regel-gebasseerde Renderer wordt gebruikt om objecten van een laag te tonen waarbij gebruikte kleuren afhankelijk zijn van toegepaste regels. Deze regels zijn gebasseerd op SQL opdrachten. Je kunt ook de Zoekopdrachtbouwer gebruiken om deze te maken. De dialoog geeft de mogelijkheid om met een filter te groeperen of verschalen en je kunt besluiten of je symboollagen wilt gebruiken of dat de eerste regel waaraan voldaan wordt gebruikt wordt.

Het voorbeeld in figure_symbology_5 toont de dialoog van een Regel-gebaseerde renderer voor de laag rivers van de QGIS voorbeeld dataset.

Om een nieuwe regel toe te voegen aan de regelgebaseerde rendering, dubbelklik op een regel in de lijst of druk op de [+] knop waarna de dialoog Regel eigenschappen opent waarmee je dat kunt doen. Druk in de dialoog op de knop browsebutton waarmee de Expressie-string bouwer opent waarmee je expressies kunt maken. Dubbelklik eerst op >-Velden en Waarden waarna je de attribuutvelden ziet. Om een attribuutveld toe te voegen, dubbelklik op het veld in de lijst van >-Velden en Waarden.Je kunt de verschillende velden, waarden en functies gebruiken om daarmee een expressie op te bouwen of je kunt dit direct doen door dit in het tekstblok van expressie in te typen (zie Veld berekening).

Figure Symbology 5:

../../../_images/rulesymbol_ng_line.png

Rule-based Symbolizing options nix

De Punt Verplaatsing Renderer

Deze Punt Verplaatsing Renderer biedt de mogelijkheid om alle objecten te zien ook al staan er meerdere op exact de zelfde positie. Wanneer dat het geval is worden deze op afstand in een circel eromheen geplaatst zodat ze toch zichtbaar zijn.

Figure Symbology 6:

../../../_images/poi_displacement.png

Point displacement dialog nix

Symbooleigenschappen

Het symbooleigenschappen menu geeft de gebruiker de mogelijkheid om de eigenschappen van het te renderen symbool aan te passen. Linksonder in het menu, kun je een voorbeeld zien van het huidige symbool zoals deze getekend zal worden op de kaart. Boven het voorbeeld bevindt zich de lijst van symboollagen. Om het menu Symbooleigenschappen te openen, klik op de knop [ mActionOptions Wijzigen...] in het tabblad Stijl van het menu Laag Eigenschappen.

Het menu geeft de mogelijkheid om lagen toe te voegen of te verwijderen, de volgorde van lagen te wijzigen of om symboollagen vast te zetten zodat van die laag de kleur niet gewijzigd wordt. Het rechterdeel van het menu toont de mogelijke instellingen voor het geselecteerde symbool in de lijst van symboollagen. Het belangrijkste is de Symboollaag type selectstring keuzeveld, waarmee je een laagtype kunt selecteren. De beschikbare opties zijn afhankelijk van de het laagtype (Punt, Lijn, Polygoon). De symboollaag type opties zijn beschreven in section vector_symbol_types. Je kunt ook de symboollaag eigenschappen wijzigen in de rechterkant van de dialoog. Wanneer je bijvoorbeeld een SVG markerings symbool hebt gekozen voor een vector puntenlaag, is het mogelijk de kleur ervan te veranderen gebruik makende van het Kleur menu.

Figure Symbology 7:

../../../_images/symbolproperties1.png

Line composed from three simple lines nix

Stijl Manager

De Stijl manager is een hulpprogramma, die de symbolen en kleurverlopen beheerd van een stijl. Het geeft de mogelijkheid om onderdelen toe te voegen of te verwijderen. Om de Stijl manager te open, selecteer het hoofdmenu Instellingen ‣ Stijl Manager.

Figure Symbology 10:

../../../_images/stylemanager.png

Style Manager to manage symbols and color ramps nix

Oude Symbologie

Notitie

QGIS 1.8 ondersteund nog de oude symbologie, maar het wordt aangeraden om de nieuwe symbologie te gaan gebruiken zoals beschreven in vector_new_symbology. In een volgende release zal het gebruik van de oude symbologie vervallen.

Wanneer je terug wilt gaan naar de oude symbologie, selecteer dan de knop [Oude Symbologie] in het tabblad Stijl van het menu Laag Eigenschappen.

Je kunt het gebruik van de oude symbologie ook als standaard instellen door het aanvinkvakje checkbox Nieuwe generatie symbologie gebruiken voor tekenen niet aan te vinken in het tabblad Rendering te openen via het hoofdmenu Instellingen ‣ mActionOptions Opties.

De oude QGIS symbologie ondersteunt de volgende renderers:

  • Enkel Symbool - Elk object in een laag krijgt hetzelfde symbool.

  • Graduated Symbool - Objecten in een laag worden verdeeld in een aantal klassen gebaseerd op de waarden van een bepaald veld. Elke klasse kun je een ander symbologie geven.

  • Continue kleur - Objecten in een laag worden getoond met hetzelfde symbool maar de kleur daarvan is afhankelijk van de numerieke waarde van een veld.

  • Unieke Waarde - Voor elke unieke waarde van een bepaald veld kun je een ander symbologie instellen.

Om de symbologie van een laag te wijzigen, dubbelklik op de laag in de legenda en het menu Laag Eigenschappen zal openen.

Stijl Opties

Binnen dit menu kun je vectorlagen een stijl geven. Afhankelijk van de geselecteerde rendering kun je ook je kaartobjecten classificeren en dit middels symbologie weergeven.

De volgende stijlen opties bestaan voor alle renderers:

  • Vul opties - Naast het kiezen van een lijn/vlak arcering of volledige vulling kun je kiezen voor Vulstijll:? Textuur selectstring waarna je met de knop browsebutton een bestand kunt selecteren met je eigen textuur waarmee de lijn/vlakvulling plaatsvindt. Momenteel worden de bestandsformaten *.jpeg, *.xpm, en *.png ondersteund.

  • Vulkleur - de kleur waarmee je objecten worden gevuld.

  • Omlijning opties

    • Omlijning stijl - lijnarcering waarmee de omlijning van je object worden getekend. Je kunt ook ‘geen pen’ selecteren.

    • Omlijning kleur - kleur waarmee de omlijning van je object worden getekend.

    • Omlijning breedte - pendikte waarmee de omlijning van je object wordt getekend.

Wanneer je tevreden bent over de gegeven stijl aan een laag, kun je deze ook vastleggen in een bestand met de bestandsextensie *.qml. Gebruik hiervoor de knop [Stijl Opslaan...]. Met de knop [Stijl laden...] kun je een opgeslagen stijl voor een laag laden.

Wanneer je wilt dat een bepaalde stijl altijd wordt gebruikt wanneer een laag geladen wordt (dus ook in nieuwe projecten), gebruik dan de knop [Opslaan Als Standaard]. Wanneer je de stijl hebt gewijzigd en je bent er niet tevreden over kun je met de knop [Terug naar Standaard Stijl] de stijl terug zetten naar de standaard stijl.

Vector transparantie

QGIS geeft de mogelijkheid om elke vectorlaag transparant te maken. Dit kun je doen met de schuifbalk Transparantie slider binnen het tabblad Stijl Dit is erg handig bij het gebruik van overlappende vectorlagen.

Tabblad Labels

labels Een label is de tekst die geplaatst wordt bij een object op de kaart. Net als voor de symbologie is er in QGIS 1.8 een oude en nieuwe methode van het toevoegen van labels aan objecten. Het tabblad Labels bevat de oude methode voor het toevoegen van labels. De nieuwe manier van het toevoegen van labels, gebeurt vanuit de werkbalk. De oude manier van labelen zal in een volgende versie van QGIS vervallen.

We raden dan ook aan gebruik te maken van de nieuwe manier beschreven in Nieuwe Labeling.

Met de oude manier van het toevoegen van labels, vanuit het tabblad Labels, geeft de mogelijkheid om de labels toe te voegen met een keuzemogelijkheden in lettertype, plaatsing, de uitlijning en het bufferen van de labels. We zullen als voorbeeld de kaartlaag lakes van labels voorzien. Lakes is de ingelezen shapefile die onderdeel uitmaakt van de Alaska voorbeeldgegevens QGIS_example_dataset:

  1. Laad de Shapefile alaska.shp en de GML file lakes.gml in QGIS

  2. Zoom in op een meer (=lake)

  3. Selecteer de laag lakes in de legenda

  4. Open het menu Laag Eigenschappen (via snelmenu onder rechtermuisknop of door op de laag Lakes te dubbelklikken

  5. Open het tabblad Labels

  6. Vink het aanvinkvakje checkbox Toon labels aan zodat labels getoond worden

  7. Kies het veld te gebruiken in labels in de keuzelijst. In dit geval gebruiken we het veld NAMES, guilabel:Veld te gebruiken in labels: Names selectstring

  8. Vul een standaard waarde in (bijv. ‘Meer’), voor meren die geen naam hebben. Deze standaard waarde wordt getoond in het kaartbeeld bij objecten, wanneer dat object (een meer) geen naam heeft.

  9. Labels kunnen uit meerdere regels bestaan en worden weergegeven wanneer het aanvinkvakje checkbox Labels met meerdere regels is aangevinkt. QGIS zal dan in het veld zoeken naar echte regelafbrekingen en op die plek in het label zal dan een nieuwe regel beginnen. Een echte regelafbreking is een enkel karakter \n, (geen twee aparte karakters zoals een \ gevolgd door het karakter n). Om in een attribuut veld regelafbrekingen in te kunnen brengen, open het tabblad Velden en wijzig van het tekstveld het Wijzig-hulpmiddel van ‘Lijn wijzigen’ naar ‘Tekstbewerken’.

  10. Selecteer de knop [Apply].

Het menu blijft openstaan en de labels worden op de kaart getekend. Waarschijnlijk niet zoals je zou willen, te groot en verkeerd geplaatst t.o.v. de objecten.

Gebruik de knop [Lettertype] om het menu te openen waarmee je lettertype, grootte en stijl kunt instellen waarmee de labels getekend worden. Gebruik de knop [Kleur] om de tekstkleur te kiezen. Je kunt ook de hoek kiezen waarmee labels geplaatst worden.

Daarnaast kun je de positie van het label veranderen ten opzichte van het object:

  1. Onder de standaard label opties kies een van de keuzerondjes in de Plaats groep om de plaatsing te wijzigen. Wij selecteren in dit voorbeeld het keuzerondje radiobuttonon Rechts.

  2. Je kunt kiezen tussen het gebruik van radiobuttonon In punten en radiobuttonoff Kaarteenheden. Wanneer je kiest voor Kaarteenheden dan worden de teksten groter en kleiner bij in- en uitzoomen. Bij de keuze In punten blijft de tekst even groot. In de meeste gevallen is de keuze In punten de beste keuze.

  3. Druk op [Apply] om het resultaat te zien in het kaartbeeld zonder het menu te sluiten.

Het begint er beter uit te zien, maar de labels kunnen beter iets verder van de meren worden geplaatst. Dit kunnen we doen door onderin het tabblad Labels onder Verspringing aangeven hoeveel de tekst nog verplaatst moet worden t.o.v. het object. Wanneer we in X-verspringing 5 ingeven (In punten) dan verschuift het label nog iets naar rechts op en wordt de tekst beter leesbaar geplaatst.

De laatste aanpassing die we zullen gebruiken is om elk label een buffer te geven. Daarmee wordt rond de tekst een vlak getekend, met ingegeven breedte, in een kleur naar keuze, wat vaak de tekst beter leesbaar maakt in een wat drukkere kaart, doordat deze er beter uitspringt. Doe het volgende om de labels van de laag Lakes een buffer te geven:

  1. Vink het aanvinkvak checkbox Labels met Buffer? aan.

  2. Kies een grootte van het buffer (invullen of met de pijltjes verhogen/verlagen).

  3. Kies een achtergrond kleur via de knop [Kleur] onder Buffer. Je kunt zelfs kiezen voor een mate van transparantie voor de buffer.

  4. Druk op [Apply] om het resultaat van de wijzigingen te zien.

Wanneer je niet tevreden bent, verander dan de instellingen en controleer tussendoor de wijzigingen met de knop [Apply] totdat je wel tevreden bent.

Een buffer van 1 (In punten) geeft vaak al een goed resultaat. Je kunt de buffer ook instellen in kaarteenheden.

De overige instellingen binnen het tabblad Labels bevindt zich onder het tabblad Geavanceerd waarmee je de eigenschappen van labels kunt instellen met de attribuutwaarden van de vectorlaag.

Het tabblad Labels bevat ook een Voorvertoning waarmee je al een indruk kunt krijgen van hoe het label eruit gaat zien.

Nieuwe Labeling

Achter de nieuwe knop mActionLabeling Labels zit de nieuwe geavanceerdere manier voor het plaatsen van labels van vector punt-, lijn- en polygoonlagen waarvoor slechts enkele instellingen nodig zijn. Deze nieuwe manier van het plaatsen van labels zal de huidige oude manier zoals beschreven in Tabblad Labels vervangen. Deze ondersteund ook Gelijktijdige CRS Transformatie.

Gebruik van de nieuwe manier van labels plaatsen

  1. Start QGIS en laad een punt, lijn en polygoon vectorlaag.

  2. Selecteer de vectorlaag in de legenda en druk op het mActionLabeling Labels in de werkbalk Labels van QGIS.

Het labelen van vector puntlagen

Vink eerst het aanvinkvakje checkbox Deze laag labelen en selecteer het veld dat je wilt gebruiken voor de inhoud van de labels via ‘Veld met labels’. Selecteer browsebutton wanneer je de een expressie wilt gebruiken voor het opbouwen van de tekst van labels. Daarna kun je de stijl en bij welke schaal het label zichtbaar is instellen in het tabblad Label opties (zie Figure_labels_1 ). Kies het tabblad Geavanceerd voor de plaatsing van het label en de de prioriteit. Voor samengestelde objecten kun je hier bepalen of elk deel zijn eigen label krijgt. Met Maak label op rond teken kun je het afbreekteken instellen waarmee labels omslaan naar de volgende regel. In het tabblad Data-bepaalde instellingen kun je velden gebruiken voor het instellen voor eigenschappen zoals lettertype, buffer en plaatsing eigenschappen die bepalen hoe een label opgemaakt.

Figure Labels 1:

../../../_images/label_points.png

Smart labeling of vector point layers nix

Het labelen van vector lijnlagen

Vink eerst het aanvinkvakje checkbox Deze laag labelen in het tabblad Label opties en selecteer een attribuutveld voor de labels. Hier kun je ook de tekst van labels maken op basis van expressies. Daarna kun je de stijl en bij welke schaal het label zichtbaar is instellen. Aanvullende labelopties zijn beschikbaar onder het tabblad Geavanceerd voor de plaatsing van het label, de labelafstand, of het label zich oriënteerd naar de lijn en de prioriteit. Voor samengestelde objecten kun je hier bepalen of elk lijndeel zijn eigen label krijgt of dat lijnen als samengevoegd worden beschouwd zodat er niet meerdere labels naast een lijn worden geplaatst. Daarnaast kun je ook symbolen op de lijnen plaatsen die deze een richting geven (zie Figure_labels_2). Het is ook mogelijk het labelen van delen te onderdrukken en een regel afbreekteken in te stellen. Gebruik Data-bepaalde instellingen voor het instellen van labeleigenschappen gebasseerd op veldwaarden.

Figure Labels 2:

../../../_images/label_line.png

Smart labeling of vector line layers nix

Het labelen van polygoon vectorlagen

Vink eerst het aanvinkvakje checkbox Deze laag labelen en selecteer het veld die je daarvoor wilt gebruiken. Ook hiervoor kun je de tekst maken op basis van regelgebasseerde expressies. In het tabblad Label opties bepaal je de tekststijl en de schaalgebasseerde zichtbaarheid (zie Figure_labels_3 ). Aanvullende labelopties zijn beschikbaar onder het tabblad Geavanceerd voor de plaatsing van het label, de labelafstand en de prioriteit. Je kunt hier aangeven of elk deel van samengestelde objecten een eigen label krijgt. Het is ook mogelijk het labelen van delen te onderdrukken en een regel afbreekteken in te stellen. Gebruik Data-bepaalde instellingen voor het instellen van labeleigenschappen gebasseerd op veldwaarden.

Figure Labels 3:

../../../_images/label_area.png

Smart labeling of vector polygon layers nix

De instellingen van de ‘engine’ wijzigen

Via de knop [Instellingen ‘engine’] kun je een aantal eigenschappen wijzigen van de ‘Label engine’, het motortje achter de functionaliteit van het plaatsen van labels. Zo kun je de zoek modus wijzigen die gebruikt wordt om de juiste plek te vinden waar het label geplaatst moet worden. Beschikbaar zijn de volgende opties: ‘Chain’ (snel), Popmusic Tabu, Popmusic Chain, Popmusic Tabu Chain en FALP (snelst).

Figure Labels 4:

../../../_images/label_engine.png

Dialog to change label engine settings nix

Je kunt daarnaast het aantal kanditaten waarnaar gekeken moet worden voor het plaatsen van labels voor punt, lijn en polygoon objecten. Wanneer je alle labels getoond wilt zien, ook wanneer deze elkaar overlappen kun je instellen via het aanvinkvakje ‘ Alle labels tonen. De optie Toon label-kandidaten (voor debugging) is niet alleen voor de ontwikkeling van belang geweest, maar geeft de gebruiker ook beter inzicht wat het effect is van het wijzigen van de engine instellingen op de plaatsing van labels. De kaders van overwogen plaatsen voor het plaatsen van labels worden daarbij op de kaart getoond.

Gereserveerde woorden voor gebruik in attribuutvelden voor plaatsing van labels

Er is een lijst van ondersteunde gereserveerde woorden die kunnen worden gebruikt bij het plaatsen van labels middels ‘Data-bepaalde instellingen’.

  • Voor horizontale uitlijning: left, center, right

  • Voor verticale uitlijning: bottom, base, half, top

  • Kleuren kunnen worden gespecificeerd in svg notation, bijvoorbeeld #ff0000

  • Gebruik de booleaanse waarden 1 en 0 of de labels Vet, Cursief, Onderstreept, Doorgestreept moeten worden weergegeven: 1 = ja (waar), 0 = nee (onwaar)

Een combinatie van gereserveerde woorden kan gebruikt worden in 1 veldwaarde bijv.: base right of bottom left.

Tabblad velden

attributes In het tabblad Velden kun je eigenschappen van de velden van de geselecteerde vectorlaag veranderen. De knoppen mActionNewAttribute Nieuwe kolom en mActionDeleteAttribute Verwijder kolom kunnen worden gebruikt wanneer de vectorlaag eerst bewerkbaar gemaakt wordt. Met de knop mActionToggleEditing Bewerken aan/uitzetten kun je wisselen tussen het al dan niet kunnen bewerken van een laag.

Eerst konden alleen kolommen in vectorlagen in PostGIS databases worden toegevoegd en verwijderd, maar wanneer QGIS is gebouwd met de OGR functiebibliotheek van GDAL versie >= 1.9, dan kan dat voor bijna alle door OGR ondersteunde formaten.

Wijzig hulpmiddel

Figure Fields 1:

../../../_images/editwidgetsdialog.png

Dialog to select an edit widget for an attribute column nix

In het tabblad Velden vind je in de lijst van velden ook de kolom Wijzig-hulpmiddel. Deze kolom bevat knoppen waarmee je zelf meer controle kunt krijgen over welke waarden er in een veld kunnen worden opgevoerd en op welke manier. Wanneer je in een kolom op de knop [Wijzig-hulpmiddel] drukt, start er een dialoog, waarmee je verschillende hulpmiddelen voor een veld kunt instellen. Dit zijn de volgende:

  • Lijn wijzigen: hiermee kun je een regel tekst voor tekstvelden opvoeren of alleen getallen voor numerieke velden.

  • Classificatie: Toont een keuzelijst met waarden die al gebruikt zijn voor dat veld wanneer je dat veld ook hebt gebruikt om daarmee de symbologie te classificeren in het tabblad Stijl. Voor elke ‘unieke waarde’ is het dan mogelijk een andere symbologie te gebruiken.

  • Range: Stel een bereik van waarden in die gebruikt mag worden door een minimum en een maximum waarde in te vullen. Daarnaast kun je ook aangeven of de waarde kan worden ingegeven via een schuifbalk of via een spinbox/draaischijf, waarmee je de waarde kunt instellen door deze naar een waarde te draaien.

  • Unieke waarden: De gebruiker kan alleen al gebruikte waarden kiezen. Daarnaast kan er voor gekozen worden om de waarde ‘aanpasbaar’ te maken, daarbij kan de gebruiker de waarden beginnen te typen en zodra er nog maar 1 mogelijk waarde over blijft zal deze automatisch helemaal worden ingevuld. Kies je niet voor ‘aanpasbaar’ dan krijg je een keuzeveld.

  • Bestandsnaam: Hiermee kun je een bestandsnaam invullen door een bestand te selecteren via de bestandskiezer.

  • Aanwezige waarden: Hiermee kun je in een keuzeveld een Omschrijving kiezen, en daarmee wordt een daaraan gekoppelde waarde ingevuld. Daarbij moet je dus eerst een gekoppelde lijst van waarden en omschrijvingen laden (vanuit een laag of vanuit een csv bestand) of je kunt deze hier opbouwen.

  • Enumeratie: Opent een keuzeveld met waarden die gebruikt kunnen worden. Dit wordt momenteel alleen ondersteund voor de postgres database.

  • Niet aanpasbaar: Wanneer deze is ingesteld is het veld niet aanpasbaar en is deze alleen leesbaar.

  • Verborgen: Een verborgen veld is niet zichtbaar. De gebruiker kan de inhoud van het veld niet zien.

  • Aanvinkvakje: Toont een aanvinkvakje en je kunt zelf invullen welke waarde wordt ingevuld wanneer deze aangevinkt en een niet aangevinkt is.

  • Tekstbewerken: Dit opent een tekstveld waarin je meerdere regels tekst kunt ingeven.

  • Kalender: Opent een kalendercomponent waarmee je een datum kunt kiezen die vervolgens wordt ingevuld. Het veldtype moet een tekstveld zijn.

  • Waarde-relatie: Keuzeveld waarde de waarden zijn ingevuld vanuit een gerelateerde tabel. Je kunt hiervoor een laag, een sleutelveld en het veld met te kiezen waarden instellen.

  • UUID Generator: Genereert een veld waarin automatisch een UUID (Universele Unieke IDentifier), een unieke waarde die automatisch wordt gegenereerd wanneer het veld, door de gebruiker,niet wordt ingevuld.

Tabblad Algemeen

general Het tabblad Algemeen is voor een vectorlaag bijna hetzelfde als voor een rasterlaag. Je kunt hiermee verschillende zaken instellen:

  • Wijzig de zichtbare naam van de laag in de legenda

  • Stel een veld dat getoond wordt in het resultaatscherm van Objecten Identificeren

  • Stel een speciaal formulier in voor een vectorlaag geschreven met Qt Creator, een onderdeel van de QT ontwikkeltoolbox die je kunt vinden onder http://qt.digia.com/Product/Developer-Tools/, zie ook forms with qt designer

  • Maak een :guilabel: Ruimtelijke Index aan (alleen voor OGR ondersteunde formaten)

  • Voeg een Init functie voor deze laag. Hiermee kun je de initialisatie van bestaande toegekende QGIS hulpmiddelen voor velden overschrijven

  • De knop [Update Extents] zal de kleinste rechthoek bepalen waarbinnen alle geometriëen van deze laag passen

  • Bekijk of wijzig de ruimtelijke projectie van deze specifieke vectorlaag, met de knop [Geef het CRS]

Daarnaast kun je met het aanvinkvakje checkbox Schaalafhankelijk tonen activeren. Voor het lezen van een aantal gegevensbronnen (via de provider) kun je aanvullende opties opgeven (bijvoorbeeld de te gebruiken encoding, oftewel de karakterset codering). Met de knop [Query Bouwer] is het mogelijk om een Query op te bouwen waarmee slechts een deelverzameling van de gegevens uit de gegevensbron gebruikt wordt in QGIS.

Figure General 1:

../../../_images/vector_general_tab.png

General tab in vector layers properties dialog nix

Tabblad Metadata

metadata Het tabblad Metadata bevat informatie over de laag. Opslagtype, bron, type geometrie het aantal objecten. Onder het kopje Extents kun je informatie vinden over het kaartbereik oftewel de grenzen van de kaart en onder het kopje Ruimtelijk Referentie Systeem vind je informatie over welk coördinaten systeem is gebruikt voor deze laag. Dit is een snelle manier om informatie te vinden over een laag.

Aanvullend kun je laag een titel en een beschrijving geven. Deze informatie zal mee opgeslagen worden in het QGIS projectbestand en zal ook gebruikt en zichtbaar worden gemaakt door de QGIS-server.

Figure Metadata 1:

../../../_images/vector_metadata_tab.png

Metadata tab in vector layers properties dialog nix

Tabblad Acties

action QGIS geeft de mogelijkheid om een actie te starten waarbij gebruik wordt gemaakt van attribuutwaarden. Je kunt meerdere acties per vectorlaag aanmaken waarmee je bijvoorbeeld een ander programma kunt aanroepen waarbij attribuutwaarden als argumenten meegeeft.

Figure Actions 1:

../../../_images/action_dialog.png

Overview action dialog with some sample actions nix

Acties zijn erg handig wanneer je regelmatig een ander programma wilt starten waarbij je waardes meegeeft van een vectorlaag. Een voorbeeld is een zoekactie op internet waarbij een waarde van een vectorlaag wordt meegegeven. Acties kunnen onderverdeeld worden in 6 typen die als volgt gebruik kunnen worden:

  • Generiek, Mac, Windows en Unix acties starten een extern process (programma),

  • Python acties start de uitvoering van python code,

  • Generieke en Python acties zijn overal zichtbaar,

  • Mac, Windows en Unix acties zijn alleen zichtbaar onder die specifieke besturingssystemen (bijv. je kunt drie ‘Bewerk’ acties maken om een bewerkingsprogramma te openen, maar de gebruiker zullen alleen die ‘Bewerk’actie zien voor hun platform).

Er zijn enkele voorbeelden toegevoegd in de dialoog. Je kunt deze laden door te drukken op [Standaard acties toevoegen]. Een voorbeeld is een zoekactie gebaseerd op een attribuutwaarde. Dit concept is gebruikt in volgende discussie.

Het definiëren van Acties

Open het Laag Eigenschappen menu voor een vectorlaag en open het tabblad Acties. Bovenin zie je een lijst van gedefiniëerde actie (leeg) en onderin kun je onder Actie-eigenschappen een nieuwe actie toevoegen. Geef in het veld ‘Naam’ een beschrijvende naam voor de nieuwe actie. Vul in het veld ‘Actie’ in ieder geval de naam (en het pad) van het te starten programma en als argumenten één of meerdere namen van velden waarvan de waarden worden gebruikt door het programma. Wanneer de actie word gestart dan worden de woorden die beginnen met een % teken gevolgd door een veldnaam vervangen door de waarde van dat veld. De speciale tekens %% zullen vervangen worden door de waarde van een nog te selecteren veld in de het scherm Identificatieresultaten of in de Attributentabel (zie using_actions hieronder). Dubbele aanhalingstekens kunnen worden gebruikt om text samen te voegen tot één enkel mee te geven argument aan een programma, script of opdracht. Dubbele aanhalingstekens zullen worden genegeerd wanneer vooraf gegaan door een backslash.

Wanneer je een veldnaam gebruikt waarvan de naam een deel vormt van een ander veldnaam (bijv. col1 en col10) gebruik dan rechte haken om het veldnaam en het % teken (bijv. [\%col10]). Dit voorkomt dat het veld %col10 wordt gelezen als veld %col1 met daarachter de tekst 0. De rechte haken zullen verwijderd worden door QGIS wanneer deze vervangen worden door de veldwaarde. Wanneer je echter rechte haken mee wilt geven gebruik dan een tweede paar haken, bijvoorbeeld: [[\%col10]].

Het venster Identificatieresultaten heeft een (Afgeleid) deel die gegevens bevat die relevant zijn voor die vectorlaag type. Ook deze afgeleide velden kunnen worden gebruikt in een actie door de van van het afgeleide veld vooraf te laten gaan door (Derived).. Een punt vectorlaag heeft bijvoorbeeld de afgeleide velden X en Y. Je kunt die waarde van die velden als volgt gebruiken in een actie met %(Derived).X en %(Derived).Y. De afgeleide waarden zijn alleen beschikbaar in het venster Identieficatieresultaten niet in het venster van de Attributentabel.

Twee voorbeeld acties worden hier getoond:

  • konqueror http://www.google.com/search?q=%nam
  • konqueror http://www.google.com/search?q=%%

In het eerste voorbeeld, wordt de web browser konqueror gestart en een URL meegegeven als argument. Er wordt gegoogled op de waarde van het veld nam van de vectorlaag. Let op dat de applicatie wel gevonden moet kunnen worden anders moet je het ook het pad meegeven bij het aanroepen van de applicatie. Om er zeker van te zijn dat deze werkt, kunnen we de actie herschrijven waarbij we het hele pad meegeven, het eerste voorbeeld wordt dan: /opt/kde3/bin/konqueror http://www.google.com/search?q=\%nam. Dit zal zeker de web browser applicatie opstarten wanneer deze actie wordt gestart.

Het tweede voorbeeld gebruikt de %% notatie, waarbij we niet uitgaan van een bepaald veld. Wanneer de actie wordt gestart, zal %% worden vervangen door de waarde van het geselecteerde veld in de Identificatieresultaten of van de Attributen tabel.

Gebruik van Acties

Acties kunnen worden gestart vanuit het venster Identificatie Resultaten of vanuit het venster Attributen Tabel. Deze kunnen worden geopend door het icoon mActionIdentify Objecten Identificeren of mActionOpenTable Open attributentabel. Om een actie te starten, selecteer een record en gebruik de rechtermuis om het snelmenu te starten, selecteer daarin de actie. De acties komen erin voor met de gegeven naam.

Wanneer je een actie start die de %% notatie gebruikt, selecteer dan eerst het veld dat je wilt meegeven als argument, in het venster Identificatieresultaten of de dialoog Attribuut tabel zodat de waarde van dat veld wordt meegegeven aan de actie.

Hier volgt nog een voorbeeld dat gegevens uit een vectorlaag met plantensoorten haalt en deze met de lokatie naar een bestand schrijft via een de bash opdracht en de echo opdracht (deze bash opdracht werkt alleen onder nix en misschien ook onder osx). De laag heeft velden met de soortnaam soortnaam, de breedtegraad lat en de lengtegraad long. Hier volgt de gedefinieerde actie:

bash -c "echo \"%taxon_name %lat %long\" >> /tmp/species_localities.txt"

Na het achtereenvolgens selecteren van een aantal objecten (planten) en het aanroepen van de actie ziet de inhoud van het bestand er ongeveer zo uit:

Acacia mearnsii -34.0800000000 150.0800000000
Acacia mearnsii -34.9000000000 150.1200000000
Acacia mearnsii -35.2200000000 149.9300000000
Acacia mearnsii -32.2700000000 150.4100000000

Als oefening kunnen we een actie maken voor de vectorlaag lakes waarbij we gegevens opzoeken in google. Eerst moeten we bepalen wat de URL is waarmee we met een zoekterm kunnen zoeken google. Dat doen we door een simpele zoekopdracht te geven en vervolgens uit de adresregel van de webbrowser de gebruikte URL over te nemen. We zien dat het formaat van de URL als volgt is: http://google.com/search?q=qgis, waarin in dit geval qgis de zoekterm is.

  1. Eerst moet de laag lakes zijn geladen.

  2. Open de dialoog Laag Eigenschappen door in de legenda te dubbelklikken op de vectorlaag of door via de rechtermuisknop het snelmenu te open en daarin Eigenschappen te selecteren.

  3. Open het tabblad Acties.

  4. Geef een naam voor de actie bijvoorbeeld Google Search.

  5. Voor de actie moeten we de opdracht geven waarmee de webbrowser wordt opgestart. In dit geval gebruiken we Firefox. Wanneer het programma niet rechtstreeks kan worden opgestart met alleen het programmanaam dan dient het volledige pad te worden meegegeven.

  6. Geef na de naam van de webbrowser de URL toe waarmee we gaan zoeken in Google zonder zoekterm: http://google.com/search?q=

  7. De tekst in het veld Actie ziet er nu als volgt uit: firefox http://google.com/search?q=

  8. Selecteer de keuzelijst die de vectorlaag lakes bevat. Deze keuzelijst staat links van de knop [Voer veld in].

  9. Selecteer in de keuzelijst met veldnamen het veld Names van de vectorlaag lakes en klik op de knop [Voer veld in].

  10. Your action text now looks like this: firefox http://google.com/search?q=%NAMES
  11. Als laatste selecteer de knop [Voer actie in] waarna de gemaakte actie wordt toegevoegd aan de lijst van acties.

Hiermee is deze actie aangemaakt en klaar om te gebruiken. De uiteindelijke tekst van de actie ziet er als volgt uit:

firefox http://google.com/search?q=%NAMES

We kunnen deze actie nu gebruiken. Sluit de dialoog Laag Eigenschappen. Zorg ervoor dat de laag lakes geselecteerd is in de legenda en start de functie Objecten Identificeren. Na selectie van een meer zie je dat de actie beschikbaar is in het resultaat:

Figure Actions 2:

../../../_images/action_identifyaction.png

Select feature and choose action nix

Wanneer we de actie selecteren, zal deze de webbrowser opstarten met gegeven URL en zoekterm. De zoekterm zou uitgebreid kunnen worden door aan de actie ‘+’ toe te voegen en nog een veld mee te geven. Voor de gebruikte laag heeft dat echter weinig zin.

Je kunt meerdere acties definiëren die getoond worden in het scherm Identificatieresultaten.

Je kunt allerlei toepassingen van acties bedenken. Wanneer je de lokaties van foto’s hebt kun je met een actie die foto’s openen in een viewer applicatie.

We kunnen ook meer geavanceerde akties te maken, door bijvoorbeeld gebruik te maken van Python acties.

Normaal gebruiken we absolute paden wanneer we een actie maken om een bestand met een externe toepassing te openen, of eventueel relatieve paden. In het tweede geval is het pad relatief ten opzichte van de locatie van de externe toepassing. Maar wat wanneer we een relatief pad willen gebruiken ten opzichte van de geopende laag (een vectorbestand, zoals een shapefile of een spatialite databasebestand)? De volgende code geeft een mogelijke oplossing:

command = "firefox";
imagerelpath = "images_test/test_image.jpg";
layer = qgis.utils.iface.activeLayer();
import os.path;
layerpath = layer.source() if layer.providerType() == 'ogr' else \
(qgis.core.QgsDataSourceURI(layer.source()).database() \
if layer.providerType() == 'spatialite' else None);
path = os.path.dirname(str(layerpath));
image = os.path.join(path,imagerelpath);
import subprocess;
subprocess.Popen( [command, image ] );

het is goed om te weten dat de actie van het type python is en om de variabelen command en imagerelpath te wijzigen naar gewenste waarden.

Maar wat als we een relatieve pad nodig hebben ten opzichte van het opgeslagen projectbestand? Dat kan met volgende python code:

command="firefox";
imagerelpath="images/test_image.jpg";
projectpath=qgis.core.QgsProject.instance().fileName();
import os.path; path=os.path.dirname(str(projectpath)) \
if projectpath != '' else None;
image=os.path.join(path, imagerelpath);
import subprocess;
subprocess.Popen( [command, image ] );

Het volgende voorbeeld van een Python actie toont hoe je daarmee nieuwe lagen kunt toevoegen aan het project. Bijvoorbeeld het volgende project zal respectievelijk een vector- en een rasterlaag toevoegen. De namen van de bestanden die toegevoegd zullen worden evenals de namen die gegeven wordt aan de lagen, zijn afkomstig uit een geladen vectorbestand, waarop de actie gedefinieerd is, waarbij filename en layname veldnamen zijn die gebruikt worden door de actie.

qgis.utils.iface.addVectorLayer('/yourpath/[% "filename" %].shp','[% "layername" %]', 'ogr')

Om een raster bestand toe te voegen (in dit voorbeeld een tif bestand), wordt dit:

qgis.utils.iface.addRasterLayer('/yourpath/[% "filename" %].tif','[% "layername" %]')

Het tabblad Koppelingen

join Het tabblad Koppelingen geeft de mogelijkheid om vectorlaag uit te breiden met gegevens uit een gegevenstabel door deze te koppelen. Daarvoor moet er wel een sleutelveld bestaan in zowel de vectorlaag als de gegevenstabel met overeenkomstige unieke waarden. QGIS ondersteund momenteel niet spatiale tabel formaten die door OGR worden ondersteund, tekengescheiden tekst tabellen en PostgreSQL (zie figure_joins_1).

Figure Joins 1:

../../../_images/join_attributes.png

Join an attribute table to an existing vector layer nix

Daarnaast geeft de dialoog Vectorkoppeling toevoegen de mogelijkheid om:

  • checkbox Koppellaag in virtueel geheugen ‘cachen’

  • checkbox Attribuutindex aanmaken op het koppelveld

Het tabblad Diagrammen

diagram Met het tabblad Diagrammen kun je diagrammen in je vectorlaag plaatsen (zie figure_diagrams_1).

De huidige implementatie van diagrammen ondersteunt taartpunt- en tekstdiagrammen. Daarbij kan de tekst van verschillende veldwaarden onder elkaar getoond worden met een circel of een vierkant en verdelers. De groote van Diagrammen kan overal gelijk zijn of rechtevenredig verschaald worden naar een veldwaarde. Het plaatsen van diagrammen werkt samen met de nieuwe manier van labels plaatsen, dat wil zeggen wanneer er tijdens het renderen (tekenen) een diagram en een label op dezelfde plaats zouden komen te staan, dan kan dat automatisch worden opgelost. Daarnaast kunnen geplaatste diagram later, door de gebruiker, handmatig verplaatst worden.

Figure Diagrams 1:

../../../_images/diagram_tab.png

Vector properties dialog with diagram tab nix

We zullen een voorbeeld geven waarbij we in de alaska boundary laag een aantal diagrammen met temperatuurgegevens plaatsen. Beide te gebruiken vectorlagen zijn onderdeel van de QGIS sample dataset (zie Voorbeeld Data).

  1. Klik eerst het icoon mActionAddOgrLayer Vectorlaag Toevoegen, ga naar de folder waarin zich de QGIS sample dataset bevindt en laad de twee shapefiles alaska.shp en climate.shp.

  2. Dubbelklik op de laag climate in de kaartlegenda waarna het menu Laag Eigenschappen opent.

  3. Selecteer het tabblad Diagrammen, activeer Toon diagrammen en selecteer Tekstdiagram als Diagram type

  4. Als Achtergrondkleur kiezen we cyaan en we zetten het Formaat van de tekst met Vast formaat op 18 mm.

  5. Selecteer voor Plaatsing RondomPunt.

  6. In het diagram willen we de waarden van de eerste drie kolommen tonen. T_F_JAN, T_F_JUL en T_F_MEAN. Selecteer eerst T_F_JAN als attribuut en klic op de groene [+] knop, daarna T_F_JUL en tenslotte T_F_MEAN.

  7. Druk nu op de knop [Apply] om de diagrammen te tonen in het kaartbeeld van QGIS.

  8. Je kunt nu de wijzigen aanbrengen, zoals het gebruik van andere kleuren voor de verschillende attribuutvelden, of door een andere grootte te kiezen. Figure_diagrams_2 geeft een indruk van het resultaat.

  9. Selecteer tenslotte [Ok].

Figure Diagrams 2:

../../../_images/climate_diagram.png

Diagram from temperature data overlayed on a map nix

In het dialoog die geopend wordt via de menuoptie Instellingen ‣ Opties, bevindt zich het tabblad Overlays waar een algemeen Plaatsingsalgoritme kan worden gekozen. Het algoritme Middelpunt (snelst) is generiek voor de overige algoritmes maken gebruik van de PAL functiebibliotheek. Deze houdt rekening met het plaatsen van diagrammen en labels in verschillende lagen. Voor aanvullende informatie zie Diagram Overlay Plugin.