Importante

La traducción es un esfuerzo comunitario al que puedes unirte. Esta página está actualmente traducida en 93.37%.

14.6. Lesson: Creating Detailed Maps with the Atlas Tool

El diseño de muestreo sistemático está listo y los equipos de campo han cargado las coordenadas GPS en sus sistemas de navegación. También tienen un formulario de datos de campo donde colectarán la información medida en cada parcela de muestreo. Para encontrár más fácilmente su camino a cada parcela de muestreo, ellos han pedido un número de mapas detallados donde se puede ver claramente alguna información sobre el terreno junto con un pequeño conjunto de parcelas de muestreo y otra información sobre el área del mapa. Puedes utilizar la herramienta Atlas para generar automáticamente un número de mapas con un formato común.

El objetivo de esta lección: Aprender a utilizar la herramienta Atlas en QGIS para generar mapas detallados que se puedan imprimir para asistir en el trabajo de inventario de campo.

14.6.1. ★☆☆ Follow Along: Preparing the Print Layout

Antes de que podamos automatizar los mapas detallados de la mayoría del área forestal y nuestras parcelas de muestreo, necesitamos crear una plantilla de mapa con todos los elementos que consideremos útiles para el trabajo de campo. Por supuesto lo más importante será un un estilo apropiado, pero como has visto anteriormente, también necesitarás añadir muchos otros elementos que completen el mapa impreso.

  1. Abra el proyecto QGIS de la lección anterior forest_inventory.qgs. Deberías tener al menos las siguientes capas:

    • forest_stands_2012 (con una transparencia del 50%, relleno verde y líneas de borde verde más oscuro)

    • systematic_plots_clip

    • rautjarvi_aerial

  2. Guarda el proyecto con un nuevo nombre, map_creation.qgs.

Para crear un mapa imprimible, recuerde usar el Administrador de composiciones:

  1. Open Proyecto ► layoutManager Administrador de composiciones….

  2. En el diálogo Administrador de composiciones:

    1. En Nuevo a partir de plantilla, pulse el botón Crear… situado junto a la entrada Diseño vacío.

    2. Nombra tu diseño de impresión forest_map.

    3. Pulse Aceptar. Se crea y abre un nuevo diseño de impresión, mostrando un papel en blanco.

  3. En la ventana Diseño de impresión, asegúrese de que las propiedades están configuradas para un papel A4:

    1. Haga clic con el botón derecho del ratón sobre el papel y seleccione Propiedades de página. El panel Propiedades de página se abre en la parte derecha de la maqueta.

    2. Comprobar Tamaño es A4.

    3. Comprobar Orientación es Paisaje.

  4. Active la pestaña Diseño junto al panel Propiedades de página y establezca Resolución de exportación en 300 dpi.

La composición de un mapa es más fácil si utiliza la cuadrícula del lienzo para colocar los diferentes elementos. Revise la configuración de la cuadrícula de diseño:

  1. En la pestaña Diseño expanda la región Guías y cuadrícula.

  2. Compruebe que Espaciado de la rejilla está ajustado a 10 mm y que Tolerancia de autoensamblado está ajustado a 5 px.

Necesitas activar el uso de la cuadrícula:

  1. Abre el menú Ver.

  2. Habilita Mostrar cuadrícula.

  3. Habilita Ajustar a cuadrícula.

  4. Observe que las opciones para usar Guías están marcadas por defecto, lo que le permite ver líneas de guía cuando mueve elementos en el diseño.

  5. Ahora puede comenzar a agregar elementos a su diseño. Agregue primero un elemento de mapa para que pueda revisar cómo se ve el lienzo del mapa mientras realiza cambios en la simbología de las capas:

    1. Click en el botón addMap Añadir mapa.

    2. Haz clic y arrastra la caja en el lienzo para que el mapa ocupe la mayor parte.

    ../../../_images/composer_1.png

Observa cómo el cursor del ratón se ajústa al lienzo en cuadrícula. Utiliza esta función cuando añadas otros elementos. Si quieres tener más precisión, cambia los ajustes de cuadrícula Espaciado. Si por alguna razón no quieres forzar el cursor a la cuadrícula en algún momento, siemper puedes habilitarlo o deshabilitarlo en el menú Ver.

14.6.2. ★☆☆ Follow Along: Adding Background Map

Deja el diseño abierto pero vuelve al mapa. Vamos a añadir algunos datos de fondo y crear algunos estilos para que el contenido del mapa sea lo más claro posible.

  1. Agregue el raster de fondo basic_map.tif que puede encontrar en la carpeta exercise_data\forestry\.

  2. Si se le solicita, seleccione el SRC ETRS89 / ETRS-TM35FIN para el raster.

    Como puedes ver el mapa base ya está estilizado. Este tipo de rásters cartográficos listos para utililar es muy común. Está creado a partir de datos vectoriales, estilizado en un formato estándar y guardado como un ráster para que no tengas que dar estilo a muchas capas vectoriales y preocuparte de obtener un buen resultado.

  3. Ahora amplía tus parcelas de muestreo, para poder ver solo cuatro o cinco líneas de parcelas.

El estilo actual de las parcelas de muestra no es el mejor:

../../../_images/plots_zoom1-2.png

Mientras que durante los últimos ejercicios, el búfer blanco estaba bien encima de la imagen aérea, ahora que la imagen de fondo es mayoritariamente blanca apenas se ven las etiquetas. Pero, ¿cómo se ve en el diseño de impresión? Vamos a comprobarlo:

  1. Vaya a la ventana de diseño de impresión.

  2. Utilice el botón select Seleccionar/Mover elemento para seleccionar el elemento del mapa en el diseño.

  3. Ve a la pestaña Propiedades de elemento.

  4. Haga clic en setToCanvasExtent Ajustar la extensión del mapa a la del lienzo principal.

  5. Si necesita actualizar el elemento, haga clic en refresh Actualizar la vista previa del mapa.

Evidentemente, esto no es suficiente; hay que hacer que los números de las parcelas sean lo más visibles posible para los equipos sobre el terreno.

14.6.3. ★☆☆ Try Yourself: Changing the Symbology of the Layers

Has estado trabajando en Module: Creating and Exploring a Basic Map con simbología y en Module: Classifying Vector Data con etiquetas. Regresa a estos módulos si necesita refrescarse sobre algunas de las opciones y herramientas disponibles. Su objetivo es conseguir que los lugares parcelas y los nombre sean tan visibles como sea posible, pero siempre permitiendo ver los elementos del mapa de fondo. Puede tomar alguna orientación de esta imagen:

../../../_images/plots_zoom2_symbology.png

Más tarde utilizará el estilo verde de la capa forest_stands_2012. Con el fin de mantenerlo, y tener una visualización de la misma que muestra sólo los bordes del stand:

  1. Haga clic con el botón derecho en forest_stands_2012 y seleccione Duplicar.

  2. Obtendrá una nueva capa llamada forest_stands_2012 copy que puede utilizar para definir un estilo diferente, por ejemplo sin relleno y con bordes rojos.

    Ahora tienes dos visualizaciones diferentes de las masas forestales y puedes decidir cual visualizar en tu mapa detallado.

  3. Vuelva a menudo a la ventana de diseño de impresión para ver cómo quedaría el mapa. Para crear mapas detallados, lo que busca es una simbología que se vea bien no a escala de toda la zona forestal (imagen inferior izquierda), sino a una escala más cercana (imagen inferior derecha). Recuerde utilizar refresh Actualizar la vista previa del mapa y setToCanvasExtent Ajustar la extensión del mapa a la del lienzo principal siempre que cambie el zoom de su mapa o el diseño.

    ../../../_images/composer_2-3.png

14.6.4. ★☆☆ Try Yourself: Create a Basic Map Template

  1. Cuando esté satisfecho con la simbología, podrá añadir más información al mapa impreso. Añade al menos los siguientes elementos:

    • Título.

    • Una barra de escala.

    • Una cuadrícula para tu mapa.

    • Coordenadas en los bordes de la cuadrícula.

  2. Ya ha creado un diseño similar en Module: Laying out the Maps. Vuelve a ese módulo cuando lo necesites. Puedes mirar esta imagen de ejemplo como referencia:

    ../../../_images/map_template1.png
  3. Exporta tu mapa como una imagen y revísalo.

    1. Diseño ► Exportar como Imagen….

    2. Utilice, por ejemplo, la etiqueta formato JPG.

Así es como se verá cuando esté impreso.

14.6.5. ★☆☆ Follow Along: Adding More Elements to the Print Layout

Como probablemente hayas observado en las imágenes sugeridas de plantilla de mapa, hay espacio de sobra en la parte derecha del lienzo. Vamos a ver qué más podría haber ahí. Para los propósitos de nuestro mapa, una leyenda no es realmente necesaria, pero un mapa resumen y algunas cajas de texto podrian añadir valor al mapa.

El mapa resumen ayudará a los equipos de campo a situar al mapa detallado dentro del área forestal general:

  1. Añade otro elemento del mapa al lienzo, justo bajo el texto del título.

  2. En la pestaña Item properties, abre el menú desplegable Resumen.

  3. Ajusta Overview frame a Map 0. Esto crea un rectángulo sombreado encima de un mapa más pequeño representando la extensión visible del mapa grande.

  4. Compruebe también la opción Marco con un color negro y un Grosor de 0.30.

../../../_images/more_elements1.png

Tenga en cuenta que su mapa general no ofrece realmente una descripción general del área forestal, que es lo que desea. Quiere que este mapa represente toda el área de bosque y quiere que muestre solo el mapa de fondo y la capa forest_stands_2012, y no muestre las parcelas de muestra. Y también desea bloquear su vista para que ya no cambie cada vez que cambie la visibilidad o el orden de las capas.

  1. Vuelve al mapa, pero no cierres Imprimir composición.

  2. Haga clic con el botón derecho en la capa forest_stands_2012 y haga clic en Zoom a la extensión de la capa.

  3. Desactivar todas las capas excepto basic_map y forest_stands_2012.

  4. Desplegar la herramienta Gestionar temas de mapa en el panel Capas y seleccione Añadir tema.

  5. Nómbrelo basic_overview.

  6. Vuelva al diseño de impresión.

  7. Con el mapa pequeño seleccionado, haga clic en la etiqueta Ajustar la extensión del mapa a la del lienzo principal para ajustar sus extensiones a lo que puede ver en la ventana del mapa.

  8. Bloquee la vista del mapa general marcando Seguir tema del mapa y seleccionando basic_overview en Propiedades principales.

Ahora su mapa general es más lo que esperaba y su vista no cambiará más. Pero, por supuesto, ahora su mapa detallado ya no muestra los bordes de los rodales ni las parcelas de muestra. Vamos a arreglarlo:

  1. Vaya de nuevo a la ventana del mapa y seleccione las capas que quiere que sean visibles (systematic_plots_clip, forest_stands_2012 copy y Basic_map).

  2. Vuelve a ampliar el zoom para tener visibles solo unas pocas líneas de parcelas de muestreo.

  3. Regrese a la ventana Imprimir diseño.

  4. Seleccione el mapa más grande en su diseño.

  5. En Propiedades de los elementos haga clic en Previsión de actualización y Ajustar la extensión del mapa a la del lienzo principal.

Observa que solo el mapa grande se muestra en la vista actual del mapa, y el mapa resumen pequeño se mantiene en la misma vista en que lo bloqueaste.

También observa que la visión general está mostrando una franja sombreada de la extensión mostrada en el mapa detallado.

../../../_images/more_elements2.png

Tu plantilla está casi lista. Añade ahora dos cajas de texto bajo el mapa, una conteniendo el texto “Detailed map zone: “ y la otra “Remarks: “. Sitúalas para que puedas verlas en la imágen superior.

También puedes añadir una flecha de Norte al mapa resumen:

  1. Seleccione la herramienta northArrow Añadir Flecha Norte.

  2. Haga clic y arrastre un rectángulo en la esquina superior derecha del mapa general.

  3. En Propiedades del artículo Marque Imagen SVG.

  4. Busque en SVG Navegador ► SVG Grupos una imagen de flecha.

  5. En Giro de imagen, marque la casilla Sincronizar con mapa y seleccione Map 1 (el mapa general).

  6. Ajusta el tamaño de la flecha para que quede bien en el mapa pequeño.

El diseño del mapa básico está listo, ahora desea hacer uso de la herramienta Atlas para generar tantos mapas detallados en este formato como considere necesarios.

14.6.6. ★☆☆ Follow Along: Creating an Atlas Coverage

La cobertura Atlas es solo una capa vectorial que se utilizará para generar los detalles de los mapas, un mapa para cada objeto espacial de la cobertura. Para tener una idea de que harás a continuación, aquí hay un conjunto completo de mapas detallados para el área forestal:

../../../_images/preview_atlas_results.png

La cubierta podría ser una capa existente, pero normalmente tiene más sentido crear una para el propósito específico. Vamos a crear una maya de polígonos cubriendo el área forestal:

  1. En la vista de mapa de QGIS, abra Vector ► Herramientas de Investigación ► vectorGrid Crear cuadrícula.

  2. Ajusta la herramienta como se muestra en la imagen:

    ../../../_images/coverage_polygons.png
  3. Guarde el resultado como atlas_coverage.shp.

  4. Estilice la nueva capa atlas_coverage para que los polígonos no tengan relleno.

Los nuevos polígonos están cubriendo toda la superficie forestal y le dan una idea de lo que cada mapa (creado a partir de cada polígono) contendrá.

../../../_images/atlas_coverage.png

14.6.7. ★☆☆ Follow Along: Setting Up the Atlas Tool

El último paso es configurar la herramienta Atlas:

  1. Vuelva al diseño de impresión.

  2. En el panel de la derecha, ve a la pestaña Generación de Atlas.

  3. Configura las opciones como sigue:

    ../../../_images/atlas_settings.png

    Eso le dice a la herramienta Atlas que use las características (polígonos) en :file:ʻatlas_coverage` como el foco para cada mapa detallado. Generará un mapa para cada entidad de la capa. La Capa de cobertura oculta le dice al Atlas que no muestre los polígonos en los mapas de salida.

Una cosa más debe hacerse. Necesitas decirle a la herramienta Atlas qué elemento del mapa será actualizado para cada mapa de salida. Por ahora, probablemente puedes suponer que el mapa a ser cambiado para cada elemento es uno de los que has preparado para contener vistas detalladas de las parcelas de muestreo, que es el elemento más grande del mapa de tu lienzo:

  1. Seleccione el elemento de mapa más grande (Map 0).

  2. Ve a la pestaña Propiedades de elemento.

  3. En la lista, habilita Controlado por Atlas.

  4. Y establece la Márgenes alrededor del elemento en 10%. La extensión de la vista será un 10% mayor que los polígonos, lo que significa que sus mapas de detalle tendrán un solapamiento del 10%.

    ../../../_images/controlled_by_atlas.png

Ahora puedes utilizar la herramienta de vista previa para los mapas Atlas para revisar que todos tus mapas se ven así:

  1. Active la vista previa de Atlas mediante el botón atlas o si la barra de herramientas del Atlas no esta visible, por Atlas ► Vista previa del Atlas.

  2. Puedes utilizar las flechas de la barra del menú de la herramientas Atlas Atlas para moverte a través de los mapas que serán creados.

Tenga en cuenta que algunos de ellos cubren zonas que no son interesantes. Hagamos algo al respecto y salvemos algunos árboles dejando de imprimir esos mapas inútiles.

14.6.8. ★☆☆ Follow Along: Editing the Coverage Layer

En lugar de borrar los polígonos para esas áreas que no son interesantes, puedes también personalizar las etiquetas de texto en tu mapa a generar con contenido de la Tabla de atributos de tu capa de cobertura:

  1. Vuelve a la vista del mapa.

  2. Habilitar la edición de la capa atlas_cobertura.

  3. Selecciona los polígonos que están seleccionados (en amarillo) en la imagen inferior.

  4. Borra los polígonos seleccionados.

  5. Guarda y deshabilita la edición.

../../../_images/remove_polygons.png

Puede volver al diseño de impresión y comprobar que las vistas previas del Atlas utilizan sólo los polígonos que ha dejado en la capa.

La capa de cobertura que estás utilizando todavía no tiene información útil que podrías utilizar para personalizar el contenido de las etiquetas en tu mapa. El primer paso es crearlas, puedes añadir por ejemplo un código de zona para las áreas de los polígonos y un campo con algunas observaciones para que los equipos de campo tengan en cuenta:

  1. Abra la Tabla de atributos de la capa atlas_cobertura.

  2. Habilita la edición.

  3. Utilice la calculadora calculateField para crear y llenar los siguientes dos campos.

  4. Cree un campo llamado Zona de tipo Número entero (integer).

  5. En la casilla Expresión escribe/copia/construye $rownum.

  6. Cree otro campo llamado Observaciones, de tipo Texto (cadena) y un ancho de 255.

  7. En la casilla Expresión escriba 'Sin observaciones.'. Esto establecerá el valor por defecto para todos los polígonos.

El gestor forestal dispondrá de información sobre la zona que puede ser útil a la hora de visitarla. Por ejemplo, la existencia de un puente, un pantano o la ubicación de una especie protegida. La capa atlas_coverage probablemente esté aún en modo edición, añada el siguiente texto en el campo Observaciones a los polígonos correspondientes (haga doble clic en la celda para editarla):

  • Para la Zona 2: Puente al norte de la parcela 19. Ardilla siberiana entre p_13 y p_14.

  • Para la Zona 6: Dificultad de tránsito en pantano al Norte del lago.

  • Para la Zona 7: Ardilla siberiana al sureste de p_94.

  • Desactiva y guarda la edición.

Casi listo, ahora tienes que decirle a la herramienta Atlas que quieres que algunas de las etiquetas de texto utilicen la información de la tabla de atributos de la capa atlas_coverage.

  1. Vuelve a Imprimir composición.

  2. Seleccione la etiqueta de texto que contiene Mapa detallado....

  3. Establezca el tamaño de Fuente de letra en 12.

  4. Ajusta el cursor al final del texto en la etiqueta.

  5. En la pestaña propiedades del elemento, dentro de propiedades Principales haga click en Insertar o Editar una Expresión….

  6. En la Lista de funciones haga doble clic en el campo Zona dentro de Campos y valores.

  7. Haz clic en OK.

  8. El texto dentro de la casilla en Propiedades de elemento debe mostrar Detallar zona de inventario del mapa: [% "Zona" %]. Tenga en cuenta que [% "Zona" %] se sustituirá por el valor del campo Zone de la característica correspondiente de la capa atlas_coverage.

  9. Comprueba el contenido de la etiqueta mirando diferentes mapas de vista previa de Atlas.

  10. Haga lo mismo para las etiquetas con el texto Observaciones: utilizando el campo con la información de la zona. Puede dejar una línea de interrupción antes de introducir la expresión. Puede ver el resultado para la vista previa de la zona 2 en la siguiente imagen:

    ../../../_images/preview_zone2.png
  11. Utiliza la vista previa del Atlas para navegar a través de todos los mapas que crearás pronto, ¡y disfrútalo!

14.6.9. ★☆☆ Follow Along: Printing the Maps

Por último pero no menos importante, imprimir o exportar tus mapas a archivos de imagen o archivos PDF. Puedes utilizar Atlas ► Export Atlas as Images… o Atlas ► Export Atlas as PDF…. Actualmente la exportación a formato SGV y funciona correctamente y dará malos resultados.

Vamos a imprimir los mapas como un archivo PDF que puedes enviar a la oficina de campo para imprimir:

  1. Ve a la pestaña Atlas generation en el panel derecho.

  2. En Output activa Single file export when possible. Esto pondrá todos los mapas juntos en un archivo PDF, si esta opción no está activada obtendrás un archivo para cada mapa.

  3. Abre Diseño ► Exportar como PDF….

  4. Guarde el archivo PDF como inventory_2012_maps.pdf en su carpeta :file:`exercise_dataforestrysampligmap_creation`.

  5. Abre el archivo PDF para comprobar que todo fué como esperabas.

  6. Podrías crear imágenes para cada mapa así de fácil (recuerda desactivar la creación de archivos individuales), aquí puedes ver las miniaturas de las imágenes que serían creadas:

    ../../../_images/maps_as_images.png
  7. En Diseño de impresión, pulse fileSave Guardar para guardar los cambios de diseño de impresión en el proyecto. Esto también guarda el archivo del proyecto. Puede volver a abrir el proyecto en cualquier momento y ejecutar o editar el atlas.

    También es posible guardar el mapa como una plantilla de diseño como forestry_atlas.qpt en su carpeta exercise_dataforestrymap_creation`. Utilice :menuselection:`Diseño --> Guardar como plantilla. Podrá utilizar esta plantilla una y otra vez en otros proyectos.

  8. Cierre la Composición de impresión y el proyecto.

14.6.10. In Conclusion

Te las has arreglado para crear un mapa de plantilla que puede ser utilizado para generar automáticamente mapas detallados para ser utilizados para ayudar a navegar hasta las diferentes parcelas. Como observaste, no fué una tarea fácil pero el beneficio vendrá cuando necesites crear mapas similares para otras regiones utilizando la plantilla que acabas de guardar.

14.6.11. What’s Next?

En la próxima lección, verá cómo puede utilizar los datos LiDAR para crear un MDE y luego utilizarlo para mejorar la visibilidad de sus datos y mapas.