Outdated version of the documentation. Find the latest one here.

.

QGIS Configuration

QGIS is highly configurable through the Settings menu. Choose between Panels, Toolbars, Project Properties, Options and Customization.

Note

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described above could be located in the View menu (Panels and Toolbars) or in Project for Options.

Panels and Toolbars

In the Panels‣ menu, you can switch on and off QGIS widgets. The Toolbars‣ menu provides the possibility to switch on and off icon groups in the QGIS toolbar (see figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

The Panels and Toolbars menu nix

Tip

Activating the QGIS Overview

In QGIS, you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu nix Settings ‣ Panels or win View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Tip

Show Log Messages

It’s possible to track the QGIS messages. You can activate checkbox Log Messages in the menu nix Settings ‣ Panels or win View ‣ Panels and follow the messages that appear in the different tabs during loading and operation.

Proprietăţi Proiect

In the properties window for the project under nix Settings ‣ Project Properties (kde) or nix win Project ‣ Project Properties (Gnome), you can set project-specific options. These include:

  • In the General menu, the project title, selection and background color, layer units, precision, and the option to save relative paths to layers can be defined. If the CRS transformation is on, you can choose an ellipsoid for distance calculations. You can define the canvas units (only used when CRS transformation is disabled) and the precision of decimal places to use. You can also define a project scale list, which overrides the global predefined scales.
  • The CRS menu enables you to choose the Coordinate Reference System for this project, and to enable on-the-fly re-projection of raster and vector layers when displaying layers from a different CRS.
  • With the third Identify layers menu, you set (or disable) which layers will respond to the identify tool (see the “Map tools” paragraph from the Opţiuni section to enable identifying of multiple layers).
  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.
  • The tab OWS Server allows you to define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions.
  • The Macros menu is used to edit Python macros for projects. Currently, only three macros are available: openProject(), saveProject() and closeProject().

Figure Macro Menu:

../../../_images/macro.png

Macro settings in QGIS

  • Meniul Relațiilor este folosit pentru a defini relațiile 1:n. Relațiile sunt definite în fereastra proprietăților proiectului. O dată ce există relații pentru un strat, un nou element de interfață cu utilizatorul, de tip formular (de exemplu, atunci când se identifică o entitate și se deschide formularul acesteia) va lista entitățile aferente. Acest lucru oferă o modalitate puternică de a exprima, de exemplu, istoria inspecțiilor de-a lungul unei conducte sau a unui segment de drum. Puteți afla mai multe despre suportul pentru relațiile 1:n în Secțiunea Creating one to many relations.

Opţiuni

mActionOptions Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ mActionOptions Options. The tabs where you can customize your options are described below.

Meniu General

Aplicație

  • Select the Style (QGIS restart required) selectstring and choose between ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlooks’ (nix).
  • Define the Icon theme selectstring. Currently only ‘default’ is possible.
  • Define the Icon size selectstring.
  • Define the Font. Choose between radiobuttonon Qt default and a user-defined font.
  • Change the Timeout for timed messages or dialogs selectstring.
  • checkbox Ascundere fereastră de întâmpinare

  • checkbox Afișează sfaturi la pornire

  • checkbox Titluri îngroșate pentru casetele grupurilor

  • checkbox Stilizare QGIS pentru casetele grupurilor

  • checkbox Se folosește fereastra nativă de alegere a culorii

  • checkbox Se folosește fereastra interactivă de alegere a culorii

  • checkbox Custom side bar style
  • checkbox Suport experimental de rotație a canevasului (este necesar restartul)

Fișierele proiectului

  • Open project on launch selectstring (choose between ‘New’, ‘Most recent’ and ‘Specific’). When choosing ‘Specific’ use the browsebutton to define a project.
  • checkbox Create new project from default project. You have the possibility to press on Set current project as default or on Reset default. You can browse through your files and define a directory where you find your user-defined project templates. This will be added to Project ‣ New From Template. If you first activate checkbox Create new project from default project and then save a project in the project templates folder.
  • checkbox :guilabel:`Se solicită salvarea modifcărilor din proiect și din sursa de date, atunci când este necesar

  • checkbox Se solicită confirmarea atunci când un strat va fi eliminat

  • checkbox Avertizare la deschiderea unui fișier de proiect salvat cu o versiune de QGIS mai veche

  • Enable macros selectstring. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

Meniul Sistemului

Mediu

Variabilele de mediu ale sistemului pot fi acum vizualizate, iar multe dintre ele pot fi configurate în grupul Environment (v. figure_environment_variables). Acest lucru este util pentru platforme, cum ar fi Mac, unde interfața unei aplicații nu moștenește în mod obligatoriu variabilele de mediu ale utilizatorului. De asemenea, este util și la stabilirea/vizualizarea variabilelor de mediu pentru seturile de instrumente externe, controlate de instrumentele Processing (ex.: SAGA, GRASS), și pentru a depana ieșirile provenite din anumite secțiuni ale codului sursă.

  • checkbox Use custom variables (restart required - include separators). You can [Add] and [Remove] variables. Already-defined environment variables are displayed in Current environment variables, and it’s possible to filter them by activating checkbox Show only QGIS-specific variables.

Figure System Environment:

../../../_images/sys-env-options.png

System environment variables in QGIS

Căile plugin-urilor

[Adăugați] sau [Eliminați] :Căil(e) către bibliotecile suplimentare cu plugin-uri C++`

Meniul Surselor de Date

Atributele şi tabela entității

  • checkbox Deschidere tabelă de atribute într-o fereastră detașabilă (este necesară restartarea QGIS)

  • checkbox Copy geometry in WKT representation from attribute table. When using mActionCopySelected Copy selected rows to clipboard from the Attribute table dialog, this has the result that the coordinates of points or vertices are also copied to the clipboard.
  • Attribute table behaviour selectstring. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Attribute table row cache selectnumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representation for NULL values. Here, you can define a value for data fields containing a NULL value.

Gestiunea surselor de date

  • Scan for valid items in the browser dock selectstring. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compressed files (.zip) in browser dock selectstring. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Prompt for raster sublayers when opening. Some rasters support sublayers — they are called subdatasets in GDAL. An example is netCDF files — if there are many netCDF variables, GDAL sees every variable as a subdataset. The option allows you to control how to deal with sublayers when a file with sublayers is opened. You have the following choices:
    • ‘Always’: Always ask (if there are existing sublayers)
    • ‘If needed’: Ask if layer has no bands, but has sublayers
    • ‘Never’: Never prompt, will not load anything
    • ‘Load all’: Never prompt, but load all sublayers
  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Adăugare straturi PostGIS printr-un dublu clic și selectarea modului extins

  • checkbox Adăugare straturi Oracle printr-un dublu clic și selectarea modului extins

Meniul de Randare

Rendering behaviour

  • checkbox În mod implicit, noile straturi adăugate hărții ar trebui să fie afișate

  • checkbox Se folosește memoria tampon, acolo unde este posibil, pentru a se accelera redesenarea

  • checkbox Straturile se randează în paralel, utilizând mai multe nuclee CPU

  • checkbox Max cores to use
  • Map update interval (default to 250 ms)
  • checkbox Enable feature simplication by default for newly added layers
  • Pragul de Simplificare

  • checkbox Simplificarea are loc la furnizor, dacă este posibil

  • Scara maximă la care stratul ar trebui să fie simplificat

Calitatea randării

  • checkbox Liniile vor apărea mai puțin zimțate, cu prețul unei pierderi de performanță la desenare

Rastere

  • With RGB band selection, you can define the number for the Red, Green and Blue band.

Îmbunătăţirea contrastului

  • Single band gray selectstring. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectstring. Options are ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’.
  • Limitele reducerii numărului cumulat de pixeli

  • Multiplicator pentru Abaterea Standard

Depanare

  • checkbox Map canvas refresh

Meniul Culorilor

This menu allows you to add some custom color that you can find in each color dialog window of the renderers. You will see a set of predefined colors in the tab: you can delete or edit all of them. Moreover you can add the color you want and perform some copy and paste operations. Finally you can export the color set as a gpl file or import them.

Meniul Canevasului și Legendei

Default map appearance (overridden by project properties)

  • Definirea Selecției culorii și a Culorii Fundalului.

Legenda stratului

  • Double click action in legend selectstring. You can either ‘Open layer properties’ or ‘Open attribute table’ with the double click.
  • The following Legend item styles are possible:
    • checkbox Capitalizarea Numelor Straturilor

    • checkbox Nume de straturi îngroșate

    • checkbox Nume de grupuri îngroșate

    • checkbox Afișează numele atributului de clasificare

    • checkbox Creează pictogramele rasterului (poate dura mult)

Meniul Instrumentelor pentru Hartă

This menu offers some options regarding the behaviour of the Identify tool.

  • Search radius for identifying and displaying map tips is a tolerance factor expressed as a percentage of the map width. This means the identify tool will depict results as long as you click within this tolerance.
  • Highlight color allows you to choose with which color should features being identified are to be highlighted.
  • Buffer expressed as a percentage of the map width, determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width expressed as a percentage of the map width, determines how thick should the outline of a highlighted object be.

Instrumentul de măsură

  • Definește Culoarea benzii elastice a instrumentelor de măsurare

  • Definire Număr de zecimale

  • checkbox Keep base unit
  • Preferred measurements units radiobuttonon (‘Meters’, ‘Feet’, ‘Nautical Miles’ or ‘Degrees’)`
  • Preferred angle units radiobuttonon (‘Degrees’, ‘Radians’ or ‘Gon’)

Deplasare și transfocare

  • Define Mouse wheel action selectstring (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Definire Factor de mărire pentru rotița mouse-ului

Scări predefinite

Here, you find a list of predefined scales. With the [+] and [-] buttons you can add or remove your individual scales.

Meniul Compozitorului

Valori implicite pentru compoziție

You can define the Default font here.

Aspectul grilei

  • Define the Grid style selectstring (‘Solid’, ‘Dots’, ‘Crosses’)
  • Definiți Culoarea grilei

Grilă și de ghidaje implicite

  • Define the Grid spacing selectnumber
  • Define the Grid offset selectnumber for x and y
  • Define the Snap tolerance selectnumber

Meniul de Digitizare

Creare entitate

  • checkbox Suppress attributes pop-up windows after each created feature
  • checkbox Se reutilizează ultimele valori introduse ale atributelor

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Bandă elastică

  • Define Rubberband Line width and Line color

Acroșare

  • checkbox Deschidere opțiuni de acroșare într-o fereastră detașabilă (este necesară restartarea QGIS)

  • Define Default snap mode selectstring (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Define Default snapping tolerance in map units or pixels
  • Definește Raza de căutare pentru editarea vertecșilor, în unități de hartă sau în pixeli

Simbolurile vertexului

  • checkbox Arată simbolurile numai pentru entitățile selectate

  • Define vertex Marker style selectstring (‘Cross’ (default), ‘Semi transparent circle’ or ‘None’)
  • Definește Dimensiunea simbolului pentru vertex

Instrument pentru curba de decalare

The next 3 options refer to the mActionOffsetCurve Offset Curve tool in Digitizare avansată. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Îmbinare stiluri

  • Segmentele cvadrantului

  • Miter limit

Meniul GDAL

GDAL is a data exchange library for raster files. In this tab, you can Edit create options and Edit Pyramids Options of the raster formats. Define which GDAL driver is to be used for a raster format, as in some cases more than one GDAL driver is available.

Meniul CRS-ului

CRS-ul implicit pentru noile proiecte

  • radiobuttonoff Don’t enable ‘on the fly’ reprojection
  • radiobuttonon Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radiobuttonoff Enable ‘on the fly’ reprojection by default
  • Select a CRS and Noile proiecte vor începe întotdeauna cu acest CRS

CRS-ul pentru noile straturi

This area allows you to define the action to take when a new layer is created, or when a layer without a CRS is loaded.

  • radiobuttonon Prompt for CRS
  • radiobuttonoff Use project CRS
  • radiobuttonoff Use default CRS

Transformări de datum implicite

  • checkbox Cerere de transformare a datum-ului, atunci când nu este definit unul implicit

  • If you have worked with the ‘on-the-fly’ CRS transformation you can see the result of the transformation in the window below. You can find information about ‘Source CRS’ and ‘Destination CRS’ as well as ‘Source datum transform’ and ‘Destination datum transform’.

Meniul Limbii

  • checkbox Overwrite system locale and Locale to use instead
  • Informaţii despre limba sistemului activ

Meniul Reţelei

Generalități

  • Define WMS search address, default is http://geopole.org/wms/search?search=\%1\&type=rss
  • Definire Timpul de așteptare pentru cererile de rețea (ms) - implicit este 60000

  • Definire Perioada de expirare prestabilită pentru plăcuțele WMS-C/WMTS (ore) - implicit este 24

  • Define Maximum de încercări, în cazul erorilor de obținere a plăcuței

  • Definire User-Agent

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

Setările memoriei tampon

Definirea Directorului și a unei Dimensiuni pentru memoria tampon.

  • checkbox Use proxy for web access and define ‘Host’, ‘Port’, ‘User’, and ‘Password’.
  • Set the Proxy type selectstring according to your needs.
    • Default Proxy: Proxy is determined based on the application proxy set using
    • Socks5Proxy: Generic proxy for any kind of connection. Supports TCP, UDP, binding to a port (incoming connections) and authentication.
    • HttpProxy: Implemented using the “CONNECT” command, supports only outgoing TCP connections; supports authentication.
    • HttpCachingProxy: Implemented using normal HTTP commands, it is useful only in the context of HTTP requests.
    • FtpCachingProxy: Implemented using an FTP proxy, it is useful only in the context of FTP requests.

Excluding some URLs can be added to the text box below the proxy settings (see Figure_Network_Tab).

If you need more detailed information about the different proxy settings, please refer to the manual of the underlying QT library documentation at http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Tip

Folosirea Proxi-urilor

Using proxies can sometimes be tricky. It is useful to proceed by ‘trial and error’ with the above proxy types, to check to see if they succeed in your case.

You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

  • nix Settings are saved in a text file: $HOME/.config/QGIS/QGIS2.conf
  • osx You can find your settings in: $HOME/Library/Preferences/org.qgis.qgis.plist
  • win Settings are stored in the registry under: HKEY\CURRENT_USER\Software\QGIS\qgis

Personalizare

The customization tool lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you have a lot of plugins installed that you never use and that are filling your screen.

Figure Customization 1:

../../../_images/customization.png

The Customization dialog nix

QGIS Customization is divided into five groups. In checkbox Menus, you can hide entries in the Menu bar. In checkbox Panels, you find the panel windows. Panel windows are applications that can be started and used as a floating, top-level window or embedded to the QGIS main window as a docked widget (see also Panels and Toolbars). In the checkbox Status Bar, features like the coordinate information can be deactivated. In checkbox Toolbars, you can (de)activate the toolbar icons of QGIS, and in checkbox Widgets, you can (de)activate dialogs as well as their buttons.

With mActionSelect Switch to catching widgets in main application, you can click on elements in QGIS that you want to be hidden and find the corresponding entry in Customization (see figure_customization). You can also save your various setups for different use cases as well. Before your changes are applied, you need to restart QGIS.