Outdated version of the documentation. Find the latest one here.

.

QGIS Configureren

QGIS is zeer goed te configuren via het menu Extra. Kies tussen Panelen, Werkbalken, Project instellingen, Opties en Aanpassingen.

Panelen en Werkbalken

Via het menu Panelen‣ kun je QGIS panelen aan of uitzetten. Via het menu Werkbalken‣ kun je werkbalken toevoegen of verwijderen in de ruimte gereserveerd voor werkbalken in QGIS (zie figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

Het menu Panelen en Werkbalken nix

Tip

Het activeren van Kaartoverzicht in QGIS

In QGIS kun je een paneel activeren die een overzichtskaart toon met de volledige extent van de toegevoegde lagen. Activeer deze via nix Extra ‣ Panelen of win Beeld ‣ Panelen. Binnen de overzichtskaart wordt een rechthoek getoond die overeenkomt met de gebiedsgrenzen van het getoonde kaartbeeld. Hiermee zie je snel welk deel van kaart je momenteel bekijkt. Labels worden niet getoond in de overzichtskaart ook al zijn de lagen zo ingesteld dat er labels moeten worden getoond. Wanneer je het rode vierkant in de overzichtskaart versleept met ingehouden linkermuisknop, zal het kaartbeeld zich overeenkomstig aanpassen.

Tip

Toon Logboekmeldingen

Het is mogelijk om gegenereerde logboekmeldingen van QGIS te bekijken. Deze kan geactiveerd worden door het aanvinkvakje checkboxLogboekmeldingen aan te vinken in het menu nix Extra ‣ Panelen of win Beeld ‣ Panelen. Vervolgens kun je de meldingen volgen die worden gegeneerd tijdens het opstarten en gebruik van QGIS.

Projectinstellingen

In the properties window for the project under nix Settings ‣ Project Properties or win Project ‣ Project Properties, you can set project-specific options. These include:

  • Onder het tabblad Algemeen kan men het volgende instellen; de projecttitel, de selectie- en achtergrondkleur, de laageenheden, de precisie (aantal decimalen van coördinaten) en of paden relatief of absoluut moeten worden opgeslagen. Wanneer gelijktijdige CRS transformatie is ingeschakeld, kun je een ellipoïde kiezen die gebruikt kan worden voor afstandsberekeningen. De te gebruiken eenheden en de precisie in aantal decimalen kunnen worden ingesteld. Je kun er ook een lijst van kaartschalen voor het project instellen die de globale ingestelde lijst van kaartschalen overschrijft.

  • In het tabblad Ruimtelijke Referentie Systeem (CRS) kun je de gewenste CRS voor dit project instellen. Daarnaast kun je instellen dat gelijktijdige CRS transformatie moet worden gebruikt wanneer er lagen aanwezig zijn met verschillende CRS.

  • In het derde tabblad Identificeerbare Lagen kun je instellen welke lagen zullen reageren wanneer Objecten Indentificeren wordt gebruikt. (zie de paragraaf “Kaartgereedschap” van :ref`gui_options` waarin het gebruik hiervan wordt uitgelegd.)

  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them.
  • Het tabblad OWS Server geeft de mogelijkheid om informatie in te vullen die meegegeven wordt door de WMS en WFS Capabilities die door QGIS Server terug wordt gegeven plus de extent, het maximale bereik van de kaart en het beperken van mogelijke Coördinaten Referentie Systemen.

  • Het menu Macro’s kan worden gebruikt om Python functies te schrijven die als module mee worden opgeslagen in het QGIS projectbestand. Momenteel zijn er drie macro’s beschikbaar: “openProject()”, “saveProject()” en “closeProject()”.

Figure Macro Menu:

../../../_images/macro.png

Macro instellingen in QGIS

  • Het menu Relaties wordt gebruikt om 1:n join relaties mee vast te leggen. Deze relaties worden vastgelegd in het project eigenschappen dialoog. Wanneer een eigenschap is aangemaakt voor een laag, dan zal het object formulier een nieuwe item bevatten waarmee de gerelateerde objecten zichtbaar getoond worden. Dit biedt een krachtige manier waarmee bijvoorbeeld de onderhoudshistorie van een leiding of een wegdeel kan worden vastgelegd. Lees meer over de ondersteuning van 1:n relaties in Een tot veel-relaties maken.

Opties

mActionOptions Voor het instellen van globale instellingen van QGIS gebruik de dialoog Opties. Open deze via het menu Extra ‣ mActionOptions Opties. Voor het wijzigen van de instellingen zijn de volgende tabbladen beschikbaar:

Tabblad Algemeen

Applicatie

  • Maak onder Stijl (Herstart QGIS nodig) selectstring en kies tussen ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ en ‘Cleanlooks’ (nix).

  • Geef het Icoon Thema selectstring. Momenteel is alleen ‘standaard’ beschikbaar.

  • Geef de Icoongrootte selectstring.

  • Geef het Lettertype. Kies tussen het keuzerondje radiobuttonon Qt standaard of maak een keuze uit een systeem lettertype.

  • Wijzig de Zichtbaarheidstijd voor berichten of dialogen selectstring.

  • checkbox Verberg het openingsscherm tijdens opstarten

  • checkbox Tips tonen tijdens het opstarten

  • checkbox Groepsvak titels vet weergeven

  • checkbox Groepsvakken in QGIS stijl

  • checkbox Gebruik direkt bijwerken kleurkeuze dialoog

Projectbestanden

  • Open project bij het opstarten selectstring (kies tussen ‘Nieuw’. ‘Meest recente’ en ‘Specifiek’). Wanneer men kiest voor ‘Specifiek’ blader naar het project met browsebutton waarmee opgestart moet worden.

  • checkbox Maak een nieuw project op basis van het standaardproject. Men heeft de mogelijkheid om het huidige project in te stellen als standaard project met de knop [Huidige project als standaardproject opslaan] of terug te gaan naar het standaardproject met de knop [Standaard terugzetten]. Men kan een folder (Sjabloonmap) instellen waar de project templates komen te staan met de knop [Bladeren]. Er zal een template project gekozen kunnen worden bij de menu optie Project ‣ Nieuw van Template, wanneer eerst het aanvinkvak checkbox Maak een nieuw project op basis van het standaardproject is geactiveerd en vervolgens het project in de folder met templates is opgeslagen.

  • checkbox Geef een waarschuwing om project en gewijzigde databronnen op te slaan indien nodig

  • checkbox Geef een waarschuwing bij het openen van een projectfile uit een oudere versie van QGIS

  • Macro’s toestaan selectstring. Je kunt daarbij kiezen tussen ‘Nooit’, ‘Vragen’, ‘Alleen voor deze sessie’ en ‘Altijd (wordt afgeraden)’.

Systeem Menu

Systeem

De Systeem omgevingsvariabelen kunnen nu worden bekeken en deze kunnen ook worden geconfigureerd via het onderdeel systeemvariabelen (zie figuur figure_environment_variables). Dit is erg handig voor besturingssystemen zoals die op de Mac waarbij voor een grafische applicatie de omgevingsvariabelen zoals men die kan opvragen via de terminal niet dezelfde hoeven te zijn als die door het programma worden gebruikt. Dit kan ook handig zijn om omgevingsvariabelen te zetten die gebruikt worden door externe tools die o.a. gebruikt worden door de processing toolbox, bijv. SAGA, GRASS; en die ook gebruikt kan worden zodat zodat bepaalde onderdelen van de broncode meer output genereren voor het opsporen van fouten (debugging).

  • checkbox Gebruik aangepaste systeemvariabelen (herstart noodzakelijk - voeg scheidingstekens toe). Je kunt nieuwe systeemvariabelen [Toevoegen] en met [Verwijder] deze weer verwijderen. Bestaande omgevingsvariabelen worden getoond met Huidige systeemvariabelen –>, en het is mogelijk om alleen de specifieke systeemvariabelen voor QGIS te tonen met het aanvinkvak checkbox Alleen QGIS-specifieke variabelen tonen.

Figure System Environment:

../../../_images/sys-env-options.png

Systeem omgevingsvariabelen in QGIS

Plugin paden

[Toevoegen] of [Verwijder] Pad(en) om voor additionele C++ pluginbibliotheken te zoeken

Databronnen Menu

Object-attributen en tabel

  • checkbox Open de attributentabel in een ‘dock-window’ (QGIS herstart vereist)

  • checkbox Kopiëer geometrie in WKT formaat van attributen tabel. Wanneer de functie mActionCopySelected Kopiëer geselecteerde rijen naar klembord in het Attributentabel menu gebruikt wordt, dan zullen ook de coördinaten van de punten of hoekpunten worden gekopieerd naar het klembord.

  • Attributentabel gedrag selectstring. Er zijn drie mogelijkheden: ‘Alle attributen tonen’ (standaard), ‘Geselecteerde objecten tonen’ en ‘Toon objecten in huidig kaartbeeld’

  • Attributentabel rijcache selectnumber. Deze instelling zorgt ervoor dat het gegeven aantal rijen in de cache (=geheugenruimte) wordt opgeslagen, zodat deze gegevens sneller beschikbaar zijn en het werken met de attributentabel ook sneller is. De gegevens in de cache worden verwijderen tijdens het sluiten van de dialoog attributentabel.

  • Weergave van NULL waarden Hier kun je een een andere waarde opgeven om te laten zien, voor velden die een NULL waarde bevatten.

Omgang met databron

  • Zoek naar geldige items in het browser dock selectstring. Je kunt kiezen tussen ‘Extentie controleren’ en ‘Bestandsinhoud controleren’.

  • Zoek naar de inhoud van gecomprimeerde (.zip) bestanden in het browser-dock selectstring. ‘Nee’, ‘Basic scan’ en ‘Volledige scan’ zijn mogelijk.

  • Suggereer raster sublagen tijdens het openen. Enkele rasterformaten ondersteunen sublagen — deze worden subdatasets in GDAL genoemd. Een voorbeeld is het netCDF bestandsformaat - wanneer er veel netCDF variabelen zijn, dan ziet GDAL elke variabele als een subdataset. De optie wordt gebruikt om controle te krijgen hoe om te gaan, tijdens het laden van, met een rasterfile die sublagen bevat. De volgende keuzes zijn mogelijk:

    • ‘Altijd’: Altijd vragen (wanneer er sublagen aanwezig zijn)

    • ‘indien nodig’: Vraag wanneer de laag geen bandlagen maar wel sublagen heeft

    • ‘Nooit’: Geen vragen, laad geen sublagen

    • ‘Laad alles’: Geen vragen gewoon alle sublagen laden

  • checkbox Vastgelegde shapefile codering negeren. Wanneer een shapefile informatie over gebruikte karaktercodering bevat, kan men hier aangeven of QGIS die informatie moet negeren.

  • checkbox PostGIS lagen toevoegen door dubbelklikken en selectie in uitgebreide modus

  • checkbox PostGIS lagen toevoegen door dubbelklikken en selectie in uitgebreide modus

Tabblad Rendering

Rendering gedrag

  • checkbox Standaard zullen nieuwe toegevoegde lagen aan de kaart direct worden afgebeeld

  • checkbox Enable back buffer
  • checkbox Gebruik de cache voor het tekenen indien mogelijk om het hertekenen te versnellen

  • checkbox Objectvereenvoudiging standaard toepassen voor nieuwe lagen

  • checkbox Vereenvoudigen bij de bron indien mogelijk

Rendering kwaliteit

  • checkbox Maak de lijnen minder rafelig ten koste van de tijd dat het tekenen kost

  • checkbox Fix problems with incorrectly filled polygons

Rasters

  • met RGB-band selectie kan men het nummer voor de Rode, de Groene en de Blauwe band opgeven.

Contrast enhancement

  • Enkelbands grijs selectstring. Een enkelbands grijs kan de waarden hebben ‘Geen Stretch’ ‘Stretch tot MinMax’, ‘Stretch en Clip tot MinMax’ en ook ‘Clip naar MinMax’.

  • Multiband kleur (byte/band) selectstring. Mogelijke keuzes zijn ‘Geen Stretch’, ‘Stretch tot MinMax’, ‘Stretch en Clip tot MinMax’ en ‘Clip naar MinMax’.

  • Multiband kleur (>byte/band) selectstring. Mogelijke keuzes zijn ‘Geen stretch’, ‘Stretch tot MinMax’, ‘Stretch en Clip tot MinMax’ en ‘Clip naar MinMax’.

  • Bereik (minimum/maximum) selectstring. Mogelijke keuzes zijn ‘Cumulatieve telling deel van pixels’, ‘Minimum/Maximum’, ‘Gemiddelde +/- standaardafwijking’

  • Bereik Cumulatieve telling van pixels

  • Vermenigvuldigingsfactor voor standaardafwijking

Debuggen

  • checkbox Kaartvenster update

Kaartvenster en Legenda Menu

Standaard waarden kaart (worden door projectwaarden overschreven)

  • Wijzig de Selectiekleur en de Achtergrondkleur.

Legenda lagen

  • Dubbelklik actie in legenda selectstring. Kies tussen ‘Open laag eigenschappen’ of ‘Open attributentabel’ voor de dubbelklik actie.

  • De volgende Legenda onderdeel stijlen zijn mogelijk:

    • checkbox Laagnamen in hoofdletters

    • checkbox Laagnamen vet

    • checkbox Groepnamen vet

    • checkbox Toon classificatie-attribuutnamen

    • checkbox Raster iconen aanmaken (kan langzaam zijn)

    • checkbox Voeg nieuwe lagen toe aan geselecteerde of huidige groep

Tabblad Kaart gereedschap

Identify

  • checkbox Open identify results in a dock window (QGIS restart required)
  • The Mode setting determines which layers will be shown by the Identify tool. By switching to ‘Top down’ or ‘Top down, stop at first’ instead of ‘Current layer’, attributes for all identifiable layers will be shown with the Identify tool. In QGIS 2.2. you can now use a ‘Layer selection’ option so that you can choose with the left-mouse menu which layer you want to identify (see the “Project properties” section under Projecten to set which layers are identifiable).
  • checkbox Open feature form, if a single feature is identified
  • Define Search radius for identifying and displaying map tips as a percentage of the map width

Meetgereedschap

  • Geef de Rubberband kleur voor het meetgereedschap

  • Zet het aantal te gebruiken Decimale posities

  • checkbox Basis eenheid bewaren

  • Voorkeurs meeteenheden radiobuttonon (‘meters’, ‘voet’, ‘Zeemijlen’ of ‘graden’)`

  • Voorkeur hoekeenheden radiobuttonon (‘Graden’, ‘Radialen’ of ‘Gon’)

Schuiven en zoomen

  • Zet het Muiswielgedrag op selectstring (‘Zoom’, ‘Zoom en recenter’, ‘Zoom naar muis cursor’, ‘Niets’)

  • Stel de Zoom factor in voor het muiswiel

Vooraf ingestelde schalen

Hier tref je de lijst aan met vooraf ingestelde schalen. Met de [+] en [-] knoppen kun je schalen toevoegen of verwijderen.

Printomgeving

Standaardwaarden opmaak

HIer kun je het Standaard lettertype geven.

Ruitennetweergave

  • Kies voor het Ruitennetstijl selectstring uit (‘Doorrgetrokken’, ‘Stippels’ of ‘Kruisjes’)

  • Geeft de Kleur...

Ruitennetstandaarden

  • Geef de Tussenruimte selectnumber

  • Geef de Ruitennetverspringing selectnumber voor x en y

  • Geef de ‘Snap’ tolerantie selectnumber

Hulplijnstandaarden

  • Geef de ‘Snap’ tolerantie selectnumber

Tabblad Digitaliseren

Objectcreatie

  • checkbox Geen attribuut-popus na het aanmaken van elk kaartobject tonen

  • checkbox Laatst ingevoerde attribuutwaarden gebruiken

  • Valideer geometriën tijdens het bewerken van complexe lijnen/polygonen bestaande uit veel punten kan dat dit het tekenen vertragen. Dit komt omdat de standaard validatie in QGIS veel tijd kan kosten. Om het tekenen te versnellen tijdens het bewerken kan men ook kiezen voor de GEOS geometrie validatie (beschikbaar vanaf GEOS 3.3) of om de validatie uit te zetten. De validatie met GEOS is veel sneller maar het nadeel is dat deze alleen het eerste geometrie probleem rapporteert.

Rubberband

  • Wijzig de Lijndikte en Lijnkleur van de Rubberband

Snapping

  • checkbox Snapping instellingen openen in een ‘dock-window’ (QGIS herstart vereist)

  • Zet de Standaard ‘snap’-modus selectstring (‘Naar hoekpunt’, Naar segment’, ‘Naar hoekpunt en segment’, ‘Uit’)

  • Zet de Standaard ‘snapping’-tolerantie in kaarteenheden of pixels

  • Zet de zoekradius voor hoekpuntaanpassingen in ‘kaart eenheden’ of ‘pixels’

Hoekpunten

  • checkbox Markers alleen gebruiken voor geselecteerde objecten heeft betrekking op het tonen ervan

  • Wijzig de Markerstijl naar selectstring (‘Kruis’ (standaard), ‘Semi transparente cirkel’ of ‘Niets’)

  • Zet de Markergrootte

Lijnverspring-gereedschap

De volgende 3 opties hebben betrekking op de tool mActionOffsetCurve Verspring Curve, zie Geavanceerd Digitaliseren. Met de verschillende settings, is het mogelijk om de vorm van de versprongen lijn te beïnvloeden. Deze opties zijn beschikbaar sinds GEOS 3.3.

  • Verbindingsstijl

  • Segmenten per Kwadrant

  • Maximale puntlengte bij scherpe hoeken

GDAL Menu

GDAL is een functiebibliotheek voor het kunnen inlezen converteren van veel rasterformaten. In dit tabblad kun je Creatie Opties bewerken en Pyramide Opties bewerken voor de raster formaten. Je kunt hier ook instellen welke GDAL driver gebruikt moet worden voor welk rasterformaat, aangezien in sommige gevallen er meer dan 1 GDAL driver beschikbaar zijn voor een rasterformaat.

CRS Menu

Standaard CRS voor nieuwe projecten

  • radiobuttonoff Gelijktijdige herprojectie uitschakelen

  • radiobuttonon Gelijktijdige CRS-transformatie gebruiken wanneer lagen verschillende CRS hebben

  • radiobuttonoff Gelijktijdige CRS-transformatie gebruiken

  • Selecteer een CRS voor Altijd dit CRS gebruiken voor nieuwe projecten

CRS voor nieuwe kaartlagen

Dit deel geeft de mogelijkheid om aan te geven of er een actie volgt nadat een nieuwe laag is aangemaakt, of wanneer een laag zonder CRS wordt geladen.

  • radiobuttonoff Vraag om CRS

  • radiobuttonoff Gebruik huidige project CRS

  • radiobuttonoff Gebruik het standaard CRS zoals hieronder getoond

Standaard datumtransformaties

  • checkbox Ask for datum transformation when no default is defined
  • Wanneer je hebt gewerkt met de gelijktijdige CRS transformatie kun je het resultaat in het onderliggende scherm zien. Je kunt informatie vinden over de ‘Bron CRS’ en de ‘Doel CRS’ maar ook over de ‘ Bron datum transformatie’ en de ‘Doel datum transformatie’.

Menu Locale

  • checkbox Systeem locale negeren en Te gebruiken locale

  • Informatie over gedetecteerde systeem locale

Netwerk Menu

Algemeen

  • Geef een WMS zoekadres, het standaard adres is http://geopole.org/wms/search?search=\%1\&type=rss

  • Geef de Timeout for netwerkaanvraagen (ms) - standaard ingesteld op 60000

  • Define Standaard verlooptijd van WMSC/WMTS tegels (uur) - standaard is 24

  • Geef Maximaal aantal pogingen bij tile request fouten

  • Geef de User-Agent

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-instellingen in QGIS

Cache instellingen

Wijzig de Folder en Grootte voor de cache.

  • checkbox Gebruik een proxy voor internettoegang en geef de ‘Host’, ‘Poort’, ‘Gebruiker’ en ‘Wachtwoord’.

  • Geef het Proxy type selectstring naar behoefte.

    • Default Proxy: Proxy wordt bepaald gebasseerd op de huidige applicatie proxy set

    • Socks5Proxy: Een generieke proxy die voor meerdere connectie protocollen. Ondersteund TCP, UDP, directe verbinding op poort (binnenkomende connecties) en autenticatie.

    • HttpProxy: Gebruikt de “CONNECT” opdracht, ondersteund alleen uitgaande TCP connecties; ondersteund autenticatie.

    • HttpCachingProxy: Gebruikt normale HTTP opdrachten, deze is alleen geschikt bij het gebruik van HTTP requests

    • FtpCachingProxy: Gebruikt een FTP proxy, is alleen goed bruikbaar in de context van FTP requests.

Men kan URL’s uitsluiten door deze toe te voegen aan het tekstinvoervak onder de proxy-instellingen (zie Figure_Network_Tab).

Wanneer je meer gedetailleerde informatie nodig hebt over de verschillende proxy settings, verwijzen we naar de handleiding QT functie bibliotheek documentatie zie http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Tip

Het gebruik van Proxies

Het gebruiken van proxies kan soms erg lastig zijn. Gebruik de ‘trial and error’ methode om de verschillende proxy typen te testen en controleer of deze voor jou werken.

Je kunt de opties wijzigen naar behoefte. Enkele aanpassingen hebben echter een herstart van QGIS nodig voordat deze effectief worden.

  • nix Settings are saved in a text file: $HOME/.config/QGIS/qgis.conf
  • osx De instellingen worden opgeslagen in: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win Instellingen worden opgeslagen in de windows registry onder: HKEY\CURRENT_USER\Software\QGIS\qgis

Aanpassingen

Met de tool Aanpassingen kun je bijna elke element aan-/uitzetten in de QGIS gebruikersinterface. Dit kan erg handig zijn wanneer veel plugins geinstalleerd zijn die je nooit gebruikt maar die wel schermruimte innemen.

Figure Customization 1:

../../../_images/customization.png

Het Aanpassingen dialoog nix

QGIS Aanpassingen is onderverdeeld in vijf groepen. Onder checkbox Menus kun je menu onderdelen verbergen. Onder checkbox Panelen vind je de ‘panelen’. Panelen zijn applicaties die gestart kunnen worden als een losstaand window maar die ook kunnen worden ingebed in het window van de QGIS applicatie zelf (zie ook Panelen en Werkbalken). Onder checkbox Status Bar kun je onderdelen zoals de coördinaten informatie uitzetten. Onder checkbox Toolbars kun je iconen van de QGIS werkbalken (de)activeren en onder checkbox Hulpmiddelen kun je ook knoppen en bijbehorende dialogen verbergen.

Met mActionSelect Schakel naar widgets in de hoofdapplicatie kun je klikken op elementen in QGIS die je wilt verbergen waarna deze ook direct springt naar de bijbehorende entry in het Aanpassingen dialoog (zie figure_customization). Je kunt ook verschillende sets van instellingen voor verschillende soorten gebruikers opslaan. Om de wijzigen toe te passen is een herstart van QGIS nodig.