Outdated version of the documentation. Find the latest one here.

.

QGIS 設定

QGIS は 設定 メニューを使って高度な設定をすることができます. パネル, ツールバー, プロジェクトプロパティ, オプションとカスタマイゼーションを選択してみてください.

パネルとツールバー

In the Panels‣ menu, you can switch on and off QGIS widgets. The Toolbars‣ menu provides the possibility to switch on and off icon groups in the QGIS toolbar (see figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

パネルとツールバーメニュー nix

ちなみに

QGISオーバービューを有効にする

QGISでは追加されたレイヤの全範囲のビューを提供するオーバービューパネルを提供します.これは nix 設定 ‣ パネル または win ビュー ‣ パネル メニューの下から選択することができます.ビュー内で現在のマップ範囲を示す長方形があります.これによって現在見ているマップのどのエリアかを決定することができます.マップオーバービューのレイヤにラベリングが設定されていても、ラベルはマップのオーバービューにレンダリングされないことに注意してください.オーバービューで現在の領域を示す赤い四角形をクリック・ドラッグすると、メインマップのビューもそれに応じて更新されます.

ちなみに

ログメッセージの表示

It’s possible to track the QGIS messages. You can activate checkbox Log Messages in the menu nix Settings ‣ Panels or win View ‣ Panels and follow the messages that appear in the different tabs during loading and operation.

プロジェクトのプロパティ

In the properties window for the project under nix Settings ‣ Project Properties or win Project ‣ Project Properties, you can set project-specific options. These include:

  • In the General menu, the project title, selection and background color, layer units, precision, and the option to save relative paths to layers can be defined. If the CRS transformation is on, you can choose an ellipsoid for distance calculations. You can define the canvas units (only used when CRS transformation is disabled) and the precision of decimal places to use. You can also define a project scale list, which overrides the global predefined scales.
  • The CRS menu enables you to choose the Coordinate Reference System for this project, and to enable on-the-fly re-projection of raster and vector layers when displaying layers from a different CRS.
  • 3番目の 情報検索レイヤ メニューからどのレイヤを情報探索ツールで確認できるようにするか (あるいはしないか) を設定できます (複数レイヤを確認する方法は オプション セクションの “マップツール” の項目を見てください).

  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them.
  • OWS Server タブは QGIS サーバのWMSとWFScapabilities、エクステントとCRSの制限についての情報を定義します。

  • マクロ メニューはPythonマクロの編集のために使います. 現時点では: openProject(), saveProject() そして closeProject() の3つのマクロのみ使用可能です.

Figure Macro Menu:

../../../_images/macro.png

QGIS でのマクロ設定

  • The Relations menu is used to define 1:n relations. The relations are defined in the project properties dialog. Once relations exist for a layer, a new user interface element in the form view (e.g. when identifying a feature and opening its form) will list the related entities. This provides a powerful way to express e.g. the inspection history on a length of pipeline or road segment. You can find out more about 1:n relations support in Section 1対多リレーションの作成.

オプション

mActionOptions Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ mActionOptions Options. The tabs where you can customize your options are described below.

一般情報メニュー

アプリケーション

  • スタイル (QGIS再起動が必要です) selectstring を選択し ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ と ‘Cleanlux’ (nix)の中から選択します。

  • アイコンテーマ selectstring を定義します。現時点では’デフォルト’のみ利用可能です。

  • Define the Icon size selectstring.
  • フォント を定義します。 radiobuttonon QT 規定値 とユーザ定義のフォントから選択します。

  • メッセージやダイアログのタイムアウト設定 selectstring を変更します。

  • checkbox 起動時のスプラッシュスクリーンを隠す

  • checkbox 起動時にチップスを表示する

  • checkbox グループボックスのタイトルを太字にする

  • checkbox QGISスタイルのグループボックス

  • checkbox 色選択ダイアログの随時更新

プロジェクトファイル

  • 起動時にプロジェクトを開く |selectstring|(’新規’、’最新’と ‘指定’の間から選択します。) ‘指定’を選択した時プロジェクトを定義するために |browsebutton| を使用します。

  • checkbox 既定のプロジェクトから新プロジェクトを作成する. 現在のプロジェクトを既定プロジェクトとして指定する または 既定を解除 ボタンをクリックすることができます. またユーザが作成したプロジェクトテンプレートをファイルやディレクトリを指定するとブラウズすることができます. プロジェクト ‣ テンプレートをもとに新規作成 というエントリでそれができます.プロジェクトテンプレートを保存したい場合は最初に checkbox 既定のプロジェクトから新プロジェクトを作成する をアクティブにしてプロジェクトテンプレートフォルダーにプロジェクトを保存してください.

  • checkbox 必要に応じプロジェクトとデータソースの変更の保存を促す

  • checkbox QGISの旧バージョンで保存したプロジェクトファイルを開く際に警告する

  • Enable macros selectstring. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

システムメニュー

環境

System environment variables can now be viewed, and many configured, in the Environment group (see figure_environment_variables). This is useful for platforms, such as Mac, where a GUI application does not necessarily inherit the user’s shell environment. It’s also useful for setting and viewing environment variables for the external tool sets controlled by the Processing toolbox (e.g., SAGA, GRASS), and for turning on debugging output for specific sections of the source code.

  • checkbox Use custom variables (restart required - include separators). You can [Add] and [Remove] variables. Already-defined environment variables are displayed in Current environment variables, and it’s possible to filter them by activating checkbox Show only QGIS-specific variables.

Figure System Environment:

../../../_images/sys-env-options.png

QGIS におけるシステム環境の多様性

プラグインパス

[Add] or [Remove] Path(s) to search for additional C++ plugin libraries

データソースメニュー

地物属性とテーブル

  • checkbox ドックウィンドウで属性テーブルを開く(QGISの再起動が必要)

  • checkbox Copy geometry in WKT representation from attribute table. When using mActionCopySelected Copy selected rows to clipboard from the Attribute table dialog, this has the result that the coordinates of points or vertices are also copied to the clipboard.
  • 属性テーブルの動作 selectstring, 3つの選択肢があります: ‘全ての地物を表示する’, ‘選択した地物を表示する’ , ‘地図上に表示された地物を表示する’.

  • Attribute table row cache selectnumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representation for NULL values. Here, you can define a value for data fields containing a NULL value.

データソースの操作

  • ブラウザドック内の正しいアイテムをスキャンする selectstring 。’領域のチェック’および’ファイルコンテンツのチェック’から選択できます。

  • ブラウザドック内の圧縮ファイル(zip)にあるコンテンツをスキャンする selectstring. ’いいえ’,’ベーシックスキャン’,’フルスキャン’ から選択できます。

  • Prompt for raster sublayers when opening. Some rasters support sublayers — they are called subdatasets in GDAL. An example is netCDF files — if there are many netCDF variables, GDAL sees every variable as a subdataset. The option allows you to control how to deal with sublayers when a file with sublayers is opened. You have the following choices:
    • ‘常に’:毎回確認 (サブレイヤが存在する場合)

    • ‘必要な場合’:バンドがなくサブレイヤをもつかを尋ねます

    • ‘利用しない’:確認せず何もロードしません

    • ‘‘すべてをロード’:確認せず,すべてのサブレイヤをロードします

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox ダブルクリックでPostGISレイヤを追加する.拡張選択モードを利用する

  • checkbox ダブルクリックでOracleレイヤを追加する.拡張選択モードを利用する

レンダリングメニュー

描画動作

  • checkbox 地図に新しくレイヤを追加した際にそのレイヤが表示されることをデフォルトにする

  • checkbox Enable back buffer
  • checkbox 再描画の速度を上げられる場合にレンダのキャッシュを利用します

  • checkbox 新規に追加されたレイヤで地物簡素化をデフォルトで有効にする

  • checkbox 可能であればプロバイダ側で簡素化

描画品質

  • checkbox 線のジャギーを目立たなくします(描画パフォーマンスが低下します)

  • checkbox Fix problems with incorrectly filled polygons

ラスタ

  • With RGB band selection, you can define the number for the Red, Green and Blue band.

Contrast enhancement

  • シングルバンドグレイ selectstring. シングルバンドグレイでは ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ と ‘Clip to MinMax’ を設定できます

  • マルチバンドカラー (byte/band) selectstring. ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ と ‘Clip to MinMax’ を設定できます.

  • マルチバンドカラー (>byte/band) selectstring. ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ と ‘Clip to MinMax’.

  • 制限 (最小/最大) selectstring. オプションは ‘累積ピクセル数のカット’, ‘最小/最大’, ‘平均 +/- 標準偏差’.

  • 累積ピクセル数のカット制限

  • 標準偏差の乗数

デバッグ

  • checkbox マップキャンバスリフレッシュ

キャンバスと凡例のメニュー

デフォルトのマップ外観(プロジェクトプロパティを上書きします)

  • Define a Selection color and a Background color.

レイヤの凡例

  • 凡例でのダブルクリックアクション selectstring. ダブルクリックを行った場合の動作を ‘レイヤプロパティを開く’ または ‘属性テーブルを開く’ から選べます.

  • 以下の 凡例アイテムスタイル は利用可能です

    • checkbox レイヤ名の最初を大文字にする

    • checkbox レイヤ名を太字にする

    • checkbox グループ名を太字にする

    • checkbox 分類の属性名称を表示する

    • checkbox ラスタアイコンの作成(多分遅い)

    • checkbox 新規レイヤをカレントグループに追加する

マップツールズメニュー

Identify

  • checkbox Open identify results in a dock window (QGIS restart required)
  • The Mode setting determines which layers will be shown by the Identify tool. By switching to ‘Top down’ or ‘Top down, stop at first’ instead of ‘Current layer’, attributes for all identifiable layers will be shown with the Identify tool. In QGIS 2.2. you can now use a ‘Layer selection’ option so that you can choose with the left-mouse menu which layer you want to identify (see the “Project properties” section under プロジェクト to set which layers are identifiable).
  • checkbox Open feature form, if a single feature is identified
  • Define Search radius for identifying and displaying map tips as a percentage of the map width

計測ツール

  • 計測ツールの ラバーバンド色 を定義します。

  • Define 小数位

  • checkbox 基礎単位の保持

  • 計測の単位 radiobuttonon (‘メーター’ , ‘フィート’, ‘海里’ または ‘度’ )

  • 優先的角度の単位 radiobuttonon (‘度’, ‘ラディアン’ または ‘グラード’)

パンとズーム

  • マウスホィール動作 の定義 selectstring (‘ズーム’, ‘ズームと中心移動’, ‘マウスカーソルにズーム’, ‘無し’)

  • ホイールマウスの ズーム倍率 の定義

定義済み縮尺

Here, you find a list of predefined scales. With the [+] and [-] buttons you can add or remove your individual scales.

コンポーザメニュー

コンポジションデフォルト

ここで デフォルト フォントを指定できます.

グリッドの外観

  • Define the Grid style selectstring (‘Solid’, ‘Dots’, ‘Crosses’)
  • Define the Color...

グリッドデフォルト

  • Define the Spacing selectnumber
  • グリッドオフセット selectnumber のxとyを指定してください

  • スナップ許容値 selectnumber を定義します

ガイドデフォルト

  • スナップ許容値 selectnumber を定義します

デジタイズメニュー

地物の作成

  • checkbox 地物作成後のポップアップ属性入力を行わない

  • checkbox 最後に入力した値を再利用する

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

ラバーバンド

  • ラバーバンドの 線幅線色 を指定して下さい

スナップ

  • checkbox ドックウィンドウ内でスナップオプションを開く (QGIS の再起動が必要)

  • Define 既定のスナップモード selectstring (‘頂点に’, ‘セグメントに’, ‘頂点とセグメントに’, ‘オフ’)

  • Define Default snapping tolerance in map units or pixels
  • Define the Search radius for vertex edits in map units or pixels

頂点マーカー

  • checkbox 選択された地物のみマーカーを表示する

  • 頂点の マーカースタイルselectstring (‘クロス’ (default), ‘半透明円’ または ‘なし’) から指定して下さい

  • 頂点の マーカーの大きさ を指定して下さい

カーブオフセットツール

The next 3 options refer to the mActionOffsetCurve Offset Curve tool in 高度なデジタイジング. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • 結合スタイル

  • Quadrant segments
  • 継ぎ目制限

GDALメニュー

GDAL is a data exchange library for raster files. In this tab, you can Edit create options and Edit Pyramids Options of the raster formats. Define which GDAL driver is to be used for a raster format, as in some cases more than one GDAL driver is available.

CRSメニュー

新プロジェクトの既定の投影座標系

  • radiobuttonoff :guilabel:` ‘オンザフライ’ 再投影を有効にしない`

  • radiobuttonon もしレイヤが異なる座標系を持つ場合,自動で ‘オンザフライ’ 再投影を有効にする

  • radiobuttonoff オンザフライ再投影をデフォルトで有効にする

  • CRS の選択と 新しいプロジェクトは常にこの CRSで開始する

新しいレイヤの投影座標系

このエリアでは新しいレイヤが作成された場合、またはCRSのないレイヤが読み込まれた場合に、実行するアクションを定義することができます。

  • radiobuttonon CRSを確認する

  • radiobuttonoff プロジェクトのCRSを利用する

  • radiobuttonoff 以下に表示されるデフォルトCRSを利用する

デフォルト datum 変換

  • checkbox デフォルトが定義されていないときにデータム変換をするかどうか問いかける

  • If you have worked with the ‘on-the-fly’ CRS transformation you can see the result of the transformation in the window below. You can find information about ‘Source CRS’ and ‘Destination CRS’ as well as ‘Source datum transform’ and ‘Destination datum transform’.

ロケールメニュー

  • checkbox システムロケールを上書きする代わりに利用するロケール

  • 有効なシステムロケールについての情報

ネットワークメニュー

一般情報

  • Define WMS search address, default is http://geopole.org/wms/search?search=\%1\&type=rss
  • Define Timeout for network requests (ms) - default is 60000
  • Default expiration period for WMSC/WMTS tiles (hours) を定義して下さい- デフォルトは 24です

  • Define Max retry in case of tile request errors
  • Define User-Agent

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

キャッシュ設定

キャッシュのための ディレクトリサイズ の指定.

  • checkbox Web接続にプロキシを使用する と ‘ホスト’, ‘ポート’, ‘ユーザ’, と ‘パスワード’ の指定.

  • Set the プロキシタイプ selectstring 必要に応じて設定して下さい.

    • Default Proxy: プロキシはアプリケーションのプロキシ設定によって決まります

    • Socks5Proxy: あらゆる種類の接続に対応した一般的なプロキシ. TCP, UDP, ポートへのバインディング (入力コネクション) と認証をサポートします.

    • HttpProxy: “CONNECT” コマンドを実装しています, 外向きの TCP コネクションのみサポートしています; 認証をサポートしています.

    • HttpCachingProxy: Implemented using normal HTTP commands, it is useful only in the context of HTTP requests.
    • FtpCachingProxy: Implemented using an FTP proxy, it is useful only in the context of FTP requests.

プロキシ設定の下のテキストボックスに除外するいくつかのURLを追加できます( Figure_Network_Tab 参照).

If you need more detailed information about the different proxy settings, please refer to the manual of the underlying QT library documentation at http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

ちなみに

プロキシの利用

Using proxies can sometimes be tricky. It is useful to proceed by ‘trial and error’ with the above proxy types, to check to see if they succeed in your case.

必要に応じてオプションを変更できます. いくつかの変更は反映させるために QGIS の再起動が必要です.

  • nix Settings are saved in a text file: $HOME/.config/QGIS/qgis.conf
  • osx $HOME/Library/Preferences/org.qgis.qgis.plist で設定を見つけることができます。

  • win  設定は以下のレジストリに保存されます: HKEY\CURRENT_USER\Software\QGIS\qgis

カスタマイゼーション

The customization tool lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you have a lot of plugins installed that you never use and that are filling your screen.

Figure Customization 1:

../../../_images/customization.png

カスタマイゼーションダイアログ nix

QGIS Customization is divided into five groups. In checkbox Menus, you can hide entries in the Menu bar. In checkbox Panel, you find the panel windows. Panel windows are applications that can be started and used as a floating, top-level window or embedded to the QGIS main window as a docked widget (see also パネルとツールバー). In the checkbox Status Bar, features like the coordinate information can be deactivated. In checkbox Toolbars, you can (de)activate the toolbar icons of QGIS, and in checkbox Widgets, you can (de)activate dialogs as well as their buttons.

With mActionSelect Switch to catching widgets in main application, you can click on elements in QGIS that you want to be hidden and find the corresponding entry in Customization (see figure_customization). You can also save your various setups for different use cases as well. Before your changes are applied, you need to restart QGIS.