Outdated version of the documentation. Find the latest one here.

Основные инструменты

Определение объектов

Инструмент определения объектов позволяет взаимодействовать с картой с целью получения атрибутов объектов. Чтобы определить объект выберите Вид ‣ Определить объекты, нажмите Ctrl+Shift+I или воспользуйтесь кнопкой mActionIdentify Определить объекты на панели инструментов.

При щелчке на объектах в этом диалоге будут отображены атрибуты всех объектов. Первый элемент это номер объекта в списке результатов, за ним идет имя слоя. Имена полей и ихзначения будут дочерними элементами. Таким образом отображается вся информация об объекте.

Это окно можно настроить на отображение только определённых полей, но по умолчанию здесь отображается три типа данных:

  • Действия: действия также отображаются в окне определения объекта. При нажатии на название действия оно будет выполнено. По умолчанию доступно только одно действие — открытие формы объекта.

  • Выведеные: это информация, вычисленная или полученная из другой информации. Здесь можно найти координаты щелчка, площадь и периметр полигона в единицах карты, длину линии в единицах карты и ID объекта.

  • Атрибуты: все атрибуты объекта.

Figure Identify 1:

../../../_images/identify_features.png

Диалог «Результат определения» nix (Gnome)

Внизу окна находится пять кнопок:

  • mActionIdentifyExpand Развернуть всё

  • mActionIdentifyCollapse Свернуть всё

  • mActionIdentifyDefaultExpand Раскрывать результаты автоматически

  • mActionIdentifyCopyAttributes Копировать выделенный объект в буфер обмена

  • mActionIdentifyPrint Распечатать веб-страницу

Дополнительные функции доступны из контекстного меню (вызывается нажатием правой кнопки мыши в области дерева результатов).

Меню позволяет:

  • Открыть форму объекта

  • Увеличить до объекта

  • Копировать объект: копирует весь объект, т.е. и геометрию, и атрибуты;

  • Копировать значение атрибута: копирует только значение выбраного атрибута;

  • Копировать атрибуты объекта: копирует только атрибуты;

  • Очистить результаты: очищает содержимое окна

  • Очистить подстветку: убирает подсветку с найденных объектов

  • Подсветить всё

  • Подсветить всё в слое

  • Свойства слоя: открывает диалог свойств слоя

  • Развернуть всё

  • Свернуть всё

Комбинации клавиш

Быстрый доступ ко многим действиям в QGIS осуществляется при помощи комбинаций клавиш клавиатуры. Комбинации, назначенные по умолчанию, перечислены в разделе Главное меню. Изменить существующие комбинации клавиш и добавить новые можно в диалоге настройки, который вызывается пунктом меню Установки ‣ Комбинации клавиш.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Настройка комбинаций клавиш nix (Gnome)

Процесс редактирования комбинаций клавиш очень прост. Выберите действие или инструмент из списка и воспользуйтесь кнопками [Изменить], [Удалить] или [По умолчанию]. Единожды определив свою конфигурацию комбинаций клавиш, можно сохранить её в XML-файле и загрузить на другом компьютере с установленной QGIS.

Контекстная справка

Если вам необходима помощь по конкретной теме, можно воспользоваться контекстной справкой по нажатию кнопки [Справка], имеющейся в большинстве диалоговых окон, но, обратите внимание на то, что сторонние модули могут перенаправлять на справочные материалы, размещенные в сети Интернет.

Рендеринг

По умолчанию, QGIS перерисовывает все видимые слои всякий раз, когда требуется обновление области карты. События, запускающие процесс обновления карты, включают:

  • добавление слоя

  • панорамирование или масштабирование

  • изменение размеров окна QGIS

  • включение или отключение слоя/слоёв в легенде

В ряде случаев QGIS позволяет контролировать процесс отрисовки.

Видимость в пределах масштаба

Видимость слоя в пределах масштаба позволяет определить минимальный и максимальный масштабы, при которых слой будет видимым. Для включения видимости в пределах масштаба откройте диалоговое окно Свойства, дважды щёлкнув на слое в легенде. На вкладке Общие активируйте флажок checkbox Видимость в пределах масштаба и установите значения минимального и максимального масштаба.

Значения масштабов можно задать по первому масштабированию слоя, который вы хотите использовать, отмечая значение масштаба в строке состояния QGIS.

Управление отрисовкой карты

Отрисовка карты может контролироваться одним из следующих способов:

Приостановка отрисовки

Для приостановки отрисовки карты снимите флажок checkbox Отрисовка в правом нижнем углу строки состояния. Когда флажок checkbox Отрисовка выключен, QGIS не будет перерисовывать карту в ответ на события, описанные в разделе Рендеринг. Приостановку отрисовки можно использовать в следующих случаях:

  • добавление нескольких слоев сразу и задание символики перед отрисовкой карты

  • добавление одного или нескольких больших слоев и включение видимости в пределах масштаба перед отрисовкой карты

  • добавление одного или нескольких больших слоев и масштабирование к определенному охвату перед отрисовкой карты

  • комбинации вышеперечисленного

Включение флажка checkbox Отрисовка активирует отрисовку и немедленно обновляет содержимое карты.

Добавление невидимых слоёв

QGIS позволяет всегда загружать новые слои без отрисовки на карте. Это означает, что слой будет добавлен к карте, но флажок видимости в легенде изначально не будет активен. Для настройки этого параметра выберите пункт меню Установки ‣ Параметры и нажмите на вкладке Отрисовка. Выключите флажок checkbox Добавляемые на карту слои видимы по умолчанию. Теперь любой слой, добавленный к карте, по умолчанию будет невидимым (выключенным).

Ещё одним параметром, влияющим на отрисовку, является флажок checkbox Использовать двойную буферизацию, который можно найти в меню Установки ‣ Параметры на вкладке Отрисовка. Он позволяет ускорить отрисовку, но делает невозможным отмену отрисовки и обновление карты во время прорисовки объектов. Если этот флажок неактивен, вы можете указать Количество объектов для прорисовки между обновлениями экрана, в противном случае этот параметр недоступен.

И наконец, можно активировать флажок checkbox Использовать кэш для ускорения перерисовки.

Отмена отрисовки

Чтобы остановить отрисовку карты нажмите ESC. Обновление карты будет отменено и она останется частично отрисованной. Между нажатием клавиши ESC и остановкой отрисовки может пройти некоторое время.

Примечание

Данная возможность в настоящее время недоступна — из-за проблем в библиотеке Qt, приводившим к ошибкам, функция временно отключена.

Обновление окна карты во время отрисовки

Можно настроить параметр обновления карты во время прорисовки объектов. По умолчанию, QGIS не отображает никаких объектов слоя на карте до тех пор, пока не отрисуется весь слой. Для обновления окна карты в процессе загрузки данных, выберите пункт меню Установки ‣ Параметры и перейдите на вкладку Отрисовка. Установите число объектов в соответствующее значение для обновления карты во время отрисовки. Установка значения равным 0 запрещает обновление карты во время отрисовки слоя (значение по умолчанию). Установка слишком низкого значения скажется на производительности — окно карты будет постоянно обновляться во время загрузки данных. Приемлемыми значениями можно считать 500 и более объектов.

Регулирование качества отрисовки

Для регулирования качества отрисовки карты можно задать два параметра. Выберите пункт меню Установки ‣ Параметры, перейдите на вкладку Отрисовка и включите или отключите следующие флажки.

  • checkbox Рисовать сглаженные линии (снижает скорость отрисовки)

  • checkbox Исправлять ошибки заливки полигонов

Измерения

Измерения на карте работают только с прямоугольными системами координат (например, UTM). Если загруженная карта определена в географической системе координат (широта/долгота), результаты измерений длин или площадей будут неправильными. Чтобы этого избежать, необходимо указать соответствующую систему координат (см. раздел Работа с проекциями). Все измерительные инструменты также используют параметры прилипания, используемые для оцифровки. Это может пригодиться, если необходимо провести измерения вдоль линейных или площадных объектов в векторных слоях.

Выбрать необходимый инструмент измерения можно нажав на кнопку mActionMeasure на панели инструментов.

Измерение длин, площадей и углов

mActionMeasure Измерить линию: QGIS позволяет измерить реальное и неспроецированное расстояние между точками в соответствии с заданными эллипсоидом. Для указания эллипсоида, выберите пункт меню Установки ‣ Параметры, перейдите на вкладку Инструменты и выберите нужный вам эллипсоид. На этой же вкладке можно выбрать цвет линии, единицы измерения по умолчанию (метры или футы) и единицы измерения углов (градусы, радианы или грады).Чтобы измерить расстояние, нажимайте на карте, ставя на ней точки. Длина каждого сегмента получившейся линии, а также суммарный результат, будут показаны в окне измерений. Прекратить измерение можно, щёлкнув правой кнопкой мыши.

Figure Measure 1:

../../../_images/measure_line.png

Измерение расстояний nix (Gnome)

mActionMeasureArea Измерить площадь: Аналогично осуществляется измерение площадей, в окне измерений выводится площадь указанной области. Кроме того, инструмент измерений будет прилипать к объектам выбранного слоя, при условии, что для слоя установлен порог прилипания (см. раздел Настройка порога прилипания и радиуса поиска). Так, если необходимо провести точное измерение длины линейного объекта или площади полигонального объекта, необходимо настроить порог прилипания, а затем выбрать слой. Теперь, при использовании инструмента измерений, при каждом нажатии кнопки мыши (в пределах порога прилипания), курсор будет прилипать к объектам этого слоя.

Figure Measure 2:

../../../_images/measure_area.png

Измерение площадей nix (Gnome)

mActionMeasureAngle Измерить угол: Также, вы можете измерять углы. Курсор станет крестообразным. Нажмите для создания первого сегмента угла, который хотите измерить, затем перемещайте курсор для создания необходимого угла. Результат измерения будет показан во всплывающем диалоговом окне.

Figure Measure 3:

../../../_images/measure_angle.png

Измерение углов nix (Gnome)

Выбор объектов

QGIS предоставляет несколько инструментов для выбора объектов на карте. Чтобы выделить один или несколько объектов нажмите на кнопку mActionSelect и воспользуйтесь одним из инструментов:

  • mActionSelect Выделить отдельный объект

  • mActionSelectRectangle Выделить объекты прямоугольником

  • mActionSelectPolygon Выделить объекты полигоном

  • mActionSelectFreehand Выделить объекты произвольной линией

  • mActionSelectRadius Выделить объекты в радиусе

Снять выделение с объектов можно нажав на кнопку mActionDeselectAll Снять выделение во всех слоях.

Оформление

QGIS предоставляет следующие элементы оформления: сетка, знак авторского права, указатель «север-юг», масштабная линейка. Они используются для оформления карты с использованием картографических элементов.

Сетка

transformed Сетка позволяет добавить на карту координатную сетку и подписи координат.

Figure Decorations 1:

../../../_images/grid_dialog.png

Диалог «Сетка» nix

  1. Выберите пункт меню Вид ‣ Оформление ‣ Сетка. Откроется диалог (см. figure_decorations_1).

  2. Активируйте флажок checkbox Включить сетку и настройте её параметры.

  3. Активируйте флажок checkbox Аннотация и настройте отображение подписей координат.

  4. Нажмите [Применить] и проверьте результат.

  5. Нажмите [OK] чтобы закрыть диалог.

Указатель «север-юг»

north_arrow Указатель «север-юг» размещает на карте простую стрелку, направленную на север. В настоящее время для указателя доступен только один стиль. Вы можете задать направление указателя или позволить QGIS определить его автоматически. Если вы выберите вариант автоматического определения направления, то QGIS предположит лучшее направление для указателя. Разместить указатель возможно в любом из четырех углов поля карты.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

Диалог «Указатель “север-юг”» nix

Масштабная линейка

scale_bar Масштабная линейка добавляет простую масштабную линейку на поле карты. Вы можете определить стить и местоположение линейки, а также расположение её подписей.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

Диалог «масштабная линейка» nix

QGIS поддерживает отображение масштаба только в тех же единицах измерения, что и карта. То есть, если единица измерения на вашем слое — метр, вы не можете добавить масштабную линейку в футах. Аналогично, если вы используете десятичные градусы, то не cможете создать масштабную линейку с единицей измерения метр.

Для добавления масштабной линейки:

  1. Выберите из меню Вид ‣ Оформление ‣ Масштабная линейка. Откроется диалог (см. figure_decorations_4)

  2. Выберите вариант размещения в открывающемся списке Размещение selectstring «Внизу слева»

  3. Выберите стиль из списка Стиль линейки selectstring «Штрихи вниз»

  4. Выберите цвет линейки Цвет линейки или используйте черный цвет по умолчанию

  5. Установите размер линейки и надписей Размер линейки «30 градусов»

  6. Убедитесь, что флажок checkbox Включить масштабную линейку включен

  7. ополнительно можете выбрать автоматическое изменение размера для округления показателя при изменении размера поля карты checkbox Автоматически изменять размер для округления показателя

  8. Нажмите кнопку [OK]

Совет

Настройки оформления

Когда вы сохраняете проект в формате .qgs, любые изменения произведенные с сеткой, указателем «север-юг», масштабной линейкой и знаком авторского права так же будут сохранены и восстановлены при последующем открытии проекта.

Инструменты аннотации

Инструмент mActionTextAnnotation Текстовая аннотация на панели атрибутов предоставляет возможность размещения форматированного текста в выноске на карте QGIS. Выберите инструмент текстовых аннотаций и нажмите внутри окна карты.

Figure annotation 1:

../../../_images/annotation.png

Диалог текстовой аннотации nix

Двойное нажатие на сноске открывает диалоговое окно с различными параметрами. Здесь находится текстовый редактор для ввода форматированного текста и прочие настраиваемые параметры. Например, можно привязать аннотацию к карте (обозначив маркером) или располагать ее свободно относительно карты. Аннотацию можно перемещать относительно карты (перетаскиванием маркера) или перемещать саму сноску. Иконки являются частью темы «gis», и используются в других темах.

Инструмент mActionAnnotation Переместить аннотацию позволяет перемещать аннотацию в окне карты.

HTML-аннотация

Инструмент mActionFormAnnotation HTML-аннотация предоставляет возможность размещения содержимого HTML-файла в выноске на карте QGIS. Выберите инструмент HTML-аннотаций, нажмите внутри окна карты и укажите расположение файла HTML.

SVG-аннотация

Инструмент mActionSaveAsSVG SVG-аннотация предоставляет возможность размещения файлов SVG в выноске на карте QGIS. Выберите инструмент SVG-аннотаций, нажмите внутри окна карты и укажите расположение файла SVG.

Диалоговая аннотация

Дополнительно, вы можете создавать свои собственные диалоговые аннотации. Инструмент mActionFormAnnotation Диалоговая аннотация полезен для отображения атрибутов векторного слоя в виде индивидуальной формы, настроенной в Qt Designer (см. рисунок figure_custom_annotation). Это похоже на конструктор форм для инструмента «Определить объекты», но отображается в виде аннотации. Для получения дополнительной информации посетите блог QGIS http://blog.qgis.org/node/143.

Figure annotation 2:

../../../_images/custom_annotation.png

Пользовательская форма аннотации nix

Примечание

Нажатие Ctrl+T при активном инструменте аннотаций (переместить аннотацию, текстовая аннотация, диалоговая аннотация), инвертирует видимость существующих аннотаций.

Пространственные закладки

Пространственные закладки позволяют создавать своеобразные «закладки» географического положения и возвращаться к ним позднее.

Создание закладки

Для создания закладки:

  1. Масштабируйте или панорамируйте карту до интересующей вас территории.

  2. Выберите пункт меню Вид ‣ Новая закладка или нажмите Ctrl-B.

  3. введите описательное имя для закладки (до 255 символов)

  4. Нажмите Enter, чтобы добавить закладку, или [Удалить] для удаления существующей закладки

Помните, что можно иметь множество закладок с одинаковыми названиями.

Работа с закладками

Для использования закладок и управления ими выберите пункт меню Вид ‣ Показать закладки. Диалоговое окно Пространственные закладки позволяет просматривать или удалять закладки. Но нельзя редактировать название закладки или координаты.

Просмотр закладки

В диалоговом окне Пространственные закладки, выберите необходимую закладку, нажав на неё, затем нажмите кнопку [Увеличить до]. Также можно просмотреть закладку, дважды нажав на неё.

Удаление закладки

Для удаления закладки из диалогового окна Пространственные закладки выберите её и нажмите кнопку [Удалить]. Подтвердите ваш выбор нажатием на кнопке [ОК] или отмените удаление нажатием кнопки [Отменить].

Встраиваемые проекты

Если вам необходимо к существующему проекту добавить содержимое другого проекта, выберите в меню Слой ‣ Встроить слои и группы.

Встраивание слоёв

Следующий диалог позволяет встраивать слои из другого проекта:

  1. Нажмите кнопку browsebutton, чтобы указать другой проект из набора данных «Аляска».

  2. Выберите проект grassland. Содержимое проекта будет отображено в диалоге (см. figure_embed_dialog).

  3. Зажмите клавишу Ctrl и выделите слои grassland и regions. Эти слои будут встроенны в текущий проект.

Figure Nesting 1:

../../../_images/embed_dialog.png

Выбор слоёв и групп для встраивания nix

Хотя встроенные слои можно редактировать, изменение их свойств, например, символики или подписей невозможно.

Удаление встроенных слоёв

Вызовите контекстное меню встроенного слоя и выберите mActionRemoveLayer Удалить.

Добавить слой CSV

Этот инструмент позволяет вам добавить в QGIS текстовый файл с разделителями как векторный слой.

  1. В качестве Раделителей обычно используют radiobuttonon Запятые (CSV). Если используется другой разделитель, выберите radiobuttonon Другие разделители, а если необходимо использовать регулярное выражение для поиска разделителей — то radiobuttonon Регулярное выражение.

  2. Заголовки полей атрибутивной таблицы будут соответствовать именам полей в файле. Обычно имена полей заданы в первой строке. Если названия полей в файле отсутствуют — снимите флажок checkbox Загружать имена полей из первой строки. Если необходимо пропустить несколько строк в начале файла, укажите их количество в поле Игнорировать строки в начале файла selectnumber.

  3. Удалить начальные и конечные пробелы из полей можно активировав флажок checkbox Удалять лишние пробелы. Также можно checkbox Отбрасывать пустые поля в каждой записи. Если не установлен флажок checkbox Использовать десятичную запятую в качестве десятичного разделителя будет использована точка.

  4. Геометрия в текстовых файлах может быть задана как radiobuttonon Координаты точки. Это значит, что в файле должны быть поля с координатами X и Y. Если используется radiobuttonon WKT, то в файле должно быть поле с описанием геометрии объекта в формате Well-Known Text. Эти поля могут иметь проивольные имена. Если же их нет, то используется режим radiobuttonon Только атрибуты. Координаты X и Y должны быть заданы в виде чисел. Система координат значения не имеет. Если используется формат градусы-минуты-секунды, включите флажок checkbox Широта/долгота

  5. Кроме того можно настроить Свойства слоя. Для ускорения отрисовки и пространственных операций используется checkbox Пространственный индекс. Также можно checkbox Индексировать подмножества и checkbox Отслеживать изменения чтобы изменения, сделанные другими приложениями отображались в QGIS.

В качестве примера корректного текстового файла, приведем фрагмент файла с данными высотных точек elevp.csv, включенный в демонстрационный набор данных QGIS (см. раздел Примеры данных):

X;Y;ELEV
-300120;7689960;13
-654360;7562040;52
1640;7512840;3
[...]

Некоторые замечания по текстовому файлу:

  1. В примере текстового файла используется разделитель ; (точка с запятой). В качестве разделителя полей может быть использован любой символ.

  2. Первая строка содержит заголовки столбцов. Она содержит поля X, Y и ELEV.

  3. Не используйте кавычки " для разделения полей.

  4. Координата Х расположена в поле X.

  5. Координата Y расположена в поле Y.

Использование

Нажмите кнопку delimited_text Добавить слой CSV на панели Управление слоями чтобы открыть диалог Создать слой из текстового файла, показанный на рисунке figure_delimited_text_1.

Figure Delimited Text 1:

../../../_images/delimited_text_dialog.png

Диалог «Создать слой из текстового файла» nix

Сначала выберите файл для импорта (например, qgis_sample_data/csv/elevp.csv) используя кнопку [Обзор...]. После того, как файл будет выбран QGIS проведет анализ содержимого файла, используя текущий вариант символа разделителя, в данном случае это символ (;). Для корректного анализа файла важно указать правильный символ разделителя. Для указания в качестве символа разделителя знака табуляции используйте \t (это регулярное выражение для символа табуляции).

После завершения анализа файла, выберите названия полей, содержащих координаты X и Y, из раскрывающегося списка полей или укажите поле, содержашее геометрию в формате WKT, и введя имя слоя (например, elevp), как показано на рисунке figure_delimited_text_1. Для добавления слоя на карту нажмите кнопку [OK]. Текстовый файл с разделителями теперь будет таким же, как любой другой слой в QGIS.