Outdated version of the documentation. Find the latest one here.

Настройка QGIS

QGIS гибко настраивается при помощи меню Установки. Здесь можно изменить настройки панелей инструментов, свойства проекта и настроить внешний вид QGIS.

Панели инструментов

В меню Панели‣ можно отключить неиспользуемые элементы QGIS. Меню Панели инструментов ‣ позволяет скрывать и отображать группы кнопок на панелях инструментов (см. figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

Меню «Панели инструментов» nix

Совет

Обзорная карта

In QGIS you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Совет

Отладочные сообщения

У вас есть возможность просматривать отладочные сообщения. Чтобы увидеть панель отладочных сообщений активируйте флажок checkbox Отладочные сообщения в меню Вид ‣ Панели. По мере поступления сообщений они будут отображаться во вкладках Общие и Модули.

Свойства проекта

In the properties window for the project under nix Project ‣ Project Properties or win Project ‣ Project Properties you set project specific options. These include:

  • На вкладке Общие определяется заглавие проекта, цвет выделения и фона, единицы слоя, точность, и параметр сохранения относительных путей к слоям. Если включено преобразование координат — можно выбрать эллипсоид для вычисления расстояний. Кроме того, здесь можно задать единицы измерения карты (используются только при отключенном преобразовании координат). В случае необходимости можно задать масштабный ряд, отличный от используемого по умолчанию.

  • Вкладка Система координат позволяет выбрать систему координат для данного проекта и включить преобразование координат векторных и растровых слоёв «на лету», если используются слои с разными системами координат.

  • C помощью третьей вкладки Определяемые слои можно настроить (или отключить) то, какие слои будут реагировать на инструмент «Определить объекты» (cм. параграф «Инструменты карты» в разделе Параметры для включения определения нескольких слоев).

  • Вкладка Стандартные стили позволяет настроить отображение слоёв, которые не имеют связанного с ними стиля. Здесь же можно настроить прозрачность для добавляемых слоёв и включить присвоение случайных цветов новым знакам.

  • Вкладка Сервер OWS позволяет задать характеристики сервера QGIS, ограничения охвата и поддерживаемые системы координат.

  • Вкладка Макросы служит для создания макросов уровня проекта, которые будут выполняться при открытии, сохранении и закрытии проекта.

Figure Macro Menu:

../../../_images/macro.png

Настройка макросов в QGIS

Параметры

mActionOptions Некоторые основные параметры QGIS могут быть определены в диалоговом окне Параметры. Выберите пункт меню Установки ‣ mActionOptions Параметры. Параметры можно изменить на следующих вкладках:

Владка «Общие»

Приложение

  • Выбрать Тема интерфейса (требуется перезапуск QGIS) selectstring из «Oxygen», «Windows», «Motif», «CDE», «Plastique» и «Cleanlooks».

  • Задать Тема значков selectstring. Доступна только тема «default».

  • Настроить Размер значков selectstring.

  • Выбрать Шрифт. Доступны варианты radiobuttonon Системный и заданный пользователем.

  • Изменить Время показа диалогов и сообщений состояния selectstring.

  • checkbox Не показывать заставку при запуске

  • checkbox Показывать совет дня при запуске

  • checkbox Выделять заголовки групп виджетов

  • checkbox Оформлять группы виджетов в стиле QGIS

  • checkbox Изменять цвета в реальном времени

Файлы проектов

  • При запуске открывать проект selectstring (можно выбрать «Новый», «Последний» и «Указанный». Если выбран «Указаный», используйте кнопку browsebutton чтобы указать проект)

  • checkbox Создавать новый проект из шаблона по умолчанию. Здесь же можно [Сохранить текущий проект как стандартный шаблон] или [Удалить шаблон] и восстановить значение по умолчанию. Ниже находится поле, где задаётся каталог шаблонов проектов. Шаблоны из этого каталога будут отображаться в меню Проект ‣ Создать из шаблона.

  • checkbox Запрашивать сохранение изменений в проекте и источниках данных, когда это необходимо

  • checkbox Предупреждать при попытке открытия файлов проекта старых версий |qg|

  • Разрешить макросы selectstring. Позволяет настроить поведение программы при открытии проектов с макросами.

Можно выбрать один из вариантов: «Не разрешать», «Спрашивать», «Разрешить на время текущего сеанса» и «Всегда разрешать (не рекомендуется)».

Вкладка «Система»

Переменные среды

На вкладке Система также можно просматривать и редактировать переменные окружения (см. рисунок figure_environment_variables).Это особенно полезно на таких системах, как Mac, где графические приложения не обязательно наследуют окружение пользователя. Также может применяться для настройки переменных окружения сторонних инструментов, использумых в Processing Toolbox, например SAGA, GRASS и др.

  • checkbox Переопределить переменные среды (требуется перезапуск). Используйте кнопки [Добавить] и [Удалить] для редактирования переменных окружения. Ниже отображаются Текущие переменные среды, активировав флажок checkbox Показывать только специфичные для QGIS переменные его можно значительно сократить.

Figure System Environment:

../../../_images/sys-env-options.png

Просмотр переменных окружения в QGIS

Модули

  • [Добавить] или [Удалить] Пути поиска дополнительных модулей

Вкладка «Источники данных»

Таблица атрибутов

  • checkbox Открывать таблицу аттрибутов во встраиваемом окне (требуется перезапуск)

  • checkbox Копировать геометрию в формате WKT из таблицы атрибутов. При использовании функции mActionCopySelectedКопировать выделенные строки в буфер обмена атрибутивной таблицы, будет также скопировано и WKT-представление геометрии объекта.

  • Вид таблицы атрибутов selectstring. Доступно три варианта: «Все объекты», «Выделенные объекты» и «Видимые объекты».

  • Размер кеша таблицы атрибутов (строк) selectnumber. Кэш таблицы атрибутов используется для хранения N последних загруженных строк, что ускоряет работу. Кэш очищается при закрытии таблицы атрибутов.

  • Представление значений NULL. Здесь задаётся представление полей содержащих значения NULL.

Источники данных

  • Искать источники данных в панели обозревателя selectstring. Предлагается два метода: «По расширению» и «По содержимому».

  • Сканировать содержимое архивов (.zip) в панели обозревателя selectstring. Возможные варианты: «Пропускать», «Быстрое сканирование» и «Полное сканирование».

  • Запрашивать загрузку дочерних слоёв растра. Некоторые растровые форматы поддерживают вложенные слои — в GDAL они называются дочерними (subdatasets). В качестве примера можно привести файлы netCDF — если в файле присутствует несколько переменных, то GDAL каждую из них считает отдельным слоем. Эта настройка определяет поведение QGIS при открытии таких файлов. Возможны следующие варианты:

    • Всегда: всегда спрашивать (если в файле есть дочерние слои)

    • Если необходимо: спрашивать, если в слое нет каналов, но есть дочерние слои

    • Никогда: никогда не спрашивать, дочерние слои не загружаются

    • Загружать всё: никогда не спрашивать, сразу загружать все дочерние слои

  • checkbox Игнорировать объявленную кодировку shape-файлов. Если shape-файл содержит информацию о кодировке, она будет игнорироваться QGIS.

  • checkbox Добавлять слои PostGIS двойным щелчком и включить расширенную выборку

  • checkbox Добавлять слои Oracle двойным щелчком и включить расширенную выборку

Вкладка «Отрисовка»

Параметры отрисовки

  • checkbox Рисовать сглаженные линии (снижает скорость отрисовки)

  • checkbox Исправлять ошибки заливки полигонов

Растры

  • Каналы отображения в RGB позволяют указать номера каналов, которые будут использованы как красный, зелёный и синий каналы.

Улучшение контраста

  • Одноканальное серое selectstring. Одноканальные изображения в оттенках серого могут использовать следущие алгоритмы улучшения контраста: «Без растяжения», «Растяжение до мин/макс», «Растяжение и отсечение по мин/макс» и «Отсечение по мин/макс»

  • Многоканальное (байт/канал) selectstring. Поддерживаются следущие алгоритмы улучшения контраста: «Без растяжения», «Растяжение до мин/макс», «Растяжение и отсечение по мин/макс» и «Отсечение по мин/макс».

  • Многоканальное (>байт/канал) selectstring. Поддерживаются следущие алгоритмы улучшения контраста: «Без растяжения», «Растяжение до мин/макс», «Растяжение и отсечение по мин/макс» и «Отсечение по мин/макс».

  • Предельные значения (мин/макс) selectstring. Доступны: ‘Срез с накоплением’, ‘Минимум/максимум’, ‘Среднее +/- стандартное отклонение’

  • Границы среза с накоплением

  • Множитель стандартного отклонения

Отладка

  • Показывать в журнале следующие события: checkbox Обновление карты

Вкладка «Карта и легенда»

Внешний вид по умолчанию

  • Установить Цвет выделения selectcolor и Цвет фона selectcolor.

Легенда

  • По двойному щелчку на слое в легенде selectstring можно открывать свойства слоя или открывать таблицу атрибутов.

  • Доступны следующие настройки элементов легенды:

    • checkbox Выводить имена слоёв с прописной буквы

    • checkbox Выделять слои полужирным шрифтом

    • checkbox Выделять группы полужирным шрифтом

    • checkbox Показывать в легенде атрибуты классификации

    • checkbox Создавать значки для растровых слоёв

    • checkbox Добавлять новые слои в выбранную или текущую группу

Вкладка «Инструменты»

Инструмент определения

  • checkbox Открывать результаты определения во встраиваемом окне (требуется перезапуск)

  • Настройка Режим определения selectstring используется для указания того, какие слои будут показываться при использовании инструмента «Определить объекты».При выборе «Сверху вниз» или «Сверху вниз, до первого найденного» вместо «Текущий слой», при использовании инструмента «Определить объекты» будут показаны атрибуты всех определяемых слоев (см. раздел Проекты, параграф «Свойства проекта» для настройки определяемых слоев).

  • checkbox Открывать форму, если найден один объект

  • установить Радиус поиска для определения объектов и всплывающих описаний (задается в процентах от ширины видимой карты)

Инструмент измерений

  • Установить Цвет линии для инструментов измерений

  • Установить число Десятичных знаков

  • checkbox Сохранять базовые единицы

  • Единицы измерения по умолчанию radiobuttonon (метры или футы)

  • Единицы измерения углов radiobuttonon (градусы, радианы или грады)

Прокрутка и масштабирование

  • Задать Действие при прокрутке колеса мыши selectstring («Увеличить», «Увеличить и центрировать», «Увеличить в положении курсора», «Ничего»)

  • Установить Фактор увеличения для колеса мыши

Масштабный ряд

Здесь находится масштабдный для. Кнопки [+] и [-] позволяют добавлять и удалять отдельные элементы списка.

Вкладка «Оцифровка»

Создание объектов

  • checkbox Отключить всплывающее окно ввода атрибутов для каждого создаваемого объекта

  • checkbox Использовать последние введённые значения

  • Проверка геометрии. Редактирование сложных линий/полигонов с большим количеством узлов может замедлить отрисовку. Это происходит из-за того, что процедура проверки геометрии, используемая в QGIS по умолчанию довольно медленная. Ускорить отрисовку можно либо используя для проверки геометрии библиотеку GEOS (начиная с GEOS 3.3) или отключив её вообще. Проверка геометрии при помощи GEOS намного быстрее, но у нее есть недостаток — обнаруживается только первая проблема с геометрией.

Резиновая нить

  • Установить Толщину линии selectnumber и Цвет линии selectcolor для «резиновой нити»

Прилипание

  • checkbox Открывать параметры прилипания во встраиваемом окне (требуется перезапуск)

  • Установить Режим прилипания по умолчанию selectstring («К вершинам», «К сегментам», «К вершинам и сегментам», «Выключена»)

  • Установить Порог прилипания по умолчанию в единицах карты или пикселях

  • Установить Радиус поиска для редактирования вершин selectnumber (в единицах карты или пикселях)

Маркеры вершин

  • checkbox Показывать маркеры только для выбранных объектов

  • Установить Стиль маркера selectstring («Перекрестие» (по умолчанию), «Полупрозрачный круг» или «Без маркера»)

  • Задать Размер маркера selectnumber.

Параллельные кривые

Следующие три параметра относятся к инструменту mActionOffsetCurve Параллельная кривая, описанному в разделе Дополнительные функции оцифровки. При помощи этих настроек можно управлять видом параллельной кривой. Все эти настройки будут учитываться только при использовании GEOS 3.3 или более поздней версии.

  • Стиль соединения параллельной линии

  • Количество сегментов на квадрант selectnumber

  • Предел острия параллельной кривой

Вкладка «GDAL»

Библиотека GDAL предназначена для работы с растровыми данными. На этой вкладке можно настроить [Параметры создания] и [Параметры пирамид], а также указать какой именно драйвер GDAL необходимо использовать для открытия файлов, если данный формат поддерживается более чем одним драйвером.

Вкладка «Система координат»

Система координат для новых проектов

  • checkbox Включать перепроецирование при добавлении слоёв в другой системе координат

  • checkbox Включить преобразование координат «на лету»

  • Создавать новые проекты в указанной системе координат

Система координат для новых слоёв

Вторая группа позволяет определить поведение QGIS при создании нового слоя или при загрузке слоя с неопределенной системой координат.

  • radiobuttonon Запрашивать систему координат

  • radiobuttonoff Использовать систему координат проекта

  • radiobuttonon Использовать указанную систему координат

Язык

  • checkbox Переопределить системный язык и Язык, используемый вместо системного

  • Дополнительная информация о системном языке

Сеть

Общие

  • Задать Адрес поиска WMS-серверов,по умолчанию используется http://geopole.org/wms/search?search=\%1\&type=rss

  • Установить Таймаут для сетевых запросов (мс). Значение по умолчанию — 60000

  • Настроить Время актуальности данных WMS-C/WMTS по умолчанию (часы). Значение по умолчанию —- 24 часа.

Figure Network Tab:

../../../_images/proxy-settings.png

Настройка прокси-сервера в QGIS

Параметры кэширования

Задать Каталог и Размер кэша.

  • checkbox Использовать прокси-сервер для внешних соединений и настроить поля «Узел», «Порт», «Пользователь», и «Пароль».

  • Установить Тип прокси selectstring в соответствии с конфигурацией сети.

    • Default Proxy: прокси определяется настройками приложения

    • Socks5Proxy: Общий прокси для любого вида связи. Поддерживаются TCP, UDP, привязка к порту (входящие соединения) и авторизация

    • HttpProxy: реализован с использованием команды «СONNECT», поддерживает только исходящие TCP соединения; поддерживает авторизацию

    • HttpCachingProxy: использует стандартные команды HTTP, имеет смысл использовать только с запросами HTTP

    • FtpCachingProxy: реализован посредством FTP прокси, имеет смысл использовать только с запросами FTP

Если вы не хотите использовать прокси-сервер для некоторых адресов, можно добавить их в текстовое поле ниже (см. Figure_Network_Tab).

Для получения более детальной информации о различных настройках прокси-сервера, обратитесь к Руководству Qt-library-documentation по адресу http://qt-project.org/doc/qt-4.8/qnetworkproxy.html#ProxyType-enum.

Совет

Использование прокси-серверов

Использование прокси-серверов иногда может быть довольно сложным. Для проверки вышеописанных типов прокси, действуйте методом «проб и ошибок», проверяя в каждом случае успешность соединений.

Можно настроить параметры в соответствии со своими потребностями. Внесение некоторых изменений может потребовать перезапуска QGIS для их применения.

  • nix параметры сохраняются в текстовом файле: $HOME/.config/QGIS/qgis2.conf

  • osx ваши настройки можно найти в файле: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win параметры хранятся в ветке системного реестра: HKEY\CURRENT_USER\Software\QGIS\qgis2

Настройка интерфейса

Диалог Настройка интерфейса позволяет (де)активировать практически любой элемент графического интерфейса QGIS. Такая возможность может быть полезной, если у вас установлено множество модулей, которые не используются, но занимают место на панелях.

Figure Customization 1:

../../../_images/customization.png

Диалог «Настройка интерфейса» nix

Все настройки интерфеса разбиты на пять групп. В разделе checkbox Menus настраивается видимость элементов главного меню. В разделе checkbox Panels собраны все плавающие окна. Плавающие окна это различные диалоги, которые после запуска могут быть размещены в любом месте экрана или встроенны в основное окно QGIS (см. также Панели инструментов). Группа checkbox StatusBar позволяет деактивировать элементы строки состояния, например, поле с системой координат. В разделе checkbox Toolbars можно (де)активировать различные кнопки на панелях инструментов и, наконец, в группе checkbox Widgets можно отключить или включить как целые диалоги, так и отдельные их элементы.

При помощи инструмента mActionSelect Выбрать элементы управления в приложении можно выбирать элементы интерфейса QGIS, которые необходимо скрыть, и быстро находить их в списке элементов (см. figure_customization). Различные варианты настройки можно сохранить для дальнейшего использования. Чтобы сделанные изменения вступили в силу, необходимо перезапустить QGIS.