Outils généraux

Raccourcis clavier

QGIS fournit des raccourcis claviers par défaut pour de nombreuses fonctionnalités. Vous les trouverez dans la section Barre de Menu. Le sous-menu Préférences ‣ Configurer les raccourcis... permet de personnaliser ces raccourcis clavier et d’en définir pour les autres fonctionnalités de QGIS listées.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Définir les options des raccourcis

La configuration est très simple. Sélectionnez juste un élément de la liste et cliquez sur :

  • [Changement] puis tapez la nouvelle combinaison de touches que vous souhaitez assigner à ce raccourci

  • [Ne rien mettre] pour supprimer un raccourci déjà défini

  • ou [Définir par défaut] pour enregistrer une valeur par défaut pour le raccourci.

Lorsque vous avez terminé, vous pouvez sauver la configuration dans un fichier XML en vue de charger cette dernière dans un autre environnement d’exécution de QGIS (sur un autre ordinateur par exemple).

Aide contextuelle

Lorsque vous avez besoin d’aide sur un sujet spécifique, vous pouvez accéder à l’aide contextuelle via le bouton [Aide] disponible dans la plupart des fenêtres — notez que les extensions additionnelles peuvent pointer vers des pages web dédiées.

Rendu

Par défaut, QGIS effectue le rendu de toutes les couches visibles à chaque fois que l’affichage de la carte est mis à jour. Les évènements qui déclenchent ce rafraîchissement incluent :

  • l’ajout d’une couche

  • le déplacement ou le zoom

  • le redimensionnement de la fenêtre de QGIS

  • la modification de la visibilité d’une ou plusieurs couches

QGIS vous laisse contrôler le processus de rendu de plusieurs manières.

Rendu dépendant de l’échelle

Le rendu dépendant de l’échelle permet de spécifier des échelles minimale et maximale auxquelles la couche doit être visible. Pour définir une échelle de rendu, ouvrez la fenêtre de Propriétés en double-cliquant sur une couche dans la légende et dans l’onglet Général, cochez la case checkboxVisibilité dépendante de l’échelle puis saisissez les valeurs voulues.

Vous pouvez déterminer les valeurs d’échelle en zoomant au niveau que vous voulez utiliser et en notant les valeurs de la barre d’état.

Contrôler le rendu

Le rendu de la carte peut être contrôlé de différentes manières, décrites ci-dessous.

Suspendre le rendu

Pour suspendre le rendu, cliquez sur la case checkbox Rendu dans le coin inférieur droit de la barre de statut. Quand cette case n’est pas cochée, QGIS ne redessine pas la carte en réponse aux évènements décrits dans la section Rendu. Voici quelques cas pour lesquels vous pourriez souhaiter ce comportement :

  • Ajouter plusieurs couches et réaliser leur symbologie avant de les afficher

  • Ajouter une ou plusieurs couches et définir leur dépendance d’échelle avant de les afficher

  • Ajouter une ou plusieurs couches et zoomer à une vue spécifique avant de les afficher

  • N’importe quelle combinaison des éléments précédents

Cocher la case checkbox Rendu activera de nouveau le rendu et provoquera un rafraîchissement immédiat de la carte.

Définir les options d’ajout de couche

Il est possible de définir une option qui chargera toutes les nouvelles couches sans les dessiner, elles seront ajoutées à la carte, mais la case de visibilité sera décochée par défaut. Pour définir cette option, sélectionnez l’option Préférences ‣ Options et cliquez sur l’onglet Rendu. Décochez la case checkbox Par défaut les couches supplémentaires sont affichées. Les nouvelles couches ajoutées à la carte seront invisibles par défaut.

Arrêter le rendu

Pour arrêter le rendu de la carte, appuyez sur la touche ESC. Ceci stoppera le rafraîchissement de la vue de la carte et laissera la carte partiellement dessinée. Il est possible qu’il y ait un délai entre le moment où la touche est pressée et le moment où le rendu de la carte est effectivement arrêté.

Note

Il n’est maintenant plus possible d’arrêter le rendu — cela a été désactivé dans Qt4 à cause de problèmes et de crashes dans l’interface utilisateur (IHM).

Influencer la qualité du rendu

QGIS dispose d’une option qui permet d’influencer la qualité du rendu de la carte. Dans le menu Préférences ‣ Options puis l’onglet Rendu, sélectionnez ou désélectionnez la case checkbox Les lignes semblent moins déchiquetées aux dépends d’une certaine vitesse d’exécution.

Accéler le rendu

Il y a plusieurs manières d’améliorer la rapidité du rendu de la carte. Dans le menu Préférences ‣ Options puis onglet Rendu, sélectionnez ou désélectionnez les cases suivantes :

  • checkbox Utiliser le cache du rendu si possible pour accélérer l’affichage

  • checkbox Rendu des couches en parallèle en utilisant plusieurs cœurs du processeur puis définissez le checkbox Nombre de cœurs à utiliser.

  • Le rendu cartographique est calculé en arrière-plan sur une image distincte et chaque checkbox Intervalle de rafraîchissement de l’affichage de la carte, le contenu (hors écran) est pris pour mettre à jour la représentation visible. Si le rendu se termine plus rapidement que cette durée, il sera affiché instantanément.

  • checkbox activez la simplification des entités par défaut lors de l’ajout de nouvelles couches , active la simplification de la géométrie des entités (moins de nœuds) pour un affichage plus rapide. Ceci peut générer des incohérences de rendu.

sélecteur de couleur

La boîte de dialogue sélecteur de couleur apparaît lorsque vous appuyez sur l’icône selectColor pour choisir une couleur. Les possibilités de cette boîte de dialogue dépendent de l’état de la case à cocher Utiliser la boîte de dialogue de sélection des couleurs natives dans le menu Paramètres -> Options -> Général. Lorsqu’elle est cochée, la boîte de dialogue de couleur utilisée est celle du système d’exploitation. Sinon, c’est le sélecteur de couleur personnalisé de QGIS qui est utilisé.

Cette boîte de dialogue comporte quatre onglets différents qui vous permettent de sélectionner des couleurs par colorBox palette de couleur, colorWheel roue chromatique, colorSwatches aplats de couleur ou colorPicker sélecteur de couleur (non disponible sous osx).

Quelle que soit la méthode utilisée, la couleur sélectionnée est toujours décrite par des curseurs de couleur pour les valeurs TSV (Teinte, Saturation, Valeur) et RVB (Rouge, Vert, Bleu). Il existe également un curseur opacité pour définir le niveau de transparence. Dans la partie inférieure gauche de la boîte de dialogue, vous pouvez voir une comparaison entre: la couleur guilabel:Ancienne et la couleur Actuelle et dans la partie inférieure droite vous avez la possibilité d’ajouter la couleur que vous venez de définir dans un bouton de couleur.

Figure color selector 1:

../../../_images/color_selector_ramp.png

Onglet du sélecteur de couleur

Astuce

Changement dynamiquement des couleurs avec l’option mise à jour en direct

Cochez l’option Fenêtres de choix de couleur avec mise à jour dynamique dans les Paramètres généraux pour que la couleur soit appliquée à vos éléments lorsque vous modifiez les paramètres de couleur dans la boîte de dialogue QGIS.

Avec la colorBox palette de couleur ou avec la colorWheel roue chromatique, vous pouvez parcourir toutes les combinaisons de couleurs possibles. Il y a d’autres possibilités. En utilisant colorSwatches Aplats de couleur vous pouvez choisir parmi une liste présélectionnée. Cette liste sélectionnée est remplie avec l’une des trois méthodes suivantes:

  • Couleurs récentes

  • Couleurs standard, liste de couleurs personnalisée définie dans le menu Préférences ‣ Options ‣ Couleurs

  • ou Couleurs du projet, liste de couleurs personnalisées définies dans le menu Projet ‣ Propriétés du Projet ‣ Styles par défaut.

Figure color selector 2:

../../../_images/color_selector_recent_colors.png

Onglet de choix du sélecteur de couleur

Une autre possibilité est d’utiliser le colorPicker Sélecteur de couleur qui permet d’échantillonner une couleur directement avec le pointeur de la souris depuis n’importe quelle partie de l’interface de QGIS et depuis une autre application en appuyant sur la barre espace. Cet outil dépend du système d’exploitation et n’est pas fonctionnel pour le moment sur OSX.

Astuce

Raccourci pour la sélection de couleur + copier/coller des couleurs

Vous pouvez rapidement choisir une couleur parmi les Couleurs récentes ou Couleurs standards ou simplement copier ou coller une couleur en cliquant sur la flèche située à droite du bouton selectColor d’affichage de couleur.

Figure color selector 3:

../../../_images/quick_color_selector.png

Raccourci pour la sélection de couleur

Modes de fusion

QGIS propose différentes options concernant les effets de rendu, options que vous connaissez peut-être des logiciels de dessin. Les Modes de fusion peuvent être appliqués sur les couches, les entités mais également sur les objets du composeur d’impression.

  • Normal : il s’agit du mode de fusion standard qui utilise la valeur de transparence (canal alpha) du pixel supérieur pour le fusionner avec le pixel sous-jacent, les couleurs ne sont pas mélangées.

  • Éclaircir : Sélectionne le maximum entre chaque composante depuis les pixels du premier-plan et de l’arrière-plan. Soyez attentif au fait que le résultat obtenu peut présenter un aspect dur et crénelé.

  • Filtrer : Les pixels lumineux de la source sont affichés par dessus la destination, alors que les pixels sombres ne le sont pas. Ce mode est utile pour mélanger la texture d’un élément avec un autre (par ex. vous pouvez utiliser un relief ombré pour texturer une autre couche).

  • Éviter : Ce mode va éclaircir et saturer les pixels sous-jacents en se basant sur la luminosité du pixel au-dessus. La brillance des pixels supérieurs vont donc provoquer une augmentation de la saturation et de la brillance des pixels inférieurs. Cela fonctionne mieux si les pixels supérieurs ne sont pas lumineux, sinon l’effet sera trop prononcé.

  • Addition : Ce mode de fusion ajoute simplement les valeurs de pixels d’un élément avec un autre. Dans le cas de valeurs obtenues au-dessus de un (en ce qui concerne le RVB), du blanc sera affiché. Ce mode est approprié pour mettre en évidence des entités.

  • Assombrir : Ce mode créé un pixel résultant qui conserve le plus petit composants parmi les pixels du premier-plan et de l’arrière-plan. Comme avec le mode éclaircir, le résultat peut présenter un aspect dur et crénelé.

  • Multiplier : Dans ce cas, les valeurs pour chaque pixel de l’élément supérieur sont multipliées par celles des pixels correspondants de l’élément inférieur. Les images obtenues sont plus sombres.

  • Découper : Les couleur sombres de l’élément supérieur provoquent un obscurcissement des éléments inférieurs. Découper peut être utilisé pour ajuster et teinter les couches inférieures.

  • Revêtement : Ce mode combine les modes multiplier et filtrer. Dans l’image résultante, les parties lumineuses deviennent plus lumineuses et les parties sombres plus sombres.

  • Lumière douce : Ce mode est très similaire au mode revêtement, mais au lieu d’utiliser multiplier/filtrer il utilise découper/éviter. Il est censé émuler une lumière douce rayonnante dans l’image.

  • Lumière dure : Ce mode est lui aussi très similaire au mode revêtement. Il est censé émuler une lumière très intense projetée dans l’image.

  • Différencier : Ce mode soustrait le pixel supérieur au pixel inférieur et vice-versa, de façon à toujours obtenir une valeur positive. Le mélange avec du noir ne produit aucun changement, étant donné que toutes les couleurs sont nulles.

  • Soustraire : Ce mode soustrait les valeurs de pixel d’un élément avec un autre. En cas de valeurs négatives obtenues, du noir est affiché.

Zoomer et se déplacer

QGIS fournit des outils pour zoomer et se déplacer vers une zone d’intérêt.

En plus d’utiliser les boutons pan Se déplacer dans la carte et zoomIn Zoom + / zoomOut Zoom - de la barre d’outils avec la souris, la navigation peut également se faire avec la molette de la souris, la barre espace et les flèches du clavier.

Zoomer et se déplacer avec la molette de la souris

Vous pouvez appuyer sur la molette de la souris pour vous déplacer dans la fenêtre principale et la faire rouler pour zoomer sur la carte. Pour vous rapprocher, placez le curseur sur la carte et faites rouler la molette vers l’avant tandis que si vous voulez vous éloigner vous devrez la faire rouler vers vous. La position du curseur sera le centre la zone affichée. Vous pouvez personnaliser le zoom via l’onglet Outils cartographiques du menu Préférences ‣ options Options.

Se déplacer avec les flèches du clavier

Il est possible de se déplacer sur la carte en utilisant les flèches du clavier. Placez votre curseur sur la carte et appuyez sur la flèche de droite pour vous déplacer vers l’Est, la flèche de gauche pour aller à l’Ouest, la flèche du haut pour le Nord et celle du bas pour le Sud.

Vous pouvez utiliser la barre d’espace pour que les mouvements de la souris se traduisent par un déplacement sur la carte. Les touches PgUp et PgDown vous permettront de zoomer.

Mesurer

QGIS propose quatre moyens de mesurer des géométries :

  • les outils interactifs de mesure measure,

  • les mesures via la calculateField Calculatrice de champs,

  • les mesures dérivées via l’outil Identifier les entités,

  • et un outil d’analyse de couches vecteur : Vecteur ‣ Outils de géométrie ‣ Exporter/ajouter des colonnes de géométrie.

Les mesures fonctionnent pour les systèmes de coordonnées projetés (par ex. UTM) et non projetés. Les trois premiers outils de mesure utilisent les mêmes options, globales au projet :

Si la transformation de SCR “à la volée” est activée, la mesure se fera, à la différence de la plupart des autres logiciels SIG, sur un ellipsoïde défini dans Projet ‣ Propriétés du projet ‣ Général. Cela se vérifie lorsqu’à la fois des systèmes de coordonnées géographiques et des systèmes projetés sont utilisés dans le projet. Si vous voulez calculer une superficie ou une distance projetée / planimétrique en utilisant les mathématiques cartésiennes, l’ellipsoïde de mesure doit être défini à “Aucun / Planimétrique”. Cependant, si un SCR géographique (non projeté) est défini pour les données et le projet, les mesures de superficies et de distances se feront sur un ellipsoïde. Si la transformation de SCR “à la volée” est désactivée, les mesures se feront de manière planimétrique pour un projet dont le système de coordonnées est projeté et, pour un projet dont le système de coordonnées est non projeté / géographique, les mesures se baseront sur un ellipsoïde.

Cependant, ni l’outil d’identification ni le calculateur de champ n’effectue une transformation dans le SCR du projet. Si vous voulez atteindre cet objectif, vous devez utiliser l’outil d’analyse vectorielle: Vecteur ‣ Outils de géométrie ‣ Exporter/ajouter des colonnes de géométrie. Dans ce cas, la mesure est par défaut planimétrique sauf si vous choisissez la mesure ellipsoïdale.

Mesurer des longueurs, des aires et des angles interactivement

Tous les modules de mesure utilisent les options d’accrochages. Cela est utile si vous souhaitez faire des mesures le long de lignes ou d’aires.

Pour choisir un outil de mesure, cliquez sur measure et sélectionnez l’outil que vous souhaitez utiliser.

Par défaut, measure Mesurer une longueur mesure les distances réelles entre des points donnés en fonction d’un ellipsoïde défini. Vous pouvez définir une couleur élastique et vos unités de mesure préférées (mètres, pieds,...) et unités angulaires (degrés, radians,...) dans l’option de menu Préférences -> Options -> Outils cartographiques. L’outil vous permet alors de cliquer sur des points sur la carte. Chaque longueur de segment, ainsi que le total, s’affiche dans la fenêtre de mesure. Pour arrêter la mesure, cliquez avec le bouton droit de la souris. Notez que vous pouvez changer les unités de mesure de manière interactive dans la boîte de dialogue de mesure. Ce qui surcharge les unités de mesure préférées des options. Une section info dans la boîte de dialogue indique les options SCR utilisés lors des calculs de mesure.

Figure Measure 1:

../../../_images/measure_line.png

Mesure de distance

measureArea Mesurer une aire : les aires peuvent aussi être mesurées. Dans la fenêtre de mesure la surface totale mesurée apparaît. En complément, l’outil de mesure s’accrochera à la couche sélectionnée à partir du moment où celle-ci a un seuil d’accrochage défini (voir section Définir le rayon de tolérance d’accrochage et de recherche). Donc si vous voulez mesurer avec exactitude le long d’une ligne ou autour d’un polygone, spécifiez d’abord un seuil d’accrochage puis sélectionnez la couche. Avec l’outil de mesure, chaque clic de souris (se situant dans ce seuil de tolérance) s’accrochera aux entités de cette couche.

Figure Measure 2:

../../../_images/measure_area.png

Mesure d’une aire

measureAngle Mesurer un angle : vous pouvez aussi mesurer des angles. Le curseur adopte une forme en croix. Cliquez pour dessiner le premier côté de l’angle à mesurer puis bougez le curseur pour dessiner l’angle désiré. La mesure est affichée dans une fenêtre.

Figure Measure 3:

../../../_images/measure_angle.png

Mesure d’un angle

Sélectionner et désélectionner des entités

La barre d’outils fournit plusieurs outils de sélection d’entités à partir du canevas de la carte. Pour sélectionner une ou plusieurs entités, cliquez sur select et choisissez l’outil :

  • selectRectangle Sélectionner les entités avec un rectangle ou un simple clic pour sélectionner une ou plusieurs entités avec un simple clic ou un rectangle

  • selectPolygon Sélection d’entités avec un polygone

  • selectFreehand Sélection d’entités à main levée

  • selectRadius Sélection d’entités selon un rayon

Pour désélectionner toutes les entités, cliquez sur deselectAll Désélectionner toutes les entités.

expressionSelect Sélectionner une entité en utilisant une expression permet à l’utilisateur de sélectionner des entités en utilisant la boîte de dialogue des expressions. Consultez le chapitre Expressions pour des exemples.

Les utilisateurs peuvent sauvegarder les entités sélectionnées dans une Nouvelle Couche Vecteur en Mémoire ou dans une Nouvelle Couche Vecteur en utilisant Édition ‣ Coller les entités en tant que ... et en choisissant le mode désiré.

Valeurs définies par des données

Pour de nombreuses options de la boîte de dialogue des propriétés de la couche vectorielle ou des paramètres du composeur d’impression, vous disposez de l’icône dataDefined Valeurs définies par les données. Grâce aux expressions basées sur les attributs de couche, sur des fonctions pré-préparées ou personnalisées et sur des variables, cet outil vous permet de définir une valeur dynamique pour le paramètre concerné. Lorsqu’elle est activée, la valeur renvoyée par cet outils est appliquée au paramètre quelle que soit sa valeur normale (case à cocher, zone de texte, curseur ...).

Cliquer sur l’icône dataDefined Valeurs définies par les données, permet de voir :

  • guilabel: Description ... qui indique si la valeur est active, quelle entrée est attendue, le type d’entrée valide et la définition actuelle,

  • une liste qui indique quels Types de champs sont disponibles,

  • Une liste des Variables disponibles,

  • le bouton Editer ... pour créer ou modifier l’expression à utiliser,

  • les boutons Coller and Copier ,

  • le bouton Effacer pour réinitialiser les valeurs.

Astuce

Quand les options du bouton Valeurs définies par les données sont correctes, celui-ci est jaune dataDefineOn ou dataDefineExpressionOn; sinon, le bouton est rouge dataDefineError or dataDefineExpressionError.

On trouve ces fonctionnalités dans :

  • Le paramétrage des styles et symboles

  • Le paramétrage des étiquettes

  • Le paramétrage du composeur

Identifier les entités

L’outil Identifier les entités vous permet d’interagir avec le canevas de la carte et d’afficher des informations sur les entités dans un menu contextuel. Pour identifier une entité, utilisez Vue ‣ Identifier les entités ou Ctrl + Shift + I ou encore cliquez sur l’icône identify Identifier les entités dans la barre d’outils Attributs.

QGIS offre deux façons pour identifier les objets avec l’outil identify Identifier les entités :

  • click gauche identifie les objets selon le mode choisi dans le panneau Identifier les résultats

  • click droit va chercher tous les objets des couches visibles et ouvre une fenêtre contextuelle qui permet de choisir l’objet à consulter.

Si vous cliquez sur le(s) entité(s), la boîte de dialogue Identifier les résultats listera les informations relatives à toutes le(s) entité(s) cliquées. La vue par défaut est une arborescence où le premier élément est le nom de la couche et les suivants sont le(s) entité(s) identifiée(s). Chaque entité est décrite par le nom d’un champ ainsi que sa valeur. Ce champ est celui qui est défini dans Propriétés -> Affichage. Suit alors toutes les autres informations de l’entité.

Cette fenêtre se personnalise pour afficher les champs choisis mais par défaut, trois types d’information sont affichés :

  • Actions: des :index: actions peuvent être ajoutées. L’action est exécutée en cliquant sur l’étiquette d’action. Par défaut, une seule action est ajoutée, à savoir Afficher le formulaire d'entités pour l’édition. Vous pouvez définir plus d’actions dans la boîte de dialogue des propriétés du calque.

  • ** Dérivé **: Cette information est calculée ou dérivée d’autres informations. Cela inclut l’id de l’entité, sa longueur ou son périmètre et sa superficie dans les unités de la carte en fonction de sa géométrie, le nombre de parties et le numéro de la partie cliquée en cas de multi-géométrie, le nombre de sommets et le numéro du sommet le plus proche du point cliqué. Il indique également les valeurs de coordonnées X et Y (et Z / M si disponibles) du point cliqué et du sommet le plus proche “Closest vertex”.

  • Attributs de données: Il s’agit de la liste des champs et des valeurs de l’entité sur laquelle vous avez cliqué.

Figure Identify 1:

../../../_images/identify_features.png

Fenêtre d’identification des entités

En haut de la fenêtre, vous avez sept icônes :

  • expandTree Déplier

  • collapseTree Replier

  • expandNewTree Comportement par défaut pour choisir si les prochains résultats seront dépliés ou repliés par défaut

  • propertyItem Voir le formulaire d’entité

  • deselectAll Effacer les résultats

  • editCopy Copier les entités sélectionnées dans le presse papier

  • filePrint Imprimer la réponse HTML sélectionnée

En bas de la fenêtre, vous trouvez les listes déroulantes Mode et Vue . Avec la liste déroulante Mode vous pouvez définir depuis quelle couches les entités doivent être identifiées:

  • ‘Couche actuelle’ : seules les entités de la couche sélectionnée sont identifiées. Il n’est pas nécessaire que la couche soit visible.

  • ‘De haut en bas, s’arrêter à la première’: pour se limiter aux entités de la plus haute couche visible.

  • ‘De haut en bas’: pour toutes les entités des couches visibles. Les résultats sont affichés dans la fenêtre.

  • et ‘Choix de la couche’: ouvre un menu contextuel dans lequel l’utilisateur choisi la couche à utiliser pour identifier les entités. Fonctionne comme un clic droit. Seules les entités sélectionnées seront affichées dans la fenêtre de résultats.

La Vue peut être paramétrée comme ‘Arbre’, ‘Table’ ou ‘Graph’. Les vues ‘Table’ et ‘Graph’ ne sont disponibles que pour les couches raster.

L’outil identifier les entités vous permet d’ checkboxouvrir le formulaire automatiquement. Si la case est cochée, à chaque fois qu’une seule entité est identifiée, QGIS ouvrira un formulaire avec ses attributs. C’est un moyen pratique d’éditer rapidement les attributs d’une entité.

D’autres fonctions peuvent être trouvées dans le menu contextuel d’un élément identifié, via un clic droit. Par exemple, depuis le menu contextuel, vous pouvez :

  • Voir le formulaire d’entité

  • Zoomer sur l’entité

  • Copier l’entité : copie toute la géométrie et les attributs d’une entité

  • Basculer vers la sélection d’éléments: Ajoute l’entité identifiée à la sélection

  • Copier les valeurs d’attributs : copie uniquement les valeurs d’attributs de l’entité identifiée

  • Copier les attributs de l’entité: Copie les attributs de l’entité

  • Lâcher les résultats : la fenêtre de résultats est vidée

  • Masquer la surbrillance : la surbrillance des entités identifiées sur la carte est retirée

  • Tout mettre en surbrillance

  • Mettre la couche en surbrillance

  • Activer une couche : Choisir la couche à activer

  • Propriétés : ouvre la fenêtre des propriétés de la couche

  • Tout déplier

  • Tout replier

Outils d’annotation

L’outil textAnnotation Annotation de texte dans la barre d’outils des attributs permet de placer du texte mis en forme dans une bulle sur la carte. Choisissez l’outil Annotation de texte et cliquez sur la carte.

Figure annotation 1:

../../../_images/annotation.png

La fenêtre d’annotation de texte

Un double clic sur l’annotation ouvre une fenêtre avec diverses options. Il y a un éditeur de texte pour entrer du texte formaté et d’autres options notamment la possibilité de figer la position de l’annotation dans la carte (montré par un symbole de marqueur) ou d’avoir la position de l’annotation relativement à l’écran (non liée à la carte). La position de l’élément peut être déplacé sur la carte (en déplaçant le marqueur de carte) ou en déplaçant seulement la bulle. Les icônes font partie du thème SIG et sont utilisées par défaut dans les autres thèmes, aussi.

L’ outil annotation déplacer une annotation permet de déplacer l’annotation sur le canevas de carte.

Annotations HTML

L’outil formAnnotation Annotation Html dans la barre d’outils d’attributs permet de placer le contenu d’un fichier html dans uns bulle sur le canevas de carte. Avec l’outil Annotation HTML, cliquez sur le canevas de carte et ajoutez le chemin du fichier html dans la boîte de dialogue.

Annotations SVG

L’outil saveAsSVG Annotation SVG dans la barre d’outils des attributs permet de placer un symbole SVG dans une bulle sur le caneva de carte. Avec Annotation SVG, cliquez sur le canevas de la carte et ajoutez le chemin du fichier SVG dans la boîte de dialogue.

Formulaire d’annotation

De plus, vous pouvez créer vos propres formulaires d’annotation. Le formAnnotation Formulaire d’annotation est utile pour afficher les attributs d’une couche vectorielle dans un formulaire QtDesigner personnalisé (voir figure_custom_annotation). Ceci est similaire au concepteur de formulaires de l’outil Identifier entité, mais affiché dans un élément d’annotation. Consultez également cette vidéo https://youtu.be/0pDBuSbQ02o?t=2m25s de Tim Sutton pour plus d’informations.

Figure annotation 2:

../../../_images/custom_annotation.png

Formulaire d’annotation personnalisé

Note

Si vous pressez les touches Ctrl+T alors que l’outil Annotation est activé (déplacement d’annotation, annotation de texte ou formulaire d’annotation), les annotations sont automatiquement cachées ou, inversement, rendues visibles.

Signets spatiaux

Les signets spatiaux vous permettent de “marquer” un emplacement géographique et y retourner plus tard. Les signets sont enregistrés sur l’ordinateur, ce qui signifie qu’ils sont disponibles à partir de n’importe quel projet sur le même ordinateur.

Créer un signet

Pour créer un signet :

  1. Déplacez-vous sur la zone concernée.

  2. Sélectionnez l’option de menu Vue -> Nouveau signet ou appuyez sur Ctrl-B. Le panneau Signets spatiaux s’ouvre avec le signet nouvellement créé.

  3. Entrez un nom pour décrire le signet (jusqu’à 255 caractères).

  4. Appuyez sur Enter pour ajouter le signet ou cliquer ailleurs.

Notez que vous pouvez avoir plusieurs signets portant le même nom.

Travailler avec les signets

Pour utiliser ou gérer des signets, sélectionnez l’option de menu Vue -> Liste des signets. Le panneau Signets spatiaux vous permet de:

  • Zoom sur un signet: sélectionnez le signet souhaité, puis cliquez sur Zoomer jusqu’au signet. Vous pouvez également zoomer sur un signet en double-cliquant dessus.

  • Supprimer un signet: sélectionnez le signet et cliquez sur Effacer le signet. Confirmez votre choix.

  • Importer ou exporter un signet: Pour partager ou transférer vos signets entre ordinateurs, vous pouvez utiliser le menu déroulant Importer ou Exporter des signets dans la boîte de dialogue Signets spatiaux. Tous les signets sont transférés.

Inclusion de projets

Si vous souhaitez inclure dans votre projet QGIS des couches ou des groupes de couches issus d’un autre projet, utilisez le menu Couches ‣ Intégrer des couches et des groupes.

Intégrer des couches

La fenêtre suivante vous permet d’intégrer des couches provenant d’autres projets QGIS :

  1. Appuyez sur browseButton pour rechercher un projet du jeu de données de l’Alaska.

  2. Sélectionnez le fichier de projet relations.qgs. Vous pouvez voir le contenu du projet (voir figure_embed_dialog).

  3. Appuyez sur Ctrl` et cliquez sur les couches airports et regions. Appuyer sur [OK]. Les couches sélectionnées sont chargées dans la légende et dans le canevas.

Figure Nesting 1:

../../../_images/embed_dialog.png

Sélectionner les couches et les groupes à intégrer.

Bien que les couches intégrées soient éditables, vous ne pouvez pas en modifier le style et l’étiquetage.

Supprimer des couches intégrées

Cliquez avec le bouton droit sur la couche intégrée et choisissez removeLayer Supprimer.

Décorations

Les décorations de QGIS incluent la grille, l’étiquette de copyright, la flèche du nord et la barre d’échelle. Ils sont utilisés pour «décorer» la carte en ajoutant des éléments cartographiques.

Grille

transformed Grille vous permet d’ajouter un graticule et des coordonnées à la carte.

Figure Decorations 1:

../../../_images/grid_dialog.png

La fenêtre Grille

  1. Sélectionnez via le menu Vue ‣ Décorations ‣ Grille. La fenêtre s’affiche (voir figure_decorations_1).

  2. Cochez la case checkbox Activer la grille et définissez les paramètres de la grille en fonction des couches chargées dans le canevas de carte.

  3. Cochez la case checkbox Dessiner une annotation et définissez les propriétés de l’annotation en fonction des couches chargées dans le canevas de carte.

  4. Cliquez sur [Appliquer] pour vérifier que le résultat est celui attendu ou [OK] si vous êtes satisfait.

Flèche du nord

northArrow Flèche Nord place une simple flèche nord sur le canevas. Actuellement, il n’y a qu’un seul style disponible. Vous pouvez ajuster l’angle de la flèche ou laisser QGIS régler la direction automatiquement. Si vous choisissez de laisser QGIS déterminer la direction, il réalise la meilleure estimation de la façon dont la flèche doit être orientée. Pour le placement de la flèche, vous avez quatre options, correspondant aux quatre coins du canevas de carte. Vous pouvez affiner le placement de la flèche en définissant une marge horizontale et/ou verticale à partir du bord (du Canevas). Ces valeurs peuvent être en Millimètre ou Pixels ou défini comme un Pourcentage de la largeur ou de la hauteur du canevas de carte.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

La fenêtre de flèche du nord

Échelle graphique

scaleBar Échelle graphique ajoute une simple barre d’échelle sur la carte. Vous choisissez le style, l’emplacement ainsi que les étiquettes de la barre.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

La fenêtre de barre d’échelle

QGIS permet uniquement d’afficher l’échelle dans la même unité que celle de la carte. Donc, si l’unité est le mètre, vous ne pouvez créer une échelle en pieds. De la même manière, si vous utilisez les degrés décimaux, vous ne pouvez afficher une échelle en mètres.

Pour ajouter une échelle graphique :

  1. Sélectionnez le menu Vue ‣ Décorations ‣ Échelle graphique. Une fenêtre s’affiche (voir figure_decorations_4).

  2. Assurez-vous que la case checkbox Activer l’échelle graphique est cochée.

  3. Choisissez le style dans la liste déroulante Style de la barre d’échelle selectString.

  4. Sélectionnez la couleur dans Couleur de la barre selectColor ou laissez le noir défini par défaut.

  5. Définissez la Taille de la barre selectNumber.

  6. En option, cochez checkbox Arrondir automatiquement lors du changement de zoom pour afficher des valeurs faciles à lire.

  7. Choisissez l’emplacement dans la liste déroulante Emplacement selectString.

  8. Vous pouvez affiner le placement de l’élément en définissant une marge horizontale et/ou verticale à partir du bord (du Canevas). Ces valeurs peuvent être en Millimètre ou en Pixels ou un Pourcentage de la largeur ou de la hauteur du canevas de carte.

  9. Cliquez sur [Appliquer] pour vérifier que le résultat est celui attendu ou [OK] si vous êtes satisfait.

Astuce

Paramètre des décorations

Lorsque vous sauvegardez un projet .qgs, toutes modifications faites sur le Carroyage, la Flèche du Nord, la Barre d’Échelle et le Copyright seront sauvées dans le fichier de projet et restaurées à la prochaine ouverture du projet.

Authentification

QGIS peut stocker/récupérer les informations d’authentification d’une manière sécurisée. Les utilisateurs peuvent enregistrer de manière sécurisée les informations d’authentification dans les configurations d’authentification, qui sont stockées dans une base de données portable, Elles peuvent être appliquées aux connexions de serveur ou de base de données et être référencées en toute sécurité par leurs jetons d’ID dans les fichiers de projet ou de paramètres. Pour plus d’informations, voir: Système d’authentification.

Un mot de passe principal doit être fourni lors de l’initialisation du système d’authentification et de sa base de données portable.

Enregistrer une couche dans un fichier

Les couches (raster ou vecteur ) peuvent être enregistrées dans un autre format avec la fonction Enregistrer sous ... dans le menu contextuel de la couche (en cliquant avec le bouton droit de la souris sur la couche dans l’arborescence des couches) ou dans le menu :menuselection:`Couche –>Enregistrer sous ... `.

La boîte de dialogue Enregistrer sous affiche plusieurs paramètres pour modifier le comportement lors de l’enregistrement de la couche. Les paramètres communs (raster et vecteur) sont:

  • Format
  • Nom de fichier

  • SCR

  • Ajouter les fichiers sauvegardés à la carte

  • Étendue (les valeurs possibles sont l’Emprise de la couche, l’Emprise du canevas ou une Emprise personnalisée)

  • Les options; Créer (pour les rasters), Couche, ou options Personnalisables (pour les vecteurs) vous permettent de modifier certaines options avancées. L’utilisateur avancé peut se reporter à la documentation du driver concerné dans la documentation gdal-ogr.

Toutefois, certains paramètres sont spécifiques aux formats raster et vecteurs:

  • Paramètres spécifiques au raster:

    • Résolution (horizontale et verticale)

    • Création de pyramides

    • Options de créations (données brutes ou image rendue)

  • Paramètres spécifiques au vecteur:

    • Encodage

    • N’enregistrer que les données sélectionnées

    • Ignorer la création d’attributs

    • Exporter la symbologie: peut être utilisé principalement pour l’export en DXF et pour tous les formats de fichiers qui gèrent les styles d’entités OGR (voir la remarque ci-dessous) comme DXF, KML, TAB.

      • Pas de symbologie : Style par défaut dans l’application qui lit les données

      • Symbologie de l’entité : Enregistre le style avec les styles d’entités OGR (voir la remarque ci-dessous)

      • Symbologie de la couche de Symboles: Enregistre avec les styles d’entités OGR (voir la remarque ci-dessous), mais exporte la même géométrie plusieurs fois si plusieurs symbologies de symboles sont utilisées

    • Géométrie:

      • Forcer le type multiple

      • Inclure la dimension Z

      • Ajoutez ou supprimez une colonne de géométrie avec la liste déroulante. Ce n’est pas lié au type de géométrie courant de la couche. Vous pouvez ajouter une colonne de géométrie vide à une table d’attributs, supprimer la colonne géométrique d’une couche spatiale.

Note

Les styles d’entités OGR sont un moyen de stocker directement le style dans les données sous la forme d’un attribut caché. Seul certains formats peuvent traiter ce type d’information. Les format des fichiers KML, DXF et TAB en sont des exemples. Pour les utilisateurs avancés, vous pouvez lire les spécifications OGR Feature Styles specification .

Note

À propos des fichiers DXF

Les couches vectorielles peuvent être exportées vers des fichiers DXF à l’aide d’un autre outil Export DXF ... dans Projet. Les fenêtres permettent à l’utilisateur de choisir le fichier, le mode de symbologie (voir la remarque ci-dessus), l’échelle de symbologie, le codage, les réglages de visibilité et les couches à inclure dans le fichier DXF.

En option, vous pouvez checkbox Utiliser le titre de la couche comme nom si paramétré ou Exporter seulement les entités visibles sur l’emprise de la carte.

Utilisation de variables pour un contenu dynamique

Vous pouvez définir des variables personnalisées à utiliser dans des expressions. Les variables peuvent être définies au niveau global de l’application, au niveau du projet, au niveau de la couche et au niveau de la composition. Tout comme les règles CSS en cascade, les variables peuvent être surchargées- par exemple, une variable de niveau projet remplacera toutes les variables de niveau d’application définies. Vous pouvez utiliser ces variables pour créer des chaînes de texte ou d’autres expressions personnalisées en utilisant le caractère @ avant le nom de la variable. Par exemple dans composeur d’impression créer une étiquette avec ce contenu:

This map was made using QGIS [% @qgis_version %]. The project file for this
map is: [% @project_path %]

Rendra l’étiquette comme ceci:

This map was made using QGIS 2.14. The project file for this map is:
/gis/qgis-user-conference-2015.qgs

Vous pouvez gérer les variables globales à partir du menu Paramètres -> Options et les variables de projet à partir des propriétés du projet (y compris l’ajout de vos propres variables personnalisées).

Figure Variables dialog 2:

../../../_images/options_variables.png

Modification des variables de niveau projet

Note

Vous pouvez lire plus d’informations et trouver des exemples ici Exploration des variables dans `Exploring variables in QGIS 2.12, part 1, part 2 and part 3.