Outdated version of the documentation. Find the latest one here.

|Atualizardireitos|

Ferramentas Gerais

Atalhos de teclado

QGIS provides default keyboard shortcuts for many features. You can find them in section Barra de Menu. Additionally, the menu option Settings ‣ Configure Shortcuts.. allows you to change the default keyboard shortcuts and to add new keyboard shortcuts to QGIS features.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Define shortcut options nix (Gnome)

Configuration is very simple. Just select a feature from the list and click on [Change], [Set none] or [Set default]. Once you have finished your configuration, you can save it as an XML file and load it to another QGIS installation.

Conteúdo da ajuda

Quando precisar de ajuda num tópico específico, pode acessar a ajuda de contexto [Help], através do botão disponível na maioria dos diálogos– por favor, veja que plugins de terceiras partes podem apontar para páginas web específicas.

Renderização

By default, QGIS renders all visible layers whenever the map canvas is refreshed. The events that trigger a refresh of the map canvas include:

  • Adicionar uma camada

  • Pan ou zoom

  • Resizing the QGIS window
  • Mudanças na visibilidade de uma camada ou camadas

QGIS allows you to control the rendering process in a number of ways.

Escala dependente da renderização

A representação dependente da escala, permite especificar as escalas mínima e máxima as quais a camada será visível. Para definir uma visualização dependente da escala, abra o diálogo Propriedades, clicando duas vezes sobre a legenda da camada. Na aba Geral, clique na caixa checkbox Visibilidade dependente da Escala para ativar a função, depois coloque os valores de escala mínimo e máximo.

You can determine the scale values by first zooming to the level you want to use and noting the scale value in the QGIS status bar.

Controlando a renderização do mapa

Map rendering can be controlled in the various ways, as described below.

Suspensão de edição

To suspend rendering, click the checkbox Render checkbox in the lower right corner of the status bar. When the checkbox Render checkbox is not checked, QGIS does not redraw the canvas in response to any of the events described in section Renderização. Examples of when you might want to suspend rendering include:

  • Adicionando várias camadas e simbolizando antes do desenho.

  • Adicionando uma ou mais camadas grandes e definindo a dependência de escala antes do desenho.

  • Adicionando uma ou várias camadas grandes e definindo a escala de visualização antes do desenho.

  • Qualquer combinação dos anteriores

Caixa de seleção checkbox :guilabel: caixa de seleção Renderizar permite renderização e causa uma atualização imediata na tela do mapa.

Opções de adicionar configurações da camada

Pode-se definir uma opção para que possa carregar novas camadas sem visualizá-las. Isto implica que a camada será adicionada ao mapa, mas a caixa de visibilidade na legenda estará desmarcada por padrão. Para definir esta opção, escolha o menu de opções Definições ‣ Opções e clique em Representação. Desmarque a caixa checkbox Por Padrão novas camadas adicionadas ao mapa serão visualizadas. Qualquer camada adicionada depois ao mapa estará deligada (invisível) por padrão.

Parar rendirização

Para parar o desenho no mapa, pressione a tecla ESC. Isto irá parar a atualização da tela do mapa e deixar o mapa parcialmente desenhado. Pode levar um pouco de tempo entre pressionar ESC e o tempo que o desenho do mapa será interrompido.

Nota

No momento não é possível parar a representação ou visualização — isto foi desabilitado no porta Qt4 devido a que a Interface do usuário (UI) ocasiona problemas e colapsa.

Updating the Map Display During Rendering

You can set an option to update the map display as features are drawn. By default, QGIS does not display any features for a layer until the entire layer has been rendered. To update the display as features are read from the datastore, choose menu option Settings ‣ Options and click on the Rendering tab. Set the feature count to an appropriate value to update the display during rendering. Setting a value of 0 disables update during drawing (this is the default). Setting a value too low will result in poor performance, as the map canvas is continually updated during the reading of the features. A suggested value to start with is 500.

Influência da qualidade da edição

To influence the rendering quality of the map, you have two options. Choose menu option Settings ‣ Options, click on the Rendering tab and select or deselect following checkboxes:

  • checkbox Make lines appear less jagged at the expense of some drawing performance
  • checkbox Fix problems with incorrectly filled polygons

Acelerando a visualização

There are two settings that allow you to improve rendering speed. Open the QGIS options dialog using Settings ‣ Options, go to the Rendering tab and select or deselect the following checkboxes:

  • checkbox Enable back buffer. This provides better graphics performance at the cost of losing the possibility to cancel rendering and incrementally draw features. If it is unchecked, you can set the Number of features to draw before updating the display, otherwise this option is inactive.
  • checkbox :guilabel:` Usar o cache de visualização quando possível para agilizar re-desenhos`

Medição

Measuring works within projected coordinate systems (e.g., UTM) and unprojected data. If the loaded map is defined with a geographic coordinate system (latitude/longitude), the results from line or area measurements will be incorrect. To fix this, you need to set an appropriate map coordinate system (see section Trabalhando com Projeções). All measuring modules also use the snapping settings from the digitizing module. This is useful, if you want to measure along lines or areas in vector layers.

To select a measuring tool, click on mActionMeasure and select the tool you want to use.

Measure length, areas and angles

mActionMeasure Measure Line: QGIS is able to measure real distances between given points according to a defined ellipsoid. To configure this, choose menu option Settings ‣ Options, click on the Map tools tab and select the appropriate ellipsoid. There, you can also define a rubberband color and your preferred measurement units (meters or feet) and angle units (degrees, radians and gon). The tool then allows you to click points on the map. Each segment length, as well as the total, shows up in the measure window. To stop measuring, click your right mouse button. Note that you can interactively change the measurement units in the measurement dialog. It overrides the Preferred measurement units in the options. There is an info section in the dialog that shows which CRS settings are being used during measurement calculations.

Figure Measure 1:

../../../_images/measure_line.png

Measure Distance nix (Gnome)

mActionMeasureArea Measure Area: Areas can also be measured. In the measure window, the accumulated area size appears. In addition, the measuring tool will snap to the currently selected layer, provided that layer has its snapping tolerance set (see section Configurando a Tolerância de Atracção e Raio de Pesquisa). So, if you want to measure exactly along a line feature, or around a polygon feature, first set its snapping tolerance, then select the layer. Now, when using the measuring tools, each mouse click (within the tolerance setting) will snap to that layer.

Figure Measure 2:

../../../_images/measure_area.png

Measure Area nix (Gnome)

mActionMeasureAngle Measure Angle: You can also measure angles. The cursor becomes cross-shaped. Click to draw the first segment of the angle you wish to measure, then move the cursor to draw the desired angle. The measure is displayed in a pop-up dialog.

Figure Measure 3:

../../../_images/measure_angle.png

Measure Angle nix (Gnome)

Selecionar e desselecionar feições

The QGIS toolbar provides several tools to select features in the map canvas. To select one or several features, just click on mActionSelect and select your tool:

  • mActionSelect Select Single Feature
  • mActionSelectRectangle Select Features by Rectangle
  • mActionSelectPolygon Select Features by Polygon
  • mActionSelectFreehand Select Features by Freehand
  • mActionSelectRadius Select Features by Radius

To deselect all selected features click on mActionDeselectAll Deselect features from all layers.

mIconExpressionSelect Select feature using an expression allow user to select feature using expression dialog. See Expressões chapter for some example.

Users can save features selection into a New Memory Vector Layer or a New Vector Layer using Edit ‣ Paste Feature as ... and choose the mode you want.

Identificar feições

The Identify tool allows you to interact with the map canvas and get information on features in a pop-up window. To identify features, use View ‣ Identify features or press Ctrl + Shift + I, or click on the mActionIdentify Identify features icon in the toolbar.

If you click on several features, the Identify results dialog will list information about all the selected features. The first item is the number of the layer in the list of results, followed by the layer name. Then, its first child will be the name of a field with its value. The first field is the one selected in Properties ‣ Display. Finally, all information about the feature is displayed.

Essa janela pode ser personalizada para exibir campos personalizados, mas por padrão ele irá exibir apenas três tipos de informação:

  • Actions: Actions can be added to the identify feature windows. When clicking on the action label, action will be run. By default, only one action is added, to view feature form for editing.
  • Derived: This information is calculated or derived from other information. You can find clicked coordinate, X and Y coordinates, area in map units and perimeter in map units for polygons, length in map units for lines and feature ids.
  • Data attributes: This is the list of attribute fields from the data.

Figure Identify 1:

../../../_images/identify_features.png

Identify feaures dialog nix (Gnome)

At the top of the window, you have five icons:

  • mActionIdentifyExpand Expand tree
  • mActionIdentifyCollapse Collapse tree
  • mActionIdentifyDefaultExpand Default behaviour
  • mActionIdentifyCopyAttributes Copy attributes
  • mActionIdentifyPrint Print selected HTML response

At the bottom of the window, you have the Mode and View comboboxes. With the Mode combobox you can define the identify mode: ‘Current layer’, ‘Top down, stop at first’, ‘Top down’ and ‘Layer selection’. The View can be set as ‘Tree’, ‘Table’ and ‘Graph’.

The identify tool allows you to auto open a form. In this mode you can change the feautures attributes.

Outras funções podem ser encontrados no menu de contexto do item identificado. Por exemplo, do menu de contexto, você pode:

  • Ver o formulário da feição

  • Zoom para feição

  • Copiar feição: Copiar todos os atributos e a geometria da feição

  • Toggle feature selection: adds identified feature to selection
  • Copiar o valor do atributo: Copiar apenas o valor do atributo que clicou.

  • Copy feature attributes: Copy only attributes
  • Limpar resultados: apaga os resultados na janela

  • Limpar destaques: Remover feiçõesdestacadas no mapa

  • Destaque todos

  • Destaque a camada

  • Ativar camada: escolha uma camada a ser ativada

  • Propriedades da camada: Abre a janela de propriedades da camada

  • Estender tudo

  • Encolher tudo

Decorações

The Decorations of QGIS include the Grid, the Copyright Label, the North Arrow and the Scale Bar. They are used to ‘decorate’ the map by adding cartographic elements.

Malha

transformed Grid allows you to add a coordinate grid and coordinate annotations to the map canvas.

Figure Decorations 1:

../../../_images/grid_dialog.png

The Grid Dialog nix

  1. Selecionar do menu Ver ‣ Decorações ‣ Malha. O diálogo abre (veja figure_decorations_1).

  2. Marque a guia checkbox Abilitar Malha e coloque as definições da malha de acordo as camadas carregadas na tela do mapa.

  3. Marque a guia checkbox Desenhar anotações e coloque as definições de anotações, de acordo as camadas carregadas na tela do mapa.

  4. Click [Apply] to verify that it looks as expected.
  5. Click [OK] to close the dialog.

Seta Norte

north_arrow North Arrow places a simple north arrow on the map canvas. At present, there is only one style available. You can adjust the angle of the arrow or let QGIS set the direction automatically. If you choose to let QGIS determine the direction, it makes its best guess as to how the arrow should be oriented. For placement of the arrow, you have four options, corresponding to the four corners of the map canvas.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

The North Arrow Dialog nix

Barra de Escala

scale_bar Scale Bar adds a simple scale bar to the map canvas. You can control the style and placement, as well as the labeling of the bar.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

The Scale Bar Dialog nix

QGIS only supports displaying the scale in the same units as your map frame. So if the units of your layers are in meters, you can’t create a scale bar in feet. Likewise, if you are using decimal degrees, you can’t create a scale bar to display distance in meters.

Para adicionar uma barra de escala:

  1. Seleccione a partir do menu: menuselection: Ver -> Decorações -> Barra de Escala. O diálogo abre (veja figure_decorations_4).

  2. Choose the placement from the Placement selectstring combo box.
  3. Choose the style from the Scale bar style selectstring combo box.
  4. Select the color for the bar Color of bar selectcolor or use the default black color.
  5. Set the size of the bar and its label Size of bar selectnumber.
  6. Confirme que a caixa checkbox Abilitar barra escala, está clicada.

  7. Optionally, check checkbox Automatically snap to round number on resize.
  8. Click [OK].

Dica

Configurações de Decorações

Quando salva um projeto .qgs, qualquer mudança que tenha efetuado ao Gride, Seta do Norte, Barra de Escala e Direitos de Cópia, serão salvos no projeto e restaurados na próxima vez que carregue o projeto.

Ferramentas de anotação

The mActionTextAnnotation Text Annotation tool in the attribute toolbar provides the possibility to place formatted text in a balloon on the QGIS map canvas. Use the Text Annotation tool and click into the map canvas.

Figure annotation 1:

../../../_images/annotation.png

Annotation text dialog nix

Dê um duplo clique no item para abrir o diálogo com várias opções. Tem um editor de texto para entrar texto formatado e definir outros itens. Por exemplo, tem uma forma de colocar um item numa posição do mapa (mostrada por um símbolo marcador) or para ter um item numa posição da tela (não relacionada ao mapa).O artigo pode ser movido pela posição do mapa (arrastando o marcador do mapa) ou movendo apenas o balão. Os ícones são parte do tema GIS e podem ser usados como padrão em outros temas também.

The mActionAnnotation Move Annotation tool allows you to move the annotation on the map canvas.

Anotações HTML

The mActionFormAnnotation Html Annotation tools in the attribute toolbar provides the possibility to place the content of an html file in a balloon on the QGIS map canvas. Using the Html Annotation tool, click into the map canvas and add the path to the html file into the dialog.

Anotações SVG

The mActionSaveAsSVG SVG Annotation tool in the attribute toolbar provides the possibility to place an SVG symbol in a balloon on the QGIS map canvas. Using the SVG Annotation tool, click into the map canvas and add the path to the SVG file into the dialog.

Anotação de formulário

Additionally, you can also create your own annotation forms. The mActionFormAnnotation Form Annotation tool is useful to display attributes of a vector layer in a customized Qt Designer form (see figure_custom_annotation). This is similar to the designer forms for the Identify features tool, but displayed in an annotation item. Also see this video https://www.youtube.com/watch?v=0pDBuSbQ02o from Tim Sutton for more information.

Figure annotation 2:

../../../_images/custom_annotation.png

Customized qt designer annotation form nix

Nota

Se você pressionar Ctrl+T enquanto uma ferramenta Anotação está ativa (mover anotação, texto de anotação, formulário de anotação), os estados de visibilidade dos itens serão invertidos.

Favoritos Espaciais

Spatial Bookmarks allow you to “bookmark” a geographic location and return to it later.

Novo Favorito

Para criar um novo favorito:

  1. Zoom ou pan na área de interesse.

  2. Select the menu option View ‣ New Bookmark or press Ctrl-B.
  3. Adicione um nome descritivo para o favorito (no máximo 255 caracteres).

  4. Press Enter to add the bookmark or [Delete] to remove the bookmark.

Note que você pode ter vários favoritos com o mesmo nome.

Trabalhando com favoritos

To use or manage bookmarks, select the menu option View ‣ Show Bookmarks. The Geospatial Bookmarks dialog allows you to zoom to or delete a bookmark. You cannot edit the bookmark name or coordinates.

Zooming to a Bookmark

From the Geospatial Bookmarks dialog, select the desired bookmark by clicking on it, then click [Zoom To]. You can also zoom to a bookmark by double-clicking on it.

Deleting a Bookmark

To delete a bookmark from the Geospatial Bookmarks dialog, click on it, then click [Delete]. Confirm your choice by clicking [Yes], or cancel the delete by clicking [No].

Import or export a bookmark

To share or transfer your bookmarks between computers you can use the Share pull down menu in the Geospatial Bookmarks dialog.

Projetos animados

Se deseja incorporar conteúdo de outros arquivos de projetos no seu projeto, pode escoler Camada ‣Incorporar Camadas e Grupos.

Incorporando camadas

Os siguientes diálogos permitem incorporar camadas de outros projetos. Aqui um pequeno exemplo:

  1. Press browsebutton to look for another project from the Alaska dataset.
  2. Select the project file grassland. You can see the content of the project (see figure_embed_dialog).
  3. Press Ctrl and click on the layers grassland and regions. Press [OK]. The selected layers are embedded in the map legend and the map view now.

Figure Nesting 1:

../../../_images/embed_dialog.png

Select layers and groups to embed nix

Enquanto as camadas incorporadas são editáveis, não podem ser mudadas suas propriedades de estilo e rotulação.

Removendo camadas incorporadas

Right-click on the embedded layer and choose mActionRemoveLayer Remove.