Outdated version of the documentation. Find the latest one here.

6.1. Lesson: 새 벡터 데이터셋 생성

여러분이 사용하는 데이터는 출처가 있어야 합니다. 가장 일반적인 응용 작업의 경우, 이미 존재하는 데이터를 사용합니다. 그러나 특별하고 전문적인 프로젝트일수록, 사용할 수 있는 데이터가 이미 존재할 가능성은 적어집니다. 이런 경우 여러분 자신의 새 데이터를 생성해야 합니다.

이 강의의 목표: 새 벡터 데이터셋 생성하기.

6.1.1. basic Follow Along: 레이어 생성 대화 창

새 벡터 데이터를 추가하려면 먼저 데이터를 추가할 벡터 데이터셋이 필요합니다. 이 예제에서는 기존 데이터셋을 편집하기보다 완전히 새로운 데이터를 생성해보려 합니다. 따라서 사용자 자신의 새 데이터셋을 먼저 정의해야 합니다.

새 레이어를 정의할 수 있는 New Vector Layer 대화창을 열어야 합니다.

  • 메뉴에서 Layer ‣ New ‣ New Shapefile Layer 항목을 찾아 클릭하십시오.

다음 대화 창이 나타날 것입니다.

../../../_images/create_vector_layer.png

이 단계에서 어떤 유형의 데이터셋을 생성할지 결정하는 것이 중요합니다. 서로 다른 벡터 레이어 유형은 백그라운드에서 “서로 다르게” 구성되기 때문에 레이어를 생성한 후에는 유형을 변경할 수 없기 때문입니다.

다음 예제에서 지역을 나타내는 새 피처들을 생성할 예정입니다. 이런 피처의 경우, 폴리곤 데이터셋을 생성해야 합니다.

  • Polygon 라디오 버튼을 클릭하십시오.

../../../_images/polygon_selected.png

대화 창의 다른 항목에 아무런 영향도 미치지 않지만, 벡터 데이터셋을 생성했을 때 정확한 도형 유형을 사용하게 해줍니다.

다음 항목을 통해 좌표계, 또는 CRS를 설정할 수 있습니다. CRS는 지구 상의 한 점을 좌표 형태로 표현하는 방법을 설정하는데, 아주 많은 방법이 있기 때문에 아주 많은 CRS들이 있습니다. 이 프로젝트의 CRS는 WGS84로, 기본값을 그대로 쓰면 됩니다.

../../../_images/default_crs.png

다음으로 New attribute 아래 모여 있는 항목 집합이 있습니다. 기본적으로 새 레이어는 단일 속성, 즉 다음 그림에 보이는 (Attributes list 에서 볼 수 있는) id 항목만을 가집니다. 그러나 여러분이 생성하는 데이터를 유용하게 만들려면 이 새 레이어 안에 생성할 피처에 대해 뭔가 정보를 부여할 필요가 있습니다. 이 예제의 목표에 따라, name 이라는 항목 하나를 추가하는 것으로 충분할 것입니다.

  • 아래 설정을 그대로 따라한 다음 Add to attributes list 버튼을 클릭하십시오.

../../../_images/new_attribute.png
  • 대화 창이 다음 그림처럼 보이는지 확인하십시오.

../../../_images/new_attribute_added.png
  • OK 를 클릭합니다. 저장 대화 창이 나타납니다.

  • exercise_data 디렉터리를 찾아갑니다.

  • 사용자가 만든 새 레이어를 school_property.shp 으로 저장합니다.

새 레이어가 Layers list 에 추가됐을 것입니다.

6.1.2. basic Follow Along: 데이터소스

새 데이터를 생성하는 작업은 당연히 지표면에 실재하는 오브젝트에 관련된 것이어야 합니다. 따라서 어딘가에서 해당 정보를 구해야 합니다.

오브젝트 관련 데이터를 구할 수 있는 방법은 많습니다. 예를 들어 GPS를 이용해서 실재 세계에 있는 포인트들을 데이터화한 다음 QGIS로 불러들일 수 있습니다. 또는 경위의 측량계를 통해 포인트를 측정한 다음 좌표를 직접 입력해서 새 피처를 생성할 수도 있습니다. 아니면 위성영상이나 항공사진 같은 원격탐사 데이터로부터 오브젝트를 따오는 디지털라이즈 작업을 할 수도 있습니다.

이 예제에서는 디지털라이즈 작업을 이용합니다. 래스터 데이터셋 샘플을 갖추고 있으므로, 필요한 대로 불러들여야 합니다.

  • Click on the Add Raster Layer button: mActionAddRasterLayer
  • exercise_data/raster/ 디렉터리를 찾아가십시오.

  • 3420C_2010_327_RGB_LATLNG.tif 파일을 선택합니다.

  • Open 을 클릭합니다. 사용자 맵에 이미지가 로드될 것입니다.

  • Layers list 에서 이 새 이미지를 찾아보십시오.

  • 목록 맨 아래로 이미지를 클릭 & 드래그해서 사용자의 다른 레이어를 볼 수 있도록 합니다.

  • 다음 지역을 찾아 줌인/줌아웃하십시오.

../../../_images/map_area_zoom.png

주석

buildings 레이어 심볼이 래스터 레이어의 일부 또는 전체를 덮고 있다면, Layers panel 에서 해당 레이어를 선택 해제해서 일시적으로 비활성화시킬 수 있습니다. 또 roads 심볼이 방해가 된다면 마찬가지로 숨길 수도 있습니다.

다음 세 군데 학교 부지를 디지타이즈할 것입니다.

../../../_images/field_outlines.png

디지타이즈를 시작하려면 편집 모드 로 들어가야 합니다. GIS 소프트웨어는 우연히 중요한 데이터를 편집하거나 삭제하는 일을 막기 위해 일반적으로 이런 단계를 거치게 합니다. 각 레이어에 대해 개별적으로 편집 모드를 켜거나 끌 수 있습니다.

school_property 레이어에 대해 편집 모드로 들어가려면,

  • Layer list 에 있는 해당 레이어를 클릭해서 선택하십시오. (정확한 레이어를 선택했는지 확인하십시오. 다른 레이어를 편집하게 될 수도 있습니다!)

  • Toggle Editing 버튼 edit 을 클릭합니다.

이 버튼을 찾을 수 없을 경우, Digitizing 툴바가 활성화돼 있는지 확인해보십시오. View ‣ Toolbars ‣ Digitizing 메뉴 항목 옆에 체크 표시가 있어야 합니다.

편집 모드로 들어간 순간 디지타이즈 작업 도구가 활성화되는 것을 볼 수 있습니다.

mActionCapturePolygon mActionMoveFeature mActionNodeTool

다른 관련 버튼 네 개가 아직 활성화되지 않았지만, 새 데이터와 상호작용을 시작하면 활성화될 것입니다.

mActionSaveEdits mActionDeleteSelected mActionEditCut mActionEditCopy mActionEditPaste

툴바의 왼쪽에서 오른쪽 방향으로 각각 다음과 같습니다.

  • Save Edits: 레이어의 변경 사항을 저장합니다.

  • Add Feature: 새 피처의 디지타이즈 작업을 시작합니다.

  • Move Feature(s): 피처 전체를 이동합니다.

  • Node Tool: 피처의 일부만을 이동합니다.

  • Delete Selected: 선택한 피처를 삭제합니다.

  • Cut Features: 선택한 피처를 잘라냅니다.

  • Copy Features: 선택한 피처를 복사합니다.

  • Paste Features: 잘라낸 또는 복사한 피처를 다시 맵에 붙여넣습니다.

새 피처를 추가할 차례입니다.

  • Add Feature 버튼을 클릭해서 학교 운동장을 디지타이즈하는 작업을 시작하겠습니다.

마우스 커서가 십자 모양으로 변한 것을 눈치채셨습니까? 여러분이 좀 더 정확하게 포인트의 위치를 디지타이즈할 수 있도록 해줍니다. 디지타이즈 작업 도중이라도 마우스 휠을 돌려 맵을 줌인/줌아웃할 수 있고, 마우스 휠을 누른 채 드래그해서 맵을 이동할 수 있다는 것을 기억하십시오.

여러분이 디지타이즈할 첫 번째 피처는 다음 athletics field 입니다.

../../../_images/school_area_one.png
  • 운동장의 경계 어딘가의 포인트를 클릭해서 디지타이즈 작업을 시작합니다.

  • 여러분이 그리는 도형이 운동장을 완전히 가릴 때까지 경계를 따라 계속 포인트를 클릭합니다.

  • 마지막 포인트의 위치를 디지타이즈한 다음, 오른쪽 클릭 으로 폴리곤 그리기를 완료합니다. 피처가 완성되고 Attributes 대화 창이 나타날 것입니다.

  • 다음과 같이 값을 입력하십시오.

../../../_images/school_area_one_attributes.png
  • OK 를 클릭하면 새 피처가 생성됩니다!

피처를 디지타이즈할 때 실수를 했을 경우, 피처 생성 후에 언제라도 편집/수정할 수 있다는 사실을 기억하십시오. 실수를 했다 하더라도 앞의 지침대로 피처를 완성할 때까지 디지타이즈 작업을 계속한 다음,

  • Select Single Feature 도구로 해당 피처를 선택합니다.

../../../_images/single_feature_select.png

다음 도구를 사용할 수 있습니다.

  • Move Feature(s) 도구로 전체 피처를 이동할 수 있고,

  • Node Tool 도구로 여러분이 잘못 클릭한 단일 포인트를 이동시킬 수 있으며,

  • Delete Selected 도구로 피처를 완전히 삭제하고 다시 디지타이즈 작업을 시작하거나,

  • Edit ‣ Undo 메뉴 항목이나 ctrl + z 단축키로 실수한 부분을 되돌릴 수도 있습니다.

6.1.3. basic Try Yourself

  • 이제 학교와 그 위에 있는 운동장을 디지타이즈해보겠습니다. 다음 이미지를 참고하십시오.

../../../_images/field_outlines.png

새 피처에 각각 유일한 id 값을 부여해야 한다는 점을 기억하십시오!

주석

레이어에 피처를 추가하는 작업이 끝나면, 편집한 내용을 저장하고 편집 모드에서 나와야 한다는 사실을 잊지 마십시오.

주석

이전 강의에서 배운 기술을 이용해서 school_property 의 면, 윤곽선, 라벨 위치 및 서식에 스타일을 적용할 수 있습니다. 이 예제에서는 투명한 면에 밝은 보라색 점선의 윤곽선을 적용해봅시다.

6.1.5. In Conclusion

이제 피처를 생성하는 법을 배웠습니다! 이 강의에서는 포인트 피처를 추가하는 법을 다루지 않았는데, 여러분이 (라인이나 폴리곤 같은) 좀 더 복잡한 피처를 다루는 법을 안다면 포인트 피처도 쉽게 생성할 수 있기 때문입니다. 포인트 위치를 딱 한 번 클릭하는 것만 제외하면, 속성을 부여하고 피처를 생성하는 방법은 똑같습니다.

디지타이즈는 GIS 프로그램을 사용하면서 매우 일상적인 작업이기 때문에 그 방법을 아는 것은 매우 중요합니다.

6.1.6. What’s Next?

GIS 레이어 안의 피처는 그냥 그림이 아니라 공간에 있는 오브젝트입니다. 예를 들어 인접한 폴리곤들은 서로의 상대적인 위치를 알고 있습니다. 이것을 위상(topology) 이라고 합니다. 다음 강의에서 이 위상이 어떻게 유용한지에 대한 예제를 배울 것입니다.