Outdated version of the documentation. Find the latest one here.

.

Configuração QGIS

O QGIS é altamente personalizável através do menu Configurações . Escolha entre Painéis, Caixa de Ferramentas, Propriedades do Projecto, Opções e Personalização.

Note

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described above could be located in the :menuselection`view` menu (Panels and Toolbars) or in Project for Options.

Painéis e Barras de Ferramentas

No menu Painéis‣ pode desligar os widgets do QGIS. O menu Caixa de Ferramentas‣ fornece a possibilidade de trocar activar ou desactivar grupos de ícones na barra de ferramentas do QGIS (veja figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

Os Painéis e o Menu de Barra de Ferramentas nix

Tip

Activando o Enquadramento QGIS

No QGIS pode usar o painel do enquadramento que fornece a extensão total das camadas adicionadas. Pode ser seleccionada no menu nix Configurações ‣ Painéis ou win Ver ‣ Paineis. Dentro da vista existe um rectângulo a mostrar a extensão actual do mapa. Isto permite rapidamente determinar que área do mapa está a ver actualmente. É de notar que os rótulos não serão renderizados no enquadramento do mapa mesmo que seja activado a rotulagem. Se clicar e arrastar o rectângulo vermelho no enquadramento que mostra a actual extensão, este irá actualizar de acordo como o mapa principal.

Tip

Mostrar Mensagens de Registo

É possível seguir as mensagens do QGIS. Pode activar o checkboxRegisto de Mensagens no menu nix Configurações ‣ Painéis ou win Vier ‣ Painéis e seguir as mensagens que aparecem nos diferentes separadores durante o carregamento e operação.

Propriedades do Projecto

In the properties window for the project under nix Settings ‣ Project Properties (kde) or nix win Project ‣ Project Properties (Gnome), you can set project-specific options. These include:

  • No menu Geral podem ser definidos o título do projecto, a cor de selecção e fundo, unidades da camadas, precisão, e os caminhos relativos onde serão guardadas as camadas. Se a transformação SRC estiver ligada pode escolher o cálculo de distâncias recorrendo ao elipsóide. Pode definir as unidades do enquadramento (apenas usado quando a transformação SRC está desactivada) e a precisão das casas decimais a usar. Pode definir também uma escala de projecto, que rescreverá sobre as escalas globais pré-definidas.

  • O menu SRC permite que escolha o Sistema de Coordenadas Referência para o projecto, e para activar a reprojecção on-the-fly das camadas matricias e vectoriais na exibição de camadas de diferentes SRC.

  • Com o terceiro menu Identificar camadas pode definir (ou desactivar) que camadas irão responder à ferramenta identificar. (Veja o parágrafo das “Ferramentas de Mapa” da secção Opções Secção para activar a identificação de múltiplas camadas).

  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.
  • O separador Servidor OWS permite definir a informação sobre as Capacidades do WMS e WFS, a extensão e as restrições SRC do Servidor QGIS.

  • O menu Macros é para editar macros Python para os projectos. Actualmente, apenas estão disponíveis três macros: openProject(), saveProject() e closeProject().

Figure Macro Menu:

../../../_images/macro.png

Configurações de Macro no QGIS

  • O menu Relations é usado para definir relações 1:n. As relações são definidas no diálogo das propriedades do projecto. Quando existirem relações para uma camada, um novo elemento de interface do utilizador na vista de formulário (p. ex. quando identificar um elemento e abrir o seu formulário) irá listar os elementos relacionados. Isto fornece uma maneira poderosa para expressar p. ex. o histórico de inspecção ao longo de um segmento de tubagem ou estrada. Poderá encontrar mais informação sobre suporte de relações 1:n na Secção Creating one to many relations.

Opções

mActionOptions Algumas opções básicas para QGIS podem ser seleccionadas usando o diálogo Options. Selecione a opção de menu Settings ‣ mActionOptions Options. Os separadores onde poderá personalizar as suas opções são descritos abaixo.

Menu Geral

Aplicação

  • Seleccione a Estilo (Necessário reiniciar o QGIS) selectstring e escolha entre ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ e ‘Cleanlux’ (nix).

  • Definir o Tema de Ícone selectstring. Actualmente só a opção ‘default’ é possível.

  • Definir o Tamanho do Ícone selectstring.

  • Definir a Fonte. Escolha entre radiobuttonon QT padrão e uma fonte definida pelo utilizador.

  • Altera o Tempo limite para mensagens temporizadas ou diálogos selectstring.

  • checkbox Esconder o ecrã inicial no arranque

  • checkbox Mostrar dicas ao iniciar

  • checkbox Títulos da caixa de grupos a negrito

  • checkbox :guilabel:` Caixas de grupo em estilo QGIS`

  • checkbox Use diálogos selectores de cor com actualizações ao vivo

Ficheiros de projecto

  • Abrir o projecto no arranque selectstring (escolha entre ‘Novo’. ‘Mais recente’ e ‘Específico’). Quando escolher ‘Específico’ use browsebutton para definir um projecto.

  • checkbox Create new project from default project. Tem a possibilidade de carregar em Set current project as default ou em Reset default. Pode navegar através dos seus ficheiros e definir uma directoria onde encontrar os modelos de projecto definidos pelo utilizador. Isto será adicionado a Project ‣ New From Template. Primeiro active checkbox Create new project from default project e a seguir salve o projecto dentro da pasta de modelos de projecto.

  • checkbox Avisar para salvar projecto e alterações de fontes de dados quando necessário

  • checkbox Avisar quando abrir um projecto guardado com uma versão antiga do |qg|

  • Enable macros selectstring. Esta opção foi criada para lidar com as macros que são escritas para executar uma acção nos eventos do projecto. Pode escolher entre ‘Never’, ‘Ask’, ‘For this session only’ e ‘Always (not recommended)’.

Menu Sistema

Ambiente

Variáveis de ambiente do sistema podem ser vistas agora, e muitas configuradas, no grupo Environment (ver figure_environment_variables). Isto é útil para plataformas, tais como Mac, onde um aplicativo GUI não herda necessariamente o ambiente do utilizador da linha de comandos. Também é útil para configuração e visualização de variáveis de ambiente para os conjuntos de ferramentas externas controlados pela caixa de ferramentas de Processamento (p. ex., SAGA, GRASS), e para activar a saída de depuração (“debugging”) para secções específicas do código-fonte.

  • checkbox Use custom variables (restart required - include separators). You can [Add] and [Remove] variables. Already-defined environment variables are displayed in Current environment variables, and it’s possible to filter them by activating checkbox Show only QGIS-specific variables.

Figure System Environment:

../../../_images/sys-env-options.png

Variáveis de ambiente do Sistema no QGIS

Directórios dos módulos

[Adicionar] ou [Remover] Caminho(s) para pesquisar bibliotecas de módulos C++ adicionais

Menu Fonte de Dados

Atributos dos elementos e tabela

  • checkbox Abre a tabela de atributos na janela principal (Necessário reiniciar o QGIS)

  • checkbox Copy geometry in WKT representation from attribute table. When using mActionCopySelected Copy selected rows to clipboard from the Attribute table dialog, this has the result that the coordinates of points or vertices are also copied to the clipboard.
  • Comportamento da tabela de atributos selectstring. Existem três possibilidades: ‘Mostrar todos os elementos’, ‘Mostrar elementos seleccionados’ e ‘Mostrar elementos visiveis no mapa’.

  • Attribute table row cache selectnumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representação para valores NULL. Aqui, pode definir um valor para os campos de dados que contêm valores NULL.

Manipulação das fontes de dados

  • Pesquisar por atributos válidos na janela do navegador selectstring. Pode escolher entre ‘Verificar extensão’ e ‘Verificar conteúdo do ficheiro’.

  • Pesquisar por conteúdo de ficheiros compactados (.zip) na janela do navegador selectstring. ‘Não’, ‘Verificação básica’ e ‘Verificação completa’ são possiveis.

  • Prompt for raster sublayers when opening. Some rasters support sublayers — they are called subdatasets in GDAL. An example is netCDF files — if there are many netCDF variables, GDAL sees every variable as a subdataset. The option allows you to control how to deal with sublayers when a file with sublayers is opened. You have the following choices:
    • ‘Sempre’: Perguntar sempre (se existem subcamadas)

    • ‘Se necessário’: Perguntar se a camada não tem bandas, mas tem subcamadas

    • ‘Nunca’: Nunca pede, não irá carregar nada

    • ‘Carregar tudo’: Nunca pede, mas carrega todas as subcamadas

  • checkbox Ignora a declaração de codificação da shapefile. Se a shapefile tiver informação de codificação, este será ignorado pelo QGIS.

  • checkbox Adicionar uma camada PostGIS com duplo clique e seleccione em modo alargado

  • checkbox Adicione camadas Oracle com duplo clique e seleccione em modo alargado

Menu de Renderização

Comportamento da renderização

  • checkbox By default new layers added to the map should be displayed
  • checkbox Use render caching where possible to speed up redraws
  • checkbox Render layers in parallel using many CPU cores
  • checkbox Max cores to use
  • Map update interval (default to 250 ms)
  • checkbox Enable feature simplication by default for newly added layers
  • Simplification threshold
  • checkbox Simplify on provider side if possible
  • Maximum scale at which the layer should be simplified

Qualidade de renderização

  • checkbox Fazer com que as linhas apareçam menos irregulares, em detrimento de algum desempenho do desenho

Matriciais

  • Com a Selecção de banda RGB pode definir o número para a banda Vermelha, Verde e Azul.

Contrast enhancement

  • Banda cinzenta única selectstring. Uma banda cinzenta única pode ter ‘Sem esticar’, ‘Esticar para MinMax’, ‘Esticar e Cortar para MinMax’ e também ‘Cortar para MinMax’.

  • Multi band color (byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectstring. Options are ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’.
  • Limites de contagem cumulativa de pixeis de corte

  • Multiplicador do desvio-padrão

Corrigindo Erros

  • checkbox Map canvas refresh

Colors Menu

This menu allows you to add some custom color that you can find in each color dialog window of the renderes. You will see a set of predefined colors in the tab: you can delete or edit all of them. Moreover you can add the color you want and perform some copy and paste operation. Finally you can export the color set as a gpl file or import them.

Menu de Janela e Legenda

Aparência padrão do mapa (reescrita pelas propriedades do projecto)

  • Define a Cor da selecção e a Cor de fundo.

Legenda da camada

  • Duplo clique na legenda selectstring. Pode ‘Abrir propriedades da camada’ ou ‘Abrir tabela de atributos’ com duplo clique.

  • The following Legend item styles are possible:
    • checkbox Maiusculizar os nomes das camadas

    • checkbox Tornar negrito os nomes das camadas

    • checkbox Tornar negrito os nomes dos grupos

    • checkbox Mostrar nomes de atributos de classificação

    • checkbox Criar ícones matriciais (pode ser lento)

    • checkbox Adicionar novas camadas ao grupo actual ou seleccionado

Menu Ferramentas de Mapa

This menu offers some options regarding the behaviour of the Identify tool.

  • Search radius for identifying and displaying map tips is a tolerance factor expressed as a percentage of the map width. This means the identify tool will depict results as long as you click within this tolerance.
  • Highlight color allows you to choose with which color should features being identified are to be highlighted.
  • Buffer expressed as a percentage of the map width, determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width expressed as a percentage of the map width, determines how thick should the outline of a highlighted object be.

Ferramenta de medida

  • Define Cor do elástico para as ferramentas de medida

  • Define Casas decimais

  • checkbox Manter unidade base

  • Preferred measurements units radiobuttonon (‘Meters’, ‘Feet’, ‘Nautical Miles’ or ‘Degrees’)`
  • Preferred angle units radiobuttonon (‘Degrees’, ‘Radians’ or ‘Gon’)

Movendo e ampliando

  • Define a Acção da roda do rato selectstring (‘Visualizar’, ‘Visualizar e Centrar’, ‘Aproximar ao cursor do rato’, ‘Nada’)

  • Define o factor de aproximação/ afastamento para a roda do rato

Escalas pré-definidas

Here, you find a list of predefined scales. With the [+] and [-] buttons you can add or remove your individual scales.

Composer Menu

Composition defaults

You can define the Default font here.

Aparência da Grelha

  • Define the Grid style selectstring (‘Solid’, ‘Dots’, ‘Crosses’)
  • Define the Color...

Grid defaults

  • Define the Spacing selectnumber
  • Define the Grid offset selectnumber for x and y
  • Define the Snap tolerance selectnumber

Guide defaults

  • Define the Snap tolerance selectnumber

Menu Digitalizar

Criação de elementos

  • checkbox Suprimir atributos de janelas pop-up depois de cada elemento criado

  • checkbox Reutilizar últimos valores de atributos inseridos

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Elástico

  • Define a Borracha Espessura da linha e Cor da linha

Ajuste

  • checkbox Abrir opções de atracção na janela principal (necessário reiniciar o QGIS)

  • Define o Modo de atracção padrão selectstring (‘Ao vértice’, ‘Ao segmento’, ‘Ao vértice e segmento’, ‘Desligado’)

  • Define Tolerância de atracção pré-definida em unidades de mapa ou pixeis

  • Define o Raio de pesquisa para editar vértices em unidades de mapa ou pixeis

Marcadores de Vértices

  • checkbox Mostrar marcadores apenas para elementos seleccionados

  • Define o vértice do Estilo do Marcador selectstring (‘Cruz’ (padrão), ‘Circulo semi-transparente’ ou ‘Nenhum’)

  • Definir o vértice Tamanho do Marcador

Ferramenta de curva de afastamento

The next 3 options refer to the mActionOffsetCurve Offset Curve tool in Digitalização Avançada. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Join style
  • Quadrant segments
  • Miter limit

Menu GDAL

GDAL is a data exchange library for raster files. In this tab, you can Edit create options and Edit Pyramids Options of the raster formats. Define which GDAL driver is to be used for a raster format, as in some cases more than one GDAL driver is available.

Menu SRC

SRC padrão para novos projectos

  • radiobuttonoff Don’t enable ‘on the fly’ reprojection
  • radiobuttonon Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radiobuttonoff Enable ‘on the fly’ reprojection by default
  • Seleccione um SRC em Iniciar sempre um novo projecto com este SRC

SRC para novas camadas

This area allows you to define the action to take when a new layer is created, or when a layer without a CRS is loaded.

  • radiobuttonon Pergunta por SRC

  • radiobuttonoff Usar SRC do projecto

  • radiobuttonoff Utilizar SRC padrão mostrado em baixo

Default datum transformations

  • checkbox Ask for datum transformation when no default is defined
  • If you have worked with the ‘on-the-fly’ CRS transformation you can see the result of the transformation in the window below. You can find information about ‘Source CRS’ and ‘Destination CRS’ as well as ‘Source datum transform’ and ‘Destination datum transform’.

Locale Menu

  • checkbox Sobrepor idioma do sistema e Idioma a utilizar em alternativa

  • Informação sobre a região do sistema activo local

Network Menu

Geral

  • Define Pesquisa de endereço WMS, padrão como http://geopole.org/wms/search?search=\%1\&type=rss

  • Define Tempo esgotado para pedidos de rede (ms) - o padrão é 60000

  • Define Período de validade por defeito para tiles WMSC/WMTS (horas) - por defeito é 24

  • Define Max retry in case of tile request errors
  • Define User-Agent

Figure Network Tab:

../../../_images/proxy-settings.png

Configurações-proxy no QGIS

Configurações de cache

Define a Pasta e Tamanho para o cache.

  • checkbox Usar proxy para aceder à web e define ‘Máquina’, ‘Porta’, ‘Utilizador’, e ‘Palavra-chave’.

  • Configura o Tipo de proxy selectstring de acordo com as necessidades.

    • Default Proxy: Proxy é determinado baseando-se na definição do proxy da aplicação em uso

    • Socks5Proxy: Proxy genérico para qualquer tipo de ligação. Suporta TCP, UDP, unindo a uma porta (ligações de entrada) e autenticação.

    • HttpProxy: Implementado usando o comando “LIGAR” , apenas suporta ligações TCP de saída; suporta autenticação.

    • HttpCachingProxy: Implementado usando comandos HTTP normais, é útil apenas no contexto de pedidos HTTP.

    • FtpCachingProxy: Implementado usando um proxy FTP, é útil no contexto de pedidos FTP.

Alguns URLs excluídos podem ser adicionados na caixa de texto debaixo das configurações de proxy (veja Figure_Network_Tab).

If you need more detailed information about the different proxy settings, please refer to the manual of the underlying QT library documentation at http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Tip

Usando Proxies

Using proxies can sometimes be tricky. It is useful to proceed by ‘trial and error’ with the above proxy types, to check to see if they succeed in your case.

Pode modificar as opções de acordo com as suas necessidades. Algumas das alterações pode requerer o reinicio do QGIS antes de ser efectiva.

  • nix Settings are saved in a text file: $HOME/.config/QGIS/QGIS2.conf
  • osx pode encontrar as configurações em: $HOME/Library/Preferences/org.qgis.qgis.plist

  • As configurações win são armazenadas no registo em: HKEY\CURRENT_USER\Software\QGIS\qgis

Personalização

A ferramenta de personalização permite que (des)active a maioria dos elementos na interface de utilizador QGIS. Isto pode ser muito útil se tiver um número elevado de módulos instalados que nunca usa e que estão a encher o ecrã.

Figure Customization 1:

../../../_images/customization.png

A janela de Personalização nix

QGIS A Personalização está dividida em cinco grupos. No checkbox Menus pode esconder as entradas na Barra Menu. No checkbox Painel pode encontrar o painel de janelas. As janelas do Painel são aplicações que pode ser iniciadas e usadas como flutuantes, janelas de topo de nível ou embebidas na janela principal do QGIS como um widget ancorado (veja also Painéis e Barras de Ferramentas). Na checkbox Barra de Estado características como a informação das coordenadas podem ser desactivadas. Na checkbox Caixa de Ferramentas pode (des)activar os ícones da barraa de ferramentas do QGIS e em checkbox Widgets pode (des)activatar janelas assim como os seus botões.

With mActionSelect Switch to catching widgets in main application, you can click on elements in QGIS that you want to be hidden and find the corresponding entry in Customization (see figure_customization). You can also save your various setups for different use cases as well. Before your changes are applied, you need to restart QGIS.