Outdated version of the documentation. Find the latest one here.

7.4. Lesson: Statistici Spațiale

Note

Lecția a fost dezvoltată de Linfiniti și S Motala (Cape Peninsula University of Technology

Statisticile spațiale vă permit să analizați și să înțelegeți ce se întâmplă într-un anumit set de date. QGIS include mai multe instrumente standard de analiză statistică, care se dovedesc utile în acest sens.

Scopul acestei lecții: De a afla cum se pot utiliza instrumentele de statistici spațiale QGIS.

7.4.1. basic Follow Along: Crearea unui Set de Date de Test

În scopul de obținerii unui set de date pentru a lucra cu el, vom crea un set de puncte aleatorii.

Pentru a face acest lucru, veți avea nevoie de un set de date poligonale, care definește extinderea zonei în care doriți să creați punctele.

Vom folosi aria acoperită de străzi.

  • Creați o nouă hartă albă.

  • Adăugați stratul dvs. roads_34S, la fel ca și rasterul srtm_41_19.tif (datele de elevatie) găsite în exercise_data/raster/SRTM/.

Note

Stratul dvs. DEM SRTM este posibil să aibă un alt CRS decât cel al stratului drumurilor. Dacă este așa, atunci puteți reproiecta fie stratul drumurilor, fie pe cel al DEM-ului, folosind tehnicile învățate mai devreme în acest modul.

  • Folosiți instrumentul Convex hull(s) (disponibil în Vector ‣ Geoprocessing Tools) pentru a genera o zonă care să includă toate drumurile:

../../../_images/roads_hull_setup.png
  • Salvați rezultatul în exercise_data/spatial_statistics/, sub denumirea roads_hull.shp.

  • Bifați opțiunea de Adăugare rezultat la canevas pentru a adăuga rezultatul la Cuprins (Lista straturilor).

7.4.1.1. Crearea de puncte aleatorii

  • Crearea de puncte aleatorii în această arie, prin utilizarea instrumentului Vector ‣ Research Tools ‣ Random points:

../../../_images/random_points_setup.png
  • Salvați rezultatul în exercise_data/spatial_statistics/, sub denumirea random_points.shp.

  • Bifați opțiunea de Adăugare rezultat la canevas pentru a adăuga rezultatul la Cuprins (Lista straturilor).

../../../_images/random_points_result.png

7.4.1.2. Eșantionarea datelor

  • Pentru a crea un set de eșantion de date raster, va trebui să utilizați plugin-ul Point sampling tool.

  • Căutați mai întâi modulul în plugin-uri, dacă este necesar.

  • Căutați fraza point sampling în Plugin –> Manage and Install Plugins... apoi veți găsi plugin-ul.

  • O dată ce ați activat Managerul de Plugin-uri, veți găsi instrumentul sub Plugins ‣ Analyses ‣ Point sampling tool:

../../../_images/sampling_plugin_dialog.png
  • Alegeți random_points ca fiind stratul care conține punctele de prelevare, precum și rasterul SRTM ca fiind banda din care se vor obține valorile.

  • Asigurați-vă că ați bifat “Add created layer to the TOC”.

  • Salvați rezultatul în exercise_data/spatial_statistics/, sub denumirea random_samples.shp.

Acum puteți verifica datele eșantion din fișierul raster în tabelul de atribute al stratului random_samples, acestea aflându-se în coloana denumită srtm_41_19.tif.

Un posibil strat eșantion este prezentat aici:

../../../_images/random_samples_result.png

Punctele eșantion sunt clasificate în funcție de valorile lor, astfel că punctele mai întunecate sunt situate la o altitudine joasă.

Veți folosi acest strat eșantion pentru restul exercițiilor statistice.

7.4.2. basic Follow Along: Statistici de Bază

Obține statisticile de bază pentru acest strat.

  • Faceți clic pe elementul de meniu Vector ‣ Analysis Tools ‣ Basic statistics.

  • În caseta de dialog care apare, specificați stratul random_samples ca și sursă.

  • Asigurați-vă că Target field este setat la srtm_41_19.tif, care este câmpul pentru care veți calcula statisticile.

  • Faceți clic pe Ok. Veți obține rezultate ca acesta:

../../../_images/basic_statistics_results.png

Note

Puteți copia și lipi rezultatele într-o foaie de calcul. Datele folosesc un separator (două puncte :).

../../../_images/paste_to_spreadsheet.png
  • Închideți dialogul plugin-ului, după încheiere.

Pentru a înțelege statisticile de mai sus, consultați această listă cu definiții:

Media

Valoarea medie (medie) valoarea reprezintă pur și simplu suma valorilor împărțită la cantitatea de valori.

StdDev

Abaterea standard. Oferă o indicație despre cât de strâns sunt grupate valorile în jurul mediei. Cu cât este mai mică deviația standard, cu atât mai apropiată tinde să fie media.

Sum

Toate valorile adunate.

Min

Valoarea minimă.

Max

Valoarea maximă.

N

Cantitatea de eșantioane/valori.

CV

Covarianța spațială a setului de date.

Numărul de valori unice

Numărul de valori, care sunt unice în acest set de date. Dacă există 90 de valori unice într-un set de date cu N = 100, atunci cele 10 valori rămase pot fi identice între ele.

Intervalul

Diferența dintre valorile minime și maxime.

Mediana

Dacă aranjați toate valorile de la cea mai mică la cea mai mare, valoarea de mijloc (sau media celor două valori de mijloc, în cazul în care N este un număr par) este mediana valorilor.

7.4.3. basic Follow Along: Calculul unei Matrici a Distanțelor

  • Creați un strat nou, de tip punct, în aceeași proiecție ca și alte seturi de date (WGS 84 / UTM 34S).

  • Intrațibîn modul de editare și digitizați trei puncte, undeva printre celelalte.

  • Ca o alternativă, utilizați aceeași metodă de generare a punctelor aleatorii la fel ca înainte, însă specificați doar trei puncte.

  • Salvați noul strat ca și distance_points.shp.

Pentru a genera o matrice a distanțelor folosind aceste puncte:

  • Deschideți instrumentul Vector ‣ Analysis Tools ‣ Distance matrix.

  • Selectați stratul distance_points ca și sursă, apoi stratul random_samples ca destinație.

  • Setați-l astfel:

../../../_images/distance_matrix_setup.png
  • Salvați rezultatul ca și distance_matrix.csv.

  • Clic pe OK, pentru a genera matricea distanțelor.

  • Deschideți-l într-un program de calcul tabelar pentru a vedea rezultatele. Iată un exemplu:

../../../_images/distance_matrix_example.png

7.4.4. basic Follow Along: Analiza Celui Mai Apropiat Vecin

Pentru a face o analiză a celui mai apropiat vecin:

  • Faceți clic pe elementul de meniu Vector ‣ Analysis Tools ‣ Nearest neighbor analysis.

  • În caseta de dialog care apare, specificați stratul random_samples, apoi faceți clic pe OK.

  • Rezultatele vor apărea în textul ferestrei de dialog, de exemplu:

../../../_images/nearest_neighbour_example.png

Note

Puteți copia și lipi rezultatele într-o foaie de calcul. Datele folosesc un separator (două puncte :).

7.4.5. basic Follow Along: Coordonatele Medii

Pentru a obține coordonatele medii ale unui set de date:

  • Clic pe elementul de meniu Vector ‣ Analysis Tools ‣ Mean coordinate(s).

  • În caseta de dialog care apare, specificați stratul random_samples ca și intrare, dar lăsați alegerile opționale neschimbate.

  • Specificați stratul de ieșire mean_coords.shp.

  • Clic pe OK

  • Adăugați stratul la Lista straturilor, atunci când vi se cere.

Haideți să-l comparăm cu coordonatele centrale ale poligonului care a fost folosit pentru a crea eșantionul aleator.

  • Faceți clic pe elementul de meniu Vector ‣ Geometry Tools ‣ Polygon centroids menu item.

  • În caseta de dialog care apare, selectați stratul roads_hull ca intrare.

  • Salvați rezultatul ca și center_point.

  • Adăugați-l în Lista straturilor, atunci când vi se cere.

După cum puteți vedea din exemplul de mai jos, coordonatele medii și centrul zonei de studiu (în portocaliu) nu coincid în mod necesar:

../../../_images/polygon_centroid_mean.png

7.4.6. basic Follow Along: Histogramele de tip Imagine

Histograma unui set de date arată distribuția valorilor sale. Cel mai simplu mod de a demonstra acest lucru în QGIS este prin histograma imaginii, disponibilă în dialogul Layer Properties al oricărui strat de imagine.

  • În Lista straturilor faceți clic-dreapta pe stratul SRTM DEM.

  • Selectați Proprietăți.

  • Alegeți fila Histogram. Poate fi necesar să faceți clic pe butonul Compute Histogram pentru a genera graficul. Veți vedea un grafic care descrie frecvența valorilor din imagine.

  • O puteți exporta ca o imagine:

../../../_images/histogram_export.png
  • Selectând fila Metadatelor, puteți vedea informații mai detaliate în interiorul casetei Properties.

Valoarea medie este 332.8, iar valoarea maximă este 1699! Dar aceste valori nu apar pe histogramă. Oare de ce? Din cauză că sunt atât de puține, comparativ cu abundența de pixeli cu valori sub medie. Acesta este motivul pentru care histograma se extinde mult spre dreapta, chiar dacă nu este vizibilă linia roșie care marchează valori de frecvență mai mari de 250.

Prin urmare, rețineți că o histogramă vă arată distribuția valorilor, dar nu toate valorile sunt în mod necesar vizibile pe grafic.

  • (Acum puteți închide Stratul Proprietăților.)

7.4.7. basic Follow Along: Interpolarea Spațială

Să presupunem că aveți o colecție de puncte de eșantionare din care ați dori să extrapolați datele. De exemplu, ați putea avea acces la setul de date random_samples pe care l-am creat mai devreme, și să vă faceți o idee despre cum ar arăta terenul.

Pentru a începe, utilizați instrumentul Grid (Interpolation), prin efectuarea unui clic pe elementul de meniu Raster ‣ Analysis ‣ Grid (Interpolation).

  • În câmpul Input file field, selectați random_samples.

  • Bifați caseta Z Field, apoi selectați câmpul srtm_41_19.

  • Setați locația Fișierului de ieșire la exercise_data/spatial_statistics/interpolation.tif.

  • Bifați caseta Algorithm, apoi selectați Inverse distance to a power.

  • Setați Power la 5.0 și Smoothing la 2.0. Lăsați celelalte valori așa cum sunt.

  • Bifaţi caseta Load into canvas when finished, apoi faceți clic pe OK.

  • Când ați terminat, faceți clic pe OK, în dialogul care spune că Procesul s-a încheiat, faceți clic pe OK, în dialogul care arată informația returnată (dacă aceasta apare), și în final faceți clic pe Close în dialogul de (Interpolare) Grilă.

Iată o comparație a setului de date original (stânga) cu cel construit din eșantionul nostru de puncte (dreapta). Al dvs. poate să arate diferit, din cauza naturii aleatorii a locației punctelor de eșantionare.

../../../_images/interpolation_comparison.png

După cum puteți vedea, un eșantion compus din 100 puncte nu este cu adevărat suficient pentru a obține o imagine detaliată a terenului. El oferă doar o idee foarte generală, care, însă, poate fi înșelătoare. De exemplu, în imaginea de mai sus, nu este clar dacă există un munte masiv, neîntrerupt, întinzându-se de la est la vest; mai degrabă, imaginea pare să arate o vale, cu vârfuri înalte la vest. Folosind doar inspecția vizuală, observăm că setul de date eșantion nu este reprezentativ pentru teren.

7.4.8. moderate Try Yourself

  • Utilizați procedeele prezentate mai sus pentru a crea un nou set de 1000 de puncte aleatorii.

  • Folosiți aceste puncte pentru a eșantiona DEM-ul original.

  • Aplicați instrumentul de (Interpolare) Grilă pe acest nou set de date, ca mai sus.

  • Setați numele fișierului de ieșire la interpolation_1000.tif, având Power și Smoothing setate la 5.0 și respectiv 2.0.

Rezultatele (în funcție de poziționarea punctelor aleatorii) va arata mai mult, sau mai puțin, ca aceasta:

../../../_images/interpolation_comparison_1000.png

Bordura din jurul stratului roads_hull (care reprezintă limita punctelor aleatorii de eșantionare), explică lipsa bruscă a detaliilor dincolo de marginile sale. Aceasta este o reprezentare a terenului mult mai bună, ca urmare a ridicatei densități de puncte eșantion.

Aici este un exemplu despre cum arată cu 10 000 de puncte eșantion:

../../../_images/011.png

Note

Nu se recomandă să încercați cu 10 000 de puncte de eșantionare dacă nu lucrați pe un computer rapid, deoarece mărimea setului de date eșantion determină timpul de procesare.

7.4.9. moderate Follow Along: Instrumente Adiționale de Analiză Spațială

Inițial, un proiect separat și apoi accesibil sub formă de plugin, soft-ul SEXTANTE a fost adăugat la QGIS ca o funcție de bază începând cu versiunea 2.0. Îl puteți găsi într-un nou meniu din QGIS, sub numele Processing, care oferă un bogat set de instrumente de analiză spațială, alături de diverse plugin-uri, toate fiind accesibile din interiorul unei singure interfețe.

  • Activați acest set de instrumente, prin accesarea elementului de meniu Processing ‣ Toolbox menu entry. Setul de instrumente arată astfel:

../../../_images/sextante_toolbox.png

Îl veți vedea, probabil, andocat în QGIS, în dreapta hărții. Rețineți că instrumentele enumerate aici sunt link-uri către instrumente reale. Unele dintre ele reprezintă algoritmi proprii SEXTANTE, iar altele reprezintă trimiteri către instrumente accesate din aplicații externe, cum ar fi GRASS, SAGA sau Orfeo Toolbox. Aceste aplicații externe sunt instalate o dată cu QGIS, astfel că sunteți deja în măsură să faceți uz de ele. În cazul în care trebuie să schimbați configurația instrumentelor Processing sau când, de exemplu, trebuie să treceți la o nouă versiune a uneia dintre aplicațiile externe, puteți accesa setările sale din Processing ‣ Options and configurations.

7.4.10. moderate Follow Along: Analiza Modelului de Puncte Spațiale

Pentru o indicație simplă a distribuției spațiale a punctelor în setul de date random_samples, putem folosi instrumentul Spatial Point Pattern Analysis din SAGA, prin intermediul Instrumentarului Processing pe care tocmai l-ați deschis.

  • În Processing Toolbox, căutați instrumentul Spatial Point Pattern Analysis.

  • Dublu-clic pe el pentru a-i deschide dialogul.

7.4.10.1. Instalarea SAGA

Note

Dacă SAGA nu este instalat pe sistemul dvs., dialogul plugin-ului vă va informa că dependența lipsește. Dacă nu vă aflați în acest caz, puteți sări peste acești pași.

7.4.10.2. Pe Windows

Inclus în materialele dvs. de curs, veți găsi programul de instalare al aplicației SAGA pentru Windows.

  • Porniți programul și urmați instrucțiunile sale pentru a instala SAGA pe sistemul dvs. Windows. Notați calea de instalare!

O dată ce ați instalat SAGA, va trebui să specificați calea sa de instalare în SEXTANTE.

  • Faceți clic pe elementul de meniu Analysis ‣ SAGA options and configuration.

  • În caseta de dialog care apare, expandați elementul SAGA, apoi căutați folderul SAGA. Valoarea sa va fi albă.

  • În acest spațiu, introduceți calea în care ați instalat SAGA.

7.4.10.3. Pe Ubuntu

  • Căutați SAGA GIS în Software Center, sau introduceți fraza sudo apt-get install saga-gis în terminalul dvs. (Este posibil să trebuiască mai întâi să adăugați un depozit SAGA la sursele dvs.)

  • QGIS va găsi SAGA automat, deși ar putea fi necesar să reporniți QGIS în cazul în care nu funcționează imediat.

7.4.10.4. Pe Mac

Utilizatorii Homebrew pot instala SAGA cu această comandă:

  • brew install saga-core

Dacă nu utilizați Homebrew, vă rugăm să urmați instrucțiunile de aici:

http://sourceforge.net/apps/trac/saga-gis/wiki/Compiling%20SAGA%20on%20Mac%20OS%20X

7.4.10.5. După instalare

Acum, că ați instalat și configurat SAGA, funcțiile sale vor deveni accesibile pentru dvs.

7.4.10.6. Folosirea SAGA

  • Deschideți fereastra de dialog SAGA.

  • SAGA produce trei ieșiri, așa că va fi nevoie de trei căi de ieșire.

  • Salvați aceste trei ieșiri în exercise_data/spatial_statistics/, folosind orice nume de fișier pe care îl veți considera adecvat.

../../../_images/002.png

Ieșirea va arata astfel (simbolistica a fost schimbată pentru acest exemplu):

../../../_images/003.png

Punctul roșu reprezintă centrul mediei; cercul mare este distanța standard, care oferă indicații despre cât de strâns sunt distribuite punctele în jurul centrului mediei; iar dreptunghiul reprezintă caseta de încadrare, care descrie cel mai mic dreptunghi posibil care include toate punctele.

7.4.11. moderate Follow Along: Analiza Distanței Minime

De multe ori, ieșirea unui algoritm nu va fi un fișier shape, ci mai degrabă un tabel care rezumă proprietățile statistice ale un set de date. Un astfel de exemplu este instrumentul Minimum Distance Analysis.

  • Găsiți acest instrument în Processing Toolbox ca Analiza Distanței Minime.

Nu este nevoie de nici o altă intrare, în afară de specificarea setului vectorial de date de tip punct, de analizat.

  • Alegeți setul de date random_points.

  • Faceți clic pe:guilabel:OK. La finalizare, un tabel DBF va apărea în Lista straturilor.

  • Selectați-l, apoi deschideți tabelul de atribute. Deși cifrele pot varia, rezultatele vor fi în acest format:

../../../_images/min_distance_results.png

7.4.12. In Conclusion

QGIS oferă multe posibilități de analiză a proprietăților statistice spațiale pentru seturile de date.

7.4.13. What’s Next?

Acum, că am acoperit analiza vectorială, de ce să nu vedem și ce se poate face cu rasterele? Asta e ceea ce vom face în modulul următor!