Outdated version of the documentation. Find the latest one here.

Editando

QGIS supports various capabilities for editing OGR, SpatiaLite, PostGIS, MSSQL Spatial and Oracle Spatial vector layers and tables.

Note

O procedimento para editar camadas GRASS é diferente - veja Secção Digitalizando e editando as camadas vectoriais GRASS para detalhes.

Tip

Edições Simultâneas

Esta versão do QGIS não controla se alguém está a editar um elemento ao mesmo tempo que você. As edições que serão guardadas são as da última pessoa que modifica o elemento.

Configurando a Tolerância de Atracção e Raio de Pesquisa

Antes de podermos editar os vértices, necessitamos de configurar a tolerância e o raio de pesquisa para um valor que nos permita uma edição ideal das geometrias da camada vectorial.

Tolerância de Atracção

A tolerância de atracção é a distância que o QGIS usa para procurar o vértice mais próximo e/ou segmento que está a tentar ligar quando define um novo vértice ou move um vértice existente. Se não estiver dentro da tolerância de atracção, o QGIS irá deixar o vértice onde libertou o botão do rato, em vez de atrair a um vértice e/ou segmento existente. A configuração da tolerância de atracção afecta todas as ferramentas que trabalham com a tolerância.

  1. A general, project wide snapping tolerance can be defined choosing Settings ‣ mActionOptions Options. On Mac: go to QIS ‣ mActionOptions Preferences..., on Linux: Edit ‣ mActionOptions Options. In the Digitizing tab you can select between to vertex, to segment or to vertex and segment as default snap mode. You can also define a default snapping tolerance and a search radius for vertex edits. The tolerance can be set either in map units or in pixels. The advantage of choosing pixels, is that the snapping tolerance doesn’t have to be changed after zoom operations. In our small digitizing project (working with the Alaska dataset), we define the snapping units in feet. Your results may vary, but something on the order of 300ft should be fine at a scale of 1:10 000 should be a reasonable setting.
  2. A camada baseada na tolerância de atracção pode ser definida escolhendo Configurações ‣ (ou Ficheiro ‣) Opções de Ressalto... para activar e ajustar o modo de atracção e tolerância na camada base (veja figure_edit_1 ).

Note que esta camada baseada na atracção e sobrepõe-se à opção global de atracção definida no separador da Digitalização. Portanto, se necessitar de editar uma camada, e efectuar a atracção dos vértices noutra camada, então active apenas atrair à camada, e de seguida diminui a tolerância de atracção global para o valor mais pequeno. Além disso, a atracção não irá ocorrer numa camada que não está activada na janela de opções de atracção, independentemente da tolerância de atracção global. Portanto, certifique-se de marcar a caixa de verificação para estas camadas que necessita de atrair.

Figure Edit 1:

../../../_images/editProjectSnapping.png

Edição das opções de atracção numa camada base nix

Raio de pesquisa

O Raio de Pesquisa é a distância que o QGIS usa para procurar pelo vértice mais próximo que está a tentar mover quando clica no mapa. Se não estiver dentro do raio de pesquisa, o QGIS não irá encontrar e seleccionar nenhum vértice para editar e irá mostrar um aviso para esse efeito. A tolerância de atracção e o raio de pesquisa são definidos em unidades de mapa ou pixeis, por isso pode experimentá-los para obter a definição correcta. Se especificar uma tolerância muito grande, o|qg| pode atrair o vértice errado, especialmente se necessita de lidar com um número grande de vértices que estão muitos próximos entre eles. Definir o raio de pesquisa muito pequenonão irá encontrar nada para mover.

O raio de pesquisa para as edições de vértices nas unidades da camada pode ser definida no separador Digitalização nas Configurações ‣ mActionOptions Opções. No mesmo sítio onde define o geral e a largura tolerância de atracção.

Ampliando e Movendo

Antes de editar uma camada, deve fazer uma ampliação à zona da área de interesse. Isto evita que espere enquanto os marcadores dos vértices são renderizados em toda a camada.

Além de usar os ícones mActionPan mover mapa e mActionZoomIn aproximar / mActionZoomOut afastar na barra de ferramentas com o rato, a navegação pode também ser feita com a roda do rato, espaço e as teclas de direcção.

Ampliando e movendo com a roda do rato

Enquanto digitaliza pode pressionar na roda do rato para mover dentro da janela principal e pode rodar a roda do rato para aproximar e afastar no mapa. Para aproximar num sítio posicione o cursor do rato dentro da área do mapa e rode para a frente (afastando de si) para aproximar e rode para trás (aproxime para si) para afastar. A posição do cursor do rato irá estar no centro da área de interesse ampliada. Pode personalizar o comportamento do zoom da roda do rato usando o separador Ferramentas do Mapa no menu Configurações ‣ mActionOptions Opções.

Movendo a direcção com as setas do teclado

O mapa pode ser movido durante a digitalização recorrendo às teclas de direcção. Posicione o cursor do rato dentro da área do mapa e clique em cima da tecla direita para mover para este, esquerda para mover para oeste, para cima para mover para norte e para baixo para mover para sul.

Pode também usar a barra de espaço para temporariamente causar movimentos no rato para mover depois o mapa. As teclas PgUp e PgDown do seu teclado irão fazer com que o mapa aproxime ou afaste interrompendo a sua sessão de edição.

Edição Topológica

Além das opções baseadas na atracção da camada pode também definir algumas funcionalidades topológicas no diálogo Opções de atracção... no menu Configurações (ou Ficheiro). Aqui pode definir checkbox Activar edição topológica e/ou para camadas de polígonos pode activar a coluna checkbox Evitar Intersecções. que evita intersecções de novos polígonos.

Activar edição topológica

The option checkbox Enable topological editing is for editing and maintaining common boundaries in polygon mosaics. QGIS ‘detects’ a shared boundary in a polygon mosaic and you only have to move the vertex once and QGIS will take care about updating the other boundary.

Evitar intersecções de novos polígonos

The second topological option in the checkbox Avoid Int. column, called Avoid intersections of new polygons avoids overlaps in polygon mosaics. It is for quicker digitizing of adjacent polygons. If you already have one polygon, it is possible with this option to digitize the second one such that both intersect and QGIS then cuts the second polygon to the common boundary. The advantage is that users don’t have to digitize all vertices of the common boundary.

Activar atracção nas intersecções

Another option is to use checkbox Enable snapping on intersection. It allows to snap on an intersection of background layers, even if there’s no vertex on the intersection.

Digitalizar uma camada existente

By default, QGIS loads layers read-only: This is a safeguard to avoid accidentally editing a layer if there is a slip of the mouse. However, you can choose to edit any layer as long as the data provider supports it, and the underlying data source is writable (i.e. its files are not read-only).

De um modo geral, a edição de camadas vectoriais está dividida na digitalização e na barra de ferramentas de digitalização avançada, descrita na Secção Digitalização Avançada. Pode marcar e desmarcar ambos em Configurações ‣ Barra de Ferramentas ‣. Usando as ferramentas de digitalização básica pode executar as seguintes funções:

Ícone

Finalidade

Ícone

Finalidade

mActionAllEdits

Edições actuais

mActionToggleEditing

Alternar edição

mActionCapturePoint

Adicionando Elementos: Capturar Ponto

mActionCaptureLine

Adicionando Elementos: Capturar Linha

mActionCapturePolygon

Adicionando Elementos: Capturar Polígono

mActionMoveFeature

Mover Elemento

mActionNodeTool

Ferramenta de Nós

mActionDeleteSelected

Apagar Seleccionados

mActionEditCut

Cortar Elementos

mActionEditCopy

Copiar Elementos

mActionEditPaste

Colar Elementos

mActionSaveEdits

Guardar edições da camada

Edição da Tabela: Edição básica da camada vectorial pela barra de ferramentas

Todas as sessões de edição começam por escolher a opção mActionToggleEditing Alternar Edição . Isto pode ser encontrado no menu de contexto depois de clicar com o botão direito do rato na entrada da legenda para essa camada

Alternadamente, pode usar o botão Alternar Edição mActionToggleEditing Alterar edições da barra de ferramentas de digitalização para iniciar e parar o modo de edição. Estando a camada no modo de edição, os marcadores irão aparecer nos vértices e botões de ferramentas adicionais na barra de ferramentas de edição estarão disponíveis.

Tip

Guardar Regularmente

Lembre-se de mActionSaveEdits Guardar Edições da Camada regularmente. Isto irá também verificar que a sua fonte de dados aceita todas as alterações.

Adicionando Elementos

Pode usar os ícones mActionCapturePoint Adicionar Elemento, mActionCaptureLine Adicionar Elemento ou mActionCapturePolygon Adicionar Elemento da barra de ferramentas para por o cursor QGIS no modo de digitalização.

Para cada elemento, primeiro digitaliza a geometria, e de seguida introduz os atributos. Para digitalizar a geometria, clique com o botão direito do rato na área do mapa para criar o primeiro ponto do seu novo elemento.

Para linhas e polígonos, mantenha o clique com o botão direito do rato para cada ponto adicional que pretende capturar. Quando acabar de adicionar os pontos, clique com o direito do rato em qualquer sítio da área do mapa para confirmar a finalização da introdução da geometria desse elemento.

The attribute window will appear, allowing you to enter the information for the new feature. Figure_edit_2 shows setting attributes for a fictitious new river in Alaska. In the Digitizing menu under the Settings ‣ Options menu, you can also activate checkbox Suppress attributes pop-up windows after each created feature checkbox Reuse last entered attribute values.

Figure Edit 2:

../../../_images/editDigitizing.png

Introduza os Valores dos atributos na Janela após a digitalização do novo elemento vectorial nix

Com o ícone mActionMoveFeature Mover Elemento(s) da barra de ferramentas pode mover elementos existentes.

Tip

Tipos de Valores de Atributo

a edição dos tipos de atributo são validados durante a introdução. Por causa disso, não é possível introduzir um número na coluna de texto na janela Introduzir Valores de Atributo ou vice-versa. Se necessita de fazer isso, deve editar os atributos numa segunda etapa dentro da janela Tabela de Atributos .

Edições Actuais

Este novo elemento permite a digitalização de múltiplas camadas. Escolha mActionFileSaveAs Guardar para as Camadas Seleccionadas para guardar todas as alterações que fez nas múltiplas camadas. Tem também a oportunidade de mActionRollbackEdits Regressão para as Camadas Seleccionadas para que a digitalização seja retirada das camadas seleccionadas. Se deseja parar a edição das camadas seleccionadas o mActionCancelEdits Cancelar para as Camada(s) Seleccionadas é a melhor forma de o fazer.

As mesmas funções para a edição de todas as camadas do projecto estão disponíveis.

Ferramenta de Nós

For shapefile-based layers as well as SpatialLite,PostgreSQL/PostGIS, MSSQL Spatial and Oracle Spatial tables the mActionNodeTool Node Tool provides manipulation capabilites of feature vertices similar to CAD programs. It is possible to simply select multiple vertices at once and to move, add or delete them alltogether. The node tool also works with ‘on the fly’ projection turned on and supports the topological editing feature. This tool is, unlike other tools in QGIS, persistent, so when some operation is done, selection stays active for this feature and tool. If the node tool couldn’t find any features, a warning will be displayed.

é importante configurar a propriedade configurações ‣ mActionOptions Opções ‣ Digitalização ‣ Raio de Pesquisa: selectnumber para um número maior que zero (ex.: 10), Caso contrário o QGIS não é capaz de dizer que vértice está a ser editado.

Tip

Marcadores de Vértice

A actual versão do QGIS suporta três tipos de marcadores vértice: círculo Semi-transparente, Cruz ou Nenhum. Para mudar o estilo do marcador, escolha mActionOptions Opções do menu Configurações e clique no separador Digitalização e seleccione a entrada apropriada.

Operações Básicas

Comece por activar a mActionNodeTool Ferramenta de Nós e seleccione um elemento clicando em cima de um, As caixas vermelhos irão aparecer em cada vértice deste elemento.

  • Selecting vertices: You can select vertices by clicking on them one at a time, by clicking on an edge to select the vertices at both ends, or by clicking and dragging a rectangle around some vertices. When a vertex is selected its color changes to blue. To add more vertices to the current selection, hold down the Ctrl key while clicking. Hold down Ctrl or Shift when clicking to toggle the selection state of vertices (vertices that are currently unselected will be selected as usual, but also vertices that are already selected will become unselected).
  • Adding vertices: To add a vertex simply double click near an edge and a new vertex will appear on the edge near to the cursor. Note that the vertex will appear on the edge, not at the cursor position, therefore it has to be moved if necessary.
  • Deleting vertices: After selecting vertices for deletion, click the Delete key. Note that you cannot use the mActionNodeTool Node Tool to delete a complete feature; QGIS will ensure it retains the minimum number of vertices for the feature type you are working on. To delete a complete feature use the mActionDeleteSelected Delete Selected tool.
  • Moving vertices: Select all the vertices you want to move. Click on a selected vertex or edge and drag in the direction you wish to move. All the selected vertices will move together. If snapping is enabled, the whole selection can jump to the nearest vertex or line.

Each change made with the node tool is stored as a separate entry in the undo dialog. Remember that all operations support topological editing when this is turned on. On the fly projection is also supported, and the node tool provides tooltips to identify a vertex by hovering the pointer over it.

Cortando, Copiando e Colando Elementos

Selected features can be cut, copied and pasted between layers in the same QGIS project, as long as destination layers are set to mActionToggleEditing Toggle editing beforehand.

Os elementos podem também ser colados em aplicações externas como texto: Ou seja, os elementos são representados no formato CSV com os dados de geometria a aparecerem no formato OGC Well-Known Text (WKT).

However in this version of QGIS, text features from outside QGIS cannot be pasted to a layer within QGIS. When would the copy and paste function come in handy? Well, it turns out that you can edit more than one layer at a time and copy/paste features between layers. Why would we want to do this? Say we need to do some work on a new layer but only need one or two lakes, not the 5,000 on our big_lakes layer. We can create a new layer and use copy/paste to plop the needed lakes into it.

Como exemplo vamos copiar alguns lagos para a nova camada:

  1. Carregue a camada que quer copiar a partir (camada de origem)

  2. Carregue ou crie a camada que quer copiar para (camada de destino)

  3. Começar a editar a camada de destino

  4. Active a camada de origem clicando nela na legenda

  5. Use a ferramenta mActionSelect Seleccione Elemento Único para seleccionar os elemento(s) na camada fonte

  6. Clique na ferramenta mActionEditCopy Copiar Elementos

  7. Active a camada de destino clicando na legenda

  8. Clique na ferramenta mActionEditPaste Colar Elementos

  9. Parar a edição e guardar as alterações

What happens if the source and target layers have different schemas (field names and types are not the same)? QGIS populates what matches and ignores the rest. If you don’t care about the attributes being copied to the target layer, it doesn’t matter how you design the fields and data types. If you want to make sure everything - feature and its attributes - gets copied, make sure the schemas match.

Tip

Congruência dos Elementos Colados

Se a sua camada fonte e a de destino usam a mesma projecção, então os elementos colados irão ter a geometria igual à camada fonte. No entanto, se a camada de destino tem uma projecção diferente então o QGIS não garante uma geometria idêntica. Isto é simples, porque existem pequenos erros arredondados envolvidos na conversão entre projecções.

Apagando os Elementos Seleccionados

Se quisermos apagar o polígono todo, podemos faze-lo seleccionando o polígono usando a ferramenta mActionSelect Seleccionar Elemento Único. Pode seleccionar múltiplos elementos para apagar. Uma vez feita a selecção do conjunto, use a ferramenta mActionDeleteSelected Apagar Seleccionados para apagar os elementos.

The mActionEditCut Cut Features tool on the digitizing toolbar can also be used to delete features. This effectively deletes the feature but also places it on a “spatial clipboard”. So we cut the feature to delete. We could then use the mActionEditPaste Paste Features tool to put it back, giving us a one-level undo capability. Cut, copy, and paste work on the currently selected features, meaning we can operate on more than one at a time.

Guardando as Camadas Editadas

Quando a camada está em modo edição, qualquer que seja a alteração permanece na memória do QGIS. Portanto não são submetidas/guardadas imediatamente na fonte de dados ou disco. Se deseja guardar as edições na camada actual mas quer continuar a editar sem deixar o modo edição, pode clicar no botão mActionSaveEdits Guardar Edições da Camada. Quando desliga o modo edição com o mActionToggleEditing Alternar edição (ou sai do QGIS por algum motivo), será-lhe sempre perguntado se quer guardar as alterações ou rejeitá-las.

Se as alterações não poderem ser guardadas (ex.: disco cheio, ou atributos que têm valores que saem fora do intervalo), o estado da memória do QGIS é preservada. Isto permite que possa ajustar as suas edições e voltar a tentar a guardar.

Tip

Integridade dos dados

É sempre boa ideia fazer cópias de segurança da sua fonte de dados antes de começar a editar. Enquanto os autores do QGIS fizeram todo o esforço para preservar a integridade dos seus dados, nós não oferecemos garantia neste sentido.

Digitalização Avançada

Ícone

Finalidade

Ícone

Finalidade

mActionUndo

Retroceder

mActionRedo

Retomar

mActionRotateFeature

Rodar Elemento(s)

mActionSimplify

Simplificar elemento

mActionAddRing

Adicionar Anél

mActionAddPart

Adicionar Parte

mActionDeleteRing

Apagar Anél

mActionDeletePart

Apagar Parte

mActionReshape Reshape Features mActionOffsetCurve

Curva de Afastamento

mActionSplitFeatures

Dividir Elementos

mActionMergeFeatures

Juntar Elementos Seleccionados

mActionRotatePointSymbols

Rodar Símbolos de Pontos

mActionMergeFeatureAttributes

Juntar Atributos dos Elementos Seleccionados

Table Advanced Editing: Vector layer advanced editing toolbar

Retroceder e Retomar

The mActionUndo Undo and mActionRedo Redo tools allow the user to undo or redo vector editing operations. There is also a dockable widget, which shows all operations in the undo/redo history (see Figure_edit_3). This widget is not displayed by default; it can be displayed by right clicking on the toolbar and activating the Undo/Redo check box. Undo/Redo is however active, even if the widget is not displayed.

Figure Edit 3:

../../../_images/redo_undo.png

Redo and Undo digitizing steps nix

When Undo is hit, the state of all features and attributes are reverted to the state before the reverted operation happened. Changes other than normal vector editing operations (for example changes done by a plugin), may or may not be reverted, depending on how the changes were performed.

To use the undo/redo history widget simply click to select an operation in the history list; all features will be reverted to the state they were in after the selected operation.

Rodar Elemento(s)

Use the mActionRotateFeatureRotate Feature(s) to rotate one or multiple selected features in the map canvas. You first need to select the features and then press the mActionRotateFeatureRotate Feature(s) Icon. Then the centroid of the feature appears and will be the rotation anchor point. If you selected multiple features the rotation anchor point will be the common center of the features. Press and drag the left mouse button in the desired direction to rotate the selected features.

It’s also possible to create a user-defined rotation anchor point by which the selected feature will rotate. Select the features to rotate and activate the mActionRotateFeatureRotate Feature(s) Tool. Press and hold the Ctrl button and move the mouse pointer (without pressing the mouse button) to the place where you want the rotation anchor to be moved. Release the Ctrl button when the desired rotation anchor point is reached. Now press and drag the left mouse button in the desired direction to rotate the selected feature(s).

Simplificar elemento

The mActionSimplify Simplify Feature tool allows to reduce the number of vertices of a feature, as long as the geometry doesn’t change. You need to select a feature, it will be highlighted by a red rubber band and a slider appears. Moving the slider, the red rubber band is changing its shape to show how the feature is being simplified. Clicking [OK] the new, simplified geometry will be stored. If a feature cannot be simplified (e.g. MultiPolygons), a message shows up.

Adicionar Anél

You can create ring polygons using the mActionAddRing Add Ring icon in the toolbar. This means inside an existing area it is possible to digitize further polygons, that will occur as a ‘hole’, so only the area in between the boundaries of the outer and inner polygons remain as a ring polygon.

Adicionar Parte

Pode mActionAddPart adicionar partes de polígonos num multipolígono seleccionado. A nova parte do polígono tem de ser digitalizado fora do multipolígono seleccionado.

Apagar Anél

The mActionDeleteRing Delete Ring tool allows to delete ring polygons inside an existing area. This tool only works with polygon layers. It doesn’t change anything when it is used on the outer ring of the polygon. This tool can be used on polygon and multi-polygon features. Before you select the vertices of a ring, adjust the vertex edit tolerance.

Apagar Parte

The mActionDeletePart Delete Part tool allows to delete parts from multifeatures (e.g. to delete polygons from a multipolygon feature). It won’t delete the last part of the feature, this last part will stay untouched. This tool works with all multi-part geometries point, line and polygon. Before you select the vertices of a part, adjust the vertex edit tolerance.

Reshape Features

You can reshape line and polygon features using the mActionReshape Reshape Features icon on the toolbar. It replaces the line or polygon part from the first to the last intersection with the original line. With polygons this can sometimes lead to unintended results. It is mainly useful to replace smaller parts of a polygon, not major overhauls and the reshape line is not allowed to cross several polygon rings as this would generate an invalid polygon.

For example, you can edit the boundary of a polygon with this tool. First, click in the inner area of the polygon next to the point where you want to add a new vertex. Then, cross the boundary and add the vertices outside the polygon. To finish, right-click in the inner area of the polygon. The tool will automatically add a node where the new line crosses the border. It is also possible to remove part of the area from the polygon, starting the new line outside the polygon, adding vertices inside, and ending the line outside the polygon with a right click.

Note

The reshape tool may alter the starting position of a polygon ring or a closed line. So the point that is represented ‘twice’ will not be the same any more. This may not be a problem for most applications, but it is something to consider.

Curvas de Afastamento

The mActionOffsetCurve Offset Curve tool creates parallel shifts of line layers. The tool can be applied to the edited layer (the geometries are modified) or also to background layers (creates copies of the lines / rings and adds it to the the edited layer). It is thus ideally suited for the creation of distance line layers. The displacement is shown at the bottom left of the taskbar. To create a shift of a line layer you have to go into editing mode and then select the feature. You can make the mActionOffsetCurve Offset Curve tool active and drag the cross to the desired distance. Your changes then can be saved with the mActionSaveEditsSave Layer Edits tool.

Dividir Elementos

Pode dividir elementos usando o ícone mActionSplitFeatures Dividir Elementos da barra de ferramentas. Apenas desenhe uma linha ao longo do elemento que quer dividir.

Juntar elementos seleccionados

A ferramenta mActionMergeFeatures Juntar Elementos Seleccionados permite juntar elementos que têm limites comuns e os mesmos atributos.

Juntar os atributos dos elementos seleccionados

The mActionMergeFeatureAttributes Merge Attributes of Selected Features tool allows to merge attributes of features with common boundaries and attributes without merging their boundaries. You can merge the attributes when selecting several features at once. Then press the mActionMergeFeatureAttributes Merge Attributes of Selected Features button. Now QGIS offers you which attributes are to be applied to all selected objects. As a result, all objects have the same attribute entries.

Rodar Símbolos de Pontos

The mActionRotatePointSymbols Rotate Point Symbols allows to change the rotation of point symbols in the map canvas. You have to define a rotation column from the attribute table of the point layer in the Advanced menu of the Style menu of the Layer Properties. Also you have to go into the ‘SVG marker’ and choose Data defined properties .... Activate checkbox Angle and choose ‘rotation’ as field. Without these settings the tool is inactive.

Figure Edit 4:

../../../_images/rotatepointsymbol.png

Rodar Símbolos de Pontos nix

To change the rotation, select a point feature in the map canvas and rotate it holding the left mouse button pressed. A red arrow with the rotation value will be visualized (see Figure_edit_4). When you release the left mouse button again, the value will be updated in the attribute table.

Note

Se segurar a tecla Ctrl premido, a rotação irá ser feita em passos de 15 graus.

Criando novas camadas Vectoriais

QGIS allows to create new Shapefile layers, new SpatiaLite layers, and new GPX Layers. Creation of a new GRASS layer is supported within the GRASS-plugin. Please refer to section Criando uma nova camada vectorial GRASS for more information on creating GRASS vector layers.

Criando uma nova camada Shapefile

To create a new Shape layer for editing, choose New ‣ mActionNewVectorLayer New Shapefile Layer... from the Layer menu. The New Vector Layer dialog will be displayed as shown in Figure_edit_5. Choose the type of layer (point, line or polygon) and the CRS (Coordinate Reference System).

Repare que o QGIS não suporta ainda a criação de elementos 2.5 D (ex.: elementos com coordenadas X,Y,Z).

Figure Edit 5:

../../../_images/editNewVector.png

Janela de criação de uma nova camada Shapefile nix

To complete the creation of the new Shapefile layer, add the desired attributes by clicking on the [Add to attributes list] button and specifying a name and type for the attribute. A first ‘id’ column is added as default but can be removed, if not wanted. Only Type: real selectstring, Type: integer selectstring, Type: string selectstring and Type:date selectstring attributes are supported. Additionally and according to the attribute type you can also define the width and precision of the new attribute column. Once you are happy with the attributes, click [OK] and provide a name for the shapefile. QGIS will automatically add a .shp extension to the name you specify. Once the layer has been created, it will be added to the map and you can edit it in the same way as described in Section Digitalizar uma camada existente above.

Criando uma nova camada SpatialLite

Para criar uma nova camada SpatialLite para edição, escolha Novo ‣ mActionNewSpatiaLiteLayer Nova Camada SpatiaLite... do menu Camada. O diálogo Nova Camada SpatiaLite irá aparecer como é mostrado na Figure_edit_6.

Figure Edit 6:

../../../_images/editNewSpatialite.png

Janela de criação de uma nova camada SpatialLite nix

First step is to select an existing SpatiaLite database or to create a new SpatiaLite database. This can be done with the browse button browsebutton to the right of the database field. Then add a name for the new layer and define the layer type and specify the Coordinate Reference System with [Specify CRS]. If desired you can select to checkbox Create an autoincrementing primary key.

To define an attribute table for the new SpatiaLite layer, add the names of the attribute columns you want to create with the according column type and click on the [Add to attribute list] button. Once you are happy with the attributes, click [OK]. QGIS will automatically add the new layer to the legend and you can edit it in the same way as described in Section Digitalizar uma camada existente above.

A gestão das camadas SpatialLite podem ser feitas como o Gestor DB Módulo Gestor BD.

Criando uma nova camada GPX

To create a new GPX file you need to load the GPS plugin first. Plugins ‣ mActionShowPluginManager Plugin Manager... opens the Plugin Manager Dialog. Activate the checkbox GPS Tools checkbox.

When this plugin is loaded choose New ‣ icon_newgpx Create new GPX Layer... from the Layer. In the Save new GPX file as dialog you can choose where to save the new GPX layer.

Trabalhando com a Tabela de Atributos

The attribute table displays features of a selected layer. Each row in the table represents one map feature and each column contains a particular piece of information about the feature. Features in the table can be searched, selected, moved or even edited.

To open the attribute table for a vector layer, make the layer active by clicking on it in the map legend area. Then from the main menu Layer choose mActionOpenTable Open Attribute Table. It is also possible to rightclick on the layer and choose mActionOpenTable Open Attribute Table from the dropdown menu and to click on the mActionOpenTable Open Attribute Table button in the Attributes toolbar.

Isto irá abrir uma nova janela que exibe os atributos dos elementos numa camada (figure_attributes_1). O número de elementos e o número de elementos seleccionados são exibidos no título da tabela de atributos.

Figure Attributes 1:

../../../_images/vectorAttributeTable.png

Tabela de Atributos para a camada regiões nix

Seleccionando elementos na tabela de atributos

Each selected row in the attribute table displays the attributes of a selected feature in the layer. If the set of features selected in the main window is changed, the selection is also updated in the attribute table. Likewise, if the set of rows selected in the attribute table is changed, the set of features selected in the main window will be updated.

Rows can be selected by clicking on the row number on the left side of the row. Multiple rows can be marked by holding the Ctrl key. A continuous selection can be made by holding the Shift key and clicking on several row headers on the left side of the rows. All rows between the current cursor position and the clicked row are selected. Moving the cursor position in the attribute table, by clicking a cell in the table, does not change the row selection. Changing the selection in the main canvas does not move the cursor position in the attribute table.

A tabela pode ser ordenada por qualquer coluna, clicando no cabeçalho da coluna. Uma pequena seta indica a forma de ordenação (apontar para baixo significa valores descendentes do topo da linha, apontar para cima significa valores descendentes do topo da linha).

For a simple search by attributes on only one column choose the Column filter ‣ from the menu in the bottom left corner. Select the field (column) from which the search should be performed from the dropdown menu and hit the [Apply] button. Then only the matching features are shown in the Attribute table.

To make a selection you have to use the mIconExpressionSelect Select features using an Expression icon on top of the Attribute table. The mIconExpressionSelect Select features using an Expression allows you to define a subset of a table using a Function List like in the mActionCalculateField Field Calculator (see Calculadora de Campos). The query result then can be saved as a new vector layer. For example if you want to find regions that are boroughs from the regions.shp of the QGIS sample data you have to open the >Fields and Values menu and choose the field that you want to query. Double-klick the field ‘TYPE_2’ and also [Load all unique values] . From list choose and double-klick ‘Borough’. In the Expression field the following query appears:

"TYPE_2"  =  'Borough'

The matching rows will be selected and the total number of matching rows will appear in the title bar of the attribute table, and in the status bar of the main window. For searches that display only selected features on the map use the Query Builder described in Section Ferramenta de Consulta.

To show selected records only, use Show Selected Features from the menu at the bottom left.

The other buttons at the top of the attribute table window provide following functionality:

  • mActionToggleEditing Alternar modo de edição para editar valores únicos e activar as funcionalidadesdescritas em baixo e também com Ctrl+E

  • mActionSaveEdits Guardar Edições também com Ctrl+S

  • mActionUnselectAttributes Unselect all also with Ctrl+U
  • mActionSelectedToTop Mover seleccionados para topo também com Ctrl+T

  • mActionInvertSelection Inverter selecção também com Ctrl+R

  • mActionCopySelected Copiar linhas seleccionadas para área de transferência também com Ctrl+C

  • mActionZoomToSelected Ampliar mapa às linhas seleccionadas também com Ctrl+J

  • PanToSelected Mover mapa para as linhas seleccionadas também com Ctrl+P

  • mActionDeleteSelected Apagar elementos seleccionados também com Ctrl+D

  • mActionNewAttribute Nova Coluna para camadas PostGIS e para camadas OGR com versão GDAL >= 1.6 também com Ctrl+W

  • mActionDeleteAttribute Apagar Coluna para camadas PostGIS e para camadas OGR com a versão GDAL >= 1.9 também com Ctrl+L

  • mActionCalculateField Abrir calculadora de campos também com Ctrl+I

Tip

Ignorar geometria WKT

If you want to use attribute data in external programs (such as Excel) use the mActionCopySelected Copy selected rows to clipboard button. You can copy the information without vector geometries if you deactivate Settings ‣ Options ‣ Data sources menu checkbox Copy geometry in WKT representation from attribute table.

Guardar elementos seleccionados como nova camada

The selected features can be saved as any OGR supported vector format and also transformed into another Coordinate Reference System (CRS). Just open the right mouse menu of the layer and click on Save selection as ‣ to define the name of the output file, its format and CRS (see Section Legenda do Mapa). It is also possible to specify OGR creation options within the dialog.

Trabalhando com tabelas de atributos não espaciais

QGIS allows also to load non spatial tables. This includes currently tables supported by OGR, delimited text as well as the PostgreSQL, MSSQL and Oracle provider. The tables can be used for field lookups or just generally browsed and edited using the table view. When you load the table you will see it in the legend field. It can be opened e.g. with the mActionOpenTable Open Attribute Table tool and is then editable like any other layer attribute table.

As an example you can use columns of the non spatial table to define attribute values or a range of values that are allowed to be added to a specific vector layer during digitizing. Have a closer look at the edit widget in section Fields Menu to find out more.