Outdated version of the documentation. Find the latest one here.

Configuração QGIS

O QGIS é altamente personalizávelatravés do menu Configurações . Escolha entre Painéis, Caixa de Ferramentas, Propriedades do Projecto, Opções e Personalização.

Painéis e Barras de Ferramentas

No menu Painéis‣ pode desligar os widgets do QGIS. O menu Caixa de Ferramentas‣ fornece a possibilidade de trocar activar ou desactivar grupos de ícones na barra de ferramentas do QGIS (veja figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

Os Painéis e o Menu de Barra de Ferramentas nix

Tip

Activando o Enquadramento QGIS

No QGIS pode usar o painel do enquadramento que fornece a extensão total das camadas adicionadas. Pode ser seleccionada no menu Ver ‣ Painéis. Dentro da vista existe um rectângulo a mostrar a extensão actual do mapa. Isto permite rapidamente determinar que área do mapa está a ver actualmente. É de notar que os rótulos não serão renderizados no enquadramento do mapa mesmo que seja activado a rotulagem. Se clicar e arrastar o rectângulo vermelho no enquadramento que mostra a actual extensão, este irá actualizar de acordo como o mapa principal.

Tip

Mostrar Mensagens de Registo

É possível seguir as mensagens do QGIS. Pode activar o checkboxRegisto de Mensagens no menu Configurações ‣ Painéis e seguir as mensagens no separador Geral e Módulo durante o carregamento da operação.

Propriedades do Projecto

Na janela de propriedades para o projecto em nix Projecto ‣ Propriedades do Projecto ou win Configurações ‣ Propriedades do Projecto pode definir as opções específicas do projecto. Aqui estão incluídos:

  • No menu Geral podem ser definidos o título do projecto, a cor de selecção e fundo, unidades da camadas, precisão, e os caminhos relativos onde serão guardadas as camadas. Se a transformação SRC estiver ligada pode escolher o cálculo de distâncias recorrendo ao elipsóide. Pode definir as unidades do enquadramento (apenas usado quando a transformação SRC está desactivada) e a precisão das casas decimais a usar. Pode definir também uma escala de projecto, que rescreverá sobre as escalas globais pré-definidas.

  • O menu SRC permite que escolha o Sistema de Coordenadas Referência para o projecto, e para activar a reprojecção on-the-fly das camadas matricias e vectoriais na exibição de camadas de diferentes SRC.

  • Com o terceiro menu Identificar camadas pode definir (ou desactivar) que camadas irão responder à ferramenta identificar. (Veja o parágrafo das ferramentas de Mapa da secção Opções Secção para activar a identificação de múltiplas camadas.)

  • O menu Estilos por defeito deixa controlar a forma como serão desenhadas as novas camadas quando não tiverem estileos .qml definidos. Pode também definir o nível de transparência padrão para novas camadas e se os símbolos devem ter cores aleatórias associadas a eles.

  • O separador Servidor OWS permite definir a informação sobre as Capacidades WMS e WFS, a extensão e as restrições SRC do Servidor|qg|.

  • O menu Macros é para criar um módulo Python, guardado no ficheiro de projecto .qgs para ser carregado e ter as funções espcíficas para correrem nos eventos seguintes do projecto: openProject(), saveProject() e closeProject().

Figure Macro Menu:

../../../_images/macro.png

Configurações de Macro no QGIS

Opções

mActionOptions Algumas opções básicas para o QGIS podem ser seleccionadas usando a janela Opções . Seleccione a opção do menu Configurações ‣ mActionOptions Opções. Os menus que pode oprimizar as suas opção são:

Menu Geral

Aplicação

  • Seleccione a estilo (Necessário reiniciar o QGIS) selectstring e escolha entre ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ e ‘Cleanlux’ (nix).

  • Definir o Tema de Ícone selectstring. Actualmente a opção ‘default’ é possível.

  • Definir o Tamanho do Ícone selectstring.

  • Definir a Fonte. Escolha entre radiobuttonon QT padrão e a uma fonte definida pelo utilizador.

  • Altera o Tempo limite para mensagens ou diágolos selectstring.

  • checkbox Não exibir a janela inicial

  • checkbox Mostrar dicas ao iniciar

  • checkbox Títulos da caixa de grupos a negrito

  • checkbox QGIS-estilo das caixas de grupo

  • checkbox Use diálogos selectores de cor para actualizações ao vivo

Ficheiros de projecto

  • Abrir o projecto no aranque selectstring (escolha entre ‘Novo’. ‘Mais recente’ e ‘Específico’. Quando escolher ‘Específico’ use browsebutton para definir um projecto)

  • checkbox Criar novo projecto a partir de um projecto padrão. Tem a possibilidade de clicar em Definir projecto actual como padrão ou em Reset. Pode pesquisar através de ficheiros e definir um directório onde irá encontrar os modelos definidos pelo utilizador. Irá existir uma entrada no Projecto ‣ Novo a partir de Modelo se activar primeiro checkbox Criar novo projecto a partir de um projecto padrão e de seguida salve o projecto na pasta de modelos de projecto.

  • checkbox Avisar para salvar projecto e alterações de fontes de dados quando necessário

  • checkbox Avisar quando abrir um projecto salvo com uma versão antiga do QGIS |qg|

  • Activar macros selectstring. Esta opção foi criada para manipular macros que são escritos para executar uma acção

nos eventos do projecto. Pode escolher entre ‘Nunca’, ‘Perguntar’, ‘Apenas para esta secção’ e ‘Sempre (não recomendado)’.

Menu Sistema

Ambiente

As variáveis de ambiente do sistema podem ser vistas e configuradas no menu Ambiente (veja figure_environment_variables). Isto é útil pata plataformas, como o Mac, onde a aplicação GUI não herda necessariamente o ambiente de comandos do utilizador. É também útil para definir/ver as variáveis de ambiente para ferramentas externas definadas e controladas pelo menu processamento, ex.: SAGA, GRASS; e, para activar a saída de correcção de erros para secções específicas do código fonte.

  • checkbox Usar variáveis personalizadas (é necessário reiniciar - inclum separadores). Pode Adicionar e Remover variáveis. Variáveis ambiente actuais ‣ são exibidas em baixo e é possível checkbox Mostrar apenas as variáveis específicas QGIS.

Figure System Environment:

../../../_images/sys-env-options.png

Variáveis de ambiente do Sistema no QGIS

Directórios dos módulos

  • Adicionar ou Remover Caminho(s) para pesquisar livrarias de módulos adicionais C++

Menu Fonte de Dados

Atributos dos elementos e tabela

  • checkbox Abre a tabela de atributos na janela principal (Necessário reiniciar o QGIS)

  • checkbox Copiar geometria na representação WKT da tabela de atributos. Quando usa mActionCopySelectedCopiar linhas seleccionadas para a área de transferência do menu Tabela de atributos então isto resultará na cópia para área de transferência dos pontos ou vértices juntamente com a restante informação.

  • Comportamento da tabela de atributos selectstring. Existem três possibilidades: ‘Mostrar todos os elementos’, ‘Mostrar elementos seleccionados’ e ‘Mostrar elementos visiveis no mapa’

  • Atributo da linha da tabela em memória selectstring. Esta linha de memória torna possível guardar as últimas linhas carregadas por x atributos das linhas para que possa trabalhar mais rapidamente com a tabela de atributos. Esta memória será apagada quando fechar a tabela de atributos.

  • Representação para valores NULL Aqui pode definir um valor para os campos de dados que contêm valores NULL.

Manipulação das fontes de dados

  • Pesquisar por atributos válidos na janela do navegador selectstring. Pode escolher entre ‘Verificar extensão’ e ‘Verificar conteúdo do ficheiro’.

  • Pesquisar por conteúdo de ficheiros compactados (.zip) na janela do navegador selectstring. ‘Não’, ‘Verificação básica’ e ‘Verificação completa’ são possiveis.

  • Solicitar subcamadas matriciais ao abrir. Alguns matriciais suportam subcamadas - e são chamados de subconjuntos de dados no GDAL. Um exemplo disso são os ficheiros netcdf - se existirem muitas variáveis netcdf, o GDAL ve cada variável como um subconjunto de dados. A opção é controlar como lidar com subcamadas quando um ficheiro com subcamadas é aberto. Tem as seguintes escolhas:

    • ‘Sempre’: pergunta sempre (se existem subcamadas)

    • ‘Se necessário’: pergunta se a camada não tem bandas, mas tem subcamadas

    • ‘Nunca’: nunca pede, não irá carregar nada

    • ‘Carregar tudo’: nunca pede, mas carrega todas as subcamadas

  • checkbox Ignora a declaração de codificação da shapefile. Se a shapefile tiver informação de codificação isto será ignorado pelo QGIS.

  • checkbox Adicionar uma camada PostGIS com duplo clique e seleccione em modo extendido

  • checkbox Adicione camadas Oracle com duplo clique e seleccione em modo extendido

Menu de Renderização

Qualidade de renderização

  • checkbox Faz com que as linhas apareçam menos irregulares, em detrimento de algum desempenho do desenho

  • checkbox Resolver problemas com polígonos incorrectamente preenchidos

Matriciais

  • com a Selecção de banda RGB pode definir o número para a banda Vermelha, Verde e Azul.

Melhorar contraste

  • Banda cinzenta única selectstring. Uma banda cinzenta única pode ter ‘Sem esticar’, ‘Esticar para MinMax’, ‘Esticar e Cortar para MinMax’ e também ‘Cortar para MinMax’

  • Cor multi-banda (byte/banda) selectstring. ‘Sem esticar’, ‘Esticar para MinMax’, ‘Esticar e Cortar para MinMax’ e também ‘Cortar para MinMax’.

  • Cor multi-banda (>byte/banda) selectstring. ‘Sem esticar’, ‘Esticar para MinMax’, ‘Esticar e Cortar para MinMax’ e também ‘Cortar para MinMax’.

  • Limites (mínimo/máximo) selectstring. ‘Contagem cumulativa de pixeis de corte’, ‘Mínimo/Máximo’, ‘Média +/- desvio-padrão’

  • Limites de contagem cumulativa de pixeis de corte

  • Multiplicador do desvio-padrão

Corrigindo Erros

  • Mostrar esses eventos no painel de Registo de Mensagens (no separador renderização): checkbox Actualizar a janela do mapa

Menu de Janela e Legenda

Aparência padrão do mapa (reescrita pelas propriedades do projecto)

  • Define a Cor da selecção e a Cor de fundo.

Legenda da camada

  • Duplo clique na legenda selectstring. Pode ‘Abrir propriedades da camada’ ou ‘Abrir tabela de atributos’ com duplo clique.

  • os seguintes Estilos de items de legenda são possíveis

    • checkbox Tornar maiusculo os nomes da camada

    • checkbox Tornar negrito os nomes da camada

    • checkbox Tornar negrito os nomes dos grupos

    • checkbox Mostrar nomes de atributos de classificação

    • checkbox Criar ícones matriciais (pode ser lento)

    • checkbox Adicionar novas camadas ao grupo actual ou seleccionado

Menu Ferramentas de Mapa

Identificar

  • checkbox Abre resultados identificados numa pequena janela (será necessário reiniciar o QGIS)

  • A configuração Modo determina que camadas serão exibidas na ferramenta Identificar. Ao trocar os atributos para ‘De cima para baixo’ ou ‘De cima para baixo, parando no primeiro’ em vez de ‘Camada actual’ para todas as camadas identificáveis (veja a secção de Propriedades de Projecto em: Projectos para definir que camadas são identificáveis) serão exibidas com a ferramenta Identificar.

  • checkbox Abre o formulário do elemento, se só um elemento for identificado

  • Define Raio de pesquisa para identificar e exibir dicas de mapa como uma percentagem de largura de mapa

Ferramenta de medida

  • Define Cor do elástico para as ferramentas de medida

  • Define Casas decimais

  • checkbox Manter unidade base

  • Unidades de preferência de medida radiobuttonon (‘metros’ ou ‘pés’)`

  • Unidades de ângulos preferenciais radiobuttonon (‘Ângulo’, ‘Radianos’ ou ‘Gon’)

Movendo e ampliando

  • Define a Acção da roda do rato selectstring (‘Visualizar’, ‘Visualizar e Centrar’, ‘Aproximar ao cursor do rato’, ‘Nada’)

  • Define o factor de aproximação/ afastamento para a roda do rato

Escalas pré-definidas

Aqui pode encontrar uma lista de escalas pré-definidas. Com os botões ‘+’ e ‘-‘ pode adicionar ou remover escalas individuais.

Menu Digitalizar

Criação de elementos

  • checkbox Suprimir atributos de janelas pop-up depois de cada elemento criado

  • checkbox Reutilizar últimos valores de atributos inseridos

  • Validar geometrias. Editar linhas/polígonos complexos com muitos nós pode acabar com uma renderização muita lenta. Isto deve-se aos procedimentos padrão de validação no QGIS que usam muito tempo. Para aumentar a rapidez de renderização é possível seleccionar a geometria de validação GEOS (começado no GEOS 3.3) ou mudar para desligado. A validação de geometria GEOS é muito mais rápida, mas a sua única desvantagem é que o primeiro problema de geometria é comunicado.

Elástico

  • Define a Borracha Espessura da linha e Cor da linha

Ajuste

  • checkbox Abrir opções de atracção na janela principal (necessário reiniciar o QGIS)

  • Define o Modo de atracção padrão selectstring (‘Ao vértice’, ‘Ao segmento’, ‘Ao vértice e segmento’, ‘Desligado’)

  • Define Tolerância de atracção pré-definida em unidades de mapa ou pixeis

  • Define o Raio de pesquisa para editar vértices em unidades de mapa ou pixeis

Marcadores de Vértices

  • checkbox Mostrar marcadores apenas para elementos seleccionados

  • Define o vértice do Estilo do Marcador selectstring (‘Cruz’ (padrão), ‘Circulo semi-transparente’ ou ‘Nenhum’)

  • Definir o vértice Tamanho do Marcador

Ferramenta de curva de afastamento

As próximas três opções referem-se à ferramenta de mActionOffsetCurve Curva de Afastamento em Digitalização Avançada. Através de várias configurações, é possível influenciar o afastamento da forma da linha. Estas opções são possíveis a partir do GEOS 3.3 .

  • Estilo de união para a curva de afastamento

  • Segmentos de quadrante para o afastamento da curva

  • Limite em metros para o afastamento da curva

Menu GDAL

O GDAL é uma biblioteca de troca de dados para ficheiros matriciais. No separador pode Editar opções de criação e Editar Opções de Pirâmides dos formatos matriciais. Defina o controlador GDAL que será usado no formato matricial em que nalguns casos pode estar mais que um controlador GDAL disponível.

Menu SRC

SRC padrão para novos projectos

  • checkbox Habilitar automaticamente a reprojecção ‘on the fly’ se as camadas tiverem diferentes SRC

  • checkbox Habilita reprojecção ‘on the fly’ por defeito

  • Seleccione um SRC em Iniciar sempre um novo projecto com este SRC

SRC para novas camadas

Esta área permite definir a acção, quando uma camada é criada, ou quando uma camada sem SRC é carregada.

  • radiobuttonon Pergunta por SRC

  • radiobuttonoff Usar SRC do projecto

  • radiobuttonoff Utilizar SRC padrão mostrado em baixo

Separador Região

  • checkbox Sobrepor idioma do sistema e Idioma a utilizar em alternativa

  • Informação sobre a região do sistema activo local

Separador de Rede

Geral

  • Define Pesquisa de endereço WMS, padrão como http://geopole.org/wms/search?search=\%1\&type=rss

  • Define Tempo esgotado para pedidos de rede (ms) - o padrão é 60000

  • Define Período padrão de validade para a quadrícula WMSC/WMTS (horas) - o padrão é 24

Figure Network Tab:

../../../_images/proxy-settings.png

Configurações-proxy no QGIS

Configurações de cache

Define a Pasta e Tamanho para o cache.

  • checkbox Usar proxy para aceder à web e define ‘Máquina’, ‘Porta’, ‘Utilizador’, e ‘Palavra-chave’.

  • Configura o Tipo de proxy selectstring de acordo com as necessidades.

    • Default Proxy: Proxy é determinado baseando-se na definição do proxy da aplicação em uso

    • Socks5Proxy: Proxy genérico para qualquer tipo de ligação. Suporta TCP, UDP, unindo a uma porta (ligações de entrada) e autenticação.

    • HttpProxy: Implementado usando o comando “LIGAR” , apenas suporta ligações TCP de saída; suporta autenticação.

    • HttpCachingProxy: Implementado usando comandos HTTP normais, é útil apenas em pedidos no contexto do HTTP

    • FtpCachingProxy: Implementado usando um proxy FTP, é útil no contexto de pedidos FTP

Alguns URLs excluídos podem ser adicionados a caixa de texto em baixo das configurações de proxy (veja Figure_Network_Tab).

Se necessitar de informação mais detalhada sobre as diferentes configurações proxy, por favor siga o manual sublinhado na documentação de bibliotecas QT em http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Tip

Usando Proxies

Usar os proxies por vezes poder ser complicado. É útil a ‘tentativa e erro’ dos tipos de proxy acima e verificar se é bem sucedido para o seu caso.

Pode modificar as opções de acordo com as suas necessidades. Algumas das alterações pode requerer o reinicio do QGIS antes de ser efectiva.

  • As configurações nix são guardadas no ficheiro de texto: $HOME/.config/QGIS/qgis.conf

  • osx pode encontrar as configurações em: $HOME/Library/Preferences/org.qgis.qgis.plist

  • as configurações win são armazenadas no registo em: HKEY\CURRENT_USER\Software\QGIS\qgis

Personalização

A ferramenta de personalização permite que (des)active a maioria dos elementos na interface de utilizador QGIS. Isto pode ser muito útil se tiver um número elevado de módulos instalados que nunca usa e que estão a encher o ecrã.

Figure Customization 1:

../../../_images/customization.png

A janela de Personalização nix

QGIS A Personalização está dividida em cinco grupos. No checkbox Menus pode esconder as entradas na Barra Menu. No checkbox Painel pode encontrar o painel de janelas. As janelas do Painel são aplicações que pode ser iniciadas e usadas como flutuantes, janelas de topo de nível ou embebidas na janela principal do QGIS como um widget ancorado (veja also Painéis e Barras de Ferramentas). Na checkbox Barra de Estado características como a informação das coordenadas podem ser desactivadas. Na checkbox Caixa de Ferramentas pode (des)activar os ícones da barraa de ferramentas do QGIS e em checkbox Widgets pode (des)activatar janelas assim como os seus botões.

Com o mActionSelect Trocar os widgets apanhados na janela principal pode clicar em elementos no|qg| que quer esconder e encontrar a entrada correspondente na Personalização (veja figure_customization). Pode também guardar em vários diferentes instalações assim como para diferentes casos de uso. Depois das alterações aplicadas, necessita de reiniciar o QGIS.