Edição

QGIS supports various capabilities for editing OGR, SpatiaLite, PostGIS, MSSQL Spatial and Oracle Spatial vector layers and tables.

Nota

The procedure for editing GRASS layers is different - see Section Digitalizando e editando uma camada vetorial GRASS for details.

Dica

Edição em uso corrente

Esta versão do QGIS não segue o mesmo caminho caso alguém mais estiver editando uma feição ao mesmo tempo que a edição que você estiver fazendo. No caso a ultima pessoa a salvar sua edição é a que estará habilitada ou dada como salvo pelo programa.

Definir o valor de tolerância de proximidade para buscar apartir do raio

Antes de editar os vértices , devemos definir a tolerância de proximidade e valores de raio de que nos permitam uma ótimização na edição das geometrias e das camadasvetoriais .

Tolerância de Proximidade

A tolerância de Proximidade e a distancia que o QGIS utiliza para procurar o vértice mais proximo e /ou seguimento que se deseja conectar quando você estabelecer um novo vértice ou mover um vértice já existente. Se não estiver nos limites de tolerância o QGIS vai posicionar o vértice onde o botão do mouse for solto, ao invés de aproximá-lo a um vértice e/ ou seguimento já existente. A configuração da tolerância de proximidade influência todas as ferramentas que trabalham com tolerância.

  1. A general, project wide snapping tolerance can be defined choosing Settings ‣ mActionOptions Options. On Mac: go to QIS ‣ mActionOptions Preferences..., on Linux: Edit ‣ mActionOptions Options. In the Digitizing tab you can select between to vertex, to segment or to vertex and segment as default snap mode. You can also define a default snapping tolerance and a search radius for vertex edits. The tolerance can be set either in map units or in pixels. The advantage of choosing pixels, is that the snapping tolerance doesn’t have to be changed after zoom operations. In our small digitizing project (working with the Alaska dataset), we define the snapping units in feet. Your results may vary, but something on the order of 300ft should be fine at a scale of 1:10 000 should be a reasonable setting.
  2. A layer based snapping tolerance can be defined by choosing Settings ‣ (or File ‣) Snapping options... to enable and adjust snapping mode and tolerance on a layer basis (see figure_edit_1 ).

Note that this layer based snapping overrides the global snapping option set in the Digitizing tab. So if you need to edit one layer, and snap its vertices to another layer, then enable snapping only on the snap to layer, then decrease the global snapping tolerance to a smaller value. Furthermore, snapping will never occur to a layer which is not checked in the snapping options dialog, regardless of the global snapping tolerance. So be sure to mark the checkbox for those layers that you need to snap to.

Figure Edit 1:

../../../_images/editProjectSnapping.png

Edit snapping options on a layer basis nix

Pesquisa de Raio

Pesquisa de raio e a diatancia que o QGIS utiliza para buscar o vertice mais proximo quendo você clica no mapa. Caso não esteja dentro dos limites da pesquisa de raio, o QGIS não encontrará e não selecionará nenhum vértice para edição e irá notificar com um aviso de alerta Tolerância de aproximar e pesquisa de raio são definidas em unidades do mapa ou em pixel, então pode ser necessário experimentar ambas para definir a utilização apropriada. Especificando uma tolerância muito grande o QGIS poderá aproximar a um vértice errado, especialmente se o número de vértice em que esteja trabalhando estiver em grande número e muito próximo um do outro. Definindo uma pesquisa de raio muito pequena pode não encontrar nada para mover.

A pesquisar o raio para edição de vértice em unidades da camada pode ser definida na aba Digitalizar em Configurações –> Opções mesmo local onde é definido a forma geral de tolerância de proximidade do projeto.

Ampliação e Visão panorâmica

Antes de editar uma camada você deve ampliar a sua área de interesse. Isso evita a espera, enquanto todos os marcadores de vértice são renderizadospor toda camada.

Alem de usar o |mAaction| sup: Panorâmica e mActionZoomIn Sup Aproximar / mActionZoomOut Afastar ícones da barra de ferramentas com o mouse, a navegação pode ser feito também com a rolagem do mouse, as setas ea barra de espaço.

Zoom e Viisão panorâmica com a rolagem do mouse

No processo de Digitalização é possível utilizar o mouse clicand clicando e arrastando a visualização panorâmica e também utilizar o recurso de rolagem do mouse para aproximar e afastar a visualização do mapa. Para aproximar o local posicione o cursor do mouse na área do mapa e gire a rolagem para frente para aproximar e para trás para afastar. A posição do cursor do mouse será o ponto central da área de interesse ampliada. É possível também customizar o comportamento da ação da roda do mouse utilizando; Ferramentas de Mapa no :menuselection: Configurações —-> ` mActionOptions :menuselection: Opções.

Panaramica com as teclas de Seta

Panning the map during digitizing is possible with the arrow keys. Place the mouse cursor inside the map area and click on the right arrow key to pan east, left arrow key to pan west, up arrow key to pan north and down arrow key to pan south.

Você também pode usar a barra de espaço para fazer com que temporariamente o mouse para mover então Movimentos mapa. Aa teclas PgUp e PgDown do teclado fazem a exibição para aproximar ou afastar sem interromper a digitalização.

Edição Topológica

Além de opções de alinhamento baseados camada também pode definir algumas funcionalidades topológicas na aba Opções de Proximidade.... Caixa de dialogo . menuselection: Configurações (ou menuselection: Arquivo ) Menu . Você pode Definir na| caixa de seleção| Na aba Habiliar edição topológica e /ou para as camadas de polígonos, você pode ativar a coluna | caixa de seleção| Na Aba Evitar int o que evita a intersecção de novos polígonos.

Ativar a edição topologica

The option checkbox Enable topological editing is for editing and maintaining common boundaries in polygon mosaics. QGIS ‘detects’ a shared boundary in a polygon mosaic and you only have to move the vertex once and QGIS will take care about updating the other boundary.

Evitando Intersecção de novos polígonos.

The second topological option in the checkbox Avoid Int. column, called Avoid intersections of new polygons avoids overlaps in polygon mosaics. It is for quicker digitizing of adjacent polygons. If you already have one polygon, it is possible with this option to digitize the second one such that both intersect and QGIS then cuts the second polygon to the common boundary. The advantage is that users don’t have to digitize all vertices of the common boundary.

Enable snapping on intersections

Another option is to use checkbox Enable snapping on intersection. It allows to snap on an intersection of background layers, even if there’s no vertex on the intersection.

Digitalizando uma Camada Vetorial Existente

By default, QGIS loads layers read-only: This is a safeguard to avoid accidentally editing a layer if there is a slip of the mouse. However, you can choose to edit any layer as long as the data provider supports it, and the underlying data source is writable (i.e. its files are not read-only).

Em geral a edição de camadas vetoriais é dividida em uma barra de digitalização e uma barra de Ferramentas avançadas descrita na seção .ref:sec_advanced_edit. Você poderá selecionar e desmarcar tanto em:menuselection:`Configurações –> Barra de Ferramentas –> Usando as ferramentas de digitalização básicas que você pode realizar as seguintes funções:

Ícone

Função

Ícone

Função

mActionAllEdits Current edits mActionToggleEditing

Alternar Edição

mActionToggleEditing

Adicionar feições: captura de ponto

mActionCaptureLine

Adicionar feições: captura de linha

mActionCapturePolygon

Adicionar feições: captura de polígono

mActionMoveFeature

Mover feição

mActionNodeTool

Ferramenta de nó

mActionDeleteSelected

Excluir selecionado(s)

mActionEditCut

Recortar feições Recortar feições

mActionEditCopy

Copiar feições

mActionEditPaste

Colar feições

mActionSaveEdits Save layer edits

Tabela de Edição: Barra de ferramentas básicas de edição vetorial.

All editing sessions start by choosing the mActionToggleEditing Toggle editing option. This can be found in the context menu after right clicking on the legend entry for that layer.

Como uma forma alternativa é possível usar o botão Alternar Edição mActionToggleEditing :sup: Alternar edição da barra de digitalização para começar ou para sair do modo de edição. Uma vez que a camada estiver em modo de edição marcadores irão aparecer nos vértices e botões adicionais na barra de edição estarão disponíveis para o uso.

Dica

Salvar Regularmente

Remember to mActionSaveEdits Save Layer Edits regularly. This will also check that your data source can accept all the changes.

Adicionando Feições

Você podera utilizar os icones mActionCapturePoint:sup Adicionar Recurso , mActionCaptureLine :sup:`Adicionar Recurso ou mActionCapturePolygon :sup:`Adicionar Recurso os icones da barra de ferramentas para colocar o curso do QGIS em modo de digitalização.

Para cada feição é necessário primeiro digitalizar a geometria para então inserir os atributos. Para digitalizar a geometria, clique com o botão esquerdo do mouse na área do mapa para criar o ponto inicial da sua nova feição.

For lines and polygons, keep on left-clicking for each additional point you wish to capture. When you have finished adding points, right-click anywhere on the map area to confirm you have finished entering the geometry of that feature.

The attribute window will appear, allowing you to enter the information for the new feature. Figure_edit_2 shows setting attributes for a fictitious new river in Alaska. In the Digitizing menu under the Settings ‣ Options menu, you can also activate checkbox Suppress attributes pop-up windows after each created feature checkbox Reuse last entered attribute values.

Figure Edit 2:

../../../_images/editDigitizing.png

Enter Attribute Values Dialog after digitizing a new vector feature nix

Com o ícone mActionMoveFeature:sup: Mover Feição da barra de ferramentas é possível movimentar as feições existentes.

Dica

Tipos de valores de atributos

For editing the attribute types are validated during the entry. Because of this, it is not possible to enter a number into the text-column in the dialog Enter Attribute Values or vice versa. If you need to do so, you should edit the attributes in a second step within the Attribute table dialog.

Current Edits

This new feature allows the digitization of multiple layers. Choose mActionFileSaveAs Save for Selected Layers to save all changes you made in multiple layers. You also have the opportunity to mActionRollbackEdits Rollback for Selected Layers so that the digitization is then withdrawn for all selected layers. If you want to stop editing the selected layers the mActionCancelEdits Cancel for Selected Layer(s) is an easy way.

The same functions for editing all layers of the project are available.

Ferramenta de nó

For shapefile-based layers as well as SpatialLite,PostgreSQL/PostGIS, MSSQL Spatial and Oracle Spatial tables the mActionNodeTool Node Tool provides manipulation capabilites of feature vertices similar to CAD programs. It is possible to simply select multiple vertices at once and to move, add or delete them alltogether. The node tool also works with ‘on the fly’ projection turned on and supports the topological editing feature. This tool is, unlike other tools in QGIS, persistent, so when some operation is done, selection stays active for this feature and tool. If the node tool couldn’t find any features, a warning will be displayed.

É importante selecionar as propriedades :menuselection:`Configurações –> mActionOptions :menuselection: Opções–> :guilabel:Encontrar Raio|selectnumber|para um número maior que zero.(i.e. 10).De outra forma o QGIS não estará apto a informar qual o vértice está sendo editado.

Dica

Marcadores de Vértice

A versão atual do QGIS suporta três tipos de marcadores de vértice – Círculo semi transparente , cruz e nenhum. Para alterar o estilo de marcador escolha em mActionOptions :menuselection:Opções do menu Configurações e Clique na aba Digitalizar e selecione a entrada apropriada.

Operações Básicas

Inicie ativando a|mActionNodeTool| :sup: Ferramentas de nós e selecionando um recurso clicando sobre ele. Caixas vermelhas aparecerão em cada vértice desse recurso.

  • Selecting vertices: You can select vertices by clicking on them one at a time, by clicking on an edge to select the vertices at both ends, or by clicking and dragging a rectangle around some vertices. When a vertex is selected its color changes to blue. To add more vertices to the current selection, hold down the Ctrl key while clicking. Hold down Ctrl or Shift when clicking to toggle the selection state of vertices (vertices that are currently unselected will be selected as usual, but also vertices that are already selected will become unselected).
  • Adicionar vértices: Para adicionar um vértice basta clicar duas vezes perto de uma borda e um novo vértice aparecerá na borda perto do cursor. Note que o vértice aparece na borda, e não na posição do cursor, por isso, tem de ser transferida, se necessário.

  • Excluir vértices:Após selecionar vértices para exclusão, clique natecla :kbd: Delete Não é possível utilizar a mActionNodeTool :sup: Ferramenta de nós para deletar uma feição completa; QGIS o número mínimo de vértices para o tipo de feição que esteja trabalhando. Para deletar uma feição completa utilize a ferramenta mActionDeleteSelected :sup:Excluir Seleção.

  • Mover Vértices:Selecione todos os vértices que desejar mover. Clique em um vértice selecionado ou em uma borda e arraste na direção que desejar movimentar. Todos os vértices selecionados irão ser movimentados juntos. Caso estiver habilitada a seleção toda pode pular para o vértice ou linha mais próximo.

Cada alteração executada com a ferramenta de nós sera armazenada como uma entrada separada no diálogo de refazer. Lembre-se que todas as operações suportam a edição topológica quando estiver ligada. A projeção “on the fly” também é suportada e a ferramenta de nós fornece tooltips para identificar um vértice ao passar o ponteiro sobre ele.

Cortar, Copiar e Colar feições

Feições selecionadas podem ser recortadas, copiadas e coladas entre camadas do mesmo projeto do QGIS contanto que a camada de destino estejam selecionadas como mActionToggleEditing :sup: Alternar edição previamente.

Features can also be pasted to external applications as text: That is, the features are represented in CSV format with the geometry data appearing in the OGC Well-Known Text (WKT) format.

However in this version of QGIS, text features from outside QGIS cannot be pasted to a layer within QGIS. When would the copy and paste function come in handy? Well, it turns out that you can edit more than one layer at a time and copy/paste features between layers. Why would we want to do this? Say we need to do some work on a new layer but only need one or two lakes, not the 5,000 on our big_lakes layer. We can create a new layer and use copy/paste to plop the needed lakes into it.

Como exemplo,iremos copiar alguns lagos para a nova camada:

  1. Coloque a camada que você deseja copiar (camada de origem)

  2. Carregar ou criar a camada que você deseja copiar (camada alvo)

  3. Iniciar a edição para a camada alvo

  4. Ative a camada de origem clicando na legenda

  5. Utilize o mActionSelect :sup: Selecionar uma Feição Simples ferramenta para selecionar o recurso (s) sobre a camada de origem

  6. Clique no mActionEditCopy :sup: Funções de cópia ferramenta

  7. Faça a camada de destino ativa cilcando sobre a legenda .

  8. Clique no mActionEditPaste :sup: Colar Recursos

  9. Para a edição e salvar as alterações

O que acontece se a fonte e alvo de camadas têm esquemas diferentes (nomes de campos diferentes e tipos não são a mesma coisa)?|qg| povoa o que corresponde e ignora o resto.Se você não se importar com os atributos que estão sendo copiados para a camada de destino, não importa como você criar os campos e tipos de dados.Se você quer ter a certeza de que tudo-função e seus atributos-que são copiados, certifique-se que os sistemas correspondem.

Dica

** Congruência de Recursos colados **

Se a sua fonte e as camadas de destino usar a mesma projeção, então as características colados terá geometria idêntica à camada de origem.No entanto, se a camada de destino é uma projeção diferente, então | qg | não pode garantir a geometria é idêntica.Isto é simplesmente porque existem pequenos erros de arredondamento envolvidos na conversão entre projeções.

Excluindo recursos selecionados

Se deseja excluir um polígono inteiro, nós podemos fazer isso, selecionando primeiro o polígono usando o normalmente mActionSelect:sup: ferramente Seleção de Recurso Único Você pode selecionar vários recursos para a eliminação.Depois de ter o conjunto de seleção, use o mActionDeleteSelected :sup: ferramenta de Excluir para excluir od recursos.

O mActionEditCut :sup: ferramenta de Recortar feiçõesna barra de ferramentas de digitalização também pode ser utilizado para eliminar características.Isso efetivamente exclui o recurso, mas também coloca-lo em uma “área de transferência espacial. Então nós cortamos o recurso para excluir. mActionEditPaste :sup:ferramenta de Colar feiçõespara colocá-lo de volta, dando-nos a capacidade de desfazer de um nível.Recortar, copiar e colar os trabalhos sobre as características escolhidas no momento, o que significa que pode operar em mais de um de cada vez.

Salvando Camadas editadas

When a layer is in editing mode, any changes remain in the memory of QGIS. Therefore they are not committed/saved immediately to the data source or disk. If you want to save edits to the current layer but want to continue editing without leaving the editing mode, you can click the mActionSaveEdits Save Layer Edits button. When you turn editing mode off with the mActionToggleEditing Toggle editing (or quit QGIS for that matter), you are also asked if you want to save your changes or discard them.

If the changes cannot be saved (e.g. disk full, or the attributes have values that are out of range), the QGIS in-memory state is preserved. This allows you to adjust your edits and try again.

Dica

Integridade dos dados

É sempre uma boa ideia fazer um backup de sua fonte de dados antes de iniciar a edição. Enquanto autores do QGIS fizemos todos os esforços para preservar a integridade de seus dados, não oferecemos garantia a este respeito.

Digitalização Avançada

Ícone

Função

Ícone

Função

mActionUndo

Desfazer

mActionRedo

Refazer

mActionRotateFeature Rotate Feature(s) mActionSimplify

Simplificar feições

mActionAddRing

Adicionar anel

mActionAddPart

Adicionar parte

mActionDeleteRing

Excluir anel

mActionDeletePart

Excluir Parte

mActionReshape

Remodelar Feição

mActionOffsetCurve

Deslocamento da curva

mActionSplitFeatures

Quebrar feições

mActionMergeFeatures

Mesclar feições selecionadas

|mAçãoRotacionarpontoscomsímbolo|

Rotacionar pontos com símbolo

mActionMergeFeatureAttributes

Mesclar Atributos dos recursos selecionados

Tabela Edição avançada: Barra de ferramentas da edição vetorial avançada

Desfazer e Refazer

A ferramenta de mActionUndo :sup:Desfazer e mActionRedo :sup: Refazer permite utilizar as operações de desfazer e refazer nas operações de edição vetorial. . Existe também uma ferramenta acoplável que exibe todas as operações do histórico desfazer/refazer (veja a Figura_edit_3) Esta ferramenta não é exibida como padrão do sistema, mas pode ser exibida a partir de um clique direito na barra de ferramentas e ativando a caixa de seleção Desfazer/Refazer. De qualquer forma desfazer/refazer esta ativa mesmo que a ferramenta não seja exibida.

Figure Edit 3:

../../../_images/redo_undo.png

Redo and Undo digitizing steps nix

Quando desfazer for o estado de todas as feições e atributos serão revertidos para o estado anterior a uma operação acontecer. Modificando outras operações que não forem as normais da adição vetorial (modificações feitas por um complemento por exemplo), podem ou não ser revertidas, dependendo de como as alterações foram executadas.

Para utilizar a ferramenta de histórico do recurso de desfazer/refazer clique para selecionar uma operação na lista de histórico; todas as feições serão revertidas ao estado que estavam depois de a operação selecionada.

Rotate Feature(s)

Use the mActionRotateFeatureRotate Feature(s) to rotate one or multiple selected features in the map canvas. You first need to select the features and then press the mActionRotateFeatureRotate Feature(s) Icon. Then the centroid of the feature appears and will be the rotation anchor point. If you selected multiple features the rotation anchor point will be the common center of the features. Press and drag the left mouse button in the desired direction to rotate the selected features.

It’s also possible to create a user-defined rotation anchor point by which the selected feature will rotate. Select the features to rotate and activate the mActionRotateFeatureRotate Feature(s) Tool. Press and hold the Ctrl button and move the mouse pointer (without pressing the mouse button) to the place where you want the rotation anchor to be moved. Release the Ctrl button when the desired rotation anchor point is reached. Now press and drag the left mouse button in the desired direction to rotate the selected feature(s).

Simplificar feições

A ferramenta mActionSimplify :sup: Simplificar Feições permite reduzir o número de vértices de uma feição de uma forma que a geometria não altere. É necessário selecionar a feição, que será destacada por uma banda de cor avermelhada e uma barra deslizante aparecerá. Movendo a barra, a banda vermelha modifica mostrando como a feição será simplificada. Clicando em [OK] a nova geometria simplificada será armazenada. Caso a feição não estiver apta a simplificação (Múltiplos polígonos por exemplo) um aviso será exibido.

Adicionar anel

É possível criar polígonos em anel usando o ícone mActionAddRing :sup: Adicionar Anel na barra de ferramentas. Isto significa que dentro de uma área existente é possível digitalizar outros polígonos, o que ocorre como um “buraco”, portanto, somente a área entre os limites de outra e dentro de polígonos mantém um polígono de anel.

Adicionar parte

You can mActionAddPart add part polygons to a selected multipolygon. The new part polygon has to be digitized outside the selected multipolygon.

Excluir anel

A ferramenta de mActionDeleteRing :sup: permite excluir um polígono de anel dentro de uma área existente. Esta Ferramenta funciona somente com camadas de polígonos. A ferramenta pode ser utilizada em feições de polígono ou em multipolígonos, contudo não altera nada quando utilizada no exterior de um polígono. Antes de selecionar os vértices de uma parte, ajuste a tolerância para edição de vértices.

Excluir Parte

A ferramenta mActionDeletePart :sup: Excluir Parte permite excluir parte de multi feições(excluir polígonos de uma feição de multi polígonos por exemplo). Entretanto ela não exclui a ultima parte da feição, a ultima parte permanece intocável. Esta ferramenta trabalha com todas as geometrias multi partes de ponto, linha e polígono. Antes de selecionar os vértices de uma parte, ajuste a tolerância para edição de vértices.

Remodelar Feição

É possível remodelar feições de linha e polígono usando o ícone da barra de ferramentas mActionReshape :sup: Remodelar Feições Ele substitui parte ma linha ou polígono da primeira a ultima intersecção com a linha original. Em alguns casos com polígonos pode levar à resultados inesperados. Este recurso é muito útil quando existe a necessidade em substituir pequenas partes de um polígono, não é preciso uma grande reformulação em remodelar linhas entretanto, não é permitido cruzar anel de polígonos originando assim um polígono inválido.

Pode-se, por exemplo, editar limites de um polígono com esta ferramenta. Primeiro, clique dentro de uma área do polígono próximo ao ponto onde deseja-se adicionar o novo vértice. Em seguida cruze o limite e adicione o vértice fora do polígono. Para finalizar dê um clique direito dentro da área do polígono.

Nota

A ferramenta de remodelar pode alterar a posição de partida de um anel ou de uma linha poligonal fechada. Assim, o ponto representado ‘duas vezes’ não será mais o mesmo. Isto pode não ser um problema para a maioria das aplicações, mas é algo a considerar.

A ferramenta de Deslocamento da Curva

The mActionOffsetCurve Offset Curve tool creates parallel shifts of line layers. The tool can be applied to the edited layer (the geometries are modified) or also to background layers (creates copies of the lines / rings and adds it to the the edited layer). It is thus ideally suited for the creation of distance line layers. The displacement is shown at the bottom left of the taskbar. To create a shift of a line layer you have to go into editing mode and then select the feature. You can make the mActionOffsetCurve Offset Curve tool active and drag the cross to the desired distance. Your changes then can be saved with the mActionSaveEditsSave Layer Edits tool.

Quebrar feições

Você pode dividir recursos usando o mActionSplitFeatures :sup: Quebrar Feições ícone na barra de ferramentas. Basta desenhar uma linha através do recurso que você deseja dividir.

Mesclar feições selecionadas

A Ferramenta mActionMergeFeatures :sup: Mesclar Feições Selecionadas permite mesclar características que têm fronteiras comuns e os mesmos atributos.

Mesclar atributos de recursos selecionados

The mActionMergeFeatureAttributes Merge Attributes of Selected Features tool allows to merge attributes of features with common boundaries and attributes without merging their boundaries. You can merge the attributes when selecting several features at once. Then press the mActionMergeFeatureAttributes Merge Attributes of Selected Features button. Now QGIS offers you which attributes are to be applied to all selected objects. As a result, all objects have the same attribute entries.

Rotacionar pontos com símbolo

The mActionRotatePointSymbols Rotate Point Symbols allows to change the rotation of point symbols in the map canvas. You have to define a rotation column from the attribute table of the point layer in the Advanced menu of the Style menu of the Layer Properties. Also you have to go into the ‘SVG marker’ and choose Data defined properties .... Activate checkbox Angle and choose ‘rotation’ as field. Without these settings the tool is inactive.

Figure Edit 4:

../../../_images/rotatepointsymbol.png

Rotate Point Symbols nix

Para alterar a rotação, selecione uma feição de ponto na tela do mapa e rotacione mantendo pressionado o botão esquerdo do mouse. Uma seta vermelha com um valor de rotação será visualizado (veja a Figura_4). Quando você soltar o botão esquerdo do mouse novamente o valor será atualizado na tabela de atributos.

Nota

Caso mantenha pressionada a tecla Control a rotação será executada em passos de 15 graus.

Creating new Vector layers

QGIS allows to create new Shapefile layers, new SpatiaLite layers, and new GPX Layers. Creation of a new GRASS layer is supported within the GRASS-plugin. Please refer to section Criando uma nova camada vetorial GRASS for more information on creating GRASS vector layers.

Criando Uma nova Camada do tipo Shape

Para criar uma nova camada Shape para edição, selecione Novo–> mActionNewVectorLayer :menuselection:Camada do tipo Shape...no menu menuselection: Camada da barra de ferramentas. A caixa de diálogo: Nova Camada Vetorial será exibida como mostra a Figure_edit_5. Escolha o tipo de camada (ponto, linha ou polígono) e o SRC (Sistema de Referência de Coordenadas).

Note that QGIS does not yet support creation of 2.5D features (i.e. features with X,Y,Z coordinates).

Figure Edit 5:

../../../_images/editNewVector.png

Creating a new Shapefile layer Dialog nix

To complete the creation of the new Shapefile layer, add the desired attributes by clicking on the [Add to attributes list] button and specifying a name and type for the attribute. A first ‘id’ column is added as default but can be removed, if not wanted. Only Type: real selectstring, Type: integer selectstring, Type: string selectstring and Type:date selectstring attributes are supported. Additionally and according to the attribute type you can also define the width and precision of the new attribute column. Once you are happy with the attributes, click [OK] and provide a name for the shapefile. QGIS will automatically add a .shp extension to the name you specify. Once the layer has been created, it will be added to the map and you can edit it in the same way as described in Section Digitalizando uma Camada Vetorial Existente above.

Criando uma nova camada SpatiaLite

To create a new SpatiaLite layer for editing, choose New ‣ mActionNewSpatiaLiteLayer New SpatiaLite Layer... from the Layer menu. The New SpatiaLite Layer dialog will be displayed as shown in Figure_edit_6.

Figure Edit 6:

../../../_images/editNewSpatialite.png

Creating a New SpatiaLite layer Dialog nix

First step is to select an existing SpatiaLite database or to create a new SpatiaLite database. This can be done with the browse button browsebutton to the right of the database field. Then add a name for the new layer and define the layer type and specify the Coordinate Reference System with [Specify CRS]. If desired you can select to checkbox Create an autoincrementing primary key.

To define an attribute table for the new SpatiaLite layer, add the names of the attribute columns you want to create with the according column type and click on the [Add to attribute list] button. Once you are happy with the attributes, click [OK]. QGIS will automatically add the new layer to the legend and you can edit it in the same way as described in Section Digitalizando uma Camada Vetorial Existente above.

Further management of SpatiaLite-Layers can be done with the DB Manager see DB Manager Plugin.

Creating a new GPX layer

To create a new GPX file you need to load the GPS plugin first. Plugins ‣ mActionShowPluginManager Plugin Manager... opens the Plugin Manager Dialog. Activate the checkbox GPS Tools checkbox.

When this plugin is loaded choose New ‣ icon_newgpx Create new GPX Layer... from the Layer. In the Save new GPX file as dialog you can choose where to save the new GPX layer.

Trabalhando com a Tabela de Atributos

A tabela de atributos exibe feições de uma camada selecionada. Cada linha na tabela de atributos representa uma feição do mapa e cada coluna contém um pouco de informação particular a camada. Feições na tabela podem ser pesquisadas, selecionadas, movimentadas ou mesmo editadas.

To open the attribute table for a vector layer, make the layer active by clicking on it in the map legend area. Then from the main menu Layer choose mActionOpenTable Open Attribute Table. It is also possible to rightclick on the layer and choose mActionOpenTable Open Attribute Table from the dropdown menu and to click on the mActionOpenTable Open Attribute Table button in the Attributes toolbar.

Este procedimento abrirá uma nova janela que exibe as feições doas atributos da camada (figure_attributes_1). O número de feições e o numero de feições selecionadas são mostrados no título da tabela de atributos.

Figure Attributes 1:

../../../_images/vectorAttributeTable.png

Attribute Table for regions layer nix

Selecionar feições na tabela de atributos

Cada linha selecionada na tabela de atributos exibe o atributo de uma feição da selecionada na camada. Caso a seleção de feições na janela principal for modificada, a seleção é também atualizada na tabela de atributos. Igualmente, caso a seleção de linhas na tabela de atributos for alterada, a seleção de feições na janela principal será atualizada.

Linhas podem ser selecionadas clicando no número de linhas ao lado esquerdo da linha. Múltiplas linhas podem ser marcadas mantendo pressionada a tecla Control. A seleção Contínua contínua pode ser executada segurando a tecla :kbd:`Shift e clicando em vários cabeçalhos de linha no lado esquerdo da linha. Todas as linhas entre a posição do cursor e a linha são selecionadas. Movimentando a posição do cursor na tabela de atributos, clicando em célula na tabela, não modifica a seleção da linha. Alterando a seleção no menu não movimenta a posição do cursor na tabela de atributos.

A tabela pode ser ordenada por qualquer coluna clicando no cabeçalho da coluna. Uma pequena seta indica o ordenamento (apontando para baixo significa valores decrescentes da linha ao topo para baixo).

For a simple search by attributes on only one column choose the Column filter ‣ from the menu in the bottom left corner. Select the field (column) from which the search should be performed from the dropdown menu and hit the [Apply] button. Then only the matching features are shown in the Attribute table.

To make a selection you have to use the mIconExpressionSelect Select features using an Expression icon on top of the Attribute table. The mIconExpressionSelect Select features using an Expression allows you to define a subset of a table using a Function List like in the mActionCalculateField Field Calculator (see Calculadora de campo). The query result then can be saved as a new vector layer. For example if you want to find regions that are boroughs from the regions.shp of the QGIS sample data you have to open the >Fields and Values menu and choose the field that you want to query. Double-klick the field ‘TYPE_2’ and also [Load all unique values] . From list choose and double-klick ‘Borough’. In the Expression field the following query appears:

"TYPE_2"  =  'Borough'

The matching rows will be selected and the total number of matching rows will appear in the title bar of the attribute table, and in the status bar of the main window. For searches that display only selected features on the map use the Query Builder described in Section Query Builder.

To show selected records only, use Show Selected Features from the menu at the bottom left.

The other buttons at the top of the attribute table window provide following functionality:

  • mActionToggleEditing Toggle editing mode to edit single values and to enable functionalities described below also with Ctrl+E
  • mActionSaveEdits Save Edits also with Ctrl+S
  • mActionUnselectAttributes Unselect all also with Ctrl+U
  • mActionSelectedToTop :sup:Mover seleção para o topo também com Ctrl+T

  • mActionInvertSelection Invert selection also with Ctrl+R
  • mActionCopySelected Copiar linhas selecionadas para área de tranferência também com Ctrl+C

  • mActionZoomToSelected Aproximar o mapa às linhas selecionadas também com Ctrl+J

  • PanToSelected Pan map to the selected rows also with Ctrl+P
  • mActionDeleteSelected Excluir recursos selecionados também com Ctrl+D

  • mActionNewAttribute Nova coluna`para camadas de PostGIS e para as camadas OGR com a versão GDAL> = 1.6 também com :kbd:`Ctrl+W

  • mActionDeleteAttribute Delete Column for PostGIS layers and for OGR layers with GDAL version >= 1.9 also with Ctrl+L
  • mActionCalculateField Abrir Calculadora campo `também com :kbd:`Ctrl+I

Dica

Ir geometria WKT

If you want to use attribute data in external programs (such as Excel) use the mActionCopySelected Copy selected rows to clipboard button. You can copy the information without vector geometries if you deactivate Settings ‣ Options ‣ Data sources menu checkbox Copy geometry in WKT representation from attribute table.

Salvar recursos selecionados como nova layer

As feições selecionadas podem ser salvas como qualquer formato vetor OGR suportado e também transformado para outro sistema de referência de coordenadas (SRC). Abra o menu da camada com o botão direito do mouse e clique em menuselection:Salvar seleção como –>para definir o nome do arquivo de saída, seu formato e CRS (veja a seção :ref:`label_legend)Também é possível especificar as opções para criação de OGR dentro da caixa de diálogo.

Trabalhando com tabelas de atributos não espaciais

QGIS allows also to load non spatial tables. This includes currently tables supported by OGR, delimited text as well as the PostgreSQL, MSSQL and Oracle provider. The tables can be used for field lookups or just generally browsed and edited using the table view. When you load the table you will see it in the legend field. It can be opened e.g. with the mActionOpenTable Open Attribute Table tool and is then editable like any other layer attribute table.

As an example you can use columns of the non spatial table to define attribute values or a range of values that are allowed to be added to a specific vector layer during digitizing. Have a closer look at the edit widget in section Fields Menu to find out more.