Важно

Translation is a community effort you can join. This page is currently translated at 65.93%.

2.2. Lesson: Adding your first layers

Мы запустим приложение и создадим базовую карту для использования в примерах и упражнениях.

Цель этого занятия: начать работу с образцом карты.

Примечание

Прежде чем приступить к этому упражнению на вашем компьютере, необходимо установить QGIS. Кроме того, вы должны были загрузить sample data для использования.

Запустите QGIS с его ярлыка на рабочем столе, пункта меню и т.д., в зависимости от того, как вы настроили его установку.

Примечание

Скриншоты для данного курса были сделаны в QGIS 3.4 на Linux. В зависимости от ваших настроек, скрины, с которыми вы сталкиваетесь, могут выглядеть несколько иначе. Однако все те же кнопки по-прежнему будут доступны, а инструкция будет работать на любой ОS. Вам необходима QGIS 3.4 (последняя версия на момент написания) для участия в данном курсе.

Давайте начнем прямо сейчас!

2.2.1. ★☆☆ Follow Along: Prepare a map

  1. Откройте QGIS. У вас появится новая, чистая карта.

    ../../../_images/add_blank_qgis.png
  2. Диалоговое окно Диспетчер источников данных Data Source Manager позволяет вам выбрать данные для загрузки в зависимости от типа данных. Мы будем использовать его для загрузки нашего набора данных: кликните кнопку Диспетчер открытых источников данных dataSourceManager Open Data Source Manager.

    Если вы не можете найти иконку, убедитесь, что панель инструментов Диспетчер источников данных Data Source Manager запущен в меню View ► Toolbars.

    ../../../_images/add_data_dialog.png
  3. Загрузите набор векторных данных Охраняемые территории protected_areas.shp:

    1. Кликните по вкладке Vector.

    2. Запустите тип источника radioButtonOnFile.

    3. Нажмите на кнопку многоточие рядом с Набор(ы) векторных данных Vector Dataset(s).

    4. Выберите файл exercise_data/shapefile/protected_areas.shp в вашем учебном каталоге.

    5. Кликните Открыть Open. Появится исходное диалоговое окно с заполненным путем к файлу.

      ../../../_images/add_vector_dialog.png
    6. Кликните также Добавить Add сюда. Указанные вами данные теперь загрузятся: вы увидите элемент protected_areas на панели Слои Layers (внизу, слева) с его функциями, показанными на основном полотне карты.

      ../../../_images/first_loaded_layer.png

Поздравляем! Теперь у вас есть базовая карта. Сейчас необходимо сохранить вашу работу.

  1. Кликните на кнопку Сохранить как Save As: fileSaveAs

  2. Сохраните карту в папке Решение solution folder рядом с exercise_data и назовите ее basic_map.qgz.

2.2.2. ★☆☆ Try Yourself:

Повторите шаги, описанные выше для добавления слоев Места places.shp и Реки rivers.shp из той же папки (exercise_data/shapefile) в карту.

2.2.3. ★☆☆ Follow Along: Loading vector data from a GeoPackage Database

Базы данных позволяют хранить большой объем связанных данных в одном файле. Возможно, вы уже знакомы с Системой управления базами данных (СУБД / DBMS), такой как Libreoffice Base или MS Access. Приложения GIS также могут использовать базы данных. Системы СУБД, ориентированные на GIS (например, PostGIS) имеют дополнительные функции, поскольку им необходимо обрабатывать пространственные данные.

Открытый формат GeoPackage это контейнер, который позволяет хранить данные (слои) GIS в одном файле. В отличие от формата ESRI Shapefile (например, набор данных protected_areas.shp, который вы загрузили ранее), один файл GeoPackage может содержать различные данные (как векторные, так и растровые) в разных системах координат, а также таблицы без пространственной информации; все эти функции позволяют легко обмениваться данными и избегать дублирования файлов.

Чтобы загрузить слой из GeoPackage, вам сначала нужно создать к нему соединение:

  1. Кликните на кнопку Диспетчер открытого источника данных  dataSourceManager Open Data Source Manager.

  2. Кликните слева на вкладку Геопакет newGeoPackageLayer GeoPackage.

  3. Кликните на кнопку Новое New и перейдите к файлу training_data.gpkg в папке exercise_data которую вы загрузили ранее.

  4. Выберите файл и нажмите Open. Теперь путь файла добавлен к списку связей Geopackage, он появляется в раскрывающемся меню.

Теперь вы готовы добавлять любой слой из GeoPackage в QGIS.

  1. Кликните по кнопке Соединить Connect. В центральной части окна вы должны увидеть список всех слоев, хранящихся в файле GeoPackage.

  2. Выберите слой Дороги roads layer и кликните на кнопку Add button.

    ../../../_images/add_data_dialog_geopackage.png

    Слой roads добавлен на панель Слои Layers с функциями, отображаемыми на полотне карты.

  3. Кликните Close.

Поздравляем! Вы загрузили первый слой из GeoPackage.

2.2.4. ★☆☆ Follow Along: Loading vector data from a SpatiaLite Database with the Browser

QGIS предоставляет доступ ко многим другим форматам баз данных. Как и GeoPackage, формат базы данных SpatiaLite является расширением библиотеки SQLite. И добавление слоя из поставщика SpatiaLite следует тем же правилам, что описаны выше: Создать соединение –> Запустить его –> Добавить слой(и), т.е.  Create the connection –> Enable it –> Add the layer(s).

Это пока один из способов добавления данных SpatiaLite на вашу карту, давайте рассмотрим еще один эффективный способ добавления данных: Браузер Browser.

  1. Кликните на иконку dataSourceManager, чтобы открыть окно Диспетчера источника данных Data Source Manager.

  2. Кликните на вкладку fileOpen Browser.

  3. В этой вкладке вы можете увидеть все жесткие диски, подключенные к вашему компьютеру, а также записи для большинства вкладок слева. Это обеспечивает быстрый доступ к подключенным базам данных или папкам.

    Например, кликните на раскрывающуюся иконку рядом со элементом Геопакет geoPackage GeoPackage. Вы увидите файл training-data.gpkg, который мы предварительно соединили (а также его слои, если он расширяется).

  4. Правый клик по элементу spatialite SpatiaLite eи выберите Новое соединение New Connection….

  5. Перейдите к папке exercise_data , выберите файл Землепользование landuse.sqlite и кликните Open.

    Обратите внимание, что элемент dbSchema landuse.sqlite добавлен в SpatiaLite.

  6. Разверните элемент dbSchema landuse.sqlite.

  7. Кликните дважды на слой  polygonLayer landuse или выберите и перетащите его на полотно карты. Новый слой добавлен на панель Layers и его функции отображены на полотне карты.

    ../../../_images/spatialite_dialog_connected.png

Совет

Запустить панель Browser в Вид-Панели View ► Panels ► и используйте ее для добавления ваших данных. Это удобный ярлык для вкладки Data Source Manager ► Browser с той же функциональностью.

Примечание

Не забудьте часто сохранять проект! Файл проекта не содержит данных, но помнит, какие слои загружены на карту.

2.2.5. ★★☆ Try Yourself: Load More Vector Data

Загрузите следующий набор данных из папки exercise_data на карту при помощи любого метода, описанного выше:

  • Здания buildings

  • Вода water

2.2.6. Follow Along: Reordering the Layers

Слои в вашем списке Слоев отображаются на карте в определенном порядке. Слой внизу списка рисуется первым, а слой вверху рисуется последним. Изменяя порядок, в котором они отображаются в списке, вы можете изменить порядок, в котором они отображаются.

Примечание

Вы можете изменить это поведение, установив флажок Управление предложенным порядком Control rendering order под панелью Порядок слоев Layer Order. Однако мы пока не будем обсуждать эту функцию.

Порядок, в котором слои были загружены на карту, на данном этапе, вероятно, не логичен. Возможно, слой дороги полностью скрыт, потому что другие слои находятся поверх него.

Например, такой порядок слоев…

../../../_images/incorrect_layer_order.png

… приведет к тому, что дороги и места будут скрыты, поскольку они находятся под полигонами слоя землепользования.

Чтобы решить данную проблему:

  1. Кликните и перетащите слой из списка Слоев.

  2. Измените их порядок, чтобы они выглядели следующим образом:

../../../_images/correct_layer_order.png

Вы увидите, что карта теперь визуально более понятна: дороги и здания появляются над территориями землепользования.

2.2.7. In Conclusion

Теперь вы добавили все необходимые слои из нескольких разных источников и создали базовую карту!

2.2.8. What’s Next?

Теперь вы знакомы с основными функциями кнопки Управление открытым источником данных Open Data Source Manager, но как насчет всех остальных? Как работает этот интерфейс? Прежде чем мы продолжим, давайте взглянем на некоторые основы взаимодействия с интерфейсом QGIS. Это тема следующего занятия.