Outdated version of the documentation. Find the latest one here.

.

Configurazione di QGIS

QGIS è altamente configurabile grazie al menu Impostazioni ‣. Altre opzioni di configurazione sono possibili attraverso i menu Pannelli e Barre degli strumenti presenti nel menu Visualizza ‣.

Nota

QGIS segue le linee guida del desktop per la posizione di opzioni e proprietà del progetto.Quindi in relazione al sistema operativo che si sta utilizzando, la posizione di alcuni degli elementi di cui sopra può essere situata nel :MenùSelection:`Visualizza` (pannelli e barre degli strumenti) o in: MenuSelection: Progetto per Opzioni.

Pannelli e Barre degli strumenti

Nel menu Pannelli ‣ è possibile attivare e disattivare i widgets di QGIS. Il menu Barre degli strumenti ‣ offre la possibilità di attivare e disattivare gruppi di icone nella barra degli strumenti di QGIS (vedi figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

Pannelli e Barre degli strumenti nix

Suggerimento

Panoramica

Attraverso il pannello panoramica hai la possibilità di visualizzare tutti i layer aggiunti. Pui attivare il pannello dal menu Visualizza ‣ Pannelli. All’interno della panoramica è presente un rettangolo che mostra l’estensione attuale della mappa. Questo ti permette di determinare rapidamente quale area della mappa stai attualmente osservando. Le etichette dei layer non sono visualizzate nella panoramica anche se la funzione di visualizzazione delle etichette è attiva. Cliccando e trascinando il rettangolo rosso che mostra l’estensione corrente della tua vista, la mappa si sposterà di conseguenza.

Suggerimento

Messaggi di log

Puoi facilmente tenere traccia dei messaggi di QGIS. Attiva la casella di controllo checkbox Messaggi di log nel menu nix Visualizza ‣ Pannelli e leggi i messaggi relativi alle varie operazioni nelle diverse schede.

Proprietà progetto

Nella finestra proprietà del progetto in nix:MenuSelection: Impostazioni -> Proprietà progetto... (kde) o nix win :MenuSelection:` Progetto -> Proprietà progetto...` (Gnome), puoi impostare specifiche opzioni del progetto. Queste includono:

  • Nella scheda Generale puoi impostare: il titolo del progetto, il colore della selezione e dello sfondo, l’unità di misura della mappa, la precisione e l’opzione di salvare il percorso ai layer come relativo o assoluto. Se hai attivato la trasformazione del SR puoi specificare un ellissoide per il calcolo delle distanze. Puoi scegliere le unità della mappa (solo se la trasformazione del SR è disattivata) e la precisione del numero (cifre decimali). Infine puoi anche inserire una lista di scale che sovrascriveranno le scale preimpostate.

  • La scheda SR permette di scegliere il sistema di riferimento e di abilitare la riproiezione al volo di raster e vettori quando questi hanno un SR diverso.

  • La terza scheda Informazioni vettore permette di attivare/disattivare i vettori che possono essere interrogati (vedi anche il paragrafo relativo agli strumenti mappa nella sezione Opzioni dell’interfaccia grafica (GUI) per maggiori informazioni sull’interrogabilità di vettori multipli).

  • La scheda Stiili predefiniti ti consente di controllare gli stili dei nuovi layer se non hanno già uno stile definito .qml. Puoi impostare il livello di trasparenza predefinito per nuovi layei e se assegnare colori casuali ai simboli. C’è anche una sezione aggiuntiva in cui puoi definire colori specifici per il progetto in corso. Potrai trovare i colori aggiunti nella lista a cascata della finestra di dialogo dei colori presente in ogni visualizzazione.

  • La scheda Server OWS permette di impostare le informazioni dei server WMS e WFS, l’estensione e le restrizioni dei SR.

  • La scheda Macro serve per modificare le macro di Python per il progetto. Attualmente sono disponibili tre macro: openProject(), saveProject() e closeProject().

Figure Macro Menu:

../../../_images/macro.png

Impostazioni macro in QGIS

  • La scheda Relazioni permette di impostare relazioni 1:n. Le relazioni sono definite nella finestra di dialogo delle proprietà del progetto. Una volta impostate le relazioni per un vettore, la vista modulo (cioè quando si interroga il vettore con lo strumento informazioni elemento) elencherà le relazioni in una finestra dedicata. Le relazioni 1:n sono uno strumento molto prezioso che può essere utilizzato, per esempio, per tenere traccia delle ispezioni storiche di un tratto stradale o di manutenzione delle tubature. Per maggiori informazioni sulle relazioni 1:n dai un’occhiata alla sezione Creating one to many relations.

Opzioni dell’interfaccia grafica (GUI)

mActionOptions Alcune opzioni di base per QGIS possono essere impostate nella finestra Opzioni. Seleziona la voce Impostazioni ‣ mActionOptions Opzioni. Le schede dedicate alla personalizzazione sono descritte di seguito.

Menu Generale

Applicazione

  • Seleziona Stile (Necessario il riavvio di QGIS) selectstring e scegli fra ‘Windows’, ‘Motif’, ‘CDE’, ‘Plastique’ e ‘Cleanlooks’ (nix).

  • Definisci il Tema delle icone selectstring. Attualmente è disponibile solo ‘default’.

  • Definisci la Dimensione delle icone selectstring.

  • Definisci il Carattere. Scegli fra radiobuttonon Qt predefinito o un carattere di tua scelta.

  • Cambia il Timeout per messaggi o dialoghi a tempo selectstring.

  • checkbox Nascondi lo splash screen all’avvio

  • checkbox Mostra suggerimenti all’avvio

  • checkbox Titoli del gruppo box in grassetto

  • checkbox Box gruppi secondo stile QGIS

  • checkbox Usa pannelli scelta colore per aggiornare

File di progetto

  • Apri un progetto all’apertura di QGIS selectstring (scegli fra ‘Nuovo’, ‘Più recente’ e ‘Specifico’). Se hai scelto ‘Specifico’ usa browsebutton per scegliere il progetto da aprire.

  • checkbox Crea un nuovo progetto dal progetto predefinito. Puoi scegliere Definisce il progetto attuale come predefinito oppure Ripristina il predefinito. Sfoglia fra i tuoi file e specifica la cartella in cui sono presenti i progetti da usare come modello. Se hai spuntato la casella di controllo checkbox Crea un nuovo progetto dal progetto predefinito e hai salvato un progetto nella cartella dei modelli, comparirà la nuova voce Progetto ‣ Nuovo da modello.

  • checkbox Chiedi di salvare il progetto e cambia sorgente dati quando richiesto

  • checkbox Avvisa quando viene aperto un file di progetto salvato con una vecchia versione di QGIS

  • Abilita macro selectstring. Questa opzione serve per gestire le macro create per eseguire azioni sul progetto. Puoi scegliere fra ‘Mai’, ‘Chiedi’, ‘Solo per questa sessione’ e ‘Sempre (sconsigliato)’.

Menu Sistema

Ambiente

Il gruppo Ambiente mostra le variabili di ambiente e permette anche di configurarle (vedi figure_environment_variables). Questa opzione è particolarmente utile per piattaforme stile Mac, dove le applicazioni GUI non ereditano necessariamente l’ambiente shell dell’utente. È utile anche per impostare/visualizzare le variabili di ambiente usate da strumenti esterni, gestiti da Processing come, SAGA e GRASS. Infine è utile anche per abilitare gli output del debug per specifiche sezione del codice sorgente.

  • checkbox Usa variabili utente (necessario il riavvio - includere i separatori). Gestisci le variabili con i pulsanti [Aggiungi] e [Rimuovi]. Il Variabili di ambiente attuali ‣ mostra le variabili di ambiente già definite e puoi scegliere di filtrarle spuntando la casella di controllo checkbox Mostrare le sole variabili specifiche di QGIS.

Figure System Environment:

../../../_images/sys-env-options.png

Variabili di ambiente in QGIS

Percorsi verso i plugin

[Aggiungi] o [Rimuovi] Percorsi per cercare ulteriori librerie plugin C++

Menu Sorgente dati

Attributi delle geometrie e tabelle

  • checkbox Apri la tabella degli attributi in una finestra agganciata (richiede il riavvio di QGIS)

  • checkbox Copia la geometria in formato WTK dalla tabella degli attributi. Cliccando su mActionCopySelectedCopia le righe selezionate nel blocco appunti dal menu della Tabella degli attributi verranno copiate, oltre agli attributi, anche le coordinate dei vertici della geometria.

  • Comportamento della tabella di attributi selectstring. Sono presenti tre possibilità: ‘Mostra tutti gli elementi’, ‘Mostra gli elementi selezionati’ e ‘Mostra gli elementi visibili nella mappa’.

  • Cache riga attributi tabella selectnumber. La cache permette di salvare le ultime n righe degli attributi caricate: in questo modo il lavoro con la tabella degli attributi risulterà essere molto più veloce. La cache verrà cancellata alla chiusura della tabella degli attributi.

  • Mostra i valori NULL come. Puoi definire un attributo con cui verranno visualizzati i valori NULL (nessun valore).

Trattamento delle sorgenti dati

  • Ricerca elementi validi nella finestra del browser selectstring. Puoi scegliere fra ‘Controlla estensione’ e ‘Controlla il contenuto del file’.

  • Ricerca contenuto dei file compressi (.zip) nella finestra del browser selectstring. Puoi scegliere fra ‘No’, ‘Scansione base’ e ‘Scansione completa’ .

  • Richiedi i sublayer raster al caricamento. Alcuni raster supportano i sublayer, chiamati subdataset in GDAL. Un esempio sono i file netCDF: se sono presenti diverse variabili netCDF, GDAL riconosce ogni variabile come un subdataset. L’opzione permette di gestire i sublayer quando uno di questi viene aperto. Puoi scegliere fra:

    • ‘Sempre’: chiede sempre (se sono presenti sublayer)

    • ‘Se necessario’: chiede se il layer non ha bande, ma ha sublayer

    • ‘Mai’: non chiede mai e non carica niente

    • ‘Carica tutto’: non chiede, ma carica tutti i sublayer

  • checkbox Ignora la dichiarazione di codifica per lo shapefile. Se lo shapefile ha informazioni sulla sua codifica, queste verranno ignorate.

  • checkbox Aggiungi un layer PostGIS con un doppio click e seleziona la modalità estesa

  • checkbox Aggiungi layer Oracle con un doppio click e seleziona modalità estesa

Menu Visualizzazione

Impostazioni di visualizzazione

  • checkbox Per impostazione predefinita i nuovi layer aggiunti alla mappa vengono visualizzati subito

  • checkbox Usa il caching del disegno quando possibile per velocizzare la visualizzazione

  • checkbox Visualizza i layyer in parallelo usando più processori della CPU

  • checkbox Numero massimo di processori

  • Intervallo dio aggiornamento della mappa (predefinito a 250 ms)

  • checkbox Abilita semplificazione delle geometrie per i nuovi vettori aggiunti

  • Semplifica dal lato provider se possibile

  • checkbox Semplifica dal lato provider se possibile

  • Scala massima alla quale il layer dovrebbe essere semplificato

Impostazioni di visualizzazione

  • checkbox Rendi le linee meno irregolari a spese delle prestazioni

Raster

  • Con Selezione banda RGB puoi scegliere il numero di bande rosse, verdi e blu.

Miglioramento contrasto

  • Banda singola grigia selectstring. Una singola banda grigia può avere: ‘Nessuno stiramento’, ‘Stira a MinMax’, ‘Stira e taglia a MinMax’ e anche ‘Taglia a MinMax’.

  • Colore multibanda (byte/band) selectstring. Le opzioni sono ‘Nessuno stiramento’, ‘Stira a MinMax’, ‘Stira e taglia a MinMax’ e ‘Taglia a MinMax’.

  • Colore multibanda (>byte/band) selectstring. Le opzioni sono ‘Nessuno stiramento’, ‘Stira a MinMax’, ‘Stira e taglia a MinMax’ e ‘Taglia a MinMax’.

  • Limiti (minimo/massimo) selectstring. Le opzioni sono ‘Taglio del conteggio cumulativo pixel’, ‘Minimo/Massimo’, ‘Media +/- deviazione standard’

  • Limiti di taglio del conteggio cumulativo pixel

  • Moltiplicatore deviazione standard

Debugging

  • checkbox Aggiornamento della visualizzazione della mappa

Menu Colori

Questo menu ti consente di aggiungere colori personalizzat che potrai trovare in ogni finestra di dialogo colore delle visualizzazioni. Vedrai una serie di colori predefiniti nella scheda, che potrai modificare o eliminare. Inoltre puoi aggiungere i colori desiderati ed eseguire operazione di copia e incolla. Infine è possibile esportare il set di colori come gpl o importarne.

Menu Mappa & Legenda

Aspetto della mappa (modificato dalle proprietà del progetto)

  • Scegli un Colore della selezione e un Colore di sfondo

Legenda dei layer

  • Azione eseguita in legenda sul comando doppio click selectstring. Puoi scegliere fra ‘Apri proprietà layer’ oppure ‘Apri tabella degli attributi’ facendo doppio click sul layer.

  • Puoi scegliere diverse opzioni per gli Stili elementi legenda:

    • checkbox Nomi dei layer in maiuscolo

    • checkbox Nomi dei layer in grassetto

    • checkbox Nomi gruppo in grassetto

    • checkbox Visualizza nomi di classificazione degli attributi

    • checkbox Crea le icone raster (potrebbe essere lento)

    • checkbox Aggiungi nuovi layer al gruppo selezionato

Menu Strumenti mappa

Questo menu ti permette di scegliere alcune opzioni sul comportamento di Informazioni.

  • Raggio di ricerca per identificare e visualizzare le relative informazioni sulla mappa è un fattore di tolleranza espressa come percentuale della larghezza mappa. Ciò significa che lo strumento di informazione mostrerà i risultati se si fa clic all’interno di questa tolleranza.

  • Colore di evidenziaione di scegliere con quale colore saranno evidenziati gli elementi identificati.

  • Buffer espressa come percentuale della larghezza mappa, determina una distanza buffer dal contorno dell’elemento da evidenziare.

  • Larghezza minima espressa come percentuale della larghezza mappa, determina lo spessore che dovrebbe il contorno di un oggetto evidenziato.

Strumenti di misura

  • Colore elastico

  • Posizioni decimali

  • checkbox Mantieni le unità di base

  • Unità di misura preferita radiobuttonon (‘Metri’, ‘Piedi’, ‘Miglia nautiche’ o ‘Gradi’)`

  • Unità preferite per gli angoli radiobuttonon (‘Gradi’, ‘Radianti’ o ‘Gradi decimali’)

Spostamento e zoom

  • Define Mouse wheel action selectstring (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Fattore di zoom

Scale preimpostate

Qui trovi un elenco di scale preimpostate. Con i pulsanti [+] e [-] puoi aggiungere ed eliminare altre scale.

Menu Compositore

Opzioni predefinite del compositore

Qui puoi impostare il Carattere predefinito.

Reticolo

  • Specifica lo Stile reticolo selectstring (‘Pieno’, ‘Punti’, ‘Croci’)

  • Scegli il Colore...

Opzioni predefinite del reticolo

  • Specifica la Spaziatura selectnumber

  • Scegli l’ Offset reticolo selectnumber per x e y

  • Definisci la Tolleranza di snap selectnumber

Opzioni predefinite delle guide

  • Definisci la Tolleranza di snap selectnumber

Menu Digitalizzazione

Creazione di geometrie

  • checkbox Non aprire la finestra degli attributi dopo la creazione di ogni geometria

  • checkbox Ripeti i valori degli attributi usati per ultimi

  • Verifica le geometrie. Modificare linee/poligoni con molti nodi può portare a una visualizzazione molto lenta: questo succede perché le procedura di verifica delle geometrie in QGIS richiede molto tempo. Per velocizzare la visualizzazione è possibile selezionare GEOS (GEOS 3.3) dal menu a tendina oppure disattivare del tutto la verifica. La verifica effettuata da GEOS è molto più rapida, ma ha lo svantaggio di comunicare solamente il primo problema geometrico riscontrato.

Elastico

  • Definisci le proprietà dell’elastico, Spessore della linea e Colore della linea

Snapping

  • checkbox Apri le opzioni di snap in una finestra agganciata (richiede il riavvio di QGIS)

  • Imposta la Modalità di snap predefinita selectstring (‘Al vertice’, ‘Al segmento’, ‘Al vertice e al segmento’, ‘Spento’)

  • Imposta la Tolleranza di snapping predefinita in unità di mappa o pixel

  • Imposta il Raggio di ricerca per le modifiche dei vertici in unità di mappa o in pixel

Indicatori di vertice

  • checkbox Utilizza indicatori solo per le geometrie selezionate

  • Imposta lo Stile indicatore selectstring (‘Croce’ (predefinito), ‘Cerchio semi trasparente’ o ‘Nessuno’)

  • Specifica le Dimensioni indicatore

Strumento per la curva di offset

Le 3 opzioni successive si riferiscono allo strumento mActionOffsetCurve Curva di offset in Digitalizzazione avanzata. Attraverso i vari settaggi è possibile influenzare la forma della linea di offset. Queste opzioni sono possibili da GEOS 3.3.

  • Stile unione

  • Segmenti di quadrante

  • Limite di smusso

Menu GDAL

GDAL è una libreria di lettura e scrittura per file raster. In questa scheda puoi Modificare le opzioni di creazione e Modificare le opzioni per le piramidi. Scegli quali driver GDAL devono essere utilizzati per un formato raster specifico poiché spesso sono disponibili più driver GDAL per lo stesso formato.

Menu SR

SR predefinito per nuovi progetti

  • radiobuttonoff Non abilitare la riproiezione ‘al volo’

  • radiobuttonon Abilita automaticamente la ‘riproiezione al volo’ se i layer hanno SR differente

  • radiobuttonoff Effettua sempre la riproiezione al volo

  • Seleziona un SR e Inizia un nuovo progetto sempre con questo SR

SR per i nuovi layer

Questa sezione permette di specificare il comportamento di QGIS quando viene creato un nuovo layer oppure quando viene caricato un layer privo di SR.

  • radiobuttonon Richiedi SR

  • radiobuttonoff Usa il SR del progetto

  • radiobuttonoff Utilizza come predefinito SR visualizzato sotto

Trasformazioni datum predefinite

  • checkbox Chiedi la trasformazione del datum quando non è definito un valore di riferimento

  • Se hai lavorato con la trasformazione del SR ‘al volo’ puoi vedere i risultati della trasformazione nella finestra di sotto. Questa finestra mostra infatti le informazioni del ‘SR sorgente’, ‘SR destinazione’, ‘Trasformazione datum sorgente’ e ‘Trasformazione datum destinazione’.

Menu Lingua

  • checkbox Sovrascrivi lingua in uso

  • Informazioni sulla lingua correntemente impostata nel sistema

Menu Rete

Generale

  • Indirizzo di ricerca WMS (Quello predefinito è “http://geopole.org/wms/search?search=%1&type=rss”)

  • Imposta il Timeout per le richieste di rete (ms) - il valore predefinito è 60000

  • Imposta il Periodo di scadenza predefinito per piastrelle WMSC/WMTS (ore) - valore standard è 24

  • Specifica il Numero massimo di tentativi in caso di errore nella richiesta della mattonella

  • Definisci l’Utente-Agente

Figure Network Tab:

../../../_images/proxy-settings.png

Impostazioni dei proxy in QGIS

Impostazioni della cache

Specifica la Cartella e la Dimensione per la cache.

  • checkbox Utilizza un proxy per l’accesso web, definizione di host, porta, utente e password.

  • Definizione del Tipo proxy selectstring.

    • Default Proxy:Il proxy è determinato sulla base delle impostazioni in uso del proxy dell’applicazione

    • Socks5Proxy: Proxy generico per ogni tipo di connessione. Supporta TCP, UDP, associazione a una porta (connessione in entrata) e autenticazione.

    • HttpProxy: Realizzato usando il comando “CONNECT”, supporta solamente connessioni TCP in uscita; supporta l’autenticatione.

    • HttpCachingProxy: Realizzato usando normali comandi HTTP, è utile solamente nel contesto di richieste HTTP.

    • FtpCachingProxy: Realizzato usando un proxy FTP, è utile solamente nel contesto di richieste FTP.

È possibile escludere alcuni URL aggiungendo il testo nella sezione dedicata (vedi Figure_Network_Tab).

Per informazioni più dettagliate sulle diverse impostazioni del proxy, fai riferimento al manuale della documentazione delle librerie QT suhttp://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Suggerimento

UTILIZZO DEI PROXY

L’utilizzo dei proxy può risultare complicato. È utile testare i tipi di proxy elencati sopra e controllare il loro funzionamento nel tuo caso specifico.

Queste opzioni possono essere modificate in funzione delle proprie esigenze. Alcuni cambiamenti potrebbero richiedere il riavvio di QGIS prima di essere attivi.

  • nix Impostazioni sono salvate in file testo $HOME/.config/QGIS/QGIS2.conf

  • osx puoi trovare le impostazioni in: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win le impostazioni sono salvate nel resistro: HKEY\CURRENT_USER\Software\QGIS\qgis

Personalizzazione

Lo strumento di personalizzazione permette di attivare/disattivare praticamente qualunque elemento dell’interfaccia di QGIS. È molto utile se sono stati installati molti plugin, usati raramente e che riempiono lo schermo e la barra degli strumenti.

Figure Customization 1:

../../../_images/customization.png

Finestra di dialogo Personalizzazione nix

Il menu Personalizzazione di QGIS è diviso in cinque gruppi. In checkbox Menu è possibile nascondere funzioni all’interno della Barra dei Menu. In checkbox Panelli puoi trovare tutti i pannelli presenti in QGIS. I pannelli sono applicazioni che possono essare avviate e usate come finestre mobili, fisse oppure possono essere incorporate nella finestra principale di QGIS come se fossero dei widget (see also Pannelli e Barre degli strumenti). In checkbox Barra di stato è possibile disattivare caratteristiche come le informazioni sulle coordinate. In checkbox Barra degli strumenti è possibile attivare/disattivare le icone della barra degli strumenti di QGIS e in checkbox Widgets si possono attivare/disattivare i diversi pannelli presenti in QGIS.

Con mActionSelect Passa ai widget per la cattura nell’applicazione principale puoi cliccare sugli elementi di QGIS che vuoi nascondere dall’interfaccia e ritrovarli cosi nel menu Personalizzazione (vedi figure_customization). Puoi anche salvare le diverse impostazioni a seconda dei diversi utilizzi. Prima che i cambiamenti diventino effettivi devi riavviare QGIS.