Outdated version of the documentation. Find the latest one here.

.

Configuração QGIS

O QGIS é altamente personalizável através do menu Configurações . Escolha entre Painéis, Caixa de Ferramentas, Propriedades do Projeto, Opções e Personalização.

Painéis e Barras de Ferramentas

No menu Painéis‣ pode desligar os widgets do QGIS. O menu Caixa de Ferramentas‣ fornece a possibilidade de trocar ativar ou desativar grupos de ícones na barra de ferramentas do QGIS (veja figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

Os Painéis e o Menu de Barra de Ferramentas nix

Dica

Ativando o Enquadramento QGIS

No QGIS pode usar o painel do enquadramento que fornece a extensão total das camadas adicionadas. Pode ser selecionada no menu nix Configurações ‣ Painéis ou win Ver ‣ Paineis. Dentro da vista existe um retângulo a mostrar a extensão atual do mapa. Isto permite rapidamente determinar que área do mapa está a ver atualmente. É de notar que os rótulos não serão renderizados no enquadramento do mapa mesmo que seja ativado a rotulagem. Se clicar e arrastar o retângulo vermelho no enquadramento que mostra a atual extensão, este irá atualizar de acordo como o mapa principal.

Dica

Mostrar Mensagens de Registro

É possível seguir as mensagens do QGIS. Pode ativar o checkboxRegisto de Mensagens no menu nix Configurações ‣ Painéis ou win Vier ‣ Painéis e seguir as mensagens que aparecem nos diferentes separadores durante o carregamento e operação.

Propriedades do Projeto

In the properties window for the project under nix Settings ‣ Project Properties or win Project ‣ Project Properties, you can set project-specific options. These include:

  • No menu Geral podem ser definidos o título do projeto, a cor de seleção e fundo, unidades da camadas, precisão, e os caminhos relativos onde serão salvas as camadas. Se a transformação SRC estiver ligada pode escolher o cálculo de distâncias recorrendo ao elipsóide. Pode definir as unidades do enquadramento (apenas usado quando a transformação SRC está desativada) e a precisão das casas decimais a usar. Pode definir também uma escala de projeto, que rescreverá sobre as escalas globais pré-definidas.

  • O menu SRC permite que escolha o Sistema de Coordenadas Referência para o projeto, e para ativar a reprojeção on-the-fly das camadas matricias e vetoriais na exibição de camadas de diferentes SRC.

  • Com o terceiro menu Identificar camadas pode definir (ou desativar) que camadas irão responder à ferramenta identificar. (Veja o parágrafo das “Ferramentas de Mapa” da seção Opções Seção para ativar a identificação de múltiplas camadas).

  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them.
  • O separador Servidor OWS permite definir a informação sobre as Capacidades do WMS e WFS, a extensão e as restrições SRC do Servidor QGIS.

  • O menu Macros é para editar macros Python para os projetos. Atualmente, apenas estão disponíveis três macros: openProject(), saveProject() e closeProject().

Figure Macro Menu:

../../../_images/macro.png

Configurações de Macro no QGIS

  • O menu Relations é usado para definir relações 1:n. As relações são definidas no diálogo das propriedades do projeto. Quando existirem relações para uma camada, um novo elemento de interface do utilizador na vista de formulário (p. ex. quando identificar um elemento e abrir o seu formulário) irá listar os elementos relacionados. Isto fornece uma maneira poderosa para expressar p. ex. o histórico de inspeção ao longo de um segmento de tubagem ou estrada. Poderá encontrar mais informação sobre suporte de relações 1:n na Seção Criando uma ou mais relações.

Opções

mActionOptions Algumas opções básicas para QGIS podem ser selecionadas usando o diálogo Options. Selecione a opção de menu Configurações ‣ mActionOptions Opções. Os separadores onde poderá personalizar as suas opções são descritos abaixo.

Menu Geral

Aplicação

  • Selecione a Estilo (Necessário reiniciar o QGIS) selectstring e escolha entre ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ e ‘Cleanlux’ (nix).

  • Definir o Tema de Ícone selectstring. Atualmente a opção ‘default’ é possível.

  • Definir o Tamanho do Ícone selectstring.

  • Definir a Fonte. Escolha entre radiobuttonon QT padrão e uma fonte definida pelo utilizador.

  • Altera o Tempo limite para mensagens ou diálogos selectstring.

  • checkbox Não exibir a janela inicial

  • checkbox Mostrar dicas ao iniciar

  • checkbox Títulos da caixa de grupos a negrito

  • checkbox QGIS-estilo das caixas de grupo

  • checkbox Use diálogos seletores de cor para atualizações ao vivo

Arquivos de projeto

  • Abrir o projeto no arranque selectstring (escolha entre ‘Novo’. ‘Mais recente’ e ‘Específico’). Quando escolher ‘Específico’ use browsebutton para definir um projeto.

  • checkbox Criar um novo projeto como projeto padrão. Tem a possibilidade de carregar em Usar projeto atual com padrão ou em Resetar padrão. Pode navegar através dos seus arquivos e definir um diretório onde encontra os modelos de projeto definidos pelo usuário. Isto será adicionado a Projeto ‣ Novo do modelo. Primeiro ative checkbox Criar novo projeto como projeto padrão e a seguir salve o projeto dentro da pasta de modelos de projeto.

  • checkbox Avisar para salvar projeto e alterações de fontes de dados quando necessário

  • checkbox Avisar quando abrir um projeto salvado com uma versão antiga do |qg|

  • Enable macros selectstring. Esta opção foi criada para lidar com as macros que são escritas para executar uma ação nos eventos do projeto. Pode escolher entre ‘Never’, ‘Ask’, ‘For this session only’ e ‘Always (not recommended)’.

Menu Sistema

Ambiente

Variáveis de ambiente do sistema podem ser vistas agora, e muitas configuradas, no grupo Environment (ver figure_environment_variables). Isto é útil para plataformas, tais como Mac, onde um aplicativo GUI não herda necessariamente o ambiente do utilizador da linha de comandos. Também é útil para configuração e visualização de variáveis de ambiente para os conjuntos de ferramentas externas controlados pela caixa de ferramentas de Processamento (p. ex., SAGA, GRASS), e para ativar a saída de depuração (“debugging”) para seções específicas do código-fonte.

  • checkbox Utilize variáveis ​​personalizadas (Reinício necessário - incluem separadores). Você pode [Adicionar] e [remover] variáveis. Variáveis ​​de ambiente já definidas são exibidos em variáveis de ambiente ​​atual, e é possível filtrá-las ativando checkbox Mostrar somente variáveis ​específicas-QGIS.

Figure System Environment:

../../../_images/sys-env-options.png

Variáveis de ambiente do Sistema no QGIS

Diretórios dos complementos

[Adicionar] ou [Remover] Caminho(s) para pesquisar bibliotecas de complementos C++ adicionais

Menu Fonte de Dados

Atributos dos elementos e tabela

  • checkbox Abre a tabela de atributos na janela principal (Necessário reiniciar o QGIS)

  • checkbox Copiar geometria na representação WKT da tabela de atributos. Ao utilizar mActionCopySelected copiar linhas selecionadas para área de transferência do diálogo :guilabel: tabela de Atributo, isso tem como resultado que as coordenadas dos pontos ou vértices também são copiados para a área de transferência.

  • Comportamento da tabela de atributos selectstring. Existem três possibilidades: ‘Mostrar todos os elementos’, ‘Mostrar elementos selecionados’ e ‘Mostrar elementos visíveis no mapa’.

  • Cache da linha da Tabela de atributos selectnumber. Esse cache de linha, torna possível para salvar as últimas linhas de atributos N carregadas, de modo que o trabalho com a tabela de atributos seja mais rápido. O cache será excluído ao fechar a tabela de atributos.

  • Representação para valores NULL. Aqui, pode definir um valor para os campos de dados que contêm valores NULL.

Manipulação das fontes de dados

  • Pesquisar por atributos válidos na janela do navegador selectstring. Pode escolher entre ‘Verificar extensão’ e ‘Verificar conteúdo do arquivo’.

  • Pesquisar por conteúdo de arquivos compatados (.zip) na janela do navegador selectstring. ‘Não’, ‘Verificação básica’ e ‘Verificação completa’ são possíveis.

  • Solicitar subcamadas raster ao abrir. Alguns rasters suportam subcamadas — elas são chamadas de subdatasets no GDAL. Um exemplo são os arquivos netCDF — se há muitas variáveis ​​netCDF, GDAL verá cada variável como um subdataset. A opção permite que você controle como lidar com subcamadas quando um arquivo é aberto com subcamadas. Você tem as seguintes opções:

    • ‘Sempre’: Perguntar sempre (se existem subcamadas)

    • ‘Se necessário’: Perguntar se a camada não tem bandas, mas tem subcamadas

    • ‘Nunca’: Nunca pede, não irá carregar nada

    • ‘Carregar tudo’: Nunca pede, mas carrega todas as subcamadas

  • checkbox Ignora a declaração de codificação do shapefile. Se o shapefile tiver informação de codificação, este será ignorado pelo QGIS.

  • checkbox Adicionar uma camada PostGIS com duplo clique e selecione em modo extendido

  • checkbox Adicione camadas Oracle com duplo clique e selecione em modo extendido

Menu de Renderização

Comportamento da renderização

  • checkbox Por padrão novas camadas adicionadas ao mapa devem ser exibidas

  • checkbox Enable back buffer
  • checkbox Use tornar cache sempre que possível para acelerar redesenhos

  • checkbox Ativar simplificação de camadas por padrão para camadas recém adicionas

  • checkbox Simplifique no provedor ao lado se possível

Qualidade de renderização

  • checkbox Faz com que as linhas apareçam menos irregulares, em detrimento de algum desempenho do desenho

  • checkbox Fix problems with incorrectly filled polygons

Matriciais

  • Com a Seleção de banda RGB pode definir o número para a banda Vermelha, Verde e Azul.

Contrast enhancement

  • Banda cinza única selectstring. Uma banda cinza única pode ter ‘Sem estender’, ‘Estender para MinMax’, ‘Estender e Cortar para MinMax’ e também ‘Cortar para MinMax’.

  • Cor de Multi banda (byte/banda) selectstring. As opções são ‘Não estender’, ‘Estender para MinMax’, ‘Estender e cortar para MinMax’ e ‘Cortar para MinMax’.

  • Cor de Multi banda (>byte/banda) selectstring. As opções são ‘Não estender’, ‘Estender para MinMax’, ‘Estender e cortar para MinMax’ e ‘Cortar para MinMax’.

  • Limites (mínimo/máximo) selectstring. As opções são ‘Corte de contagem de pixel cumulativa’, ‘Mínimo/Máximo’, ‘Média +/- desvio padrão’.

  • Limites de contagem cumulativa de pixeis de corte

  • Multiplicador do desvio-padrão

Corrigindo Erros

  • checkbox Atualiza o mapa da tela

Menu de Janela e Legenda

Aparência padrão do mapa (reescrita pelas propriedades do projeto)

  • Define a Cor da seleção e a Cor de fundo.

Legenda da camada

  • Duplo clique na legenda selectstring. Pode ‘Abrir propriedades da camada’ ou ‘Abrir tabela de atributos’ com duplo clique.

  • As seguintes Estilos de itens de legenda são possíveis:

    • checkbox Tornar maiúsculo os nomes da camada

    • checkbox Tornar negrito os nomes da camada

    • checkbox Tornar negrito os nomes dos grupos

    • checkbox Mostrar nomes de atributos de classificação

    • checkbox Criar ícones matriciais (pode ser lento)

    • checkbox Adicionar novas camadas ao grupo atual ou selecionado

Menu Ferramentas de Mapa

Identify

  • checkbox Open identify results in a dock window (QGIS restart required)
  • The Mode setting determines which layers will be shown by the Identify tool. By switching to ‘Top down’ or ‘Top down, stop at first’ instead of ‘Current layer’, attributes for all identifiable layers will be shown with the Identify tool. In QGIS 2.2. you can now use a ‘Layer selection’ option so that you can choose with the left-mouse menu which layer you want to identify (see the “Project properties” section under Projetos to set which layers are identifiable).
  • checkbox Open feature form, if a single feature is identified
  • Define Search radius for identifying and displaying map tips as a percentage of the map width

Ferramenta de medida

  • Define Cor do elástico para as ferramentas de medida

  • Define Casas decimais

  • checkbox Manter unidade base

  • Unidades de medição preferidas radiobuttonon (‘Metros’, ‘Pés’, ‘Milhas Nauticas’ ou ‘Graus’)`

  • Unidades de ângulo preferida radiobuttonon (‘Graus’, ‘Radianos’ ou ‘Grados’)

Movendo e ampliando

  • Define a Ação da roda do rato selectstring (‘Visualizar’, ‘Visualizar e Centrar’, ‘Aproximar ao cursor do rato’, ‘Nada’)

  • Define o factor de aproximação/ afastamento para a roda do mouse

Escalas pré-definidas

Aqui, você encontrará uma lista de escalas pré-definidas. Com os botões [+] e [-] que você pode adicionar ou remover suas escalas individuais.

Menu do Compositor

Composição padrão

Você pode definir a fonte Padrão aqui.

Aparência da Gride

  • Define o Estilo do Gride selectstring (‘Sólido’, ‘Pontos’, ‘Cruzamentos’)

  • Define a Cor...

Gride padrão

  • Define o Espaçamento selectnumber

  • Define o Espaçamento do Gride selectnumber para x e y

  • Define o Tolerância de Atração selectnumber

Guia padrão

  • Define o Tolerância de Atração selectnumber

Menu Digitalizar

Criação de elementos

  • checkbox Suprimir atributos de janelas pop-up depois de cada elemento criado

  • checkbox Reutilizar últimos valores de atributos inseridos

  • Validar geometrias. Edição de linhas complexas e polígonos com muitos nós pode resultar em edição muito lenta. Isso ocorre porque os procedimentos de validação padrão no QGIS pode levar bastante tempo. Para acelerar o processamento, é possível selecionar a validação de geometria GEOS (a partir de GEOS 3.3) ou desligá-la. Validação geometria GEOS é muito mais rápida, mas a desvantagem é que apenas o primeiro problema de geometria será relatado.

Elástico

  • Define a Borracha Espessura da linha e Cor da linha

Ajuste

  • checkbox Abrir opções de atração na janela principal (necessário reiniciar o QGIS)

  • Define o Modo de atração padrão selectstring (‘Ao vértice’, ‘Ao segmento’, ‘Ao vértice e segmento’, ‘Desligado’)

  • Define Tolerância de atração pré-definida em unidades de mapa ou pixeis

  • Define o Raio de pesquisa para editar vértices em unidades de mapa ou pixeis

Marcadores de Vértices

  • checkbox Mostrar marcadores apenas para elementos selecionados

  • Define o vértice do Estilo do Marcador selectstring (‘Cruz’ (padrão), ‘Circulo semi-transparente’ ou ‘Nenhum’)

  • Definir o vértice Tamanho do Marcador

Ferramenta de curva de afastamento

A 3 opções seguintes referem a ferramentas mActionOffsetCurve Curva Offset no Digitalização Avançada. Através das várias configurações, é possível influenciar a forma da linha de deslocamento. Estas opções são possíveis a partir de GEOS 3.3.

  • Juntar estilo

  • Quadrante do Segmento

  • Limite quadrante

Menu GDAL

GDAL é uma biblioteca de troca de dados para arquivos raster. Neste guia, você pode Edite criar opções e: guilabel: Editar Opções Pirâmides dos formatos raster. Definir que drive GDAL está sendo utilizado para um formato raster, como em alguns casos, mais do que um drive GDAL está disponível.

Menu SRC

SRC padrão para novos projetos

  • radiobuttonoff Não permitir reprojeção ‘on the fly’

  • radiobuttonon Habilitar automaticamente a reprojeção ‘on the fly’ se a camada tiver SRC diferente

  • radiobuttonoff Habilitar reprojeção ‘on the fly’ por padrão

  • Selecione um SRC em Iniciar sempre um novo projeto com este SRC

SRC para novas camadas

Esta área permite que você defina a ação a ser tomada quando uma nova camada é criada, ou quando uma camada sem SRC é carregada.

  • radiobuttonon Pergunta por SRC

  • radiobuttonoff Usar SRC do projeto

  • radiobuttonoff Utilizar SRC padrão mostrado em baixo

Transformação de datum padrão

  • checkbox Pergunte pela transformação do datum quando nenhum padrão for definido

  • Se você trabalhou com a transformação SRC ‘on-the-fly’ você pode ver o resultado da transformação na janela abaixo. Você pode encontrar informações sobre ‘Fonte da SRC’ e ‘Destino do SRC’, bem como ‘Transformação de Datum Fonte’ e ‘Transformação de Datum de Destino’.

Menu local

  • checkbox Sobrepor idioma do sistema e Idioma a utilizar em alternativa

  • Informação sobre a região do sistema ativo local

Menu rede

Geral

  • Define Pesquisa de endereço WMS, padrão como http://geopole.org/wms/search?search=\%1\&type=rss

  • Define Tempo esgotado para pedidos de rede (ms) - o padrão é 60000

  • Define Período padrão de validade para a quadrícula WMSC/WMTS (horas) - o padrão é 24

  • Define Máxima repetição no caso de erros na requisição de mosaico

  • Define Usuário-Agente

Figure Network Tab:

../../../_images/proxy-settings.png

Configurações-proxy no QGIS

Configurações de cache

Define a Pasta e Tamanho para o cache.

  • checkbox Usar proxy para acessar à web e define ‘Máquina’, ‘Porta’, ‘Usuário’, e ‘Palavra-chave’.

  • Configura o Tipo de proxy selectstring de acordo com as necessidades.

    • Default Proxy: Proxy é determinado baseando-se na definição do proxy da aplicação em uso

    • Socks5Proxy: Proxy genérico para qualquer tipo de ligação. Suporta TCP, UDP, unindo a uma porta (ligações de entrada) e autenticação.

    • HttpProxy: Implementado usando o comando “LIGAR” , apenas suporta ligações TCP de saída; suporta autenticação.

    • HttpCachingProxy: Implementado usando comandos HTTP normais, é útil apenas em pedidos no contexto do HTTP.

    • FtpCachingProxy: Implementado usando um proxy FTP, é útil no contexto de pedidos FTP.

Alguns URLs excluídos podem ser adicionados na caixa de texto debaixo das configurações de proxy (veja Figure_Network_Tab).

Se você precisar de informações mais detalhadas sobre as diferentes configurações de proxy, consulte o manual da documentação da biblioteca QT subjacente a http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Dica

Usando Proxies

Usando proxies, por vezes, pode ser complicado. É útil proceder por “tentativa e erro”, com os tipos de proxy acima, verifique para ver se eles conseguem no seu caso.

Pode modificar as opções de acordo com as suas necessidades. Algumas das alterações pode requerer o reinicio do QGIS antes de ser efetiva.

  • nix Settings are saved in a text file: $HOME/.config/QGIS/qgis.conf
  • osx pode encontrar as configurações em: $HOME/Library/Preferences/org.qgis.qgis.plist

  • As configurações win são armazenadas no registo em: HKEY\CURRENT_USER\Software\QGIS\qgis

Personalização

A ferramenta de personalização permite que (des)ative a maioria dos elementos na interface de utilizador QGIS. Isto pode ser muito útil se tiver um número elevado de módulos instalados que nunca usa e que estão preenchendo o ecrã.

Figure Customization 1:

../../../_images/customization.png

A janela de Personalização nix

QGIS A Personalização está dividida em cinco grupos. No checkbox Menus pode esconder as entradas na Barra Menu. No checkbox Painel pode encontrar o painel de janelas. As janelas do Painel são aplicações que pode ser iniciadas e usadas como flutuantes, janelas de topo de nível ou contidas na janela principal do QGIS como um widget ancorado (veja also Painéis e Barras de Ferramentas). Na checkbox Barra de Estado características como a informação das coordenadas podem ser desativadas. Na checkbox Caixa de Ferramentas pode (des)ativar os ícones da barra de ferramentas do QGIS e em checkbox Widgets pode (des)ativar janelas assim como os seus botões.

Com mActionSelect Mudar para pegar widgets na aplicação principal, você pode clicar em elementos QGIS que deseja ser escondida e localize a entrada correspondente na personalização (ver figura_customization). Você também pode salvar suas várias configurações também para diferentes casos de uso. Antes das alterações serem aplicadas, você precisa reiniciar QGIS.