Outdated version of the documentation. Find the latest one here.

10.2. Lesson: 유용한 QGIS 플러그인

이제 플러그인을 설치하고 활성화/비활성화할 수 있게 됐으니, 몇몇 유용한 플러그인의 예제를 통해 어떻게 활용할 수 있는지 배워보겠습니다.

이 강의의 목표: 플러그인 인터페이스에 익숙해지고 몇몇 유용한 플러그인에 대해 배우기.

10.2.1. basic Follow Along: 래스터 지형 분석 플러그인

  • srtm_41_19.tif 래스터 데이터셋만 있는 새 맵을 시작하십시오. (exercise_data/raster/SRTM 경로에서 찾을 수 있습니다.)

래스터 분석에 대한 강의에서 이미 래스터 분석 기능에 대해 배웠습니다. (Raster ‣ Analysis 메뉴를 통해) GDAL 도구를 사용했죠. 하지만 래스터 지형 분석 플러그인도 알아둬야 합니다. QGIS 신규 버전에는 표준으로 내장되어 있기 때문에, 사용자가 개별적으로 설치할 필요도 없습니다.

  • Plugin Manager 를 열고, 다음과 같이 래스터 지형 분석 플러그인이 활성화돼 있는지 확인하십시오.

    ../../../_images/raster_terrain_enabled.png
  • Raster 메뉴를 클릭하십시오. Terrain analysis 서브메뉴를 볼 수 있을 겁니다.

  • Terrain analysis ‣ Relief 를 선택한 다음, 다음 옵션들을 입력하십시오.

    ../../../_images/terrain_analysis_dialog.png
  • 새 파일의 경로 및 파일명을 exercise_data/plugins/relief.tif 로 지정하십시오. (필요한 경우 새 폴더를 생성하십시오.)

  • Output formatZ factor 는 그대로 두십시오.

  • Add result to project 체크박스를 체크했는지 확인하십시오.

  • Create automatically 버튼을 클릭하십시오. 다음과 같은 목록이 나타날 것입니다.

    ../../../_images/terrain_analysis_list.png

    이 목록은 플러그인이 기복도를 생성하는 데 사용할 색상들입니다.

  • 원한다면 색상 막대의 각 행을 더블클릭해서 다음과 같이 색상을 변경할 수도 있습니다.

    ../../../_images/color_changes.png
  • OK 를 클릭하면 기복도가 생성됩니다.

    ../../../_images/relief_created.png

이 기능은 반투명한 음영기복도를 다른 래스터 레이어 위에 오버레이하는 것과 비슷한 효과를 냅니다. 이 플러그인의 장점은 단 하나의 레이어로 이 효과를 생성한다는 것입니다.

10.2.2. basic Follow Along: OpenLayers 플러그인

  • 새 맵을 시작한 다음 roads.shp 레이어를 추가하십시오.

  • Swellendam 지역으로 줌인하십시오.

  • Plugin Manager 에서 Filter 란에 OpenLayers 라고 입력해서 새 플러그인을 검색하십시오.

  • Select the OpenLayers Layers plugin from the filtered list:

    ../../../_images/select_openlayers.png
  • Install plugin 버튼을 클릭해서 설치합니다.

  • 설치가 끝나면 Plugin Manager 를 닫으십시오.

이 플러그인을 사용하기 전에, 사용자의 맵과 해당 플러그인이 제대로 설정되었는지 확인합니다.

  • Open the plugin’s settings by clicking on Plugins ‣ OpenLayers plugin ‣ OpenLayers Overview.

  • 패널에서 사용자가 원하는 맵 유형을 선택하십시오. 이 예제에서는 “혼합” 유형을 쓰겠지만, 사용자가 원하는 어떤 유형이든 선택할 수 있습니다.

    ../../../_images/hybrid_map_selected.png
  • 메뉴에서 Project ‣ Project Properties 를 선택해서 Project Properties 대화 창을 여십시오.

  • “실시간” 투영을 활성화하고 구글 메르카토르 투영체를 선택하십시오.

    ../../../_images/google_mercator_crs.png
  • 이제 플러그인을 써서 이 지역의 구글 지도를 불러와보겠습니다. 구글 지도를 추가하려면 메뉴에서 Plugins ‣ OpenLayers Plugin ‣ Add Google Hybrid Layer 항목을 클릭하면 됩니다.

    ../../../_images/add_google_hybrid.png

이렇게 하면 구글에서 새 래스터 이미지를 불러오는데, 배경으로 사용할 수도, 현재 맵 상의 위치가 어디인지 알아내는 데 사용할 수도 있습니다. 다음은 구글 지도 위에 우리가 사용한 벡터 도로 레이어를 오버레이한 화면입니다.

../../../_images/google_hybrid_result.png

주석

여러분의 도로 레이어를 구글 레이어 위로 드래그해서 배경 레이어 위에 도로 레이어가 보이도록 해야 할 수도 있습니다. 맵을 다시 정렬하기 위해 도로 레이어의 범위로 확대/축소해야 할 수도 있습니다.

10.2.3. moderate Follow Along: GeoSearch 플러그인

  • 아무 데이터셋도 없는 새 맵을 시작하십시오.

  • Plugin Manager 를 열고, GeoSearch 플러그인을 검색한 다음 Install Plugin 을 클릭해서 설치하십시오.

    ../../../_images/find_geosearch_plugin.png
  • Plugin Manager 를 닫습니다.

  • 이제 GeoSearch 플러그인을 통해 지명을 검색할 수 있습니다. Plugins ‣ GeoSearch Plugin ‣ GeoSearch 메뉴를 클릭해서 GeoSearch 대화 창을 여십시오.

    ../../../_images/geosearch_menu.png
  • GeoSearch 대화 창에서 Swellendam 을 검색해서 사용자 맵 상 어디에 위치하는지 찾아보십시오.

    ../../../_images/city_search.png

10.2.4. In Conclusion

QGIS에서 사용할 수 있는 유용한 플러그인들이 많이 있습니다. 이 플러그인들을 설치하고 관리하기 위한 내장 도구를 사용하면, 새 플러그인을 찾아 최대한 활용할 수 있습니다.

10.2.5. What’s Next?

다음으로 원격 서버에 존재하는 레이어를 실시간으로 이용하는 방법을 배워보겠습니다.