Outdated version of the documentation. Find the latest one here.

14.6. Lesson: Gedetailleerde kaarten maken met het gereedschap Atlas

Het systematisch ontwerp voor het nemen van monsters is gereed en de teams in het veld hebben de GPS-coördinaten in hun navigatieapparaten geladen. Zij hebben ook een formulier met veldgegevens waarop zij de informatie zullen verzamelen die zij hebben gemeten op elke monsterplaats. Zij hebben een aantal gedetailleerde kaarten gevraagd waarop enige informatie over het terrein duidelijk zichtbaar is, tezamen met een kleinere subset van monsterplaatsen en enige informatie over het gebied van de kaart om eenvoudiger hun weg naar elke monsterplaats te vinden. U kunt het gereedschap Atlas gebruiken om automatisch een aantal kaarten in een gelijke indeling te generen.

Het doel voor deze les: Het gereedschap Atlas in QGIS leren gebruiken om gedetailleerde af te drukken kaarten te genereren om te helpen bij de inventarisatie in het veld.

14.6.1. basic Follow Along: De Printvormgeving voorbereiden

Vóór we de gedetailleerde kaarten van het bosgebied en onze monsterplaatsen kunnen automatiseren, moeten we een kaartsjabloon maken met alle elementen die we nuttig achten voor het werk in het veld. Natuurlijk is het meest belangrijke dat het goed opgemaakt is, maar, zoals u al eerder heeft gezien, u zult ook heel veel andere elementen moeten toevoegen die de afgedrukte kaart completeren.

Open het project forest_inventory.qgs van QGIS vanuit de vorige les. U zou ten minste de volgende lagen moeten hebben:

  • forest_stands_2012 (met een transparantie van 50%, groene vulling en donkergroene lijnen als rand).

  • systematic_plots_clip.
  • rautjarvi_aerial.

Sla het project op onder de nieuwe naam map_creation.qgs.

Onthoud dat u de Printvormgeving-manager: gebruikt om een kaart te maken die kan worden afgedrukt,

  • Open Project ‣ Printvormgeving-manager....

  • In het dialoogvenster Printvormgeving-manager.

  • Klik op de knop Toevoegen en noem uw compositie forest_map.

  • Klik op OK.

  • Klik op de knop Tonen.

Stel de printeropties zo in dat uw kaarten en marges op uw papier passen, voor een A4-tje:

  • Open menuselection:Printvormgeving –> Pagina-instellingen.

  • Grootte is A4 (217 x 297 mm).

  • Oriëntatie is Landschap.

  • Marges (millimeters) worden allemaal ingesteld op 5.

Ga, in het venster Printvormgeving, naar de tab Lay-out (in het paneel rechts) en zorg er voor dat deze instellingen voor Papier en kwaliteit hetzelfde zijn als die welke u definieerde voor de printer:

  • Voorinstellingen: A4 (210x297mm).

  • Oriëntatie: Liggend.

  • Export resolutie: 300dpi.

Het maken van een kaart gaat eenvoudiger als u gebruikt maakt van het kaartraster om de verschillende elementen te plaatsen. Bekijk de instellingen voor het raster van Printvormgeving:

  • Vergroot, op de tab Lay-out, het gebied Hulplijnen en raster.

  • Controleer of Rasterafstand is ingesteld op 10 mm.

  • En dat Tolerantie voor ‘snappen’ is ingesteld op 2 mm.

U dient het gebruiken van het raster te activeren:

  • Open het menu Beeld.

  • Klik op Grid tonen.

  • Selecteer Aan grid snappen.

  • Merk op dat de opties voor het gebruiken van hulplijnen standaard zijn geselecteerd, wat u in staat stelt rode hulplijnen te zien wanneer u elementen in de printvormgeving verplaatst.

Nu kunt u beginnen met het toevoegen van elementen aan aan kaartvenster. Voeg eerst een kaartelement toe zodat u kunt bekijken hoe het er uitziet als u wijzigingen in de symbologie van de kaart maakt:

  • Klik op de knop Nieuwe kaart toevoegen: addMap.

  • Klik en sleep een rechthoek op het kaartvenster zodat de kaart het grootste deel daarvan bedekt.

../../../_images/composer_1.png

Merk op hoe de muiscursor snapt aan het kaartraster. Gebruik deze functie als u andere elementen toevoegt. Als u nauwkeuriger wilt werken, wijzig dan de instelling Rasterafstand voor het raster. Als u om enige reden niet op een bepaald punt niet zou willen snappen aan het raster, kunt u het altijd in- of uitschakelen in het menu Beeld.

14.6.2. basic Follow Along: Een achtergrondkaart toevoegen

Laat de printvormgeving open maar ga terug naar de kaart. Laten we enige achtergrondgegevens toevoegen en enige opmaak maken zodat de inhoud van de kaart zo duidelijk als maar mogelijk is.

  • Voeg het raster voor de achtergrond basic_map.tif toe dat u kunt vinden in de map exercise_data\forestry\.

  • Selecteer het CRS ETRS89 / ETRS-TM35FIN CRS voor het raster als daarnaar gevraagd wordt.

Zoals u kunt zien is de kaart voor de achtergrond al opgemaakt. Dit type direct te gebruiken cartografie-raster is vrij algemeen. Het wordt gemaakt vanuit vectorgegevens, opgemaakt in een standaard indeling en opgeslagen als een raster zodat u zich niet bezig hoeft te houden met het opmaken van verscheidene vectorlagen en u geen zorgen hoeft te maken of u wel een goed resultaat krijgt.

  • Zoom nu in op uw monsterplaatsen, zodat u alleen nog vier of vijf lijnen met monsterplaatsen ziet.

De huidige opmaak van de monsterplaatsen is niet al te best, maar hoe ziet het er in de printvormgeving uit?:

../../../_images/plots_zoom1-2.png

Gedurende de laatste oefeningen was de witte buffer boven op de luchtfoto OK, maar nu dat de achtergrondafbeelding meest wit is kunt u de labels nog nauwelijks zien. U kunt ook controleren hoe het eruit ziet in de printvormgeving:

  • Ga naar het venster Printvormgeving.

  • Gebruik de knop select om het kaartelement te selecteren in de Printvormgeving.

  • Ga naar de tab Item-eigenschappen.

  • Klik, onder Bereik, op Toon bereik in kaartvenster.

  • Klik onder Algemene eigenschappen op de knop Voorvertoning bijwerken als u het element moet vernieuwen.

Dit is duidelijk niet voldoende, u wilt de nummers van de monsterplaatsen zo zichtbaar mogelijk maken voor de teams in het veld.

14.6.3. basic Try Yourself De symbologie van de lagen wijzigen

In Module: Een basiskaart maken is gewerkt met symbologie en in Module: Vectorgegevens classificeren met labels. Het is aan te raden deze delen van de handleiding nog even door te lezen. Doel is om locaties en namen van monsterplaatsen zichtbaar te maken op een manier waarbij de ondergrond ook zichtbaar blijft. Onderstaande afbeelding geeft een mogelijk resultaat:

../../../_images/plots_zoom2_symbology.png

U zult later de groene opmaak van de laag forest_stands_2012 gebruiken. Om die te behouden en een visualisatie er van te hebben die alleen de randen van de bosopstanden weergeeft:

  • Klik met rechts op forest_stands_2012 en selecteer Dupliceren

  • U krijgt een nieuwe laag, genaamd forest_stands_2012 kopiëren, die u kunt gebruiken om een andere stijl te definiëren, bijvoorbeeld zonder vulling en met rode randen.

Nu heeft u twee verschillende visualisaties van de bosopstanden en kunt u beslissen welke weer te geven voor uw detailkaart.

Ga vaak terug naar het venster Printvormgeving om te zien hoe de kaart er uit zou komen te zien. Voor het doel gedetailleerde kaarten te maken, zoekt u naar een symbologie die er niet goed uitziet op de schaal van het gehele bosgebied (linker afbeelding hieronder) maar op een kleinere schaal (rechter afbeelding hieronder). Vergeet niet Voorvertoning bijwerken en Aanpassen aan kaartformaat te gebruiken wanneer u de zoomfactor wijzigt in uw kaart of de printvormgeving.

../../../_images/composer_2-3.png

14.6.4. basic Try Yourself Een sjabloon voor een basiskaart maken

Als u eenmaal een symbologie heeft die u bevalt, bent u klaar om meer informatie aan uw af te drukken kaart toe te voegen. Voeg ten minste de volgende elementen toe:

  • Titel.

  • Een schaalbalk.

  • Een raster voor uw kaart.

  • Coördinaten aan de zijkanten van het raster.

U heeft een soortgelijke lay-out al gemaakt in composition already in Module: Kaarten maken. Ga terug naar die module als dat nodig is. U kunt deze voorbeeldafbeelding als verwijzing gebruiken:

../../../_images/map_template1.png

Exporteer uw kaart als een afbeelding en bekijk hem.

  • Printvormgeving ‣ Als afbeelding exporteren.

  • Gebruik de JPG format voor het voorbeeld.

Dat is hoe het er uit zal zien na het afdrukken.

14.6.5. basic Follow Along: Meer elementen aan de printvormgeving toevoegen

Zoals u waarschijnlijk al is opgevallen in de voorgestelde voorbeelden voor afbeeldingen van sjablonen, is er ruim voldoende ruimte aan de rechterzijde van het kaartvenster. Laten we eens zien wat daar nog meer zou kunnen worden geplaatst. Voor het doel van onze kaart is een legenda niet echt nodig, maar een overzichtskaart en enkele tekstvakken zouden waarde aan de kaart kunnen toevoegen.

Een overzichtskaart zou de teams in het veld helpen de gedetailleerde kaart binnen het algehele bosgebied te plaatsen:

  • Voeg een ander kaartelement toe aan het kaartvenster, rechts onder de tekst voor de titel.

  • Open, op de tab Item-eigenschappen, de keuzelijst Overzichtskaarten.

  • Stel het Kaartframe in op Kaart 0. Dit maakt een geschaduwde rechthoek over de kleinere kaart die het bereik weergeeft dat zichtbaar is in de grotere kaart.

  • Selecteer ook de optie Frame met een zwarte kleur en een Dikte van 0.30.

../../../_images/more_elements1.png

Merk op dat uw overzichtskaart niet echt een overzicht geeft van het gehele bosgebied, wat is wat u wilt. U wilt dat deze kaart het gehele bosgebied weergeeft en u wilt dat het alleen de achtergrondkaart en de laag forest_stands_2012 weergeeft, en niet de monsterplaatsen. Ook wilt u dat zijn weergave wordt vergrendeld zodat die niet meer wijzigt wanneer u de zichtbaarheid of volgorde van de lagen wijzigt.

  • Ga terug naar de kaart, maar sluit de Printvormgeving niet.

  • Klik met rechts op de laag forest_stands_2012 en klik op Op kaartlaag inzoomen.

  • Deactiveer alle lagen met uitzondering van basic_map en forest_stands_2012.

  • Ga terug naar de Printvormgeving.

  • Klik, met de kleine kaart geselecteerd, op Aanpassen aan kaartformaat om zijn bereik in te stellen op wat u ziet in het kaartvenster.

  • Vergrendel de weergave voor de overzichtskaart door te selecteren Lagen vastzetten voor kaartonderdeel onder Algemene eigenschappen.

Nu is uw overzichtskaart meer zoals u verwachtte en de weergave ervan zal niet meer wijzigen. Maar, natuurlijk, nu geeft uw gedetailleerde kaart de randen van de bosopstanden niet meer weer, noch de monsterplaatsen. Laten we dat repareren:

  • Ga opnieuw naar het kaartvenster en selecteer de lagen die zichtbaar moeten zijn (systematic_plots_clip, forest_stands_2012 kopiëren en Basic_map).

  • Zoom opnieuw in zodat slechts een paar lijnen met monsterplaatsen zichtbaar zijn.

  • Ga terug naar het venster Printvormgeving.

  • Selecteer de grotere kaart in uw Printvormgeving (select).

  • Klik, in Item-eigenschappen op Voorvertoning bijwerken en Aanpassen aan kaartformaat.

Merk op dat alleen de grotere kaart de huidige kaartweergave toont, en dat de kleinere overzichtskaart dezelfde weergave heeft als toen u die vergrendelde.

Merk ook op dat de overzichtskaart een geschaduwd frame weergeeft voor het bereik dat wordt weergegeven in de detailkaart.

../../../_images/more_elements2.png

Uw sjabloon voor de kaart is bijna voltooid. Voeg nu twee tekstvakken onder de kaart toe, één met de tekst ‘Gedetailleerde kaart zone: ‘ en de andere met ‘Opmerking: ‘. Plaats ze zoals u kunt zien in bovenstaande afbeelding.

U kunt ook een Noordpijl toevoegen aan de overzichtskaart:

  • Gebruik het gereedschap Afbeelding toevoegen, addImage.

  • Klik in de rechter bovenhoek van de overzichtskaart.

  • Open, in Item-eigenschappen, Mappen doorzoeken en blader naar een afbeelding van een pijl.

  • Selecteer, onder Rotatie afbeelding, Met kaart synchroniseren en selecteer Kaart 1 (de overzichtskaart).

  • Deselecteer Achtergrond.

  • Wijzig de grootte van de afbeelding van de pijl zodat die er goed uitziet op een kleine kaart.

De lay-out voor de basiskaart is nu gereed, nu wilt u gebruikmaken van het gereedschap Atlas om zoveel gedetailleerde kaarten in deze indeling te generen als u nodig vindt.

14.6.6. basic Follow Along: Een Atlas-bedekking genereren

De Atlas dekking is slechts een vectorlaag die zal worden gebruikt om de gedetailleerde kaarten te genereren, één kaart voor elk object in de dekking. Hier is een volledige set van gedetailleerde kaarten voor het bosgebied om een idee te krijgen van wat vervolgens zal worden gedaan.

../../../_images/preview_atlas_results.png

De bedekking zou elke bestaande laag kunnen zijn, maar gewoonlijk is het verstandiger er een te maken voor dit specifieke doel. Laten we een raster van polygonen maken die het bosgebied bedekken:

  • Open, in de kaartweergave van QGIS, Vector ‣ Onderzoeks-gereedschap ‣ Vectorgrid.

  • Stel het gereedschap in zoals in deze afbeelding:

../../../_images/coverage_polygons.png
  • Sla de uitvoer op als atlas_coverage.shp.

  • Maak de nieuwe laag atlas_coverage zo op dat de polygonen geen vulling hebben.

De nieuwe vlakken bedekken het hele gebied van het bos en geven een indruk van wat elke kaart (gemaakt van individuele vlakken) bevat.

../../../_images/atlas_coverage.png

14.6.7. basic Follow Along: Het gereedschap Atlas instellen

De laatste stap is om het gereedschap Atlas in te stellen:

  • Ga terug naar de Printvormgeving.

  • Ga, in het paneel rechts, naar de tab Atlas-generatie.

  • Stel de opties als volgt in:

../../../_images/atlas_settings.png

Dat vertelt het gereedschap Atlas om de objecten (polygonen) binnen atlas_coverage te gebruiken als de focus voor elke gedetailleerde kaart. Het zal één kaart uitvoeren voor elk object in de laag. De Verborgen bedekkingslaag vertelt de Atlas om de polygonen niet weer te geven op de uitgevoerde kaarten.

Er moet nog één ding worden gedaan. U moet het gereedschap Atlas vertellen welk kaartelement moet worden bijgewerkt voor elke uitgevoerde kaart. U kunt nu waarschijnlijk wel raden dat het kaartonderdeel dat voor elke kaart moet worden bijgewerkt dat is welk u heeft voorbereid om detailweergaven te bevatten van de monsterplaatsen, dat is het grotere kaartelement in uw kaartvenster:

  • Selecteer het grotere kaartelement.

  • Ga naar de tab Item-eigenschappen.

  • Selecteer in de lijst Beheerd door Atlas.

  • En stel Marge rond object in op 10%. Het bereik voor de weergave zal 10% groter zijn dan de polygonen, wat betekent dat uw gedetailleerde kaarten elkaar 10% overlappen.

../../../_images/controlled_by_atlas.png

Nu kunt u het gereedschap Voorvertoning voor Atlas-kaarten gebruiken om te zien hoe uw kaarten eruit zullen komen te zien:

  • Activeer de voorbeelden van Atlas met behulp van de knop atlas of, als uw werkbalk Atlas niet zichtbaar is, via Atlas ‣ Voorbeeld Atlas.

  • U kunt de pijlen in de werkbalk Atlas gebruiken of die in het menu Atlas om door de te maken kaarten te verplaatsen.

Merk op dat sommige ervan niet interessant zijn. Laten we daar iets aan doen en enkele bomen sparen door die onbruikbare kaarten niet af te drukken.

14.6.8. basic Follow Along: De bedekkingslaag bewerken

Naast het verwijderen van de polygonen voor die gebieden die niet interessant zijn, kunt u ook de tekstlabels in uw te generen kaart aanpassen met inhoud uit de Attributentabel van uw bedekkingslaag:

  • Ga terug naar de kaartweergave.

  • Schakel Bewerken in voor de laag atlas_coverage.

  • Selecteer de polygonen die zijn geselecteerd (in geel) in onderstaande afbeelding.

  • Verwijder de geselecteerde polygonen.

  • Schakel Bewerken uit en sla de wijzigingen op.

../../../_images/remove_polygons.png

U kunt nu terug gaan naar de Printvormgeving en controleren of de voorbeelden van Atlas alleen de polygonen gebruiken die zijn overgebleven op de laag.

De bedekkingslaag die u gebruikt heeft nog geen bruikbare informatie die u zou kunnen gebruiken om de inhoud van de labels op uw kaart aan te passen. De eerste stap is om ze te maken, u kunt bijvoorbeeld een code voor de zone toevoegen voor de gebieden van de polygonen en een veld met enkele opmerkingen voor de teams in het veld om rekening mee te houden:

  • Open de Attributentabel voor de laag atlas_coverage.

  • Schakel Bewerken in.

  • Gebruik de calculateField veldberekening om de volgende twee velden te maken en in te vullen.

  • Maak een veld genaamd Zone en typ Geheel getal (integer).

  • In het vak Expressie schrijf/kopieer/construeer $rownum.

  • Maak een ander veld, genaamd Opmerking:,van het type Tekst (string) en een breedte van 255.

  • Schrijf, in het vak Expressie, 'Geen opmerkingen.'. Dat zal de standaard waarde instellen voor alle polygonen.

De beheerder van het bos zal enige informatie hebben over het gebied die bruikbaar is bij het bezoeken van het gebied.Bijvoorbeeld de aanwezigheid van een brug, een moeras of de locatie van een beschermde soort. De laag atlas_coverage staat waarschijnlijk nog steeds in de modus Bewerken, voeg de volgende tekst toe in het veld Opmerking voor de overeenkomende polygonen (dubbelklik op de cel om die te bewerken):

  • Voor de Zone 2: Brug ten noorden van monsterplaats 19. Gewone vliegende eekhoorn tussen p_13 en p_14..

  • Voor de Zone 6: Moeilijk te verplaatsen in het moeras ten noorden van het meer..

  • Voor de Zone 7: Gewone vliegende eekhoorn ten zuiden van p_94..

  • Schakel Bewerken uit en sla uw wijzigingen op.

Bijna klaar. Nu moet u het gereedschap Atlas vertellen dat u wilt dat enkele tekstlabels de informatie uit de attributentabel van de laag atlas_coverage gebruiken.

  • Ga terug naar de Printvormgeving.

  • Selecteer het tekstlabel dat Gedetailleerde kaart... bevat.

  • Stel de grootte van Lettertype in op 12.

  • Zet de cursor aan het einde van de tekst in het label.

  • Klik op Voeg een expressie in op de tab Item-eigenschappen, in de Algemene eigenschappen .

  • Dubbelklik, in de Functielijst, op het veld Zone onder Velden en waarden.

  • Klik op OK.

  • De tekst in het vak in de Item-eigenschappen zou nu Gedetailleerde kaart zone [% "Zone" %] moeten weergeven. Onthoud dat [% "Zone" %] zal worden vervangen door de waarde van het veld Zone voor het overeenkomende object uit de laag atlas_coverage.

Test de inhoud van het label door te kijken naar de verschillende voorbeelden van de kaarten in Atlas.

Doe hetzelfde voor de labels met de tekst Opmerking: door het veld met de informatie voor de zone te gebruiken. U kunt een regeleinde invoegen vóór u de expressie invoert. U kunt het resultaat voor het voorbeeld van zone 2 zien in de afbeelding hieronder:

../../../_images/preview_zone2.png

Gebruik de voorbeelden van Atlas om door alle kaarten te bladeren die u nu snel zult maken en geniet ervan!

14.6.9. basic Follow Along: De kaarten afdrukken

Als laatste maar niet het minste, afdrukken of exporteren van uw kaarten als afbeeldingen of PDF-bestanden. U kunt Atlas ‣ Atlas als afbeeldingen exporteren... of Atlas ‣ Atlas als PDF exporteren... gebruiken. Momenteel werkt het exporteren naar de indeling SVG nog niet goed en zal een slecht resultaat geven.

Laten we de kaarten als één enkele PDF exporteren die u naar het veldbureau kunt sturen om af te drukken:

  • Ga naar de tab Atlas-generatie in het paneel rechts.

  • Selecteer, onder Uitvoer, Exporteren naar enkel bestand indien mogelijk. Dit zal alle kaarten bij elkaar in één PDF stoppen, als deze optie niet wordt geselecteerd krijgt u één bestand voor elke kaart.

  • Open Printvormgeving ‣ Als PDF exporteren....

  • Sla het PDF-bestand op als inventory_2012_maps.pdf in uw map exercise_data\forestry\samplig\map_creation\.

Open het PDF-bestand om te controleren of alles is gegaan zoals verwacht.

U zou net zo makkelijk afzonderlijke afbeeldingen kunnen maken voor elke kaart (onthoud om het maken van één enkel bestand uit te schakelen), hier kunt u de miniaturen zien voor de afbeeldingen die gemaakt zullen worden:

../../../_images/maps_as_images.png

Sla, in de Printvormgeving, uw jaart op als een sjabloon voor printvormgeving als forestry_atlas.qpt in uw map exercise_data\forestry\map_creation\. Gebruik Printvormgeving ‣ Als sjabloon opslaan. U zult in staat zijn dit sjabloon steeds opnieuw te gebruiken.

Sluit de Printvormgeving en sla uw project van QGIS op.

14.6.10. In Conclusion

U bent erin geslaagd een sjabloonkaart te maken die kan worden gebruikt om automatisch gedetailleerde kaarten te genereren die in het veld kunnen worden gebruikt om naar de verschillende monsterplaatsen te navigeren. Zoals u heeft gemerkt was dit geen eenvoudige taak maar de voordelen worden duidelijk wanneer u soortgelijke kaarten moet maken voor andere regio’s en u het sjabloon kunt gebruiken dat u zojuist heeft gemaakt.

14.6.11. What’s Next?

In de volgende les zult u zien hoe u gegevens van LiDAR kunt gebruiken om een DEM te maken en die dan te gebruiken om de zichtbaarheid van uw gegevens en kaarten te vergroten.