Outdated version of the documentation. Find the latest one here.

General Tools

Keyboard shortcuts

QGIS provides default keyboard shortcuts for many features. You find them in Section Menu Bar. Additionally the menu option Settings ‣ Configure Shortcuts allows to change the default keyboard shortcuts and to add new keyboard shortcuts to QGIS features.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Define shortcut options nix (KDE)

Configuration is very simple. Just select a feature from the list and click on [Change], [Set none] or [Set default]. Once you have found your configuration, you can save it as XML file and load it to another QGIS installation.

Context help

When you need help on a specific topic, you can access context help via the Help button available in most dialogs - please note that third-party plugins can point to dedicated web pages.

Rendering

By default, QGIS renders all visible layers whenever the map canvas must be refreshed. The events that trigger a refresh of the map canvas include:

  • Adding a layer
  • Panning or zooming
  • Resizing the QGIS window
  • Changing the visibility of a layer or layers

QGIS allows you to control the rendering process in a number of ways.

Scale Dependent Rendering

Scale dependent rendering allows you to specify the minimum and maximum scales at which a layer will be visible. To set scale dependency rendering, open the Properties dialog by double-clicking on the layer in the legend. On the General tab, set the minimum and maximum scale values and then click on the checkboxUse scale dependent rendering checkbox.

You can determine the scale values by first zooming to the level you want to use and noting the scale value in the QGIS status bar.

Controlling Map Rendering

Map rendering can be controlled in the following ways:

Suspending Rendering

To suspend rendering, click the checkbox Render checkbox in the lower right corner of the statusbar. When the checkbox Render checkbox is not checked, QGIS does not redraw the canvas in response to any of the events described in Section Rendering. Examples of when you might want to suspend rendering include:

  • Add many layers and symbolize them prior to drawing
  • Add one or more large layers and set scale dependency before drawing
  • Add one or more large layers and zoom to a specific view before drawing
  • Any combination of the above

Checking the checkbox Render checkbox enables rendering and causes an immediate refresh of the map canvas.

Setting Layer Add Option

You can set an option to always load new layers without drawing them. This means the layer will be added to the map, but its visibility checkbox in the legend will be unchecked by default. To set this option, choose menu option Settings ‣ Options ‣ and click on the Rendering tab. Uncheck the checkbox By default new layers added to the map should be displayed checkbox. Any layer added to the map will be off (invisible) by default.

Stopping Rendering

To stop the map drawing, press the ESC key. This will halt the refresh of the map canvas and leave the map partially drawn. It may take a bit of time between pressing ESC and the time the map drawing is halted.

Muista

It is currently not possible to stop rendering - this was disabled in qt4 port because of User Interface (UI) problems and crashes.

Updating the Map Display During Rendering

You can set an option to update the map display as features are drawn. By default, QGIS does not display any features for a layer until the entire layer has been rendered. To update the display as features are read from the datastore, choose menu option Settings ‣ Options click on the Rendering tab. Set the feature count to an appropriate value to update the display during rendering. Setting a value of 0 disables update during drawing (this is the default). Setting a value too low will result in poor performance as the map canvas is continually updated during the reading of the features. A suggested value to start with is 500.

Influence Rendering Quality

To influence the rendering quality of the map you have 2 options. Choose menu option Settings ‣ Options click on the Rendering tab and select or deselect following checkboxes.

  • checkbox Make lines appear less jagged at the expense of some drawing performance
  • checkbox Fix problems with incorrectly filled polygons

Measuring

Measuring works within projected coordinate systems (e.g., UTM) and unprojected data. If the loaded map is defined with a geographic coordinate system (latitude/longitude), the results from line or area measurements will be incorrect. To fix this you need to set an appropriate map coordinate system (See Section Working with Projections). All measuring modules also use the snapping settings from the digitizing module. This is useful, if you want to measure along lines or areas in vector layers.

To select a measure tool click on mActionMeasure and select the tool you want to use.

Measure length, areas and angles

mActionMeasure QGIS is able to measure real distances between given points according to a defined ellipsoid. To configure this, choose menu option Settings ‣ Options, click on the Map tools tab and choose the appropriate ellipsoid. There you can also define a rubberband color and your preferred measurement units (meters or feet) and angle units (degrees, radians and gon). The tools then allows you to click points on the map. Each segment-length as well as the total shows up in the measure-window. To stop measuring click your right mouse button.

Figure Measure 1:

../../../_images/measure_line.png

Measure Distance nix (KDE)

mActionMeasureArea Areas can also be measured. In the measure window the accumulated area size appears. In addition, the measuring tool will snap to the currently selected layer, provided that layer has its snapping tolerance set. (See Section Setting the Snapping Tolerance and Search Radius). So if you want to measure exactly along a line feature, or around a polygon feature, first set its snapping tolerance, then select the layer. Now, when using the measuring tools, each mouse click (within the tolerance setting) will snap to that layer.

Figure Measure 2:

../../../_images/measure_area.png

Measure Area nix (KDE)

mActionMeasureAngle You can also measure angles, selecting Measure Angle tool. The cursor becomes cross-shaped. Click to draw the first segment of the angle you wish to measure, then move the the cursor to draw the desired angle. The measure is displayed in a popup dialog.

Figure Measure 3:

../../../_images/measure_angle.png

Measure Angle nix (KDE)

Select and deselect features

The QGIS toolbar provides several tools to select features in the map canvas. To select one or several features just click on mActionSelect and select your tool:

  • mActionSelect Select single feature
  • mActionSelectRectangle Select features by rectangle
  • mActionSelectPolygon Select features by polygon
  • mActionSelectFreehand Select features by freehand
  • mActionSelectRadius Select features by radius

To deselect all selected features click on mActionDeselectAll Deselect features from all layers.

Decorations

The Decorations of QGIS includes the Copyright Label, the North Arrow and the Scale Bar. They are used to ‘decorate’ the map by adding cartographic elements.

Muista

Before QGIS 1.8 the same functionality was provided by the Decoration Plugin.

North Arrow

north_arrow North Arrow places a simple north arrow on the map canvas. At present there is only one style available. You can adjust the angle of the arrow or let QGIS set the direction automatically. If you choose to let QGIS determine the direction, it makes its best guess as to how the arrow should be oriented. For placement of the arrow you have four options, corresponding to the four corners of the map canvas.

Figure Decorations 2:

../../../_images/north_arrow_dialog.png

The North Arrow Dialog nix

Scale Bar

scale_bar Scale Bar adds a simple scale bar to the map canvas. You control the style and placement, as well as the labeling of the bar.

Figure Decorations 3:

../../../_images/scale_bar_dialog.png

The Scale Bar Dialog nix

QGIS only supports displaying the scale in the same units as your map frame. So if the units of your layers are in meters, you can’t create a scale bar in feet. Likewise if you are using decimal degrees, you can’t create a scale bar to display distance in meters.

To add a scale bar:

  1. Select from menu View ‣ Decorations ‣ Scale Bar The dialog starts (see figure_decorations_3)
  2. Choose the placement from the Placement ‘Bottom Left’ drop-down list
  3. Choose the style from the Scale bar style ‘Tick Down’ list
  4. Select the color for the bar Color of bar ‘black’ or use the default black color
  5. Set the size of the bar and its label Size of bar ‘30 degrees’
  6. Make sure the checkbox Enable scale bar checkbox is checked
  7. Optionally choose to automatically snap to a round number when the canvas is resized checkbox Automatically snap to round number on resize
  8. Click [OK]

Vihje

Settings of Decorations

When you save a .qgs project, any changes you have made to NorthArrow, ScaleBar and Copyright will be saved in the project and restored the next time you load the project.

Annotation Tools

The mActionTextAnnotation Text Annotation tools in the attribute toolbar provides the possibility to place formatted text in a balloon on the QGIS map canvas. Use the Text Annotation tool and click into the map canvas.

Figure annotation 1:

../../../_images/annotation.png

Annotation text dialog nix

Double click on the item opens a dialog with various options. There is the text editor to enter the formatted text and other item settings. E.g. there is the choice of having the item placed on a map position (displayed by a marker symbol) or to have the item on a screen position (not related to the map). The item can be moved by map position (drag the map marker) or by moving only the balloon. The icons are part of GIS theme, and are used by default in the other themes too.

The mActionAnnotation Move Annotation tool allows to move the annotation on the map canvas.

Form annotations

Additionally you can also create your own annotation forms. The mActionFormAnnotation Form Annotation tool is useful to display attributes of a vector layer in a customized qt designer form (see figure_custom_annotation). It is similar to the designer forms for the Identify features tool, but displayed in an annotation item. Also see QGIS blog http://blog.qgis.org/node/143 for more information.

Figure annotation 2:

../../../_images/custom_annotation.png

Customized qt designer annotation form nix

Muista

If you press Ctrl+T while an Annotation tool is active (move annotation, text annotation, form annotation), the visibility states of the items are inverted.

Spatial Bookmarks

Spatial Bookmarks allow you to “bookmark” a geographic location and return to it later.

Creating a Bookmark

To create a bookmark:

  1. Zoom or pan to the area of interest.
  2. Select the menu option View ‣ New Bookmark or press Ctrl-B.
  3. Enter a descriptive name for the bookmark (up to 255 characters).
  4. Press Enter to add the bookmark or [Delete] to remove the bookmark.

Note that you can have multiple bookmarks with the same name.

Working with Bookmarks

To use or manage bookmarks, select the menu option View ‣ Show Bookmarks. The Geospatial Bookmarks dialog allows you to zoom to or delete a bookmark. You can not edit the bookmark name or coordinates.

Zooming to a Bookmark

From the Geospatial Bookmarks dialog, select the desired bookmark by clicking on it, then click [Zoom To]. You can also zoom to a bookmark by double-clicking on it.

Deleting a Bookmark

To delete a bookmark from the Geospatial Bookmarks dialog, click on it then click [Delete]. Confirm your choice by clicking [Yes] or cancel the delete by clicking [No].

Nesting Projects

If you want to embed content from other project files into your project you can choose Layer ‣ Embed Layers and Groups.

Embedding layers

The following dialog allows you to embed layers from other projects:

  1. Press browsebutton to look for another project from the Alaska dataset.
  2. Select the project file grassland. You can see the content of the project (see figure_embed_dialog).
  3. Press Ctrl and klick on the layers grassland and regions. The layers are embedded in the map legend and the map view now.

Figure Nesting 1:

../../../_images/embed_dialog.png

Select layers and groups to embed nix

While the embedded layers are editable you can’t change it’s properties like Style and Labeling.

Removing embedded layers

Right-click on the embedded layer and choose mActionRemoveLayer Remove .